changelog 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647
  1. qubes-core-admin-client (4.1.0-1) unstable; urgency=medium
  2. [ Frédéric Pierret (fepitre) ]
  3. * devices: make PEP8 happy
  4. * devices: handle listing of available device classes
  5. * tests/devices: make PEP8 happy
  6. * tests/devices: add test for handling listing device classes
  7. * tools/qvm-device: make PEP8 happy
  8. * devices: make iteration device classes compatible with Python2
  9. * devices: add missing docstring for _get_device_classes
  10. * qvm-check: refactor check mechanism and add filter for checking
  11. netvm
  12. * qvm-check: fix from Marek's comment
  13. [ hexagonrecursion ]
  14. * Fix a pref name in the qvm-prefs man page
  15. * Clarify the network-manager qubes service default
  16. * Correct network-manager qubes service default
  17. [ Frédéric Pierret (fepitre) ]
  18. * qubesadmin: make PEP8 happy
  19. * qubesadmin: define methods list_vmclass and list_devicesclass
  20. * qvm-device: handle 'list-device-classes' and 'list-classes'
  21. * qvm-device: prevent parser allowing abbreviations
  22. * qvm-device: add manpage entry
  23. [ Marek Marczykowski-Górecki ]
  24. * backup/restore: reject uncommon compression filters and improve
  25. header validation
  26. * backup/restore: add option to use uncommon compression filter anyway
  27. * tests: check rejecting/accepting compression filters
  28. * backup/restore: make pylint happy
  29. [ Frédéric Pierret (fepitre) ]
  30. * Fix Sphinx 2 new API for Fedora 31+
  31. * dochelpers: handle legacy sphinx library
  32. * dochelpers: make PEP8 happier
  33. [ Marta Marczykowska-Górecka ]
  34. * Fixed error with VM being incorrectly listed as its own dependency
  35. [ Marek Marczykowski-Górecki ]
  36. * rpm: fix release number
  37. * Add support for run_service(..., filter_esc=True) in a VM
  38. * Add run_service(..., autostart=False) argument
  39. * tools/qvm-start-gui: avoid starting a VM just to send it monitor
  40. layout
  41. * Make pylint happy
  42. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 09 Oct 2019 05:48:48 +0200
  43. qubes-core-admin-client (4.0.26-1) unstable; urgency=medium
  44. [ Marek Marczykowski-Górecki ]
  45. * doc: typo fix
  46. [ anadahz ]
  47. * Remove policy option from man page
  48. [ Marek Marczykowski-Górecki ]
  49. * tests: update yaml syntax in qvm-backup tests
  50. [ Conor Schaefer ]
  51. * Adds support for `--ignore-errors` to qvm-clone CLI
  52. * Adds docs for clone ignore_errors, feeds linter
  53. [ Malte Leip ]
  54. * qvm-prefs: add --hide-default option
  55. [ Marek Marczykowski-Górecki ]
  56. * travis: switch to xenial, update distributions
  57. [ unman ]
  58. * Remove unnecessary comma in qvm-backup.rst
  59. [ Marek Marczykowski-Górecki ]
  60. * Allow app.domains[vm] where vm is a QubesVM object
  61. * travis: drop python 3.4, add python 3.6 and 3.7
  62. * tests: fix events tests on python3.7
  63. * tools: reset private volume when importing template over existing
  64. one
  65. * tools/qvm-volume: add 'import' action
  66. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 30 Jul 2019 16:29:31 +0200
  67. qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
  68. [ Marek Marczykowski-Górecki ]
  69. * doc: update meminfo-writer service note
  70. [ GammaSQ ]
  71. * fixed typo
  72. [ Marek Marczykowski-Górecki ]
  73. * rpm: unify fedora and centos packaging
  74. * rpm: add R: python3-yaml, as needed by qvm-backup tool
  75. * backup: do not fail restore if scrypt anticipate more time needed
  76. * tools/qvm-run: do not color the output unless --pass-io is used
  77. * Bump Python version requirement for qvm-* to 3.5
  78. * utils: include management_dispvm property when checking where VM is
  79. used
  80. * backup: Do not try to attach devices during backup verification
  81. * tools/qvm-backup: allow to disable compression
  82. * events: simplify handling qubesd reconnect
  83. * vm: add run_with_args method to call a single command with specific
  84. arguments
  85. * tests: vm.run, vm.run_with_args
  86. * tools/qvm-start: use vm.run_with_args to call losetup in the VM
  87. * tools/qvm-start: validate output of losetup command
  88. * Make vm.run_with_args working on python2
  89. * Make pylint happy
  90. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
  91. qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
  92. * tools/qvm-run: make -q affect 'command failed with code' message
  93. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
  94. qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
  95. [ Marek Marczykowski-Górecki ]
  96. * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
  97. * Remove useless 'pass' to make pylint happy
  98. * backup: simplify test expressions to make pylint happy
  99. [ GammaSQ ]
  100. * get_label now accepts integer and has correct return-type
  101. * forgot braces
  102. * reverted to comparing .index
  103. * forgot braces
  104. * isinstance instead of type
  105. * added --standalone and --disp shortcuts
  106. * diff doesn't set template
  107. * added tests for shortcuts
  108. * Documentation is important! Added shortcuts to manpages
  109. * Fixed typo in documentation
  110. [ Marek Marczykowski-Górecki ]
  111. * tests/tools: extend vm.run_service() mockup
  112. * tests/tools: improve qvm-run tests
  113. * tools: fix qvm-run --pass-io --localcmd=... vmname command
  114. * tools/qvm-run: handle Ctrl+C nicely
  115. * tools/qvm-run: factor out print_no_color function
  116. * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
  117. * tools/qvm-run: add error message if command in VM failed
  118. * tools/qvm-device: allow detaching all devices
  119. * doc: add 'permissive' PCI device option and 'mic' device class
  120. * Clone VM's volume into the same pool, unless overridden specifically
  121. * tools: remove extra debug
  122. * tools/qvm-create: reject --root-{move,copy}-from with template-based
  123. qubes
  124. * tools/qvm-run: factor out actual process running into separate
  125. function
  126. * doc: improve qvm-device man page
  127. * doc: fix rst syntax in documentation, including docstrings
  128. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
  129. qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
  130. [ Patrik Hagara ]
  131. * qvm-ls: add filtering by domain power state
  132. [ Marek Marczykowski-Górecki ]
  133. * app: add option to ignore select volumes on app.clone_vm()
  134. * tools/qvm-create: properly create template-based StandaloneVM
  135. * tools/qvm-create: fix handling invalid label
  136. * Copy application menu on VM clone
  137. * Code style fix
  138. * tools: clarify qvm-service --help
  139. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
  140. qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
  141. [ Marek Marczykowski-Górecki ]
  142. * Move pylint config to canonical place
  143. * devices: add DeviceInfo.devclass attribute
  144. [ AJ Jordan ]
  145. * Fix typo
  146. [ jimtahu ]
  147. * Exclude installed_by_rpm when Restoring VM from Backup
  148. [ Marek Marczykowski-Górecki ]
  149. * devices: drop DeviceInfo.options
  150. * events: deserialize DeviceInfo class in device-* events
  151. * devices: include devclass when comparing devices
  152. * events: try reconnecting to qubesd also on BrokenPipeError
  153. * rpm: fix building on fc29
  154. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
  155. qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
  156. [ Marek Marczykowski-Górecki ]
  157. * Adjust shell input for Windows shell, for qvm-run tool
  158. * travis: install python-docutils in separate step
  159. [ Patrik Hagara ]
  160. * qvm-ls: add filtering by tags
  161. [ Marek Marczykowski-Górecki ]
  162. * tools/qvm-create: resize root volume if needed before imporing data
  163. * events: add support for wildcard event handlers
  164. * events: fix reconnecting to qubesd on its restart
  165. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
  166. qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
  167. [ Marek Marczykowski-Górecki ]
  168. * app: fix error reporting when connection to qubesd fails
  169. * tools/qvm-start-gui: do not crash on qubesd restart
  170. * Fixes for pylint 2.0
  171. [ Marta Marczykowska-Górecka ]
  172. * Deleted a duplicate man qvm-services entry
  173. [ Marek Marczykowski-Górecki ]
  174. * qvm-start-gui: fix handlign rpc-clipboard feature
  175. * Add 'gui-emulated' feature
  176. * doc: add info what properties are inherited from template
  177. * backup: avoid deadlock on logging during restore
  178. * doc: add linux-stubdom feature to man qvm-features
  179. [ Marta Marczykowska-Górecka ]
  180. * Helper function that lists where a given VM is used
  181. * Added tests and minor correction to vm_usage helper function
  182. * Name change of vm dependencies helper function
  183. * Better information on error in qvm-remove
  184. * Added test for qvm-remove dependency reporting
  185. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
  186. qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
  187. [ Peter Gerber ]
  188. * tools/qvm-firewall: Describe available rules in --help output
  189. [ Marek Marczykowski-Górecki ]
  190. * tools/qvm-firewall: add 'expire' rule support
  191. * tools/qvm-firewall: make 'list' a default action
  192. [ Peter Gerber ]
  193. * tools/qvm-firewall: Show EXPIRE column in list output
  194. * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
  195. * .gitignore: add doc/_build/
  196. * tools/qvm-firewall: improve manpage and --help output
  197. [ Marek Marczykowski-Górecki ]
  198. * Fix reporting events even if its source is not available anymore
  199. * tools: don't fail qvm-template-postprocess on shutdown race
  200. condition
  201. [ jimtahu ]
  202. * Change "None" to Property None
  203. * Change "None" in qvm_prefs
  204. * Add test of qvm_prefs for specal case "None"
  205. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
  206. qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
  207. [ Frédéric Pierret ]
  208. * Create .spec.in and Source0
  209. * Remove _builddir and useless condition on qubes_builder
  210. * doc: handle release definition when not being in a git repository
  211. * spec.in: add changelog placeholder
  212. [ Marek Marczykowski-Górecki ]
  213. * tools: fix error reporing on unknown storage pool
  214. * tools/qvm-pool: add --set to modify pool properties
  215. * doc: adjust example in qvm-pool man page
  216. * Add 'make clean' target, use it for Debian build
  217. * tools/qvm-ls: add --kernel option for compatibility with R3.2
  218. * tools/qvm-template-postprocess: fix reinstall action
  219. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
  220. qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
  221. * doc: typos
  222. * doc: fix module index generation
  223. * storage: add 'rw' and 'revision_to_keep' setters
  224. * qvm-volume: add 'info' and 'config' actions
  225. * storage: make Pool.{size,usage} integers
  226. * doc: update qvm-volume parameters
  227. * qvm-volume: refuse to shrink volume unless --force option is used
  228. * tools: add SubParsersHelpAction, which include subcommands details
  229. in --help
  230. * tools: suppress full traceback in console tools
  231. * qvm-template-postprocess: resize volume only when needed
  232. * qvm-template-postprocess: do not remove VM on failed reinstall
  233. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
  234. qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
  235. [ Marek Marczykowski-Górecki ]
  236. * doc: add 'pci-e820-host' feature description
  237. [ Rusty Bird ]
  238. * qvm-backup-restore: remove orphaned --replace-template option
  239. * qvm-backup-restore: really pass options
  240. * qvm-backup: let backup core handle default VM selection
  241. * restore.py: don't try to restore dispid property
  242. * restore.py: sort into three tiers in _templates_first()
  243. * restore.py: deal with DispVM templates
  244. * restore.py: factor out _restore_property() helper
  245. * restory.py: restore template_for_dispvms property early
  246. * restore.py: add template-related debug log messages
  247. [ Frédéric Pierret ]
  248. * Add support for python34-sphinx: package is provided in Qubes
  249. repository
  250. [ Marek Marczykowski-Górecki ]
  251. * tools: terminate qvm-start-gui when X server is terminated
  252. [ Rusty Bird ]
  253. * qvm-backup-restore: also handle absent --ignore-missing
  254. [ Marek Marczykowski-Górecki ]
  255. * qvm-template-postprocess: call fstrim after removing image file
  256. * tools/qvm-prefs: fix printing None value
  257. * tests: add tests for various 'qvm-prefs vm pref' cases
  258. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
  259. qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
  260. [ Marek Marczykowski-Górecki ]
  261. * vm: restore force_shutdown->kill deprecated alias
  262. [ Christopher Laprise ]
  263. * Fix AdminVm class name
  264. * Fix dom0 handling
  265. * Fix dom0 restore
  266. * style issues
  267. * unused variable
  268. [ Marek Marczykowski-Górecki ]
  269. * backup: skip dom0's properties while restoring core2 backup
  270. * backup: add support for openssl 1.1.0 options
  271. * tests: dom0 backup restore, both v3 and v4
  272. * backup: don't crash when no 'qubes' group is present
  273. [ Rusty Bird ]
  274. * template-postprocess: fast path for file-reflink, like file
  275. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
  276. qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
  277. [ Christopher Laprise ]
  278. * Fix dom0-related issues
  279. [ Marek Marczykowski-Górecki ]
  280. * backup: make pylint happy
  281. * Make pylint happy
  282. * tools/qvm-ls: fix handling columns with underscore
  283. * backup: restore Qubes 3.x VMs as HVMs
  284. * doc: update qvm-features documentation
  285. [ Christopher Laprise ]
  286. * Add --yes option and confirm prompt.
  287. * Fix error message grammar
  288. * Toggle installed_by_rpm in template tool
  289. * Use --force instead of --yes
  290. * Print vm list before prompt
  291. * Avoid cloning installed_by_rpm
  292. * Add --force to manpage.
  293. * Fix style else-return
  294. [ Marek Marczykowski-Górecki ]
  295. * tests: update qvm-template-process and qvm-remove tests
  296. * add QubesVM.connected_vms attribute
  297. [ Rusty Bird ]
  298. * qvm-device/block: Alias '--ro' to '--option read-only=yes'
  299. * qvm-device.rst: Document '--ro' option
  300. [ Marek Marczykowski-Górecki ]
  301. * doc: add info about specific qvm-device cases
  302. * storage: add volume.is_outdated() function
  303. * tools/qvm-start: add naive waiting for cdrom device
  304. * tools: fix handling optional domain list
  305. * tools/qvm-ls: allow list only selected VMs
  306. * tools/qvm-ls: add --raw-list option for compatibility with R3.2
  307. * tools/qvm-ls: add --network and --disk compatibility options
  308. * tools/qvm-ls: clarify that disk usage is in percents
  309. * base: make WrapperObjectsCollection behave like a dict
  310. * rpm,deb: add missing python lxml dependency
  311. * Add property_get_default method
  312. * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
  313. [ Rusty Bird ]
  314. * qvm-run: wait for X11 in --dispvm --gui case
  315. [ Marek Marczykowski-Górecki ]
  316. * storage: add size and usage properties
  317. * backup/restore: do not shrink volumes on restore
  318. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
  319. qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
  320. [ Jean-Philippe Ouellet ]
  321. * Stop leaking terminal escapes via stderr
  322. [ Marek Marczykowski-Górecki ]
  323. * tests: Update tests after fix for filtering stderr
  324. [ Jean-Philippe Ouellet ]
  325. * Fix qvm-ls --raw-data
  326. * Disable spinner if --raw-data
  327. * Remove dead code
  328. [ qubesuser ]
  329. * don't lookup list of labels just to read VM properties
  330. * don't use ast.literal_eval, just directly convert to the desired
  331. type
  332. [ Marek Marczykowski-Górecki ]
  333. * tests: make filter-esc tests working also on travis
  334. * tests: fix tests after dropping unnecessary admin.label.List call
  335. [ Christopher Laprise ]
  336. * Issue #3303
  337. * Fix verify-only
  338. * verify-only avoid dom0 handler
  339. [ Marek Marczykowski-Górecki ]
  340. * tests: update tests for fixed verify_only handling
  341. * make qvm-shutdown nice for unit tests
  342. * Make pylint happy
  343. * Another approach for making qvm-shutdown nice for tests
  344. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
  345. qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
  346. [ qubesuser ]
  347. * remove format_doc and docutils import
  348. * don't import pkg_resources in the top of qubesadmin/utils.py
  349. * replace console entry points with just importing the module
  350. * replace key in dir(self) with faster and better code
  351. [ Jean-Philippe Ouellet ]
  352. * Fix setting stderr default coloring policy
  353. * Restore correct colors in verbose mode
  354. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
  355. qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
  356. [ Marek Marczykowski-Górecki ]
  357. * Document device attach options in man page
  358. * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
  359. * backup: fix handling labels in Qubes 4.0 backups
  360. [ qubesuser ]
  361. * make qvm-run work for non-blocking stdin
  362. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
  363. qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
  364. [ Frédéric Pierret ]
  365. * Add CentOS support and fix python3 dependencies for CentOS (except
  366. python3-sphinx and python3-daemon which has no python34 package)
  367. [ Marek Marczykowski-Górecki ]
  368. * Fix DeviceInfo objects comparing
  369. * vm: fix handling policy deny on admin.vm.List
  370. * Drop log.DBusHandler
  371. * backup: improve migrating templates from Qubes 3.x
  372. * tools: fix handling qvm-run --no-autostart
  373. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
  374. qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
  375. * backup: fix restoring template VMs
  376. * tools: clarify that qvm-backup needs absolute path
  377. * backup: fix name of meminfo-writer feature
  378. * backup: update DispVM template property: template_for_dispvms
  379. * backup: improve restoring HVMs from Qubes 3.2
  380. * backup: do not try to read tar's stderr past EOF
  381. * tests: multi-part volume in backup tests
  382. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
  383. qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
  384. [ Marek Marczykowski-Górecki ]
  385. * Implement "blind mode" to avoid listing objects
  386. * events: ignore events from non-existing domains
  387. * tools: fix qvm-run --help
  388. * Always use QubesVM objects, instead of AppVM/TemplateVM etc
  389. * Move vm.appvms to QubesVM
  390. * Drop individual VM classes as python types completely
  391. * tools: finish 'qvm-volume revert' implementation, add tests
  392. * tools/qvm-start: fix starting a VM with cdrom image
  393. * vm: drop suspend and resume methods - not part of the Admin API
  394. * rpm: add conflict with too-old qubes-manager
  395. [ Mindy Preston ]
  396. * qvm-start: exit if domain running and no --skip-if-running
  397. [ Marek Marczykowski-Górecki ]
  398. * tools: adjust qvm-start message and logic, update tests
  399. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
  400. qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
  401. [ Marek Marczykowski-Górecki ]
  402. * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
  403. is given
  404. * vm/dispvm: fix dispvm.cleanup() when no service was called
  405. * tests: add DispVM tests
  406. * Improve QubesDaemonNoResponseError error message
  407. * tools: drop --delete and --unset aliases for --default option
  408. * doc: update list of properties in qvm-prefs/qubes-prefs man pages
  409. * doc: add short description of VM classes to qvm-create man page
  410. * tools: implement qvm-create --root-move-from/--root-copy-from
  411. * tools: add qvm-create --help-classes
  412. * backup/restore: make backup header extraction faster
  413. * backup/restore: do not fail the whole restore when qvm-appmenus is
  414. missing
  415. [ blackpit ]
  416. * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
  417. [ Marek Marczykowski-Górecki ]
  418. * tools: fix too long lines
  419. * tools: cleanup temporary files after qvm-template-postprocess
  420. * devices: client stub for DeviceCollection.update_persistent
  421. * tools: restore qvm-start --cdrom and similar options
  422. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
  423. qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
  424. * tools/qvm-run: fix handling small data blocks
  425. * vm: add DispVMWrapper for calling a single service in new DispVM
  426. * tools: add qvm-run --dispvm option
  427. * doc: list known features in qvm-features manual page
  428. * app: add VMCollection.values()
  429. * tools/qvm-run: do not use os.set_blocking
  430. * tools/qvm-device: list attach options
  431. * doc: add default values to qvm-features man page
  432. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
  433. qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
  434. * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
  435. agent
  436. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
  437. qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
  438. * tools/qvm-backup-restore: fix default list of VMs to restore
  439. * storage: drop 'internal' volume property
  440. * tools/qvm-volume: fix default action handling
  441. * tests: qvm-backup-restore tool tests
  442. * tools/qvm-backup-restore: fix restoring only specific VMs
  443. * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
  444. * backup: move BackupRestore class and helpers to 'restore' submodule
  445. * tools: add qvm-backup tool
  446. * debian: update build depends
  447. * doc: update qvm-backup man page
  448. * backup/restore: improve error reporting
  449. * backup/restore: add option to ignore size limit
  450. * events: add variable Admin API method name
  451. * tools/qvm-shutdown: drop --force option, it isn't supported anymore
  452. * tools/qvm-shutdown: fix help message
  453. * tools/qvm-start-gui: add --force-stubdomain options
  454. * features: serialize True as '1'
  455. * tests: too much copy&paste
  456. * tools: qvm-service tool
  457. * doc: update manpage of qvm-service
  458. * qvm-ls: fix total VM size reporting
  459. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
  460. qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
  461. [ Marek Marczykowski-Górecki ]
  462. * vm: make QubesVM objects hashable
  463. * events: simplify wait_for_domain_shutdown coroutine
  464. * tools: handle shutdown order in qvm-shutdown
  465. * tests/tools: add MockEventsReader
  466. * tests: qvm-shutdown --wait tests
  467. * Fix VM creation with default template
  468. * events: fix cleanup function in qrexec case
  469. * tests: improve test failure message
  470. [ Marta Marczykowska-Górecka ]
  471. * added helper function updates_vms_status
  472. [ Marek Marczykowski-Górecki ]
  473. * tools/qvm-run: fix handling copying stdin to the process
  474. * tests: mark qvm-run tests with "expected failure"
  475. * tools/qvm-run: fix handling EOF
  476. * Make pylint happy
  477. * Don't try to set 'created-by-' tag when cloning VM
  478. * backup: initial support for backup restore over Admin API
  479. * tests/backup: tests for backup-restore code
  480. * Exclude 'qubesadmin.backup' module from python2 install
  481. * devices,features: fix bool values handling
  482. * tests/backup: use smaller images
  483. * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
  484. * backup: add firewall and appmenus list handling
  485. * firewall: fix handling DstHost.prefixlen=0
  486. * tests: backup: add firewall.xml and appmenus checking
  487. * tools: add qvm-backup-restore
  488. * app: call admin.vm.volume.Import as root
  489. * backup: do not show full stacktrace to the user
  490. * backup: change 'hvm' property to 'virt_mode'
  491. * backup: use 'cat' instead of read-write loop in python
  492. * backup: improve error logging
  493. * tools/qvm-backup-restore: handle VMs selection, not only exclusion
  494. * Choose QubesLocal or QubesRemote based on /etc/qubes-release
  495. presence
  496. * Change 'hvm' property to 'virt_mode'
  497. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
  498. qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
  499. *
  500. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
  501. qubes-core-admin-client (4.0.0-1) unstable; urgency=low
  502. * Initial release
  503. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200