changelog 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562
  1. qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
  2. [ Marek Marczykowski-Górecki ]
  3. * doc: update meminfo-writer service note
  4. [ GammaSQ ]
  5. * fixed typo
  6. [ Marek Marczykowski-Górecki ]
  7. * rpm: unify fedora and centos packaging
  8. * rpm: add R: python3-yaml, as needed by qvm-backup tool
  9. * backup: do not fail restore if scrypt anticipate more time needed
  10. * tools/qvm-run: do not color the output unless --pass-io is used
  11. * Bump Python version requirement for qvm-* to 3.5
  12. * utils: include management_dispvm property when checking where VM is
  13. used
  14. * backup: Do not try to attach devices during backup verification
  15. * tools/qvm-backup: allow to disable compression
  16. * events: simplify handling qubesd reconnect
  17. * vm: add run_with_args method to call a single command with specific
  18. arguments
  19. * tests: vm.run, vm.run_with_args
  20. * tools/qvm-start: use vm.run_with_args to call losetup in the VM
  21. * tools/qvm-start: validate output of losetup command
  22. * Make vm.run_with_args working on python2
  23. * Make pylint happy
  24. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
  25. qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
  26. * tools/qvm-run: make -q affect 'command failed with code' message
  27. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
  28. qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
  29. [ Marek Marczykowski-Górecki ]
  30. * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
  31. * Remove useless 'pass' to make pylint happy
  32. * backup: simplify test expressions to make pylint happy
  33. [ GammaSQ ]
  34. * get_label now accepts integer and has correct return-type
  35. * forgot braces
  36. * reverted to comparing .index
  37. * forgot braces
  38. * isinstance instead of type
  39. * added --standalone and --disp shortcuts
  40. * diff doesn't set template
  41. * added tests for shortcuts
  42. * Documentation is important! Added shortcuts to manpages
  43. * Fixed typo in documentation
  44. [ Marek Marczykowski-Górecki ]
  45. * tests/tools: extend vm.run_service() mockup
  46. * tests/tools: improve qvm-run tests
  47. * tools: fix qvm-run --pass-io --localcmd=... vmname command
  48. * tools/qvm-run: handle Ctrl+C nicely
  49. * tools/qvm-run: factor out print_no_color function
  50. * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
  51. * tools/qvm-run: add error message if command in VM failed
  52. * tools/qvm-device: allow detaching all devices
  53. * doc: add 'permissive' PCI device option and 'mic' device class
  54. * Clone VM's volume into the same pool, unless overridden specifically
  55. * tools: remove extra debug
  56. * tools/qvm-create: reject --root-{move,copy}-from with template-based
  57. qubes
  58. * tools/qvm-run: factor out actual process running into separate
  59. function
  60. * doc: improve qvm-device man page
  61. * doc: fix rst syntax in documentation, including docstrings
  62. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
  63. qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
  64. [ Patrik Hagara ]
  65. * qvm-ls: add filtering by domain power state
  66. [ Marek Marczykowski-Górecki ]
  67. * app: add option to ignore select volumes on app.clone_vm()
  68. * tools/qvm-create: properly create template-based StandaloneVM
  69. * tools/qvm-create: fix handling invalid label
  70. * Copy application menu on VM clone
  71. * Code style fix
  72. * tools: clarify qvm-service --help
  73. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
  74. qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
  75. [ Marek Marczykowski-Górecki ]
  76. * Move pylint config to canonical place
  77. * devices: add DeviceInfo.devclass attribute
  78. [ AJ Jordan ]
  79. * Fix typo
  80. [ jimtahu ]
  81. * Exclude installed_by_rpm when Restoring VM from Backup
  82. [ Marek Marczykowski-Górecki ]
  83. * devices: drop DeviceInfo.options
  84. * events: deserialize DeviceInfo class in device-* events
  85. * devices: include devclass when comparing devices
  86. * events: try reconnecting to qubesd also on BrokenPipeError
  87. * rpm: fix building on fc29
  88. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
  89. qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
  90. [ Marek Marczykowski-Górecki ]
  91. * Adjust shell input for Windows shell, for qvm-run tool
  92. * travis: install python-docutils in separate step
  93. [ Patrik Hagara ]
  94. * qvm-ls: add filtering by tags
  95. [ Marek Marczykowski-Górecki ]
  96. * tools/qvm-create: resize root volume if needed before imporing data
  97. * events: add support for wildcard event handlers
  98. * events: fix reconnecting to qubesd on its restart
  99. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
  100. qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
  101. [ Marek Marczykowski-Górecki ]
  102. * app: fix error reporting when connection to qubesd fails
  103. * tools/qvm-start-gui: do not crash on qubesd restart
  104. * Fixes for pylint 2.0
  105. [ Marta Marczykowska-Górecka ]
  106. * Deleted a duplicate man qvm-services entry
  107. [ Marek Marczykowski-Górecki ]
  108. * qvm-start-gui: fix handlign rpc-clipboard feature
  109. * Add 'gui-emulated' feature
  110. * doc: add info what properties are inherited from template
  111. * backup: avoid deadlock on logging during restore
  112. * doc: add linux-stubdom feature to man qvm-features
  113. [ Marta Marczykowska-Górecka ]
  114. * Helper function that lists where a given VM is used
  115. * Added tests and minor correction to vm_usage helper function
  116. * Name change of vm dependencies helper function
  117. * Better information on error in qvm-remove
  118. * Added test for qvm-remove dependency reporting
  119. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
  120. qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
  121. [ Peter Gerber ]
  122. * tools/qvm-firewall: Describe available rules in --help output
  123. [ Marek Marczykowski-Górecki ]
  124. * tools/qvm-firewall: add 'expire' rule support
  125. * tools/qvm-firewall: make 'list' a default action
  126. [ Peter Gerber ]
  127. * tools/qvm-firewall: Show EXPIRE column in list output
  128. * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
  129. * .gitignore: add doc/_build/
  130. * tools/qvm-firewall: improve manpage and --help output
  131. [ Marek Marczykowski-Górecki ]
  132. * Fix reporting events even if its source is not available anymore
  133. * tools: don't fail qvm-template-postprocess on shutdown race
  134. condition
  135. [ jimtahu ]
  136. * Change "None" to Property None
  137. * Change "None" in qvm_prefs
  138. * Add test of qvm_prefs for specal case "None"
  139. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
  140. qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
  141. [ Frédéric Pierret ]
  142. * Create .spec.in and Source0
  143. * Remove _builddir and useless condition on qubes_builder
  144. * doc: handle release definition when not being in a git repository
  145. * spec.in: add changelog placeholder
  146. [ Marek Marczykowski-Górecki ]
  147. * tools: fix error reporing on unknown storage pool
  148. * tools/qvm-pool: add --set to modify pool properties
  149. * doc: adjust example in qvm-pool man page
  150. * Add 'make clean' target, use it for Debian build
  151. * tools/qvm-ls: add --kernel option for compatibility with R3.2
  152. * tools/qvm-template-postprocess: fix reinstall action
  153. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
  154. qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
  155. * doc: typos
  156. * doc: fix module index generation
  157. * storage: add 'rw' and 'revision_to_keep' setters
  158. * qvm-volume: add 'info' and 'config' actions
  159. * storage: make Pool.{size,usage} integers
  160. * doc: update qvm-volume parameters
  161. * qvm-volume: refuse to shrink volume unless --force option is used
  162. * tools: add SubParsersHelpAction, which include subcommands details
  163. in --help
  164. * tools: suppress full traceback in console tools
  165. * qvm-template-postprocess: resize volume only when needed
  166. * qvm-template-postprocess: do not remove VM on failed reinstall
  167. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
  168. qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
  169. [ Marek Marczykowski-Górecki ]
  170. * doc: add 'pci-e820-host' feature description
  171. [ Rusty Bird ]
  172. * qvm-backup-restore: remove orphaned --replace-template option
  173. * qvm-backup-restore: really pass options
  174. * qvm-backup: let backup core handle default VM selection
  175. * restore.py: don't try to restore dispid property
  176. * restore.py: sort into three tiers in _templates_first()
  177. * restore.py: deal with DispVM templates
  178. * restore.py: factor out _restore_property() helper
  179. * restory.py: restore template_for_dispvms property early
  180. * restore.py: add template-related debug log messages
  181. [ Frédéric Pierret ]
  182. * Add support for python34-sphinx: package is provided in Qubes
  183. repository
  184. [ Marek Marczykowski-Górecki ]
  185. * tools: terminate qvm-start-gui when X server is terminated
  186. [ Rusty Bird ]
  187. * qvm-backup-restore: also handle absent --ignore-missing
  188. [ Marek Marczykowski-Górecki ]
  189. * qvm-template-postprocess: call fstrim after removing image file
  190. * tools/qvm-prefs: fix printing None value
  191. * tests: add tests for various 'qvm-prefs vm pref' cases
  192. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
  193. qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
  194. [ Marek Marczykowski-Górecki ]
  195. * vm: restore force_shutdown->kill deprecated alias
  196. [ Christopher Laprise ]
  197. * Fix AdminVm class name
  198. * Fix dom0 handling
  199. * Fix dom0 restore
  200. * style issues
  201. * unused variable
  202. [ Marek Marczykowski-Górecki ]
  203. * backup: skip dom0's properties while restoring core2 backup
  204. * backup: add support for openssl 1.1.0 options
  205. * tests: dom0 backup restore, both v3 and v4
  206. * backup: don't crash when no 'qubes' group is present
  207. [ Rusty Bird ]
  208. * template-postprocess: fast path for file-reflink, like file
  209. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
  210. qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
  211. [ Christopher Laprise ]
  212. * Fix dom0-related issues
  213. [ Marek Marczykowski-Górecki ]
  214. * backup: make pylint happy
  215. * Make pylint happy
  216. * tools/qvm-ls: fix handling columns with underscore
  217. * backup: restore Qubes 3.x VMs as HVMs
  218. * doc: update qvm-features documentation
  219. [ Christopher Laprise ]
  220. * Add --yes option and confirm prompt.
  221. * Fix error message grammar
  222. * Toggle installed_by_rpm in template tool
  223. * Use --force instead of --yes
  224. * Print vm list before prompt
  225. * Avoid cloning installed_by_rpm
  226. * Add --force to manpage.
  227. * Fix style else-return
  228. [ Marek Marczykowski-Górecki ]
  229. * tests: update qvm-template-process and qvm-remove tests
  230. * add QubesVM.connected_vms attribute
  231. [ Rusty Bird ]
  232. * qvm-device/block: Alias '--ro' to '--option read-only=yes'
  233. * qvm-device.rst: Document '--ro' option
  234. [ Marek Marczykowski-Górecki ]
  235. * doc: add info about specific qvm-device cases
  236. * storage: add volume.is_outdated() function
  237. * tools/qvm-start: add naive waiting for cdrom device
  238. * tools: fix handling optional domain list
  239. * tools/qvm-ls: allow list only selected VMs
  240. * tools/qvm-ls: add --raw-list option for compatibility with R3.2
  241. * tools/qvm-ls: add --network and --disk compatibility options
  242. * tools/qvm-ls: clarify that disk usage is in percents
  243. * base: make WrapperObjectsCollection behave like a dict
  244. * rpm,deb: add missing python lxml dependency
  245. * Add property_get_default method
  246. * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
  247. [ Rusty Bird ]
  248. * qvm-run: wait for X11 in --dispvm --gui case
  249. [ Marek Marczykowski-Górecki ]
  250. * storage: add size and usage properties
  251. * backup/restore: do not shrink volumes on restore
  252. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
  253. qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
  254. [ Jean-Philippe Ouellet ]
  255. * Stop leaking terminal escapes via stderr
  256. [ Marek Marczykowski-Górecki ]
  257. * tests: Update tests after fix for filtering stderr
  258. [ Jean-Philippe Ouellet ]
  259. * Fix qvm-ls --raw-data
  260. * Disable spinner if --raw-data
  261. * Remove dead code
  262. [ qubesuser ]
  263. * don't lookup list of labels just to read VM properties
  264. * don't use ast.literal_eval, just directly convert to the desired
  265. type
  266. [ Marek Marczykowski-Górecki ]
  267. * tests: make filter-esc tests working also on travis
  268. * tests: fix tests after dropping unnecessary admin.label.List call
  269. [ Christopher Laprise ]
  270. * Issue #3303
  271. * Fix verify-only
  272. * verify-only avoid dom0 handler
  273. [ Marek Marczykowski-Górecki ]
  274. * tests: update tests for fixed verify_only handling
  275. * make qvm-shutdown nice for unit tests
  276. * Make pylint happy
  277. * Another approach for making qvm-shutdown nice for tests
  278. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
  279. qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
  280. [ qubesuser ]
  281. * remove format_doc and docutils import
  282. * don't import pkg_resources in the top of qubesadmin/utils.py
  283. * replace console entry points with just importing the module
  284. * replace key in dir(self) with faster and better code
  285. [ Jean-Philippe Ouellet ]
  286. * Fix setting stderr default coloring policy
  287. * Restore correct colors in verbose mode
  288. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
  289. qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
  290. [ Marek Marczykowski-Górecki ]
  291. * Document device attach options in man page
  292. * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
  293. * backup: fix handling labels in Qubes 4.0 backups
  294. [ qubesuser ]
  295. * make qvm-run work for non-blocking stdin
  296. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
  297. qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
  298. [ Frédéric Pierret ]
  299. * Add CentOS support and fix python3 dependencies for CentOS (except
  300. python3-sphinx and python3-daemon which has no python34 package)
  301. [ Marek Marczykowski-Górecki ]
  302. * Fix DeviceInfo objects comparing
  303. * vm: fix handling policy deny on admin.vm.List
  304. * Drop log.DBusHandler
  305. * backup: improve migrating templates from Qubes 3.x
  306. * tools: fix handling qvm-run --no-autostart
  307. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
  308. qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
  309. * backup: fix restoring template VMs
  310. * tools: clarify that qvm-backup needs absolute path
  311. * backup: fix name of meminfo-writer feature
  312. * backup: update DispVM template property: template_for_dispvms
  313. * backup: improve restoring HVMs from Qubes 3.2
  314. * backup: do not try to read tar's stderr past EOF
  315. * tests: multi-part volume in backup tests
  316. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
  317. qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
  318. [ Marek Marczykowski-Górecki ]
  319. * Implement "blind mode" to avoid listing objects
  320. * events: ignore events from non-existing domains
  321. * tools: fix qvm-run --help
  322. * Always use QubesVM objects, instead of AppVM/TemplateVM etc
  323. * Move vm.appvms to QubesVM
  324. * Drop individual VM classes as python types completely
  325. * tools: finish 'qvm-volume revert' implementation, add tests
  326. * tools/qvm-start: fix starting a VM with cdrom image
  327. * vm: drop suspend and resume methods - not part of the Admin API
  328. * rpm: add conflict with too-old qubes-manager
  329. [ Mindy Preston ]
  330. * qvm-start: exit if domain running and no --skip-if-running
  331. [ Marek Marczykowski-Górecki ]
  332. * tools: adjust qvm-start message and logic, update tests
  333. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
  334. qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
  335. [ Marek Marczykowski-Górecki ]
  336. * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
  337. is given
  338. * vm/dispvm: fix dispvm.cleanup() when no service was called
  339. * tests: add DispVM tests
  340. * Improve QubesDaemonNoResponseError error message
  341. * tools: drop --delete and --unset aliases for --default option
  342. * doc: update list of properties in qvm-prefs/qubes-prefs man pages
  343. * doc: add short description of VM classes to qvm-create man page
  344. * tools: implement qvm-create --root-move-from/--root-copy-from
  345. * tools: add qvm-create --help-classes
  346. * backup/restore: make backup header extraction faster
  347. * backup/restore: do not fail the whole restore when qvm-appmenus is
  348. missing
  349. [ blackpit ]
  350. * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
  351. [ Marek Marczykowski-Górecki ]
  352. * tools: fix too long lines
  353. * tools: cleanup temporary files after qvm-template-postprocess
  354. * devices: client stub for DeviceCollection.update_persistent
  355. * tools: restore qvm-start --cdrom and similar options
  356. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
  357. qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
  358. * tools/qvm-run: fix handling small data blocks
  359. * vm: add DispVMWrapper for calling a single service in new DispVM
  360. * tools: add qvm-run --dispvm option
  361. * doc: list known features in qvm-features manual page
  362. * app: add VMCollection.values()
  363. * tools/qvm-run: do not use os.set_blocking
  364. * tools/qvm-device: list attach options
  365. * doc: add default values to qvm-features man page
  366. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
  367. qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
  368. * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
  369. agent
  370. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
  371. qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
  372. * tools/qvm-backup-restore: fix default list of VMs to restore
  373. * storage: drop 'internal' volume property
  374. * tools/qvm-volume: fix default action handling
  375. * tests: qvm-backup-restore tool tests
  376. * tools/qvm-backup-restore: fix restoring only specific VMs
  377. * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
  378. * backup: move BackupRestore class and helpers to 'restore' submodule
  379. * tools: add qvm-backup tool
  380. * debian: update build depends
  381. * doc: update qvm-backup man page
  382. * backup/restore: improve error reporting
  383. * backup/restore: add option to ignore size limit
  384. * events: add variable Admin API method name
  385. * tools/qvm-shutdown: drop --force option, it isn't supported anymore
  386. * tools/qvm-shutdown: fix help message
  387. * tools/qvm-start-gui: add --force-stubdomain options
  388. * features: serialize True as '1'
  389. * tests: too much copy&paste
  390. * tools: qvm-service tool
  391. * doc: update manpage of qvm-service
  392. * qvm-ls: fix total VM size reporting
  393. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
  394. qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
  395. [ Marek Marczykowski-Górecki ]
  396. * vm: make QubesVM objects hashable
  397. * events: simplify wait_for_domain_shutdown coroutine
  398. * tools: handle shutdown order in qvm-shutdown
  399. * tests/tools: add MockEventsReader
  400. * tests: qvm-shutdown --wait tests
  401. * Fix VM creation with default template
  402. * events: fix cleanup function in qrexec case
  403. * tests: improve test failure message
  404. [ Marta Marczykowska-Górecka ]
  405. * added helper function updates_vms_status
  406. [ Marek Marczykowski-Górecki ]
  407. * tools/qvm-run: fix handling copying stdin to the process
  408. * tests: mark qvm-run tests with "expected failure"
  409. * tools/qvm-run: fix handling EOF
  410. * Make pylint happy
  411. * Don't try to set 'created-by-' tag when cloning VM
  412. * backup: initial support for backup restore over Admin API
  413. * tests/backup: tests for backup-restore code
  414. * Exclude 'qubesadmin.backup' module from python2 install
  415. * devices,features: fix bool values handling
  416. * tests/backup: use smaller images
  417. * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
  418. * backup: add firewall and appmenus list handling
  419. * firewall: fix handling DstHost.prefixlen=0
  420. * tests: backup: add firewall.xml and appmenus checking
  421. * tools: add qvm-backup-restore
  422. * app: call admin.vm.volume.Import as root
  423. * backup: do not show full stacktrace to the user
  424. * backup: change 'hvm' property to 'virt_mode'
  425. * backup: use 'cat' instead of read-write loop in python
  426. * backup: improve error logging
  427. * tools/qvm-backup-restore: handle VMs selection, not only exclusion
  428. * Choose QubesLocal or QubesRemote based on /etc/qubes-release
  429. presence
  430. * Change 'hvm' property to 'virt_mode'
  431. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
  432. qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
  433. *
  434. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
  435. qubes-core-admin-client (4.0.0-1) unstable; urgency=low
  436. * Initial release
  437. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200