qubes-core-admin-client.spec 2.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118
  1. Name: qubes-core-admin-client
  2. Version: %(cat version)
  3. Release: 0.1%{?dist}
  4. Summary: Qubes OS admin client tools
  5. Group: Qubes
  6. License: LGPLv2.1+
  7. URL: https://www.qubes-os.org
  8. BuildRequires: python2-setuptools
  9. BuildRequires: python2-devel
  10. %if 0%{?rhel} >= 7
  11. BuildRequires: python34-setuptools
  12. BuildRequires: python34-devel
  13. BuildRequires: python-sphinx
  14. BuildRequires: python34-dbus
  15. Requires: python34-qubesadmin
  16. %else
  17. BuildRequires: python3-setuptools
  18. BuildRequires: python3-devel
  19. BuildRequires: python3-sphinx
  20. BuildRequires: python3-dbus
  21. Requires: python3-qubesadmin
  22. %endif
  23. BuildArch: noarch
  24. %if 0%{?qubes_builder}
  25. %define _builddir %(pwd)
  26. %endif
  27. %description
  28. This package include managemt tools, like qvm-*.
  29. %package -n python2-qubesadmin
  30. Summary: Python2 module qubesadmin
  31. Requires: python-daemon
  32. Requires: python-docutils
  33. Requires: python2-lxml
  34. %description -n python2-qubesadmin
  35. Python2 module qubesadmin.
  36. %if 0%{?rhel} >= 7
  37. %package -n python34-qubesadmin
  38. Summary: Python34 module qubesadmin
  39. Requires: python-daemon
  40. Requires: python34-docutils
  41. Requires: python34-lxml
  42. Conflicts: qubes-manager < 4.0.6
  43. %description -n python34-qubesadmin
  44. Python34 module qubesadmin.
  45. %else
  46. %package -n python3-qubesadmin
  47. Summary: Python3 module qubesadmin
  48. Requires: python3-daemon
  49. Requires: python3-docutils
  50. Requires: python3-lxml
  51. Conflicts: qubes-manager < 4.0.6
  52. %description -n python3-qubesadmin
  53. Python3 module qubesadmin.
  54. %endif
  55. %prep
  56. %if !0%{?qubes_builder}
  57. %setup -q
  58. %endif
  59. %build
  60. %if 0%{?rhel} >= 7
  61. make -C doc PYTHON=%{__python3} SPHINXBUILD=sphinx-build man
  62. %else
  63. make -C doc PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} man
  64. %endif
  65. %install
  66. rm -rf build
  67. %make_install PYTHON=%{__python2}
  68. rm -rf build
  69. %make_install PYTHON=%{__python3}
  70. %if 0%{?rhel} >= 7
  71. make -C doc DESTDIR=$RPM_BUILD_ROOT \
  72. PYTHON=%{__python3} SPHINXBUILD=sphinx-build \
  73. install
  74. %else
  75. make -C doc DESTDIR=$RPM_BUILD_ROOT \
  76. PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} \
  77. install
  78. %endif
  79. %files
  80. %defattr(-,root,root,-)
  81. %doc LICENSE
  82. %config /etc/xdg/autostart/qvm-start-gui.desktop
  83. %{_bindir}/qubes-*
  84. %{_bindir}/qvm-*
  85. %{_mandir}/man1/qvm-*.1*
  86. %{_mandir}/man1/qubes*.1*
  87. %files -n python2-qubesadmin
  88. %{python_sitelib}/qubesadmin-*egg-info
  89. %{python_sitelib}/qubesadmin
  90. %if 0%{?rhel} >= 7
  91. %files -n python34-qubesadmin
  92. %else
  93. %files -n python3-qubesadmin
  94. %endif
  95. %{python3_sitelib}/qubesadmin-*egg-info
  96. %{python3_sitelib}/qubesadmin
  97. %changelog