changelog 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727
  1. qubes-core-admin-client (4.1.3-1) unstable; urgency=medium
  2. [ Marta Marczykowska-Górecka ]
  3. * Fixed Exceptions inferiting from KeyError
  4. [ Marek Marczykowski-Górecki ]
  5. * Drop Python2 support
  6. [ tetrahedras ]
  7. * add --wait documentation for qvm-shutdown
  8. [ Pawel Marczewski ]
  9. * qvm-ls: don't exclude dom0 when using --all
  10. * Add test for qvm-ls --all
  11. * Use admin.vm.CurrentState method for power state and memory
  12. * qvm-ls: display memory as integer number
  13. * Update tests to mock admin.vm.CurrentState
  14. * Add a test for vm.get_mem()
  15. * Add missing docstrings
  16. * qvm-shutdown: report errors, don't crash on DispVMs
  17. * qvm-remove: improve error message
  18. * Import data using ImportWithSize call, not manual resizing
  19. * qvm-run: use qubes.VMExec, if available
  20. * Document the new behaviour of qvm-run with arguments
  21. * Use qubes.VMExec in run_with_args()
  22. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 27 Jan 2020 19:33:19 +0100
  23. qubes-core-admin-client (4.1.2-1) unstable; urgency=medium
  24. [ Marta Marczykowska-Górecka ]
  25. * Fixed overeager assert
  26. * Fixed metadata usage being served as strings
  27. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 30 Nov 2019 05:12:01 +0100
  28. qubes-core-admin-client (4.1.1-1) unstable; urgency=medium
  29. [ Frédéric Pierret (fepitre) ]
  30. * travis: switch to bionic
  31. * Make PEP8 happier
  32. * qvm-start-gui: handle GuiVM
  33. * guivm: use getattr instead of try/except and direct property access
  34. * qvm-start-gui: simplify log info for start_gui function
  35. * app: fix missing docstring for get_local_name
  36. * app: get_local_name set/from self attribute
  37. * tests: fix with respect to gui properties
  38. * tests: qvm_start_gui: make PEP8 happier
  39. * app: switch get_local_name method to property
  40. [ Marta Marczykowska-Górecka ]
  41. * Fixed error with import
  42. * Added pool.usage_details API method
  43. [ Saswat Padhi ]
  44. * Improvements to qvm-pool argument parser
  45. * Updated tests for qvm-pool
  46. * Fixed a bug and removed unused import
  47. * Added a new test and minor updates to others
  48. * Updated qvm-pool.rst file
  49. * Preserve backward compatibility
  50. [ Rot127 ]
  51. * added feature to list domains as network tree
  52. * network tree manpage entry added
  53. * Sort domains in network tree list
  54. * Add tests for --tree option of qvm-ls
  55. [ Frédéric Pierret (fepitre) ]
  56. * prefs: handle 'none' value for guivm
  57. * utils: handle default_guivm and guivm properties
  58. * utils: make PEP8 happy
  59. * tests: add default_guivm and guivm in utils properties
  60. * tests: make PEP8 and pylint happy
  61. [ Marta Marczykowska-Górecka ]
  62. * Added an exception for backup already in progress
  63. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 13 Nov 2019 05:58:53 +0100
  64. qubes-core-admin-client (4.1.0-1) unstable; urgency=medium
  65. [ Frédéric Pierret (fepitre) ]
  66. * devices: make PEP8 happy
  67. * devices: handle listing of available device classes
  68. * tests/devices: make PEP8 happy
  69. * tests/devices: add test for handling listing device classes
  70. * tools/qvm-device: make PEP8 happy
  71. * devices: make iteration device classes compatible with Python2
  72. * devices: add missing docstring for _get_device_classes
  73. * qvm-check: refactor check mechanism and add filter for checking
  74. netvm
  75. * qvm-check: fix from Marek's comment
  76. [ hexagonrecursion ]
  77. * Fix a pref name in the qvm-prefs man page
  78. * Clarify the network-manager qubes service default
  79. * Correct network-manager qubes service default
  80. [ Frédéric Pierret (fepitre) ]
  81. * qubesadmin: make PEP8 happy
  82. * qubesadmin: define methods list_vmclass and list_devicesclass
  83. * qvm-device: handle 'list-device-classes' and 'list-classes'
  84. * qvm-device: prevent parser allowing abbreviations
  85. * qvm-device: add manpage entry
  86. [ Marek Marczykowski-Górecki ]
  87. * backup/restore: reject uncommon compression filters and improve
  88. header validation
  89. * backup/restore: add option to use uncommon compression filter anyway
  90. * tests: check rejecting/accepting compression filters
  91. * backup/restore: make pylint happy
  92. [ Frédéric Pierret (fepitre) ]
  93. * Fix Sphinx 2 new API for Fedora 31+
  94. * dochelpers: handle legacy sphinx library
  95. * dochelpers: make PEP8 happier
  96. [ Marta Marczykowska-Górecka ]
  97. * Fixed error with VM being incorrectly listed as its own dependency
  98. [ Marek Marczykowski-Górecki ]
  99. * rpm: fix release number
  100. * Add support for run_service(..., filter_esc=True) in a VM
  101. * Add run_service(..., autostart=False) argument
  102. * tools/qvm-start-gui: avoid starting a VM just to send it monitor
  103. layout
  104. * Make pylint happy
  105. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 09 Oct 2019 05:48:48 +0200
  106. qubes-core-admin-client (4.0.26-1) unstable; urgency=medium
  107. [ Marek Marczykowski-Górecki ]
  108. * doc: typo fix
  109. [ anadahz ]
  110. * Remove policy option from man page
  111. [ Marek Marczykowski-Górecki ]
  112. * tests: update yaml syntax in qvm-backup tests
  113. [ Conor Schaefer ]
  114. * Adds support for `--ignore-errors` to qvm-clone CLI
  115. * Adds docs for clone ignore_errors, feeds linter
  116. [ Malte Leip ]
  117. * qvm-prefs: add --hide-default option
  118. [ Marek Marczykowski-Górecki ]
  119. * travis: switch to xenial, update distributions
  120. [ unman ]
  121. * Remove unnecessary comma in qvm-backup.rst
  122. [ Marek Marczykowski-Górecki ]
  123. * Allow app.domains[vm] where vm is a QubesVM object
  124. * travis: drop python 3.4, add python 3.6 and 3.7
  125. * tests: fix events tests on python3.7
  126. * tools: reset private volume when importing template over existing
  127. one
  128. * tools/qvm-volume: add 'import' action
  129. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 30 Jul 2019 16:29:31 +0200
  130. qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
  131. [ Marek Marczykowski-Górecki ]
  132. * doc: update meminfo-writer service note
  133. [ GammaSQ ]
  134. * fixed typo
  135. [ Marek Marczykowski-Górecki ]
  136. * rpm: unify fedora and centos packaging
  137. * rpm: add R: python3-yaml, as needed by qvm-backup tool
  138. * backup: do not fail restore if scrypt anticipate more time needed
  139. * tools/qvm-run: do not color the output unless --pass-io is used
  140. * Bump Python version requirement for qvm-* to 3.5
  141. * utils: include management_dispvm property when checking where VM is
  142. used
  143. * backup: Do not try to attach devices during backup verification
  144. * tools/qvm-backup: allow to disable compression
  145. * events: simplify handling qubesd reconnect
  146. * vm: add run_with_args method to call a single command with specific
  147. arguments
  148. * tests: vm.run, vm.run_with_args
  149. * tools/qvm-start: use vm.run_with_args to call losetup in the VM
  150. * tools/qvm-start: validate output of losetup command
  151. * Make vm.run_with_args working on python2
  152. * Make pylint happy
  153. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
  154. qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
  155. * tools/qvm-run: make -q affect 'command failed with code' message
  156. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
  157. qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
  158. [ Marek Marczykowski-Górecki ]
  159. * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
  160. * Remove useless 'pass' to make pylint happy
  161. * backup: simplify test expressions to make pylint happy
  162. [ GammaSQ ]
  163. * get_label now accepts integer and has correct return-type
  164. * forgot braces
  165. * reverted to comparing .index
  166. * forgot braces
  167. * isinstance instead of type
  168. * added --standalone and --disp shortcuts
  169. * diff doesn't set template
  170. * added tests for shortcuts
  171. * Documentation is important! Added shortcuts to manpages
  172. * Fixed typo in documentation
  173. [ Marek Marczykowski-Górecki ]
  174. * tests/tools: extend vm.run_service() mockup
  175. * tests/tools: improve qvm-run tests
  176. * tools: fix qvm-run --pass-io --localcmd=... vmname command
  177. * tools/qvm-run: handle Ctrl+C nicely
  178. * tools/qvm-run: factor out print_no_color function
  179. * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
  180. * tools/qvm-run: add error message if command in VM failed
  181. * tools/qvm-device: allow detaching all devices
  182. * doc: add 'permissive' PCI device option and 'mic' device class
  183. * Clone VM's volume into the same pool, unless overridden specifically
  184. * tools: remove extra debug
  185. * tools/qvm-create: reject --root-{move,copy}-from with template-based
  186. qubes
  187. * tools/qvm-run: factor out actual process running into separate
  188. function
  189. * doc: improve qvm-device man page
  190. * doc: fix rst syntax in documentation, including docstrings
  191. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
  192. qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
  193. [ Patrik Hagara ]
  194. * qvm-ls: add filtering by domain power state
  195. [ Marek Marczykowski-Górecki ]
  196. * app: add option to ignore select volumes on app.clone_vm()
  197. * tools/qvm-create: properly create template-based StandaloneVM
  198. * tools/qvm-create: fix handling invalid label
  199. * Copy application menu on VM clone
  200. * Code style fix
  201. * tools: clarify qvm-service --help
  202. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
  203. qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
  204. [ Marek Marczykowski-Górecki ]
  205. * Move pylint config to canonical place
  206. * devices: add DeviceInfo.devclass attribute
  207. [ AJ Jordan ]
  208. * Fix typo
  209. [ jimtahu ]
  210. * Exclude installed_by_rpm when Restoring VM from Backup
  211. [ Marek Marczykowski-Górecki ]
  212. * devices: drop DeviceInfo.options
  213. * events: deserialize DeviceInfo class in device-* events
  214. * devices: include devclass when comparing devices
  215. * events: try reconnecting to qubesd also on BrokenPipeError
  216. * rpm: fix building on fc29
  217. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
  218. qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
  219. [ Marek Marczykowski-Górecki ]
  220. * Adjust shell input for Windows shell, for qvm-run tool
  221. * travis: install python-docutils in separate step
  222. [ Patrik Hagara ]
  223. * qvm-ls: add filtering by tags
  224. [ Marek Marczykowski-Górecki ]
  225. * tools/qvm-create: resize root volume if needed before imporing data
  226. * events: add support for wildcard event handlers
  227. * events: fix reconnecting to qubesd on its restart
  228. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
  229. qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
  230. [ Marek Marczykowski-Górecki ]
  231. * app: fix error reporting when connection to qubesd fails
  232. * tools/qvm-start-gui: do not crash on qubesd restart
  233. * Fixes for pylint 2.0
  234. [ Marta Marczykowska-Górecka ]
  235. * Deleted a duplicate man qvm-services entry
  236. [ Marek Marczykowski-Górecki ]
  237. * qvm-start-gui: fix handlign rpc-clipboard feature
  238. * Add 'gui-emulated' feature
  239. * doc: add info what properties are inherited from template
  240. * backup: avoid deadlock on logging during restore
  241. * doc: add linux-stubdom feature to man qvm-features
  242. [ Marta Marczykowska-Górecka ]
  243. * Helper function that lists where a given VM is used
  244. * Added tests and minor correction to vm_usage helper function
  245. * Name change of vm dependencies helper function
  246. * Better information on error in qvm-remove
  247. * Added test for qvm-remove dependency reporting
  248. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
  249. qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
  250. [ Peter Gerber ]
  251. * tools/qvm-firewall: Describe available rules in --help output
  252. [ Marek Marczykowski-Górecki ]
  253. * tools/qvm-firewall: add 'expire' rule support
  254. * tools/qvm-firewall: make 'list' a default action
  255. [ Peter Gerber ]
  256. * tools/qvm-firewall: Show EXPIRE column in list output
  257. * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
  258. * .gitignore: add doc/_build/
  259. * tools/qvm-firewall: improve manpage and --help output
  260. [ Marek Marczykowski-Górecki ]
  261. * Fix reporting events even if its source is not available anymore
  262. * tools: don't fail qvm-template-postprocess on shutdown race
  263. condition
  264. [ jimtahu ]
  265. * Change "None" to Property None
  266. * Change "None" in qvm_prefs
  267. * Add test of qvm_prefs for specal case "None"
  268. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
  269. qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
  270. [ Frédéric Pierret ]
  271. * Create .spec.in and Source0
  272. * Remove _builddir and useless condition on qubes_builder
  273. * doc: handle release definition when not being in a git repository
  274. * spec.in: add changelog placeholder
  275. [ Marek Marczykowski-Górecki ]
  276. * tools: fix error reporing on unknown storage pool
  277. * tools/qvm-pool: add --set to modify pool properties
  278. * doc: adjust example in qvm-pool man page
  279. * Add 'make clean' target, use it for Debian build
  280. * tools/qvm-ls: add --kernel option for compatibility with R3.2
  281. * tools/qvm-template-postprocess: fix reinstall action
  282. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
  283. qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
  284. * doc: typos
  285. * doc: fix module index generation
  286. * storage: add 'rw' and 'revision_to_keep' setters
  287. * qvm-volume: add 'info' and 'config' actions
  288. * storage: make Pool.{size,usage} integers
  289. * doc: update qvm-volume parameters
  290. * qvm-volume: refuse to shrink volume unless --force option is used
  291. * tools: add SubParsersHelpAction, which include subcommands details
  292. in --help
  293. * tools: suppress full traceback in console tools
  294. * qvm-template-postprocess: resize volume only when needed
  295. * qvm-template-postprocess: do not remove VM on failed reinstall
  296. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
  297. qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
  298. [ Marek Marczykowski-Górecki ]
  299. * doc: add 'pci-e820-host' feature description
  300. [ Rusty Bird ]
  301. * qvm-backup-restore: remove orphaned --replace-template option
  302. * qvm-backup-restore: really pass options
  303. * qvm-backup: let backup core handle default VM selection
  304. * restore.py: don't try to restore dispid property
  305. * restore.py: sort into three tiers in _templates_first()
  306. * restore.py: deal with DispVM templates
  307. * restore.py: factor out _restore_property() helper
  308. * restory.py: restore template_for_dispvms property early
  309. * restore.py: add template-related debug log messages
  310. [ Frédéric Pierret ]
  311. * Add support for python34-sphinx: package is provided in Qubes
  312. repository
  313. [ Marek Marczykowski-Górecki ]
  314. * tools: terminate qvm-start-gui when X server is terminated
  315. [ Rusty Bird ]
  316. * qvm-backup-restore: also handle absent --ignore-missing
  317. [ Marek Marczykowski-Górecki ]
  318. * qvm-template-postprocess: call fstrim after removing image file
  319. * tools/qvm-prefs: fix printing None value
  320. * tests: add tests for various 'qvm-prefs vm pref' cases
  321. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
  322. qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
  323. [ Marek Marczykowski-Górecki ]
  324. * vm: restore force_shutdown->kill deprecated alias
  325. [ Christopher Laprise ]
  326. * Fix AdminVm class name
  327. * Fix dom0 handling
  328. * Fix dom0 restore
  329. * style issues
  330. * unused variable
  331. [ Marek Marczykowski-Górecki ]
  332. * backup: skip dom0's properties while restoring core2 backup
  333. * backup: add support for openssl 1.1.0 options
  334. * tests: dom0 backup restore, both v3 and v4
  335. * backup: don't crash when no 'qubes' group is present
  336. [ Rusty Bird ]
  337. * template-postprocess: fast path for file-reflink, like file
  338. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
  339. qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
  340. [ Christopher Laprise ]
  341. * Fix dom0-related issues
  342. [ Marek Marczykowski-Górecki ]
  343. * backup: make pylint happy
  344. * Make pylint happy
  345. * tools/qvm-ls: fix handling columns with underscore
  346. * backup: restore Qubes 3.x VMs as HVMs
  347. * doc: update qvm-features documentation
  348. [ Christopher Laprise ]
  349. * Add --yes option and confirm prompt.
  350. * Fix error message grammar
  351. * Toggle installed_by_rpm in template tool
  352. * Use --force instead of --yes
  353. * Print vm list before prompt
  354. * Avoid cloning installed_by_rpm
  355. * Add --force to manpage.
  356. * Fix style else-return
  357. [ Marek Marczykowski-Górecki ]
  358. * tests: update qvm-template-process and qvm-remove tests
  359. * add QubesVM.connected_vms attribute
  360. [ Rusty Bird ]
  361. * qvm-device/block: Alias '--ro' to '--option read-only=yes'
  362. * qvm-device.rst: Document '--ro' option
  363. [ Marek Marczykowski-Górecki ]
  364. * doc: add info about specific qvm-device cases
  365. * storage: add volume.is_outdated() function
  366. * tools/qvm-start: add naive waiting for cdrom device
  367. * tools: fix handling optional domain list
  368. * tools/qvm-ls: allow list only selected VMs
  369. * tools/qvm-ls: add --raw-list option for compatibility with R3.2
  370. * tools/qvm-ls: add --network and --disk compatibility options
  371. * tools/qvm-ls: clarify that disk usage is in percents
  372. * base: make WrapperObjectsCollection behave like a dict
  373. * rpm,deb: add missing python lxml dependency
  374. * Add property_get_default method
  375. * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
  376. [ Rusty Bird ]
  377. * qvm-run: wait for X11 in --dispvm --gui case
  378. [ Marek Marczykowski-Górecki ]
  379. * storage: add size and usage properties
  380. * backup/restore: do not shrink volumes on restore
  381. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
  382. qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
  383. [ Jean-Philippe Ouellet ]
  384. * Stop leaking terminal escapes via stderr
  385. [ Marek Marczykowski-Górecki ]
  386. * tests: Update tests after fix for filtering stderr
  387. [ Jean-Philippe Ouellet ]
  388. * Fix qvm-ls --raw-data
  389. * Disable spinner if --raw-data
  390. * Remove dead code
  391. [ qubesuser ]
  392. * don't lookup list of labels just to read VM properties
  393. * don't use ast.literal_eval, just directly convert to the desired
  394. type
  395. [ Marek Marczykowski-Górecki ]
  396. * tests: make filter-esc tests working also on travis
  397. * tests: fix tests after dropping unnecessary admin.label.List call
  398. [ Christopher Laprise ]
  399. * Issue #3303
  400. * Fix verify-only
  401. * verify-only avoid dom0 handler
  402. [ Marek Marczykowski-Górecki ]
  403. * tests: update tests for fixed verify_only handling
  404. * make qvm-shutdown nice for unit tests
  405. * Make pylint happy
  406. * Another approach for making qvm-shutdown nice for tests
  407. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
  408. qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
  409. [ qubesuser ]
  410. * remove format_doc and docutils import
  411. * don't import pkg_resources in the top of qubesadmin/utils.py
  412. * replace console entry points with just importing the module
  413. * replace key in dir(self) with faster and better code
  414. [ Jean-Philippe Ouellet ]
  415. * Fix setting stderr default coloring policy
  416. * Restore correct colors in verbose mode
  417. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
  418. qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
  419. [ Marek Marczykowski-Górecki ]
  420. * Document device attach options in man page
  421. * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
  422. * backup: fix handling labels in Qubes 4.0 backups
  423. [ qubesuser ]
  424. * make qvm-run work for non-blocking stdin
  425. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
  426. qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
  427. [ Frédéric Pierret ]
  428. * Add CentOS support and fix python3 dependencies for CentOS (except
  429. python3-sphinx and python3-daemon which has no python34 package)
  430. [ Marek Marczykowski-Górecki ]
  431. * Fix DeviceInfo objects comparing
  432. * vm: fix handling policy deny on admin.vm.List
  433. * Drop log.DBusHandler
  434. * backup: improve migrating templates from Qubes 3.x
  435. * tools: fix handling qvm-run --no-autostart
  436. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
  437. qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
  438. * backup: fix restoring template VMs
  439. * tools: clarify that qvm-backup needs absolute path
  440. * backup: fix name of meminfo-writer feature
  441. * backup: update DispVM template property: template_for_dispvms
  442. * backup: improve restoring HVMs from Qubes 3.2
  443. * backup: do not try to read tar's stderr past EOF
  444. * tests: multi-part volume in backup tests
  445. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
  446. qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
  447. [ Marek Marczykowski-Górecki ]
  448. * Implement "blind mode" to avoid listing objects
  449. * events: ignore events from non-existing domains
  450. * tools: fix qvm-run --help
  451. * Always use QubesVM objects, instead of AppVM/TemplateVM etc
  452. * Move vm.appvms to QubesVM
  453. * Drop individual VM classes as python types completely
  454. * tools: finish 'qvm-volume revert' implementation, add tests
  455. * tools/qvm-start: fix starting a VM with cdrom image
  456. * vm: drop suspend and resume methods - not part of the Admin API
  457. * rpm: add conflict with too-old qubes-manager
  458. [ Mindy Preston ]
  459. * qvm-start: exit if domain running and no --skip-if-running
  460. [ Marek Marczykowski-Górecki ]
  461. * tools: adjust qvm-start message and logic, update tests
  462. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
  463. qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
  464. [ Marek Marczykowski-Górecki ]
  465. * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
  466. is given
  467. * vm/dispvm: fix dispvm.cleanup() when no service was called
  468. * tests: add DispVM tests
  469. * Improve QubesDaemonNoResponseError error message
  470. * tools: drop --delete and --unset aliases for --default option
  471. * doc: update list of properties in qvm-prefs/qubes-prefs man pages
  472. * doc: add short description of VM classes to qvm-create man page
  473. * tools: implement qvm-create --root-move-from/--root-copy-from
  474. * tools: add qvm-create --help-classes
  475. * backup/restore: make backup header extraction faster
  476. * backup/restore: do not fail the whole restore when qvm-appmenus is
  477. missing
  478. [ blackpit ]
  479. * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
  480. [ Marek Marczykowski-Górecki ]
  481. * tools: fix too long lines
  482. * tools: cleanup temporary files after qvm-template-postprocess
  483. * devices: client stub for DeviceCollection.update_persistent
  484. * tools: restore qvm-start --cdrom and similar options
  485. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
  486. qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
  487. * tools/qvm-run: fix handling small data blocks
  488. * vm: add DispVMWrapper for calling a single service in new DispVM
  489. * tools: add qvm-run --dispvm option
  490. * doc: list known features in qvm-features manual page
  491. * app: add VMCollection.values()
  492. * tools/qvm-run: do not use os.set_blocking
  493. * tools/qvm-device: list attach options
  494. * doc: add default values to qvm-features man page
  495. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
  496. qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
  497. * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
  498. agent
  499. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
  500. qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
  501. * tools/qvm-backup-restore: fix default list of VMs to restore
  502. * storage: drop 'internal' volume property
  503. * tools/qvm-volume: fix default action handling
  504. * tests: qvm-backup-restore tool tests
  505. * tools/qvm-backup-restore: fix restoring only specific VMs
  506. * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
  507. * backup: move BackupRestore class and helpers to 'restore' submodule
  508. * tools: add qvm-backup tool
  509. * debian: update build depends
  510. * doc: update qvm-backup man page
  511. * backup/restore: improve error reporting
  512. * backup/restore: add option to ignore size limit
  513. * events: add variable Admin API method name
  514. * tools/qvm-shutdown: drop --force option, it isn't supported anymore
  515. * tools/qvm-shutdown: fix help message
  516. * tools/qvm-start-gui: add --force-stubdomain options
  517. * features: serialize True as '1'
  518. * tests: too much copy&paste
  519. * tools: qvm-service tool
  520. * doc: update manpage of qvm-service
  521. * qvm-ls: fix total VM size reporting
  522. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
  523. qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
  524. [ Marek Marczykowski-Górecki ]
  525. * vm: make QubesVM objects hashable
  526. * events: simplify wait_for_domain_shutdown coroutine
  527. * tools: handle shutdown order in qvm-shutdown
  528. * tests/tools: add MockEventsReader
  529. * tests: qvm-shutdown --wait tests
  530. * Fix VM creation with default template
  531. * events: fix cleanup function in qrexec case
  532. * tests: improve test failure message
  533. [ Marta Marczykowska-Górecka ]
  534. * added helper function updates_vms_status
  535. [ Marek Marczykowski-Górecki ]
  536. * tools/qvm-run: fix handling copying stdin to the process
  537. * tests: mark qvm-run tests with "expected failure"
  538. * tools/qvm-run: fix handling EOF
  539. * Make pylint happy
  540. * Don't try to set 'created-by-' tag when cloning VM
  541. * backup: initial support for backup restore over Admin API
  542. * tests/backup: tests for backup-restore code
  543. * Exclude 'qubesadmin.backup' module from python2 install
  544. * devices,features: fix bool values handling
  545. * tests/backup: use smaller images
  546. * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
  547. * backup: add firewall and appmenus list handling
  548. * firewall: fix handling DstHost.prefixlen=0
  549. * tests: backup: add firewall.xml and appmenus checking
  550. * tools: add qvm-backup-restore
  551. * app: call admin.vm.volume.Import as root
  552. * backup: do not show full stacktrace to the user
  553. * backup: change 'hvm' property to 'virt_mode'
  554. * backup: use 'cat' instead of read-write loop in python
  555. * backup: improve error logging
  556. * tools/qvm-backup-restore: handle VMs selection, not only exclusion
  557. * Choose QubesLocal or QubesRemote based on /etc/qubes-release
  558. presence
  559. * Change 'hvm' property to 'virt_mode'
  560. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
  561. qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
  562. *
  563. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
  564. qubes-core-admin-client (4.0.0-1) unstable; urgency=low
  565. * Initial release
  566. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200