changelog 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691
  1. qubes-core-admin-client (4.1.1-1) unstable; urgency=medium
  2. [ Frédéric Pierret (fepitre) ]
  3. * travis: switch to bionic
  4. * Make PEP8 happier
  5. * qvm-start-gui: handle GuiVM
  6. * guivm: use getattr instead of try/except and direct property access
  7. * qvm-start-gui: simplify log info for start_gui function
  8. * app: fix missing docstring for get_local_name
  9. * app: get_local_name set/from self attribute
  10. * tests: fix with respect to gui properties
  11. * tests: qvm_start_gui: make PEP8 happier
  12. * app: switch get_local_name method to property
  13. [ Marta Marczykowska-Górecka ]
  14. * Fixed error with import
  15. * Added pool.usage_details API method
  16. [ Saswat Padhi ]
  17. * Improvements to qvm-pool argument parser
  18. * Updated tests for qvm-pool
  19. * Fixed a bug and removed unused import
  20. * Added a new test and minor updates to others
  21. * Updated qvm-pool.rst file
  22. * Preserve backward compatibility
  23. [ Rot127 ]
  24. * added feature to list domains as network tree
  25. * network tree manpage entry added
  26. * Sort domains in network tree list
  27. * Add tests for --tree option of qvm-ls
  28. [ Frédéric Pierret (fepitre) ]
  29. * prefs: handle 'none' value for guivm
  30. * utils: handle default_guivm and guivm properties
  31. * utils: make PEP8 happy
  32. * tests: add default_guivm and guivm in utils properties
  33. * tests: make PEP8 and pylint happy
  34. [ Marta Marczykowska-Górecka ]
  35. * Added an exception for backup already in progress
  36. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 13 Nov 2019 05:58:53 +0100
  37. qubes-core-admin-client (4.1.0-1) unstable; urgency=medium
  38. [ Frédéric Pierret (fepitre) ]
  39. * devices: make PEP8 happy
  40. * devices: handle listing of available device classes
  41. * tests/devices: make PEP8 happy
  42. * tests/devices: add test for handling listing device classes
  43. * tools/qvm-device: make PEP8 happy
  44. * devices: make iteration device classes compatible with Python2
  45. * devices: add missing docstring for _get_device_classes
  46. * qvm-check: refactor check mechanism and add filter for checking
  47. netvm
  48. * qvm-check: fix from Marek's comment
  49. [ hexagonrecursion ]
  50. * Fix a pref name in the qvm-prefs man page
  51. * Clarify the network-manager qubes service default
  52. * Correct network-manager qubes service default
  53. [ Frédéric Pierret (fepitre) ]
  54. * qubesadmin: make PEP8 happy
  55. * qubesadmin: define methods list_vmclass and list_devicesclass
  56. * qvm-device: handle 'list-device-classes' and 'list-classes'
  57. * qvm-device: prevent parser allowing abbreviations
  58. * qvm-device: add manpage entry
  59. [ Marek Marczykowski-Górecki ]
  60. * backup/restore: reject uncommon compression filters and improve
  61. header validation
  62. * backup/restore: add option to use uncommon compression filter anyway
  63. * tests: check rejecting/accepting compression filters
  64. * backup/restore: make pylint happy
  65. [ Frédéric Pierret (fepitre) ]
  66. * Fix Sphinx 2 new API for Fedora 31+
  67. * dochelpers: handle legacy sphinx library
  68. * dochelpers: make PEP8 happier
  69. [ Marta Marczykowska-Górecka ]
  70. * Fixed error with VM being incorrectly listed as its own dependency
  71. [ Marek Marczykowski-Górecki ]
  72. * rpm: fix release number
  73. * Add support for run_service(..., filter_esc=True) in a VM
  74. * Add run_service(..., autostart=False) argument
  75. * tools/qvm-start-gui: avoid starting a VM just to send it monitor
  76. layout
  77. * Make pylint happy
  78. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 09 Oct 2019 05:48:48 +0200
  79. qubes-core-admin-client (4.0.26-1) unstable; urgency=medium
  80. [ Marek Marczykowski-Górecki ]
  81. * doc: typo fix
  82. [ anadahz ]
  83. * Remove policy option from man page
  84. [ Marek Marczykowski-Górecki ]
  85. * tests: update yaml syntax in qvm-backup tests
  86. [ Conor Schaefer ]
  87. * Adds support for `--ignore-errors` to qvm-clone CLI
  88. * Adds docs for clone ignore_errors, feeds linter
  89. [ Malte Leip ]
  90. * qvm-prefs: add --hide-default option
  91. [ Marek Marczykowski-Górecki ]
  92. * travis: switch to xenial, update distributions
  93. [ unman ]
  94. * Remove unnecessary comma in qvm-backup.rst
  95. [ Marek Marczykowski-Górecki ]
  96. * Allow app.domains[vm] where vm is a QubesVM object
  97. * travis: drop python 3.4, add python 3.6 and 3.7
  98. * tests: fix events tests on python3.7
  99. * tools: reset private volume when importing template over existing
  100. one
  101. * tools/qvm-volume: add 'import' action
  102. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 30 Jul 2019 16:29:31 +0200
  103. qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
  104. [ Marek Marczykowski-Górecki ]
  105. * doc: update meminfo-writer service note
  106. [ GammaSQ ]
  107. * fixed typo
  108. [ Marek Marczykowski-Górecki ]
  109. * rpm: unify fedora and centos packaging
  110. * rpm: add R: python3-yaml, as needed by qvm-backup tool
  111. * backup: do not fail restore if scrypt anticipate more time needed
  112. * tools/qvm-run: do not color the output unless --pass-io is used
  113. * Bump Python version requirement for qvm-* to 3.5
  114. * utils: include management_dispvm property when checking where VM is
  115. used
  116. * backup: Do not try to attach devices during backup verification
  117. * tools/qvm-backup: allow to disable compression
  118. * events: simplify handling qubesd reconnect
  119. * vm: add run_with_args method to call a single command with specific
  120. arguments
  121. * tests: vm.run, vm.run_with_args
  122. * tools/qvm-start: use vm.run_with_args to call losetup in the VM
  123. * tools/qvm-start: validate output of losetup command
  124. * Make vm.run_with_args working on python2
  125. * Make pylint happy
  126. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
  127. qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
  128. * tools/qvm-run: make -q affect 'command failed with code' message
  129. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
  130. qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
  131. [ Marek Marczykowski-Górecki ]
  132. * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
  133. * Remove useless 'pass' to make pylint happy
  134. * backup: simplify test expressions to make pylint happy
  135. [ GammaSQ ]
  136. * get_label now accepts integer and has correct return-type
  137. * forgot braces
  138. * reverted to comparing .index
  139. * forgot braces
  140. * isinstance instead of type
  141. * added --standalone and --disp shortcuts
  142. * diff doesn't set template
  143. * added tests for shortcuts
  144. * Documentation is important! Added shortcuts to manpages
  145. * Fixed typo in documentation
  146. [ Marek Marczykowski-Górecki ]
  147. * tests/tools: extend vm.run_service() mockup
  148. * tests/tools: improve qvm-run tests
  149. * tools: fix qvm-run --pass-io --localcmd=... vmname command
  150. * tools/qvm-run: handle Ctrl+C nicely
  151. * tools/qvm-run: factor out print_no_color function
  152. * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
  153. * tools/qvm-run: add error message if command in VM failed
  154. * tools/qvm-device: allow detaching all devices
  155. * doc: add 'permissive' PCI device option and 'mic' device class
  156. * Clone VM's volume into the same pool, unless overridden specifically
  157. * tools: remove extra debug
  158. * tools/qvm-create: reject --root-{move,copy}-from with template-based
  159. qubes
  160. * tools/qvm-run: factor out actual process running into separate
  161. function
  162. * doc: improve qvm-device man page
  163. * doc: fix rst syntax in documentation, including docstrings
  164. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
  165. qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
  166. [ Patrik Hagara ]
  167. * qvm-ls: add filtering by domain power state
  168. [ Marek Marczykowski-Górecki ]
  169. * app: add option to ignore select volumes on app.clone_vm()
  170. * tools/qvm-create: properly create template-based StandaloneVM
  171. * tools/qvm-create: fix handling invalid label
  172. * Copy application menu on VM clone
  173. * Code style fix
  174. * tools: clarify qvm-service --help
  175. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
  176. qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
  177. [ Marek Marczykowski-Górecki ]
  178. * Move pylint config to canonical place
  179. * devices: add DeviceInfo.devclass attribute
  180. [ AJ Jordan ]
  181. * Fix typo
  182. [ jimtahu ]
  183. * Exclude installed_by_rpm when Restoring VM from Backup
  184. [ Marek Marczykowski-Górecki ]
  185. * devices: drop DeviceInfo.options
  186. * events: deserialize DeviceInfo class in device-* events
  187. * devices: include devclass when comparing devices
  188. * events: try reconnecting to qubesd also on BrokenPipeError
  189. * rpm: fix building on fc29
  190. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
  191. qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
  192. [ Marek Marczykowski-Górecki ]
  193. * Adjust shell input for Windows shell, for qvm-run tool
  194. * travis: install python-docutils in separate step
  195. [ Patrik Hagara ]
  196. * qvm-ls: add filtering by tags
  197. [ Marek Marczykowski-Górecki ]
  198. * tools/qvm-create: resize root volume if needed before imporing data
  199. * events: add support for wildcard event handlers
  200. * events: fix reconnecting to qubesd on its restart
  201. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
  202. qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
  203. [ Marek Marczykowski-Górecki ]
  204. * app: fix error reporting when connection to qubesd fails
  205. * tools/qvm-start-gui: do not crash on qubesd restart
  206. * Fixes for pylint 2.0
  207. [ Marta Marczykowska-Górecka ]
  208. * Deleted a duplicate man qvm-services entry
  209. [ Marek Marczykowski-Górecki ]
  210. * qvm-start-gui: fix handlign rpc-clipboard feature
  211. * Add 'gui-emulated' feature
  212. * doc: add info what properties are inherited from template
  213. * backup: avoid deadlock on logging during restore
  214. * doc: add linux-stubdom feature to man qvm-features
  215. [ Marta Marczykowska-Górecka ]
  216. * Helper function that lists where a given VM is used
  217. * Added tests and minor correction to vm_usage helper function
  218. * Name change of vm dependencies helper function
  219. * Better information on error in qvm-remove
  220. * Added test for qvm-remove dependency reporting
  221. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
  222. qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
  223. [ Peter Gerber ]
  224. * tools/qvm-firewall: Describe available rules in --help output
  225. [ Marek Marczykowski-Górecki ]
  226. * tools/qvm-firewall: add 'expire' rule support
  227. * tools/qvm-firewall: make 'list' a default action
  228. [ Peter Gerber ]
  229. * tools/qvm-firewall: Show EXPIRE column in list output
  230. * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
  231. * .gitignore: add doc/_build/
  232. * tools/qvm-firewall: improve manpage and --help output
  233. [ Marek Marczykowski-Górecki ]
  234. * Fix reporting events even if its source is not available anymore
  235. * tools: don't fail qvm-template-postprocess on shutdown race
  236. condition
  237. [ jimtahu ]
  238. * Change "None" to Property None
  239. * Change "None" in qvm_prefs
  240. * Add test of qvm_prefs for specal case "None"
  241. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
  242. qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
  243. [ Frédéric Pierret ]
  244. * Create .spec.in and Source0
  245. * Remove _builddir and useless condition on qubes_builder
  246. * doc: handle release definition when not being in a git repository
  247. * spec.in: add changelog placeholder
  248. [ Marek Marczykowski-Górecki ]
  249. * tools: fix error reporing on unknown storage pool
  250. * tools/qvm-pool: add --set to modify pool properties
  251. * doc: adjust example in qvm-pool man page
  252. * Add 'make clean' target, use it for Debian build
  253. * tools/qvm-ls: add --kernel option for compatibility with R3.2
  254. * tools/qvm-template-postprocess: fix reinstall action
  255. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
  256. qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
  257. * doc: typos
  258. * doc: fix module index generation
  259. * storage: add 'rw' and 'revision_to_keep' setters
  260. * qvm-volume: add 'info' and 'config' actions
  261. * storage: make Pool.{size,usage} integers
  262. * doc: update qvm-volume parameters
  263. * qvm-volume: refuse to shrink volume unless --force option is used
  264. * tools: add SubParsersHelpAction, which include subcommands details
  265. in --help
  266. * tools: suppress full traceback in console tools
  267. * qvm-template-postprocess: resize volume only when needed
  268. * qvm-template-postprocess: do not remove VM on failed reinstall
  269. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
  270. qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
  271. [ Marek Marczykowski-Górecki ]
  272. * doc: add 'pci-e820-host' feature description
  273. [ Rusty Bird ]
  274. * qvm-backup-restore: remove orphaned --replace-template option
  275. * qvm-backup-restore: really pass options
  276. * qvm-backup: let backup core handle default VM selection
  277. * restore.py: don't try to restore dispid property
  278. * restore.py: sort into three tiers in _templates_first()
  279. * restore.py: deal with DispVM templates
  280. * restore.py: factor out _restore_property() helper
  281. * restory.py: restore template_for_dispvms property early
  282. * restore.py: add template-related debug log messages
  283. [ Frédéric Pierret ]
  284. * Add support for python34-sphinx: package is provided in Qubes
  285. repository
  286. [ Marek Marczykowski-Górecki ]
  287. * tools: terminate qvm-start-gui when X server is terminated
  288. [ Rusty Bird ]
  289. * qvm-backup-restore: also handle absent --ignore-missing
  290. [ Marek Marczykowski-Górecki ]
  291. * qvm-template-postprocess: call fstrim after removing image file
  292. * tools/qvm-prefs: fix printing None value
  293. * tests: add tests for various 'qvm-prefs vm pref' cases
  294. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
  295. qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
  296. [ Marek Marczykowski-Górecki ]
  297. * vm: restore force_shutdown->kill deprecated alias
  298. [ Christopher Laprise ]
  299. * Fix AdminVm class name
  300. * Fix dom0 handling
  301. * Fix dom0 restore
  302. * style issues
  303. * unused variable
  304. [ Marek Marczykowski-Górecki ]
  305. * backup: skip dom0's properties while restoring core2 backup
  306. * backup: add support for openssl 1.1.0 options
  307. * tests: dom0 backup restore, both v3 and v4
  308. * backup: don't crash when no 'qubes' group is present
  309. [ Rusty Bird ]
  310. * template-postprocess: fast path for file-reflink, like file
  311. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
  312. qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
  313. [ Christopher Laprise ]
  314. * Fix dom0-related issues
  315. [ Marek Marczykowski-Górecki ]
  316. * backup: make pylint happy
  317. * Make pylint happy
  318. * tools/qvm-ls: fix handling columns with underscore
  319. * backup: restore Qubes 3.x VMs as HVMs
  320. * doc: update qvm-features documentation
  321. [ Christopher Laprise ]
  322. * Add --yes option and confirm prompt.
  323. * Fix error message grammar
  324. * Toggle installed_by_rpm in template tool
  325. * Use --force instead of --yes
  326. * Print vm list before prompt
  327. * Avoid cloning installed_by_rpm
  328. * Add --force to manpage.
  329. * Fix style else-return
  330. [ Marek Marczykowski-Górecki ]
  331. * tests: update qvm-template-process and qvm-remove tests
  332. * add QubesVM.connected_vms attribute
  333. [ Rusty Bird ]
  334. * qvm-device/block: Alias '--ro' to '--option read-only=yes'
  335. * qvm-device.rst: Document '--ro' option
  336. [ Marek Marczykowski-Górecki ]
  337. * doc: add info about specific qvm-device cases
  338. * storage: add volume.is_outdated() function
  339. * tools/qvm-start: add naive waiting for cdrom device
  340. * tools: fix handling optional domain list
  341. * tools/qvm-ls: allow list only selected VMs
  342. * tools/qvm-ls: add --raw-list option for compatibility with R3.2
  343. * tools/qvm-ls: add --network and --disk compatibility options
  344. * tools/qvm-ls: clarify that disk usage is in percents
  345. * base: make WrapperObjectsCollection behave like a dict
  346. * rpm,deb: add missing python lxml dependency
  347. * Add property_get_default method
  348. * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
  349. [ Rusty Bird ]
  350. * qvm-run: wait for X11 in --dispvm --gui case
  351. [ Marek Marczykowski-Górecki ]
  352. * storage: add size and usage properties
  353. * backup/restore: do not shrink volumes on restore
  354. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
  355. qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
  356. [ Jean-Philippe Ouellet ]
  357. * Stop leaking terminal escapes via stderr
  358. [ Marek Marczykowski-Górecki ]
  359. * tests: Update tests after fix for filtering stderr
  360. [ Jean-Philippe Ouellet ]
  361. * Fix qvm-ls --raw-data
  362. * Disable spinner if --raw-data
  363. * Remove dead code
  364. [ qubesuser ]
  365. * don't lookup list of labels just to read VM properties
  366. * don't use ast.literal_eval, just directly convert to the desired
  367. type
  368. [ Marek Marczykowski-Górecki ]
  369. * tests: make filter-esc tests working also on travis
  370. * tests: fix tests after dropping unnecessary admin.label.List call
  371. [ Christopher Laprise ]
  372. * Issue #3303
  373. * Fix verify-only
  374. * verify-only avoid dom0 handler
  375. [ Marek Marczykowski-Górecki ]
  376. * tests: update tests for fixed verify_only handling
  377. * make qvm-shutdown nice for unit tests
  378. * Make pylint happy
  379. * Another approach for making qvm-shutdown nice for tests
  380. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
  381. qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
  382. [ qubesuser ]
  383. * remove format_doc and docutils import
  384. * don't import pkg_resources in the top of qubesadmin/utils.py
  385. * replace console entry points with just importing the module
  386. * replace key in dir(self) with faster and better code
  387. [ Jean-Philippe Ouellet ]
  388. * Fix setting stderr default coloring policy
  389. * Restore correct colors in verbose mode
  390. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
  391. qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
  392. [ Marek Marczykowski-Górecki ]
  393. * Document device attach options in man page
  394. * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
  395. * backup: fix handling labels in Qubes 4.0 backups
  396. [ qubesuser ]
  397. * make qvm-run work for non-blocking stdin
  398. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
  399. qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
  400. [ Frédéric Pierret ]
  401. * Add CentOS support and fix python3 dependencies for CentOS (except
  402. python3-sphinx and python3-daemon which has no python34 package)
  403. [ Marek Marczykowski-Górecki ]
  404. * Fix DeviceInfo objects comparing
  405. * vm: fix handling policy deny on admin.vm.List
  406. * Drop log.DBusHandler
  407. * backup: improve migrating templates from Qubes 3.x
  408. * tools: fix handling qvm-run --no-autostart
  409. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
  410. qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
  411. * backup: fix restoring template VMs
  412. * tools: clarify that qvm-backup needs absolute path
  413. * backup: fix name of meminfo-writer feature
  414. * backup: update DispVM template property: template_for_dispvms
  415. * backup: improve restoring HVMs from Qubes 3.2
  416. * backup: do not try to read tar's stderr past EOF
  417. * tests: multi-part volume in backup tests
  418. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
  419. qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
  420. [ Marek Marczykowski-Górecki ]
  421. * Implement "blind mode" to avoid listing objects
  422. * events: ignore events from non-existing domains
  423. * tools: fix qvm-run --help
  424. * Always use QubesVM objects, instead of AppVM/TemplateVM etc
  425. * Move vm.appvms to QubesVM
  426. * Drop individual VM classes as python types completely
  427. * tools: finish 'qvm-volume revert' implementation, add tests
  428. * tools/qvm-start: fix starting a VM with cdrom image
  429. * vm: drop suspend and resume methods - not part of the Admin API
  430. * rpm: add conflict with too-old qubes-manager
  431. [ Mindy Preston ]
  432. * qvm-start: exit if domain running and no --skip-if-running
  433. [ Marek Marczykowski-Górecki ]
  434. * tools: adjust qvm-start message and logic, update tests
  435. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
  436. qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
  437. [ Marek Marczykowski-Górecki ]
  438. * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
  439. is given
  440. * vm/dispvm: fix dispvm.cleanup() when no service was called
  441. * tests: add DispVM tests
  442. * Improve QubesDaemonNoResponseError error message
  443. * tools: drop --delete and --unset aliases for --default option
  444. * doc: update list of properties in qvm-prefs/qubes-prefs man pages
  445. * doc: add short description of VM classes to qvm-create man page
  446. * tools: implement qvm-create --root-move-from/--root-copy-from
  447. * tools: add qvm-create --help-classes
  448. * backup/restore: make backup header extraction faster
  449. * backup/restore: do not fail the whole restore when qvm-appmenus is
  450. missing
  451. [ blackpit ]
  452. * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
  453. [ Marek Marczykowski-Górecki ]
  454. * tools: fix too long lines
  455. * tools: cleanup temporary files after qvm-template-postprocess
  456. * devices: client stub for DeviceCollection.update_persistent
  457. * tools: restore qvm-start --cdrom and similar options
  458. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
  459. qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
  460. * tools/qvm-run: fix handling small data blocks
  461. * vm: add DispVMWrapper for calling a single service in new DispVM
  462. * tools: add qvm-run --dispvm option
  463. * doc: list known features in qvm-features manual page
  464. * app: add VMCollection.values()
  465. * tools/qvm-run: do not use os.set_blocking
  466. * tools/qvm-device: list attach options
  467. * doc: add default values to qvm-features man page
  468. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
  469. qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
  470. * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
  471. agent
  472. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
  473. qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
  474. * tools/qvm-backup-restore: fix default list of VMs to restore
  475. * storage: drop 'internal' volume property
  476. * tools/qvm-volume: fix default action handling
  477. * tests: qvm-backup-restore tool tests
  478. * tools/qvm-backup-restore: fix restoring only specific VMs
  479. * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
  480. * backup: move BackupRestore class and helpers to 'restore' submodule
  481. * tools: add qvm-backup tool
  482. * debian: update build depends
  483. * doc: update qvm-backup man page
  484. * backup/restore: improve error reporting
  485. * backup/restore: add option to ignore size limit
  486. * events: add variable Admin API method name
  487. * tools/qvm-shutdown: drop --force option, it isn't supported anymore
  488. * tools/qvm-shutdown: fix help message
  489. * tools/qvm-start-gui: add --force-stubdomain options
  490. * features: serialize True as '1'
  491. * tests: too much copy&paste
  492. * tools: qvm-service tool
  493. * doc: update manpage of qvm-service
  494. * qvm-ls: fix total VM size reporting
  495. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
  496. qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
  497. [ Marek Marczykowski-Górecki ]
  498. * vm: make QubesVM objects hashable
  499. * events: simplify wait_for_domain_shutdown coroutine
  500. * tools: handle shutdown order in qvm-shutdown
  501. * tests/tools: add MockEventsReader
  502. * tests: qvm-shutdown --wait tests
  503. * Fix VM creation with default template
  504. * events: fix cleanup function in qrexec case
  505. * tests: improve test failure message
  506. [ Marta Marczykowska-Górecka ]
  507. * added helper function updates_vms_status
  508. [ Marek Marczykowski-Górecki ]
  509. * tools/qvm-run: fix handling copying stdin to the process
  510. * tests: mark qvm-run tests with "expected failure"
  511. * tools/qvm-run: fix handling EOF
  512. * Make pylint happy
  513. * Don't try to set 'created-by-' tag when cloning VM
  514. * backup: initial support for backup restore over Admin API
  515. * tests/backup: tests for backup-restore code
  516. * Exclude 'qubesadmin.backup' module from python2 install
  517. * devices,features: fix bool values handling
  518. * tests/backup: use smaller images
  519. * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
  520. * backup: add firewall and appmenus list handling
  521. * firewall: fix handling DstHost.prefixlen=0
  522. * tests: backup: add firewall.xml and appmenus checking
  523. * tools: add qvm-backup-restore
  524. * app: call admin.vm.volume.Import as root
  525. * backup: do not show full stacktrace to the user
  526. * backup: change 'hvm' property to 'virt_mode'
  527. * backup: use 'cat' instead of read-write loop in python
  528. * backup: improve error logging
  529. * tools/qvm-backup-restore: handle VMs selection, not only exclusion
  530. * Choose QubesLocal or QubesRemote based on /etc/qubes-release
  531. presence
  532. * Change 'hvm' property to 'virt_mode'
  533. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
  534. qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
  535. *
  536. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
  537. qubes-core-admin-client (4.0.0-1) unstable; urgency=low
  538. * Initial release
  539. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200