changelog 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699
  1. qubes-core-admin-client (4.1.2-1) unstable; urgency=medium
  2. [ Marta Marczykowska-Górecka ]
  3. * Fixed overeager assert
  4. * Fixed metadata usage being served as strings
  5. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 30 Nov 2019 05:12:01 +0100
  6. qubes-core-admin-client (4.1.1-1) unstable; urgency=medium
  7. [ Frédéric Pierret (fepitre) ]
  8. * travis: switch to bionic
  9. * Make PEP8 happier
  10. * qvm-start-gui: handle GuiVM
  11. * guivm: use getattr instead of try/except and direct property access
  12. * qvm-start-gui: simplify log info for start_gui function
  13. * app: fix missing docstring for get_local_name
  14. * app: get_local_name set/from self attribute
  15. * tests: fix with respect to gui properties
  16. * tests: qvm_start_gui: make PEP8 happier
  17. * app: switch get_local_name method to property
  18. [ Marta Marczykowska-Górecka ]
  19. * Fixed error with import
  20. * Added pool.usage_details API method
  21. [ Saswat Padhi ]
  22. * Improvements to qvm-pool argument parser
  23. * Updated tests for qvm-pool
  24. * Fixed a bug and removed unused import
  25. * Added a new test and minor updates to others
  26. * Updated qvm-pool.rst file
  27. * Preserve backward compatibility
  28. [ Rot127 ]
  29. * added feature to list domains as network tree
  30. * network tree manpage entry added
  31. * Sort domains in network tree list
  32. * Add tests for --tree option of qvm-ls
  33. [ Frédéric Pierret (fepitre) ]
  34. * prefs: handle 'none' value for guivm
  35. * utils: handle default_guivm and guivm properties
  36. * utils: make PEP8 happy
  37. * tests: add default_guivm and guivm in utils properties
  38. * tests: make PEP8 and pylint happy
  39. [ Marta Marczykowska-Górecka ]
  40. * Added an exception for backup already in progress
  41. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 13 Nov 2019 05:58:53 +0100
  42. qubes-core-admin-client (4.1.0-1) unstable; urgency=medium
  43. [ Frédéric Pierret (fepitre) ]
  44. * devices: make PEP8 happy
  45. * devices: handle listing of available device classes
  46. * tests/devices: make PEP8 happy
  47. * tests/devices: add test for handling listing device classes
  48. * tools/qvm-device: make PEP8 happy
  49. * devices: make iteration device classes compatible with Python2
  50. * devices: add missing docstring for _get_device_classes
  51. * qvm-check: refactor check mechanism and add filter for checking
  52. netvm
  53. * qvm-check: fix from Marek's comment
  54. [ hexagonrecursion ]
  55. * Fix a pref name in the qvm-prefs man page
  56. * Clarify the network-manager qubes service default
  57. * Correct network-manager qubes service default
  58. [ Frédéric Pierret (fepitre) ]
  59. * qubesadmin: make PEP8 happy
  60. * qubesadmin: define methods list_vmclass and list_devicesclass
  61. * qvm-device: handle 'list-device-classes' and 'list-classes'
  62. * qvm-device: prevent parser allowing abbreviations
  63. * qvm-device: add manpage entry
  64. [ Marek Marczykowski-Górecki ]
  65. * backup/restore: reject uncommon compression filters and improve
  66. header validation
  67. * backup/restore: add option to use uncommon compression filter anyway
  68. * tests: check rejecting/accepting compression filters
  69. * backup/restore: make pylint happy
  70. [ Frédéric Pierret (fepitre) ]
  71. * Fix Sphinx 2 new API for Fedora 31+
  72. * dochelpers: handle legacy sphinx library
  73. * dochelpers: make PEP8 happier
  74. [ Marta Marczykowska-Górecka ]
  75. * Fixed error with VM being incorrectly listed as its own dependency
  76. [ Marek Marczykowski-Górecki ]
  77. * rpm: fix release number
  78. * Add support for run_service(..., filter_esc=True) in a VM
  79. * Add run_service(..., autostart=False) argument
  80. * tools/qvm-start-gui: avoid starting a VM just to send it monitor
  81. layout
  82. * Make pylint happy
  83. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 09 Oct 2019 05:48:48 +0200
  84. qubes-core-admin-client (4.0.26-1) unstable; urgency=medium
  85. [ Marek Marczykowski-Górecki ]
  86. * doc: typo fix
  87. [ anadahz ]
  88. * Remove policy option from man page
  89. [ Marek Marczykowski-Górecki ]
  90. * tests: update yaml syntax in qvm-backup tests
  91. [ Conor Schaefer ]
  92. * Adds support for `--ignore-errors` to qvm-clone CLI
  93. * Adds docs for clone ignore_errors, feeds linter
  94. [ Malte Leip ]
  95. * qvm-prefs: add --hide-default option
  96. [ Marek Marczykowski-Górecki ]
  97. * travis: switch to xenial, update distributions
  98. [ unman ]
  99. * Remove unnecessary comma in qvm-backup.rst
  100. [ Marek Marczykowski-Górecki ]
  101. * Allow app.domains[vm] where vm is a QubesVM object
  102. * travis: drop python 3.4, add python 3.6 and 3.7
  103. * tests: fix events tests on python3.7
  104. * tools: reset private volume when importing template over existing
  105. one
  106. * tools/qvm-volume: add 'import' action
  107. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 30 Jul 2019 16:29:31 +0200
  108. qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
  109. [ Marek Marczykowski-Górecki ]
  110. * doc: update meminfo-writer service note
  111. [ GammaSQ ]
  112. * fixed typo
  113. [ Marek Marczykowski-Górecki ]
  114. * rpm: unify fedora and centos packaging
  115. * rpm: add R: python3-yaml, as needed by qvm-backup tool
  116. * backup: do not fail restore if scrypt anticipate more time needed
  117. * tools/qvm-run: do not color the output unless --pass-io is used
  118. * Bump Python version requirement for qvm-* to 3.5
  119. * utils: include management_dispvm property when checking where VM is
  120. used
  121. * backup: Do not try to attach devices during backup verification
  122. * tools/qvm-backup: allow to disable compression
  123. * events: simplify handling qubesd reconnect
  124. * vm: add run_with_args method to call a single command with specific
  125. arguments
  126. * tests: vm.run, vm.run_with_args
  127. * tools/qvm-start: use vm.run_with_args to call losetup in the VM
  128. * tools/qvm-start: validate output of losetup command
  129. * Make vm.run_with_args working on python2
  130. * Make pylint happy
  131. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
  132. qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
  133. * tools/qvm-run: make -q affect 'command failed with code' message
  134. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
  135. qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
  136. [ Marek Marczykowski-Górecki ]
  137. * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
  138. * Remove useless 'pass' to make pylint happy
  139. * backup: simplify test expressions to make pylint happy
  140. [ GammaSQ ]
  141. * get_label now accepts integer and has correct return-type
  142. * forgot braces
  143. * reverted to comparing .index
  144. * forgot braces
  145. * isinstance instead of type
  146. * added --standalone and --disp shortcuts
  147. * diff doesn't set template
  148. * added tests for shortcuts
  149. * Documentation is important! Added shortcuts to manpages
  150. * Fixed typo in documentation
  151. [ Marek Marczykowski-Górecki ]
  152. * tests/tools: extend vm.run_service() mockup
  153. * tests/tools: improve qvm-run tests
  154. * tools: fix qvm-run --pass-io --localcmd=... vmname command
  155. * tools/qvm-run: handle Ctrl+C nicely
  156. * tools/qvm-run: factor out print_no_color function
  157. * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
  158. * tools/qvm-run: add error message if command in VM failed
  159. * tools/qvm-device: allow detaching all devices
  160. * doc: add 'permissive' PCI device option and 'mic' device class
  161. * Clone VM's volume into the same pool, unless overridden specifically
  162. * tools: remove extra debug
  163. * tools/qvm-create: reject --root-{move,copy}-from with template-based
  164. qubes
  165. * tools/qvm-run: factor out actual process running into separate
  166. function
  167. * doc: improve qvm-device man page
  168. * doc: fix rst syntax in documentation, including docstrings
  169. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
  170. qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
  171. [ Patrik Hagara ]
  172. * qvm-ls: add filtering by domain power state
  173. [ Marek Marczykowski-Górecki ]
  174. * app: add option to ignore select volumes on app.clone_vm()
  175. * tools/qvm-create: properly create template-based StandaloneVM
  176. * tools/qvm-create: fix handling invalid label
  177. * Copy application menu on VM clone
  178. * Code style fix
  179. * tools: clarify qvm-service --help
  180. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
  181. qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
  182. [ Marek Marczykowski-Górecki ]
  183. * Move pylint config to canonical place
  184. * devices: add DeviceInfo.devclass attribute
  185. [ AJ Jordan ]
  186. * Fix typo
  187. [ jimtahu ]
  188. * Exclude installed_by_rpm when Restoring VM from Backup
  189. [ Marek Marczykowski-Górecki ]
  190. * devices: drop DeviceInfo.options
  191. * events: deserialize DeviceInfo class in device-* events
  192. * devices: include devclass when comparing devices
  193. * events: try reconnecting to qubesd also on BrokenPipeError
  194. * rpm: fix building on fc29
  195. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
  196. qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
  197. [ Marek Marczykowski-Górecki ]
  198. * Adjust shell input for Windows shell, for qvm-run tool
  199. * travis: install python-docutils in separate step
  200. [ Patrik Hagara ]
  201. * qvm-ls: add filtering by tags
  202. [ Marek Marczykowski-Górecki ]
  203. * tools/qvm-create: resize root volume if needed before imporing data
  204. * events: add support for wildcard event handlers
  205. * events: fix reconnecting to qubesd on its restart
  206. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
  207. qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
  208. [ Marek Marczykowski-Górecki ]
  209. * app: fix error reporting when connection to qubesd fails
  210. * tools/qvm-start-gui: do not crash on qubesd restart
  211. * Fixes for pylint 2.0
  212. [ Marta Marczykowska-Górecka ]
  213. * Deleted a duplicate man qvm-services entry
  214. [ Marek Marczykowski-Górecki ]
  215. * qvm-start-gui: fix handlign rpc-clipboard feature
  216. * Add 'gui-emulated' feature
  217. * doc: add info what properties are inherited from template
  218. * backup: avoid deadlock on logging during restore
  219. * doc: add linux-stubdom feature to man qvm-features
  220. [ Marta Marczykowska-Górecka ]
  221. * Helper function that lists where a given VM is used
  222. * Added tests and minor correction to vm_usage helper function
  223. * Name change of vm dependencies helper function
  224. * Better information on error in qvm-remove
  225. * Added test for qvm-remove dependency reporting
  226. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
  227. qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
  228. [ Peter Gerber ]
  229. * tools/qvm-firewall: Describe available rules in --help output
  230. [ Marek Marczykowski-Górecki ]
  231. * tools/qvm-firewall: add 'expire' rule support
  232. * tools/qvm-firewall: make 'list' a default action
  233. [ Peter Gerber ]
  234. * tools/qvm-firewall: Show EXPIRE column in list output
  235. * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
  236. * .gitignore: add doc/_build/
  237. * tools/qvm-firewall: improve manpage and --help output
  238. [ Marek Marczykowski-Górecki ]
  239. * Fix reporting events even if its source is not available anymore
  240. * tools: don't fail qvm-template-postprocess on shutdown race
  241. condition
  242. [ jimtahu ]
  243. * Change "None" to Property None
  244. * Change "None" in qvm_prefs
  245. * Add test of qvm_prefs for specal case "None"
  246. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
  247. qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
  248. [ Frédéric Pierret ]
  249. * Create .spec.in and Source0
  250. * Remove _builddir and useless condition on qubes_builder
  251. * doc: handle release definition when not being in a git repository
  252. * spec.in: add changelog placeholder
  253. [ Marek Marczykowski-Górecki ]
  254. * tools: fix error reporing on unknown storage pool
  255. * tools/qvm-pool: add --set to modify pool properties
  256. * doc: adjust example in qvm-pool man page
  257. * Add 'make clean' target, use it for Debian build
  258. * tools/qvm-ls: add --kernel option for compatibility with R3.2
  259. * tools/qvm-template-postprocess: fix reinstall action
  260. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
  261. qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
  262. * doc: typos
  263. * doc: fix module index generation
  264. * storage: add 'rw' and 'revision_to_keep' setters
  265. * qvm-volume: add 'info' and 'config' actions
  266. * storage: make Pool.{size,usage} integers
  267. * doc: update qvm-volume parameters
  268. * qvm-volume: refuse to shrink volume unless --force option is used
  269. * tools: add SubParsersHelpAction, which include subcommands details
  270. in --help
  271. * tools: suppress full traceback in console tools
  272. * qvm-template-postprocess: resize volume only when needed
  273. * qvm-template-postprocess: do not remove VM on failed reinstall
  274. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
  275. qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
  276. [ Marek Marczykowski-Górecki ]
  277. * doc: add 'pci-e820-host' feature description
  278. [ Rusty Bird ]
  279. * qvm-backup-restore: remove orphaned --replace-template option
  280. * qvm-backup-restore: really pass options
  281. * qvm-backup: let backup core handle default VM selection
  282. * restore.py: don't try to restore dispid property
  283. * restore.py: sort into three tiers in _templates_first()
  284. * restore.py: deal with DispVM templates
  285. * restore.py: factor out _restore_property() helper
  286. * restory.py: restore template_for_dispvms property early
  287. * restore.py: add template-related debug log messages
  288. [ Frédéric Pierret ]
  289. * Add support for python34-sphinx: package is provided in Qubes
  290. repository
  291. [ Marek Marczykowski-Górecki ]
  292. * tools: terminate qvm-start-gui when X server is terminated
  293. [ Rusty Bird ]
  294. * qvm-backup-restore: also handle absent --ignore-missing
  295. [ Marek Marczykowski-Górecki ]
  296. * qvm-template-postprocess: call fstrim after removing image file
  297. * tools/qvm-prefs: fix printing None value
  298. * tests: add tests for various 'qvm-prefs vm pref' cases
  299. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
  300. qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
  301. [ Marek Marczykowski-Górecki ]
  302. * vm: restore force_shutdown->kill deprecated alias
  303. [ Christopher Laprise ]
  304. * Fix AdminVm class name
  305. * Fix dom0 handling
  306. * Fix dom0 restore
  307. * style issues
  308. * unused variable
  309. [ Marek Marczykowski-Górecki ]
  310. * backup: skip dom0's properties while restoring core2 backup
  311. * backup: add support for openssl 1.1.0 options
  312. * tests: dom0 backup restore, both v3 and v4
  313. * backup: don't crash when no 'qubes' group is present
  314. [ Rusty Bird ]
  315. * template-postprocess: fast path for file-reflink, like file
  316. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
  317. qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
  318. [ Christopher Laprise ]
  319. * Fix dom0-related issues
  320. [ Marek Marczykowski-Górecki ]
  321. * backup: make pylint happy
  322. * Make pylint happy
  323. * tools/qvm-ls: fix handling columns with underscore
  324. * backup: restore Qubes 3.x VMs as HVMs
  325. * doc: update qvm-features documentation
  326. [ Christopher Laprise ]
  327. * Add --yes option and confirm prompt.
  328. * Fix error message grammar
  329. * Toggle installed_by_rpm in template tool
  330. * Use --force instead of --yes
  331. * Print vm list before prompt
  332. * Avoid cloning installed_by_rpm
  333. * Add --force to manpage.
  334. * Fix style else-return
  335. [ Marek Marczykowski-Górecki ]
  336. * tests: update qvm-template-process and qvm-remove tests
  337. * add QubesVM.connected_vms attribute
  338. [ Rusty Bird ]
  339. * qvm-device/block: Alias '--ro' to '--option read-only=yes'
  340. * qvm-device.rst: Document '--ro' option
  341. [ Marek Marczykowski-Górecki ]
  342. * doc: add info about specific qvm-device cases
  343. * storage: add volume.is_outdated() function
  344. * tools/qvm-start: add naive waiting for cdrom device
  345. * tools: fix handling optional domain list
  346. * tools/qvm-ls: allow list only selected VMs
  347. * tools/qvm-ls: add --raw-list option for compatibility with R3.2
  348. * tools/qvm-ls: add --network and --disk compatibility options
  349. * tools/qvm-ls: clarify that disk usage is in percents
  350. * base: make WrapperObjectsCollection behave like a dict
  351. * rpm,deb: add missing python lxml dependency
  352. * Add property_get_default method
  353. * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
  354. [ Rusty Bird ]
  355. * qvm-run: wait for X11 in --dispvm --gui case
  356. [ Marek Marczykowski-Górecki ]
  357. * storage: add size and usage properties
  358. * backup/restore: do not shrink volumes on restore
  359. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
  360. qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
  361. [ Jean-Philippe Ouellet ]
  362. * Stop leaking terminal escapes via stderr
  363. [ Marek Marczykowski-Górecki ]
  364. * tests: Update tests after fix for filtering stderr
  365. [ Jean-Philippe Ouellet ]
  366. * Fix qvm-ls --raw-data
  367. * Disable spinner if --raw-data
  368. * Remove dead code
  369. [ qubesuser ]
  370. * don't lookup list of labels just to read VM properties
  371. * don't use ast.literal_eval, just directly convert to the desired
  372. type
  373. [ Marek Marczykowski-Górecki ]
  374. * tests: make filter-esc tests working also on travis
  375. * tests: fix tests after dropping unnecessary admin.label.List call
  376. [ Christopher Laprise ]
  377. * Issue #3303
  378. * Fix verify-only
  379. * verify-only avoid dom0 handler
  380. [ Marek Marczykowski-Górecki ]
  381. * tests: update tests for fixed verify_only handling
  382. * make qvm-shutdown nice for unit tests
  383. * Make pylint happy
  384. * Another approach for making qvm-shutdown nice for tests
  385. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
  386. qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
  387. [ qubesuser ]
  388. * remove format_doc and docutils import
  389. * don't import pkg_resources in the top of qubesadmin/utils.py
  390. * replace console entry points with just importing the module
  391. * replace key in dir(self) with faster and better code
  392. [ Jean-Philippe Ouellet ]
  393. * Fix setting stderr default coloring policy
  394. * Restore correct colors in verbose mode
  395. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
  396. qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
  397. [ Marek Marczykowski-Górecki ]
  398. * Document device attach options in man page
  399. * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
  400. * backup: fix handling labels in Qubes 4.0 backups
  401. [ qubesuser ]
  402. * make qvm-run work for non-blocking stdin
  403. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
  404. qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
  405. [ Frédéric Pierret ]
  406. * Add CentOS support and fix python3 dependencies for CentOS (except
  407. python3-sphinx and python3-daemon which has no python34 package)
  408. [ Marek Marczykowski-Górecki ]
  409. * Fix DeviceInfo objects comparing
  410. * vm: fix handling policy deny on admin.vm.List
  411. * Drop log.DBusHandler
  412. * backup: improve migrating templates from Qubes 3.x
  413. * tools: fix handling qvm-run --no-autostart
  414. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
  415. qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
  416. * backup: fix restoring template VMs
  417. * tools: clarify that qvm-backup needs absolute path
  418. * backup: fix name of meminfo-writer feature
  419. * backup: update DispVM template property: template_for_dispvms
  420. * backup: improve restoring HVMs from Qubes 3.2
  421. * backup: do not try to read tar's stderr past EOF
  422. * tests: multi-part volume in backup tests
  423. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
  424. qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
  425. [ Marek Marczykowski-Górecki ]
  426. * Implement "blind mode" to avoid listing objects
  427. * events: ignore events from non-existing domains
  428. * tools: fix qvm-run --help
  429. * Always use QubesVM objects, instead of AppVM/TemplateVM etc
  430. * Move vm.appvms to QubesVM
  431. * Drop individual VM classes as python types completely
  432. * tools: finish 'qvm-volume revert' implementation, add tests
  433. * tools/qvm-start: fix starting a VM with cdrom image
  434. * vm: drop suspend and resume methods - not part of the Admin API
  435. * rpm: add conflict with too-old qubes-manager
  436. [ Mindy Preston ]
  437. * qvm-start: exit if domain running and no --skip-if-running
  438. [ Marek Marczykowski-Górecki ]
  439. * tools: adjust qvm-start message and logic, update tests
  440. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
  441. qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
  442. [ Marek Marczykowski-Górecki ]
  443. * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
  444. is given
  445. * vm/dispvm: fix dispvm.cleanup() when no service was called
  446. * tests: add DispVM tests
  447. * Improve QubesDaemonNoResponseError error message
  448. * tools: drop --delete and --unset aliases for --default option
  449. * doc: update list of properties in qvm-prefs/qubes-prefs man pages
  450. * doc: add short description of VM classes to qvm-create man page
  451. * tools: implement qvm-create --root-move-from/--root-copy-from
  452. * tools: add qvm-create --help-classes
  453. * backup/restore: make backup header extraction faster
  454. * backup/restore: do not fail the whole restore when qvm-appmenus is
  455. missing
  456. [ blackpit ]
  457. * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
  458. [ Marek Marczykowski-Górecki ]
  459. * tools: fix too long lines
  460. * tools: cleanup temporary files after qvm-template-postprocess
  461. * devices: client stub for DeviceCollection.update_persistent
  462. * tools: restore qvm-start --cdrom and similar options
  463. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
  464. qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
  465. * tools/qvm-run: fix handling small data blocks
  466. * vm: add DispVMWrapper for calling a single service in new DispVM
  467. * tools: add qvm-run --dispvm option
  468. * doc: list known features in qvm-features manual page
  469. * app: add VMCollection.values()
  470. * tools/qvm-run: do not use os.set_blocking
  471. * tools/qvm-device: list attach options
  472. * doc: add default values to qvm-features man page
  473. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
  474. qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
  475. * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
  476. agent
  477. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
  478. qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
  479. * tools/qvm-backup-restore: fix default list of VMs to restore
  480. * storage: drop 'internal' volume property
  481. * tools/qvm-volume: fix default action handling
  482. * tests: qvm-backup-restore tool tests
  483. * tools/qvm-backup-restore: fix restoring only specific VMs
  484. * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
  485. * backup: move BackupRestore class and helpers to 'restore' submodule
  486. * tools: add qvm-backup tool
  487. * debian: update build depends
  488. * doc: update qvm-backup man page
  489. * backup/restore: improve error reporting
  490. * backup/restore: add option to ignore size limit
  491. * events: add variable Admin API method name
  492. * tools/qvm-shutdown: drop --force option, it isn't supported anymore
  493. * tools/qvm-shutdown: fix help message
  494. * tools/qvm-start-gui: add --force-stubdomain options
  495. * features: serialize True as '1'
  496. * tests: too much copy&paste
  497. * tools: qvm-service tool
  498. * doc: update manpage of qvm-service
  499. * qvm-ls: fix total VM size reporting
  500. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
  501. qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
  502. [ Marek Marczykowski-Górecki ]
  503. * vm: make QubesVM objects hashable
  504. * events: simplify wait_for_domain_shutdown coroutine
  505. * tools: handle shutdown order in qvm-shutdown
  506. * tests/tools: add MockEventsReader
  507. * tests: qvm-shutdown --wait tests
  508. * Fix VM creation with default template
  509. * events: fix cleanup function in qrexec case
  510. * tests: improve test failure message
  511. [ Marta Marczykowska-Górecka ]
  512. * added helper function updates_vms_status
  513. [ Marek Marczykowski-Górecki ]
  514. * tools/qvm-run: fix handling copying stdin to the process
  515. * tests: mark qvm-run tests with "expected failure"
  516. * tools/qvm-run: fix handling EOF
  517. * Make pylint happy
  518. * Don't try to set 'created-by-' tag when cloning VM
  519. * backup: initial support for backup restore over Admin API
  520. * tests/backup: tests for backup-restore code
  521. * Exclude 'qubesadmin.backup' module from python2 install
  522. * devices,features: fix bool values handling
  523. * tests/backup: use smaller images
  524. * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
  525. * backup: add firewall and appmenus list handling
  526. * firewall: fix handling DstHost.prefixlen=0
  527. * tests: backup: add firewall.xml and appmenus checking
  528. * tools: add qvm-backup-restore
  529. * app: call admin.vm.volume.Import as root
  530. * backup: do not show full stacktrace to the user
  531. * backup: change 'hvm' property to 'virt_mode'
  532. * backup: use 'cat' instead of read-write loop in python
  533. * backup: improve error logging
  534. * tools/qvm-backup-restore: handle VMs selection, not only exclusion
  535. * Choose QubesLocal or QubesRemote based on /etc/qubes-release
  536. presence
  537. * Change 'hvm' property to 'virt_mode'
  538. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
  539. qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
  540. *
  541. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
  542. qubes-core-admin-client (4.0.0-1) unstable; urgency=low
  543. * Initial release
  544. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200