123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647 |
- qubes-core-admin-client (4.1.0-1) unstable; urgency=medium
- [ Frédéric Pierret (fepitre) ]
- * devices: make PEP8 happy
- * devices: handle listing of available device classes
- * tests/devices: make PEP8 happy
- * tests/devices: add test for handling listing device classes
- * tools/qvm-device: make PEP8 happy
- * devices: make iteration device classes compatible with Python2
- * devices: add missing docstring for _get_device_classes
- * qvm-check: refactor check mechanism and add filter for checking
- netvm
- * qvm-check: fix from Marek's comment
- [ hexagonrecursion ]
- * Fix a pref name in the qvm-prefs man page
- * Clarify the network-manager qubes service default
- * Correct network-manager qubes service default
- [ Frédéric Pierret (fepitre) ]
- * qubesadmin: make PEP8 happy
- * qubesadmin: define methods list_vmclass and list_devicesclass
- * qvm-device: handle 'list-device-classes' and 'list-classes'
- * qvm-device: prevent parser allowing abbreviations
- * qvm-device: add manpage entry
- [ Marek Marczykowski-Górecki ]
- * backup/restore: reject uncommon compression filters and improve
- header validation
- * backup/restore: add option to use uncommon compression filter anyway
- * tests: check rejecting/accepting compression filters
- * backup/restore: make pylint happy
- [ Frédéric Pierret (fepitre) ]
- * Fix Sphinx 2 new API for Fedora 31+
- * dochelpers: handle legacy sphinx library
- * dochelpers: make PEP8 happier
- [ Marta Marczykowska-Górecka ]
- * Fixed error with VM being incorrectly listed as its own dependency
- [ Marek Marczykowski-Górecki ]
- * rpm: fix release number
- * Add support for run_service(..., filter_esc=True) in a VM
- * Add run_service(..., autostart=False) argument
- * tools/qvm-start-gui: avoid starting a VM just to send it monitor
- layout
- * Make pylint happy
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 09 Oct 2019 05:48:48 +0200
- qubes-core-admin-client (4.0.26-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * doc: typo fix
- [ anadahz ]
- * Remove policy option from man page
- [ Marek Marczykowski-Górecki ]
- * tests: update yaml syntax in qvm-backup tests
- [ Conor Schaefer ]
- * Adds support for `--ignore-errors` to qvm-clone CLI
- * Adds docs for clone ignore_errors, feeds linter
- [ Malte Leip ]
- * qvm-prefs: add --hide-default option
- [ Marek Marczykowski-Górecki ]
- * travis: switch to xenial, update distributions
- [ unman ]
- * Remove unnecessary comma in qvm-backup.rst
- [ Marek Marczykowski-Górecki ]
- * Allow app.domains[vm] where vm is a QubesVM object
- * travis: drop python 3.4, add python 3.6 and 3.7
- * tests: fix events tests on python3.7
- * tools: reset private volume when importing template over existing
- one
- * tools/qvm-volume: add 'import' action
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 30 Jul 2019 16:29:31 +0200
- qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * doc: update meminfo-writer service note
- [ GammaSQ ]
- * fixed typo
- [ Marek Marczykowski-Górecki ]
- * rpm: unify fedora and centos packaging
- * rpm: add R: python3-yaml, as needed by qvm-backup tool
- * backup: do not fail restore if scrypt anticipate more time needed
- * tools/qvm-run: do not color the output unless --pass-io is used
- * Bump Python version requirement for qvm-* to 3.5
- * utils: include management_dispvm property when checking where VM is
- used
- * backup: Do not try to attach devices during backup verification
- * tools/qvm-backup: allow to disable compression
- * events: simplify handling qubesd reconnect
- * vm: add run_with_args method to call a single command with specific
- arguments
- * tests: vm.run, vm.run_with_args
- * tools/qvm-start: use vm.run_with_args to call losetup in the VM
- * tools/qvm-start: validate output of losetup command
- * Make vm.run_with_args working on python2
- * Make pylint happy
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
- qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
- * tools/qvm-run: make -q affect 'command failed with code' message
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
- qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
- * Remove useless 'pass' to make pylint happy
- * backup: simplify test expressions to make pylint happy
- [ GammaSQ ]
- * get_label now accepts integer and has correct return-type
- * forgot braces
- * reverted to comparing .index
- * forgot braces
- * isinstance instead of type
- * added --standalone and --disp shortcuts
- * diff doesn't set template
- * added tests for shortcuts
- * Documentation is important! Added shortcuts to manpages
- * Fixed typo in documentation
- [ Marek Marczykowski-Górecki ]
- * tests/tools: extend vm.run_service() mockup
- * tests/tools: improve qvm-run tests
- * tools: fix qvm-run --pass-io --localcmd=... vmname command
- * tools/qvm-run: handle Ctrl+C nicely
- * tools/qvm-run: factor out print_no_color function
- * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
- * tools/qvm-run: add error message if command in VM failed
- * tools/qvm-device: allow detaching all devices
- * doc: add 'permissive' PCI device option and 'mic' device class
- * Clone VM's volume into the same pool, unless overridden specifically
- * tools: remove extra debug
- * tools/qvm-create: reject --root-{move,copy}-from with template-based
- qubes
- * tools/qvm-run: factor out actual process running into separate
- function
- * doc: improve qvm-device man page
- * doc: fix rst syntax in documentation, including docstrings
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
- qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
- [ Patrik Hagara ]
- * qvm-ls: add filtering by domain power state
- [ Marek Marczykowski-Górecki ]
- * app: add option to ignore select volumes on app.clone_vm()
- * tools/qvm-create: properly create template-based StandaloneVM
- * tools/qvm-create: fix handling invalid label
- * Copy application menu on VM clone
- * Code style fix
- * tools: clarify qvm-service --help
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
- qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * Move pylint config to canonical place
- * devices: add DeviceInfo.devclass attribute
- [ AJ Jordan ]
- * Fix typo
- [ jimtahu ]
- * Exclude installed_by_rpm when Restoring VM from Backup
- [ Marek Marczykowski-Górecki ]
- * devices: drop DeviceInfo.options
- * events: deserialize DeviceInfo class in device-* events
- * devices: include devclass when comparing devices
- * events: try reconnecting to qubesd also on BrokenPipeError
- * rpm: fix building on fc29
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
- qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * Adjust shell input for Windows shell, for qvm-run tool
- * travis: install python-docutils in separate step
- [ Patrik Hagara ]
- * qvm-ls: add filtering by tags
- [ Marek Marczykowski-Górecki ]
- * tools/qvm-create: resize root volume if needed before imporing data
- * events: add support for wildcard event handlers
- * events: fix reconnecting to qubesd on its restart
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
- qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * app: fix error reporting when connection to qubesd fails
- * tools/qvm-start-gui: do not crash on qubesd restart
- * Fixes for pylint 2.0
- [ Marta Marczykowska-Górecka ]
- * Deleted a duplicate man qvm-services entry
- [ Marek Marczykowski-Górecki ]
- * qvm-start-gui: fix handlign rpc-clipboard feature
- * Add 'gui-emulated' feature
- * doc: add info what properties are inherited from template
- * backup: avoid deadlock on logging during restore
- * doc: add linux-stubdom feature to man qvm-features
- [ Marta Marczykowska-Górecka ]
- * Helper function that lists where a given VM is used
- * Added tests and minor correction to vm_usage helper function
- * Name change of vm dependencies helper function
- * Better information on error in qvm-remove
- * Added test for qvm-remove dependency reporting
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
- qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
- [ Peter Gerber ]
- * tools/qvm-firewall: Describe available rules in --help output
- [ Marek Marczykowski-Górecki ]
- * tools/qvm-firewall: add 'expire' rule support
- * tools/qvm-firewall: make 'list' a default action
- [ Peter Gerber ]
- * tools/qvm-firewall: Show EXPIRE column in list output
- * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
- * .gitignore: add doc/_build/
- * tools/qvm-firewall: improve manpage and --help output
- [ Marek Marczykowski-Górecki ]
- * Fix reporting events even if its source is not available anymore
- * tools: don't fail qvm-template-postprocess on shutdown race
- condition
- [ jimtahu ]
- * Change "None" to Property None
- * Change "None" in qvm_prefs
- * Add test of qvm_prefs for specal case "None"
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
- qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
- [ Frédéric Pierret ]
- * Create .spec.in and Source0
- * Remove _builddir and useless condition on qubes_builder
- * doc: handle release definition when not being in a git repository
- * spec.in: add changelog placeholder
- [ Marek Marczykowski-Górecki ]
- * tools: fix error reporing on unknown storage pool
- * tools/qvm-pool: add --set to modify pool properties
- * doc: adjust example in qvm-pool man page
- * Add 'make clean' target, use it for Debian build
- * tools/qvm-ls: add --kernel option for compatibility with R3.2
- * tools/qvm-template-postprocess: fix reinstall action
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
- qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
- * doc: typos
- * doc: fix module index generation
- * storage: add 'rw' and 'revision_to_keep' setters
- * qvm-volume: add 'info' and 'config' actions
- * storage: make Pool.{size,usage} integers
- * doc: update qvm-volume parameters
- * qvm-volume: refuse to shrink volume unless --force option is used
- * tools: add SubParsersHelpAction, which include subcommands details
- in --help
- * tools: suppress full traceback in console tools
- * qvm-template-postprocess: resize volume only when needed
- * qvm-template-postprocess: do not remove VM on failed reinstall
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
- qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * doc: add 'pci-e820-host' feature description
- [ Rusty Bird ]
- * qvm-backup-restore: remove orphaned --replace-template option
- * qvm-backup-restore: really pass options
- * qvm-backup: let backup core handle default VM selection
- * restore.py: don't try to restore dispid property
- * restore.py: sort into three tiers in _templates_first()
- * restore.py: deal with DispVM templates
- * restore.py: factor out _restore_property() helper
- * restory.py: restore template_for_dispvms property early
- * restore.py: add template-related debug log messages
- [ Frédéric Pierret ]
- * Add support for python34-sphinx: package is provided in Qubes
- repository
- [ Marek Marczykowski-Górecki ]
- * tools: terminate qvm-start-gui when X server is terminated
- [ Rusty Bird ]
- * qvm-backup-restore: also handle absent --ignore-missing
- [ Marek Marczykowski-Górecki ]
- * qvm-template-postprocess: call fstrim after removing image file
- * tools/qvm-prefs: fix printing None value
- * tests: add tests for various 'qvm-prefs vm pref' cases
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
- qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * vm: restore force_shutdown->kill deprecated alias
- [ Christopher Laprise ]
- * Fix AdminVm class name
- * Fix dom0 handling
- * Fix dom0 restore
- * style issues
- * unused variable
- [ Marek Marczykowski-Górecki ]
- * backup: skip dom0's properties while restoring core2 backup
- * backup: add support for openssl 1.1.0 options
- * tests: dom0 backup restore, both v3 and v4
- * backup: don't crash when no 'qubes' group is present
- [ Rusty Bird ]
- * template-postprocess: fast path for file-reflink, like file
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
- qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
- [ Christopher Laprise ]
- * Fix dom0-related issues
- [ Marek Marczykowski-Górecki ]
- * backup: make pylint happy
- * Make pylint happy
- * tools/qvm-ls: fix handling columns with underscore
- * backup: restore Qubes 3.x VMs as HVMs
- * doc: update qvm-features documentation
- [ Christopher Laprise ]
- * Add --yes option and confirm prompt.
- * Fix error message grammar
- * Toggle installed_by_rpm in template tool
- * Use --force instead of --yes
- * Print vm list before prompt
- * Avoid cloning installed_by_rpm
- * Add --force to manpage.
- * Fix style else-return
- [ Marek Marczykowski-Górecki ]
- * tests: update qvm-template-process and qvm-remove tests
- * add QubesVM.connected_vms attribute
- [ Rusty Bird ]
- * qvm-device/block: Alias '--ro' to '--option read-only=yes'
- * qvm-device.rst: Document '--ro' option
- [ Marek Marczykowski-Górecki ]
- * doc: add info about specific qvm-device cases
- * storage: add volume.is_outdated() function
- * tools/qvm-start: add naive waiting for cdrom device
- * tools: fix handling optional domain list
- * tools/qvm-ls: allow list only selected VMs
- * tools/qvm-ls: add --raw-list option for compatibility with R3.2
- * tools/qvm-ls: add --network and --disk compatibility options
- * tools/qvm-ls: clarify that disk usage is in percents
- * base: make WrapperObjectsCollection behave like a dict
- * rpm,deb: add missing python lxml dependency
- * Add property_get_default method
- * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
- [ Rusty Bird ]
- * qvm-run: wait for X11 in --dispvm --gui case
- [ Marek Marczykowski-Górecki ]
- * storage: add size and usage properties
- * backup/restore: do not shrink volumes on restore
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
- qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
- [ Jean-Philippe Ouellet ]
- * Stop leaking terminal escapes via stderr
- [ Marek Marczykowski-Górecki ]
- * tests: Update tests after fix for filtering stderr
- [ Jean-Philippe Ouellet ]
- * Fix qvm-ls --raw-data
- * Disable spinner if --raw-data
- * Remove dead code
- [ qubesuser ]
- * don't lookup list of labels just to read VM properties
- * don't use ast.literal_eval, just directly convert to the desired
- type
- [ Marek Marczykowski-Górecki ]
- * tests: make filter-esc tests working also on travis
- * tests: fix tests after dropping unnecessary admin.label.List call
- [ Christopher Laprise ]
- * Issue #3303
- * Fix verify-only
- * verify-only avoid dom0 handler
- [ Marek Marczykowski-Górecki ]
- * tests: update tests for fixed verify_only handling
- * make qvm-shutdown nice for unit tests
- * Make pylint happy
- * Another approach for making qvm-shutdown nice for tests
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
- qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
- [ qubesuser ]
- * remove format_doc and docutils import
- * don't import pkg_resources in the top of qubesadmin/utils.py
- * replace console entry points with just importing the module
- * replace key in dir(self) with faster and better code
- [ Jean-Philippe Ouellet ]
- * Fix setting stderr default coloring policy
- * Restore correct colors in verbose mode
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
- qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * Document device attach options in man page
- * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
- * backup: fix handling labels in Qubes 4.0 backups
- [ qubesuser ]
- * make qvm-run work for non-blocking stdin
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
- qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
- [ Frédéric Pierret ]
- * Add CentOS support and fix python3 dependencies for CentOS (except
- python3-sphinx and python3-daemon which has no python34 package)
- [ Marek Marczykowski-Górecki ]
- * Fix DeviceInfo objects comparing
- * vm: fix handling policy deny on admin.vm.List
- * Drop log.DBusHandler
- * backup: improve migrating templates from Qubes 3.x
- * tools: fix handling qvm-run --no-autostart
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
- qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
- * backup: fix restoring template VMs
- * tools: clarify that qvm-backup needs absolute path
- * backup: fix name of meminfo-writer feature
- * backup: update DispVM template property: template_for_dispvms
- * backup: improve restoring HVMs from Qubes 3.2
- * backup: do not try to read tar's stderr past EOF
- * tests: multi-part volume in backup tests
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
- qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * Implement "blind mode" to avoid listing objects
- * events: ignore events from non-existing domains
- * tools: fix qvm-run --help
- * Always use QubesVM objects, instead of AppVM/TemplateVM etc
- * Move vm.appvms to QubesVM
- * Drop individual VM classes as python types completely
- * tools: finish 'qvm-volume revert' implementation, add tests
- * tools/qvm-start: fix starting a VM with cdrom image
- * vm: drop suspend and resume methods - not part of the Admin API
- * rpm: add conflict with too-old qubes-manager
- [ Mindy Preston ]
- * qvm-start: exit if domain running and no --skip-if-running
- [ Marek Marczykowski-Górecki ]
- * tools: adjust qvm-start message and logic, update tests
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
- qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
- is given
- * vm/dispvm: fix dispvm.cleanup() when no service was called
- * tests: add DispVM tests
- * Improve QubesDaemonNoResponseError error message
- * tools: drop --delete and --unset aliases for --default option
- * doc: update list of properties in qvm-prefs/qubes-prefs man pages
- * doc: add short description of VM classes to qvm-create man page
- * tools: implement qvm-create --root-move-from/--root-copy-from
- * tools: add qvm-create --help-classes
- * backup/restore: make backup header extraction faster
- * backup/restore: do not fail the whole restore when qvm-appmenus is
- missing
- [ blackpit ]
- * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
- [ Marek Marczykowski-Górecki ]
- * tools: fix too long lines
- * tools: cleanup temporary files after qvm-template-postprocess
- * devices: client stub for DeviceCollection.update_persistent
- * tools: restore qvm-start --cdrom and similar options
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
- qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
- * tools/qvm-run: fix handling small data blocks
- * vm: add DispVMWrapper for calling a single service in new DispVM
- * tools: add qvm-run --dispvm option
- * doc: list known features in qvm-features manual page
- * app: add VMCollection.values()
- * tools/qvm-run: do not use os.set_blocking
- * tools/qvm-device: list attach options
- * doc: add default values to qvm-features man page
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
- qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
- * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
- agent
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
- qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
- * tools/qvm-backup-restore: fix default list of VMs to restore
- * storage: drop 'internal' volume property
- * tools/qvm-volume: fix default action handling
- * tests: qvm-backup-restore tool tests
- * tools/qvm-backup-restore: fix restoring only specific VMs
- * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
- * backup: move BackupRestore class and helpers to 'restore' submodule
- * tools: add qvm-backup tool
- * debian: update build depends
- * doc: update qvm-backup man page
- * backup/restore: improve error reporting
- * backup/restore: add option to ignore size limit
- * events: add variable Admin API method name
- * tools/qvm-shutdown: drop --force option, it isn't supported anymore
- * tools/qvm-shutdown: fix help message
- * tools/qvm-start-gui: add --force-stubdomain options
- * features: serialize True as '1'
- * tests: too much copy&paste
- * tools: qvm-service tool
- * doc: update manpage of qvm-service
- * qvm-ls: fix total VM size reporting
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
- qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
- [ Marek Marczykowski-Górecki ]
- * vm: make QubesVM objects hashable
- * events: simplify wait_for_domain_shutdown coroutine
- * tools: handle shutdown order in qvm-shutdown
- * tests/tools: add MockEventsReader
- * tests: qvm-shutdown --wait tests
- * Fix VM creation with default template
- * events: fix cleanup function in qrexec case
- * tests: improve test failure message
- [ Marta Marczykowska-Górecka ]
- * added helper function updates_vms_status
- [ Marek Marczykowski-Górecki ]
- * tools/qvm-run: fix handling copying stdin to the process
- * tests: mark qvm-run tests with "expected failure"
- * tools/qvm-run: fix handling EOF
- * Make pylint happy
- * Don't try to set 'created-by-' tag when cloning VM
- * backup: initial support for backup restore over Admin API
- * tests/backup: tests for backup-restore code
- * Exclude 'qubesadmin.backup' module from python2 install
- * devices,features: fix bool values handling
- * tests/backup: use smaller images
- * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
- * backup: add firewall and appmenus list handling
- * firewall: fix handling DstHost.prefixlen=0
- * tests: backup: add firewall.xml and appmenus checking
- * tools: add qvm-backup-restore
- * app: call admin.vm.volume.Import as root
- * backup: do not show full stacktrace to the user
- * backup: change 'hvm' property to 'virt_mode'
- * backup: use 'cat' instead of read-write loop in python
- * backup: improve error logging
- * tools/qvm-backup-restore: handle VMs selection, not only exclusion
- * Choose QubesLocal or QubesRemote based on /etc/qubes-release
- presence
- * Change 'hvm' property to 'virt_mode'
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
- qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
- *
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
- qubes-core-admin-client (4.0.0-1) unstable; urgency=low
- * Initial release
- -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200
|