changelog 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733
  1. qubes-core-admin-client (4.1.4-1) unstable; urgency=medium
  2. * debian: really drop python2 build
  3. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 27 Jan 2020 22:58:58 +0100
  4. qubes-core-admin-client (4.1.3-1) unstable; urgency=medium
  5. [ Marta Marczykowska-Górecka ]
  6. * Fixed Exceptions inferiting from KeyError
  7. [ Marek Marczykowski-Górecki ]
  8. * Drop Python2 support
  9. [ tetrahedras ]
  10. * add --wait documentation for qvm-shutdown
  11. [ Pawel Marczewski ]
  12. * qvm-ls: don't exclude dom0 when using --all
  13. * Add test for qvm-ls --all
  14. * Use admin.vm.CurrentState method for power state and memory
  15. * qvm-ls: display memory as integer number
  16. * Update tests to mock admin.vm.CurrentState
  17. * Add a test for vm.get_mem()
  18. * Add missing docstrings
  19. * qvm-shutdown: report errors, don't crash on DispVMs
  20. * qvm-remove: improve error message
  21. * Import data using ImportWithSize call, not manual resizing
  22. * qvm-run: use qubes.VMExec, if available
  23. * Document the new behaviour of qvm-run with arguments
  24. * Use qubes.VMExec in run_with_args()
  25. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 27 Jan 2020 19:33:19 +0100
  26. qubes-core-admin-client (4.1.2-1) unstable; urgency=medium
  27. [ Marta Marczykowska-Górecka ]
  28. * Fixed overeager assert
  29. * Fixed metadata usage being served as strings
  30. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 30 Nov 2019 05:12:01 +0100
  31. qubes-core-admin-client (4.1.1-1) unstable; urgency=medium
  32. [ Frédéric Pierret (fepitre) ]
  33. * travis: switch to bionic
  34. * Make PEP8 happier
  35. * qvm-start-gui: handle GuiVM
  36. * guivm: use getattr instead of try/except and direct property access
  37. * qvm-start-gui: simplify log info for start_gui function
  38. * app: fix missing docstring for get_local_name
  39. * app: get_local_name set/from self attribute
  40. * tests: fix with respect to gui properties
  41. * tests: qvm_start_gui: make PEP8 happier
  42. * app: switch get_local_name method to property
  43. [ Marta Marczykowska-Górecka ]
  44. * Fixed error with import
  45. * Added pool.usage_details API method
  46. [ Saswat Padhi ]
  47. * Improvements to qvm-pool argument parser
  48. * Updated tests for qvm-pool
  49. * Fixed a bug and removed unused import
  50. * Added a new test and minor updates to others
  51. * Updated qvm-pool.rst file
  52. * Preserve backward compatibility
  53. [ Rot127 ]
  54. * added feature to list domains as network tree
  55. * network tree manpage entry added
  56. * Sort domains in network tree list
  57. * Add tests for --tree option of qvm-ls
  58. [ Frédéric Pierret (fepitre) ]
  59. * prefs: handle 'none' value for guivm
  60. * utils: handle default_guivm and guivm properties
  61. * utils: make PEP8 happy
  62. * tests: add default_guivm and guivm in utils properties
  63. * tests: make PEP8 and pylint happy
  64. [ Marta Marczykowska-Górecka ]
  65. * Added an exception for backup already in progress
  66. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 13 Nov 2019 05:58:53 +0100
  67. qubes-core-admin-client (4.1.0-1) unstable; urgency=medium
  68. [ Frédéric Pierret (fepitre) ]
  69. * devices: make PEP8 happy
  70. * devices: handle listing of available device classes
  71. * tests/devices: make PEP8 happy
  72. * tests/devices: add test for handling listing device classes
  73. * tools/qvm-device: make PEP8 happy
  74. * devices: make iteration device classes compatible with Python2
  75. * devices: add missing docstring for _get_device_classes
  76. * qvm-check: refactor check mechanism and add filter for checking
  77. netvm
  78. * qvm-check: fix from Marek's comment
  79. [ hexagonrecursion ]
  80. * Fix a pref name in the qvm-prefs man page
  81. * Clarify the network-manager qubes service default
  82. * Correct network-manager qubes service default
  83. [ Frédéric Pierret (fepitre) ]
  84. * qubesadmin: make PEP8 happy
  85. * qubesadmin: define methods list_vmclass and list_devicesclass
  86. * qvm-device: handle 'list-device-classes' and 'list-classes'
  87. * qvm-device: prevent parser allowing abbreviations
  88. * qvm-device: add manpage entry
  89. [ Marek Marczykowski-Górecki ]
  90. * backup/restore: reject uncommon compression filters and improve
  91. header validation
  92. * backup/restore: add option to use uncommon compression filter anyway
  93. * tests: check rejecting/accepting compression filters
  94. * backup/restore: make pylint happy
  95. [ Frédéric Pierret (fepitre) ]
  96. * Fix Sphinx 2 new API for Fedora 31+
  97. * dochelpers: handle legacy sphinx library
  98. * dochelpers: make PEP8 happier
  99. [ Marta Marczykowska-Górecka ]
  100. * Fixed error with VM being incorrectly listed as its own dependency
  101. [ Marek Marczykowski-Górecki ]
  102. * rpm: fix release number
  103. * Add support for run_service(..., filter_esc=True) in a VM
  104. * Add run_service(..., autostart=False) argument
  105. * tools/qvm-start-gui: avoid starting a VM just to send it monitor
  106. layout
  107. * Make pylint happy
  108. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 09 Oct 2019 05:48:48 +0200
  109. qubes-core-admin-client (4.0.26-1) unstable; urgency=medium
  110. [ Marek Marczykowski-Górecki ]
  111. * doc: typo fix
  112. [ anadahz ]
  113. * Remove policy option from man page
  114. [ Marek Marczykowski-Górecki ]
  115. * tests: update yaml syntax in qvm-backup tests
  116. [ Conor Schaefer ]
  117. * Adds support for `--ignore-errors` to qvm-clone CLI
  118. * Adds docs for clone ignore_errors, feeds linter
  119. [ Malte Leip ]
  120. * qvm-prefs: add --hide-default option
  121. [ Marek Marczykowski-Górecki ]
  122. * travis: switch to xenial, update distributions
  123. [ unman ]
  124. * Remove unnecessary comma in qvm-backup.rst
  125. [ Marek Marczykowski-Górecki ]
  126. * Allow app.domains[vm] where vm is a QubesVM object
  127. * travis: drop python 3.4, add python 3.6 and 3.7
  128. * tests: fix events tests on python3.7
  129. * tools: reset private volume when importing template over existing
  130. one
  131. * tools/qvm-volume: add 'import' action
  132. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 30 Jul 2019 16:29:31 +0200
  133. qubes-core-admin-client (4.0.25-1) unstable; urgency=medium
  134. [ Marek Marczykowski-Górecki ]
  135. * doc: update meminfo-writer service note
  136. [ GammaSQ ]
  137. * fixed typo
  138. [ Marek Marczykowski-Górecki ]
  139. * rpm: unify fedora and centos packaging
  140. * rpm: add R: python3-yaml, as needed by qvm-backup tool
  141. * backup: do not fail restore if scrypt anticipate more time needed
  142. * tools/qvm-run: do not color the output unless --pass-io is used
  143. * Bump Python version requirement for qvm-* to 3.5
  144. * utils: include management_dispvm property when checking where VM is
  145. used
  146. * backup: Do not try to attach devices during backup verification
  147. * tools/qvm-backup: allow to disable compression
  148. * events: simplify handling qubesd reconnect
  149. * vm: add run_with_args method to call a single command with specific
  150. arguments
  151. * tests: vm.run, vm.run_with_args
  152. * tools/qvm-start: use vm.run_with_args to call losetup in the VM
  153. * tools/qvm-start: validate output of losetup command
  154. * Make vm.run_with_args working on python2
  155. * Make pylint happy
  156. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 07 Mar 2019 03:58:08 +0100
  157. qubes-core-admin-client (4.0.24-1) unstable; urgency=medium
  158. * tools/qvm-run: make -q affect 'command failed with code' message
  159. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Dec 2018 04:58:21 +0100
  160. qubes-core-admin-client (4.0.23-1) unstable; urgency=medium
  161. [ Marek Marczykowski-Górecki ]
  162. * Clarify QubesBase(), Qubes() and QubesLocal/QubesRemote usage
  163. * Remove useless 'pass' to make pylint happy
  164. * backup: simplify test expressions to make pylint happy
  165. [ GammaSQ ]
  166. * get_label now accepts integer and has correct return-type
  167. * forgot braces
  168. * reverted to comparing .index
  169. * forgot braces
  170. * isinstance instead of type
  171. * added --standalone and --disp shortcuts
  172. * diff doesn't set template
  173. * added tests for shortcuts
  174. * Documentation is important! Added shortcuts to manpages
  175. * Fixed typo in documentation
  176. [ Marek Marczykowski-Górecki ]
  177. * tests/tools: extend vm.run_service() mockup
  178. * tests/tools: improve qvm-run tests
  179. * tools: fix qvm-run --pass-io --localcmd=... vmname command
  180. * tools/qvm-run: handle Ctrl+C nicely
  181. * tools/qvm-run: factor out print_no_color function
  182. * tools/qvm-run: fix error reporting on qvm-run -n on halted qube
  183. * tools/qvm-run: add error message if command in VM failed
  184. * tools/qvm-device: allow detaching all devices
  185. * doc: add 'permissive' PCI device option and 'mic' device class
  186. * Clone VM's volume into the same pool, unless overridden specifically
  187. * tools: remove extra debug
  188. * tools/qvm-create: reject --root-{move,copy}-from with template-based
  189. qubes
  190. * tools/qvm-run: factor out actual process running into separate
  191. function
  192. * doc: improve qvm-device man page
  193. * doc: fix rst syntax in documentation, including docstrings
  194. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 09 Dec 2018 18:33:27 +0100
  195. qubes-core-admin-client (4.0.22-1) unstable; urgency=medium
  196. [ Patrik Hagara ]
  197. * qvm-ls: add filtering by domain power state
  198. [ Marek Marczykowski-Górecki ]
  199. * app: add option to ignore select volumes on app.clone_vm()
  200. * tools/qvm-create: properly create template-based StandaloneVM
  201. * tools/qvm-create: fix handling invalid label
  202. * Copy application menu on VM clone
  203. * Code style fix
  204. * tools: clarify qvm-service --help
  205. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 29 Oct 2018 05:45:34 +0100
  206. qubes-core-admin-client (4.0.21-1) unstable; urgency=medium
  207. [ Marek Marczykowski-Górecki ]
  208. * Move pylint config to canonical place
  209. * devices: add DeviceInfo.devclass attribute
  210. [ AJ Jordan ]
  211. * Fix typo
  212. [ jimtahu ]
  213. * Exclude installed_by_rpm when Restoring VM from Backup
  214. [ Marek Marczykowski-Górecki ]
  215. * devices: drop DeviceInfo.options
  216. * events: deserialize DeviceInfo class in device-* events
  217. * devices: include devclass when comparing devices
  218. * events: try reconnecting to qubesd also on BrokenPipeError
  219. * rpm: fix building on fc29
  220. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 07 Oct 2018 15:37:03 +0200
  221. qubes-core-admin-client (4.0.20-1) unstable; urgency=medium
  222. [ Marek Marczykowski-Górecki ]
  223. * Adjust shell input for Windows shell, for qvm-run tool
  224. * travis: install python-docutils in separate step
  225. [ Patrik Hagara ]
  226. * qvm-ls: add filtering by tags
  227. [ Marek Marczykowski-Górecki ]
  228. * tools/qvm-create: resize root volume if needed before imporing data
  229. * events: add support for wildcard event handlers
  230. * events: fix reconnecting to qubesd on its restart
  231. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 13 Sep 2018 23:40:01 +0200
  232. qubes-core-admin-client (4.0.19-1) unstable; urgency=medium
  233. [ Marek Marczykowski-Górecki ]
  234. * app: fix error reporting when connection to qubesd fails
  235. * tools/qvm-start-gui: do not crash on qubesd restart
  236. * Fixes for pylint 2.0
  237. [ Marta Marczykowska-Górecka ]
  238. * Deleted a duplicate man qvm-services entry
  239. [ Marek Marczykowski-Górecki ]
  240. * qvm-start-gui: fix handlign rpc-clipboard feature
  241. * Add 'gui-emulated' feature
  242. * doc: add info what properties are inherited from template
  243. * backup: avoid deadlock on logging during restore
  244. * doc: add linux-stubdom feature to man qvm-features
  245. [ Marta Marczykowska-Górecka ]
  246. * Helper function that lists where a given VM is used
  247. * Added tests and minor correction to vm_usage helper function
  248. * Name change of vm dependencies helper function
  249. * Better information on error in qvm-remove
  250. * Added test for qvm-remove dependency reporting
  251. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Fri, 20 Jul 2018 18:29:28 +0200
  252. qubes-core-admin-client (4.0.18-1) unstable; urgency=medium
  253. [ Peter Gerber ]
  254. * tools/qvm-firewall: Describe available rules in --help output
  255. [ Marek Marczykowski-Górecki ]
  256. * tools/qvm-firewall: add 'expire' rule support
  257. * tools/qvm-firewall: make 'list' a default action
  258. [ Peter Gerber ]
  259. * tools/qvm-firewall: Show EXPIRE column in list output
  260. * tools/qvm-firewall: add dst4 and dst6 as synonyms for dsthost
  261. * .gitignore: add doc/_build/
  262. * tools/qvm-firewall: improve manpage and --help output
  263. [ Marek Marczykowski-Górecki ]
  264. * Fix reporting events even if its source is not available anymore
  265. * tools: don't fail qvm-template-postprocess on shutdown race
  266. condition
  267. [ jimtahu ]
  268. * Change "None" to Property None
  269. * Change "None" in qvm_prefs
  270. * Add test of qvm_prefs for specal case "None"
  271. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 27 Jun 2018 03:31:03 +0200
  272. qubes-core-admin-client (4.0.17-1) unstable; urgency=medium
  273. [ Frédéric Pierret ]
  274. * Create .spec.in and Source0
  275. * Remove _builddir and useless condition on qubes_builder
  276. * doc: handle release definition when not being in a git repository
  277. * spec.in: add changelog placeholder
  278. [ Marek Marczykowski-Górecki ]
  279. * tools: fix error reporing on unknown storage pool
  280. * tools/qvm-pool: add --set to modify pool properties
  281. * doc: adjust example in qvm-pool man page
  282. * Add 'make clean' target, use it for Debian build
  283. * tools/qvm-ls: add --kernel option for compatibility with R3.2
  284. * tools/qvm-template-postprocess: fix reinstall action
  285. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Apr 2018 15:27:37 +0200
  286. qubes-core-admin-client (4.0.16-1) unstable; urgency=medium
  287. * doc: typos
  288. * doc: fix module index generation
  289. * storage: add 'rw' and 'revision_to_keep' setters
  290. * qvm-volume: add 'info' and 'config' actions
  291. * storage: make Pool.{size,usage} integers
  292. * doc: update qvm-volume parameters
  293. * qvm-volume: refuse to shrink volume unless --force option is used
  294. * tools: add SubParsersHelpAction, which include subcommands details
  295. in --help
  296. * tools: suppress full traceback in console tools
  297. * qvm-template-postprocess: resize volume only when needed
  298. * qvm-template-postprocess: do not remove VM on failed reinstall
  299. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 21 Mar 2018 01:55:21 +0100
  300. qubes-core-admin-client (4.0.15-1) unstable; urgency=medium
  301. [ Marek Marczykowski-Górecki ]
  302. * doc: add 'pci-e820-host' feature description
  303. [ Rusty Bird ]
  304. * qvm-backup-restore: remove orphaned --replace-template option
  305. * qvm-backup-restore: really pass options
  306. * qvm-backup: let backup core handle default VM selection
  307. * restore.py: don't try to restore dispid property
  308. * restore.py: sort into three tiers in _templates_first()
  309. * restore.py: deal with DispVM templates
  310. * restore.py: factor out _restore_property() helper
  311. * restory.py: restore template_for_dispvms property early
  312. * restore.py: add template-related debug log messages
  313. [ Frédéric Pierret ]
  314. * Add support for python34-sphinx: package is provided in Qubes
  315. repository
  316. [ Marek Marczykowski-Górecki ]
  317. * tools: terminate qvm-start-gui when X server is terminated
  318. [ Rusty Bird ]
  319. * qvm-backup-restore: also handle absent --ignore-missing
  320. [ Marek Marczykowski-Górecki ]
  321. * qvm-template-postprocess: call fstrim after removing image file
  322. * tools/qvm-prefs: fix printing None value
  323. * tests: add tests for various 'qvm-prefs vm pref' cases
  324. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 04 Mar 2018 03:54:39 +0100
  325. qubes-core-admin-client (4.0.14-1) unstable; urgency=medium
  326. [ Marek Marczykowski-Górecki ]
  327. * vm: restore force_shutdown->kill deprecated alias
  328. [ Christopher Laprise ]
  329. * Fix AdminVm class name
  330. * Fix dom0 handling
  331. * Fix dom0 restore
  332. * style issues
  333. * unused variable
  334. [ Marek Marczykowski-Górecki ]
  335. * backup: skip dom0's properties while restoring core2 backup
  336. * backup: add support for openssl 1.1.0 options
  337. * tests: dom0 backup restore, both v3 and v4
  338. * backup: don't crash when no 'qubes' group is present
  339. [ Rusty Bird ]
  340. * template-postprocess: fast path for file-reflink, like file
  341. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 14 Feb 2018 04:46:52 +0100
  342. qubes-core-admin-client (4.0.13-1) unstable; urgency=medium
  343. [ Christopher Laprise ]
  344. * Fix dom0-related issues
  345. [ Marek Marczykowski-Górecki ]
  346. * backup: make pylint happy
  347. * Make pylint happy
  348. * tools/qvm-ls: fix handling columns with underscore
  349. * backup: restore Qubes 3.x VMs as HVMs
  350. * doc: update qvm-features documentation
  351. [ Christopher Laprise ]
  352. * Add --yes option and confirm prompt.
  353. * Fix error message grammar
  354. * Toggle installed_by_rpm in template tool
  355. * Use --force instead of --yes
  356. * Print vm list before prompt
  357. * Avoid cloning installed_by_rpm
  358. * Add --force to manpage.
  359. * Fix style else-return
  360. [ Marek Marczykowski-Górecki ]
  361. * tests: update qvm-template-process and qvm-remove tests
  362. * add QubesVM.connected_vms attribute
  363. [ Rusty Bird ]
  364. * qvm-device/block: Alias '--ro' to '--option read-only=yes'
  365. * qvm-device.rst: Document '--ro' option
  366. [ Marek Marczykowski-Górecki ]
  367. * doc: add info about specific qvm-device cases
  368. * storage: add volume.is_outdated() function
  369. * tools/qvm-start: add naive waiting for cdrom device
  370. * tools: fix handling optional domain list
  371. * tools/qvm-ls: allow list only selected VMs
  372. * tools/qvm-ls: add --raw-list option for compatibility with R3.2
  373. * tools/qvm-ls: add --network and --disk compatibility options
  374. * tools/qvm-ls: clarify that disk usage is in percents
  375. * base: make WrapperObjectsCollection behave like a dict
  376. * rpm,deb: add missing python lxml dependency
  377. * Add property_get_default method
  378. * vm/DispVM: use 'qrexec_timeout' also for call connection timeout
  379. [ Rusty Bird ]
  380. * qvm-run: wait for X11 in --dispvm --gui case
  381. [ Marek Marczykowski-Górecki ]
  382. * storage: add size and usage properties
  383. * backup/restore: do not shrink volumes on restore
  384. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 18 Jan 2018 21:06:36 +0100
  385. qubes-core-admin-client (4.0.12-1) unstable; urgency=medium
  386. [ Jean-Philippe Ouellet ]
  387. * Stop leaking terminal escapes via stderr
  388. [ Marek Marczykowski-Górecki ]
  389. * tests: Update tests after fix for filtering stderr
  390. [ Jean-Philippe Ouellet ]
  391. * Fix qvm-ls --raw-data
  392. * Disable spinner if --raw-data
  393. * Remove dead code
  394. [ qubesuser ]
  395. * don't lookup list of labels just to read VM properties
  396. * don't use ast.literal_eval, just directly convert to the desired
  397. type
  398. [ Marek Marczykowski-Górecki ]
  399. * tests: make filter-esc tests working also on travis
  400. * tests: fix tests after dropping unnecessary admin.label.List call
  401. [ Christopher Laprise ]
  402. * Issue #3303
  403. * Fix verify-only
  404. * verify-only avoid dom0 handler
  405. [ Marek Marczykowski-Górecki ]
  406. * tests: update tests for fixed verify_only handling
  407. * make qvm-shutdown nice for unit tests
  408. * Make pylint happy
  409. * Another approach for making qvm-shutdown nice for tests
  410. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 12 Dec 2017 01:42:19 +0100
  411. qubes-core-admin-client (4.0.11-1) unstable; urgency=medium
  412. [ qubesuser ]
  413. * remove format_doc and docutils import
  414. * don't import pkg_resources in the top of qubesadmin/utils.py
  415. * replace console entry points with just importing the module
  416. * replace key in dir(self) with faster and better code
  417. [ Jean-Philippe Ouellet ]
  418. * Fix setting stderr default coloring policy
  419. * Restore correct colors in verbose mode
  420. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 21 Nov 2017 04:52:46 +0100
  421. qubes-core-admin-client (4.0.10-1) unstable; urgency=medium
  422. [ Marek Marczykowski-Górecki ]
  423. * Document device attach options in man page
  424. * tools/qvm-shutdown: fix handling shutdown timeout for multiple VMs
  425. * backup: fix handling labels in Qubes 4.0 backups
  426. [ qubesuser ]
  427. * make qvm-run work for non-blocking stdin
  428. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 09 Nov 2017 11:56:18 +0100
  429. qubes-core-admin-client (4.0.9-1) unstable; urgency=medium
  430. [ Frédéric Pierret ]
  431. * Add CentOS support and fix python3 dependencies for CentOS (except
  432. python3-sphinx and python3-daemon which has no python34 package)
  433. [ Marek Marczykowski-Górecki ]
  434. * Fix DeviceInfo objects comparing
  435. * vm: fix handling policy deny on admin.vm.List
  436. * Drop log.DBusHandler
  437. * backup: improve migrating templates from Qubes 3.x
  438. * tools: fix handling qvm-run --no-autostart
  439. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 21 Oct 2017 04:11:20 +0200
  440. qubes-core-admin-client (4.0.8-1) unstable; urgency=medium
  441. * backup: fix restoring template VMs
  442. * tools: clarify that qvm-backup needs absolute path
  443. * backup: fix name of meminfo-writer feature
  444. * backup: update DispVM template property: template_for_dispvms
  445. * backup: improve restoring HVMs from Qubes 3.2
  446. * backup: do not try to read tar's stderr past EOF
  447. * tests: multi-part volume in backup tests
  448. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Mon, 16 Oct 2017 04:44:26 +0200
  449. qubes-core-admin-client (4.0.7-1) unstable; urgency=medium
  450. [ Marek Marczykowski-Górecki ]
  451. * Implement "blind mode" to avoid listing objects
  452. * events: ignore events from non-existing domains
  453. * tools: fix qvm-run --help
  454. * Always use QubesVM objects, instead of AppVM/TemplateVM etc
  455. * Move vm.appvms to QubesVM
  456. * Drop individual VM classes as python types completely
  457. * tools: finish 'qvm-volume revert' implementation, add tests
  458. * tools/qvm-start: fix starting a VM with cdrom image
  459. * vm: drop suspend and resume methods - not part of the Admin API
  460. * rpm: add conflict with too-old qubes-manager
  461. [ Mindy Preston ]
  462. * qvm-start: exit if domain running and no --skip-if-running
  463. [ Marek Marczykowski-Górecki ]
  464. * tools: adjust qvm-start message and logic, update tests
  465. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 08 Oct 2017 18:42:41 +0200
  466. qubes-core-admin-client (4.0.6-1) unstable; urgency=medium
  467. [ Marek Marczykowski-Górecki ]
  468. * tools/qvm-run: ignore --filter-esc/--no-filter-esc unless --pass-io
  469. is given
  470. * vm/dispvm: fix dispvm.cleanup() when no service was called
  471. * tests: add DispVM tests
  472. * Improve QubesDaemonNoResponseError error message
  473. * tools: drop --delete and --unset aliases for --default option
  474. * doc: update list of properties in qvm-prefs/qubes-prefs man pages
  475. * doc: add short description of VM classes to qvm-create man page
  476. * tools: implement qvm-create --root-move-from/--root-copy-from
  477. * tools: add qvm-create --help-classes
  478. * backup/restore: make backup header extraction faster
  479. * backup/restore: do not fail the whole restore when qvm-appmenus is
  480. missing
  481. [ blackpit ]
  482. * Fixed https://github.com/QubesOS/qubes-issues/issues/2983
  483. [ Marek Marczykowski-Górecki ]
  484. * tools: fix too long lines
  485. * tools: cleanup temporary files after qvm-template-postprocess
  486. * devices: client stub for DeviceCollection.update_persistent
  487. * tools: restore qvm-start --cdrom and similar options
  488. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 14 Sep 2017 02:47:48 +0200
  489. qubes-core-admin-client (4.0.5-1) unstable; urgency=medium
  490. * tools/qvm-run: fix handling small data blocks
  491. * vm: add DispVMWrapper for calling a single service in new DispVM
  492. * tools: add qvm-run --dispvm option
  493. * doc: list known features in qvm-features manual page
  494. * app: add VMCollection.values()
  495. * tools/qvm-run: do not use os.set_blocking
  496. * tools/qvm-device: list attach options
  497. * doc: add default values to qvm-features man page
  498. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Thu, 10 Aug 2017 16:10:40 +0200
  499. qubes-core-admin-client (4.0.4-1) unstable; urgency=medium
  500. * tools/qvm-start-gui: do not start stubdomain GUI for VMs with gui-
  501. agent
  502. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sun, 30 Jul 2017 19:20:07 +0200
  503. qubes-core-admin-client (4.0.3-1) unstable; urgency=medium
  504. * tools/qvm-backup-restore: fix default list of VMs to restore
  505. * storage: drop 'internal' volume property
  506. * tools/qvm-volume: fix default action handling
  507. * tests: qvm-backup-restore tool tests
  508. * tools/qvm-backup-restore: fix restoring only specific VMs
  509. * tests: disable slow tests unless ENABLE_SLOW_TESTS=1 is set
  510. * backup: move BackupRestore class and helpers to 'restore' submodule
  511. * tools: add qvm-backup tool
  512. * debian: update build depends
  513. * doc: update qvm-backup man page
  514. * backup/restore: improve error reporting
  515. * backup/restore: add option to ignore size limit
  516. * events: add variable Admin API method name
  517. * tools/qvm-shutdown: drop --force option, it isn't supported anymore
  518. * tools/qvm-shutdown: fix help message
  519. * tools/qvm-start-gui: add --force-stubdomain options
  520. * features: serialize True as '1'
  521. * tests: too much copy&paste
  522. * tools: qvm-service tool
  523. * doc: update manpage of qvm-service
  524. * qvm-ls: fix total VM size reporting
  525. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 29 Jul 2017 06:16:06 +0200
  526. qubes-core-admin-client (4.0.2-1) unstable; urgency=medium
  527. [ Marek Marczykowski-Górecki ]
  528. * vm: make QubesVM objects hashable
  529. * events: simplify wait_for_domain_shutdown coroutine
  530. * tools: handle shutdown order in qvm-shutdown
  531. * tests/tools: add MockEventsReader
  532. * tests: qvm-shutdown --wait tests
  533. * Fix VM creation with default template
  534. * events: fix cleanup function in qrexec case
  535. * tests: improve test failure message
  536. [ Marta Marczykowska-Górecka ]
  537. * added helper function updates_vms_status
  538. [ Marek Marczykowski-Górecki ]
  539. * tools/qvm-run: fix handling copying stdin to the process
  540. * tests: mark qvm-run tests with "expected failure"
  541. * tools/qvm-run: fix handling EOF
  542. * Make pylint happy
  543. * Don't try to set 'created-by-' tag when cloning VM
  544. * backup: initial support for backup restore over Admin API
  545. * tests/backup: tests for backup-restore code
  546. * Exclude 'qubesadmin.backup' module from python2 install
  547. * devices,features: fix bool values handling
  548. * tests/backup: use smaller images
  549. * tests: add v4 (Qubes 4.0) backup format tests, move qubes.xml
  550. * backup: add firewall and appmenus list handling
  551. * firewall: fix handling DstHost.prefixlen=0
  552. * tests: backup: add firewall.xml and appmenus checking
  553. * tools: add qvm-backup-restore
  554. * app: call admin.vm.volume.Import as root
  555. * backup: do not show full stacktrace to the user
  556. * backup: change 'hvm' property to 'virt_mode'
  557. * backup: use 'cat' instead of read-write loop in python
  558. * backup: improve error logging
  559. * tools/qvm-backup-restore: handle VMs selection, not only exclusion
  560. * Choose QubesLocal or QubesRemote based on /etc/qubes-release
  561. presence
  562. * Change 'hvm' property to 'virt_mode'
  563. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Tue, 18 Jul 2017 05:37:29 +0200
  564. qubes-core-admin-client (4.0.1-1) unstable; urgency=medium
  565. *
  566. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Wed, 05 Jul 2017 20:14:12 +0200
  567. qubes-core-admin-client (4.0.0-1) unstable; urgency=low
  568. * Initial release
  569. -- Marek Marczykowski-Górecki <marmarek@invisiblethingslab.com> Sat, 20 May 2017 00:13:54 +0200