core-dom0.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. #%{!?python3_sitelib: %define python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(False)")}
  26. %{!?version: %define version %(cat version)}
  27. # debug_package hack should be removed when BuildArch:noarch is enabled below
  28. %define debug_package %{nil}
  29. %define _dracutmoddir /usr/lib/dracut/modules.d
  30. %if %{fedora} < 17
  31. %define _dracutmoddir /usr/share/dracut/modules.d
  32. %endif
  33. Name: qubes-core-dom0
  34. Version: %{version}
  35. Release: 1%{dist}
  36. Summary: The Qubes core files (Dom0-side)
  37. Group: Qubes
  38. Vendor: Invisible Things Lab
  39. License: GPL
  40. URL: http://www.qubes-os.org
  41. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  42. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  43. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  44. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  45. AutoReq: no
  46. # FIXME: Enable this and disable debug_package
  47. #BuildArch: noarch
  48. BuildRequires: ImageMagick
  49. BuildRequires: systemd-units
  50. BuildRequires: systemd
  51. BuildRequires: python3-devel
  52. # for building documentation
  53. BuildRequires: python3-sphinx
  54. BuildRequires: python3-lxml
  55. BuildRequires: libvirt-python3
  56. BuildRequires: python3-dbus
  57. Requires(post): systemd-units
  58. Requires(preun): systemd-units
  59. Requires(postun): systemd-units
  60. Requires: python3
  61. #Requires: python3-aiofiles
  62. Requires: python3-docutils
  63. Requires: python3-jinja2
  64. Requires: python3-lxml
  65. Requires: python3-pydbus
  66. Requires: python3-qubesdb
  67. Requires: python3-setuptools
  68. Requires: python3-xen
  69. Requires: libvirt-python3
  70. Requires: pciutils
  71. Requires: qubes-core-dom0-linux >= 3.1.8
  72. Requires: qubes-db-dom0
  73. # TODO: R: qubes-gui-dom0 >= 2.1.11
  74. Conflicts: qubes-gui-dom0 < 1.1.13
  75. %if x%{?backend_vmm} == xxen
  76. Requires: xen-runtime
  77. Requires: xen-hvm
  78. Requires: xen-hvm-stubdom-linux
  79. Requires: libvirt-daemon-xen >= 1.2.20-6
  80. %endif
  81. Requires: createrepo
  82. Requires: gnome-packagekit
  83. Requires: cronie
  84. Requires: bsdtar
  85. Requires: scrypt
  86. # for qubes-hcl-report
  87. Requires: dmidecode
  88. Requires: PyQt4
  89. %{?systemd_requires}
  90. # for lvm support
  91. Requires: lvm2-python-libs
  92. Obsoletes: qubes-core-dom0-doc <= 4.0
  93. Provides: qubes-core-dom0-doc
  94. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  95. Obsoletes: preupgrade < 2.0
  96. Provides: preupgrade = 2.0
  97. %define _builddir %(pwd)
  98. %description
  99. The Qubes core files for installation on Dom0.
  100. %prep
  101. # we operate on the current directory, so no need to unpack anything
  102. # symlink is to generate useful debuginfo packages
  103. rm -f %{name}-%{version}
  104. ln -sf . %{name}-%{version}
  105. %setup -T -D
  106. %build
  107. make all
  108. make -C doc PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} man
  109. %install
  110. make install \
  111. DESTDIR=$RPM_BUILD_ROOT \
  112. UNITDIR=%{_unitdir} \
  113. PYTHON_SITEPATH=%{python3_sitelib} \
  114. SYSCONFDIR=%{_sysconfdir}
  115. make -C doc DESTDIR=$RPM_BUILD_ROOT \
  116. PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} \
  117. install
  118. %post
  119. %systemd_post qubes-core.service
  120. %systemd_post qubes-netvm.service
  121. %systemd_post qubes-qmemman.service
  122. %systemd_post qubesd.service
  123. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  124. echo 'autoballoon=0' >> /etc/xen/xl.conf
  125. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  126. if [ -e /etc/sysconfig/prelink ]; then
  127. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  128. fi
  129. # Conflicts with libxl stack, so disable it
  130. systemctl --no-reload disable xend.service >/dev/null 2>&1
  131. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  132. systemctl daemon-reload >/dev/null 2>&1 || :
  133. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  134. # echo "Initializing Qubes DB..."
  135. umask 007; sg qubes -c 'qubes-create --offline-mode'
  136. fi
  137. %clean
  138. rm -rf $RPM_BUILD_ROOT
  139. rm -f %{name}-%{version}
  140. %pre
  141. if ! grep -q ^qubes: /etc/group ; then
  142. groupadd qubes
  143. fi
  144. %triggerin -- xen-runtime
  145. /usr/lib/qubes/fix-dir-perms.sh
  146. %preun
  147. %systemd_preun qubes-core.service
  148. %systemd_preun qubes-netvm.service
  149. %systemd_preun qubes-qmemman.service
  150. %systemd_preun qubesd.service
  151. if [ "$1" = 0 ] ; then
  152. # no more packages left
  153. service qubes_netvm stop
  154. service qubes_core stop
  155. fi
  156. %postun
  157. %systemd_postun qubes-core.service
  158. %systemd_postun qubes-netvm.service
  159. %systemd_postun_with_restart qubes-qmemman.service
  160. %systemd_postun_with_restart qubesd.service
  161. if [ "$1" = 0 ] ; then
  162. # no more packages left
  163. chgrp root /etc/xen
  164. chmod 700 /etc/xen
  165. groupdel qubes
  166. fi
  167. %files
  168. %defattr(-,root,root,-)
  169. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  170. %config(noreplace) /etc/dbus-1/system.d/org.qubesos.PolicyAgent.conf
  171. /usr/bin/qvm-*
  172. /usr/bin/qubes-*
  173. /usr/bin/qmemmand
  174. /usr/bin/qubesd*
  175. /usr/bin/qrexec-policy
  176. /usr/bin/qrexec-policy-agent
  177. %{_mandir}/man1/qubes*.1*
  178. %dir %{python3_sitelib}/qubes-*.egg-info
  179. %{python3_sitelib}/qubes-*.egg-info/*
  180. %dir %{python3_sitelib}/qubes
  181. %dir %{python3_sitelib}/qubes/__pycache__
  182. %{python3_sitelib}/qubes/__pycache__/*
  183. %{python3_sitelib}/qubes/__init__.py
  184. %{python3_sitelib}/qubes/app.py
  185. %{python3_sitelib}/qubes/backup.py
  186. %{python3_sitelib}/qubes/config.py
  187. %{python3_sitelib}/qubes/core2migration.py
  188. %{python3_sitelib}/qubes/devices.py
  189. %{python3_sitelib}/qubes/dochelpers.py
  190. %{python3_sitelib}/qubes/events.py
  191. %{python3_sitelib}/qubes/exc.py
  192. %{python3_sitelib}/qubes/firewall.py
  193. %{python3_sitelib}/qubes/log.py
  194. %{python3_sitelib}/qubes/rngdoc.py
  195. %{python3_sitelib}/qubes/tarwriter.py
  196. %{python3_sitelib}/qubes/utils.py
  197. %dir %{python3_sitelib}/qubes/api
  198. %dir %{python3_sitelib}/qubes/api/__pycache__
  199. %{python3_sitelib}/qubes/api/__pycache__/*
  200. %{python3_sitelib}/qubes/api/__init__.py
  201. %{python3_sitelib}/qubes/api/admin.py
  202. %{python3_sitelib}/qubes/api/internal.py
  203. %{python3_sitelib}/qubes/api/misc.py
  204. %dir %{python3_sitelib}/qubes/vm
  205. %dir %{python3_sitelib}/qubes/vm/__pycache__
  206. %{python3_sitelib}/qubes/vm/__pycache__/*
  207. %{python3_sitelib}/qubes/vm/__init__.py
  208. %{python3_sitelib}/qubes/vm/adminvm.py
  209. %{python3_sitelib}/qubes/vm/appvm.py
  210. %{python3_sitelib}/qubes/vm/dispvm.py
  211. %{python3_sitelib}/qubes/vm/qubesvm.py
  212. %{python3_sitelib}/qubes/vm/standalonevm.py
  213. %{python3_sitelib}/qubes/vm/templatevm.py
  214. %dir %{python3_sitelib}/qubes/vm/mix
  215. %dir %{python3_sitelib}/qubes/vm/mix/__pycache__
  216. %{python3_sitelib}/qubes/vm/mix/__pycache__/*
  217. %{python3_sitelib}/qubes/vm/mix/__init__.py
  218. %{python3_sitelib}/qubes/vm/mix/net.py
  219. %dir %{python3_sitelib}/qubes/storage
  220. %dir %{python3_sitelib}/qubes/storage/__pycache__
  221. %{python3_sitelib}/qubes/storage/__pycache__/*
  222. %{python3_sitelib}/qubes/storage/__init__.py
  223. %{python3_sitelib}/qubes/storage/file.py
  224. %{python3_sitelib}/qubes/storage/kernels.py
  225. %{python3_sitelib}/qubes/storage/lvm.py
  226. %dir %{python3_sitelib}/qubes/tools
  227. %dir %{python3_sitelib}/qubes/tools/__pycache__
  228. %{python3_sitelib}/qubes/tools/__pycache__/*
  229. %{python3_sitelib}/qubes/tools/__init__.py
  230. %{python3_sitelib}/qubes/tools/qmemmand.py
  231. %{python3_sitelib}/qubes/tools/qubes_create.py
  232. %{python3_sitelib}/qubes/tools/qubesd.py
  233. %{python3_sitelib}/qubes/tools/qubesd_query.py
  234. %{python3_sitelib}/qubes/tools/qvm_backup.py
  235. %{python3_sitelib}/qubes/tools/qvm_backup_restore.py
  236. %dir %{python3_sitelib}/qubes/ext
  237. %dir %{python3_sitelib}/qubes/ext/__pycache__
  238. %{python3_sitelib}/qubes/ext/__pycache__/*
  239. %{python3_sitelib}/qubes/ext/__init__.py
  240. %{python3_sitelib}/qubes/ext/block.py
  241. %{python3_sitelib}/qubes/ext/gui.py
  242. %{python3_sitelib}/qubes/ext/pci.py
  243. %{python3_sitelib}/qubes/ext/qubesmanager.py
  244. %{python3_sitelib}/qubes/ext/r3compatibility.py
  245. %dir %{python3_sitelib}/qubes/tests
  246. %dir %{python3_sitelib}/qubes/tests/__pycache__
  247. %{python3_sitelib}/qubes/tests/__pycache__/*
  248. %{python3_sitelib}/qubes/tests/__init__.py
  249. %{python3_sitelib}/qubes/tests/run.py
  250. %{python3_sitelib}/qubes/tests/extra.py
  251. %{python3_sitelib}/qubes/tests/api_admin.py
  252. %{python3_sitelib}/qubes/tests/api_misc.py
  253. %{python3_sitelib}/qubes/tests/app.py
  254. %{python3_sitelib}/qubes/tests/devices.py
  255. %{python3_sitelib}/qubes/tests/devices_block.py
  256. %{python3_sitelib}/qubes/tests/events.py
  257. %{python3_sitelib}/qubes/tests/firewall.py
  258. %{python3_sitelib}/qubes/tests/init.py
  259. %{python3_sitelib}/qubes/tests/storage.py
  260. %{python3_sitelib}/qubes/tests/storage_file.py
  261. %{python3_sitelib}/qubes/tests/storage_kernels.py
  262. %{python3_sitelib}/qubes/tests/storage_lvm.py
  263. %{python3_sitelib}/qubes/tests/tarwriter.py
  264. %dir %{python3_sitelib}/qubes/tests/vm
  265. %dir %{python3_sitelib}/qubes/tests/vm/__pycache__
  266. %{python3_sitelib}/qubes/tests/vm/__pycache__/*
  267. %{python3_sitelib}/qubes/tests/vm/__init__.py
  268. %{python3_sitelib}/qubes/tests/vm/init.py
  269. %{python3_sitelib}/qubes/tests/vm/adminvm.py
  270. %{python3_sitelib}/qubes/tests/vm/qubesvm.py
  271. %dir %{python3_sitelib}/qubes/tests/vm/mix
  272. %dir %{python3_sitelib}/qubes/tests/vm/mix/__pycache__
  273. %{python3_sitelib}/qubes/tests/vm/mix/__pycache__/*
  274. %{python3_sitelib}/qubes/tests/vm/mix/__init__.py
  275. %{python3_sitelib}/qubes/tests/vm/mix/net.py
  276. %dir %{python3_sitelib}/qubes/tests/tools
  277. %dir %{python3_sitelib}/qubes/tests/tools/__pycache__
  278. %{python3_sitelib}/qubes/tests/tools/__pycache__/*
  279. %{python3_sitelib}/qubes/tests/tools/__init__.py
  280. %{python3_sitelib}/qubes/tests/tools/qubesd.py
  281. %dir %{python3_sitelib}/qubes/tests/integ
  282. %dir %{python3_sitelib}/qubes/tests/integ/__pycache__
  283. %{python3_sitelib}/qubes/tests/integ/__pycache__/*
  284. %{python3_sitelib}/qubes/tests/integ/__init__.py
  285. %{python3_sitelib}/qubes/tests/integ/backup.py
  286. %{python3_sitelib}/qubes/tests/integ/backupcompatibility.py
  287. %{python3_sitelib}/qubes/tests/integ/basic.py
  288. %{python3_sitelib}/qubes/tests/integ/devices_pci.py
  289. %{python3_sitelib}/qubes/tests/integ/dispvm.py
  290. %{python3_sitelib}/qubes/tests/integ/dom0_update.py
  291. %{python3_sitelib}/qubes/tests/integ/network.py
  292. %{python3_sitelib}/qubes/tests/integ/storage.py
  293. %{python3_sitelib}/qubes/tests/integ/vm_qrexec_gui.py
  294. %dir %{python3_sitelib}/qubes/tests/integ/tools
  295. %dir %{python3_sitelib}/qubes/tests/integ/tools/__pycache__
  296. %{python3_sitelib}/qubes/tests/integ/tools/__pycache__/*
  297. %{python3_sitelib}/qubes/tests/integ/tools/__init__.py
  298. %{python3_sitelib}/qubes/tests/integ/tools/qubes_create.py
  299. %dir %{python3_sitelib}/qubes/qmemman
  300. %dir %{python3_sitelib}/qubes/qmemman/__pycache__
  301. %{python3_sitelib}/qubes/qmemman/__pycache__/*
  302. %{python3_sitelib}/qubes/qmemman/__init__.py
  303. %{python3_sitelib}/qubes/qmemman/algo.py
  304. %{python3_sitelib}/qubes/qmemman/client.py
  305. %dir %{python3_sitelib}/qubespolicy
  306. %dir %{python3_sitelib}/qubespolicy/__pycache__
  307. %{python3_sitelib}/qubespolicy/__pycache__/*
  308. %{python3_sitelib}/qubespolicy/__init__.py
  309. %{python3_sitelib}/qubespolicy/cli.py
  310. %{python3_sitelib}/qubespolicy/agent.py
  311. %{python3_sitelib}/qubespolicy/gtkhelpers.py
  312. %{python3_sitelib}/qubespolicy/rpcconfirmation.py
  313. %{python3_sitelib}/qubespolicy/utils.py
  314. %dir %{python3_sitelib}/qubespolicy/tests
  315. %dir %{python3_sitelib}/qubespolicy/tests/__pycache__
  316. %{python3_sitelib}/qubespolicy/tests/__pycache__/*
  317. %{python3_sitelib}/qubespolicy/tests/__init__.py
  318. %{python3_sitelib}/qubespolicy/tests/gtkhelpers.py
  319. %{python3_sitelib}/qubespolicy/tests/rpcconfirmation.py
  320. %dir %{python3_sitelib}/qubespolicy/glade
  321. %{python3_sitelib}/qubespolicy/glade/RPCConfirmationWindow.glade
  322. /usr/lib/qubes/cleanup-dispvms
  323. /usr/lib/qubes/fix-dir-perms.sh
  324. /usr/lib/qubes/startup-misc.sh
  325. /usr/libexec/qubes/qubesd-query-fast
  326. %{_unitdir}/qubes-core.service
  327. %{_unitdir}/qubes-netvm.service
  328. %{_unitdir}/qubes-qmemman.service
  329. %{_unitdir}/qubes-vm@.service
  330. %{_unitdir}/qubesd.service
  331. %{_unitdir}/qubes-reload-firewall@.service
  332. %{_unitdir}/qubes-reload-firewall@.timer
  333. %attr(2770,root,qubes) %dir /var/lib/qubes
  334. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  335. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  336. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  337. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  338. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  339. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  340. /usr/share/qubes/templates/libvirt/xen.xml
  341. /usr/share/qubes/templates/libvirt/devices/block.xml
  342. /usr/share/qubes/templates/libvirt/devices/pci.xml
  343. /usr/share/qubes/templates/libvirt/devices/net.xml
  344. /usr/lib/tmpfiles.d/qubes.conf
  345. /etc/xen/scripts/block-snapshot
  346. /etc/xen/scripts/block-origin
  347. /etc/xen/scripts/vif-route-qubes
  348. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/admin.*
  349. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/include/admin-all
  350. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  351. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  352. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  353. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  354. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  355. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  356. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  357. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenURL
  358. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  359. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.UpdatesProxy
  360. /etc/qubes-rpc/admin.*
  361. /etc/qubes-rpc/qubes.FeaturesRequest
  362. /etc/qubes-rpc/qubes.GetRandomizedTime
  363. /etc/qubes-rpc/qubes.NotifyTools
  364. /etc/qubes-rpc/qubes.NotifyUpdates
  365. %attr(2770,root,qubes) %dir /var/log/qubes
  366. %attr(0770,root,qubes) %dir /var/run/qubes
  367. /etc/xdg/autostart/qrexec-policy-agent.desktop
  368. /usr/share/doc/qubes/relaxng/*.rng