core-dom0.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. %{!?version: %define version %(cat version)}
  26. # debug_package hack should be removed when BuildArch:noarch is enabled below
  27. %define debug_package %{nil}
  28. %define _dracutmoddir /usr/lib/dracut/modules.d
  29. %if %{fedora} < 17
  30. %define _dracutmoddir /usr/share/dracut/modules.d
  31. %endif
  32. Name: qubes-core-dom0
  33. Version: %{version}
  34. Release: 1%{dist}
  35. Summary: The Qubes core files (Dom0-side)
  36. Group: Qubes
  37. Vendor: Invisible Things Lab
  38. License: GPL
  39. URL: http://www.qubes-os.org
  40. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  41. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  42. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  43. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  44. AutoReq: no
  45. # FIXME: Enable this and disable debug_package
  46. #BuildArch: noarch
  47. BuildRequires: ImageMagick
  48. BuildRequires: systemd-units
  49. BuildRequires: systemd
  50. BuildRequires: python3-devel
  51. # for building documentation
  52. BuildRequires: python3-sphinx
  53. BuildRequires: python3-lxml
  54. BuildRequires: libvirt-python3
  55. BuildRequires: python3-dbus
  56. BuildRequires: python3-PyYAML
  57. Requires(post): systemd-units
  58. Requires(preun): systemd-units
  59. Requires(postun): systemd-units
  60. Requires: python3
  61. #Requires: python3-aiofiles
  62. Requires: python3-docutils
  63. Requires: python3-jinja2
  64. Requires: python3-lxml
  65. Requires: python3-pydbus
  66. Requires: python3-qubesdb
  67. Requires: python3-setuptools
  68. Requires: python3-PyYAML
  69. Requires: python3-xen
  70. Requires: libvirt-python3
  71. Requires: pciutils
  72. Requires: qubes-core-dom0-linux >= 3.1.8
  73. Requires: qubes-db-dom0
  74. # TODO: R: qubes-gui-dom0 >= 2.1.11
  75. Conflicts: qubes-gui-dom0 < 1.1.13
  76. %if x%{?backend_vmm} == xxen
  77. Requires: xen-runtime
  78. Requires: xen-hvm
  79. Requires: xen-hvm-stubdom-linux
  80. Requires: libvirt-daemon-xen >= 1.2.20-6
  81. %endif
  82. Requires: createrepo
  83. Requires: gnome-packagekit
  84. Requires: cronie
  85. Requires: bsdtar
  86. Requires: scrypt
  87. # for qubes-hcl-report
  88. Requires: dmidecode
  89. Requires: PyQt4
  90. %{?systemd_requires}
  91. # for lvm support
  92. Requires: lvm2-python-libs
  93. Obsoletes: qubes-core-dom0-doc <= 4.0
  94. Provides: qubes-core-dom0-doc
  95. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  96. Obsoletes: preupgrade < 2.0
  97. Provides: preupgrade = 2.0
  98. %define _builddir %(pwd)
  99. %description
  100. The Qubes core files for installation on Dom0.
  101. %prep
  102. # we operate on the current directory, so no need to unpack anything
  103. # symlink is to generate useful debuginfo packages
  104. rm -f %{name}-%{version}
  105. ln -sf . %{name}-%{version}
  106. %setup -T -D
  107. %build
  108. make all
  109. make -C doc PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} man
  110. %install
  111. make install \
  112. DESTDIR=$RPM_BUILD_ROOT \
  113. UNITDIR=%{_unitdir} \
  114. PYTHON_SITEPATH=%{python3_sitelib} \
  115. SYSCONFDIR=%{_sysconfdir}
  116. make -C doc DESTDIR=$RPM_BUILD_ROOT \
  117. PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} \
  118. install
  119. mkdir -p $RPM_BUILD_ROOT/etc/qubes/backup
  120. %post
  121. %systemd_post qubes-core.service
  122. %systemd_post qubes-qmemman.service
  123. %systemd_post qubesd.service
  124. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  125. echo 'autoballoon=0' >> /etc/xen/xl.conf
  126. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  127. if [ -e /etc/sysconfig/prelink ]; then
  128. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  129. fi
  130. # Conflicts with libxl stack, so disable it
  131. systemctl --no-reload disable xend.service >/dev/null 2>&1
  132. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  133. systemctl daemon-reload >/dev/null 2>&1 || :
  134. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  135. # echo "Initializing Qubes DB..."
  136. umask 007; sg qubes -c 'qubes-create --offline-mode'
  137. fi
  138. %clean
  139. rm -rf $RPM_BUILD_ROOT
  140. rm -f %{name}-%{version}
  141. %pre
  142. if ! grep -q ^qubes: /etc/group ; then
  143. groupadd qubes
  144. fi
  145. %triggerin -- xen-runtime
  146. /usr/lib/qubes/fix-dir-perms.sh
  147. %preun
  148. %systemd_preun qubes-core.service
  149. %systemd_preun qubes-qmemman.service
  150. %systemd_preun qubesd.service
  151. if [ "$1" = 0 ] ; then
  152. # no more packages left
  153. service qubes_netvm stop
  154. service qubes_core stop
  155. fi
  156. %postun
  157. %systemd_postun qubes-core.service
  158. %systemd_postun_with_restart qubes-qmemman.service
  159. %systemd_postun_with_restart qubesd.service
  160. if [ "$1" = 0 ] ; then
  161. # no more packages left
  162. chgrp root /etc/xen
  163. chmod 700 /etc/xen
  164. groupdel qubes
  165. fi
  166. %files
  167. %defattr(-,root,root,-)
  168. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  169. %config(noreplace) /etc/dbus-1/system.d/org.qubesos.PolicyAgent.conf
  170. %attr(770,root,qubes) %dir /etc/qubes/backup
  171. /usr/bin/qvm-*
  172. /usr/bin/qubes-*
  173. /usr/bin/qmemmand
  174. /usr/bin/qubesd*
  175. /usr/bin/qrexec-policy
  176. /usr/bin/qrexec-policy-agent
  177. /usr/bin/qrexec-policy-graph
  178. %{_mandir}/man1/qrexec-policy-graph.1*
  179. %{_mandir}/man1/qubes*.1*
  180. %dir %{python3_sitelib}/qubes-*.egg-info
  181. %{python3_sitelib}/qubes-*.egg-info/*
  182. %dir %{python3_sitelib}/qubes
  183. %dir %{python3_sitelib}/qubes/__pycache__
  184. %{python3_sitelib}/qubes/__pycache__/*
  185. %{python3_sitelib}/qubes/__init__.py
  186. %{python3_sitelib}/qubes/app.py
  187. %{python3_sitelib}/qubes/backup.py
  188. %{python3_sitelib}/qubes/config.py
  189. %{python3_sitelib}/qubes/core2migration.py
  190. %{python3_sitelib}/qubes/devices.py
  191. %{python3_sitelib}/qubes/dochelpers.py
  192. %{python3_sitelib}/qubes/events.py
  193. %{python3_sitelib}/qubes/exc.py
  194. %{python3_sitelib}/qubes/firewall.py
  195. %{python3_sitelib}/qubes/log.py
  196. %{python3_sitelib}/qubes/rngdoc.py
  197. %{python3_sitelib}/qubes/tarwriter.py
  198. %{python3_sitelib}/qubes/utils.py
  199. %dir %{python3_sitelib}/qubes/api
  200. %dir %{python3_sitelib}/qubes/api/__pycache__
  201. %{python3_sitelib}/qubes/api/__pycache__/*
  202. %{python3_sitelib}/qubes/api/__init__.py
  203. %{python3_sitelib}/qubes/api/admin.py
  204. %{python3_sitelib}/qubes/api/internal.py
  205. %{python3_sitelib}/qubes/api/misc.py
  206. %dir %{python3_sitelib}/qubes/vm
  207. %dir %{python3_sitelib}/qubes/vm/__pycache__
  208. %{python3_sitelib}/qubes/vm/__pycache__/*
  209. %{python3_sitelib}/qubes/vm/__init__.py
  210. %{python3_sitelib}/qubes/vm/adminvm.py
  211. %{python3_sitelib}/qubes/vm/appvm.py
  212. %{python3_sitelib}/qubes/vm/dispvm.py
  213. %{python3_sitelib}/qubes/vm/qubesvm.py
  214. %{python3_sitelib}/qubes/vm/standalonevm.py
  215. %{python3_sitelib}/qubes/vm/templatevm.py
  216. %dir %{python3_sitelib}/qubes/vm/mix
  217. %dir %{python3_sitelib}/qubes/vm/mix/__pycache__
  218. %{python3_sitelib}/qubes/vm/mix/__pycache__/*
  219. %{python3_sitelib}/qubes/vm/mix/__init__.py
  220. %{python3_sitelib}/qubes/vm/mix/net.py
  221. %dir %{python3_sitelib}/qubes/storage
  222. %dir %{python3_sitelib}/qubes/storage/__pycache__
  223. %{python3_sitelib}/qubes/storage/__pycache__/*
  224. %{python3_sitelib}/qubes/storage/__init__.py
  225. %{python3_sitelib}/qubes/storage/file.py
  226. %{python3_sitelib}/qubes/storage/kernels.py
  227. %{python3_sitelib}/qubes/storage/lvm.py
  228. %dir %{python3_sitelib}/qubes/tools
  229. %dir %{python3_sitelib}/qubes/tools/__pycache__
  230. %{python3_sitelib}/qubes/tools/__pycache__/*
  231. %{python3_sitelib}/qubes/tools/__init__.py
  232. %{python3_sitelib}/qubes/tools/qmemmand.py
  233. %{python3_sitelib}/qubes/tools/qubes_create.py
  234. %{python3_sitelib}/qubes/tools/qubesd.py
  235. %{python3_sitelib}/qubes/tools/qubesd_query.py
  236. %dir %{python3_sitelib}/qubes/ext
  237. %dir %{python3_sitelib}/qubes/ext/__pycache__
  238. %{python3_sitelib}/qubes/ext/__pycache__/*
  239. %{python3_sitelib}/qubes/ext/__init__.py
  240. %{python3_sitelib}/qubes/ext/admin.py
  241. %{python3_sitelib}/qubes/ext/block.py
  242. %{python3_sitelib}/qubes/ext/core_features.py
  243. %{python3_sitelib}/qubes/ext/gui.py
  244. %{python3_sitelib}/qubes/ext/pci.py
  245. %{python3_sitelib}/qubes/ext/qubesmanager.py
  246. %{python3_sitelib}/qubes/ext/r3compatibility.py
  247. %{python3_sitelib}/qubes/ext/services.py
  248. %dir %{python3_sitelib}/qubes/tests
  249. %dir %{python3_sitelib}/qubes/tests/__pycache__
  250. %{python3_sitelib}/qubes/tests/__pycache__/*
  251. %{python3_sitelib}/qubes/tests/__init__.py
  252. %{python3_sitelib}/qubes/tests/run.py
  253. %{python3_sitelib}/qubes/tests/extra.py
  254. %{python3_sitelib}/qubes/tests/api.py
  255. %{python3_sitelib}/qubes/tests/api_admin.py
  256. %{python3_sitelib}/qubes/tests/api_misc.py
  257. %{python3_sitelib}/qubes/tests/app.py
  258. %{python3_sitelib}/qubes/tests/devices.py
  259. %{python3_sitelib}/qubes/tests/devices_block.py
  260. %{python3_sitelib}/qubes/tests/events.py
  261. %{python3_sitelib}/qubes/tests/ext.py
  262. %{python3_sitelib}/qubes/tests/firewall.py
  263. %{python3_sitelib}/qubes/tests/init.py
  264. %{python3_sitelib}/qubes/tests/storage.py
  265. %{python3_sitelib}/qubes/tests/storage_file.py
  266. %{python3_sitelib}/qubes/tests/storage_kernels.py
  267. %{python3_sitelib}/qubes/tests/storage_lvm.py
  268. %{python3_sitelib}/qubes/tests/tarwriter.py
  269. %dir %{python3_sitelib}/qubes/tests/vm
  270. %dir %{python3_sitelib}/qubes/tests/vm/__pycache__
  271. %{python3_sitelib}/qubes/tests/vm/__pycache__/*
  272. %{python3_sitelib}/qubes/tests/vm/__init__.py
  273. %{python3_sitelib}/qubes/tests/vm/init.py
  274. %{python3_sitelib}/qubes/tests/vm/adminvm.py
  275. %{python3_sitelib}/qubes/tests/vm/appvm.py
  276. %{python3_sitelib}/qubes/tests/vm/dispvm.py
  277. %{python3_sitelib}/qubes/tests/vm/qubesvm.py
  278. %dir %{python3_sitelib}/qubes/tests/vm/mix
  279. %dir %{python3_sitelib}/qubes/tests/vm/mix/__pycache__
  280. %{python3_sitelib}/qubes/tests/vm/mix/__pycache__/*
  281. %{python3_sitelib}/qubes/tests/vm/mix/__init__.py
  282. %{python3_sitelib}/qubes/tests/vm/mix/net.py
  283. %dir %{python3_sitelib}/qubes/tests/tools
  284. %dir %{python3_sitelib}/qubes/tests/tools/__pycache__
  285. %{python3_sitelib}/qubes/tests/tools/__pycache__/*
  286. %{python3_sitelib}/qubes/tests/tools/__init__.py
  287. %dir %{python3_sitelib}/qubes/tests/integ
  288. %dir %{python3_sitelib}/qubes/tests/integ/__pycache__
  289. %{python3_sitelib}/qubes/tests/integ/__pycache__/*
  290. %{python3_sitelib}/qubes/tests/integ/__init__.py
  291. %{python3_sitelib}/qubes/tests/integ/backup.py
  292. %{python3_sitelib}/qubes/tests/integ/backupcompatibility.py
  293. %{python3_sitelib}/qubes/tests/integ/basic.py
  294. %{python3_sitelib}/qubes/tests/integ/devices_pci.py
  295. %{python3_sitelib}/qubes/tests/integ/dispvm.py
  296. %{python3_sitelib}/qubes/tests/integ/dom0_update.py
  297. %{python3_sitelib}/qubes/tests/integ/network.py
  298. %{python3_sitelib}/qubes/tests/integ/storage.py
  299. %{python3_sitelib}/qubes/tests/integ/vm_qrexec_gui.py
  300. %dir %{python3_sitelib}/qubes/tests/integ/tools
  301. %dir %{python3_sitelib}/qubes/tests/integ/tools/__pycache__
  302. %{python3_sitelib}/qubes/tests/integ/tools/__pycache__/*
  303. %{python3_sitelib}/qubes/tests/integ/tools/__init__.py
  304. %{python3_sitelib}/qubes/tests/integ/tools/qubes_create.py
  305. %dir %{python3_sitelib}/qubes/qmemman
  306. %dir %{python3_sitelib}/qubes/qmemman/__pycache__
  307. %{python3_sitelib}/qubes/qmemman/__pycache__/*
  308. %{python3_sitelib}/qubes/qmemman/__init__.py
  309. %{python3_sitelib}/qubes/qmemman/algo.py
  310. %{python3_sitelib}/qubes/qmemman/client.py
  311. %dir %{python3_sitelib}/qubespolicy
  312. %dir %{python3_sitelib}/qubespolicy/__pycache__
  313. %{python3_sitelib}/qubespolicy/__pycache__/*
  314. %{python3_sitelib}/qubespolicy/__init__.py
  315. %{python3_sitelib}/qubespolicy/cli.py
  316. %{python3_sitelib}/qubespolicy/agent.py
  317. %{python3_sitelib}/qubespolicy/gtkhelpers.py
  318. %{python3_sitelib}/qubespolicy/policycreateconfirmation.py
  319. %{python3_sitelib}/qubespolicy/rpcconfirmation.py
  320. %{python3_sitelib}/qubespolicy/utils.py
  321. %{python3_sitelib}/qubespolicy/graph.py
  322. %dir %{python3_sitelib}/qubespolicy/tests
  323. %dir %{python3_sitelib}/qubespolicy/tests/__pycache__
  324. %{python3_sitelib}/qubespolicy/tests/__pycache__/*
  325. %{python3_sitelib}/qubespolicy/tests/__init__.py
  326. %{python3_sitelib}/qubespolicy/tests/cli.py
  327. %{python3_sitelib}/qubespolicy/tests/gtkhelpers.py
  328. %{python3_sitelib}/qubespolicy/tests/rpcconfirmation.py
  329. %dir %{python3_sitelib}/qubespolicy/glade
  330. %{python3_sitelib}/qubespolicy/glade/PolicyCreateConfirmationWindow.glade
  331. %{python3_sitelib}/qubespolicy/glade/RPCConfirmationWindow.glade
  332. /usr/lib/qubes/cleanup-dispvms
  333. /usr/lib/qubes/fix-dir-perms.sh
  334. /usr/lib/qubes/startup-misc.sh
  335. /usr/libexec/qubes/qubesd-query-fast
  336. %{_unitdir}/lvm2-pvscan@.service.d/30_qubes.conf
  337. %{_unitdir}/qubes-core.service
  338. %{_unitdir}/qubes-qmemman.service
  339. %{_unitdir}/qubes-vm@.service
  340. %{_unitdir}/qubesd.service
  341. %{_unitdir}/qubes-reload-firewall@.service
  342. %{_unitdir}/qubes-reload-firewall@.timer
  343. %attr(2770,root,qubes) %dir /var/lib/qubes
  344. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  345. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  346. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  347. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  348. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  349. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  350. /usr/share/qubes/templates/libvirt/xen.xml
  351. /usr/share/qubes/templates/libvirt/devices/block.xml
  352. /usr/share/qubes/templates/libvirt/devices/pci.xml
  353. /usr/share/qubes/templates/libvirt/devices/net.xml
  354. /usr/lib/tmpfiles.d/qubes.conf
  355. /etc/xen/scripts/block-snapshot
  356. /etc/xen/scripts/block-origin
  357. /etc/xen/scripts/vif-route-qubes
  358. %attr(2775,root,qubes) %dir /etc/qubes-rpc/policy
  359. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/admin.*
  360. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/include/admin-local-ro
  361. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/include/admin-local-rwx
  362. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/include/admin-global-ro
  363. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/include/admin-global-rwx
  364. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  365. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  366. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  367. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  368. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  369. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  370. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  371. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenURL
  372. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  373. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMRootShell
  374. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.UpdatesProxy
  375. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetDate
  376. /etc/qubes-rpc/admin.*
  377. /etc/qubes-rpc/qubes.FeaturesRequest
  378. /etc/qubes-rpc/qubes.GetRandomizedTime
  379. /etc/qubes-rpc/qubes.NotifyTools
  380. /etc/qubes-rpc/qubes.NotifyUpdates
  381. %attr(2770,root,qubes) %dir /var/log/qubes
  382. %attr(0770,root,qubes) %dir /var/run/qubes
  383. /etc/xdg/autostart/qrexec-policy-agent.desktop
  384. /usr/share/doc/qubes/relaxng/*.rng