core-dom0.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. #%{!?python3_sitelib: %define python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(False)")}
  26. %{!?version: %define version %(cat version)}
  27. # debug_package hack should be removed when BuildArch:noarch is enabled below
  28. %define debug_package %{nil}
  29. %define _dracutmoddir /usr/lib/dracut/modules.d
  30. %if %{fedora} < 17
  31. %define _dracutmoddir /usr/share/dracut/modules.d
  32. %endif
  33. Name: qubes-core-dom0
  34. Version: %{version}
  35. Release: 1%{dist}
  36. Summary: The Qubes core files (Dom0-side)
  37. Group: Qubes
  38. Vendor: Invisible Things Lab
  39. License: GPL
  40. URL: http://www.qubes-os.org
  41. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  42. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  43. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  44. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  45. AutoReq: no
  46. # FIXME: Enable this and disable debug_package
  47. #BuildArch: noarch
  48. BuildRequires: ImageMagick
  49. BuildRequires: systemd-units
  50. BuildRequires: python3-devel
  51. # for building documentation
  52. BuildRequires: python3-sphinx
  53. BuildRequires: libvirt-python3
  54. BuildRequires: python3-dbus
  55. Requires(post): systemd-units
  56. Requires(preun): systemd-units
  57. Requires(postun): systemd-units
  58. Requires: python3
  59. #Requires: python3-aiofiles
  60. Requires: python3-docutils
  61. Requires: python3-jinja2
  62. Requires: python3-lxml
  63. Requires: python3-pydbus
  64. Requires: python3-qubesdb
  65. Requires: python3-setuptools
  66. Requires: python3-xen
  67. Requires: libvirt-python3
  68. Requires: pciutils
  69. Requires: qubes-core-dom0-linux >= 3.1.8
  70. Requires: qubes-core-dom0-doc
  71. Requires: qubes-db-dom0
  72. # TODO: R: qubes-gui-dom0 >= 2.1.11
  73. Conflicts: qubes-gui-dom0 < 1.1.13
  74. %if x%{?backend_vmm} == xxen
  75. Requires: xen-runtime
  76. Requires: xen-hvm
  77. Requires: libvirt-daemon-xen >= 1.2.20-6
  78. %endif
  79. Requires: createrepo
  80. Requires: gnome-packagekit
  81. Requires: cronie
  82. Requires: bsdtar
  83. Requires: scrypt
  84. # for qubes-hcl-report
  85. Requires: dmidecode
  86. Requires: PyQt4
  87. # for lvm support
  88. Requires: lvm2-python-libs
  89. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  90. Obsoletes: preupgrade < 2.0
  91. Provides: preupgrade = 2.0
  92. %define _builddir %(pwd)
  93. %description
  94. The Qubes core files for installation on Dom0.
  95. %prep
  96. # we operate on the current directory, so no need to unpack anything
  97. # symlink is to generate useful debuginfo packages
  98. rm -f %{name}-%{version}
  99. ln -sf . %{name}-%{version}
  100. %setup -T -D
  101. %build
  102. make all
  103. %install
  104. make install \
  105. DESTDIR=$RPM_BUILD_ROOT \
  106. UNITDIR=%{_unitdir} \
  107. PYTHON_SITEPATH=%{python3_sitelib} \
  108. SYSCONFDIR=%{_sysconfdir}
  109. %post
  110. # Create NetworkManager configuration if we do not have it
  111. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  112. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  113. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  114. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  115. fi
  116. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  117. echo 'autoballoon=0' >> /etc/xen/xl.conf
  118. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  119. if [ -e /etc/sysconfig/prelink ]; then
  120. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  121. fi
  122. systemctl --no-reload enable qubes-core.service >/dev/null 2>&1
  123. systemctl --no-reload enable qubes-netvm.service >/dev/null 2>&1
  124. # Conflicts with libxl stack, so disable it
  125. systemctl --no-reload disable xend.service >/dev/null 2>&1
  126. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  127. systemctl daemon-reload >/dev/null 2>&1 || :
  128. HAD_SYSCONFIG_NETWORK=yes
  129. if ! [ -e /etc/sysconfig/network ]; then
  130. HAD_SYSCONFIG_NETWORK=no
  131. # supplant empty one so NetworkManager init script does not complain
  132. touch /etc/sysconfig/network
  133. fi
  134. # Load evtchn module - xenstored needs it
  135. modprobe evtchn 2> /dev/null || modprobe xen-evtchn
  136. service xenstored start
  137. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  138. # echo "Initializing Qubes DB..."
  139. umask 007; sg qubes -c 'qubes-create --offline-mode'
  140. qubes-prefs --force-root --offline-mode default-kernel `ls /var/lib/qubes/vm-kernels|head -n 1` 2> /dev/null
  141. fi
  142. # Because we now have an installer
  143. # this script is always executed during upgrade
  144. # and we decided not to restart core during upgrade
  145. #service qubes_core start
  146. if [ "x"$HAD_SYSCONFIG_NETWORK = "xno" ]; then
  147. rm -f /etc/sysconfig/network
  148. fi
  149. %clean
  150. rm -rf $RPM_BUILD_ROOT
  151. rm -f %{name}-%{version}
  152. %pre
  153. if ! grep -q ^qubes: /etc/group ; then
  154. groupadd qubes
  155. fi
  156. %triggerin -- xen-runtime
  157. /usr/lib/qubes/fix-dir-perms.sh
  158. %preun
  159. if [ "$1" = 0 ] ; then
  160. # no more packages left
  161. service qubes_netvm stop
  162. service qubes_core stop
  163. fi
  164. %postun
  165. if [ "$1" = 0 ] ; then
  166. # no more packages left
  167. chgrp root /etc/xen
  168. chmod 700 /etc/xen
  169. groupdel qubes
  170. fi
  171. %files
  172. %defattr(-,root,root,-)
  173. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  174. %config(noreplace) /etc/dbus-1/system.d/org.qubesos.PolicyAgent.conf
  175. /usr/bin/qvm-*
  176. /usr/bin/qubes-*
  177. /usr/bin/qmemmand
  178. /usr/bin/qubesd*
  179. /usr/bin/qrexec-policy
  180. /usr/bin/qrexec-policy-agent
  181. %dir %{python3_sitelib}/qubes-*.egg-info
  182. %{python3_sitelib}/qubes-*.egg-info/*
  183. %dir %{python3_sitelib}/qubes
  184. %dir %{python3_sitelib}/qubes/__pycache__
  185. %{python3_sitelib}/qubes/__pycache__/*
  186. %{python3_sitelib}/qubes/__init__.py
  187. %{python3_sitelib}/qubes/app.py
  188. %{python3_sitelib}/qubes/backup.py
  189. %{python3_sitelib}/qubes/config.py
  190. %{python3_sitelib}/qubes/core2migration.py
  191. %{python3_sitelib}/qubes/devices.py
  192. %{python3_sitelib}/qubes/dochelpers.py
  193. %{python3_sitelib}/qubes/events.py
  194. %{python3_sitelib}/qubes/exc.py
  195. %{python3_sitelib}/qubes/firewall.py
  196. %{python3_sitelib}/qubes/log.py
  197. %{python3_sitelib}/qubes/mgmt.py
  198. %{python3_sitelib}/qubes/mgmtinternal.py
  199. %{python3_sitelib}/qubes/rngdoc.py
  200. %{python3_sitelib}/qubes/tarwriter.py
  201. %{python3_sitelib}/qubes/utils.py
  202. %dir %{python3_sitelib}/qubes/vm
  203. %dir %{python3_sitelib}/qubes/vm/__pycache__
  204. %{python3_sitelib}/qubes/vm/__pycache__/*
  205. %{python3_sitelib}/qubes/vm/__init__.py
  206. %{python3_sitelib}/qubes/vm/adminvm.py
  207. %{python3_sitelib}/qubes/vm/appvm.py
  208. %{python3_sitelib}/qubes/vm/dispvm.py
  209. %{python3_sitelib}/qubes/vm/qubesvm.py
  210. %{python3_sitelib}/qubes/vm/standalonevm.py
  211. %{python3_sitelib}/qubes/vm/templatevm.py
  212. %dir %{python3_sitelib}/qubes/vm/mix
  213. %dir %{python3_sitelib}/qubes/vm/mix/__pycache__
  214. %{python3_sitelib}/qubes/vm/mix/__pycache__/*
  215. %{python3_sitelib}/qubes/vm/mix/__init__.py
  216. %{python3_sitelib}/qubes/vm/mix/net.py
  217. %dir %{python3_sitelib}/qubes/storage
  218. %dir %{python3_sitelib}/qubes/storage/__pycache__
  219. %{python3_sitelib}/qubes/storage/__pycache__/*
  220. %{python3_sitelib}/qubes/storage/__init__.py
  221. %{python3_sitelib}/qubes/storage/file.py
  222. %{python3_sitelib}/qubes/storage/domain.py
  223. %{python3_sitelib}/qubes/storage/kernels.py
  224. %{python3_sitelib}/qubes/storage/lvm.py
  225. %dir %{python3_sitelib}/qubes/tools
  226. %dir %{python3_sitelib}/qubes/tools/__pycache__
  227. %{python3_sitelib}/qubes/tools/__pycache__/*
  228. %{python3_sitelib}/qubes/tools/__init__.py
  229. %{python3_sitelib}/qubes/tools/qmemmand.py
  230. %{python3_sitelib}/qubes/tools/qubes_create.py
  231. %{python3_sitelib}/qubes/tools/qubesd.py
  232. %{python3_sitelib}/qubes/tools/qubesd_query.py
  233. %{python3_sitelib}/qubes/tools/qvm_backup.py
  234. %{python3_sitelib}/qubes/tools/qvm_backup_restore.py
  235. %{python3_sitelib}/qubes/tools/qvm_template_postprocess.py
  236. %dir %{python3_sitelib}/qubes/ext
  237. %dir %{python3_sitelib}/qubes/ext/__pycache__
  238. %{python3_sitelib}/qubes/ext/__pycache__/*
  239. %{python3_sitelib}/qubes/ext/__init__.py
  240. %{python3_sitelib}/qubes/ext/gui.py
  241. %{python3_sitelib}/qubes/ext/pci.py
  242. %{python3_sitelib}/qubes/ext/qubesmanager.py
  243. %{python3_sitelib}/qubes/ext/r3compatibility.py
  244. %dir %{python3_sitelib}/qubes/tests
  245. %dir %{python3_sitelib}/qubes/tests/__pycache__
  246. %{python3_sitelib}/qubes/tests/__pycache__/*
  247. %{python3_sitelib}/qubes/tests/__init__.py
  248. %{python3_sitelib}/qubes/tests/run.py
  249. %{python3_sitelib}/qubes/tests/extra.py
  250. %{python3_sitelib}/qubes/tests/app.py
  251. %{python3_sitelib}/qubes/tests/devices.py
  252. %{python3_sitelib}/qubes/tests/events.py
  253. %{python3_sitelib}/qubes/tests/firewall.py
  254. %{python3_sitelib}/qubes/tests/init.py
  255. %{python3_sitelib}/qubes/tests/mgmt.py
  256. %{python3_sitelib}/qubes/tests/storage.py
  257. %{python3_sitelib}/qubes/tests/storage_file.py
  258. %{python3_sitelib}/qubes/tests/storage_lvm.py
  259. %{python3_sitelib}/qubes/tests/tarwriter.py
  260. %dir %{python3_sitelib}/qubes/tests/vm
  261. %dir %{python3_sitelib}/qubes/tests/vm/__pycache__
  262. %{python3_sitelib}/qubes/tests/vm/__pycache__/*
  263. %{python3_sitelib}/qubes/tests/vm/__init__.py
  264. %{python3_sitelib}/qubes/tests/vm/init.py
  265. %{python3_sitelib}/qubes/tests/vm/adminvm.py
  266. %{python3_sitelib}/qubes/tests/vm/qubesvm.py
  267. %dir %{python3_sitelib}/qubes/tests/vm/mix
  268. %dir %{python3_sitelib}/qubes/tests/vm/mix/__pycache__
  269. %{python3_sitelib}/qubes/tests/vm/mix/__pycache__/*
  270. %{python3_sitelib}/qubes/tests/vm/mix/__init__.py
  271. %{python3_sitelib}/qubes/tests/vm/mix/net.py
  272. %dir %{python3_sitelib}/qubes/tests/tools
  273. %dir %{python3_sitelib}/qubes/tests/tools/__pycache__
  274. %{python3_sitelib}/qubes/tests/tools/__pycache__/*
  275. %{python3_sitelib}/qubes/tests/tools/__init__.py
  276. %{python3_sitelib}/qubes/tests/tools/qubesd.py
  277. %dir %{python3_sitelib}/qubes/tests/integ
  278. %dir %{python3_sitelib}/qubes/tests/integ/__pycache__
  279. %{python3_sitelib}/qubes/tests/integ/__pycache__/*
  280. %{python3_sitelib}/qubes/tests/integ/__init__.py
  281. %{python3_sitelib}/qubes/tests/integ/backup.py
  282. %{python3_sitelib}/qubes/tests/integ/backupcompatibility.py
  283. %{python3_sitelib}/qubes/tests/integ/basic.py
  284. %{python3_sitelib}/qubes/tests/integ/devices_pci.py
  285. %{python3_sitelib}/qubes/tests/integ/dispvm.py
  286. %{python3_sitelib}/qubes/tests/integ/dom0_update.py
  287. %{python3_sitelib}/qubes/tests/integ/network.py
  288. %{python3_sitelib}/qubes/tests/integ/storage.py
  289. %{python3_sitelib}/qubes/tests/integ/vm_qrexec_gui.py
  290. %dir %{python3_sitelib}/qubes/tests/integ/tools
  291. %dir %{python3_sitelib}/qubes/tests/integ/tools/__pycache__
  292. %{python3_sitelib}/qubes/tests/integ/tools/__pycache__/*
  293. %{python3_sitelib}/qubes/tests/integ/tools/__init__.py
  294. %{python3_sitelib}/qubes/tests/integ/tools/qubes_create.py
  295. %dir %{python3_sitelib}/qubes/qmemman
  296. %dir %{python3_sitelib}/qubes/qmemman/__pycache__
  297. %{python3_sitelib}/qubes/qmemman/__pycache__/*
  298. %{python3_sitelib}/qubes/qmemman/__init__.py
  299. %{python3_sitelib}/qubes/qmemman/algo.py
  300. %{python3_sitelib}/qubes/qmemman/client.py
  301. %dir %{python3_sitelib}/qubespolicy
  302. %dir %{python3_sitelib}/qubespolicy/__pycache__
  303. %{python3_sitelib}/qubespolicy/__pycache__/*
  304. %{python3_sitelib}/qubespolicy/__init__.py
  305. %{python3_sitelib}/qubespolicy/cli.py
  306. %{python3_sitelib}/qubespolicy/agent.py
  307. %{python3_sitelib}/qubespolicy/gtkhelpers.py
  308. %{python3_sitelib}/qubespolicy/rpcconfirmation.py
  309. %{python3_sitelib}/qubespolicy/utils.py
  310. %dir %{python3_sitelib}/qubespolicy/tests
  311. %dir %{python3_sitelib}/qubespolicy/tests/__pycache__
  312. %{python3_sitelib}/qubespolicy/tests/__pycache__/*
  313. %{python3_sitelib}/qubespolicy/tests/__init__.py
  314. %{python3_sitelib}/qubespolicy/tests/gtkhelpers.py
  315. %{python3_sitelib}/qubespolicy/tests/rpcconfirmation.py
  316. %dir %{python3_sitelib}/qubespolicy/glade
  317. %{python3_sitelib}/qubespolicy/glade/RPCConfirmationWindow.glade
  318. /usr/lib/qubes/cleanup-dispvms
  319. /usr/lib/qubes/block-cleaner-daemon.py*
  320. /usr/lib/qubes/fix-dir-perms.sh
  321. /usr/lib/qubes/startup-misc.sh
  322. /usr/libexec/qubes/qubes-notify-tools
  323. /usr/libexec/qubes/qubes-notify-updates
  324. %{_unitdir}/qubes-block-cleaner.service
  325. %{_unitdir}/qubes-core.service
  326. %{_unitdir}/qubes-netvm.service
  327. %{_unitdir}/qubes-qmemman.service
  328. %{_unitdir}/qubes-vm@.service
  329. %{_unitdir}/qubesd.service
  330. %{_unitdir}/qubes-reload-firewall@.service
  331. %{_unitdir}/qubes-reload-firewall@.timer
  332. %attr(2770,root,qubes) %dir /var/lib/qubes
  333. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  334. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  335. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  336. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  337. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  338. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  339. /usr/share/qubes/templates/libvirt/xen.xml
  340. /usr/share/qubes/templates/libvirt/devices/pci.xml
  341. /usr/share/qubes/templates/libvirt/devices/net.xml
  342. /usr/lib/tmpfiles.d/qubes.conf
  343. /etc/xen/scripts/block-snapshot
  344. /etc/xen/scripts/block-origin
  345. /etc/xen/scripts/vif-route-qubes
  346. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  347. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  348. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  349. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  350. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  351. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  352. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  353. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenURL
  354. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  355. /etc/qubes-rpc/qubes.FeaturesRequest
  356. /etc/qubes-rpc/qubes.GetRandomizedTime
  357. /etc/qubes-rpc/qubes.NotifyTools
  358. /etc/qubes-rpc/qubes.NotifyUpdates
  359. %attr(2770,root,qubes) %dir /var/log/qubes
  360. %attr(0770,root,qubes) %dir /var/run/qubes
  361. /etc/xdg/autostart/qrexec-policy-agent.desktop
  362. /usr/share/doc/qubes/relaxng/*.rng