core-dom0.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. #%{!?python3_sitelib: %define python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(False)")}
  26. %{!?version: %define version %(cat version)}
  27. # debug_package hack should be removed when BuildArch:noarch is enabled below
  28. %define debug_package %{nil}
  29. %define _dracutmoddir /usr/lib/dracut/modules.d
  30. %if %{fedora} < 17
  31. %define _dracutmoddir /usr/share/dracut/modules.d
  32. %endif
  33. Name: qubes-core-dom0
  34. Version: %{version}
  35. Release: 1%{dist}
  36. Summary: The Qubes core files (Dom0-side)
  37. Group: Qubes
  38. Vendor: Invisible Things Lab
  39. License: GPL
  40. URL: http://www.qubes-os.org
  41. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  42. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  43. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  44. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  45. AutoReq: no
  46. # FIXME: Enable this and disable debug_package
  47. #BuildArch: noarch
  48. BuildRequires: ImageMagick
  49. BuildRequires: systemd-units
  50. BuildRequires: python3-devel
  51. # for building documentation
  52. BuildRequires: python3-sphinx
  53. BuildRequires: libvirt-python3
  54. BuildRequires: python3-dbus
  55. Requires(post): systemd-units
  56. Requires(preun): systemd-units
  57. Requires(postun): systemd-units
  58. Requires: python3
  59. #Requires: python3-aiofiles
  60. Requires: python3-docutils
  61. Requires: python3-jinja2
  62. Requires: python3-lxml
  63. Requires: python3-pydbus
  64. Requires: python3-qubesdb
  65. Requires: python3-setuptools
  66. Requires: python3-xen
  67. Requires: libvirt-python3
  68. Requires: pciutils
  69. Requires: qubes-core-dom0-linux >= 3.1.8
  70. Requires: qubes-core-dom0-doc
  71. Requires: qubes-db-dom0
  72. # TODO: R: qubes-gui-dom0 >= 2.1.11
  73. Conflicts: qubes-gui-dom0 < 1.1.13
  74. %if x%{?backend_vmm} == xxen
  75. Requires: xen-runtime
  76. Requires: xen-hvm
  77. Requires: libvirt-daemon-xen >= 1.2.20-6
  78. %endif
  79. Requires: createrepo
  80. Requires: gnome-packagekit
  81. Requires: cronie
  82. Requires: bsdtar
  83. Requires: scrypt
  84. # for qubes-hcl-report
  85. Requires: dmidecode
  86. Requires: PyQt4
  87. # for lvm support
  88. Requires: lvm2-python-libs
  89. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  90. Obsoletes: preupgrade < 2.0
  91. Provides: preupgrade = 2.0
  92. %define _builddir %(pwd)
  93. %description
  94. The Qubes core files for installation on Dom0.
  95. %prep
  96. # we operate on the current directory, so no need to unpack anything
  97. # symlink is to generate useful debuginfo packages
  98. rm -f %{name}-%{version}
  99. ln -sf . %{name}-%{version}
  100. %setup -T -D
  101. %build
  102. make all
  103. %install
  104. make install \
  105. DESTDIR=$RPM_BUILD_ROOT \
  106. UNITDIR=%{_unitdir} \
  107. PYTHON_SITEPATH=%{python3_sitelib} \
  108. SYSCONFDIR=%{_sysconfdir}
  109. %post
  110. # Create NetworkManager configuration if we do not have it
  111. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  112. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  113. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  114. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  115. fi
  116. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  117. echo 'autoballoon=0' >> /etc/xen/xl.conf
  118. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  119. if [ -e /etc/sysconfig/prelink ]; then
  120. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  121. fi
  122. systemctl --no-reload enable qubes-core.service >/dev/null 2>&1
  123. systemctl --no-reload enable qubes-netvm.service >/dev/null 2>&1
  124. systemctl --no-reload enable qubes-setupdvm.service >/dev/null 2>&1
  125. # Conflicts with libxl stack, so disable it
  126. systemctl --no-reload disable xend.service >/dev/null 2>&1
  127. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  128. systemctl daemon-reload >/dev/null 2>&1 || :
  129. HAD_SYSCONFIG_NETWORK=yes
  130. if ! [ -e /etc/sysconfig/network ]; then
  131. HAD_SYSCONFIG_NETWORK=no
  132. # supplant empty one so NetworkManager init script does not complain
  133. touch /etc/sysconfig/network
  134. fi
  135. # Load evtchn module - xenstored needs it
  136. modprobe evtchn 2> /dev/null || modprobe xen-evtchn
  137. service xenstored start
  138. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  139. # echo "Initializing Qubes DB..."
  140. umask 007; sg qubes -c 'qubes-create --offline-mode'
  141. qubes-prefs --force-root --offline-mode default-kernel `ls /var/lib/qubes/vm-kernels|head -n 1` 2> /dev/null
  142. fi
  143. # Because we now have an installer
  144. # this script is always executed during upgrade
  145. # and we decided not to restart core during upgrade
  146. #service qubes_core start
  147. if [ "x"$HAD_SYSCONFIG_NETWORK = "xno" ]; then
  148. rm -f /etc/sysconfig/network
  149. fi
  150. %clean
  151. rm -rf $RPM_BUILD_ROOT
  152. rm -f %{name}-%{version}
  153. %pre
  154. if ! grep -q ^qubes: /etc/group ; then
  155. groupadd qubes
  156. fi
  157. %triggerin -- xen-runtime
  158. /usr/lib/qubes/fix-dir-perms.sh
  159. %preun
  160. if [ "$1" = 0 ] ; then
  161. # no more packages left
  162. service qubes_netvm stop
  163. service qubes_core stop
  164. fi
  165. %postun
  166. if [ "$1" = 0 ] ; then
  167. # no more packages left
  168. chgrp root /etc/xen
  169. chmod 700 /etc/xen
  170. groupdel qubes
  171. fi
  172. %files
  173. %defattr(-,root,root,-)
  174. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  175. %config(noreplace) /etc/dbus-1/system.d/org.qubesos.PolicyAgent.conf
  176. /usr/bin/qvm-*
  177. /usr/bin/qubes-*
  178. /usr/bin/qmemmand
  179. /usr/bin/qubesd*
  180. /usr/bin/qrexec-policy
  181. /usr/bin/qrexec-policy-agent
  182. %dir %{python3_sitelib}/qubes-*.egg-info
  183. %{python3_sitelib}/qubes-*.egg-info/*
  184. %dir %{python3_sitelib}/qubes
  185. %dir %{python3_sitelib}/qubes/__pycache__
  186. %{python3_sitelib}/qubes/__pycache__/*
  187. %{python3_sitelib}/qubes/__init__.py
  188. %{python3_sitelib}/qubes/app.py
  189. %{python3_sitelib}/qubes/backup.py
  190. %{python3_sitelib}/qubes/config.py
  191. %{python3_sitelib}/qubes/core2migration.py
  192. %{python3_sitelib}/qubes/devices.py
  193. %{python3_sitelib}/qubes/dochelpers.py
  194. %{python3_sitelib}/qubes/events.py
  195. %{python3_sitelib}/qubes/exc.py
  196. %{python3_sitelib}/qubes/firewall.py
  197. %{python3_sitelib}/qubes/log.py
  198. %{python3_sitelib}/qubes/mgmt.py
  199. %{python3_sitelib}/qubes/mgmtinternal.py
  200. %{python3_sitelib}/qubes/rngdoc.py
  201. %{python3_sitelib}/qubes/tarwriter.py
  202. %{python3_sitelib}/qubes/utils.py
  203. %dir %{python3_sitelib}/qubes/vm
  204. %dir %{python3_sitelib}/qubes/vm/__pycache__
  205. %{python3_sitelib}/qubes/vm/__pycache__/*
  206. %{python3_sitelib}/qubes/vm/__init__.py
  207. %{python3_sitelib}/qubes/vm/adminvm.py
  208. %{python3_sitelib}/qubes/vm/appvm.py
  209. %{python3_sitelib}/qubes/vm/dispvm.py
  210. %{python3_sitelib}/qubes/vm/qubesvm.py
  211. %{python3_sitelib}/qubes/vm/standalonevm.py
  212. %{python3_sitelib}/qubes/vm/templatevm.py
  213. %dir %{python3_sitelib}/qubes/vm/mix
  214. %dir %{python3_sitelib}/qubes/vm/mix/__pycache__
  215. %{python3_sitelib}/qubes/vm/mix/__pycache__/*
  216. %{python3_sitelib}/qubes/vm/mix/__init__.py
  217. %{python3_sitelib}/qubes/vm/mix/net.py
  218. %dir %{python3_sitelib}/qubes/storage
  219. %dir %{python3_sitelib}/qubes/storage/__pycache__
  220. %{python3_sitelib}/qubes/storage/__pycache__/*
  221. %{python3_sitelib}/qubes/storage/__init__.py
  222. %{python3_sitelib}/qubes/storage/file.py
  223. %{python3_sitelib}/qubes/storage/domain.py
  224. %{python3_sitelib}/qubes/storage/kernels.py
  225. %{python3_sitelib}/qubes/storage/lvm.py
  226. %dir %{python3_sitelib}/qubes/tools
  227. %dir %{python3_sitelib}/qubes/tools/__pycache__
  228. %{python3_sitelib}/qubes/tools/__pycache__/*
  229. %{python3_sitelib}/qubes/tools/__init__.py
  230. %{python3_sitelib}/qubes/tools/qmemmand.py
  231. %{python3_sitelib}/qubes/tools/qubes_create.py
  232. %{python3_sitelib}/qubes/tools/qubes_monitor_layout_notify.py
  233. %{python3_sitelib}/qubes/tools/qubes_prefs.py
  234. %{python3_sitelib}/qubes/tools/qubesd.py
  235. %{python3_sitelib}/qubes/tools/qubesd_query.py
  236. %{python3_sitelib}/qubes/tools/qvm_block.py
  237. %{python3_sitelib}/qubes/tools/qvm_backup.py
  238. %{python3_sitelib}/qubes/tools/qvm_backup_restore.py
  239. %{python3_sitelib}/qubes/tools/qvm_create.py
  240. %{python3_sitelib}/qubes/tools/qvm_device.py
  241. %{python3_sitelib}/qubes/tools/qvm_features.py
  242. %{python3_sitelib}/qubes/tools/qvm_firewall.py
  243. %{python3_sitelib}/qubes/tools/qvm_check.py
  244. %{python3_sitelib}/qubes/tools/qvm_clone.py
  245. %{python3_sitelib}/qubes/tools/qvm_kill.py
  246. %{python3_sitelib}/qubes/tools/qvm_ls.py
  247. %{python3_sitelib}/qubes/tools/qvm_pause.py
  248. %{python3_sitelib}/qubes/tools/qvm_pool.py
  249. %{python3_sitelib}/qubes/tools/qvm_prefs.py
  250. %{python3_sitelib}/qubes/tools/qvm_remove.py
  251. %{python3_sitelib}/qubes/tools/qvm_run.py
  252. %{python3_sitelib}/qubes/tools/qvm_shutdown.py
  253. %{python3_sitelib}/qubes/tools/qvm_start.py
  254. %{python3_sitelib}/qubes/tools/qvm_tags.py
  255. %{python3_sitelib}/qubes/tools/qvm_template_commit.py
  256. %{python3_sitelib}/qubes/tools/qvm_template_postprocess.py
  257. %{python3_sitelib}/qubes/tools/qvm_unpause.py
  258. %dir %{python3_sitelib}/qubes/ext
  259. %dir %{python3_sitelib}/qubes/ext/__pycache__
  260. %{python3_sitelib}/qubes/ext/__pycache__/*
  261. %{python3_sitelib}/qubes/ext/__init__.py
  262. %{python3_sitelib}/qubes/ext/gui.py
  263. %{python3_sitelib}/qubes/ext/pci.py
  264. %{python3_sitelib}/qubes/ext/qubesmanager.py
  265. %{python3_sitelib}/qubes/ext/r3compatibility.py
  266. %dir %{python3_sitelib}/qubes/tests
  267. %dir %{python3_sitelib}/qubes/tests/__pycache__
  268. %{python3_sitelib}/qubes/tests/__pycache__/*
  269. %{python3_sitelib}/qubes/tests/__init__.py
  270. %{python3_sitelib}/qubes/tests/run.py
  271. %{python3_sitelib}/qubes/tests/extra.py
  272. %{python3_sitelib}/qubes/tests/app.py
  273. %{python3_sitelib}/qubes/tests/devices.py
  274. %{python3_sitelib}/qubes/tests/events.py
  275. %{python3_sitelib}/qubes/tests/firewall.py
  276. %{python3_sitelib}/qubes/tests/init.py
  277. %{python3_sitelib}/qubes/tests/mgmt.py
  278. %{python3_sitelib}/qubes/tests/storage.py
  279. %{python3_sitelib}/qubes/tests/storage_file.py
  280. %{python3_sitelib}/qubes/tests/storage_lvm.py
  281. %{python3_sitelib}/qubes/tests/tarwriter.py
  282. %dir %{python3_sitelib}/qubes/tests/vm
  283. %dir %{python3_sitelib}/qubes/tests/vm/__pycache__
  284. %{python3_sitelib}/qubes/tests/vm/__pycache__/*
  285. %{python3_sitelib}/qubes/tests/vm/__init__.py
  286. %{python3_sitelib}/qubes/tests/vm/init.py
  287. %{python3_sitelib}/qubes/tests/vm/adminvm.py
  288. %{python3_sitelib}/qubes/tests/vm/qubesvm.py
  289. %dir %{python3_sitelib}/qubes/tests/vm/mix
  290. %dir %{python3_sitelib}/qubes/tests/vm/mix/__pycache__
  291. %{python3_sitelib}/qubes/tests/vm/mix/__pycache__/*
  292. %{python3_sitelib}/qubes/tests/vm/mix/__init__.py
  293. %{python3_sitelib}/qubes/tests/vm/mix/net.py
  294. %dir %{python3_sitelib}/qubes/tests/tools
  295. %dir %{python3_sitelib}/qubes/tests/tools/__pycache__
  296. %{python3_sitelib}/qubes/tests/tools/__pycache__/*
  297. %{python3_sitelib}/qubes/tests/tools/__init__.py
  298. %{python3_sitelib}/qubes/tests/tools/init.py
  299. %{python3_sitelib}/qubes/tests/tools/qvm_device.py
  300. %{python3_sitelib}/qubes/tests/tools/qvm_firewall.py
  301. %{python3_sitelib}/qubes/tests/tools/qvm_ls.py
  302. %dir %{python3_sitelib}/qubes/tests/integ
  303. %dir %{python3_sitelib}/qubes/tests/integ/__pycache__
  304. %{python3_sitelib}/qubes/tests/integ/__pycache__/*
  305. %{python3_sitelib}/qubes/tests/integ/__init__.py
  306. %{python3_sitelib}/qubes/tests/integ/backup.py
  307. %{python3_sitelib}/qubes/tests/integ/backupcompatibility.py
  308. %{python3_sitelib}/qubes/tests/integ/basic.py
  309. %{python3_sitelib}/qubes/tests/integ/devices_pci.py
  310. %{python3_sitelib}/qubes/tests/integ/dispvm.py
  311. %{python3_sitelib}/qubes/tests/integ/dom0_update.py
  312. %{python3_sitelib}/qubes/tests/integ/network.py
  313. %{python3_sitelib}/qubes/tests/integ/storage.py
  314. %{python3_sitelib}/qubes/tests/integ/vm_qrexec_gui.py
  315. %dir %{python3_sitelib}/qubes/tests/integ/tools
  316. %dir %{python3_sitelib}/qubes/tests/integ/tools/__pycache__
  317. %{python3_sitelib}/qubes/tests/integ/tools/__pycache__/*
  318. %{python3_sitelib}/qubes/tests/integ/tools/__init__.py
  319. %{python3_sitelib}/qubes/tests/integ/tools/qubes_create.py
  320. %{python3_sitelib}/qubes/tests/integ/tools/qvm_features.py*
  321. %{python3_sitelib}/qubes/tests/integ/tools/qvm_firewall.py
  322. %{python3_sitelib}/qubes/tests/integ/tools/qvm_check.py
  323. %{python3_sitelib}/qubes/tests/integ/tools/qvm_prefs.py
  324. %{python3_sitelib}/qubes/tests/integ/tools/qvm_run.py
  325. %dir %{python3_sitelib}/qubes/qmemman
  326. %dir %{python3_sitelib}/qubes/qmemman/__pycache__
  327. %{python3_sitelib}/qubes/qmemman/__pycache__/*
  328. %{python3_sitelib}/qubes/qmemman/__init__.py
  329. %{python3_sitelib}/qubes/qmemman/algo.py
  330. %{python3_sitelib}/qubes/qmemman/client.py
  331. %dir %{python3_sitelib}/qubespolicy
  332. %dir %{python3_sitelib}/qubespolicy/__pycache__
  333. %{python3_sitelib}/qubespolicy/__pycache__/*
  334. %{python3_sitelib}/qubespolicy/__init__.py
  335. %{python3_sitelib}/qubespolicy/cli.py
  336. %{python3_sitelib}/qubespolicy/agent.py
  337. %{python3_sitelib}/qubespolicy/gtkhelpers.py
  338. %{python3_sitelib}/qubespolicy/rpcconfirmation.py
  339. %{python3_sitelib}/qubespolicy/utils.py
  340. %dir %{python3_sitelib}/qubespolicy/tests
  341. %dir %{python3_sitelib}/qubespolicy/tests/__pycache__
  342. %{python3_sitelib}/qubespolicy/tests/__pycache__/*
  343. %{python3_sitelib}/qubespolicy/tests/__init__.py
  344. %{python3_sitelib}/qubespolicy/tests/gtkhelpers.py
  345. %{python3_sitelib}/qubespolicy/tests/rpcconfirmation.py
  346. %dir %{python3_sitelib}/qubespolicy/glade
  347. %{python3_sitelib}/qubespolicy/glade/RPCConfirmationWindow.glade
  348. /usr/lib/qubes/unbind-pci-device.sh
  349. /usr/lib/qubes/cleanup-dispvms
  350. /usr/lib/qubes/qfile-daemon-dvm*
  351. /usr/lib/qubes/block-cleaner-daemon.py*
  352. /usr/lib/qubes/vusb-ctl.py*
  353. /usr/lib/qubes/xl-qvm-usb-attach.py*
  354. /usr/lib/qubes/xl-qvm-usb-detach.py*
  355. /usr/lib/qubes/fix-dir-perms.sh
  356. /usr/lib/qubes/startup-dvm.sh
  357. /usr/lib/qubes/startup-misc.sh
  358. /usr/lib/qubes/prepare-volatile-img.sh
  359. /usr/libexec/qubes/qubes-notify-tools
  360. /usr/libexec/qubes/qubes-notify-updates
  361. %{_unitdir}/qubes-block-cleaner.service
  362. %{_unitdir}/qubes-core.service
  363. %{_unitdir}/qubes-setupdvm.service
  364. %{_unitdir}/qubes-netvm.service
  365. %{_unitdir}/qubes-qmemman.service
  366. %{_unitdir}/qubes-vm@.service
  367. %{_unitdir}/qubesd.service
  368. %{_unitdir}/qubes-reload-firewall@.service
  369. %{_unitdir}/qubes-reload-firewall@.timer
  370. %attr(2770,root,qubes) %dir /var/lib/qubes
  371. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  372. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  373. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  374. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  375. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  376. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  377. /usr/share/qubes/templates/libvirt/xen.xml
  378. /usr/share/qubes/templates/libvirt/devices/pci.xml
  379. /usr/share/qubes/templates/libvirt/devices/net.xml
  380. /usr/lib/tmpfiles.d/qubes.conf
  381. /usr/lib/qubes/qubes-prepare-saved-domain.sh
  382. /usr/lib/qubes/qubes-update-dispvm-savefile-with-progress.sh
  383. /etc/xen/scripts/block.qubes
  384. /etc/xen/scripts/block-snapshot
  385. /etc/xen/scripts/block-origin
  386. /etc/xen/scripts/vif-route-qubes
  387. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  388. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  389. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  390. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  391. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  392. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  393. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  394. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenURL
  395. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  396. /etc/qubes-rpc/qubes.FeaturesRequest
  397. /etc/qubes-rpc/qubes.GetRandomizedTime
  398. /etc/qubes-rpc/qubes.NotifyTools
  399. /etc/qubes-rpc/qubes.NotifyUpdates
  400. %attr(2770,root,qubes) %dir /var/log/qubes
  401. %attr(0770,root,qubes) %dir /var/run/qubes
  402. /etc/xdg/autostart/qubes-guid.desktop
  403. /etc/xdg/autostart/qrexec-policy-agent.desktop
  404. /usr/share/doc/qubes/relaxng/*.rng