core-dom0.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. #%{!?python3_sitelib: %define python3_sitelib %(%{__python3} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(False)")}
  26. %{!?version: %define version %(cat version)}
  27. # debug_package hack should be removed when BuildArch:noarch is enabled below
  28. %define debug_package %{nil}
  29. %define _dracutmoddir /usr/lib/dracut/modules.d
  30. %if %{fedora} < 17
  31. %define _dracutmoddir /usr/share/dracut/modules.d
  32. %endif
  33. Name: qubes-core-dom0
  34. Version: %{version}
  35. Release: 1%{dist}
  36. Summary: The Qubes core files (Dom0-side)
  37. Group: Qubes
  38. Vendor: Invisible Things Lab
  39. License: GPL
  40. URL: http://www.qubes-os.org
  41. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  42. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  43. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  44. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  45. AutoReq: no
  46. # FIXME: Enable this and disable debug_package
  47. #BuildArch: noarch
  48. BuildRequires: ImageMagick
  49. BuildRequires: systemd-units
  50. BuildRequires: python3-devel
  51. # for building documentation
  52. BuildRequires: python3-sphinx
  53. BuildRequires: python3-lxml
  54. BuildRequires: libvirt-python3
  55. BuildRequires: python3-dbus
  56. Requires(post): systemd-units
  57. Requires(preun): systemd-units
  58. Requires(postun): systemd-units
  59. Requires: python3
  60. #Requires: python3-aiofiles
  61. Requires: python3-docutils
  62. Requires: python3-jinja2
  63. Requires: python3-lxml
  64. Requires: python3-pydbus
  65. Requires: python3-qubesdb
  66. Requires: python3-setuptools
  67. Requires: python3-xen
  68. Requires: libvirt-python3
  69. Requires: pciutils
  70. Requires: qubes-core-dom0-linux >= 3.1.8
  71. Requires: qubes-core-dom0-doc
  72. Requires: qubes-db-dom0
  73. # TODO: R: qubes-gui-dom0 >= 2.1.11
  74. Conflicts: qubes-gui-dom0 < 1.1.13
  75. %if x%{?backend_vmm} == xxen
  76. Requires: xen-runtime
  77. Requires: xen-hvm
  78. Requires: libvirt-daemon-xen >= 1.2.20-6
  79. %endif
  80. Requires: createrepo
  81. Requires: gnome-packagekit
  82. Requires: cronie
  83. Requires: bsdtar
  84. Requires: scrypt
  85. # for qubes-hcl-report
  86. Requires: dmidecode
  87. Requires: PyQt4
  88. # for lvm support
  89. Requires: lvm2-python-libs
  90. Obsoletes: qubes-core-dom0-doc <= 4.0
  91. Provides: qubes-core-dom0-doc
  92. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  93. Obsoletes: preupgrade < 2.0
  94. Provides: preupgrade = 2.0
  95. %define _builddir %(pwd)
  96. %description
  97. The Qubes core files for installation on Dom0.
  98. %prep
  99. # we operate on the current directory, so no need to unpack anything
  100. # symlink is to generate useful debuginfo packages
  101. rm -f %{name}-%{version}
  102. ln -sf . %{name}-%{version}
  103. %setup -T -D
  104. %build
  105. make all
  106. make -C doc PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} man
  107. %install
  108. make install \
  109. DESTDIR=$RPM_BUILD_ROOT \
  110. UNITDIR=%{_unitdir} \
  111. PYTHON_SITEPATH=%{python3_sitelib} \
  112. SYSCONFDIR=%{_sysconfdir}
  113. make -C doc DESTDIR=$RPM_BUILD_ROOT \
  114. PYTHON=%{__python3} SPHINXBUILD=sphinx-build-%{python3_version} \
  115. install
  116. %post
  117. # Create NetworkManager configuration if we do not have it
  118. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  119. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  120. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  121. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  122. fi
  123. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  124. echo 'autoballoon=0' >> /etc/xen/xl.conf
  125. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  126. if [ -e /etc/sysconfig/prelink ]; then
  127. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  128. fi
  129. systemctl --no-reload enable qubes-core.service >/dev/null 2>&1
  130. systemctl --no-reload enable qubes-netvm.service >/dev/null 2>&1
  131. # Conflicts with libxl stack, so disable it
  132. systemctl --no-reload disable xend.service >/dev/null 2>&1
  133. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  134. systemctl daemon-reload >/dev/null 2>&1 || :
  135. HAD_SYSCONFIG_NETWORK=yes
  136. if ! [ -e /etc/sysconfig/network ]; then
  137. HAD_SYSCONFIG_NETWORK=no
  138. # supplant empty one so NetworkManager init script does not complain
  139. touch /etc/sysconfig/network
  140. fi
  141. # Load evtchn module - xenstored needs it
  142. modprobe evtchn 2> /dev/null || modprobe xen-evtchn
  143. service xenstored start
  144. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  145. # echo "Initializing Qubes DB..."
  146. umask 007; sg qubes -c 'qubes-create --offline-mode'
  147. qubes-prefs --force-root --offline-mode default-kernel `ls /var/lib/qubes/vm-kernels|head -n 1` 2> /dev/null
  148. fi
  149. # Because we now have an installer
  150. # this script is always executed during upgrade
  151. # and we decided not to restart core during upgrade
  152. #service qubes_core start
  153. if [ "x"$HAD_SYSCONFIG_NETWORK = "xno" ]; then
  154. rm -f /etc/sysconfig/network
  155. fi
  156. %clean
  157. rm -rf $RPM_BUILD_ROOT
  158. rm -f %{name}-%{version}
  159. %pre
  160. if ! grep -q ^qubes: /etc/group ; then
  161. groupadd qubes
  162. fi
  163. %triggerin -- xen-runtime
  164. /usr/lib/qubes/fix-dir-perms.sh
  165. %preun
  166. if [ "$1" = 0 ] ; then
  167. # no more packages left
  168. service qubes_netvm stop
  169. service qubes_core stop
  170. fi
  171. %postun
  172. if [ "$1" = 0 ] ; then
  173. # no more packages left
  174. chgrp root /etc/xen
  175. chmod 700 /etc/xen
  176. groupdel qubes
  177. fi
  178. %files
  179. %defattr(-,root,root,-)
  180. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  181. %config(noreplace) /etc/dbus-1/system.d/org.qubesos.PolicyAgent.conf
  182. /usr/bin/qvm-*
  183. /usr/bin/qubes-*
  184. /usr/bin/qmemmand
  185. /usr/bin/qubesd*
  186. /usr/bin/qrexec-policy
  187. /usr/bin/qrexec-policy-agent
  188. %{_mandir}/man1/qubes*.1*
  189. %dir %{python3_sitelib}/qubes-*.egg-info
  190. %{python3_sitelib}/qubes-*.egg-info/*
  191. %dir %{python3_sitelib}/qubes
  192. %dir %{python3_sitelib}/qubes/__pycache__
  193. %{python3_sitelib}/qubes/__pycache__/*
  194. %{python3_sitelib}/qubes/__init__.py
  195. %{python3_sitelib}/qubes/app.py
  196. %{python3_sitelib}/qubes/backup.py
  197. %{python3_sitelib}/qubes/config.py
  198. %{python3_sitelib}/qubes/core2migration.py
  199. %{python3_sitelib}/qubes/devices.py
  200. %{python3_sitelib}/qubes/dochelpers.py
  201. %{python3_sitelib}/qubes/events.py
  202. %{python3_sitelib}/qubes/exc.py
  203. %{python3_sitelib}/qubes/firewall.py
  204. %{python3_sitelib}/qubes/log.py
  205. %{python3_sitelib}/qubes/rngdoc.py
  206. %{python3_sitelib}/qubes/tarwriter.py
  207. %{python3_sitelib}/qubes/utils.py
  208. %dir %{python3_sitelib}/qubes/api
  209. %dir %{python3_sitelib}/qubes/api/__pycache__
  210. %{python3_sitelib}/qubes/api/__pycache__/*
  211. %{python3_sitelib}/qubes/api/__init__.py
  212. %{python3_sitelib}/qubes/api/internal.py
  213. %{python3_sitelib}/qubes/api/admin.py
  214. %dir %{python3_sitelib}/qubes/vm
  215. %dir %{python3_sitelib}/qubes/vm/__pycache__
  216. %{python3_sitelib}/qubes/vm/__pycache__/*
  217. %{python3_sitelib}/qubes/vm/__init__.py
  218. %{python3_sitelib}/qubes/vm/adminvm.py
  219. %{python3_sitelib}/qubes/vm/appvm.py
  220. %{python3_sitelib}/qubes/vm/dispvm.py
  221. %{python3_sitelib}/qubes/vm/qubesvm.py
  222. %{python3_sitelib}/qubes/vm/standalonevm.py
  223. %{python3_sitelib}/qubes/vm/templatevm.py
  224. %dir %{python3_sitelib}/qubes/vm/mix
  225. %dir %{python3_sitelib}/qubes/vm/mix/__pycache__
  226. %{python3_sitelib}/qubes/vm/mix/__pycache__/*
  227. %{python3_sitelib}/qubes/vm/mix/__init__.py
  228. %{python3_sitelib}/qubes/vm/mix/net.py
  229. %dir %{python3_sitelib}/qubes/storage
  230. %dir %{python3_sitelib}/qubes/storage/__pycache__
  231. %{python3_sitelib}/qubes/storage/__pycache__/*
  232. %{python3_sitelib}/qubes/storage/__init__.py
  233. %{python3_sitelib}/qubes/storage/file.py
  234. %{python3_sitelib}/qubes/storage/domain.py
  235. %{python3_sitelib}/qubes/storage/kernels.py
  236. %{python3_sitelib}/qubes/storage/lvm.py
  237. %dir %{python3_sitelib}/qubes/tools
  238. %dir %{python3_sitelib}/qubes/tools/__pycache__
  239. %{python3_sitelib}/qubes/tools/__pycache__/*
  240. %{python3_sitelib}/qubes/tools/__init__.py
  241. %{python3_sitelib}/qubes/tools/qmemmand.py
  242. %{python3_sitelib}/qubes/tools/qubes_create.py
  243. %{python3_sitelib}/qubes/tools/qubesd.py
  244. %{python3_sitelib}/qubes/tools/qubesd_query.py
  245. %{python3_sitelib}/qubes/tools/qvm_backup.py
  246. %{python3_sitelib}/qubes/tools/qvm_backup_restore.py
  247. %{python3_sitelib}/qubes/tools/qvm_template_postprocess.py
  248. %dir %{python3_sitelib}/qubes/ext
  249. %dir %{python3_sitelib}/qubes/ext/__pycache__
  250. %{python3_sitelib}/qubes/ext/__pycache__/*
  251. %{python3_sitelib}/qubes/ext/__init__.py
  252. %{python3_sitelib}/qubes/ext/gui.py
  253. %{python3_sitelib}/qubes/ext/pci.py
  254. %{python3_sitelib}/qubes/ext/qubesmanager.py
  255. %{python3_sitelib}/qubes/ext/r3compatibility.py
  256. %dir %{python3_sitelib}/qubes/tests
  257. %dir %{python3_sitelib}/qubes/tests/__pycache__
  258. %{python3_sitelib}/qubes/tests/__pycache__/*
  259. %{python3_sitelib}/qubes/tests/__init__.py
  260. %{python3_sitelib}/qubes/tests/run.py
  261. %{python3_sitelib}/qubes/tests/extra.py
  262. %{python3_sitelib}/qubes/tests/api_admin.py
  263. %{python3_sitelib}/qubes/tests/app.py
  264. %{python3_sitelib}/qubes/tests/devices.py
  265. %{python3_sitelib}/qubes/tests/events.py
  266. %{python3_sitelib}/qubes/tests/firewall.py
  267. %{python3_sitelib}/qubes/tests/init.py
  268. %{python3_sitelib}/qubes/tests/storage.py
  269. %{python3_sitelib}/qubes/tests/storage_file.py
  270. %{python3_sitelib}/qubes/tests/storage_lvm.py
  271. %{python3_sitelib}/qubes/tests/tarwriter.py
  272. %dir %{python3_sitelib}/qubes/tests/vm
  273. %dir %{python3_sitelib}/qubes/tests/vm/__pycache__
  274. %{python3_sitelib}/qubes/tests/vm/__pycache__/*
  275. %{python3_sitelib}/qubes/tests/vm/__init__.py
  276. %{python3_sitelib}/qubes/tests/vm/init.py
  277. %{python3_sitelib}/qubes/tests/vm/adminvm.py
  278. %{python3_sitelib}/qubes/tests/vm/qubesvm.py
  279. %dir %{python3_sitelib}/qubes/tests/vm/mix
  280. %dir %{python3_sitelib}/qubes/tests/vm/mix/__pycache__
  281. %{python3_sitelib}/qubes/tests/vm/mix/__pycache__/*
  282. %{python3_sitelib}/qubes/tests/vm/mix/__init__.py
  283. %{python3_sitelib}/qubes/tests/vm/mix/net.py
  284. %dir %{python3_sitelib}/qubes/tests/tools
  285. %dir %{python3_sitelib}/qubes/tests/tools/__pycache__
  286. %{python3_sitelib}/qubes/tests/tools/__pycache__/*
  287. %{python3_sitelib}/qubes/tests/tools/__init__.py
  288. %{python3_sitelib}/qubes/tests/tools/qubesd.py
  289. %dir %{python3_sitelib}/qubes/tests/integ
  290. %dir %{python3_sitelib}/qubes/tests/integ/__pycache__
  291. %{python3_sitelib}/qubes/tests/integ/__pycache__/*
  292. %{python3_sitelib}/qubes/tests/integ/__init__.py
  293. %{python3_sitelib}/qubes/tests/integ/backup.py
  294. %{python3_sitelib}/qubes/tests/integ/backupcompatibility.py
  295. %{python3_sitelib}/qubes/tests/integ/basic.py
  296. %{python3_sitelib}/qubes/tests/integ/devices_pci.py
  297. %{python3_sitelib}/qubes/tests/integ/dispvm.py
  298. %{python3_sitelib}/qubes/tests/integ/dom0_update.py
  299. %{python3_sitelib}/qubes/tests/integ/network.py
  300. %{python3_sitelib}/qubes/tests/integ/storage.py
  301. %{python3_sitelib}/qubes/tests/integ/vm_qrexec_gui.py
  302. %dir %{python3_sitelib}/qubes/tests/integ/tools
  303. %dir %{python3_sitelib}/qubes/tests/integ/tools/__pycache__
  304. %{python3_sitelib}/qubes/tests/integ/tools/__pycache__/*
  305. %{python3_sitelib}/qubes/tests/integ/tools/__init__.py
  306. %{python3_sitelib}/qubes/tests/integ/tools/qubes_create.py
  307. %dir %{python3_sitelib}/qubes/qmemman
  308. %dir %{python3_sitelib}/qubes/qmemman/__pycache__
  309. %{python3_sitelib}/qubes/qmemman/__pycache__/*
  310. %{python3_sitelib}/qubes/qmemman/__init__.py
  311. %{python3_sitelib}/qubes/qmemman/algo.py
  312. %{python3_sitelib}/qubes/qmemman/client.py
  313. %dir %{python3_sitelib}/qubespolicy
  314. %dir %{python3_sitelib}/qubespolicy/__pycache__
  315. %{python3_sitelib}/qubespolicy/__pycache__/*
  316. %{python3_sitelib}/qubespolicy/__init__.py
  317. %{python3_sitelib}/qubespolicy/cli.py
  318. %{python3_sitelib}/qubespolicy/agent.py
  319. %{python3_sitelib}/qubespolicy/gtkhelpers.py
  320. %{python3_sitelib}/qubespolicy/rpcconfirmation.py
  321. %{python3_sitelib}/qubespolicy/utils.py
  322. %dir %{python3_sitelib}/qubespolicy/tests
  323. %dir %{python3_sitelib}/qubespolicy/tests/__pycache__
  324. %{python3_sitelib}/qubespolicy/tests/__pycache__/*
  325. %{python3_sitelib}/qubespolicy/tests/__init__.py
  326. %{python3_sitelib}/qubespolicy/tests/gtkhelpers.py
  327. %{python3_sitelib}/qubespolicy/tests/rpcconfirmation.py
  328. %dir %{python3_sitelib}/qubespolicy/glade
  329. %{python3_sitelib}/qubespolicy/glade/RPCConfirmationWindow.glade
  330. /usr/lib/qubes/cleanup-dispvms
  331. /usr/lib/qubes/block-cleaner-daemon.py*
  332. /usr/lib/qubes/fix-dir-perms.sh
  333. /usr/lib/qubes/startup-misc.sh
  334. /usr/libexec/qubes/qubes-notify-tools
  335. /usr/libexec/qubes/qubes-notify-updates
  336. %{_unitdir}/qubes-block-cleaner.service
  337. %{_unitdir}/qubes-core.service
  338. %{_unitdir}/qubes-netvm.service
  339. %{_unitdir}/qubes-qmemman.service
  340. %{_unitdir}/qubes-vm@.service
  341. %{_unitdir}/qubesd.service
  342. %{_unitdir}/qubes-reload-firewall@.service
  343. %{_unitdir}/qubes-reload-firewall@.timer
  344. %attr(2770,root,qubes) %dir /var/lib/qubes
  345. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  346. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  347. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  348. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  349. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  350. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  351. /usr/share/qubes/templates/libvirt/xen.xml
  352. /usr/share/qubes/templates/libvirt/devices/pci.xml
  353. /usr/share/qubes/templates/libvirt/devices/net.xml
  354. /usr/lib/tmpfiles.d/qubes.conf
  355. /etc/xen/scripts/block-snapshot
  356. /etc/xen/scripts/block-origin
  357. /etc/xen/scripts/vif-route-qubes
  358. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  359. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  360. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  361. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  362. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  363. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  364. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  365. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenURL
  366. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  367. /etc/qubes-rpc/qubes.FeaturesRequest
  368. /etc/qubes-rpc/qubes.GetRandomizedTime
  369. /etc/qubes-rpc/qubes.NotifyTools
  370. /etc/qubes-rpc/qubes.NotifyUpdates
  371. %attr(2770,root,qubes) %dir /var/log/qubes
  372. %attr(0770,root,qubes) %dir /var/run/qubes
  373. /etc/xdg/autostart/qrexec-policy-agent.desktop
  374. /usr/share/doc/qubes/relaxng/*.rng