core-dom0.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. #%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(False)")}
  26. %{!?version: %define version %(cat version)}
  27. # debug_package hack should be removed when BuildArch:noarch is enabled below
  28. %define debug_package %{nil}
  29. %define _dracutmoddir /usr/lib/dracut/modules.d
  30. %if %{fedora} < 17
  31. %define _dracutmoddir /usr/share/dracut/modules.d
  32. %endif
  33. Name: qubes-core-dom0
  34. Version: %{version}
  35. Release: 1%{dist}
  36. Summary: The Qubes core files (Dom0-side)
  37. Group: Qubes
  38. Vendor: Invisible Things Lab
  39. License: GPL
  40. URL: http://www.qubes-os.org
  41. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  42. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  43. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  44. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  45. AutoReq: no
  46. # FIXME: Enable this and disable debug_package
  47. #BuildArch: noarch
  48. BuildRequires: ImageMagick
  49. BuildRequires: systemd-units
  50. # for building documentation
  51. BuildRequires: python-sphinx
  52. BuildRequires: libvirt-python
  53. BuildRequires: dbus-python
  54. Requires(post): systemd-units
  55. Requires(preun): systemd-units
  56. Requires(postun): systemd-units
  57. Requires: python, pciutils, python-inotify, python-daemon
  58. Requires: python-setuptools
  59. Requires: qubes-core-dom0-linux >= 3.1.8
  60. Requires: qubes-db-dom0
  61. Requires: python-lxml
  62. # TODO: R: qubes-gui-dom0 >= 2.1.11
  63. Conflicts: qubes-gui-dom0 < 1.1.13
  64. Requires: libvirt-python
  65. %if x%{?backend_vmm} == xxen
  66. Requires: xen-runtime
  67. Requires: xen-hvm
  68. Requires: libvirt-daemon-xen >= 1.2.20-4
  69. %endif
  70. Requires: createrepo
  71. Requires: gnome-packagekit
  72. Requires: cronie
  73. Requires: bsdtar
  74. # for qubes-hcl-report
  75. Requires: dmidecode
  76. Requires: PyQt4
  77. # for property's docstrings
  78. Requires: python-docutils
  79. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  80. Obsoletes: preupgrade < 2.0
  81. Provides: preupgrade = 2.0
  82. %define _builddir %(pwd)
  83. %description
  84. The Qubes core files for installation on Dom0.
  85. %prep
  86. # we operate on the current directory, so no need to unpack anything
  87. # symlink is to generate useful debuginfo packages
  88. rm -f %{name}-%{version}
  89. ln -sf . %{name}-%{version}
  90. %setup -T -D
  91. %build
  92. make all
  93. %install
  94. make install \
  95. DESTDIR=$RPM_BUILD_ROOT \
  96. UNITDIR=%{_unitdir} \
  97. PYTHON_SITEPATH=%{python_sitelib} \
  98. SYSCONFDIR=%{_sysconfdir}
  99. %post
  100. # Create NetworkManager configuration if we do not have it
  101. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  102. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  103. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  104. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  105. fi
  106. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  107. echo 'autoballoon=0' >> /etc/xen/xl.conf
  108. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  109. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  110. systemctl --no-reload enable qubes-core.service >/dev/null 2>&1
  111. systemctl --no-reload enable qubes-netvm.service >/dev/null 2>&1
  112. systemctl --no-reload enable qubes-setupdvm.service >/dev/null 2>&1
  113. # Conflicts with libxl stack, so disable it
  114. systemctl --no-reload disable xend.service >/dev/null 2>&1
  115. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  116. systemctl daemon-reload >/dev/null 2>&1 || :
  117. HAD_SYSCONFIG_NETWORK=yes
  118. if ! [ -e /etc/sysconfig/network ]; then
  119. HAD_SYSCONFIG_NETWORK=no
  120. # supplant empty one so NetworkManager init script does not complain
  121. touch /etc/sysconfig/network
  122. fi
  123. # Load evtchn module - xenstored needs it
  124. modprobe evtchn 2> /dev/null || modprobe xen-evtchn
  125. service xenstored start
  126. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  127. # echo "Initializing Qubes DB..."
  128. umask 007; sg qubes -c qvm-init-storage
  129. qubes-prefs -s default-kernel `ls /var/lib/qubes/vm-kernels|head -n 1` 2> /dev/null
  130. fi
  131. # Because we now have an installer
  132. # this script is always executed during upgrade
  133. # and we decided not to restart core during upgrade
  134. #service qubes_core start
  135. if [ "x"$HAD_SYSCONFIG_NETWORK = "xno" ]; then
  136. rm -f /etc/sysconfig/network
  137. fi
  138. %clean
  139. rm -rf $RPM_BUILD_ROOT
  140. rm -f %{name}-%{version}
  141. %pre
  142. if ! grep -q ^qubes: /etc/group ; then
  143. groupadd qubes
  144. fi
  145. %triggerin -- xen-runtime
  146. /usr/lib/qubes/fix-dir-perms.sh
  147. %preun
  148. if [ "$1" = 0 ] ; then
  149. # no more packages left
  150. service qubes_netvm stop
  151. service qubes_core stop
  152. fi
  153. %postun
  154. if [ "$1" = 0 ] ; then
  155. # no more packages left
  156. chgrp root /etc/xen
  157. chmod 700 /etc/xen
  158. groupdel qubes
  159. fi
  160. %files
  161. %defattr(-,root,root,-)
  162. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  163. /usr/bin/qvm-*
  164. /usr/bin/qubes-*
  165. /usr/bin/qmemmand
  166. %dir %{python_sitelib}/qubes-*.egg-info
  167. %{python_sitelib}/qubes-*.egg-info/*
  168. %dir %{python_sitelib}/qubes
  169. %{python_sitelib}/qubes/__init__.py*
  170. %{python_sitelib}/qubes/app.py*
  171. %{python_sitelib}/qubes/backup.py*
  172. %{python_sitelib}/qubes/config.py*
  173. %{python_sitelib}/qubes/core2migration.py*
  174. %{python_sitelib}/qubes/devices.py*
  175. %{python_sitelib}/qubes/dochelpers.py*
  176. %{python_sitelib}/qubes/events.py*
  177. %{python_sitelib}/qubes/exc.py*
  178. %{python_sitelib}/qubes/log.py*
  179. %{python_sitelib}/qubes/rngdoc.py*
  180. %{python_sitelib}/qubes/utils.py*
  181. %dir %{python_sitelib}/qubes/vm
  182. %{python_sitelib}/qubes/vm/__init__.py*
  183. %{python_sitelib}/qubes/vm/adminvm.py*
  184. %{python_sitelib}/qubes/vm/appvm.py*
  185. %{python_sitelib}/qubes/vm/dispvm.py*
  186. %{python_sitelib}/qubes/vm/qubesvm.py*
  187. %{python_sitelib}/qubes/vm/standalonevm.py*
  188. %{python_sitelib}/qubes/vm/templatevm.py*
  189. %dir %{python_sitelib}/qubes/vm/mix
  190. %{python_sitelib}/qubes/vm/mix/__init__.py*
  191. %{python_sitelib}/qubes/vm/mix/net.py*
  192. %dir %{python_sitelib}/qubes/storage
  193. %{python_sitelib}/qubes/storage/__init__.py*
  194. %{python_sitelib}/qubes/storage/file.py*
  195. %{python_sitelib}/qubes/storage/kernels.py*
  196. %dir %{python_sitelib}/qubes/tools
  197. %{python_sitelib}/qubes/tools/__init__.py*
  198. %{python_sitelib}/qubes/tools/qmemmand.py*
  199. %{python_sitelib}/qubes/tools/qubes_create.py*
  200. %{python_sitelib}/qubes/tools/qubes_monitor_layout_notify.py*
  201. %{python_sitelib}/qubes/tools/qubes_prefs.py*
  202. %{python_sitelib}/qubes/tools/qvm_create.py*
  203. %{python_sitelib}/qubes/tools/qvm_features.py*
  204. %{python_sitelib}/qubes/tools/qvm_kill.py*
  205. %{python_sitelib}/qubes/tools/qvm_ls.py*
  206. %{python_sitelib}/qubes/tools/qvm_pause.py*
  207. %{python_sitelib}/qubes/tools/qvm_prefs.py*
  208. %{python_sitelib}/qubes/tools/qvm_run.py*
  209. %{python_sitelib}/qubes/tools/qvm_shutdown.py*
  210. %{python_sitelib}/qubes/tools/qvm_start.py*
  211. %{python_sitelib}/qubes/tools/qvm_unpause.py*
  212. %dir %{python_sitelib}/qubes/ext
  213. %{python_sitelib}/qubes/ext/__init__.py*
  214. %{python_sitelib}/qubes/ext/gui.py*
  215. %{python_sitelib}/qubes/ext/qubesmanager.py*
  216. %{python_sitelib}/qubes/ext/r3compatibility.py*
  217. %dir %{python_sitelib}/qubes/tests
  218. %{python_sitelib}/qubes/tests/__init__.py*
  219. %{python_sitelib}/qubes/tests/run.py*
  220. %{python_sitelib}/qubes/tests/extra.py*
  221. %{python_sitelib}/qubes/tests/app.py*
  222. %{python_sitelib}/qubes/tests/devices.py*
  223. %{python_sitelib}/qubes/tests/events.py*
  224. %{python_sitelib}/qubes/tests/init.py*
  225. %{python_sitelib}/qubes/tests/storage.py*
  226. %{python_sitelib}/qubes/tests/storage_file.py*
  227. %dir %{python_sitelib}/qubes/tests/vm
  228. %{python_sitelib}/qubes/tests/vm/__init__.py*
  229. %{python_sitelib}/qubes/tests/vm/init.py*
  230. %{python_sitelib}/qubes/tests/vm/adminvm.py*
  231. %{python_sitelib}/qubes/tests/vm/qubesvm.py*
  232. %dir %{python_sitelib}/qubes/tests/vm/mix
  233. %{python_sitelib}/qubes/tests/vm/mix/__init__.py*
  234. %{python_sitelib}/qubes/tests/vm/mix/net.py*
  235. %dir %{python_sitelib}/qubes/tests/tools
  236. %{python_sitelib}/qubes/tests/tools/__init__.py*
  237. %{python_sitelib}/qubes/tests/tools/init.py*
  238. %{python_sitelib}/qubes/tests/tools/qvm_ls.py*
  239. %dir %{python_sitelib}/qubes/tests/int
  240. %{python_sitelib}/qubes/tests/int/__init__.py*
  241. %{python_sitelib}/qubes/tests/int/backup.py*
  242. %{python_sitelib}/qubes/tests/int/backupcompatibility.py*
  243. %{python_sitelib}/qubes/tests/int/basic.py*
  244. %{python_sitelib}/qubes/tests/int/dom0_update.py*
  245. %{python_sitelib}/qubes/tests/int/network.py*
  246. %dir %{python_sitelib}/qubes/tests/int/tools
  247. %{python_sitelib}/qubes/tests/int/tools/__init__.py*
  248. %{python_sitelib}/qubes/tests/int/tools/qubes_create.py*
  249. %{python_sitelib}/qubes/tests/int/tools/qvm_prefs.py*
  250. %{python_sitelib}/qubes/tests/int/tools/qvm_run.py*
  251. %dir %{python_sitelib}/qubes/qmemman
  252. %{python_sitelib}/qubes/qmemman/__init__.py*
  253. %{python_sitelib}/qubes/qmemman/algo.py*
  254. %{python_sitelib}/qubes/qmemman/client.py*
  255. /usr/lib/qubes/unbind-pci-device.sh
  256. /usr/lib/qubes/cleanup-dispvms
  257. /usr/lib/qubes/qfile-daemon-dvm*
  258. /usr/lib/qubes/block-cleaner-daemon.py*
  259. /usr/lib/qubes/vusb-ctl.py*
  260. /usr/lib/qubes/xl-qvm-usb-attach.py*
  261. /usr/lib/qubes/xl-qvm-usb-detach.py*
  262. /usr/lib/qubes/fix-dir-perms.sh
  263. /usr/lib/qubes/startup-dvm.sh
  264. /usr/lib/qubes/startup-misc.sh
  265. /usr/lib/qubes/prepare-volatile-img.sh
  266. /usr/libexec/qubes/qubes-notify-tools
  267. /usr/libexec/qubes/qubes-notify-updates
  268. %{_unitdir}/qubes-block-cleaner.service
  269. %{_unitdir}/qubes-core.service
  270. %{_unitdir}/qubes-setupdvm.service
  271. %{_unitdir}/qubes-netvm.service
  272. %{_unitdir}/qubes-qmemman.service
  273. %{_unitdir}/qubes-vm@.service
  274. %{_unitdir}/qubes-reload-firewall@.service
  275. %{_unitdir}/qubes-reload-firewall@.timer
  276. %attr(2770,root,qubes) %dir /var/lib/qubes
  277. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  278. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  279. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  280. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  281. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  282. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  283. /usr/share/qubes/templates/libvirt/xen.xml
  284. /usr/lib/tmpfiles.d/qubes.conf
  285. /usr/lib/qubes/qubes-prepare-saved-domain.sh
  286. /usr/lib/qubes/qubes-update-dispvm-savefile-with-progress.sh
  287. /etc/xen/scripts/block.qubes
  288. /etc/xen/scripts/block-snapshot
  289. /etc/xen/scripts/block-origin
  290. /etc/xen/scripts/vif-route-qubes
  291. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  292. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  293. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  294. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  295. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  296. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  297. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  298. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  299. /etc/qubes-rpc/qubes.FeaturesRequest
  300. /etc/qubes-rpc/qubes.GetRandomizedTime
  301. /etc/qubes-rpc/qubes.NotifyTools
  302. /etc/qubes-rpc/qubes.NotifyUpdates
  303. %attr(2770,root,qubes) %dir /var/log/qubes
  304. %attr(0770,root,qubes) %dir /var/run/qubes
  305. /etc/xdg/autostart/qubes-guid.desktop
  306. /usr/share/doc/qubes/relaxng/*.rng