core-dom0.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368
  1. #
  2. # This is the SPEC file for creating binary RPMs for the Dom0.
  3. #
  4. #
  5. # The Qubes OS Project, http://www.qubes-os.org
  6. #
  7. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  8. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  9. #
  10. # This program is free software; you can redistribute it and/or
  11. # modify it under the terms of the GNU General Public License
  12. # as published by the Free Software Foundation; either version 2
  13. # of the License, or (at your option) any later version.
  14. #
  15. # This program is distributed in the hope that it will be useful,
  16. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  17. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  18. # GNU General Public License for more details.
  19. #
  20. # You should have received a copy of the GNU General Public License
  21. # along with this program; if not, write to the Free Software
  22. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  23. #
  24. #
  25. #%{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(False)")}
  26. %{!?version: %define version %(cat version)}
  27. # debug_package hack should be removed when BuildArch:noarch is enabled below
  28. %define debug_package %{nil}
  29. %define _dracutmoddir /usr/lib/dracut/modules.d
  30. %if %{fedora} < 17
  31. %define _dracutmoddir /usr/share/dracut/modules.d
  32. %endif
  33. Name: qubes-core-dom0
  34. Version: %{version}
  35. Release: 1%{dist}
  36. Summary: The Qubes core files (Dom0-side)
  37. Group: Qubes
  38. Vendor: Invisible Things Lab
  39. License: GPL
  40. URL: http://www.qubes-os.org
  41. # because we have "#!/usr/bin/env python" shebangs, RPM puts
  42. # "Requires: $(which # python)" dependency, which, depending on $PATH order,
  43. # may point to /usr/bin/python or /bin/python (because Fedora has this stupid
  44. # /bin -> usr/bin symlink). python*.rpm provides only /usr/bin/python.
  45. AutoReq: no
  46. # FIXME: Enable this and disable debug_package
  47. #BuildArch: noarch
  48. BuildRequires: ImageMagick
  49. BuildRequires: systemd-units
  50. # for building documentation
  51. BuildRequires: python-sphinx
  52. BuildRequires: libvirt-python
  53. BuildRequires: dbus-python
  54. Requires(post): systemd-units
  55. Requires(preun): systemd-units
  56. Requires(postun): systemd-units
  57. Requires: python, pciutils, python-inotify, python-daemon
  58. Requires: python-setuptools
  59. Requires: qubes-core-dom0-linux >= 3.1.8
  60. Requires: qubes-core-dom0-doc
  61. Requires: qubes-db-dom0
  62. Requires: python-lxml
  63. # TODO: R: qubes-gui-dom0 >= 2.1.11
  64. Conflicts: qubes-gui-dom0 < 1.1.13
  65. Requires: libvirt-python
  66. %if x%{?backend_vmm} == xxen
  67. Requires: xen-runtime
  68. Requires: xen-hvm
  69. Requires: libvirt-daemon-xen >= 1.2.20-6
  70. %endif
  71. Requires: createrepo
  72. Requires: gnome-packagekit
  73. Requires: cronie
  74. Requires: bsdtar
  75. # for qubes-hcl-report
  76. Requires: dmidecode
  77. Requires: PyQt4
  78. # for property's docstrings
  79. Requires: python-docutils
  80. # Prevent preupgrade from installation (it pretend to provide distribution upgrade)
  81. Obsoletes: preupgrade < 2.0
  82. Provides: preupgrade = 2.0
  83. %define _builddir %(pwd)
  84. %description
  85. The Qubes core files for installation on Dom0.
  86. %prep
  87. # we operate on the current directory, so no need to unpack anything
  88. # symlink is to generate useful debuginfo packages
  89. rm -f %{name}-%{version}
  90. ln -sf . %{name}-%{version}
  91. %setup -T -D
  92. %build
  93. make all
  94. %install
  95. make install \
  96. DESTDIR=$RPM_BUILD_ROOT \
  97. UNITDIR=%{_unitdir} \
  98. PYTHON_SITEPATH=%{python_sitelib} \
  99. SYSCONFDIR=%{_sysconfdir}
  100. %post
  101. # Create NetworkManager configuration if we do not have it
  102. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  103. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  104. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  105. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  106. fi
  107. sed '/^autoballoon=/d;/^lockfile=/d' -i /etc/xen/xl.conf
  108. echo 'autoballoon=0' >> /etc/xen/xl.conf
  109. echo 'lockfile="/var/run/qubes/xl-lock"' >> /etc/xen/xl.conf
  110. sed 's/^PRELINKING\s*=.*/PRELINKING=no/' -i /etc/sysconfig/prelink
  111. systemctl --no-reload enable qubes-core.service >/dev/null 2>&1
  112. systemctl --no-reload enable qubes-netvm.service >/dev/null 2>&1
  113. systemctl --no-reload enable qubes-setupdvm.service >/dev/null 2>&1
  114. # Conflicts with libxl stack, so disable it
  115. systemctl --no-reload disable xend.service >/dev/null 2>&1
  116. systemctl --no-reload disable xendomains.service >/dev/null 2>&1
  117. systemctl daemon-reload >/dev/null 2>&1 || :
  118. HAD_SYSCONFIG_NETWORK=yes
  119. if ! [ -e /etc/sysconfig/network ]; then
  120. HAD_SYSCONFIG_NETWORK=no
  121. # supplant empty one so NetworkManager init script does not complain
  122. touch /etc/sysconfig/network
  123. fi
  124. # Load evtchn module - xenstored needs it
  125. modprobe evtchn 2> /dev/null || modprobe xen-evtchn
  126. service xenstored start
  127. if ! [ -e /var/lib/qubes/qubes.xml ]; then
  128. # echo "Initializing Qubes DB..."
  129. umask 007; sg qubes -c qvm-init-storage
  130. qubes-prefs -s default-kernel `ls /var/lib/qubes/vm-kernels|head -n 1` 2> /dev/null
  131. fi
  132. # Because we now have an installer
  133. # this script is always executed during upgrade
  134. # and we decided not to restart core during upgrade
  135. #service qubes_core start
  136. if [ "x"$HAD_SYSCONFIG_NETWORK = "xno" ]; then
  137. rm -f /etc/sysconfig/network
  138. fi
  139. %clean
  140. rm -rf $RPM_BUILD_ROOT
  141. rm -f %{name}-%{version}
  142. %pre
  143. if ! grep -q ^qubes: /etc/group ; then
  144. groupadd qubes
  145. fi
  146. %triggerin -- xen-runtime
  147. /usr/lib/qubes/fix-dir-perms.sh
  148. %preun
  149. if [ "$1" = 0 ] ; then
  150. # no more packages left
  151. service qubes_netvm stop
  152. service qubes_core stop
  153. fi
  154. %postun
  155. if [ "$1" = 0 ] ; then
  156. # no more packages left
  157. chgrp root /etc/xen
  158. chmod 700 /etc/xen
  159. groupdel qubes
  160. fi
  161. %files
  162. %defattr(-,root,root,-)
  163. %config(noreplace) %attr(0664,root,qubes) %{_sysconfdir}/qubes/qmemman.conf
  164. /usr/bin/qvm-*
  165. /usr/bin/qubes-*
  166. /usr/bin/qmemmand
  167. %dir %{python_sitelib}/qubes-*.egg-info
  168. %{python_sitelib}/qubes-*.egg-info/*
  169. %dir %{python_sitelib}/qubes
  170. %{python_sitelib}/qubes/__init__.py*
  171. %{python_sitelib}/qubes/app.py*
  172. %{python_sitelib}/qubes/backup.py*
  173. %{python_sitelib}/qubes/config.py*
  174. %{python_sitelib}/qubes/core2migration.py*
  175. %{python_sitelib}/qubes/devices.py*
  176. %{python_sitelib}/qubes/dochelpers.py*
  177. %{python_sitelib}/qubes/events.py*
  178. %{python_sitelib}/qubes/exc.py*
  179. %{python_sitelib}/qubes/log.py*
  180. %{python_sitelib}/qubes/rngdoc.py*
  181. %{python_sitelib}/qubes/utils.py*
  182. %dir %{python_sitelib}/qubes/vm
  183. %{python_sitelib}/qubes/vm/__init__.py*
  184. %{python_sitelib}/qubes/vm/adminvm.py*
  185. %{python_sitelib}/qubes/vm/appvm.py*
  186. %{python_sitelib}/qubes/vm/dispvm.py*
  187. %{python_sitelib}/qubes/vm/qubesvm.py*
  188. %{python_sitelib}/qubes/vm/standalonevm.py*
  189. %{python_sitelib}/qubes/vm/templatevm.py*
  190. %dir %{python_sitelib}/qubes/vm/mix
  191. %{python_sitelib}/qubes/vm/mix/__init__.py*
  192. %{python_sitelib}/qubes/vm/mix/net.py*
  193. %dir %{python_sitelib}/qubes/storage
  194. %{python_sitelib}/qubes/storage/__init__.py*
  195. %{python_sitelib}/qubes/storage/file.py*
  196. %{python_sitelib}/qubes/storage/domain.py*
  197. %{python_sitelib}/qubes/storage/kernels.py*
  198. %dir %{python_sitelib}/qubes/tools
  199. %{python_sitelib}/qubes/tools/__init__.py*
  200. %{python_sitelib}/qubes/tools/qmemmand.py*
  201. %{python_sitelib}/qubes/tools/qubes_create.py*
  202. %{python_sitelib}/qubes/tools/qubes_monitor_layout_notify.py*
  203. %{python_sitelib}/qubes/tools/qubes_prefs.py*
  204. %{python_sitelib}/qubes/tools/qvm_block.py*
  205. %{python_sitelib}/qubes/tools/qvm_create.py*
  206. %{python_sitelib}/qubes/tools/qvm_features.py*
  207. %{python_sitelib}/qubes/tools/qvm_kill.py*
  208. %{python_sitelib}/qubes/tools/qvm_ls.py*
  209. %{python_sitelib}/qubes/tools/qvm_pause.py*
  210. %{python_sitelib}/qubes/tools/qvm_pool.py*
  211. %{python_sitelib}/qubes/tools/qvm_prefs.py*
  212. %{python_sitelib}/qubes/tools/qvm_remove.py*
  213. %{python_sitelib}/qubes/tools/qvm_run.py*
  214. %{python_sitelib}/qubes/tools/qvm_shutdown.py*
  215. %{python_sitelib}/qubes/tools/qvm_start.py*
  216. %{python_sitelib}/qubes/tools/qvm_unpause.py*
  217. %dir %{python_sitelib}/qubes/ext
  218. %{python_sitelib}/qubes/ext/__init__.py*
  219. %{python_sitelib}/qubes/ext/gui.py*
  220. %{python_sitelib}/qubes/ext/qubesmanager.py*
  221. %{python_sitelib}/qubes/ext/r3compatibility.py*
  222. %dir %{python_sitelib}/qubes/tests
  223. %{python_sitelib}/qubes/tests/__init__.py*
  224. %{python_sitelib}/qubes/tests/run.py*
  225. %{python_sitelib}/qubes/tests/extra.py*
  226. %{python_sitelib}/qubes/tests/app.py*
  227. %{python_sitelib}/qubes/tests/devices.py*
  228. %{python_sitelib}/qubes/tests/events.py*
  229. %{python_sitelib}/qubes/tests/init.py*
  230. %{python_sitelib}/qubes/tests/storage.py*
  231. %{python_sitelib}/qubes/tests/storage_file.py*
  232. %dir %{python_sitelib}/qubes/tests/vm
  233. %{python_sitelib}/qubes/tests/vm/__init__.py*
  234. %{python_sitelib}/qubes/tests/vm/init.py*
  235. %{python_sitelib}/qubes/tests/vm/adminvm.py*
  236. %{python_sitelib}/qubes/tests/vm/qubesvm.py*
  237. %dir %{python_sitelib}/qubes/tests/vm/mix
  238. %{python_sitelib}/qubes/tests/vm/mix/__init__.py*
  239. %{python_sitelib}/qubes/tests/vm/mix/net.py*
  240. %dir %{python_sitelib}/qubes/tests/tools
  241. %{python_sitelib}/qubes/tests/tools/__init__.py*
  242. %{python_sitelib}/qubes/tests/tools/init.py*
  243. %{python_sitelib}/qubes/tests/tools/qvm_ls.py*
  244. %dir %{python_sitelib}/qubes/tests/int
  245. %{python_sitelib}/qubes/tests/int/__init__.py*
  246. %{python_sitelib}/qubes/tests/int/backup.py*
  247. %{python_sitelib}/qubes/tests/int/backupcompatibility.py*
  248. %{python_sitelib}/qubes/tests/int/basic.py*
  249. %{python_sitelib}/qubes/tests/int/dom0_update.py*
  250. %{python_sitelib}/qubes/tests/int/network.py*
  251. %dir %{python_sitelib}/qubes/tests/int/tools
  252. %{python_sitelib}/qubes/tests/int/tools/__init__.py*
  253. %{python_sitelib}/qubes/tests/int/tools/qubes_create.py*
  254. %{python_sitelib}/qubes/tests/int/tools/qvm_prefs.py*
  255. %{python_sitelib}/qubes/tests/int/tools/qvm_run.py*
  256. %dir %{python_sitelib}/qubes/qmemman
  257. %{python_sitelib}/qubes/qmemman/__init__.py*
  258. %{python_sitelib}/qubes/qmemman/algo.py*
  259. %{python_sitelib}/qubes/qmemman/client.py*
  260. /usr/lib/qubes/unbind-pci-device.sh
  261. /usr/lib/qubes/cleanup-dispvms
  262. /usr/lib/qubes/qfile-daemon-dvm*
  263. /usr/lib/qubes/block-cleaner-daemon.py*
  264. /usr/lib/qubes/vusb-ctl.py*
  265. /usr/lib/qubes/xl-qvm-usb-attach.py*
  266. /usr/lib/qubes/xl-qvm-usb-detach.py*
  267. /usr/lib/qubes/fix-dir-perms.sh
  268. /usr/lib/qubes/startup-dvm.sh
  269. /usr/lib/qubes/startup-misc.sh
  270. /usr/lib/qubes/prepare-volatile-img.sh
  271. /usr/libexec/qubes/qubes-notify-tools
  272. /usr/libexec/qubes/qubes-notify-updates
  273. %{_unitdir}/qubes-block-cleaner.service
  274. %{_unitdir}/qubes-core.service
  275. %{_unitdir}/qubes-setupdvm.service
  276. %{_unitdir}/qubes-netvm.service
  277. %{_unitdir}/qubes-qmemman.service
  278. %{_unitdir}/qubes-vm@.service
  279. %{_unitdir}/qubes-reload-firewall@.service
  280. %{_unitdir}/qubes-reload-firewall@.timer
  281. %attr(2770,root,qubes) %dir /var/lib/qubes
  282. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-templates
  283. %attr(2770,root,qubes) %dir /var/lib/qubes/appvms
  284. %attr(2770,root,qubes) %dir /var/lib/qubes/servicevms
  285. %attr(2770,root,qubes) %dir /var/lib/qubes/backup
  286. %attr(2770,root,qubes) %dir /var/lib/qubes/dvmdata
  287. %attr(2770,root,qubes) %dir /var/lib/qubes/vm-kernels
  288. /usr/share/qubes/templates/libvirt/xen.xml
  289. /usr/share/qubes/templates/libvirt/devices/pci.xml
  290. /usr/share/qubes/templates/libvirt/devices/net.xml
  291. /usr/lib/tmpfiles.d/qubes.conf
  292. /usr/lib/qubes/qubes-prepare-saved-domain.sh
  293. /usr/lib/qubes/qubes-update-dispvm-savefile-with-progress.sh
  294. /etc/xen/scripts/block.qubes
  295. /etc/xen/scripts/block-snapshot
  296. /etc/xen/scripts/block-origin
  297. /etc/xen/scripts/vif-route-qubes
  298. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.FeaturesRequest
  299. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.Filecopy
  300. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetImageRGBA
  301. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.GetRandomizedTime
  302. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyTools
  303. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.NotifyUpdates
  304. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenInVM
  305. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.OpenURL
  306. %attr(0664,root,qubes) %config(noreplace) /etc/qubes-rpc/policy/qubes.VMShell
  307. /etc/qubes-rpc/qubes.FeaturesRequest
  308. /etc/qubes-rpc/qubes.GetRandomizedTime
  309. /etc/qubes-rpc/qubes.NotifyTools
  310. /etc/qubes-rpc/qubes.NotifyUpdates
  311. %attr(2770,root,qubes) %dir /var/log/qubes
  312. %attr(0770,root,qubes) %dir /var/run/qubes
  313. /etc/xdg/autostart/qubes-guid.desktop
  314. /usr/share/doc/qubes/relaxng/*.rng