core-agent.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: nmap-ncat
  123. Requires: ntpdate
  124. Requires: net-tools
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. Requires: python-daemon
  138. # for qvm-feature-request
  139. Requires: python2-qubesdb
  140. Requires: nftables
  141. Requires: ImageMagick
  142. Requires: librsvg2-tools
  143. Requires: fakeroot
  144. Requires: desktop-notification-daemon
  145. # to show/hide nm-applet
  146. Requires: dconf
  147. Requires: zenity
  148. Requires: qubes-libvchan
  149. Requires: qubes-db-vm
  150. %if 0%{fedora} >= 23
  151. Requires: python3-dnf-plugins-qubes-hooks
  152. %else
  153. Requires: python2-dnf-plugins-qubes-hooks
  154. %endif
  155. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  156. Obsoletes: qubes-upgrade-vm < 3.2
  157. Provides: qubes-core-vm = %{version}-%{release}
  158. Obsoletes: qubes-core-vm < 4.0.0
  159. BuildRequires: xen-devel
  160. BuildRequires: libX11-devel
  161. BuildRequires: qubes-utils-devel >= 3.1.3
  162. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  163. %package -n python2-dnf-plugins-qubes-hooks
  164. Summary: DNF plugin for Qubes specific post-installation actions
  165. BuildRequires: python2-devel
  166. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  167. %description -n python2-dnf-plugins-qubes-hooks
  168. DNF plugin for Qubes specific post-installation actions:
  169. * notify dom0 that updates were installed
  170. * refresh applications shortcut list
  171. %package -n python3-dnf-plugins-qubes-hooks
  172. Summary: DNF plugin for Qubes specific post-installation actions
  173. BuildRequires: python3-devel
  174. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  175. %description -n python3-dnf-plugins-qubes-hooks
  176. DNF plugin for Qubes specific post-installation actions:
  177. * notify dom0 that updates were installed
  178. * refresh applications shortcut list
  179. %package -n qubes-nautilus
  180. Summary: Qubes integration for Nautilus
  181. Requires: qubes-core-agent
  182. Requires: nautilus-python
  183. %description -n qubes-nautilus
  184. Nautilus addons for inter-VM file copy/move/open.
  185. %define _builddir %(pwd)
  186. %define kde_service_dir /usr/share/kde4/services
  187. %description
  188. The Qubes core files for installation inside a Qubes VM.
  189. %prep
  190. # we operate on the current directory, so no need to unpack anything
  191. # symlink is to generate useful debuginfo packages
  192. rm -f %{name}-%{version}
  193. ln -sf . %{name}-%{version}
  194. %setup -T -D
  195. %build
  196. for dir in qubes-rpc qrexec misc; do
  197. (cd $dir; make)
  198. done
  199. %pre
  200. # Make sure there is a qubes group
  201. groupadd --force --system --gid 98 qubes
  202. id -u 'user' >/dev/null 2>&1 || {
  203. useradd --user-group --create-home --shell /bin/bash user
  204. }
  205. usermod -a --groups qubes user
  206. if [ "$1" != 1 ] ; then
  207. # do this whole %%pre thing only when updating for the first time...
  208. exit 0
  209. fi
  210. mkdir -p /var/lib/qubes
  211. if [ -e /etc/fstab ] ; then
  212. mv /etc/fstab /var/lib/qubes/fstab.orig
  213. fi
  214. usermod -p '' root
  215. usermod -L user
  216. %install
  217. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  218. make install-vm DESTDIR=$RPM_BUILD_ROOT
  219. %if %{fedora} >= 22
  220. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  221. %endif
  222. %triggerin -- initscripts
  223. if [ -e /etc/init/serial.conf ]; then
  224. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  225. fi
  226. %post
  227. # disable some Upstart services
  228. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  229. if [ -e /etc/init/$F.conf ]; then
  230. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  231. fi
  232. done
  233. # Create NetworkManager configuration if we do not have it
  234. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  235. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  236. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  237. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  238. fi
  239. /usr/lib/qubes/qubes-fix-nm-conf.sh
  240. # Remove ip_forward setting from sysctl, so NM will not reset it
  241. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  242. # Remove old firmware updates link
  243. if [ -L /lib/firmware/updates ]; then
  244. rm -f /lib/firmware/updates
  245. fi
  246. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  247. echo >> /etc/yum.conf
  248. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  249. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  250. fi
  251. # And actually setup the proxy usage in package managers
  252. /usr/lib/qubes/update-proxy-configs
  253. # Location of files which contains list of protected files
  254. mkdir -p /etc/qubes/protected-files.d
  255. . /usr/lib/qubes/init/functions
  256. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  257. if ! is_protected_file /etc/hosts ; then
  258. if ! grep -q localhost /etc/hosts; then
  259. cat <<EOF > /etc/hosts
  260. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  261. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  262. EOF
  263. fi
  264. fi
  265. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  266. # in the form expected by qubes-sysinit.sh
  267. if ! is_protected_file /etc/hostname ; then
  268. for ip in '127\.0\.0\.1' '::1'; do
  269. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  270. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  271. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  272. else
  273. echo "${ip} `hostname`" >> /etc/hosts
  274. fi
  275. done
  276. fi
  277. %if %{fedora} >= 20
  278. # Make sure there is a default locale set so gnome-terminal will start
  279. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  280. touch /etc/locale.conf
  281. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  282. fi
  283. # ... and make sure it is really generated
  284. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  285. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  286. base=`echo "$current_locale" | cut -f 1 -d .`
  287. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  288. [ -n "$charmap" ] && charmap="-f $charmap"
  289. localedef -i $base $charmap $current_locale
  290. fi
  291. %endif
  292. if [ "$1" != 1 ] ; then
  293. # do the rest of %%post thing only when updating for the first time...
  294. exit 0
  295. fi
  296. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  297. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  298. fi
  299. # Remove most of the udev scripts to speed up the VM boot time
  300. # Just leave the xen* scripts, that are needed if this VM was
  301. # ever used as a net backend (e.g. as a VPN domain in the future)
  302. #echo "--> Removing unnecessary udev scripts..."
  303. mkdir -p /var/lib/qubes/removed-udev-scripts
  304. for f in /etc/udev/rules.d/*
  305. do
  306. if [ $(basename $f) == "xen-backend.rules" ] ; then
  307. continue
  308. fi
  309. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  310. continue
  311. fi
  312. if echo $f | grep -q qubes; then
  313. continue
  314. fi
  315. mv $f /var/lib/qubes/removed-udev-scripts/
  316. done
  317. mkdir -p /rw
  318. #rm -f /etc/mtab
  319. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  320. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  321. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  322. %triggerin -- notification-daemon
  323. # Enable autostart of notification-daemon when installed
  324. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  325. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  326. fi
  327. exit 0
  328. %triggerin -- selinux-policy
  329. #echo "--> Disabling SELinux..."
  330. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  331. mv /etc/selinux/config.processed /etc/selinux/config
  332. setenforce 0 2>/dev/null
  333. exit 0
  334. %preun
  335. if [ "$1" = 0 ] ; then
  336. # no more packages left
  337. if [ -e /var/lib/qubes/fstab.orig ] ; then
  338. mv /var/lib/qubes/fstab.orig /etc/fstab
  339. fi
  340. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  341. if [ -e /var/lib/qubes/serial.orig ] ; then
  342. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  343. fi
  344. fi
  345. %postun
  346. if [ $1 -eq 0 ] ; then
  347. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  348. if [ -L /lib/firmware/updates ]; then
  349. rm /lib/firmware/updates
  350. fi
  351. rm -rf /var/lib/qubes/xdg
  352. fi
  353. %posttrans
  354. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  355. %clean
  356. rm -rf $RPM_BUILD_ROOT
  357. rm -f %{name}-%{version}
  358. %files
  359. %defattr(-,root,root,-)
  360. %dir /var/lib/qubes
  361. %dir /var/run/qubes
  362. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  363. %{kde_service_dir}/qvm-copy.desktop
  364. %{kde_service_dir}/qvm-move.desktop
  365. %{kde_service_dir}/qvm-dvm.desktop
  366. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  367. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  368. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  369. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  370. /etc/fstab
  371. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  372. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  373. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  374. %dir /etc/qubes-rpc
  375. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  376. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  377. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  378. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  379. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  380. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  381. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  382. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  383. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  384. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  385. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  386. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  387. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  388. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  389. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  390. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  391. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  392. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  393. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  394. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  395. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  396. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  397. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  398. %dir /etc/qubes/autostart
  399. /etc/qubes/autostart/README.txt
  400. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  401. %dir /etc/qubes/suspend-pre.d
  402. /etc/qubes/suspend-pre.d/README
  403. %dir /etc/qubes/suspend-post.d
  404. /etc/qubes/suspend-post.d/README
  405. %dir /etc/qubes/post-install.d
  406. /etc/qubes/post-install.d/README
  407. /etc/qubes/post-install.d/*.sh
  408. %config(noreplace) /etc/sudoers.d/qubes
  409. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  410. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  411. %config(noreplace) /etc/qubes/iptables.rules
  412. %config(noreplace) /etc/qubes/ip6tables.rules
  413. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  414. %config(noreplace) /etc/tinyproxy/updates-blacklist
  415. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  416. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  417. %config(noreplace) /etc/qubes-suspend-module-blacklist
  418. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  419. /etc/xen/scripts/vif-route-qubes
  420. /etc/xen/scripts/vif-qubes-nat.sh
  421. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  422. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  423. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  424. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  425. %if %{fedora} < 22
  426. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  427. %endif
  428. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  429. /usr/sbin/qubes-serial-login
  430. /usr/bin/qvm-copy-to-vm
  431. /usr/bin/qvm-move-to-vm
  432. /usr/bin/qvm-open-in-dvm
  433. /usr/bin/qvm-open-in-vm
  434. /usr/bin/qvm-run-vm
  435. /usr/bin/qvm-features-request
  436. /usr/bin/xenstore-watch-qubes
  437. /usr/bin/qubes-desktop-run
  438. /usr/bin/qubes-open
  439. /usr/bin/qrexec-fork-server
  440. /usr/bin/qrexec-client-vm
  441. /usr/bin/qubes-session-autostart
  442. %dir /usr/lib/qubes
  443. /usr/lib/qubes/vusb-ctl.py*
  444. /usr/lib/qubes/dispvm-prerun.sh
  445. /usr/lib/qubes/sync-ntp-clock
  446. /usr/lib/qubes/prepare-suspend
  447. /usr/lib/qubes/network-manager-prepare-conf-dir
  448. /usr/lib/qubes/show-hide-nm-applet.sh
  449. /usr/lib/qubes/qrexec-agent
  450. /usr/lib/qubes/qrexec-client-vm
  451. /usr/lib/qubes/qrexec_client_vm
  452. /usr/lib/qubes/qubes-rpc-multiplexer
  453. /usr/lib/qubes/qfile-agent
  454. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  455. /usr/lib/qubes/qopen-in-vm
  456. /usr/lib/qubes/qrun-in-vm
  457. /usr/lib/qubes/qubes-download-dom0-updates.sh
  458. /usr/lib/qubes/qubes-fix-nm-conf.sh
  459. /usr/lib/qubes/qubes-setup-dnat-to-ns
  460. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  461. /usr/lib/qubes/qvm-copy-to-vm.kde
  462. /usr/lib/qubes/qvm-move-to-vm.kde
  463. /usr/lib/qubes/setup-ip
  464. /usr/lib/qubes/tar2qfile
  465. /usr/lib/qubes/vm-file-editor
  466. /usr/lib/qubes/iptables-updates-proxy
  467. /usr/lib/qubes/close-window
  468. /usr/lib/qubes/xdg-icon
  469. /usr/lib/qubes/update-proxy-configs
  470. /usr/lib/qubes/upgrades-installed-check
  471. /usr/lib/qubes/upgrades-status-notify
  472. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  473. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  474. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  475. %dir /usr/lib/qubes/init
  476. /usr/lib/qubes/init/*.sh
  477. /usr/lib/qubes/init/functions
  478. %dir /usr/lib/qubes-bind-dirs.d
  479. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  480. /usr/lib/python2.7/site-packages/qubesxdg.py*
  481. /usr/sbin/qubes-firewall
  482. /usr/share/qubes/serial.conf
  483. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  484. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  485. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  486. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  487. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  488. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  489. %dir %{python_sitelib}/qubesagent
  490. %{python_sitelib}/qubesagent/__init__.py*
  491. %{python_sitelib}/qubesagent/firewall.py*
  492. %{python_sitelib}/qubesagent/test_firewall.py*
  493. /usr/share/qubes/mime-override/globs
  494. /usr/share/qubes/qubes-master-key.asc
  495. %dir /home_volatile
  496. %attr(700,user,user) /home_volatile/user
  497. %dir /mnt/removable
  498. %dir /rw
  499. %files -n python2-dnf-plugins-qubes-hooks
  500. %{python2_sitelib}/dnf-plugins/*
  501. %files -n python3-dnf-plugins-qubes-hooks
  502. %{python3_sitelib}/dnf-plugins/*
  503. %files -n qubes-nautilus
  504. /usr/lib/qubes/qvm-copy-to-vm.gnome
  505. /usr/lib/qubes/qvm-move-to-vm.gnome
  506. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  507. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  508. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  509. %package sysvinit
  510. Summary: Qubes unit files for SysV init style or upstart
  511. License: GPL v2 only
  512. Group: Qubes
  513. Requires: upstart
  514. Requires: qubes-core-agent
  515. Provides: qubes-core-agent-init-scripts
  516. Conflicts: qubes-core-agent-systemd
  517. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  518. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  519. %description sysvinit
  520. The Qubes core startup configuration for SysV init (or upstart).
  521. %files sysvinit
  522. /etc/init.d/qubes-sysinit
  523. /etc/init.d/qubes-core-early
  524. /etc/init.d/qubes-core
  525. /etc/init.d/qubes-dvm
  526. /etc/init.d/qubes-core-netvm
  527. /etc/init.d/qubes-firewall
  528. /etc/init.d/qubes-iptables
  529. /etc/init.d/qubes-updates-proxy
  530. /etc/init.d/qubes-qrexec-agent
  531. /etc/init.d/qubes-updates-proxy-forwarder
  532. /etc/sysconfig/modules/qubes-core.modules
  533. /etc/sysconfig/modules/qubes-misc.modules
  534. %post sysvinit
  535. #echo "--> Turning off unnecessary services..."
  536. # FIXME: perhaps there is more elegant way to do this?
  537. for f in /etc/init.d/*
  538. do
  539. srv=`basename $f`
  540. [ $srv = 'functions' ] && continue
  541. [ $srv = 'killall' ] && continue
  542. [ $srv = 'halt' ] && continue
  543. [ $srv = 'single' ] && continue
  544. [ $srv = 'reboot' ] && continue
  545. [ $srv = 'qubes-gui' ] && continue
  546. chkconfig $srv off
  547. done
  548. #echo "--> Enabling essential services..."
  549. chkconfig rsyslog on
  550. chkconfig haldaemon on
  551. chkconfig messagebus on
  552. for svc in %qubes_services ; do
  553. if [ "$1" = 1 ] ; then
  554. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  555. else
  556. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  557. fi
  558. done
  559. # dropped services
  560. chkconfig qubes-netwatcher off || :
  561. # TODO: make this not display the silly message about security context...
  562. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  563. %preun sysvinit
  564. if [ "$1" = 0 ] ; then
  565. # no more packages left
  566. for svc in %qubes_services ; do
  567. chkconfig --del $svc
  568. done
  569. fi
  570. %package systemd
  571. Summary: Qubes unit files for SystemD init style
  572. License: GPL v2 only
  573. Group: Qubes
  574. Requires: systemd
  575. Requires(post): systemd-units
  576. Requires(preun): systemd-units
  577. Requires(postun): systemd-units
  578. Requires: qubes-core-agent
  579. Provides: qubes-core-agent-init-scripts
  580. Conflicts: qubes-core-agent-sysvinit
  581. Provides: qubes-core-vm-systemd = %{version}-%{release}
  582. Obsoletes: qubes-core-vm-systemd < 4.0.0
  583. %description systemd
  584. The Qubes core startup configuration for SystemD init.
  585. %files systemd
  586. %defattr(-,root,root,-)
  587. /lib/systemd/system/qubes-dvm.service
  588. /lib/systemd/system/qubes-misc-post.service
  589. /lib/systemd/system/qubes-firewall.service
  590. /lib/systemd/system/qubes-mount-dirs.service
  591. /lib/systemd/system/qubes-network.service
  592. /lib/systemd/system/qubes-iptables.service
  593. /lib/systemd/system/qubes-sysinit.service
  594. /lib/systemd/system/qubes-early-vm-config.service
  595. /lib/systemd/system/qubes-update-check.service
  596. /lib/systemd/system/qubes-update-check.timer
  597. /lib/systemd/system/qubes-updates-proxy.service
  598. /lib/systemd/system/qubes-qrexec-agent.service
  599. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  600. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  601. /lib/systemd/system-preset/%qubes_preset_file
  602. /lib/modules-load.d/qubes-core.conf
  603. /lib/modules-load.d/qubes-misc.conf
  604. /usr/lib/qubes/init/qubes-iptables
  605. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  606. /lib/systemd/system/crond.service.d/30_qubes.conf
  607. /lib/systemd/system/cups.service.d/30_qubes.conf
  608. /lib/systemd/system/cups.socket.d/30_qubes.conf
  609. /lib/systemd/system/cups.path.d/30_qubes.conf
  610. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  611. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  612. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  613. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  614. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  615. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  616. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  617. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  618. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  619. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  620. /lib/systemd/system/tor.service.d/30_qubes.conf
  621. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  622. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  623. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  624. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  625. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  626. %post systemd
  627. changed=
  628. %scriptletfuns
  629. if [ $1 -eq 1 ]
  630. then
  631. preset_units %{_presetdir}/%qubes_preset_file initial
  632. changed=true
  633. else
  634. preset_units %{_presetdir}/%qubes_preset_file upgrade
  635. changed=true
  636. # Upgrade path - now qubes-iptables is used instead
  637. for svc in iptables ip6tables
  638. do
  639. if [ -f "$svc".service ]
  640. then
  641. systemctl --no-reload preset "$svc".service
  642. changed=true
  643. fi
  644. done
  645. fi
  646. if [ $1 -eq 1 ]
  647. then
  648. # First install.
  649. # Set default "runlevel".
  650. # FIXME: this ought to be done via kernel command line.
  651. # The fewer deviations of the template from the seed
  652. # image, the better.
  653. rm -f %{_sysconfdir}/systemd/system/default.target
  654. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  655. changed=true
  656. fi
  657. # remove old symlinks
  658. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  659. then
  660. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  661. changed=true
  662. fi
  663. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  664. then
  665. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  666. changed=true
  667. fi
  668. if [ "x$changed" != "x" ]
  669. then
  670. systemctl daemon-reload
  671. fi
  672. %preun systemd
  673. if [ $1 -eq 0 ] ; then
  674. # Run this only during uninstall.
  675. # Save the preset file to later use it to re-preset services there
  676. # once the Qubes OS preset file is removed.
  677. mkdir -p %{_rundir}/qubes-uninstall
  678. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  679. fi
  680. %postun systemd
  681. changed=
  682. %scriptletfuns
  683. if [ -d %{_rundir}/qubes-uninstall ]
  684. then
  685. # We have a saved preset file (or more).
  686. # Re-preset the units mentioned there.
  687. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  688. rm -rf %{_rundir}/qubes-uninstall
  689. changed=true
  690. fi
  691. if [ "x$changed" != "x" ]
  692. then
  693. systemctl daemon-reload
  694. fi