core-vm.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Conflicts: firewalld
  38. %endif
  39. Requires: /usr/bin/mimeopen
  40. Requires: ethtool
  41. Requires: tinyproxy
  42. Requires: ntpdate
  43. Requires: net-tools
  44. Requires: nautilus-python
  45. Requires: qubes-core-vm-kernel-placeholder
  46. Requires: qubes-utils
  47. Requires: initscripts
  48. # for qubes-desktop-run
  49. Requires: pygobject3-base
  50. Requires: dbus-python
  51. # for qubes-session-autostart, xdg-icon
  52. Requires: pyxdg
  53. %if %{fedora} >= 20
  54. # gpk-update-viewer required by qubes-manager
  55. Requires: gnome-packagekit-updater
  56. %endif
  57. Requires: ImageMagick
  58. Requires: librsvg2-tools
  59. Requires: fakeroot
  60. Requires: desktop-notification-daemon
  61. Requires: pygtk2
  62. Requires: zenity
  63. Requires: qubes-libvchan
  64. Requires: qubes-db-vm
  65. Provides: qubes-core-vm
  66. Obsoletes: qubes-core-commonvm
  67. Obsoletes: qubes-core-appvm
  68. Obsoletes: qubes-core-netvm
  69. Obsoletes: qubes-core-proxyvm
  70. Obsoletes: qubes-upgrade-vm < 3.1
  71. BuildRequires: xen-devel
  72. BuildRequires: libX11-devel
  73. BuildRequires: qubes-utils-devel >= 3.0.1
  74. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  75. %define _builddir %(pwd)
  76. %define kde_service_dir /usr/share/kde4/services
  77. %description
  78. The Qubes core files for installation inside a Qubes VM.
  79. %prep
  80. # we operate on the current directory, so no need to unpack anything
  81. # symlink is to generate useful debuginfo packages
  82. rm -f %{name}-%{version}
  83. ln -sf . %{name}-%{version}
  84. %setup -T -D
  85. %build
  86. for dir in qubes-rpc qrexec misc; do
  87. (cd $dir; make)
  88. done
  89. %pre
  90. # Make sure there is a qubes group
  91. groupadd --force --system --gid 98 qubes
  92. id -u 'user' >/dev/null 2>&1 || {
  93. useradd --user-group --create-home --shell /bin/bash user
  94. }
  95. usermod -a --groups qubes user
  96. if [ "$1" != 1 ] ; then
  97. # do this whole %pre thing only when updating for the first time...
  98. exit 0
  99. fi
  100. mkdir -p /var/lib/qubes
  101. if [ -e /etc/fstab ] ; then
  102. mv /etc/fstab /var/lib/qubes/fstab.orig
  103. fi
  104. usermod -p '' root
  105. usermod -L user
  106. %install
  107. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  108. make install-vm DESTDIR=$RPM_BUILD_ROOT
  109. %triggerin -- initscripts
  110. if [ -e /etc/init/serial.conf ]; then
  111. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  112. fi
  113. %post
  114. # disable some Upstart services
  115. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  116. if [ -e /etc/init/$F.conf ]; then
  117. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  118. fi
  119. done
  120. # Remove ip_forward setting from sysctl, so NM will not reset it
  121. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  122. # Remove old firmware updates link
  123. if [ -L /lib/firmware/updates ]; then
  124. rm -f /lib/firmware/updates
  125. fi
  126. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  127. echo >> /etc/yum.conf
  128. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  129. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  130. fi
  131. # Revert 'Prevent unnecessary updates in VMs':
  132. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  133. # Location of files which contains list of protected files
  134. mkdir -p /etc/qubes/protected-files.d
  135. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  136. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  137. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  138. if ! grep -q localhost /etc/hosts; then
  139. cat <<EOF > /etc/hosts
  140. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  141. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  142. EOF
  143. fi
  144. fi
  145. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  146. # in the form expected by qubes-sysinit.sh
  147. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  148. for ip in '127\.0\.0\.1' '::1'; do
  149. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  150. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  151. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  152. else
  153. echo "${ip} `hostname`" >> /etc/hosts
  154. fi
  155. done
  156. fi
  157. %if %{fedora} >= 20
  158. # Make sure there is a default locale set so gnome-terminal will start
  159. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  160. touch /etc/locale.conf
  161. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  162. fi
  163. # ... and make sure it is really generated
  164. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  165. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  166. base=`echo "$current_locale" | cut -f 1 -d .`
  167. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  168. [ -n "$charmap" ] && charmap="-f $charmap"
  169. localedef -i $base $charmap $current_locale
  170. fi
  171. %endif
  172. if [ "$1" != 1 ] ; then
  173. # do the rest of %post thing only when updating for the first time...
  174. exit 0
  175. fi
  176. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  177. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  178. fi
  179. # Remove most of the udev scripts to speed up the VM boot time
  180. # Just leave the xen* scripts, that are needed if this VM was
  181. # ever used as a net backend (e.g. as a VPN domain in the future)
  182. #echo "--> Removing unnecessary udev scripts..."
  183. mkdir -p /var/lib/qubes/removed-udev-scripts
  184. for f in /etc/udev/rules.d/*
  185. do
  186. if [ $(basename $f) == "xen-backend.rules" ] ; then
  187. continue
  188. fi
  189. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  190. continue
  191. fi
  192. if echo $f | grep -q qubes; then
  193. continue
  194. fi
  195. mv $f /var/lib/qubes/removed-udev-scripts/
  196. done
  197. mkdir -p /rw
  198. #rm -f /etc/mtab
  199. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  200. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  201. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  202. %triggerin -- notification-daemon
  203. # Enable autostart of notification-daemon when installed
  204. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  205. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  206. fi
  207. exit 0
  208. %triggerin -- selinux-policy
  209. #echo "--> Disabling SELinux..."
  210. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  211. mv /etc/selinux/config.processed /etc/selinux/config
  212. setenforce 0 2>/dev/null
  213. exit 0
  214. %preun
  215. if [ "$1" = 0 ] ; then
  216. # no more packages left
  217. if [ -e /var/lib/qubes/fstab.orig ] ; then
  218. mv /var/lib/qubes/fstab.orig /etc/fstab
  219. fi
  220. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  221. if [ -e /var/lib/qubes/serial.orig ] ; then
  222. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  223. fi
  224. fi
  225. %postun
  226. if [ $1 -eq 0 ] ; then
  227. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  228. if [ -L /lib/firmware/updates ]; then
  229. rm /lib/firmware/updates
  230. fi
  231. rm -rf /var/lib/qubes/xdg
  232. fi
  233. %posttrans
  234. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  235. %clean
  236. rm -rf $RPM_BUILD_ROOT
  237. rm -f %{name}-%{version}
  238. %files
  239. %defattr(-,root,root,-)
  240. %dir /var/lib/qubes
  241. %dir /var/run/qubes
  242. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  243. %{kde_service_dir}/qvm-copy.desktop
  244. %{kde_service_dir}/qvm-move.desktop
  245. %{kde_service_dir}/qvm-dvm.desktop
  246. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  247. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  248. %config /etc/NetworkManager/conf.d/30-qubes.conf
  249. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  250. /etc/dispvm-dotfiles.tbz
  251. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  252. /etc/fstab
  253. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  254. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  255. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  256. %dir /etc/qubes-rpc
  257. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  258. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  259. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  260. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  261. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  262. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  263. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  264. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  265. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  266. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  267. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  268. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  269. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  270. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  271. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  272. %dir /etc/qubes/autostart
  273. /etc/qubes/autostart/README.txt
  274. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  275. %config(noreplace) /etc/sudoers.d/qubes
  276. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  277. %config(noreplace) /etc/qubes/iptables.rules
  278. %config(noreplace) /etc/qubes/ip6tables.rules
  279. %config(noreplace) /etc/tinyproxy/filter-updates
  280. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  281. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  282. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  283. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  284. /etc/xen/scripts/vif-route-qubes
  285. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  286. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  287. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  288. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  289. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  290. /usr/sbin/qubes-serial-login
  291. /usr/bin/qvm-copy-to-vm
  292. /usr/bin/qvm-move-to-vm
  293. /usr/bin/qvm-open-in-dvm
  294. /usr/bin/qvm-open-in-vm
  295. /usr/bin/qvm-run
  296. /usr/bin/qvm-mru-entry
  297. /usr/bin/xenstore-watch-qubes
  298. /usr/bin/qubes-desktop-run
  299. /usr/bin/qrexec-fork-server
  300. /usr/bin/qrexec-client-vm
  301. /usr/bin/qubes-session-autostart
  302. %dir /usr/lib/qubes
  303. /usr/lib/qubes/vusb-ctl.py*
  304. /usr/lib/qubes/dispvm-prerun.sh
  305. /usr/lib/qubes/sync-ntp-clock
  306. /usr/lib/qubes/prepare-suspend
  307. /usr/lib/qubes/network-manager-prepare-conf-dir
  308. /usr/lib/qubes/show-hide-nm-applet.sh
  309. /usr/lib/qubes/qrexec-agent
  310. /usr/lib/qubes/qrexec-client-vm
  311. /usr/lib/qubes/qrexec_client_vm
  312. /usr/lib/qubes/qubes-rpc-multiplexer
  313. /usr/lib/qubes/qfile-agent
  314. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  315. /usr/lib/qubes/qopen-in-vm
  316. /usr/lib/qubes/qrun-in-vm
  317. /usr/lib/qubes/qubes-download-dom0-updates.sh
  318. /usr/lib/qubes/qubes-setup-dnat-to-ns
  319. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  320. /usr/lib/qubes/qvm-copy-to-vm.gnome
  321. /usr/lib/qubes/qvm-copy-to-vm.kde
  322. /usr/lib/qubes/qvm-move-to-vm.gnome
  323. /usr/lib/qubes/qvm-move-to-vm.kde
  324. /usr/lib/qubes/setup-ip
  325. /usr/lib/qubes/tar2qfile
  326. /usr/lib/qubes/vm-file-editor
  327. /usr/lib/qubes/wrap-in-html-if-url.sh
  328. /usr/lib/qubes/iptables-updates-proxy
  329. /usr/lib/qubes/close-window
  330. /usr/lib/qubes/xdg-icon
  331. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  332. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  333. /usr/sbin/qubes-firewall
  334. /usr/sbin/qubes-netwatcher
  335. /usr/share/qubes/serial.conf
  336. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  337. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  338. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  339. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  340. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  341. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  342. %dir /var/lib/qubes
  343. /usr/share/qubes/mime-override/globs
  344. %dir /home_volatile
  345. %attr(700,user,user) /home_volatile/user
  346. %dir /mnt/removable
  347. %dir /rw
  348. %package sysvinit
  349. Summary: Qubes unit files for SysV init style or upstart
  350. License: GPL v2 only
  351. Group: Qubes
  352. Requires: upstart
  353. Requires: qubes-core-vm
  354. Provides: qubes-core-vm-init-scripts
  355. Conflicts: qubes-core-vm-systemd
  356. %description sysvinit
  357. The Qubes core startup configuration for SysV init (or upstart).
  358. %files sysvinit
  359. /etc/init.d/qubes-core
  360. /etc/init.d/qubes-core-appvm
  361. /etc/init.d/qubes-core-netvm
  362. /etc/init.d/qubes-firewall
  363. /etc/init.d/qubes-netwatcher
  364. /etc/init.d/qubes-iptables
  365. /etc/init.d/qubes-updates-proxy
  366. /etc/init.d/qubes-qrexec-agent
  367. /etc/sysconfig/modules/qubes-core.modules
  368. /etc/sysconfig/modules/qubes-misc.modules
  369. %post sysvinit
  370. #echo "--> Turning off unnecessary services..."
  371. # FIXME: perhaps there is more elegant way to do this?
  372. for f in /etc/init.d/*
  373. do
  374. srv=`basename $f`
  375. [ $srv = 'functions' ] && continue
  376. [ $srv = 'killall' ] && continue
  377. [ $srv = 'halt' ] && continue
  378. [ $srv = 'single' ] && continue
  379. [ $srv = 'reboot' ] && continue
  380. [ $srv = 'qubes-gui' ] && continue
  381. chkconfig $srv off
  382. done
  383. #echo "--> Enabling essential services..."
  384. chkconfig rsyslog on
  385. chkconfig haldaemon on
  386. chkconfig messagebus on
  387. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  388. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  389. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  390. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  391. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  392. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  393. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  394. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  395. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  396. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  397. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  398. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  399. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  400. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  401. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  402. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  403. # TODO: make this not display the silly message about security context...
  404. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  405. %preun sysvinit
  406. if [ "$1" = 0 ] ; then
  407. # no more packages left
  408. chkconfig qubes-core off
  409. chkconfig qubes-core-netvm off
  410. chkconfig qubes-core-appvm off
  411. chkconfig qubes-firewall off
  412. chkconfig qubes-netwatcher off
  413. chkconfig qubes-updates-proxy off
  414. chkconfig qubes-qrexec-agent off
  415. fi
  416. %package systemd
  417. Summary: Qubes unit files for SystemD init style
  418. License: GPL v2 only
  419. Group: Qubes
  420. Requires: systemd
  421. Requires(post): systemd-units
  422. Requires(preun): systemd-units
  423. Requires(postun): systemd-units
  424. Requires: qubes-core-vm
  425. Provides: qubes-core-vm-init-scripts
  426. Conflicts: qubes-core-vm-sysvinit
  427. %description systemd
  428. The Qubes core startup configuration for SystemD init.
  429. %files systemd
  430. %defattr(-,root,root,-)
  431. /lib/systemd/system/qubes-dvm.service
  432. /lib/systemd/system/qubes-misc-post.service
  433. /lib/systemd/system/qubes-firewall.service
  434. /lib/systemd/system/qubes-mount-home.service
  435. /lib/systemd/system/qubes-netwatcher.service
  436. /lib/systemd/system/qubes-network.service
  437. /lib/systemd/system/qubes-iptables.service
  438. /lib/systemd/system/qubes-sysinit.service
  439. /lib/systemd/system/qubes-update-check.service
  440. /lib/systemd/system/qubes-update-check.timer
  441. /lib/systemd/system/qubes-updates-proxy.service
  442. /lib/systemd/system/qubes-qrexec-agent.service
  443. /lib/systemd/system/qubes-random-seed.service
  444. /lib/systemd/system-preset/75-qubes-vm.preset
  445. /lib/modules-load.d/qubes-core.conf
  446. /lib/modules-load.d/qubes-misc.conf
  447. %dir /usr/lib/qubes/init
  448. /usr/lib/qubes/init/prepare-dvm.sh
  449. /usr/lib/qubes/init/network-proxy-setup.sh
  450. /usr/lib/qubes/init/qubes-iptables
  451. /usr/lib/qubes/init/misc-post.sh
  452. /usr/lib/qubes/init/misc-post-stop.sh
  453. /usr/lib/qubes/init/mount-home.sh
  454. /usr/lib/qubes/init/qubes-random-seed.sh
  455. /usr/lib/qubes/init/qubes-sysinit.sh
  456. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  457. /lib/systemd/system/crond.service.d/30_qubes.conf
  458. /lib/systemd/system/cups.service.d/30_qubes.conf
  459. /lib/systemd/system/cups.socket.d/30_qubes.conf
  460. /lib/systemd/system/cups.path.d/30_qubes.conf
  461. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  462. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  463. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  464. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  465. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  466. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  467. %post systemd
  468. PRESET_FAILED=0
  469. if [ $1 -eq 1 ]; then
  470. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  471. else
  472. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-home"
  473. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  474. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  475. services="$services qubes-random-seed"
  476. for srv in $services; do
  477. /bin/systemctl --no-reload preset $srv.service
  478. done
  479. /bin/systemctl --no-reload preset qubes-update-check.timer
  480. # Upgrade path - now qubes-iptables is used instead
  481. /bin/systemctl --no-reload preset iptables.service
  482. /bin/systemctl --no-reload preset ip6tables.service
  483. fi
  484. # Set default "runlevel"
  485. rm -f /etc/systemd/system/default.target
  486. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  487. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  488. case "$action" in
  489. (disable)
  490. if [ -f /lib/systemd/system/$unit_name ]; then
  491. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  492. # forcibly disable
  493. ln -sf /dev/null /etc/systemd/system/$unit_name
  494. fi
  495. fi
  496. ;;
  497. *)
  498. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  499. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  500. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  501. fi
  502. ;;
  503. esac
  504. done
  505. /bin/systemctl daemon-reload
  506. exit 0
  507. %postun systemd
  508. #Do not run this part on upgrades
  509. if [ "$1" != 0 ] ; then
  510. exit 0
  511. fi
  512. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-home qubes-netwatcher qubes-network qubes-qrexec-agent; do
  513. /bin/systemctl disable $srv.service
  514. do