rules 534 B

123456789101112131415161718192021222324252627
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Uncomment this to turn on verbose mode.
  4. #export DH_VERBOSE=1
  5. export PYTHON_PREFIX_ARG=--install-layout=deb
  6. include /usr/share/dpkg/default.mk
  7. export DESTDIR=$(shell pwd)/debian/tmp
  8. %:
  9. dh $@ --with systemd,python2 --with=config-package
  10. override_dh_auto_build:
  11. make all
  12. override_dh_auto_install:
  13. make install-deb
  14. override_dh_fixperms:
  15. dh_fixperms -a -Xqfile-unpacker
  16. override_dh_systemd_start:
  17. dh_systemd_start --no-restart-on-upgrade
  18. override_dh_install:
  19. dh_install --fail-missing