core-vm.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-netwatcher qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: ntpdate
  123. Requires: net-tools
  124. Requires: nautilus-python
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. # for dispvm-prerun.sh
  129. Requires: procps-ng
  130. Requires: util-linux
  131. # for qubes-desktop-run
  132. Requires: pygobject3-base
  133. Requires: dbus-python
  134. # for qubes-session-autostart, xdg-icon
  135. Requires: pyxdg
  136. %if %{fedora} >= 20
  137. # gpk-update-viewer required by qubes-manager
  138. Requires: gnome-packagekit-updater
  139. %endif
  140. Requires: ImageMagick
  141. Requires: librsvg2-tools
  142. Requires: fakeroot
  143. Requires: desktop-notification-daemon
  144. # to show/hide nm-applet
  145. Requires: dconf
  146. Requires: pygtk2
  147. Requires: zenity
  148. Requires: qubes-libvchan
  149. Requires: qubes-db-vm
  150. %if 0%{fedora} >= 23
  151. Requires: python3-dnf-plugins-qubes-hooks
  152. %else
  153. Requires: python2-dnf-plugins-qubes-hooks
  154. %endif
  155. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  156. Obsoletes: qubes-upgrade-vm < 3.2
  157. BuildRequires: xen-devel
  158. BuildRequires: libX11-devel
  159. BuildRequires: qubes-utils-devel >= 3.1.3
  160. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  161. %package -n python2-dnf-plugins-qubes-hooks
  162. Summary: DNF plugin for Qubes specific post-installation actions
  163. BuildRequires: python2-devel
  164. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  165. %description -n python2-dnf-plugins-qubes-hooks
  166. DNF plugin for Qubes specific post-installation actions:
  167. * notify dom0 that updates were installed
  168. * refresh applications shortcut list
  169. %package -n python3-dnf-plugins-qubes-hooks
  170. Summary: DNF plugin for Qubes specific post-installation actions
  171. BuildRequires: python3-devel
  172. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  173. %description -n python3-dnf-plugins-qubes-hooks
  174. DNF plugin for Qubes specific post-installation actions:
  175. * notify dom0 that updates were installed
  176. * refresh applications shortcut list
  177. %define _builddir %(pwd)
  178. %define kde_service_dir /usr/share/kde4/services
  179. %description
  180. The Qubes core files for installation inside a Qubes VM.
  181. %prep
  182. # we operate on the current directory, so no need to unpack anything
  183. # symlink is to generate useful debuginfo packages
  184. rm -f %{name}-%{version}
  185. ln -sf . %{name}-%{version}
  186. %setup -T -D
  187. %build
  188. for dir in qubes-rpc qrexec misc; do
  189. (cd $dir; make)
  190. done
  191. %pre
  192. # Make sure there is a qubes group
  193. groupadd --force --system --gid 98 qubes
  194. id -u 'user' >/dev/null 2>&1 || {
  195. useradd --user-group --create-home --shell /bin/bash user
  196. }
  197. usermod -a --groups qubes user
  198. if [ "$1" != 1 ] ; then
  199. # do this whole %%pre thing only when updating for the first time...
  200. exit 0
  201. fi
  202. mkdir -p /var/lib/qubes
  203. if [ -e /etc/fstab ] ; then
  204. mv /etc/fstab /var/lib/qubes/fstab.orig
  205. fi
  206. usermod -p '' root
  207. usermod -L user
  208. %install
  209. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  210. make install-vm DESTDIR=$RPM_BUILD_ROOT
  211. %if %{fedora} >= 22
  212. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  213. %endif
  214. %triggerin -- initscripts
  215. if [ -e /etc/init/serial.conf ]; then
  216. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  217. fi
  218. %post
  219. # disable some Upstart services
  220. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  221. if [ -e /etc/init/$F.conf ]; then
  222. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  223. fi
  224. done
  225. # Create NetworkManager configuration if we do not have it
  226. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  227. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  228. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  229. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  230. fi
  231. /usr/lib/qubes/qubes-fix-nm-conf.sh
  232. # Remove ip_forward setting from sysctl, so NM will not reset it
  233. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  234. # Remove old firmware updates link
  235. if [ -L /lib/firmware/updates ]; then
  236. rm -f /lib/firmware/updates
  237. fi
  238. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  239. echo >> /etc/yum.conf
  240. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  241. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  242. fi
  243. # And actually setup the proxy usage in package managers
  244. /usr/lib/qubes/update-proxy-configs
  245. # Location of files which contains list of protected files
  246. mkdir -p /etc/qubes/protected-files.d
  247. . /usr/lib/qubes/init/functions
  248. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  249. if ! is_protected_file /etc/hosts ; then
  250. if ! grep -q localhost /etc/hosts; then
  251. cat <<EOF > /etc/hosts
  252. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  253. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  254. EOF
  255. fi
  256. fi
  257. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  258. # in the form expected by qubes-sysinit.sh
  259. if ! is_protected_file /etc/hostname ; then
  260. for ip in '127\.0\.0\.1' '::1'; do
  261. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  262. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  263. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  264. else
  265. echo "${ip} `hostname`" >> /etc/hosts
  266. fi
  267. done
  268. fi
  269. %if %{fedora} >= 20
  270. # Make sure there is a default locale set so gnome-terminal will start
  271. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  272. touch /etc/locale.conf
  273. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  274. fi
  275. # ... and make sure it is really generated
  276. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  277. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  278. base=`echo "$current_locale" | cut -f 1 -d .`
  279. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  280. [ -n "$charmap" ] && charmap="-f $charmap"
  281. localedef -i $base $charmap $current_locale
  282. fi
  283. %endif
  284. if [ "$1" != 1 ] ; then
  285. # do the rest of %%post thing only when updating for the first time...
  286. exit 0
  287. fi
  288. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  289. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  290. fi
  291. # Remove most of the udev scripts to speed up the VM boot time
  292. # Just leave the xen* scripts, that are needed if this VM was
  293. # ever used as a net backend (e.g. as a VPN domain in the future)
  294. #echo "--> Removing unnecessary udev scripts..."
  295. mkdir -p /var/lib/qubes/removed-udev-scripts
  296. for f in /etc/udev/rules.d/*
  297. do
  298. if [ $(basename $f) == "xen-backend.rules" ] ; then
  299. continue
  300. fi
  301. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  302. continue
  303. fi
  304. if echo $f | grep -q qubes; then
  305. continue
  306. fi
  307. mv $f /var/lib/qubes/removed-udev-scripts/
  308. done
  309. mkdir -p /rw
  310. #rm -f /etc/mtab
  311. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  312. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  313. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  314. %triggerin -- notification-daemon
  315. # Enable autostart of notification-daemon when installed
  316. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  317. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  318. fi
  319. exit 0
  320. %triggerin -- selinux-policy
  321. #echo "--> Disabling SELinux..."
  322. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  323. mv /etc/selinux/config.processed /etc/selinux/config
  324. setenforce 0 2>/dev/null
  325. exit 0
  326. %preun
  327. if [ "$1" = 0 ] ; then
  328. # no more packages left
  329. if [ -e /var/lib/qubes/fstab.orig ] ; then
  330. mv /var/lib/qubes/fstab.orig /etc/fstab
  331. fi
  332. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  333. if [ -e /var/lib/qubes/serial.orig ] ; then
  334. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  335. fi
  336. fi
  337. %postun
  338. if [ $1 -eq 0 ] ; then
  339. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  340. if [ -L /lib/firmware/updates ]; then
  341. rm /lib/firmware/updates
  342. fi
  343. rm -rf /var/lib/qubes/xdg
  344. fi
  345. %posttrans
  346. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  347. %clean
  348. rm -rf $RPM_BUILD_ROOT
  349. rm -f %{name}-%{version}
  350. %files
  351. %defattr(-,root,root,-)
  352. %dir /var/lib/qubes
  353. %dir /var/run/qubes
  354. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  355. %{kde_service_dir}/qvm-copy.desktop
  356. %{kde_service_dir}/qvm-move.desktop
  357. %{kde_service_dir}/qvm-dvm.desktop
  358. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  359. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  360. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  361. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  362. /etc/fstab
  363. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  364. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  365. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  366. %dir /etc/qubes-rpc
  367. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  368. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  369. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  370. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  371. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  372. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  373. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  374. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  375. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  376. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  377. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  378. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  379. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  380. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  381. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  382. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  383. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  384. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  385. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  386. %dir /etc/qubes/autostart
  387. /etc/qubes/autostart/README.txt
  388. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  389. %dir /etc/qubes/suspend-pre.d
  390. /etc/qubes/suspend-pre.d/README
  391. %dir /etc/qubes/suspend-post.d
  392. /etc/qubes/suspend-post.d/README
  393. %config(noreplace) /etc/sudoers.d/qubes
  394. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  395. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  396. %config(noreplace) /etc/qubes/iptables.rules
  397. %config(noreplace) /etc/qubes/ip6tables.rules
  398. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  399. %config(noreplace) /etc/tinyproxy/updates-blacklist
  400. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  401. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  402. %config(noreplace) /etc/qubes-suspend-module-blacklist
  403. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  404. /etc/xen/scripts/vif-route-qubes
  405. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  406. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  407. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  408. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  409. %if %{fedora} < 22
  410. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  411. %endif
  412. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  413. /usr/sbin/qubes-serial-login
  414. /usr/bin/qvm-copy-to-vm
  415. /usr/bin/qvm-move-to-vm
  416. /usr/bin/qvm-open-in-dvm
  417. /usr/bin/qvm-open-in-vm
  418. /usr/bin/qvm-run
  419. /usr/bin/qvm-mru-entry
  420. /usr/bin/xenstore-watch-qubes
  421. /usr/bin/qubes-desktop-run
  422. /usr/bin/qubes-open
  423. /usr/bin/qrexec-fork-server
  424. /usr/bin/qrexec-client-vm
  425. /usr/bin/qubes-session-autostart
  426. %dir /usr/lib/qubes
  427. /usr/lib/qubes/vusb-ctl.py*
  428. /usr/lib/qubes/dispvm-prerun.sh
  429. /usr/lib/qubes/sync-ntp-clock
  430. /usr/lib/qubes/prepare-suspend
  431. /usr/lib/qubes/network-manager-prepare-conf-dir
  432. /usr/lib/qubes/show-hide-nm-applet.sh
  433. /usr/lib/qubes/qrexec-agent
  434. /usr/lib/qubes/qrexec-client-vm
  435. /usr/lib/qubes/qrexec_client_vm
  436. /usr/lib/qubes/qubes-rpc-multiplexer
  437. /usr/lib/qubes/qfile-agent
  438. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  439. /usr/lib/qubes/qopen-in-vm
  440. /usr/lib/qubes/qrun-in-vm
  441. /usr/lib/qubes/qubes-download-dom0-updates.sh
  442. /usr/lib/qubes/qubes-fix-nm-conf.sh
  443. /usr/lib/qubes/qubes-setup-dnat-to-ns
  444. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  445. /usr/lib/qubes/qvm-copy-to-vm.gnome
  446. /usr/lib/qubes/qvm-copy-to-vm.kde
  447. /usr/lib/qubes/qvm-move-to-vm.gnome
  448. /usr/lib/qubes/qvm-move-to-vm.kde
  449. /usr/lib/qubes/setup-ip
  450. /usr/lib/qubes/tar2qfile
  451. /usr/lib/qubes/vm-file-editor
  452. /usr/lib/qubes/iptables-updates-proxy
  453. /usr/lib/qubes/close-window
  454. /usr/lib/qubes/xdg-icon
  455. /usr/lib/qubes/update-proxy-configs
  456. /usr/lib/qubes/upgrades-installed-check
  457. /usr/lib/qubes/upgrades-status-notify
  458. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  459. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  460. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  461. %dir /usr/lib/qubes/init
  462. /usr/lib/qubes/init/*.sh
  463. /usr/lib/qubes/init/functions
  464. %dir /usr/lib/qubes-bind-dirs.d
  465. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  466. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  467. /usr/sbin/qubes-firewall
  468. /usr/sbin/qubes-netwatcher
  469. /usr/share/qubes/serial.conf
  470. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  471. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  472. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  473. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  474. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  475. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  476. /usr/share/qubes/mime-override/globs
  477. /usr/share/qubes/qubes-master-key.asc
  478. %dir /home_volatile
  479. %attr(700,user,user) /home_volatile/user
  480. %dir /mnt/removable
  481. %dir /rw
  482. %files -n python2-dnf-plugins-qubes-hooks
  483. %{python2_sitelib}/dnf-plugins/*
  484. %files -n python3-dnf-plugins-qubes-hooks
  485. %{python3_sitelib}/dnf-plugins/*
  486. %package sysvinit
  487. Summary: Qubes unit files for SysV init style or upstart
  488. License: GPL v2 only
  489. Group: Qubes
  490. Requires: upstart
  491. Requires: qubes-core-vm
  492. Provides: qubes-core-vm-init-scripts
  493. Conflicts: qubes-core-vm-systemd
  494. %description sysvinit
  495. The Qubes core startup configuration for SysV init (or upstart).
  496. %files sysvinit
  497. /etc/init.d/qubes-sysinit
  498. /etc/init.d/qubes-core-early
  499. /etc/init.d/qubes-core
  500. /etc/init.d/qubes-dvm
  501. /etc/init.d/qubes-core-netvm
  502. /etc/init.d/qubes-firewall
  503. /etc/init.d/qubes-netwatcher
  504. /etc/init.d/qubes-iptables
  505. /etc/init.d/qubes-updates-proxy
  506. /etc/init.d/qubes-qrexec-agent
  507. /etc/sysconfig/modules/qubes-core.modules
  508. /etc/sysconfig/modules/qubes-misc.modules
  509. %post sysvinit
  510. #echo "--> Turning off unnecessary services..."
  511. # FIXME: perhaps there is more elegant way to do this?
  512. for f in /etc/init.d/*
  513. do
  514. srv=`basename $f`
  515. [ $srv = 'functions' ] && continue
  516. [ $srv = 'killall' ] && continue
  517. [ $srv = 'halt' ] && continue
  518. [ $srv = 'single' ] && continue
  519. [ $srv = 'reboot' ] && continue
  520. [ $srv = 'qubes-gui' ] && continue
  521. chkconfig $srv off
  522. done
  523. #echo "--> Enabling essential services..."
  524. chkconfig rsyslog on
  525. chkconfig haldaemon on
  526. chkconfig messagebus on
  527. for svc in %qubes_services ; do
  528. if [ "$1" = 1 ] ; then
  529. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  530. else
  531. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  532. fi
  533. done
  534. # TODO: make this not display the silly message about security context...
  535. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  536. %preun sysvinit
  537. if [ "$1" = 0 ] ; then
  538. # no more packages left
  539. for svc in %qubes_services ; do
  540. chkconfig --del $svc
  541. done
  542. fi
  543. %package systemd
  544. Summary: Qubes unit files for SystemD init style
  545. License: GPL v2 only
  546. Group: Qubes
  547. Requires: systemd
  548. Requires(post): systemd-units
  549. Requires(preun): systemd-units
  550. Requires(postun): systemd-units
  551. Requires: qubes-core-vm
  552. Provides: qubes-core-vm-init-scripts
  553. Conflicts: qubes-core-vm-sysvinit
  554. %description systemd
  555. The Qubes core startup configuration for SystemD init.
  556. %files systemd
  557. %defattr(-,root,root,-)
  558. /lib/systemd/system/qubes-dvm.service
  559. /lib/systemd/system/qubes-misc-post.service
  560. /lib/systemd/system/qubes-firewall.service
  561. /lib/systemd/system/qubes-mount-dirs.service
  562. /lib/systemd/system/qubes-netwatcher.service
  563. /lib/systemd/system/qubes-network.service
  564. /lib/systemd/system/qubes-iptables.service
  565. /lib/systemd/system/qubes-sysinit.service
  566. /lib/systemd/system/qubes-early-vm-config.service
  567. /lib/systemd/system/qubes-update-check.service
  568. /lib/systemd/system/qubes-update-check.timer
  569. /lib/systemd/system/qubes-updates-proxy.service
  570. /lib/systemd/system/qubes-qrexec-agent.service
  571. /lib/systemd/system-preset/%qubes_preset_file
  572. /lib/modules-load.d/qubes-core.conf
  573. /lib/modules-load.d/qubes-misc.conf
  574. /usr/lib/qubes/init/qubes-iptables
  575. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  576. /lib/systemd/system/crond.service.d/30_qubes.conf
  577. /lib/systemd/system/cups.service.d/30_qubes.conf
  578. /lib/systemd/system/cups.socket.d/30_qubes.conf
  579. /lib/systemd/system/cups.path.d/30_qubes.conf
  580. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  581. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  582. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  583. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  584. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  585. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  586. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  587. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  588. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  589. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  590. /lib/systemd/system/tor.service.d/30_qubes.conf
  591. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  592. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  593. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  594. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  595. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  596. %post systemd
  597. changed=
  598. %scriptletfuns
  599. if [ $1 -eq 1 ]
  600. then
  601. preset_units %{_presetdir}/%qubes_preset_file initial
  602. changed=true
  603. else
  604. preset_units %{_presetdir}/%qubes_preset_file upgrade
  605. changed=true
  606. # Upgrade path - now qubes-iptables is used instead
  607. for svc in iptables ip6tables
  608. do
  609. if [ -f "$svc".service ]
  610. then
  611. systemctl --no-reload preset "$svc".service
  612. changed=true
  613. fi
  614. done
  615. fi
  616. if [ $1 -eq 1 ]
  617. then
  618. # First install.
  619. # Set default "runlevel".
  620. # FIXME: this ought to be done via kernel command line.
  621. # The fewer deviations of the template from the seed
  622. # image, the better.
  623. rm -f %{_sysconfdir}/systemd/system/default.target
  624. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  625. changed=true
  626. fi
  627. # remove old symlinks
  628. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  629. then
  630. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  631. changed=true
  632. fi
  633. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  634. then
  635. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  636. changed=true
  637. fi
  638. if [ "x$changed" != "x" ]
  639. then
  640. systemctl daemon-reload
  641. fi
  642. %preun systemd
  643. if [ $1 -eq 0 ] ; then
  644. # Run this only during uninstall.
  645. # Save the preset file to later use it to re-preset services there
  646. # once the Qubes OS preset file is removed.
  647. mkdir -p %{_rundir}/qubes-uninstall
  648. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  649. fi
  650. %postun systemd
  651. changed=
  652. %scriptletfuns
  653. if [ -d %{_rundir}/qubes-uninstall ]
  654. then
  655. # We have a saved preset file (or more).
  656. # Re-preset the units mentioned there.
  657. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  658. rm -rf %{_rundir}/qubes-uninstall
  659. changed=true
  660. fi
  661. if [ "x$changed" != "x" ]
  662. then
  663. systemctl daemon-reload
  664. fi