core-vm.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: ntpdate
  123. Requires: net-tools
  124. Requires: nautilus-python
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. Requires: python3-daemon
  138. Requires: nftables
  139. Requires: ImageMagick
  140. Requires: librsvg2-tools
  141. Requires: fakeroot
  142. Requires: desktop-notification-daemon
  143. # to show/hide nm-applet
  144. Requires: dconf
  145. Requires: pygtk2
  146. Requires: zenity
  147. Requires: qubes-libvchan
  148. Requires: qubes-db-vm
  149. %if 0%{fedora} >= 23
  150. Requires: python3-dnf-plugins-qubes-hooks
  151. %else
  152. Requires: python2-dnf-plugins-qubes-hooks
  153. %endif
  154. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  155. Obsoletes: qubes-upgrade-vm < 3.2
  156. BuildRequires: xen-devel
  157. BuildRequires: python3-devel
  158. BuildRequires: libX11-devel
  159. BuildRequires: qubes-utils-devel >= 3.1.3
  160. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  161. %package -n python2-dnf-plugins-qubes-hooks
  162. Summary: DNF plugin for Qubes specific post-installation actions
  163. BuildRequires: python2-devel
  164. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  165. %description -n python2-dnf-plugins-qubes-hooks
  166. DNF plugin for Qubes specific post-installation actions:
  167. * notify dom0 that updates were installed
  168. * refresh applications shortcut list
  169. %package -n python3-dnf-plugins-qubes-hooks
  170. Summary: DNF plugin for Qubes specific post-installation actions
  171. BuildRequires: python3-devel
  172. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  173. %description -n python3-dnf-plugins-qubes-hooks
  174. DNF plugin for Qubes specific post-installation actions:
  175. * notify dom0 that updates were installed
  176. * refresh applications shortcut list
  177. %define _builddir %(pwd)
  178. %define kde_service_dir /usr/share/kde4/services
  179. %description
  180. The Qubes core files for installation inside a Qubes VM.
  181. %prep
  182. # we operate on the current directory, so no need to unpack anything
  183. # symlink is to generate useful debuginfo packages
  184. rm -f %{name}-%{version}
  185. ln -sf . %{name}-%{version}
  186. %setup -T -D
  187. %build
  188. for dir in qubes-rpc qrexec misc; do
  189. (cd $dir; make)
  190. done
  191. %pre
  192. # Make sure there is a qubes group
  193. groupadd --force --system --gid 98 qubes
  194. id -u 'user' >/dev/null 2>&1 || {
  195. useradd --user-group --create-home --shell /bin/bash user
  196. }
  197. usermod -a --groups qubes user
  198. if [ "$1" != 1 ] ; then
  199. # do this whole %%pre thing only when updating for the first time...
  200. exit 0
  201. fi
  202. mkdir -p /var/lib/qubes
  203. if [ -e /etc/fstab ] ; then
  204. mv /etc/fstab /var/lib/qubes/fstab.orig
  205. fi
  206. usermod -p '' root
  207. usermod -L user
  208. %install
  209. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  210. make install-vm DESTDIR=$RPM_BUILD_ROOT
  211. %if %{fedora} >= 22
  212. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  213. %endif
  214. %triggerin -- initscripts
  215. if [ -e /etc/init/serial.conf ]; then
  216. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  217. fi
  218. %post
  219. # disable some Upstart services
  220. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  221. if [ -e /etc/init/$F.conf ]; then
  222. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  223. fi
  224. done
  225. # Create NetworkManager configuration if we do not have it
  226. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  227. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  228. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  229. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  230. fi
  231. /usr/lib/qubes/qubes-fix-nm-conf.sh
  232. # Remove ip_forward setting from sysctl, so NM will not reset it
  233. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  234. # Remove old firmware updates link
  235. if [ -L /lib/firmware/updates ]; then
  236. rm -f /lib/firmware/updates
  237. fi
  238. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  239. echo >> /etc/yum.conf
  240. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  241. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  242. fi
  243. # And actually setup the proxy usage in package managers
  244. /usr/lib/qubes/update-proxy-configs
  245. # Location of files which contains list of protected files
  246. mkdir -p /etc/qubes/protected-files.d
  247. . /usr/lib/qubes/init/functions
  248. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  249. if ! is_protected_file /etc/hosts ; then
  250. if ! grep -q localhost /etc/hosts; then
  251. cat <<EOF > /etc/hosts
  252. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  253. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  254. EOF
  255. fi
  256. fi
  257. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  258. # in the form expected by qubes-sysinit.sh
  259. if ! is_protected_file /etc/hostname ; then
  260. for ip in '127\.0\.0\.1' '::1'; do
  261. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  262. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  263. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  264. else
  265. echo "${ip} `hostname`" >> /etc/hosts
  266. fi
  267. done
  268. fi
  269. %if %{fedora} >= 20
  270. # Make sure there is a default locale set so gnome-terminal will start
  271. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  272. touch /etc/locale.conf
  273. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  274. fi
  275. # ... and make sure it is really generated
  276. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  277. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  278. base=`echo "$current_locale" | cut -f 1 -d .`
  279. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  280. [ -n "$charmap" ] && charmap="-f $charmap"
  281. localedef -i $base $charmap $current_locale
  282. fi
  283. %endif
  284. if [ "$1" != 1 ] ; then
  285. # do the rest of %%post thing only when updating for the first time...
  286. exit 0
  287. fi
  288. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  289. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  290. fi
  291. # Remove most of the udev scripts to speed up the VM boot time
  292. # Just leave the xen* scripts, that are needed if this VM was
  293. # ever used as a net backend (e.g. as a VPN domain in the future)
  294. #echo "--> Removing unnecessary udev scripts..."
  295. mkdir -p /var/lib/qubes/removed-udev-scripts
  296. for f in /etc/udev/rules.d/*
  297. do
  298. if [ $(basename $f) == "xen-backend.rules" ] ; then
  299. continue
  300. fi
  301. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  302. continue
  303. fi
  304. if echo $f | grep -q qubes; then
  305. continue
  306. fi
  307. mv $f /var/lib/qubes/removed-udev-scripts/
  308. done
  309. mkdir -p /rw
  310. #rm -f /etc/mtab
  311. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  312. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  313. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  314. %triggerin -- notification-daemon
  315. # Enable autostart of notification-daemon when installed
  316. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  317. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  318. fi
  319. exit 0
  320. %triggerin -- selinux-policy
  321. #echo "--> Disabling SELinux..."
  322. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  323. mv /etc/selinux/config.processed /etc/selinux/config
  324. setenforce 0 2>/dev/null
  325. exit 0
  326. %preun
  327. if [ "$1" = 0 ] ; then
  328. # no more packages left
  329. if [ -e /var/lib/qubes/fstab.orig ] ; then
  330. mv /var/lib/qubes/fstab.orig /etc/fstab
  331. fi
  332. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  333. if [ -e /var/lib/qubes/serial.orig ] ; then
  334. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  335. fi
  336. fi
  337. %postun
  338. if [ $1 -eq 0 ] ; then
  339. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  340. if [ -L /lib/firmware/updates ]; then
  341. rm /lib/firmware/updates
  342. fi
  343. rm -rf /var/lib/qubes/xdg
  344. fi
  345. %posttrans
  346. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  347. %clean
  348. rm -rf $RPM_BUILD_ROOT
  349. rm -f %{name}-%{version}
  350. %files
  351. %defattr(-,root,root,-)
  352. %dir /var/lib/qubes
  353. %dir /var/run/qubes
  354. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  355. %{kde_service_dir}/qvm-copy.desktop
  356. %{kde_service_dir}/qvm-move.desktop
  357. %{kde_service_dir}/qvm-dvm.desktop
  358. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  359. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  360. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  361. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  362. /etc/fstab
  363. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  364. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  365. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  366. %dir /etc/qubes-rpc
  367. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  368. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  369. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  370. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  371. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  372. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  373. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  374. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  375. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  376. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  377. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  378. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  379. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  380. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  381. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  382. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  383. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  384. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  385. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  386. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  387. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  388. %dir /etc/qubes/autostart
  389. /etc/qubes/autostart/README.txt
  390. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  391. %dir /etc/qubes/suspend-pre.d
  392. /etc/qubes/suspend-pre.d/README
  393. %dir /etc/qubes/suspend-post.d
  394. /etc/qubes/suspend-post.d/README
  395. %config(noreplace) /etc/sudoers.d/qubes
  396. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  397. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  398. %config(noreplace) /etc/qubes/iptables.rules
  399. %config(noreplace) /etc/qubes/ip6tables.rules
  400. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  401. %config(noreplace) /etc/tinyproxy/updates-blacklist
  402. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  403. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  404. %config(noreplace) /etc/qubes-suspend-module-blacklist
  405. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  406. /etc/xen/scripts/vif-route-qubes
  407. /etc/xen/scripts/vif-qubes-nat.sh
  408. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  409. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  410. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  411. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  412. %if %{fedora} < 22
  413. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  414. %endif
  415. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  416. /usr/sbin/qubes-serial-login
  417. /usr/bin/qvm-copy-to-vm
  418. /usr/bin/qvm-move-to-vm
  419. /usr/bin/qvm-open-in-dvm
  420. /usr/bin/qvm-open-in-vm
  421. /usr/bin/qvm-run
  422. /usr/bin/qvm-mru-entry
  423. /usr/bin/qvm-features-request
  424. /usr/bin/xenstore-watch-qubes
  425. /usr/bin/qubes-desktop-run
  426. /usr/bin/qubes-open
  427. /usr/bin/qrexec-fork-server
  428. /usr/bin/qrexec-client-vm
  429. /usr/bin/qubes-session-autostart
  430. %dir /usr/lib/qubes
  431. /usr/lib/qubes/vusb-ctl.py*
  432. /usr/lib/qubes/dispvm-prerun.sh
  433. /usr/lib/qubes/sync-ntp-clock
  434. /usr/lib/qubes/prepare-suspend
  435. /usr/lib/qubes/network-manager-prepare-conf-dir
  436. /usr/lib/qubes/show-hide-nm-applet.sh
  437. /usr/lib/qubes/qrexec-agent
  438. /usr/lib/qubes/qrexec-client-vm
  439. /usr/lib/qubes/qrexec_client_vm
  440. /usr/lib/qubes/qubes-rpc-multiplexer
  441. /usr/lib/qubes/qfile-agent
  442. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  443. /usr/lib/qubes/qopen-in-vm
  444. /usr/lib/qubes/qrun-in-vm
  445. /usr/lib/qubes/qubes-download-dom0-updates.sh
  446. /usr/lib/qubes/qubes-fix-nm-conf.sh
  447. /usr/lib/qubes/qubes-setup-dnat-to-ns
  448. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  449. /usr/lib/qubes/qvm-copy-to-vm.gnome
  450. /usr/lib/qubes/qvm-copy-to-vm.kde
  451. /usr/lib/qubes/qvm-move-to-vm.gnome
  452. /usr/lib/qubes/qvm-move-to-vm.kde
  453. /usr/lib/qubes/setup-ip
  454. /usr/lib/qubes/tar2qfile
  455. /usr/lib/qubes/vm-file-editor
  456. /usr/lib/qubes/iptables-updates-proxy
  457. /usr/lib/qubes/close-window
  458. /usr/lib/qubes/xdg-icon
  459. /usr/lib/qubes/update-proxy-configs
  460. /usr/lib/qubes/upgrades-installed-check
  461. /usr/lib/qubes/upgrades-status-notify
  462. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  463. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  464. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  465. %dir /usr/lib/qubes/init
  466. /usr/lib/qubes/init/*.sh
  467. /usr/lib/qubes/init/functions
  468. %dir /usr/lib/qubes-bind-dirs.d
  469. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  470. /usr/lib/python2.7/site-packages/qubesxdg.py*
  471. /usr/sbin/qubes-firewall
  472. /usr/share/qubes/serial.conf
  473. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  474. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  475. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  476. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  477. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  478. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  479. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  480. %dir %{python3_sitelib}/qubesagent-*.egg-info
  481. %{python3_sitelib}/qubesagent-*.egg-info/*
  482. %dir %{python3_sitelib}/qubesagent
  483. %dir %{python3_sitelib}/qubesagent/__pycache__
  484. %{python3_sitelib}/qubesagent/__pycache__/*
  485. %{python3_sitelib}/qubesagent/__init__.py
  486. %{python3_sitelib}/qubesagent/firewall.py
  487. %{python3_sitelib}/qubesagent/test_firewall.py
  488. /usr/share/qubes/mime-override/globs
  489. /usr/share/qubes/qubes-master-key.asc
  490. %dir /home_volatile
  491. %attr(700,user,user) /home_volatile/user
  492. %dir /mnt/removable
  493. %dir /rw
  494. %files -n python2-dnf-plugins-qubes-hooks
  495. %{python2_sitelib}/dnf-plugins/*
  496. %files -n python3-dnf-plugins-qubes-hooks
  497. %{python3_sitelib}/dnf-plugins/*
  498. %package sysvinit
  499. Summary: Qubes unit files for SysV init style or upstart
  500. License: GPL v2 only
  501. Group: Qubes
  502. Requires: upstart
  503. Requires: qubes-core-vm
  504. Provides: qubes-core-vm-init-scripts
  505. Conflicts: qubes-core-vm-systemd
  506. %description sysvinit
  507. The Qubes core startup configuration for SysV init (or upstart).
  508. %files sysvinit
  509. /etc/init.d/qubes-sysinit
  510. /etc/init.d/qubes-core-early
  511. /etc/init.d/qubes-core
  512. /etc/init.d/qubes-dvm
  513. /etc/init.d/qubes-core-netvm
  514. /etc/init.d/qubes-firewall
  515. /etc/init.d/qubes-iptables
  516. /etc/init.d/qubes-updates-proxy
  517. /etc/init.d/qubes-qrexec-agent
  518. /etc/sysconfig/modules/qubes-core.modules
  519. /etc/sysconfig/modules/qubes-misc.modules
  520. %post sysvinit
  521. #echo "--> Turning off unnecessary services..."
  522. # FIXME: perhaps there is more elegant way to do this?
  523. for f in /etc/init.d/*
  524. do
  525. srv=`basename $f`
  526. [ $srv = 'functions' ] && continue
  527. [ $srv = 'killall' ] && continue
  528. [ $srv = 'halt' ] && continue
  529. [ $srv = 'single' ] && continue
  530. [ $srv = 'reboot' ] && continue
  531. [ $srv = 'qubes-gui' ] && continue
  532. chkconfig $srv off
  533. done
  534. #echo "--> Enabling essential services..."
  535. chkconfig rsyslog on
  536. chkconfig haldaemon on
  537. chkconfig messagebus on
  538. for svc in %qubes_services ; do
  539. if [ "$1" = 1 ] ; then
  540. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  541. else
  542. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  543. fi
  544. done
  545. # dropped services
  546. chkconfig qubes-netwatcher off || :
  547. # TODO: make this not display the silly message about security context...
  548. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  549. %preun sysvinit
  550. if [ "$1" = 0 ] ; then
  551. # no more packages left
  552. for svc in %qubes_services ; do
  553. chkconfig --del $svc
  554. done
  555. fi
  556. %package systemd
  557. Summary: Qubes unit files for SystemD init style
  558. License: GPL v2 only
  559. Group: Qubes
  560. Requires: systemd
  561. Requires(post): systemd-units
  562. Requires(preun): systemd-units
  563. Requires(postun): systemd-units
  564. Requires: qubes-core-vm
  565. Provides: qubes-core-vm-init-scripts
  566. Conflicts: qubes-core-vm-sysvinit
  567. %description systemd
  568. The Qubes core startup configuration for SystemD init.
  569. %files systemd
  570. %defattr(-,root,root,-)
  571. /lib/systemd/system/qubes-dvm.service
  572. /lib/systemd/system/qubes-misc-post.service
  573. /lib/systemd/system/qubes-firewall.service
  574. /lib/systemd/system/qubes-mount-dirs.service
  575. /lib/systemd/system/qubes-network.service
  576. /lib/systemd/system/qubes-iptables.service
  577. /lib/systemd/system/qubes-sysinit.service
  578. /lib/systemd/system/qubes-early-vm-config.service
  579. /lib/systemd/system/qubes-update-check.service
  580. /lib/systemd/system/qubes-update-check.timer
  581. /lib/systemd/system/qubes-updates-proxy.service
  582. /lib/systemd/system/qubes-qrexec-agent.service
  583. /lib/systemd/system-preset/%qubes_preset_file
  584. /lib/modules-load.d/qubes-core.conf
  585. /lib/modules-load.d/qubes-misc.conf
  586. /usr/lib/qubes/init/qubes-iptables
  587. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  588. /lib/systemd/system/crond.service.d/30_qubes.conf
  589. /lib/systemd/system/cups.service.d/30_qubes.conf
  590. /lib/systemd/system/cups.socket.d/30_qubes.conf
  591. /lib/systemd/system/cups.path.d/30_qubes.conf
  592. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  593. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  594. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  595. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  596. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  597. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  598. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  599. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  600. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  601. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  602. /lib/systemd/system/tor.service.d/30_qubes.conf
  603. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  604. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  605. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  606. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  607. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  608. %post systemd
  609. changed=
  610. %scriptletfuns
  611. if [ $1 -eq 1 ]
  612. then
  613. preset_units %{_presetdir}/%qubes_preset_file initial
  614. changed=true
  615. else
  616. preset_units %{_presetdir}/%qubes_preset_file upgrade
  617. changed=true
  618. # Upgrade path - now qubes-iptables is used instead
  619. for svc in iptables ip6tables
  620. do
  621. if [ -f "$svc".service ]
  622. then
  623. systemctl --no-reload preset "$svc".service
  624. changed=true
  625. fi
  626. done
  627. fi
  628. if [ $1 -eq 1 ]
  629. then
  630. # First install.
  631. # Set default "runlevel".
  632. # FIXME: this ought to be done via kernel command line.
  633. # The fewer deviations of the template from the seed
  634. # image, the better.
  635. rm -f %{_sysconfdir}/systemd/system/default.target
  636. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  637. changed=true
  638. fi
  639. # remove old symlinks
  640. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  641. then
  642. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  643. changed=true
  644. fi
  645. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  646. then
  647. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  648. changed=true
  649. fi
  650. if [ "x$changed" != "x" ]
  651. then
  652. systemctl daemon-reload
  653. fi
  654. %preun systemd
  655. if [ $1 -eq 0 ] ; then
  656. # Run this only during uninstall.
  657. # Save the preset file to later use it to re-preset services there
  658. # once the Qubes OS preset file is removed.
  659. mkdir -p %{_rundir}/qubes-uninstall
  660. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  661. fi
  662. %postun systemd
  663. changed=
  664. %scriptletfuns
  665. if [ -d %{_rundir}/qubes-uninstall ]
  666. then
  667. # We have a saved preset file (or more).
  668. # Re-preset the units mentioned there.
  669. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  670. rm -rf %{_rundir}/qubes-uninstall
  671. changed=true
  672. fi
  673. if [ "x$changed" != "x" ]
  674. then
  675. systemctl daemon-reload
  676. fi