qubes-core-agent.postinst 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427
  1. #!/bin/bash
  2. # postinst script for core-agent-linux
  3. #
  4. # see: dh_installdeb(1)
  5. set -e
  6. # The postint script may be called in the following ways:
  7. # * <postinst> 'configure' <most-recently-configured-version>
  8. # * <old-postinst> 'abort-upgrade' <new version>
  9. # * <conflictor's-postinst> 'abort-remove' 'in-favour' <package>
  10. # <new-version>
  11. # * <postinst> 'abort-remove'
  12. # * <deconfigured's-postinst> 'abort-deconfigure' 'in-favour'
  13. # <failed-install-package> <version> 'removing'
  14. # <conflicting-package> <version>
  15. #
  16. # For details, see http://www.debian.org/doc/debian-policy/ or
  17. # https://www.debian.org/doc/debian-policy/ch-maintainerscripts.html or
  18. # the debian-policy package
  19. # Directory that modified desktop entry config files are stored in
  20. XDG_CONFIG_QUBES="/usr/share/qubes/xdg"
  21. # Install overriden services only when original exists
  22. installOverridenServices() {
  23. override_dir="${1}"
  24. service="${2}"
  25. retval=1
  26. for unit in ${service}; do
  27. unit="${unit%%.*}"
  28. unit_name="$(basename ${unit})"
  29. if [ -f ${unit}.service ]; then
  30. echo "Installing override for ${unit}.service..."
  31. cp ${override_dir}/${unit_name}.service /etc/systemd/system/
  32. retval=0
  33. fi
  34. if [ -f ${unit}.socket -a -f ${override_dir}/${unit}.socket ]; then
  35. echo "Installing override for ${unit}.socket..."
  36. cp ${override_dir}/${unit_name}.socket /etc/systemd/system/
  37. retval=0
  38. fi
  39. if [ -f ${unit}.path -a -f ${override_dir}/${unit}.path ]; then
  40. echo "Installing override for ${unit}.path..."
  41. cp ${override_dir}/${unit_name}.path /etc/systemd/system/
  42. retval=0
  43. fi
  44. done
  45. return ${retval}
  46. }
  47. reenableNetworkManager() {
  48. # Disable original service to enable overriden one
  49. echo "Disabling original service to enable overriden one..."
  50. disableSystemdUnits ModemManager.service
  51. disableSystemdUnits NetworkManager.service
  52. # Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)
  53. echo "Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)"
  54. systemctl mask dbus-org.freedesktop.NetworkManager.service 2> /dev/null || echo "Could not disable D-BUS activation of NetworkManager"
  55. echo "Re-enabling original service to enable overriden one..."
  56. enableSystemdUnits ModemManager.service
  57. enableSystemdUnits NetworkManager.service
  58. # Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811
  59. echo "Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811"
  60. enableSystemdUnits NetworkManager-dispatcher.service
  61. }
  62. remove_ShowIn() {
  63. if [ -e "${1}" ]; then
  64. sed -i '/^\(Not\|Only\)ShowIn/d' "${1}"
  65. fi
  66. }
  67. showIn() {
  68. desktop_entry="${1}"
  69. shown_in="${2}"
  70. message="${shown_in:-"Shown in All;"}"
  71. desktop_entry_qubes="${XDG_CONFIG_QUBES}/autostart/${desktop_entry##*/}"
  72. # Make sure Qubes autostart directory exists
  73. mkdir -p "${XDG_CONFIG_QUBES}/autostart"
  74. # Desktop entry exists, so move to Qubes directory and modify it
  75. if [ -e "${desktop_entry}" ]; then
  76. echo "Desktop Entry Modification - ${message} ${desktop_entry##*/}..."
  77. cp -pf "${desktop_entry}" "${desktop_entry_qubes}"
  78. remove_ShowIn "${desktop_entry_qubes}"
  79. sed -i '/^X-GNOME-Autostart-enabled.*[fF0]/d' "${desktop_entry_qubes}"
  80. # Will only be '' if shown in all
  81. if [ ! "${shown_in}x" == "x" ]; then
  82. echo "${shown_in}" >> "${desktop_entry_qubes}" || true
  83. fi
  84. # Desktop entry must have been removed, so also remove from Qubes directory
  85. else
  86. echo "Desktop Entry Modification - Remove: ${desktop_entry##*/}..."
  87. rm -f "${desktop_entry_qubes}"
  88. fi
  89. }
  90. setArrayAsGlobal() {
  91. local array="$1"
  92. local export_as="$2"
  93. local code=$(declare -p "$array")
  94. local replaced="${code/$array/$export_as}"
  95. eval ${replaced/declare -/declare -g}
  96. }
  97. systemdInfo() {
  98. unit=${1}
  99. return_global_var=${2}
  100. declare -A INFO=()
  101. while read line; do
  102. INFO[${line%%=*}]="${line##*=}"
  103. done < <(systemctl show ${unit} 2> /dev/null)
  104. setArrayAsGlobal INFO $return_global_var
  105. return ${#INFO[@]}
  106. }
  107. displayFailedStatus() {
  108. action=${1}
  109. unit=${2}
  110. # Only display if there are results. In chroot environmnet there will be
  111. # no results to 'systemctl show' command
  112. systemdInfo ${unit} info || {
  113. echo
  114. echo "==================================================="
  115. echo "FAILED: systemd ${action} ${unit}"
  116. echo "==================================================="
  117. echo " LoadState = ${info[LoadState]}"
  118. echo " LoadError = ${info[LoadError]}"
  119. echo " ActiveState = ${info[ActiveState]}"
  120. echo " SubState = ${info[SubState]}"
  121. echo "UnitFileState = ${info[UnitFileState]}"
  122. echo
  123. }
  124. }
  125. # Disable systemd units
  126. disableSystemdUnits() {
  127. for unit in $*; do
  128. echo "Disabling ${unit}..."
  129. systemctl is-active ${unit} > /dev/null 2>&1 && {
  130. systemctl stop ${unit} > /dev/null 2>&1 || displayFailedStatus stop ${unit}
  131. }
  132. if [ -f /lib/systemd/system/${unit} ]; then
  133. if fgrep -q '[Install]' /lib/systemd/system/${unit}; then
  134. systemctl disable ${unit} > /dev/null 2>&1 || displayFailedStatus disable ${unit}
  135. else
  136. echo "Masking service: ${unit}"
  137. systemctl mask ${unit}
  138. fi
  139. else
  140. systemctl disable ${unit} > /dev/null 2>&1 || displayFailedStatus disable ${unit}
  141. fi
  142. done
  143. }
  144. # Enable systemd units
  145. enableSystemdUnits() {
  146. for unit in $*; do
  147. systemctl is-enabled ${unit} > /dev/null 2>&1 && {
  148. echo "It appears ${unit} is already enabled!"
  149. #displayFailedStatus is-enabled ${unit}
  150. } || {
  151. echo "Enabling: ${unit}..."
  152. systemctl enable ${unit} > /dev/null 2>&1 || {
  153. echo "Could not enable: ${unit}"
  154. displayFailedStatus enable ${unit}
  155. }
  156. }
  157. done
  158. }
  159. # Manually trigger all triggers to automaticatly configure
  160. triggerTriggers() {
  161. path="$(readlink -m ${0})"
  162. triggers="${path/postinst/triggers}"
  163. awk '{sub(/[ \t]*#.*/,"")} NF' ${triggers} | while read line
  164. do
  165. /bin/bash -c "${0} triggered ${line##* }" || true
  166. done
  167. }
  168. case "${1}" in
  169. configure)
  170. # disable some Upstart services
  171. for init in plymouth-shutdown \
  172. prefdm \
  173. splash-manager \
  174. start-ttys \
  175. tty ; do
  176. dpkg-divert --divert /etc/init/${init}.conf.qubes-disabled --package qubes-core-agent --rename --add /etc/init/${init}.conf
  177. done
  178. # Create NetworkManager configuration if we do not have it
  179. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  180. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  181. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  182. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  183. fi
  184. /usr/lib/qubes/qubes-fix-nm-conf.sh
  185. # Remove old firmware updates link
  186. if [ -L /lib/firmware/updates ]; then
  187. rm -f /lib/firmware/updates
  188. fi
  189. # ensure that hostname resolves to 127.0.1.1 resp. ::1 and that /etc/hosts is
  190. # in the form expected by qubes-sysinit.sh
  191. for ip in '127\.0\.1\.1' '::1'; do
  192. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  193. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  194. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  195. else
  196. echo "${ip//\\/} `hostname`" >> /etc/hosts
  197. fi
  198. done
  199. # remove hostname from 127.0.0.1 line (in debian the hostname is by default
  200. # resolved to 127.0.1.1)
  201. sed -i "/^127\.0\.0\.1\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  202. chown user:user /home_volatile/user
  203. dpkg-divert --divert /etc/init/serial.conf.qubes-orig --package qubes-core-agent --rename --add /etc/init/serial.conf
  204. # Enable Qubes systemd units
  205. enableSystemdUnits \
  206. qubes-sysinit.service \
  207. qubes-misc-post.service \
  208. qubes-netwatcher.service \
  209. qubes-network.service \
  210. qubes-firewall.service \
  211. qubes-updates-proxy.service \
  212. qubes-update-check.timer \
  213. qubes-qrexec-agent.service
  214. # Set default "runlevel"
  215. rm -f /etc/systemd/system/default.target
  216. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  217. # Process all triggers which will set defaults to wanted values
  218. triggerTriggers
  219. disableSystemdUnits \
  220. alsa-store.service \
  221. alsa-restore.service \
  222. auditd.service \
  223. avahi.service \
  224. avahi-daemon.service \
  225. backuppc.service \
  226. cpuspeed.service \
  227. crond.service \
  228. fedora-autorelabel.service \
  229. fedora-autorelabel-mark.service \
  230. ipmi.service \
  231. hwclock-load.service \
  232. hwclock-save.service \
  233. mdmonitor.service \
  234. multipathd.service \
  235. openct.service \
  236. rpcbind.service \
  237. mcelog.service \
  238. fedora-storage-init.service \
  239. fedora-storage-init-late.service \
  240. plymouth-start.service \
  241. plymouth-read-write.service \
  242. plymouth-quit.service \
  243. plymouth-quit-wait.service \
  244. sshd.service \
  245. tcsd.service \
  246. sm-client.service \
  247. sendmail.service \
  248. mdmonitor-takeover.service \
  249. rngd smartd.service \
  250. upower.service \
  251. irqbalance.service \
  252. colord.service
  253. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  254. # Enable other systemd units
  255. enableSystemdUnits \
  256. rsyslog.service \
  257. netfilter-persistent.service
  258. # XXX: TODO: Needs to be implemented still
  259. # These do not exist on debian; maybe a different package name
  260. # ntpd.service \
  261. ;;
  262. abort-upgrade|abort-remove|abort-deconfigure)
  263. exit 0
  264. ;;
  265. triggered)
  266. for trigger in ${2}; do
  267. case "${trigger}" in
  268. # Update Qubes App Menus
  269. /usr/share/applications)
  270. echo "Updating Qubes App Menus..."
  271. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh || true
  272. ;;
  273. # Install overriden services only when original exists
  274. /lib/systemd/system/NetworkManager.service | \
  275. /lib/systemd/system/NetworkManager-wait-online.service | \
  276. /lib/systemd/system/ModemManager.service)
  277. UNITDIR=/lib/systemd/system
  278. OVERRIDEDIR=/usr/lib/qubes/init
  279. installOverridenServices "${OVERRIDEDIR}" "${trigger}"
  280. if [ $? -eq 0 ]; then
  281. reenableNetworkManager
  282. fi
  283. ;;
  284. # Enable cups only when it is real Systemd service
  285. /lib/systemd/system/cups.service)
  286. [ -e /lib/systemd/system/cups.service ] && enableSystemdUnits cups.service
  287. ;;
  288. # "Enable haveged service"
  289. /lib/systemd/system/haveged.service)
  290. [ -e /lib/systemd/system/haveged.service ] && enableSystemdUnits haveged.service
  291. ;;
  292. # Install overridden serial.conf init script
  293. /etc/init/serial.conf)
  294. echo "Installing over-ridden serial.conf init script..."
  295. if [ -e /etc/init/serial.conf ]; then
  296. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  297. fi
  298. ;;
  299. # Disable SELinux"
  300. /etc/selinux/config)
  301. echo "Disabling SELinux..."
  302. if [ -e /etc/selinux/config ]; then
  303. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  304. mv /etc/selinux/config.processed /etc/selinux/config
  305. setenforce 0 2>/dev/null
  306. fi
  307. ;;
  308. # Desktop Entry Modification - Remove existing rules
  309. /etc/xdg/autostart/gpk-update-icon.desktop | \
  310. /etc/xdg/autostart/nm-applet.desktop | \
  311. /etc/xdg/autostart/abrt-applet.desktop | \
  312. /etc/xdg/autostart/notify-osd.desktop)
  313. showIn "${trigger}"
  314. ;;
  315. # Desktop Entry Modification - Not shown in Qubes
  316. /etc/xdg/autostart/pulseaudio.desktop | \
  317. /etc/xdg/autostart/deja-dup-monitor.desktop | \
  318. /etc/xdg/autostart/imsettings-start.desktop | \
  319. /etc/xdg/autostart/krb5-auth-dialog.desktop | \
  320. /etc/xdg/autostart/pulseaudio.desktop | \
  321. /etc/xdg/autostart/restorecond.desktop | \
  322. /etc/xdg/autostart/sealertauto.desktop | \
  323. /etc/xdg/autostart/gnome-power-manager.desktop | \
  324. /etc/xdg/autostart/gnome-sound-applet.desktop | \
  325. /etc/xdg/autostart/gnome-screensaver.desktop | \
  326. /etc/xdg/autostart/orca-autostart.desktop)
  327. showIn "${trigger}" 'NotShowIn=QUBES;'
  328. ;;
  329. # Desktop Entry Modification - Not shown in in DisposableVM
  330. /etc/xdg/autostart/gcm-apply.desktop)
  331. showIn "${trigger}" 'NotShowIn=DisposableVM;'
  332. ;;
  333. # Desktop Entry Modification - Only shown in AppVM
  334. /etc/xdg/autostart/gnome-keyring-gpg.desktop | \
  335. /etc/xdg/autostart/gnome-keyring-pkcs11.desktop | \
  336. /etc/xdg/autostart/gnome-keyring-secrets.desktop | \
  337. /etc/xdg/autostart/gnome-keyring-ssh.desktop | \
  338. /etc/xdg/autostart/gnome-settings-daemon.desktop | \
  339. /etc/xdg/autostart/user-dirs-update-gtk.desktop | \
  340. /etc/xdg/autostart/gsettings-data-convert.desktop)
  341. showIn "${trigger}" 'OnlyShowIn=GNOME;AppVM;'
  342. ;;
  343. # Desktop Entry Modification - Only shown in Gnome & UpdateableVM
  344. /etc/xdg/autostart/gpk-update-icon.desktop)
  345. showIn "${trigger}" 'OnlyShowIn=GNOME;UpdateableVM;'
  346. ;;
  347. # Desktop Entry Modification - Only shown in Gnome & Qubes
  348. /etc/xdg/autostart/nm-applet.desktop)
  349. showIn "${trigger}" 'OnlyShowIn=GNOME;QUBES;'
  350. ;;
  351. *)
  352. echo "postinst called with unknown trigger \`${2}'" >&2
  353. exit 1
  354. ;;
  355. esac
  356. done
  357. ;;
  358. *)
  359. echo "postinst called with unknown argument \`${1}'" >&2
  360. exit 1
  361. ;;
  362. esac
  363. # dh_installdeb will replace this with shell code automatically
  364. # generated by other debhelper scripts.
  365. #DEBHELPER#
  366. exit 0
  367. # vim: set ts=4 sw=4 sts=4 et :