core-agent.spec 29 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. %if %{fedora} < 22
  111. Requires: yum-plugin-post-transaction-actions
  112. %endif
  113. %if %{fedora} >= 18
  114. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  115. Conflicts: firewalld
  116. %endif
  117. Requires: xdg-utils
  118. Requires: qubes-utils >= 3.1.3
  119. Requires: initscripts
  120. Requires: gawk
  121. Requires: sed
  122. Requires: util-linux
  123. # for qubes-desktop-run
  124. Requires: pygobject3-base
  125. Requires: dbus-python
  126. # for qubes-session-autostart, xdg-icon
  127. Requires: pyxdg
  128. Requires: python-daemon
  129. # for qvm-feature-request
  130. Requires: python2-qubesdb
  131. Requires: ImageMagick
  132. Requires: librsvg2-tools
  133. Requires: zenity
  134. Requires: qubes-core-agent-qrexec
  135. Requires: qubes-libvchan
  136. Requires: qubes-db-vm
  137. %if 0%{fedora} >= 23
  138. Requires: python3-dnf-plugins-qubes-hooks
  139. %else
  140. Requires: python2-dnf-plugins-qubes-hooks
  141. %endif
  142. %if 0%{?rhel} >= 7
  143. Requires: python34-dnf-plugins-qubes-hooks
  144. %endif
  145. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  146. Obsoletes: qubes-upgrade-vm < 3.2
  147. Provides: qubes-core-vm = %{version}-%{release}
  148. Obsoletes: qubes-core-vm < 4.0.0
  149. Provides: qubes-core-vm-doc = %{version}-%{release}
  150. Obsoletes: qubes-core-vm-doc < 4.0.0
  151. BuildRequires: pandoc
  152. BuildRequires: xen-devel
  153. BuildRequires: libX11-devel
  154. BuildRequires: qubes-utils-devel >= 3.1.3
  155. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  156. BuildRequires: pam-devel
  157. %description
  158. The Qubes core files for installation inside a Qubes VM.
  159. %package -n python2-dnf-plugins-qubes-hooks
  160. Summary: DNF plugin for Qubes specific post-installation actions
  161. BuildRequires: python2-devel
  162. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  163. %description -n python2-dnf-plugins-qubes-hooks
  164. DNF plugin for Qubes specific post-installation actions:
  165. * notify dom0 that updates were installed
  166. * refresh applications shortcut list
  167. %if 0%{fedora} >= 23
  168. %package -n python3-dnf-plugins-qubes-hooks
  169. Summary: DNF plugin for Qubes specific post-installation actions
  170. BuildRequires: python3-devel
  171. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  172. %description -n python3-dnf-plugins-qubes-hooks
  173. DNF plugin for Qubes specific post-installation actions:
  174. * notify dom0 that updates were installed
  175. * refresh applications shortcut list
  176. %endif
  177. %if 0%{?rhel} >= 7
  178. %package -n python34-dnf-plugins-qubes-hooks
  179. Summary: DNF plugin for Qubes specific post-installation actions
  180. BuildRequires: python34-devel
  181. %{?python_provide:%python_provide python34-dnf-plugins-qubes-hooks}
  182. %description -n python34-dnf-plugins-qubes-hooks
  183. DNF plugin for Qubes specific post-installation actions:
  184. * notify dom0 that updates were installed
  185. * refresh applications shortcut list
  186. %endif
  187. %package qrexec
  188. Summary: Qubes qrexec agent
  189. Requires: qubes-core-agent
  190. Requires: nautilus-python
  191. Conflicts: qubes-core-vm < 4.0.0
  192. %description qrexec
  193. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  194. requested by dom0 or other VMs, according to dom0-enforced policy.
  195. %package nautilus
  196. Summary: Qubes integration for Nautilus
  197. Requires: qubes-core-agent
  198. Requires: nautilus-python
  199. Conflicts: qubes-core-vm < 4.0.0
  200. %description nautilus
  201. Nautilus addons for inter-VM file copy/move/open.
  202. %package dom0-updates
  203. Summary: Scripts required to handle dom0 updates
  204. Requires: qubes-core-agent
  205. Requires: fakeroot
  206. Conflicts: qubes-core-vm < 4.0.0
  207. %description dom0-updates
  208. Scripts required to handle dom0 updates.
  209. %package networking
  210. Summary: Networking support for Qubes VM
  211. Requires: ethtool
  212. Requires: iptables
  213. Requires: net-tools
  214. Requires: nftables
  215. Requires: socat
  216. Requires: qubes-core-agent
  217. Requires: tinyproxy
  218. Conflicts: qubes-core-vm < 4.0.0
  219. %description networking
  220. This package provides:
  221. * basic network functionality (setting IP address, DNS, default gateway)
  222. * proxy service used by TemplateVMs to download updates
  223. * qubes-firewall service (FirewallVM)
  224. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  225. qubes-core-agent-network-manager.
  226. %package network-manager
  227. Summary: NetworkManager integration for Qubes VM
  228. # to show/hide nm-applet
  229. Requires: NetworkManager >= 0.8.1-1
  230. Requires: glib2
  231. Requires: qubes-core-agent-networking
  232. Conflicts: qubes-core-vm < 4.0.0
  233. %description network-manager
  234. Integration of NetworkManager for Qubes VM:
  235. * make connections config persistent
  236. * adjust DNS redirections when needed
  237. * show/hide NetworkManager applet icon
  238. %package passwordless-root
  239. Summary: Passwordless root access from normal user
  240. Conflicts: qubes-core-vm < 4.0.0
  241. %description passwordless-root
  242. Configure sudo, PolicyKit and similar tool to not ask for any password when
  243. switching from user to root. Since all the user data in a VM is accessible
  244. already from normal user account, there is not much more to guard there. Qubes
  245. VM is a single user system.
  246. %define _builddir %(pwd)
  247. %define kde_service_dir /usr/share/kde4/services
  248. %prep
  249. # we operate on the current directory, so no need to unpack anything
  250. # symlink is to generate useful debuginfo packages
  251. rm -f %{name}-%{version}
  252. ln -sf . %{name}-%{version}
  253. %setup -T -D
  254. %build
  255. for dir in qubes-rpc qrexec misc; do
  256. (cd $dir; make)
  257. done
  258. make -C doc manpages
  259. %pre
  260. # Make sure there is a qubes group
  261. groupadd --force --system --gid 98 qubes
  262. id -u 'user' >/dev/null 2>&1 || {
  263. useradd --user-group --create-home --shell /bin/bash user
  264. }
  265. usermod -a --groups qubes user
  266. if [ "$1" != 1 ] ; then
  267. # do this whole %%pre thing only when updating for the first time...
  268. exit 0
  269. fi
  270. mkdir -p /var/lib/qubes
  271. if [ -e /etc/fstab ] ; then
  272. mv /etc/fstab /var/lib/qubes/fstab.orig
  273. fi
  274. usermod -L user
  275. %pre passwordless-root
  276. usermod -p '' root
  277. %install
  278. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  279. make install-vm DESTDIR=$RPM_BUILD_ROOT
  280. %if %{fedora} >= 22
  281. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  282. %endif
  283. %if 0%{?rhel} >= 7
  284. sed -i \
  285. -e 's:-primary:-centos:' \
  286. -e 's:/fc:/centos:' \
  287. $RPM_BUILD_ROOT/etc/yum.repos.d/qubes-*.repo
  288. %endif
  289. %triggerin -- initscripts
  290. if [ -e /etc/init/serial.conf ]; then
  291. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  292. fi
  293. %triggerin -- grub2-tools
  294. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  295. # do not keep Qubes-related settings directly in user-controlled config,
  296. # include another file
  297. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  298. fi
  299. %post
  300. # disable some Upstart services
  301. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  302. if [ -e /etc/init/$F.conf ]; then
  303. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  304. fi
  305. done
  306. # Remove old firmware updates link
  307. if [ -L /lib/firmware/updates ]; then
  308. rm -f /lib/firmware/updates
  309. fi
  310. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  311. echo >> /etc/yum.conf
  312. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  313. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  314. fi
  315. # And actually setup the proxy usage in package managers
  316. /usr/lib/qubes/update-proxy-configs
  317. # Location of files which contains list of protected files
  318. mkdir -p /etc/qubes/protected-files.d
  319. . /usr/lib/qubes/init/functions
  320. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  321. if ! is_protected_file /etc/hosts ; then
  322. if ! grep -q localhost /etc/hosts; then
  323. cat <<EOF > /etc/hosts
  324. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  325. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  326. EOF
  327. fi
  328. fi
  329. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  330. # in the form expected by qubes-sysinit.sh
  331. if ! is_protected_file /etc/hostname ; then
  332. for ip in '127\.0\.0\.1' '::1'; do
  333. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  334. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  335. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  336. else
  337. echo "${ip} `hostname`" >> /etc/hosts
  338. fi
  339. done
  340. fi
  341. if [ "$1" != 1 ] ; then
  342. # do the rest of %%post thing only when updating for the first time...
  343. exit 0
  344. fi
  345. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  346. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  347. fi
  348. # Remove most of the udev scripts to speed up the VM boot time
  349. # Just leave the xen* scripts, that are needed if this VM was
  350. # ever used as a net backend (e.g. as a VPN domain in the future)
  351. #echo "--> Removing unnecessary udev scripts..."
  352. mkdir -p /var/lib/qubes/removed-udev-scripts
  353. for f in /etc/udev/rules.d/*
  354. do
  355. if [ $(basename $f) == "xen-backend.rules" ] ; then
  356. continue
  357. fi
  358. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  359. continue
  360. fi
  361. if echo $f | grep -q qubes; then
  362. continue
  363. fi
  364. mv $f /var/lib/qubes/removed-udev-scripts/
  365. done
  366. mkdir -p /rw
  367. #rm -f /etc/mtab
  368. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  369. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  370. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  371. %triggerin -- notification-daemon
  372. # Enable autostart of notification-daemon when installed
  373. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  374. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  375. fi
  376. exit 0
  377. %triggerin -- selinux-policy
  378. #echo "--> Disabling SELinux..."
  379. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  380. mv /etc/selinux/config.processed /etc/selinux/config
  381. setenforce 0 2>/dev/null
  382. exit 0
  383. %post network-manager
  384. # Create NetworkManager configuration if we do not have it
  385. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  386. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  387. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  388. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  389. fi
  390. # Remove ip_forward setting from sysctl, so NM will not reset it
  391. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  392. /usr/lib/qubes/qubes-fix-nm-conf.sh
  393. %post networking
  394. %systemd_post qubes-firewall.service
  395. %systemd_post qubes-iptables.service
  396. %systemd_post qubes-network.service
  397. %systemd_post qubes-updates-proxy.service
  398. %post qrexec
  399. %systemd_post qubes-qrexec-agent.service
  400. %preun
  401. if [ "$1" = 0 ] ; then
  402. # no more packages left
  403. if [ -e /var/lib/qubes/fstab.orig ] ; then
  404. mv /var/lib/qubes/fstab.orig /etc/fstab
  405. fi
  406. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  407. if [ -e /var/lib/qubes/serial.orig ] ; then
  408. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  409. fi
  410. fi
  411. %preun networking
  412. %systemd_preun qubes-firewall.service
  413. %systemd_preun qubes-iptables.service
  414. %systemd_preun qubes-network.service
  415. %systemd_preun qubes-updates-proxy.service
  416. %preun qrexec
  417. %systemd_preun qubes-qrexec-agent.service
  418. %postun
  419. if [ $1 -eq 0 ] ; then
  420. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  421. if [ -L /lib/firmware/updates ]; then
  422. rm /lib/firmware/updates
  423. fi
  424. rm -rf /var/lib/qubes/xdg
  425. fi
  426. %postun passwordless-root
  427. if [ $1 -eq 0 ]; then
  428. usermod -p '*' root
  429. fi
  430. %posttrans
  431. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  432. %clean
  433. rm -rf $RPM_BUILD_ROOT
  434. rm -f %{name}-%{version}
  435. %files
  436. %defattr(-,root,root,-)
  437. %dir /var/lib/qubes
  438. %dir /var/run/qubes
  439. %{kde_service_dir}/qvm-copy.desktop
  440. %{kde_service_dir}/qvm-move.desktop
  441. %{kde_service_dir}/qvm-dvm.desktop
  442. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  443. /etc/fstab
  444. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  445. %dir /etc/qubes-rpc
  446. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  447. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  448. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  449. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  450. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  451. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  452. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  453. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  454. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  455. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  456. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  457. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  458. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  459. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  460. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  461. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  462. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  463. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  464. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  465. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  466. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  467. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  468. %config(noreplace) /etc/qubes-rpc/qubes.GetDate
  469. %dir /etc/qubes/rpc-config
  470. /etc/qubes/rpc-config/README
  471. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenInVM
  472. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenURL
  473. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectFile
  474. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectDirectory
  475. %config(noreplace) /etc/qubes/rpc-config/qubes.StartApp
  476. %config(noreplace) /etc/qubes/rpc-config/qubes.InstallUpdatesGUI
  477. %dir /etc/qubes/autostart
  478. %config(noreplace) /etc/default/grub.qubes
  479. /etc/qubes/autostart/README.txt
  480. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  481. %dir /etc/qubes/suspend-pre.d
  482. /etc/qubes/suspend-pre.d/README
  483. %dir /etc/qubes/suspend-post.d
  484. /etc/qubes/suspend-post.d/README
  485. /etc/qubes/suspend-post.d/qvm-sync-clock.sh
  486. %dir /etc/qubes/post-install.d
  487. /etc/qubes/post-install.d/README
  488. /etc/qubes/post-install.d/*.sh
  489. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  490. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  491. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  492. %config(noreplace) /etc/qubes-suspend-module-blacklist
  493. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  494. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  495. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  496. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  497. %if %{fedora} < 22
  498. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  499. %endif
  500. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  501. /usr/sbin/qubes-serial-login
  502. /usr/bin/qvm-copy-to-vm
  503. /usr/bin/qvm-move-to-vm
  504. /usr/bin/qvm-copy
  505. /usr/bin/qvm-move
  506. /usr/bin/qvm-open-in-dvm
  507. /usr/bin/qvm-open-in-vm
  508. /usr/bin/qvm-run-vm
  509. /usr/bin/qvm-features-request
  510. /usr/bin/qvm-sync-clock
  511. /usr/bin/xenstore-watch-qubes
  512. /usr/bin/qubes-desktop-run
  513. /usr/bin/qubes-open
  514. /usr/bin/qubes-session-autostart
  515. %dir /usr/lib/qubes
  516. /usr/lib/qubes/prepare-suspend
  517. /usr/lib/qubes/qfile-agent
  518. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  519. /usr/lib/qubes/qopen-in-vm
  520. /usr/lib/qubes/qrun-in-vm
  521. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  522. /usr/lib/qubes/qvm-copy-to-vm.kde
  523. /usr/lib/qubes/qvm-move-to-vm.kde
  524. /usr/lib/qubes/tar2qfile
  525. /usr/lib/qubes/vm-file-editor
  526. /usr/lib/qubes/close-window
  527. /usr/lib/qubes/xdg-icon
  528. /usr/lib/qubes/update-proxy-configs
  529. /usr/lib/qubes/upgrades-installed-check
  530. /usr/lib/qubes/upgrades-status-notify
  531. /usr/lib/qubes/qubes-sync-clock
  532. /usr/lib/qubes/resize-rootfs
  533. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  534. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  535. %dir /usr/lib/qubes/init
  536. /usr/lib/qubes/init/bind-dirs.sh
  537. /usr/lib/qubes/init/control-printer-icon.sh
  538. /usr/lib/qubes/init/functions
  539. /usr/lib/qubes/init/misc-post-stop.sh
  540. /usr/lib/qubes/init/misc-post.sh
  541. /usr/lib/qubes/init/mount-dirs.sh
  542. /usr/lib/qubes/init/qubes-early-vm-config.sh
  543. /usr/lib/qubes/init/qubes-random-seed.sh
  544. /usr/lib/qubes/init/qubes-sysinit.sh
  545. /usr/lib/qubes/init/resize-rootfs-if-needed.sh
  546. /usr/lib/qubes/init/setup-rw.sh
  547. /usr/lib/qubes/init/setup-rwdev.sh
  548. /usr/lib/qubes/init/functions
  549. %dir /usr/lib/qubes-bind-dirs.d
  550. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  551. /usr/lib/python2.7/site-packages/qubesxdg.py*
  552. /usr/share/qubes/serial.conf
  553. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  554. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  555. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  556. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  557. %{_mandir}/man1/qvm-*.1*
  558. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  559. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  560. %dir %{python_sitelib}/qubesagent
  561. %{python_sitelib}/qubesagent/__init__.py*
  562. %{python_sitelib}/qubesagent/firewall.py*
  563. %{python_sitelib}/qubesagent/test_firewall.py*
  564. /usr/share/qubes/mime-override/globs
  565. /usr/share/qubes/qubes-master-key.asc
  566. %dir /mnt/removable
  567. %dir /rw
  568. %files -n python2-dnf-plugins-qubes-hooks
  569. %{python2_sitelib}/dnf-plugins/*
  570. %if 0%{fedora} >= 23
  571. %files -n python3-dnf-plugins-qubes-hooks
  572. %{python3_sitelib}/dnf-plugins/*
  573. %endif
  574. %if 0%{?rhel} >= 7
  575. %files -n python34-dnf-plugins-qubes-hooks
  576. %{python3_sitelib}/dnf-plugins/*
  577. %endif
  578. %files qrexec
  579. %config(noreplace) /etc/pam.d/qrexec
  580. /usr/bin/qrexec-fork-server
  581. /usr/bin/qrexec-client-vm
  582. /usr/lib/qubes/qrexec-agent
  583. /usr/lib/qubes/qrexec-client-vm
  584. /usr/lib/qubes/qrexec_client_vm
  585. /usr/lib/qubes/qubes-rpc-multiplexer
  586. /lib/systemd/system/qubes-qrexec-agent.service
  587. %{_mandir}/man1/qrexec-client-vm.1*
  588. %files nautilus
  589. /usr/lib/qubes/qvm-copy-to-vm.gnome
  590. /usr/lib/qubes/qvm-move-to-vm.gnome
  591. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  592. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  593. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  594. %files dom0-updates
  595. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  596. /usr/lib/qubes/qubes-download-dom0-updates.sh
  597. %files networking
  598. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  599. %config(noreplace) /etc/qubes/ip6tables.rules
  600. %config(noreplace) /etc/qubes/iptables.rules
  601. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  602. %config(noreplace) /etc/tinyproxy/updates-blacklist
  603. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  604. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  605. /etc/xen/scripts/vif-qubes-nat.sh
  606. /etc/xen/scripts/vif-route-qubes
  607. /lib/systemd/system/qubes-firewall.service
  608. /lib/systemd/system/qubes-iptables.service
  609. /lib/systemd/system/qubes-network.service
  610. /lib/systemd/system/qubes-updates-proxy.service
  611. /usr/lib/qubes/init/network-proxy-setup.sh
  612. /usr/lib/qubes/init/qubes-iptables
  613. /usr/lib/qubes/iptables-updates-proxy
  614. /usr/lib/qubes/qubes-setup-dnat-to-ns
  615. /usr/lib/qubes/setup-ip
  616. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  617. /usr/sbin/qubes-firewall
  618. %files network-manager
  619. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  620. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  621. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  622. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  623. /usr/lib/qubes/network-manager-prepare-conf-dir
  624. /usr/lib/qubes/qubes-fix-nm-conf.sh
  625. /usr/lib/qubes/show-hide-nm-applet.sh
  626. %files passwordless-root
  627. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  628. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  629. %config(noreplace) /etc/sudoers.d/qubes
  630. %package sysvinit
  631. Summary: Qubes unit files for SysV init style or upstart
  632. License: GPL v2 only
  633. Group: Qubes
  634. Requires: upstart
  635. Requires: qubes-core-agent
  636. Requires: qubes-core-agent-qrexec
  637. Requires: qubes-core-agent-networking
  638. Provides: qubes-core-agent-init-scripts
  639. Conflicts: qubes-core-agent-systemd
  640. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  641. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  642. %description sysvinit
  643. The Qubes core startup configuration for SysV init (or upstart).
  644. %files sysvinit
  645. /etc/init.d/qubes-sysinit
  646. /etc/init.d/qubes-core-early
  647. /etc/init.d/qubes-core
  648. /etc/init.d/qubes-core-netvm
  649. /etc/init.d/qubes-firewall
  650. /etc/init.d/qubes-iptables
  651. /etc/init.d/qubes-updates-proxy
  652. /etc/init.d/qubes-qrexec-agent
  653. /etc/init.d/qubes-updates-proxy-forwarder
  654. /etc/sysconfig/modules/qubes-core.modules
  655. %post sysvinit
  656. #echo "--> Turning off unnecessary services..."
  657. # FIXME: perhaps there is more elegant way to do this?
  658. for f in /etc/init.d/*
  659. do
  660. srv=`basename $f`
  661. [ $srv = 'functions' ] && continue
  662. [ $srv = 'killall' ] && continue
  663. [ $srv = 'halt' ] && continue
  664. [ $srv = 'single' ] && continue
  665. [ $srv = 'reboot' ] && continue
  666. [ $srv = 'qubes-gui' ] && continue
  667. chkconfig $srv off
  668. done
  669. #echo "--> Enabling essential services..."
  670. chkconfig rsyslog on
  671. chkconfig haldaemon on
  672. chkconfig messagebus on
  673. for svc in %qubes_services ; do
  674. if [ "$1" = 1 ] ; then
  675. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  676. else
  677. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  678. fi
  679. done
  680. # dropped services
  681. chkconfig qubes-netwatcher off || :
  682. # TODO: make this not display the silly message about security context...
  683. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  684. %preun sysvinit
  685. if [ "$1" = 0 ] ; then
  686. # no more packages left
  687. for svc in %qubes_services ; do
  688. chkconfig --del $svc
  689. done
  690. fi
  691. %package systemd
  692. Summary: Qubes unit files for SystemD init style
  693. License: GPL v2 only
  694. Group: Qubes
  695. Requires: systemd
  696. Requires(post): systemd-units
  697. Requires(preun): systemd-units
  698. Requires(postun): systemd-units
  699. Requires: qubes-core-agent
  700. Provides: qubes-core-agent-init-scripts
  701. Conflicts: qubes-core-agent-sysvinit
  702. Provides: qubes-core-vm-systemd = %{version}-%{release}
  703. Obsoletes: qubes-core-vm-systemd < 4.0.0
  704. %description systemd
  705. The Qubes core startup configuration for SystemD init.
  706. %files systemd
  707. %defattr(-,root,root,-)
  708. /lib/systemd/system/qubes-misc-post.service
  709. /lib/systemd/system/qubes-mount-dirs.service
  710. /lib/systemd/system/qubes-rootfs-resize.service
  711. /lib/systemd/system/qubes-sysinit.service
  712. /lib/systemd/system/qubes-early-vm-config.service
  713. /lib/systemd/system/qubes-update-check.service
  714. /lib/systemd/system/qubes-update-check.timer
  715. /lib/systemd/system/qubes-sync-time.service
  716. /lib/systemd/system/qubes-sync-time.timer
  717. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  718. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  719. /lib/systemd/system-preset/%qubes_preset_file
  720. /lib/modules-load.d/qubes-core.conf
  721. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  722. /lib/systemd/system/crond.service.d/30_qubes.conf
  723. /lib/systemd/system/cups.service.d/30_qubes.conf
  724. /lib/systemd/system/cups.socket.d/30_qubes.conf
  725. /lib/systemd/system/cups.path.d/30_qubes.conf
  726. /lib/systemd/system/cups-browsed.service.d/30_qubes.conf
  727. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  728. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  729. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  730. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  731. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  732. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  733. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  734. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  735. /lib/systemd/system/systemd-timesyncd.service.d/30_qubes.conf
  736. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  737. /lib/systemd/system/tor.service.d/30_qubes.conf
  738. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  739. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  740. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  741. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  742. %post systemd
  743. changed=
  744. %scriptletfuns
  745. if [ $1 -eq 1 ]
  746. then
  747. preset_units %{_presetdir}/%qubes_preset_file initial
  748. changed=true
  749. else
  750. preset_units %{_presetdir}/%qubes_preset_file upgrade
  751. changed=true
  752. # Upgrade path - now qubes-iptables is used instead
  753. for svc in iptables ip6tables
  754. do
  755. if [ -f "$svc".service ]
  756. then
  757. systemctl --no-reload preset "$svc".service
  758. changed=true
  759. fi
  760. done
  761. fi
  762. if [ $1 -eq 1 ]
  763. then
  764. # First install.
  765. # Set default "runlevel".
  766. # FIXME: this ought to be done via kernel command line.
  767. # The fewer deviations of the template from the seed
  768. # image, the better.
  769. rm -f %{_sysconfdir}/systemd/system/default.target
  770. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  771. changed=true
  772. fi
  773. # remove old symlinks
  774. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  775. then
  776. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  777. changed=true
  778. fi
  779. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  780. then
  781. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  782. changed=true
  783. fi
  784. if [ "x$changed" != "x" ]
  785. then
  786. systemctl daemon-reload
  787. fi
  788. %preun systemd
  789. if [ $1 -eq 0 ] ; then
  790. # Run this only during uninstall.
  791. # Save the preset file to later use it to re-preset services there
  792. # once the Qubes OS preset file is removed.
  793. mkdir -p %{_rundir}/qubes-uninstall
  794. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  795. fi
  796. %postun systemd
  797. changed=
  798. %scriptletfuns
  799. if [ -d %{_rundir}/qubes-uninstall ]
  800. then
  801. # We have a saved preset file (or more).
  802. # Re-preset the units mentioned there.
  803. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  804. rm -rf %{_rundir}/qubes-uninstall
  805. changed=true
  806. fi
  807. if [ "x$changed" != "x" ]
  808. then
  809. systemctl daemon-reload
  810. fi