core-vm.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Requires: iptables-services
  38. Conflicts: firewalld
  39. %endif
  40. Requires: /usr/bin/mimeopen
  41. Requires: ethtool
  42. Requires: tinyproxy
  43. Requires: ntpdate
  44. Requires: net-tools
  45. Requires: nautilus-actions
  46. Requires: qubes-core-vm-kernel-placeholder
  47. Requires: qubes-utils
  48. Requires: initscripts
  49. %if %{fedora} >= 20
  50. # gpk-update-viewer required by qubes-manager
  51. Requires: gnome-packagekit-updater
  52. %endif
  53. Requires: ImageMagick
  54. Requires: fakeroot
  55. Requires: desktop-notification-daemon
  56. Requires: qubes-libvchan
  57. Requires: qubes-db-vm
  58. Provides: qubes-core-vm
  59. Obsoletes: qubes-core-commonvm
  60. Obsoletes: qubes-core-appvm
  61. Obsoletes: qubes-core-netvm
  62. Obsoletes: qubes-core-proxyvm
  63. Obsoletes: qubes-upgrade-vm < 2.0
  64. BuildRequires: xen-devel
  65. BuildRequires: qubes-utils-devel >= 2.0.5
  66. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  67. %define _builddir %(pwd)
  68. %define kde_service_dir /usr/share/kde4/services
  69. %description
  70. The Qubes core files for installation inside a Qubes VM.
  71. %prep
  72. # we operate on the current directory, so no need to unpack anything
  73. # symlink is to generate useful debuginfo packages
  74. rm -f %{name}-%{version}
  75. ln -sf . %{name}-%{version}
  76. %setup -T -D
  77. %build
  78. for dir in qubes-rpc qrexec misc; do
  79. (cd $dir; make)
  80. done
  81. %pre
  82. if [ "$1" != 1 ] ; then
  83. # do this whole %pre thing only when updating for the first time...
  84. exit 0
  85. fi
  86. mkdir -p /var/lib/qubes
  87. if [ -e /etc/fstab ] ; then
  88. mv /etc/fstab /var/lib/qubes/fstab.orig
  89. fi
  90. adduser --create-home user
  91. usermod -p '' root
  92. usermod -L user
  93. %install
  94. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  95. make install-vm DESTDIR=$RPM_BUILD_ROOT
  96. # Create ghost files to silent rpmbuild warnings, those files will NOT be
  97. # included in package
  98. mkdir -p $RPM_BUILD_ROOT/etc/systemd/system
  99. for f in ModemManager.service NetworkManager.service \
  100. NetworkManager-wait-online.service cups.service cups.socket cups.path; do
  101. cp $RPM_BUILD_ROOT/usr/lib/qubes/init/$f $RPM_BUILD_ROOT/etc/systemd/system/
  102. done
  103. %if %{fedora} < 21
  104. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/iptables $RPM_BUILD_ROOT/etc/sysconfig/iptables
  105. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/ip6tables $RPM_BUILD_ROOT/etc/sysconfig/ip6tables
  106. %endif
  107. %triggerin -- initscripts
  108. if [ -e /etc/init/serial.conf ]; then
  109. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  110. fi
  111. %triggerin -- pulseaudio-module-x11
  112. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/pulseaudio.desktop
  113. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/pulseaudio.desktop
  114. %post
  115. # disable some Upstart services
  116. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  117. if [ -e /etc/init/$F.conf ]; then
  118. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  119. fi
  120. done
  121. remove_ShowIn () {
  122. if [ -e /etc/xdg/autostart/$1.desktop ]; then
  123. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/$1.desktop
  124. fi
  125. }
  126. # reenable if disabled by some earlier version of package
  127. remove_ShowIn abrt-applet.desktop imsettings-start.desktop
  128. # don't want it at all
  129. for F in deja-dup-monitor krb5-auth-dialog pulseaudio restorecond sealertauto gnome-power-manager gnome-sound-applet gnome-screensaver orca-autostart; do
  130. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  131. remove_ShowIn $F
  132. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/$F.desktop
  133. fi
  134. done
  135. # don't want it in DisposableVM
  136. for F in gcm-apply ; do
  137. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  138. remove_ShowIn $F
  139. echo 'NotShowIn=DisposableVM;' >> /etc/xdg/autostart/$F.desktop
  140. fi
  141. done
  142. # want it in AppVM only
  143. for F in gnome-keyring-gpg gnome-keyring-pkcs11 gnome-keyring-secrets gnome-keyring-ssh gnome-settings-daemon user-dirs-update-gtk gsettings-data-convert ; do
  144. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  145. remove_ShowIn $F
  146. echo 'OnlyShowIn=GNOME;AppVM;' >> /etc/xdg/autostart/$F.desktop
  147. fi
  148. done
  149. # remove existing rule to add own later
  150. for F in gpk-update-icon nm-applet ; do
  151. remove_ShowIn $F
  152. done
  153. echo 'OnlyShowIn=GNOME;UpdateableVM;' >> /etc/xdg/autostart/gpk-update-icon.desktop || :
  154. %if %{fedora} >= 20
  155. echo 'OnlyShowIn=GNOME;QUBES;' >> /etc/xdg/autostart/nm-applet.desktop || :
  156. %else
  157. echo 'OnlyShowIn=GNOME;NetVM;' >> /etc/xdg/autostart/nm-applet.desktop || :
  158. %endif
  159. # Create NetworkManager configuration if we do not have it
  160. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  161. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  162. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  163. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  164. fi
  165. /usr/lib/qubes/qubes-fix-nm-conf.sh
  166. # Remove ip_forward setting from sysctl, so NM will not reset it
  167. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  168. # Remove old firmware updates link
  169. if [ -L /lib/firmware/updates ]; then
  170. rm -f /lib/firmware/updates
  171. fi
  172. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  173. echo >> /etc/yum.conf
  174. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  175. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  176. fi
  177. # Revert 'Prevent unnecessary updates in VMs':
  178. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  179. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  180. if ! grep -q localhost /etc/hosts; then
  181. cat <<EOF > /etc/hosts
  182. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  183. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  184. EOF
  185. fi
  186. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  187. # in the form expected by qubes-sysinit.sh
  188. for ip in '127\.0\.0\.1' '::1'; do
  189. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  190. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  191. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  192. else
  193. echo "${ip} `hostname`" >> /etc/hosts
  194. fi
  195. done
  196. # Copy ip(|6)tables into place if they do not already exist in filesystem.
  197. # This prevents conflict with iptables-service
  198. if [ ! -f '/etc/sysconfig/iptables' ]; then
  199. cp -p /usr/lib/qubes/init/iptables /etc/sysconfig/iptables
  200. fi
  201. if [ ! -f '/etc/sysconfig/ip6tables' ]; then
  202. cp -p /usr/lib/qubes/init/ip6tables /etc/sysconfig/ip6tables
  203. fi
  204. if [ "$1" != 1 ] ; then
  205. # do the rest of %post thing only when updating for the first time...
  206. exit 0
  207. fi
  208. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  209. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  210. fi
  211. # Remove most of the udev scripts to speed up the VM boot time
  212. # Just leave the xen* scripts, that are needed if this VM was
  213. # ever used as a net backend (e.g. as a VPN domain in the future)
  214. #echo "--> Removing unnecessary udev scripts..."
  215. mkdir -p /var/lib/qubes/removed-udev-scripts
  216. for f in /etc/udev/rules.d/*
  217. do
  218. if [ $(basename $f) == "xen-backend.rules" ] ; then
  219. continue
  220. fi
  221. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  222. continue
  223. fi
  224. if echo $f | grep -q qubes; then
  225. continue
  226. fi
  227. mv $f /var/lib/qubes/removed-udev-scripts/
  228. done
  229. mkdir -p /rw
  230. #rm -f /etc/mtab
  231. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  232. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  233. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  234. %triggerin -- notification-daemon
  235. # Enable autostart of notification-daemon when installed
  236. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  237. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  238. fi
  239. exit 0
  240. %triggerin -- selinux-policy
  241. #echo "--> Disabling SELinux..."
  242. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  243. mv /etc/selinux/config.processed /etc/selinux/config
  244. setenforce 0 2>/dev/null
  245. exit 0
  246. %preun
  247. if [ "$1" = 0 ] ; then
  248. # no more packages left
  249. if [ -e /var/lib/qubes/fstab.orig ] ; then
  250. mv /var/lib/qubes/fstab.orig /etc/fstab
  251. fi
  252. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  253. if [ -e /var/lib/qubes/serial.orig ] ; then
  254. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  255. fi
  256. fi
  257. %postun
  258. if [ $1 -eq 0 ] ; then
  259. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  260. if [ -L /lib/firmware/updates ]; then
  261. rm /lib/firmware/updates
  262. fi
  263. fi
  264. %posttrans
  265. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  266. %clean
  267. rm -rf $RPM_BUILD_ROOT
  268. rm -f %{name}-%{version}
  269. %files
  270. %defattr(-,root,root,-)
  271. %dir /var/lib/qubes
  272. %dir /var/run/qubes
  273. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  274. %{kde_service_dir}/qvm-copy.desktop
  275. %{kde_service_dir}/qvm-move.desktop
  276. %{kde_service_dir}/qvm-dvm.desktop
  277. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  278. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  279. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  280. /etc/dispvm-dotfiles.tbz
  281. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  282. /etc/fstab
  283. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  284. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  285. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  286. %dir /etc/qubes-rpc
  287. /etc/qubes-rpc/qubes.Filecopy
  288. /etc/qubes-rpc/qubes.OpenInVM
  289. /etc/qubes-rpc/qubes.GetAppmenus
  290. /etc/qubes-rpc/qubes.VMShell
  291. /etc/qubes-rpc/qubes.SyncNtpClock
  292. /etc/qubes-rpc/qubes.SuspendPre
  293. /etc/qubes-rpc/qubes.SuspendPost
  294. /etc/qubes-rpc/qubes.WaitForSession
  295. /etc/qubes-rpc/qubes.DetachPciDevice
  296. /etc/qubes-rpc/qubes.Backup
  297. /etc/qubes-rpc/qubes.Restore
  298. /etc/qubes-rpc/qubes.SelectFile
  299. /etc/qubes-rpc/qubes.SelectDirectory
  300. /etc/qubes-rpc/qubes.GetImageRGBA
  301. /etc/qubes-rpc/qubes.SetDateTime
  302. %config(noreplace) /etc/sudoers.d/qubes
  303. %if %{fedora} < 21
  304. %config(noreplace) /etc/sysconfig/iptables
  305. %config(noreplace) /etc/sysconfig/ip6tables
  306. %endif
  307. /usr/lib/qubes/init/iptables
  308. /usr/lib/qubes/init/ip6tables
  309. %config(noreplace) /etc/tinyproxy/filter-updates
  310. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  311. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  312. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  313. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  314. /etc/xdg/nautilus-actions/nautilus-actions.conf
  315. /etc/xen/scripts/vif-route-qubes
  316. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  317. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  318. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  319. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  320. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  321. /usr/sbin/qubes-serial-login
  322. /usr/bin/qvm-copy-to-vm
  323. /usr/bin/qvm-move-to-vm
  324. /usr/bin/qvm-open-in-dvm
  325. /usr/bin/qvm-open-in-vm
  326. /usr/bin/qvm-run
  327. /usr/bin/qvm-mru-entry
  328. /usr/bin/xenstore-watch-qubes
  329. /usr/bin/qubes-desktop-run
  330. %dir /usr/lib/qubes
  331. /usr/lib/qubes/vusb-ctl.py*
  332. /usr/lib/qubes/dispvm-prerun.sh
  333. /usr/lib/qubes/sync-ntp-clock
  334. /usr/lib/qubes/prepare-suspend
  335. /usr/lib/qubes/network-manager-prepare-conf-dir
  336. /usr/lib/qubes/show-hide-nm-applet.sh
  337. /usr/lib/qubes/qrexec-agent
  338. /usr/lib/qubes/qrexec-client-vm
  339. /usr/lib/qubes/qrexec_client_vm
  340. /usr/lib/qubes/qubes-rpc-multiplexer
  341. /usr/lib/qubes/qfile-agent
  342. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  343. /usr/lib/qubes/qopen-in-vm
  344. /usr/lib/qubes/qrun-in-vm
  345. /usr/lib/qubes/qubes-download-dom0-updates.sh
  346. /usr/lib/qubes/qubes-fix-nm-conf.sh
  347. /usr/lib/qubes/qubes-setup-dnat-to-ns
  348. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  349. /usr/lib/qubes/qvm-copy-to-vm.gnome
  350. /usr/lib/qubes/qvm-copy-to-vm.kde
  351. /usr/lib/qubes/qvm-move-to-vm.gnome
  352. /usr/lib/qubes/qvm-move-to-vm.kde
  353. /usr/lib/qubes/setup-ip
  354. /usr/lib/qubes/tar2qfile
  355. /usr/lib/qubes/vm-file-editor
  356. /usr/lib/qubes/wrap-in-html-if-url.sh
  357. /usr/lib/qubes/iptables-updates-proxy
  358. /usr/lib/qubes/close-window
  359. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  360. /usr/sbin/qubes-firewall
  361. /usr/sbin/qubes-netwatcher
  362. /usr/share/qubes/serial.conf
  363. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  364. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  365. /usr/share/file-manager/actions/qvm-copy-gnome.desktop
  366. /usr/share/file-manager/actions/qvm-move-gnome.desktop
  367. /usr/share/file-manager/actions/qvm-dvm-gnome.desktop
  368. %dir /usr/share/qubes
  369. /usr/share/qubes/mime-override/globs
  370. %dir /home_volatile
  371. %attr(700,user,user) /home_volatile/user
  372. %dir /mnt/removable
  373. %dir /rw
  374. %package sysvinit
  375. Summary: Qubes unit files for SysV init style or upstart
  376. License: GPL v2 only
  377. Group: Qubes
  378. Requires: upstart
  379. Requires: qubes-core-vm
  380. Provides: qubes-core-vm-init-scripts
  381. Conflicts: qubes-core-vm-systemd
  382. %description sysvinit
  383. The Qubes core startup configuration for SysV init (or upstart).
  384. %files sysvinit
  385. /etc/init.d/qubes-core
  386. /etc/init.d/qubes-core-appvm
  387. /etc/init.d/qubes-core-netvm
  388. /etc/init.d/qubes-firewall
  389. /etc/init.d/qubes-netwatcher
  390. /etc/init.d/qubes-updates-proxy
  391. /etc/init.d/qubes-qrexec-agent
  392. /etc/sysconfig/modules/qubes-core.modules
  393. /etc/sysconfig/modules/qubes-misc.modules
  394. %post sysvinit
  395. #echo "--> Turning off unnecessary services..."
  396. # FIXME: perhaps there is more elegant way to do this?
  397. for f in /etc/init.d/*
  398. do
  399. srv=`basename $f`
  400. [ $srv = 'functions' ] && continue
  401. [ $srv = 'killall' ] && continue
  402. [ $srv = 'halt' ] && continue
  403. [ $srv = 'single' ] && continue
  404. [ $srv = 'reboot' ] && continue
  405. [ $srv = 'qubes-gui' ] && continue
  406. chkconfig $srv off
  407. done
  408. #echo "--> Enabling essential services..."
  409. chkconfig rsyslog on
  410. chkconfig haldaemon on
  411. chkconfig messagebus on
  412. chkconfig iptables on
  413. chkconfig ip6tables on
  414. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  415. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  416. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  417. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  418. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  419. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  420. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  421. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  422. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  423. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  424. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  425. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  426. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  427. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  428. # TODO: make this not display the silly message about security context...
  429. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  430. %preun sysvinit
  431. if [ "$1" = 0 ] ; then
  432. # no more packages left
  433. chkconfig qubes-core off
  434. chkconfig qubes-core-netvm off
  435. chkconfig qubes-core-appvm off
  436. chkconfig qubes-firewall off
  437. chkconfig qubes-netwatcher off
  438. chkconfig qubes-updates-proxy off
  439. chkconfig qubes-qrexec-agent off
  440. fi
  441. %package systemd
  442. Summary: Qubes unit files for SystemD init style
  443. License: GPL v2 only
  444. Group: Qubes
  445. Requires: systemd
  446. Requires(post): systemd-units
  447. Requires(preun): systemd-units
  448. Requires(postun): systemd-units
  449. Requires: qubes-core-vm
  450. Provides: qubes-core-vm-init-scripts
  451. Conflicts: qubes-core-vm-sysvinit
  452. %description systemd
  453. The Qubes core startup configuration for SystemD init.
  454. %files systemd
  455. %defattr(-,root,root,-)
  456. /lib/systemd/system/qubes-dvm.service
  457. /lib/systemd/system/qubes-misc-post.service
  458. /lib/systemd/system/qubes-firewall.service
  459. /lib/systemd/system/qubes-netwatcher.service
  460. /lib/systemd/system/qubes-network.service
  461. /lib/systemd/system/qubes-sysinit.service
  462. /lib/systemd/system/qubes-update-check.service
  463. /lib/systemd/system/qubes-update-check.timer
  464. /lib/systemd/system/qubes-updates-proxy.service
  465. /lib/systemd/system/qubes-qrexec-agent.service
  466. /lib/modules-load.d/qubes-core.conf
  467. /lib/modules-load.d/qubes-misc.conf
  468. %dir /usr/lib/qubes/init
  469. /usr/lib/qubes/init/prepare-dvm.sh
  470. /usr/lib/qubes/init/network-proxy-setup.sh
  471. /usr/lib/qubes/init/misc-post.sh
  472. /usr/lib/qubes/init/misc-post-stop.sh
  473. /usr/lib/qubes/init/qubes-sysinit.sh
  474. /usr/lib/qubes/init/ModemManager.service
  475. /usr/lib/qubes/init/NetworkManager.service
  476. /usr/lib/qubes/init/NetworkManager-wait-online.service
  477. /usr/lib/qubes/init/cups.service
  478. /usr/lib/qubes/init/cups.socket
  479. /usr/lib/qubes/init/cups.path
  480. /usr/lib/qubes/init/ntpd.service
  481. /usr/lib/qubes/init/chronyd.service
  482. %ghost %attr(0644,root,root) /etc/systemd/system/ModemManager.service
  483. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager.service
  484. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager-wait-online.service
  485. %ghost %attr(0644,root,root) /etc/systemd/system/cups.service
  486. %ghost %attr(0644,root,root) /etc/systemd/system/cups.socket
  487. %ghost %attr(0644,root,root) /etc/systemd/system/cups.path
  488. %post systemd
  489. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-firewall qubes-updates-proxy qubes-qrexec-agent; do
  490. /bin/systemctl enable $srv.service 2> /dev/null
  491. done
  492. /bin/systemctl enable qubes-update-check.timer 2> /dev/null
  493. UNITDIR=/lib/systemd/system
  494. OVERRIDEDIR=/usr/lib/qubes/init
  495. # Install overriden services only when original exists
  496. for srv in cups ModemManager NetworkManager NetworkManager-wait-online ntpd chronyd; do
  497. if [ -f $UNITDIR/$srv.service ]; then
  498. cp $OVERRIDEDIR/$srv.service /etc/systemd/system/
  499. fi
  500. if [ -f $UNITDIR/$srv.socket -a -f $OVERRIDEDIR/$srv.socket ]; then
  501. cp $OVERRIDEDIR/$srv.socket /etc/systemd/system/
  502. fi
  503. if [ -f $UNITDIR/$srv.path -a -f $OVERRIDEDIR/$srv.path ]; then
  504. cp $OVERRIDEDIR/$srv.path /etc/systemd/system/
  505. fi
  506. done
  507. # Set default "runlevel"
  508. rm -f /etc/systemd/system/default.target
  509. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  510. DISABLE_SERVICES="alsa-store alsa-restore auditd avahi avahi-daemon backuppc cpuspeed crond"
  511. DISABLE_SERVICES="$DISABLE_SERVICES fedora-autorelabel fedora-autorelabel-mark ipmi hwclock-load hwclock-save"
  512. DISABLE_SERVICES="$DISABLE_SERVICES mdmonitor multipathd openct rpcbind mcelog fedora-storage-init fedora-storage-init-late"
  513. DISABLE_SERVICES="$DISABLE_SERVICES plymouth-start plymouth-read-write plymouth-quit plymouth-quit-wait"
  514. DISABLE_SERVICES="$DISABLE_SERVICES sshd tcsd sm-client sendmail mdmonitor-takeover"
  515. DISABLE_SERVICES="$DISABLE_SERVICES rngd smartd upower irqbalance colord"
  516. for srv in $DISABLE_SERVICES; do
  517. if [ -f /lib/systemd/system/$srv.service ]; then
  518. if fgrep -q '[Install]' /lib/systemd/system/$srv.service; then
  519. /bin/systemctl disable $srv.service 2> /dev/null
  520. else
  521. # forcibly disable
  522. ln -sf /dev/null /etc/systemd/system/$srv.service
  523. fi
  524. fi
  525. done
  526. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  527. # Enable some services
  528. /bin/systemctl enable iptables.service 2> /dev/null
  529. /bin/systemctl enable ip6tables.service 2> /dev/null
  530. /bin/systemctl enable rsyslog.service 2> /dev/null
  531. /bin/systemctl enable ntpd.service 2> /dev/null
  532. # Enable cups only when it is real SystemD service
  533. [ -e /lib/systemd/system/cups.service ] && /bin/systemctl enable cups.service 2> /dev/null
  534. exit 0
  535. %triggerin systemd -- NetworkManager
  536. UNITDIR=/lib/systemd/system
  537. OVERRIDEDIR=/usr/lib/qubes/init
  538. # Install overriden services only when original exists
  539. for srv in ModemManager NetworkManager NetworkManager-wait-online; do
  540. if [ -f $UNITDIR/$srv.service ]; then
  541. cp $OVERRIDEDIR/$srv.service /etc/systemd/system/
  542. fi
  543. if [ -f $UNITDIR/$srv.socket -a -f $OVERRIDEDIR/$srv.socket ]; then
  544. cp $OVERRIDEDIR/$srv.socket /etc/systemd/system/
  545. fi
  546. if [ -f $UNITDIR/$srv.path -a -f $OVERRIDEDIR/$srv.path ]; then
  547. cp $OVERRIDEDIR/$srv.path /etc/systemd/system/
  548. fi
  549. done
  550. # Disable original service to enable overriden one
  551. /bin/systemctl disable ModemManager.service 2> /dev/null
  552. /bin/systemctl disable NetworkManager.service 2> /dev/null
  553. # Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)
  554. /bin/systemctl mask dbus-org.freedesktop.NetworkManager.service 2> /dev/null
  555. /bin/systemctl enable ModemManager.service 2> /dev/null
  556. /bin/systemctl enable NetworkManager.service 2> /dev/null
  557. # Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811
  558. /bin/systemctl enable NetworkManager-dispatcher.service 2> /dev/null
  559. exit 0
  560. %triggerin systemd -- cups
  561. UNITDIR=/lib/systemd/system
  562. OVERRIDEDIR=/usr/lib/qubes/init
  563. # Install overriden services only when original exists
  564. for srv in cups; do
  565. if [ -f $UNITDIR/$srv.service ]; then
  566. cp $OVERRIDEDIR/$srv.service /etc/systemd/system/
  567. fi
  568. if [ -f $UNITDIR/$srv.socket -a -f $OVERRIDEDIR/$srv.socket ]; then
  569. cp $OVERRIDEDIR/$srv.socket /etc/systemd/system/
  570. fi
  571. if [ -f $UNITDIR/$srv.path -a -f $OVERRIDEDIR/$srv.path ]; then
  572. cp $OVERRIDEDIR/$srv.path /etc/systemd/system/
  573. fi
  574. done
  575. # Enable cups only when it is real SystemD service
  576. [ -e /lib/systemd/system/cups.service ] && /bin/systemctl enable cups.service 2> /dev/null
  577. exit 0
  578. %triggerin systemd -- haveged
  579. /bin/systemctl enable haveged.service 2> /dev/null
  580. exit 0
  581. %postun systemd
  582. #Do not run this part on upgrades
  583. if [ "$1" != 0 ] ; then
  584. exit 0
  585. fi
  586. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-qrexec-agent; do
  587. /bin/systemctl disable $srv.service
  588. do