core-agent.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: zenity
  136. Requires: qubes-core-agent-qrexec
  137. Requires: qubes-libvchan
  138. Requires: qubes-db-vm
  139. %if 0%{fedora} >= 23
  140. Requires: python3-dnf-plugins-qubes-hooks
  141. %else
  142. Requires: python2-dnf-plugins-qubes-hooks
  143. %endif
  144. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  145. Obsoletes: qubes-upgrade-vm < 3.2
  146. Provides: qubes-core-vm = %{version}-%{release}
  147. Obsoletes: qubes-core-vm < 4.0.0
  148. Provides: qubes-core-vm-doc = %{version}-%{release}
  149. Obsoletes: qubes-core-vm-doc < 4.0.0
  150. BuildRequires: pandoc
  151. BuildRequires: xen-devel
  152. BuildRequires: libX11-devel
  153. BuildRequires: qubes-utils-devel >= 3.1.3
  154. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  155. BuildRequires: pam-devel
  156. %description
  157. The Qubes core files for installation inside a Qubes VM.
  158. %package -n python2-dnf-plugins-qubes-hooks
  159. Summary: DNF plugin for Qubes specific post-installation actions
  160. BuildRequires: python2-devel
  161. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  162. %description -n python2-dnf-plugins-qubes-hooks
  163. DNF plugin for Qubes specific post-installation actions:
  164. * notify dom0 that updates were installed
  165. * refresh applications shortcut list
  166. %package -n python3-dnf-plugins-qubes-hooks
  167. Summary: DNF plugin for Qubes specific post-installation actions
  168. BuildRequires: python3-devel
  169. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  170. %description -n python3-dnf-plugins-qubes-hooks
  171. DNF plugin for Qubes specific post-installation actions:
  172. * notify dom0 that updates were installed
  173. * refresh applications shortcut list
  174. %package qrexec
  175. Summary: Qubes qrexec agent
  176. Requires: qubes-core-agent
  177. Requires: nautilus-python
  178. Conflicts: qubes-core-vm < 4.0.0
  179. %description qrexec
  180. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  181. requested by dom0 or other VMs, according to dom0-enforced policy.
  182. %package nautilus
  183. Summary: Qubes integration for Nautilus
  184. Requires: qubes-core-agent
  185. Requires: nautilus-python
  186. Conflicts: qubes-core-vm < 4.0.0
  187. %description nautilus
  188. Nautilus addons for inter-VM file copy/move/open.
  189. %package dom0-updates
  190. Summary: Scripts required to handle dom0 updates
  191. Requires: qubes-core-agent
  192. Requires: fakeroot
  193. Conflicts: qubes-core-vm < 4.0.0
  194. %description dom0-updates
  195. Scripts required to handle dom0 updates.
  196. %package networking
  197. Summary: Networking support for Qubes VM
  198. Requires: ethtool
  199. Requires: net-tools
  200. Requires: nftables
  201. Requires: socat
  202. Requires: qubes-core-agent
  203. Requires: tinyproxy
  204. Conflicts: qubes-core-vm < 4.0.0
  205. %description networking
  206. This package provides:
  207. * basic network functionality (setting IP address, DNS, default gateway)
  208. * proxy service used by TemplateVMs to download updates
  209. * qubes-firewall service (FirewallVM)
  210. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  211. qubes-core-agent-network-manager.
  212. %package network-manager
  213. Summary: NetworkManager integration for Qubes VM
  214. # to show/hide nm-applet
  215. Requires: NetworkManager >= 0.8.1-1
  216. Requires: glib2
  217. Requires: qubes-core-agent-networking
  218. Conflicts: qubes-core-vm < 4.0.0
  219. %description network-manager
  220. Integration of NetworkManager for Qubes VM:
  221. * make connections config persistent
  222. * adjust DNS redirections when needed
  223. * show/hide NetworkManager applet icon
  224. %package passwordless-root
  225. Summary: Passwordless root access from normal user
  226. Conflicts: qubes-core-vm < 4.0.0
  227. %description passwordless-root
  228. Configure sudo, PolicyKit and similar tool to not ask for any password when
  229. switching from user to root. Since all the user data in a VM is accessible
  230. already from normal user account, there is not much more to guard there. Qubes
  231. VM is a single user system.
  232. %define _builddir %(pwd)
  233. %define kde_service_dir /usr/share/kde4/services
  234. %prep
  235. # we operate on the current directory, so no need to unpack anything
  236. # symlink is to generate useful debuginfo packages
  237. rm -f %{name}-%{version}
  238. ln -sf . %{name}-%{version}
  239. %setup -T -D
  240. %build
  241. for dir in qubes-rpc qrexec misc; do
  242. (cd $dir; make)
  243. done
  244. make -C doc manpages
  245. %pre
  246. # Make sure there is a qubes group
  247. groupadd --force --system --gid 98 qubes
  248. id -u 'user' >/dev/null 2>&1 || {
  249. useradd --user-group --create-home --shell /bin/bash user
  250. }
  251. usermod -a --groups qubes user
  252. if [ "$1" != 1 ] ; then
  253. # do this whole %%pre thing only when updating for the first time...
  254. exit 0
  255. fi
  256. mkdir -p /var/lib/qubes
  257. if [ -e /etc/fstab ] ; then
  258. mv /etc/fstab /var/lib/qubes/fstab.orig
  259. fi
  260. usermod -L user
  261. %pre passwordless-root
  262. usermod -p '' root
  263. %install
  264. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  265. make install-vm DESTDIR=$RPM_BUILD_ROOT
  266. %if %{fedora} >= 22
  267. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  268. %endif
  269. %triggerin -- initscripts
  270. if [ -e /etc/init/serial.conf ]; then
  271. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  272. fi
  273. %triggerin -- grub2-tools
  274. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  275. # do not keep Qubes-related settings directly in user-controlled config,
  276. # include another file
  277. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  278. fi
  279. %post
  280. # disable some Upstart services
  281. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  282. if [ -e /etc/init/$F.conf ]; then
  283. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  284. fi
  285. done
  286. # Remove old firmware updates link
  287. if [ -L /lib/firmware/updates ]; then
  288. rm -f /lib/firmware/updates
  289. fi
  290. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  291. echo >> /etc/yum.conf
  292. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  293. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  294. fi
  295. # And actually setup the proxy usage in package managers
  296. /usr/lib/qubes/update-proxy-configs
  297. # Location of files which contains list of protected files
  298. mkdir -p /etc/qubes/protected-files.d
  299. . /usr/lib/qubes/init/functions
  300. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  301. if ! is_protected_file /etc/hosts ; then
  302. if ! grep -q localhost /etc/hosts; then
  303. cat <<EOF > /etc/hosts
  304. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  305. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  306. EOF
  307. fi
  308. fi
  309. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  310. # in the form expected by qubes-sysinit.sh
  311. if ! is_protected_file /etc/hostname ; then
  312. for ip in '127\.0\.0\.1' '::1'; do
  313. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  314. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  315. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  316. else
  317. echo "${ip} `hostname`" >> /etc/hosts
  318. fi
  319. done
  320. fi
  321. if [ "$1" != 1 ] ; then
  322. # do the rest of %%post thing only when updating for the first time...
  323. exit 0
  324. fi
  325. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  326. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  327. fi
  328. # Remove most of the udev scripts to speed up the VM boot time
  329. # Just leave the xen* scripts, that are needed if this VM was
  330. # ever used as a net backend (e.g. as a VPN domain in the future)
  331. #echo "--> Removing unnecessary udev scripts..."
  332. mkdir -p /var/lib/qubes/removed-udev-scripts
  333. for f in /etc/udev/rules.d/*
  334. do
  335. if [ $(basename $f) == "xen-backend.rules" ] ; then
  336. continue
  337. fi
  338. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  339. continue
  340. fi
  341. if echo $f | grep -q qubes; then
  342. continue
  343. fi
  344. mv $f /var/lib/qubes/removed-udev-scripts/
  345. done
  346. mkdir -p /rw
  347. #rm -f /etc/mtab
  348. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  349. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  350. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  351. %triggerin -- notification-daemon
  352. # Enable autostart of notification-daemon when installed
  353. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  354. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  355. fi
  356. exit 0
  357. %triggerin -- selinux-policy
  358. #echo "--> Disabling SELinux..."
  359. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  360. mv /etc/selinux/config.processed /etc/selinux/config
  361. setenforce 0 2>/dev/null
  362. exit 0
  363. %post network-manager
  364. # Create NetworkManager configuration if we do not have it
  365. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  366. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  367. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  368. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  369. fi
  370. # Remove ip_forward setting from sysctl, so NM will not reset it
  371. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  372. /usr/lib/qubes/qubes-fix-nm-conf.sh
  373. %preun
  374. if [ "$1" = 0 ] ; then
  375. # no more packages left
  376. if [ -e /var/lib/qubes/fstab.orig ] ; then
  377. mv /var/lib/qubes/fstab.orig /etc/fstab
  378. fi
  379. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  380. if [ -e /var/lib/qubes/serial.orig ] ; then
  381. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  382. fi
  383. fi
  384. %postun
  385. if [ $1 -eq 0 ] ; then
  386. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  387. if [ -L /lib/firmware/updates ]; then
  388. rm /lib/firmware/updates
  389. fi
  390. rm -rf /var/lib/qubes/xdg
  391. fi
  392. %postun passwordless-root
  393. if [ $1 -eq 0 ]; then
  394. usermod -p '*' root
  395. fi
  396. %posttrans
  397. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  398. %clean
  399. rm -rf $RPM_BUILD_ROOT
  400. rm -f %{name}-%{version}
  401. %files
  402. %defattr(-,root,root,-)
  403. %dir /var/lib/qubes
  404. %dir /var/run/qubes
  405. %{kde_service_dir}/qvm-copy.desktop
  406. %{kde_service_dir}/qvm-move.desktop
  407. %{kde_service_dir}/qvm-dvm.desktop
  408. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  409. /etc/fstab
  410. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  411. %dir /etc/qubes-rpc
  412. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  413. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  414. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  415. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  416. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  417. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  418. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  419. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  420. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  421. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  422. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  423. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  424. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  425. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  426. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  427. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  428. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  429. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  430. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  431. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  432. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  433. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  434. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  435. %dir /etc/qubes/autostart
  436. %config(noreplace) /etc/default/grub.qubes
  437. /etc/qubes/autostart/README.txt
  438. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  439. %dir /etc/qubes/suspend-pre.d
  440. /etc/qubes/suspend-pre.d/README
  441. %dir /etc/qubes/suspend-post.d
  442. /etc/qubes/suspend-post.d/README
  443. %dir /etc/qubes/post-install.d
  444. /etc/qubes/post-install.d/README
  445. /etc/qubes/post-install.d/*.sh
  446. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  447. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  448. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  449. %config(noreplace) /etc/qubes-suspend-module-blacklist
  450. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  451. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  452. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  453. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  454. %if %{fedora} < 22
  455. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  456. %endif
  457. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  458. /usr/sbin/qubes-serial-login
  459. /usr/bin/qvm-copy-to-vm
  460. /usr/bin/qvm-move-to-vm
  461. /usr/bin/qvm-open-in-dvm
  462. /usr/bin/qvm-open-in-vm
  463. /usr/bin/qvm-run-vm
  464. /usr/bin/qvm-features-request
  465. /usr/bin/xenstore-watch-qubes
  466. /usr/bin/qubes-desktop-run
  467. /usr/bin/qubes-open
  468. /usr/bin/qubes-session-autostart
  469. %dir /usr/lib/qubes
  470. /usr/lib/qubes/sync-ntp-clock
  471. /usr/lib/qubes/prepare-suspend
  472. /usr/lib/qubes/qfile-agent
  473. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  474. /usr/lib/qubes/qopen-in-vm
  475. /usr/lib/qubes/qrun-in-vm
  476. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  477. /usr/lib/qubes/qvm-copy-to-vm.kde
  478. /usr/lib/qubes/qvm-move-to-vm.kde
  479. /usr/lib/qubes/tar2qfile
  480. /usr/lib/qubes/vm-file-editor
  481. /usr/lib/qubes/close-window
  482. /usr/lib/qubes/xdg-icon
  483. /usr/lib/qubes/update-proxy-configs
  484. /usr/lib/qubes/upgrades-installed-check
  485. /usr/lib/qubes/upgrades-status-notify
  486. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  487. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  488. %dir /usr/lib/qubes/init
  489. /usr/lib/qubes/init/bind-dirs.sh
  490. /usr/lib/qubes/init/control-printer-icon.sh
  491. /usr/lib/qubes/init/functions
  492. /usr/lib/qubes/init/misc-post-stop.sh
  493. /usr/lib/qubes/init/misc-post.sh
  494. /usr/lib/qubes/init/mount-dirs.sh
  495. /usr/lib/qubes/init/qubes-early-vm-config.sh
  496. /usr/lib/qubes/init/qubes-random-seed.sh
  497. /usr/lib/qubes/init/qubes-sysinit.sh
  498. /usr/lib/qubes/init/setup-rw.sh
  499. /usr/lib/qubes/init/setup-rwdev.sh
  500. /usr/lib/qubes/init/functions
  501. %dir /usr/lib/qubes-bind-dirs.d
  502. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  503. /usr/lib/python2.7/site-packages/qubesxdg.py*
  504. /usr/share/qubes/serial.conf
  505. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  506. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  507. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  508. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  509. %{_mandir}/man1/qvm-*.1*
  510. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  511. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  512. %dir %{python_sitelib}/qubesagent
  513. %{python_sitelib}/qubesagent/__init__.py*
  514. %{python_sitelib}/qubesagent/firewall.py*
  515. %{python_sitelib}/qubesagent/test_firewall.py*
  516. /usr/share/qubes/mime-override/globs
  517. /usr/share/qubes/qubes-master-key.asc
  518. %dir /mnt/removable
  519. %dir /rw
  520. %files -n python2-dnf-plugins-qubes-hooks
  521. %{python2_sitelib}/dnf-plugins/*
  522. %files -n python3-dnf-plugins-qubes-hooks
  523. %{python3_sitelib}/dnf-plugins/*
  524. %files qrexec
  525. %config(noreplace) /etc/pam.d/qrexec
  526. /usr/bin/qrexec-fork-server
  527. /usr/bin/qrexec-client-vm
  528. /usr/lib/qubes/qrexec-agent
  529. /usr/lib/qubes/qrexec-client-vm
  530. /usr/lib/qubes/qrexec_client_vm
  531. /usr/lib/qubes/qubes-rpc-multiplexer
  532. /lib/systemd/system/qubes-qrexec-agent.service
  533. %{_mandir}/man1/qrexec-client-vm.1*
  534. %files nautilus
  535. /usr/lib/qubes/qvm-copy-to-vm.gnome
  536. /usr/lib/qubes/qvm-move-to-vm.gnome
  537. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  538. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  539. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  540. %files dom0-updates
  541. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  542. /usr/lib/qubes/qubes-download-dom0-updates.sh
  543. %files networking
  544. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  545. %config(noreplace) /etc/qubes/ip6tables.rules
  546. %config(noreplace) /etc/qubes/iptables.rules
  547. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  548. %config(noreplace) /etc/tinyproxy/updates-blacklist
  549. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  550. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  551. /etc/xen/scripts/vif-qubes-nat.sh
  552. /etc/xen/scripts/vif-route-qubes
  553. /lib/systemd/system/qubes-firewall.service
  554. /lib/systemd/system/qubes-iptables.service
  555. /lib/systemd/system/qubes-network.service
  556. /lib/systemd/system/qubes-updates-proxy.service
  557. /usr/lib/qubes/init/network-proxy-setup.sh
  558. /usr/lib/qubes/init/qubes-iptables
  559. /usr/lib/qubes/iptables-updates-proxy
  560. /usr/lib/qubes/qubes-setup-dnat-to-ns
  561. /usr/lib/qubes/setup-ip
  562. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  563. /usr/sbin/qubes-firewall
  564. %files network-manager
  565. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  566. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  567. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  568. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  569. /usr/lib/qubes/network-manager-prepare-conf-dir
  570. /usr/lib/qubes/qubes-fix-nm-conf.sh
  571. /usr/lib/qubes/show-hide-nm-applet.sh
  572. %files passwordless-root
  573. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  574. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  575. %config(noreplace) /etc/sudoers.d/qubes
  576. %package sysvinit
  577. Summary: Qubes unit files for SysV init style or upstart
  578. License: GPL v2 only
  579. Group: Qubes
  580. Requires: upstart
  581. Requires: qubes-core-agent
  582. Requires: qubes-core-agent-qrexec
  583. Requires: qubes-core-agent-networking
  584. Provides: qubes-core-agent-init-scripts
  585. Conflicts: qubes-core-agent-systemd
  586. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  587. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  588. %description sysvinit
  589. The Qubes core startup configuration for SysV init (or upstart).
  590. %files sysvinit
  591. /etc/init.d/qubes-sysinit
  592. /etc/init.d/qubes-core-early
  593. /etc/init.d/qubes-core
  594. /etc/init.d/qubes-core-netvm
  595. /etc/init.d/qubes-firewall
  596. /etc/init.d/qubes-iptables
  597. /etc/init.d/qubes-updates-proxy
  598. /etc/init.d/qubes-qrexec-agent
  599. /etc/init.d/qubes-updates-proxy-forwarder
  600. /etc/sysconfig/modules/qubes-core.modules
  601. %post sysvinit
  602. #echo "--> Turning off unnecessary services..."
  603. # FIXME: perhaps there is more elegant way to do this?
  604. for f in /etc/init.d/*
  605. do
  606. srv=`basename $f`
  607. [ $srv = 'functions' ] && continue
  608. [ $srv = 'killall' ] && continue
  609. [ $srv = 'halt' ] && continue
  610. [ $srv = 'single' ] && continue
  611. [ $srv = 'reboot' ] && continue
  612. [ $srv = 'qubes-gui' ] && continue
  613. chkconfig $srv off
  614. done
  615. #echo "--> Enabling essential services..."
  616. chkconfig rsyslog on
  617. chkconfig haldaemon on
  618. chkconfig messagebus on
  619. for svc in %qubes_services ; do
  620. if [ "$1" = 1 ] ; then
  621. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  622. else
  623. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  624. fi
  625. done
  626. # dropped services
  627. chkconfig qubes-netwatcher off || :
  628. # TODO: make this not display the silly message about security context...
  629. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  630. %preun sysvinit
  631. if [ "$1" = 0 ] ; then
  632. # no more packages left
  633. for svc in %qubes_services ; do
  634. chkconfig --del $svc
  635. done
  636. fi
  637. %package systemd
  638. Summary: Qubes unit files for SystemD init style
  639. License: GPL v2 only
  640. Group: Qubes
  641. Requires: systemd
  642. Requires(post): systemd-units
  643. Requires(preun): systemd-units
  644. Requires(postun): systemd-units
  645. Requires: qubes-core-agent
  646. Provides: qubes-core-agent-init-scripts
  647. Conflicts: qubes-core-agent-sysvinit
  648. Provides: qubes-core-vm-systemd = %{version}-%{release}
  649. Obsoletes: qubes-core-vm-systemd < 4.0.0
  650. %description systemd
  651. The Qubes core startup configuration for SystemD init.
  652. %files systemd
  653. %defattr(-,root,root,-)
  654. /lib/systemd/system/qubes-misc-post.service
  655. /lib/systemd/system/qubes-mount-dirs.service
  656. /lib/systemd/system/qubes-sysinit.service
  657. /lib/systemd/system/qubes-early-vm-config.service
  658. /lib/systemd/system/qubes-update-check.service
  659. /lib/systemd/system/qubes-update-check.timer
  660. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  661. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  662. /lib/systemd/system-preset/%qubes_preset_file
  663. /lib/modules-load.d/qubes-core.conf
  664. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  665. /lib/systemd/system/crond.service.d/30_qubes.conf
  666. /lib/systemd/system/cups.service.d/30_qubes.conf
  667. /lib/systemd/system/cups.socket.d/30_qubes.conf
  668. /lib/systemd/system/cups.path.d/30_qubes.conf
  669. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  670. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  671. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  672. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  673. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  674. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  675. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  676. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  677. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  678. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  679. /lib/systemd/system/tor.service.d/30_qubes.conf
  680. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  681. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  682. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  683. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  684. %post systemd
  685. changed=
  686. %scriptletfuns
  687. if [ $1 -eq 1 ]
  688. then
  689. preset_units %{_presetdir}/%qubes_preset_file initial
  690. changed=true
  691. else
  692. preset_units %{_presetdir}/%qubes_preset_file upgrade
  693. changed=true
  694. # Upgrade path - now qubes-iptables is used instead
  695. for svc in iptables ip6tables
  696. do
  697. if [ -f "$svc".service ]
  698. then
  699. systemctl --no-reload preset "$svc".service
  700. changed=true
  701. fi
  702. done
  703. fi
  704. if [ $1 -eq 1 ]
  705. then
  706. # First install.
  707. # Set default "runlevel".
  708. # FIXME: this ought to be done via kernel command line.
  709. # The fewer deviations of the template from the seed
  710. # image, the better.
  711. rm -f %{_sysconfdir}/systemd/system/default.target
  712. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  713. changed=true
  714. fi
  715. # remove old symlinks
  716. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  717. then
  718. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  719. changed=true
  720. fi
  721. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  722. then
  723. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  724. changed=true
  725. fi
  726. if [ "x$changed" != "x" ]
  727. then
  728. systemctl daemon-reload
  729. fi
  730. %preun systemd
  731. if [ $1 -eq 0 ] ; then
  732. # Run this only during uninstall.
  733. # Save the preset file to later use it to re-preset services there
  734. # once the Qubes OS preset file is removed.
  735. mkdir -p %{_rundir}/qubes-uninstall
  736. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  737. fi
  738. %postun systemd
  739. changed=
  740. %scriptletfuns
  741. if [ -d %{_rundir}/qubes-uninstall ]
  742. then
  743. # We have a saved preset file (or more).
  744. # Re-preset the units mentioned there.
  745. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  746. rm -rf %{_rundir}/qubes-uninstall
  747. changed=true
  748. fi
  749. if [ "x$changed" != "x" ]
  750. then
  751. systemctl daemon-reload
  752. fi