core-agent.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: zenity
  136. Requires: qubes-libvchan
  137. Requires: qubes-db-vm
  138. %if 0%{fedora} >= 23
  139. Requires: python3-dnf-plugins-qubes-hooks
  140. %else
  141. Requires: python2-dnf-plugins-qubes-hooks
  142. %endif
  143. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  144. Obsoletes: qubes-upgrade-vm < 3.2
  145. Provides: qubes-core-vm = %{version}-%{release}
  146. Obsoletes: qubes-core-vm < 4.0.0
  147. Provides: qubes-core-vm-doc = %{version}-%{release}
  148. Obsoletes: qubes-core-vm-doc < 4.0.0
  149. BuildRequires: pandoc
  150. BuildRequires: xen-devel
  151. BuildRequires: libX11-devel
  152. BuildRequires: qubes-utils-devel >= 3.1.3
  153. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  154. %description
  155. The Qubes core files for installation inside a Qubes VM.
  156. %package -n python2-dnf-plugins-qubes-hooks
  157. Summary: DNF plugin for Qubes specific post-installation actions
  158. BuildRequires: python2-devel
  159. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  160. %description -n python2-dnf-plugins-qubes-hooks
  161. DNF plugin for Qubes specific post-installation actions:
  162. * notify dom0 that updates were installed
  163. * refresh applications shortcut list
  164. %package -n python3-dnf-plugins-qubes-hooks
  165. Summary: DNF plugin for Qubes specific post-installation actions
  166. BuildRequires: python3-devel
  167. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  168. %description -n python3-dnf-plugins-qubes-hooks
  169. DNF plugin for Qubes specific post-installation actions:
  170. * notify dom0 that updates were installed
  171. * refresh applications shortcut list
  172. %package nautilus
  173. Summary: Qubes integration for Nautilus
  174. Requires: qubes-core-agent
  175. Requires: nautilus-python
  176. Conflicts: qubes-core-vm < 4.0.0
  177. %description nautilus
  178. Nautilus addons for inter-VM file copy/move/open.
  179. %package dom0-updates
  180. Summary: Scripts required to handle dom0 updates
  181. Requires: qubes-core-agent
  182. Requires: fakeroot
  183. Conflicts: qubes-core-vm < 4.0.0
  184. %description dom0-updates
  185. Scripts required to handle dom0 updates.
  186. %package networking
  187. Summary: Networking support for Qubes VM
  188. Requires: ethtool
  189. Requires: net-tools
  190. Requires: nftables
  191. Requires: nmap-ncat
  192. Requires: qubes-core-agent
  193. Requires: tinyproxy
  194. Conflicts: qubes-core-vm < 4.0.0
  195. %description networking
  196. This package provides:
  197. * basic network functionality (setting IP address, DNS, default gateway)
  198. * proxy service used by TemplateVMs to download updates
  199. * qubes-firewall service (FirewallVM)
  200. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  201. qubes-core-agent-network-manager.
  202. %package network-manager
  203. Summary: NetworkManager integration for Qubes VM
  204. # to show/hide nm-applet
  205. Requires: NetworkManager >= 0.8.1-1
  206. Requires: dconf
  207. Requires: qubes-core-agent-networking
  208. Conflicts: qubes-core-vm < 4.0.0
  209. %description network-manager
  210. Integration of NetworkManager for Qubes VM:
  211. * make connections config persistent
  212. * adjust DNS redirections when needed
  213. * show/hide NetworkManager applet icon
  214. %package passwordless-root
  215. Summary: Passwordless root access from normal user
  216. Conflicts: qubes-core-vm < 4.0.0
  217. %description passwordless-root
  218. Configure sudo, PolicyKit and similar tool to not ask for any password when
  219. switching from user to root. Since all the user data in a VM is accessible
  220. already from normal user account, there is not much more to guard there. Qubes
  221. VM is a single user system.
  222. %define _builddir %(pwd)
  223. %define kde_service_dir /usr/share/kde4/services
  224. %prep
  225. # we operate on the current directory, so no need to unpack anything
  226. # symlink is to generate useful debuginfo packages
  227. rm -f %{name}-%{version}
  228. ln -sf . %{name}-%{version}
  229. %setup -T -D
  230. %build
  231. for dir in qubes-rpc qrexec misc; do
  232. (cd $dir; make)
  233. done
  234. make -C doc manpages
  235. %pre
  236. # Make sure there is a qubes group
  237. groupadd --force --system --gid 98 qubes
  238. id -u 'user' >/dev/null 2>&1 || {
  239. useradd --user-group --create-home --shell /bin/bash user
  240. }
  241. usermod -a --groups qubes user
  242. if [ "$1" != 1 ] ; then
  243. # do this whole %%pre thing only when updating for the first time...
  244. exit 0
  245. fi
  246. mkdir -p /var/lib/qubes
  247. if [ -e /etc/fstab ] ; then
  248. mv /etc/fstab /var/lib/qubes/fstab.orig
  249. fi
  250. usermod -L user
  251. %pre passwordless-root
  252. usermod -p '' root
  253. %install
  254. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  255. make install-vm DESTDIR=$RPM_BUILD_ROOT
  256. make -C doc install DESTDIR=$RPM_BUILD_ROOT
  257. %if %{fedora} >= 22
  258. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  259. %endif
  260. %triggerin -- initscripts
  261. if [ -e /etc/init/serial.conf ]; then
  262. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  263. fi
  264. %post
  265. # disable some Upstart services
  266. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  267. if [ -e /etc/init/$F.conf ]; then
  268. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  269. fi
  270. done
  271. # Remove old firmware updates link
  272. if [ -L /lib/firmware/updates ]; then
  273. rm -f /lib/firmware/updates
  274. fi
  275. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  276. echo >> /etc/yum.conf
  277. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  278. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  279. fi
  280. # And actually setup the proxy usage in package managers
  281. /usr/lib/qubes/update-proxy-configs
  282. # Location of files which contains list of protected files
  283. mkdir -p /etc/qubes/protected-files.d
  284. . /usr/lib/qubes/init/functions
  285. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  286. if ! is_protected_file /etc/hosts ; then
  287. if ! grep -q localhost /etc/hosts; then
  288. cat <<EOF > /etc/hosts
  289. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  290. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  291. EOF
  292. fi
  293. fi
  294. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  295. # in the form expected by qubes-sysinit.sh
  296. if ! is_protected_file /etc/hostname ; then
  297. for ip in '127\.0\.0\.1' '::1'; do
  298. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  299. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  300. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  301. else
  302. echo "${ip} `hostname`" >> /etc/hosts
  303. fi
  304. done
  305. fi
  306. %if %{fedora} >= 20
  307. # Make sure there is a default locale set so gnome-terminal will start
  308. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  309. touch /etc/locale.conf
  310. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  311. fi
  312. # ... and make sure it is really generated
  313. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  314. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  315. base=`echo "$current_locale" | cut -f 1 -d .`
  316. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  317. [ -n "$charmap" ] && charmap="-f $charmap"
  318. localedef -i $base $charmap $current_locale
  319. fi
  320. %endif
  321. if [ "$1" != 1 ] ; then
  322. # do the rest of %%post thing only when updating for the first time...
  323. exit 0
  324. fi
  325. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  326. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  327. fi
  328. # Remove most of the udev scripts to speed up the VM boot time
  329. # Just leave the xen* scripts, that are needed if this VM was
  330. # ever used as a net backend (e.g. as a VPN domain in the future)
  331. #echo "--> Removing unnecessary udev scripts..."
  332. mkdir -p /var/lib/qubes/removed-udev-scripts
  333. for f in /etc/udev/rules.d/*
  334. do
  335. if [ $(basename $f) == "xen-backend.rules" ] ; then
  336. continue
  337. fi
  338. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  339. continue
  340. fi
  341. if echo $f | grep -q qubes; then
  342. continue
  343. fi
  344. mv $f /var/lib/qubes/removed-udev-scripts/
  345. done
  346. mkdir -p /rw
  347. #rm -f /etc/mtab
  348. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  349. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  350. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  351. %triggerin -- notification-daemon
  352. # Enable autostart of notification-daemon when installed
  353. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  354. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  355. fi
  356. exit 0
  357. %triggerin -- selinux-policy
  358. #echo "--> Disabling SELinux..."
  359. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  360. mv /etc/selinux/config.processed /etc/selinux/config
  361. setenforce 0 2>/dev/null
  362. exit 0
  363. %post network-manager
  364. # Create NetworkManager configuration if we do not have it
  365. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  366. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  367. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  368. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  369. fi
  370. # Remove ip_forward setting from sysctl, so NM will not reset it
  371. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  372. /usr/lib/qubes/qubes-fix-nm-conf.sh
  373. %preun
  374. if [ "$1" = 0 ] ; then
  375. # no more packages left
  376. if [ -e /var/lib/qubes/fstab.orig ] ; then
  377. mv /var/lib/qubes/fstab.orig /etc/fstab
  378. fi
  379. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  380. if [ -e /var/lib/qubes/serial.orig ] ; then
  381. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  382. fi
  383. fi
  384. %postun
  385. if [ $1 -eq 0 ] ; then
  386. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  387. if [ -L /lib/firmware/updates ]; then
  388. rm /lib/firmware/updates
  389. fi
  390. rm -rf /var/lib/qubes/xdg
  391. fi
  392. %postun passwordless-root
  393. if [ $1 -eq 0 ]; then
  394. usermod -p '*' root
  395. fi
  396. %posttrans
  397. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  398. %clean
  399. rm -rf $RPM_BUILD_ROOT
  400. rm -f %{name}-%{version}
  401. %files
  402. %defattr(-,root,root,-)
  403. %dir /var/lib/qubes
  404. %dir /var/run/qubes
  405. %{kde_service_dir}/qvm-copy.desktop
  406. %{kde_service_dir}/qvm-move.desktop
  407. %{kde_service_dir}/qvm-dvm.desktop
  408. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  409. /etc/fstab
  410. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  411. %dir /etc/qubes-rpc
  412. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  413. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  414. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  415. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  416. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  417. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  418. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  419. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  420. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  421. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  422. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  423. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  424. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  425. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  426. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  427. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  428. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  429. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  430. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  431. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  432. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  433. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  434. %dir /etc/qubes/autostart
  435. /etc/qubes/autostart/README.txt
  436. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  437. %dir /etc/qubes/suspend-pre.d
  438. /etc/qubes/suspend-pre.d/README
  439. %dir /etc/qubes/suspend-post.d
  440. /etc/qubes/suspend-post.d/README
  441. %dir /etc/qubes/post-install.d
  442. /etc/qubes/post-install.d/README
  443. /etc/qubes/post-install.d/*.sh
  444. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  445. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  446. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  447. %config(noreplace) /etc/qubes-suspend-module-blacklist
  448. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  449. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  450. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  451. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  452. %if %{fedora} < 22
  453. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  454. %endif
  455. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  456. /usr/sbin/qubes-serial-login
  457. /usr/bin/qvm-copy-to-vm
  458. /usr/bin/qvm-move-to-vm
  459. /usr/bin/qvm-open-in-dvm
  460. /usr/bin/qvm-open-in-vm
  461. /usr/bin/qvm-run-vm
  462. /usr/bin/qvm-features-request
  463. /usr/bin/xenstore-watch-qubes
  464. /usr/bin/qubes-desktop-run
  465. /usr/bin/qubes-open
  466. /usr/bin/qrexec-fork-server
  467. /usr/bin/qrexec-client-vm
  468. /usr/bin/qubes-session-autostart
  469. %dir /usr/lib/qubes
  470. /usr/lib/qubes/sync-ntp-clock
  471. /usr/lib/qubes/prepare-suspend
  472. /usr/lib/qubes/qrexec-agent
  473. /usr/lib/qubes/qrexec-client-vm
  474. /usr/lib/qubes/qrexec_client_vm
  475. /usr/lib/qubes/qubes-rpc-multiplexer
  476. /usr/lib/qubes/qfile-agent
  477. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  478. /usr/lib/qubes/qopen-in-vm
  479. /usr/lib/qubes/qrun-in-vm
  480. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  481. /usr/lib/qubes/qvm-copy-to-vm.kde
  482. /usr/lib/qubes/qvm-move-to-vm.kde
  483. /usr/lib/qubes/tar2qfile
  484. /usr/lib/qubes/vm-file-editor
  485. /usr/lib/qubes/close-window
  486. /usr/lib/qubes/xdg-icon
  487. /usr/lib/qubes/update-proxy-configs
  488. /usr/lib/qubes/upgrades-installed-check
  489. /usr/lib/qubes/upgrades-status-notify
  490. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  491. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  492. %dir /usr/lib/qubes/init
  493. /usr/lib/qubes/init/bind-dirs.sh
  494. /usr/lib/qubes/init/control-printer-icon.sh
  495. /usr/lib/qubes/init/functions
  496. /usr/lib/qubes/init/misc-post-stop.sh
  497. /usr/lib/qubes/init/misc-post.sh
  498. /usr/lib/qubes/init/mount-dirs.sh
  499. /usr/lib/qubes/init/qubes-early-vm-config.sh
  500. /usr/lib/qubes/init/qubes-random-seed.sh
  501. /usr/lib/qubes/init/qubes-sysinit.sh
  502. /usr/lib/qubes/init/setup-rw.sh
  503. /usr/lib/qubes/init/setup-rwdev.sh
  504. /usr/lib/qubes/init/functions
  505. %dir /usr/lib/qubes-bind-dirs.d
  506. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  507. /usr/lib/python2.7/site-packages/qubesxdg.py*
  508. /usr/share/qubes/serial.conf
  509. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  510. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  511. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  512. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  513. %{_mandir}/man1/qvm-*.1*
  514. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  515. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  516. %dir %{python_sitelib}/qubesagent
  517. %{python_sitelib}/qubesagent/__init__.py*
  518. %{python_sitelib}/qubesagent/firewall.py*
  519. %{python_sitelib}/qubesagent/test_firewall.py*
  520. /usr/share/qubes/mime-override/globs
  521. /usr/share/qubes/qubes-master-key.asc
  522. %dir /mnt/removable
  523. %dir /rw
  524. %files -n python2-dnf-plugins-qubes-hooks
  525. %{python2_sitelib}/dnf-plugins/*
  526. %files -n python3-dnf-plugins-qubes-hooks
  527. %{python3_sitelib}/dnf-plugins/*
  528. %files nautilus
  529. /usr/lib/qubes/qvm-copy-to-vm.gnome
  530. /usr/lib/qubes/qvm-move-to-vm.gnome
  531. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  532. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  533. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  534. %files dom0-updates
  535. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  536. /usr/lib/qubes/qubes-download-dom0-updates.sh
  537. %files networking
  538. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  539. %config(noreplace) /etc/qubes/ip6tables.rules
  540. %config(noreplace) /etc/qubes/iptables.rules
  541. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  542. %config(noreplace) /etc/tinyproxy/updates-blacklist
  543. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  544. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  545. /etc/xen/scripts/vif-qubes-nat.sh
  546. /etc/xen/scripts/vif-route-qubes
  547. /lib/systemd/system/qubes-firewall.service
  548. /lib/systemd/system/qubes-iptables.service
  549. /lib/systemd/system/qubes-network.service
  550. /lib/systemd/system/qubes-updates-proxy.service
  551. /usr/lib/qubes/init/network-proxy-setup.sh
  552. /usr/lib/qubes/init/qubes-iptables
  553. /usr/lib/qubes/iptables-updates-proxy
  554. /usr/lib/qubes/qubes-setup-dnat-to-ns
  555. /usr/lib/qubes/setup-ip
  556. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  557. /usr/sbin/qubes-firewall
  558. %files network-manager
  559. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  560. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  561. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  562. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  563. /usr/lib/qubes/network-manager-prepare-conf-dir
  564. /usr/lib/qubes/qubes-fix-nm-conf.sh
  565. /usr/lib/qubes/show-hide-nm-applet.sh
  566. %files passwordless-root
  567. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  568. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  569. %config(noreplace) /etc/sudoers.d/qubes
  570. %package sysvinit
  571. Summary: Qubes unit files for SysV init style or upstart
  572. License: GPL v2 only
  573. Group: Qubes
  574. Requires: upstart
  575. Requires: qubes-core-agent
  576. Requires: qubes-core-agent-networking
  577. Provides: qubes-core-agent-init-scripts
  578. Conflicts: qubes-core-agent-systemd
  579. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  580. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  581. %description sysvinit
  582. The Qubes core startup configuration for SysV init (or upstart).
  583. %files sysvinit
  584. /etc/init.d/qubes-sysinit
  585. /etc/init.d/qubes-core-early
  586. /etc/init.d/qubes-core
  587. /etc/init.d/qubes-core-netvm
  588. /etc/init.d/qubes-firewall
  589. /etc/init.d/qubes-iptables
  590. /etc/init.d/qubes-updates-proxy
  591. /etc/init.d/qubes-qrexec-agent
  592. /etc/init.d/qubes-updates-proxy-forwarder
  593. /etc/sysconfig/modules/qubes-core.modules
  594. /etc/sysconfig/modules/qubes-misc.modules
  595. %post sysvinit
  596. #echo "--> Turning off unnecessary services..."
  597. # FIXME: perhaps there is more elegant way to do this?
  598. for f in /etc/init.d/*
  599. do
  600. srv=`basename $f`
  601. [ $srv = 'functions' ] && continue
  602. [ $srv = 'killall' ] && continue
  603. [ $srv = 'halt' ] && continue
  604. [ $srv = 'single' ] && continue
  605. [ $srv = 'reboot' ] && continue
  606. [ $srv = 'qubes-gui' ] && continue
  607. chkconfig $srv off
  608. done
  609. #echo "--> Enabling essential services..."
  610. chkconfig rsyslog on
  611. chkconfig haldaemon on
  612. chkconfig messagebus on
  613. for svc in %qubes_services ; do
  614. if [ "$1" = 1 ] ; then
  615. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  616. else
  617. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  618. fi
  619. done
  620. # dropped services
  621. chkconfig qubes-netwatcher off || :
  622. # TODO: make this not display the silly message about security context...
  623. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  624. %preun sysvinit
  625. if [ "$1" = 0 ] ; then
  626. # no more packages left
  627. for svc in %qubes_services ; do
  628. chkconfig --del $svc
  629. done
  630. fi
  631. %package systemd
  632. Summary: Qubes unit files for SystemD init style
  633. License: GPL v2 only
  634. Group: Qubes
  635. Requires: systemd
  636. Requires(post): systemd-units
  637. Requires(preun): systemd-units
  638. Requires(postun): systemd-units
  639. Requires: qubes-core-agent
  640. Provides: qubes-core-agent-init-scripts
  641. Conflicts: qubes-core-agent-sysvinit
  642. Provides: qubes-core-vm-systemd = %{version}-%{release}
  643. Obsoletes: qubes-core-vm-systemd < 4.0.0
  644. %description systemd
  645. The Qubes core startup configuration for SystemD init.
  646. %files systemd
  647. %defattr(-,root,root,-)
  648. /lib/systemd/system/qubes-misc-post.service
  649. /lib/systemd/system/qubes-mount-dirs.service
  650. /lib/systemd/system/qubes-sysinit.service
  651. /lib/systemd/system/qubes-early-vm-config.service
  652. /lib/systemd/system/qubes-update-check.service
  653. /lib/systemd/system/qubes-update-check.timer
  654. /lib/systemd/system/qubes-qrexec-agent.service
  655. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  656. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  657. /lib/systemd/system-preset/%qubes_preset_file
  658. /lib/modules-load.d/qubes-core.conf
  659. /lib/modules-load.d/qubes-misc.conf
  660. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  661. /lib/systemd/system/crond.service.d/30_qubes.conf
  662. /lib/systemd/system/cups.service.d/30_qubes.conf
  663. /lib/systemd/system/cups.socket.d/30_qubes.conf
  664. /lib/systemd/system/cups.path.d/30_qubes.conf
  665. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  666. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  667. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  668. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  669. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  670. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  671. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  672. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  673. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  674. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  675. /lib/systemd/system/tor.service.d/30_qubes.conf
  676. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  677. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  678. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  679. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  680. %post systemd
  681. changed=
  682. %scriptletfuns
  683. if [ $1 -eq 1 ]
  684. then
  685. preset_units %{_presetdir}/%qubes_preset_file initial
  686. changed=true
  687. else
  688. preset_units %{_presetdir}/%qubes_preset_file upgrade
  689. changed=true
  690. # Upgrade path - now qubes-iptables is used instead
  691. for svc in iptables ip6tables
  692. do
  693. if [ -f "$svc".service ]
  694. then
  695. systemctl --no-reload preset "$svc".service
  696. changed=true
  697. fi
  698. done
  699. fi
  700. if [ $1 -eq 1 ]
  701. then
  702. # First install.
  703. # Set default "runlevel".
  704. # FIXME: this ought to be done via kernel command line.
  705. # The fewer deviations of the template from the seed
  706. # image, the better.
  707. rm -f %{_sysconfdir}/systemd/system/default.target
  708. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  709. changed=true
  710. fi
  711. # remove old symlinks
  712. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  713. then
  714. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  715. changed=true
  716. fi
  717. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  718. then
  719. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  720. changed=true
  721. fi
  722. if [ "x$changed" != "x" ]
  723. then
  724. systemctl daemon-reload
  725. fi
  726. %preun systemd
  727. if [ $1 -eq 0 ] ; then
  728. # Run this only during uninstall.
  729. # Save the preset file to later use it to re-preset services there
  730. # once the Qubes OS preset file is removed.
  731. mkdir -p %{_rundir}/qubes-uninstall
  732. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  733. fi
  734. %postun systemd
  735. changed=
  736. %scriptletfuns
  737. if [ -d %{_rundir}/qubes-uninstall ]
  738. then
  739. # We have a saved preset file (or more).
  740. # Re-preset the units mentioned there.
  741. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  742. rm -rf %{_rundir}/qubes-uninstall
  743. changed=true
  744. fi
  745. if [ "x$changed" != "x" ]
  746. then
  747. systemctl daemon-reload
  748. fi