core-vm.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. Name: qubes-core-vm
  24. Version: %{version}
  25. Release: 1%{dist}
  26. Summary: The Qubes core files for VM
  27. Group: Qubes
  28. Vendor: Invisible Things Lab
  29. License: GPL
  30. URL: http://www.qubes-os.org
  31. Requires: /usr/bin/xenstore-read
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Requires: iptables-services
  38. Conflicts: firewalld
  39. %endif
  40. Requires: /usr/bin/mimeopen
  41. Requires: ethtool
  42. Requires: tinyproxy
  43. Requires: ntpdate
  44. Requires: net-tools
  45. Requires: nautilus-actions
  46. Requires: qubes-core-vm-kernel-placeholder
  47. Requires: qubes-utils
  48. %if %{fedora} >= 20
  49. # gpk-update-viewer required by qubes-manager
  50. Requires: gnome-packagekit-updater
  51. %endif
  52. Requires: ImageMagick
  53. Requires: fakeroot
  54. Requires: notification-daemon
  55. Provides: qubes-core-vm
  56. Obsoletes: qubes-core-commonvm
  57. Obsoletes: qubes-core-appvm
  58. Obsoletes: qubes-core-netvm
  59. Obsoletes: qubes-core-proxyvm
  60. Obsoletes: qubes-upgrade-vm < 2.0
  61. BuildRequires: xen-devel
  62. BuildRequires: qubes-utils-devel >= 2.0.5
  63. %define _builddir %(pwd)
  64. %define kde_service_dir /usr/share/kde4/services
  65. %description
  66. The Qubes core files for installation inside a Qubes VM.
  67. %prep
  68. # we operate on the current directory, so no need to unpack anything
  69. # symlink is to generate useful debuginfo packages
  70. rm -f %{name}-%{version}
  71. ln -sf . %{name}-%{version}
  72. %setup -T -D
  73. %build
  74. for dir in qubes-rpc qrexec misc; do
  75. (cd $dir; make)
  76. done
  77. %pre
  78. if [ "$1" != 1 ] ; then
  79. # do this whole %pre thing only when updating for the first time...
  80. exit 0
  81. fi
  82. mkdir -p /var/lib/qubes
  83. if [ -e /etc/fstab ] ; then
  84. mv /etc/fstab /var/lib/qubes/fstab.orig
  85. fi
  86. adduser --create-home user
  87. %install
  88. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  89. make install-vm DESTDIR=$RPM_BUILD_ROOT
  90. # Create ghost files to silent rpmbuild warnings, those files will NOT be
  91. # included in package
  92. mkdir -p $RPM_BUILD_ROOT/etc/systemd/system
  93. for f in ModemManager.service NetworkManager.service \
  94. NetworkManager-wait-online.service cups.service cups.socket cups.path; do
  95. cp $RPM_BUILD_ROOT/usr/lib/qubes/init/$f $RPM_BUILD_ROOT/etc/systemd/system/
  96. done
  97. %triggerin -- initscripts
  98. if [ -e /etc/init/serial.conf ]; then
  99. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  100. fi
  101. %triggerin -- pulseaudio-module-x11
  102. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/pulseaudio.desktop
  103. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/pulseaudio.desktop
  104. %post
  105. # disable some Upstart services
  106. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  107. if [ -e /etc/init/$F.conf ]; then
  108. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  109. fi
  110. done
  111. remove_ShowIn () {
  112. if [ -e /etc/xdg/autostart/$1.desktop ]; then
  113. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/$1.desktop
  114. fi
  115. }
  116. # reenable abrt-aplet if disable by some earlier version of package
  117. remove_ShowIn abrt-applet.desktop
  118. # don't want it at all
  119. for F in deja-dup-monitor imsettings-start krb5-auth-dialog pulseaudio restorecond sealertauto gnome-power-manager gnome-sound-applet gnome-screensaver orca-autostart; do
  120. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  121. remove_ShowIn $F
  122. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/$F.desktop
  123. fi
  124. done
  125. # don't want it in DisposableVM
  126. for F in gcm-apply ; do
  127. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  128. remove_ShowIn $F
  129. echo 'NotShowIn=DisposableVM;' >> /etc/xdg/autostart/$F.desktop
  130. fi
  131. done
  132. # want it in AppVM only
  133. for F in gnome-keyring-gpg gnome-keyring-pkcs11 gnome-keyring-secrets gnome-keyring-ssh gnome-settings-daemon user-dirs-update-gtk gsettings-data-convert ; do
  134. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  135. remove_ShowIn $F
  136. echo 'OnlyShowIn=GNOME;AppVM;' >> /etc/xdg/autostart/$F.desktop
  137. fi
  138. done
  139. # remove existing rule to add own later
  140. for F in gpk-update-icon nm-applet ; do
  141. remove_ShowIn $F
  142. done
  143. echo 'OnlyShowIn=GNOME;UpdateableVM;' >> /etc/xdg/autostart/gpk-update-icon.desktop || :
  144. %if %{fedora} >= 20
  145. echo 'OnlyShowIn=GNOME;QUBES;' >> /etc/xdg/autostart/nm-applet.desktop || :
  146. %else
  147. echo 'OnlyShowIn=GNOME;NetVM;' >> /etc/xdg/autostart/nm-applet.desktop || :
  148. %endif
  149. # Enable autostart of notification-daemon when installed
  150. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  151. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  152. fi
  153. usermod -p '' root
  154. usermod -L user
  155. # Create NetworkManager configuration if we do not have it
  156. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  157. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  158. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  159. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  160. fi
  161. /usr/lib/qubes/qubes-fix-nm-conf.sh
  162. # Remove ip_forward setting from sysctl, so NM will not reset it
  163. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  164. # Install firmware link only on system which haven't it yet
  165. if ! [ -e /lib/firmware/updates ]; then
  166. ln -s /lib/modules/firmware /lib/firmware/updates
  167. fi
  168. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  169. echo >> /etc/yum.conf
  170. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  171. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  172. fi
  173. # Revert 'Prevent unnecessary updates in VMs':
  174. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  175. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  176. if ! grep -q localhost /etc/hosts; then
  177. cat <<EOF > /etc/hosts
  178. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  179. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  180. EOF
  181. fi
  182. if [ "$1" != 1 ] ; then
  183. # do the rest of %post thing only when updating for the first time...
  184. exit 0
  185. fi
  186. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  187. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  188. fi
  189. #echo "--> Disabling SELinux..."
  190. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  191. mv /etc/selinux/config.processed /etc/selinux/config
  192. setenforce 0 2>/dev/null
  193. # Remove most of the udev scripts to speed up the VM boot time
  194. # Just leave the xen* scripts, that are needed if this VM was
  195. # ever used as a net backend (e.g. as a VPN domain in the future)
  196. #echo "--> Removing unnecessary udev scripts..."
  197. mkdir -p /var/lib/qubes/removed-udev-scripts
  198. for f in /etc/udev/rules.d/*
  199. do
  200. if [ $(basename $f) == "xen-backend.rules" ] ; then
  201. continue
  202. fi
  203. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  204. continue
  205. fi
  206. if echo $f | grep -q qubes; then
  207. continue
  208. fi
  209. mv $f /var/lib/qubes/removed-udev-scripts/
  210. done
  211. mkdir -p /rw
  212. #rm -f /etc/mtab
  213. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  214. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  215. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  216. %preun
  217. if [ "$1" = 0 ] ; then
  218. # no more packages left
  219. if [ -e /var/lib/qubes/fstab.orig ] ; then
  220. mv /var/lib/qubes/fstab.orig /etc/fstab
  221. fi
  222. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  223. if [ -e /var/lib/qubes/serial.orig ] ; then
  224. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  225. fi
  226. fi
  227. %postun
  228. if [ $1 -eq 0 ] ; then
  229. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  230. if [ -l /lib/firmware/updates ]; then
  231. rm /lib/firmware/updates
  232. fi
  233. fi
  234. %posttrans
  235. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  236. %clean
  237. rm -rf $RPM_BUILD_ROOT
  238. rm -f %{name}-%{version}
  239. %files
  240. %defattr(-,root,root,-)
  241. %dir /var/lib/qubes
  242. %dir /var/run/qubes
  243. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  244. %{kde_service_dir}/qvm-copy.desktop
  245. %{kde_service_dir}/qvm-move.desktop
  246. %{kde_service_dir}/qvm-dvm.desktop
  247. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  248. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  249. /etc/X11/xorg-preload-apps.conf
  250. /etc/dispvm-dotfiles.tbz
  251. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  252. /etc/fstab
  253. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  254. /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  255. /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  256. %dir /etc/qubes-rpc
  257. /etc/qubes-rpc/qubes.Filecopy
  258. /etc/qubes-rpc/qubes.OpenInVM
  259. /etc/qubes-rpc/qubes.GetAppmenus
  260. /etc/qubes-rpc/qubes.VMShell
  261. /etc/qubes-rpc/qubes.SyncNtpClock
  262. /etc/qubes-rpc/qubes.SuspendPre
  263. /etc/qubes-rpc/qubes.SuspendPost
  264. /etc/qubes-rpc/qubes.WaitForSession
  265. /etc/qubes-rpc/qubes.DetachPciDevice
  266. /etc/qubes-rpc/qubes.Backup
  267. /etc/qubes-rpc/qubes.Restore
  268. /etc/qubes-rpc/qubes.SelectFile
  269. /etc/qubes-rpc/qubes.SelectDirectory
  270. /etc/qubes-rpc/qubes.GetImageRGBA
  271. /etc/sudoers.d/qubes
  272. %config(noreplace) /etc/sysconfig/iptables
  273. %config(noreplace) /etc/sysconfig/ip6tables
  274. /etc/sysconfig/modules/qubes-core.modules
  275. /etc/sysconfig/modules/qubes-misc.modules
  276. %config(noreplace) /etc/tinyproxy/filter-qubes-yum
  277. %config(noreplace) /etc/tinyproxy/tinyproxy-qubes-yum.conf
  278. /etc/udev/rules.d/50-qubes-misc.rules
  279. /etc/udev/rules.d/99-qubes-network.rules
  280. /etc/xdg/autostart/qubes-show-hide-nm-applet.desktop
  281. /etc/xdg/nautilus-actions/nautilus-actions.conf
  282. /etc/xen/scripts/vif-route-qubes
  283. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  284. %config(noreplace) /etc/yum.repos.d/qubes-r2.repo
  285. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  286. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  287. /usr/sbin/qubes-serial-login
  288. /usr/bin/qvm-copy-to-vm
  289. /usr/bin/qvm-move-to-vm
  290. /usr/bin/qvm-open-in-dvm
  291. /usr/bin/qvm-open-in-vm
  292. /usr/bin/qvm-run
  293. /usr/bin/qvm-mru-entry
  294. /usr/bin/xenstore-watch-qubes
  295. %dir /usr/lib/qubes
  296. /usr/lib/qubes/vusb-ctl.py*
  297. /usr/lib/qubes/dispvm-prerun.sh
  298. /usr/lib/qubes/sync-ntp-clock
  299. /usr/lib/qubes/prepare-suspend
  300. /usr/lib/qubes/network-manager-prepare-conf-dir
  301. /usr/lib/qubes/show-hide-nm-applet.sh
  302. /usr/lib/qubes/qrexec-agent
  303. /usr/lib/qubes/qrexec-client-vm
  304. /usr/lib/qubes/qrexec_client_vm
  305. /usr/lib/qubes/qubes-rpc-multiplexer
  306. /usr/lib/qubes/qfile-agent
  307. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  308. /usr/lib/qubes/qopen-in-vm
  309. /usr/lib/qubes/qrun-in-vm
  310. /usr/lib/qubes/qubes-download-dom0-updates.sh
  311. /usr/lib/qubes/qubes-fix-nm-conf.sh
  312. /usr/lib/qubes/qubes-setup-dnat-to-ns
  313. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  314. /usr/lib/qubes/qvm-copy-to-vm.gnome
  315. /usr/lib/qubes/qvm-copy-to-vm.kde
  316. /usr/lib/qubes/qvm-move-to-vm.gnome
  317. /usr/lib/qubes/qvm-move-to-vm.kde
  318. /usr/lib/qubes/setup-ip
  319. /usr/lib/qubes/tar2qfile
  320. /usr/lib/qubes/vm-file-editor
  321. /usr/lib/qubes/wrap-in-html-if-url.sh
  322. /usr/lib/qubes/iptables-yum-proxy
  323. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  324. /usr/sbin/qubes-firewall
  325. /usr/sbin/qubes-netwatcher
  326. /usr/share/qubes/serial.conf
  327. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  328. /usr/share/file-manager/actions/qvm-copy-gnome.desktop
  329. /usr/share/file-manager/actions/qvm-move-gnome.desktop
  330. /usr/share/file-manager/actions/qvm-dvm-gnome.desktop
  331. %dir /usr/share/qubes
  332. /usr/share/qubes/mime-override/globs
  333. %dir /home_volatile
  334. %attr(700,user,user) /home_volatile/user
  335. %dir /mnt/removable
  336. %package sysvinit
  337. Summary: Qubes unit files for SysV init style or upstart
  338. License: GPL v2 only
  339. Group: Qubes
  340. Requires: upstart
  341. Requires: qubes-core-vm
  342. Provides: qubes-core-vm-init-scripts
  343. Conflicts: qubes-core-vm-systemd
  344. %description sysvinit
  345. The Qubes core startup configuration for SysV init (or upstart).
  346. %files sysvinit
  347. /etc/init.d/qubes-core
  348. /etc/init.d/qubes-core-appvm
  349. /etc/init.d/qubes-core-netvm
  350. /etc/init.d/qubes-firewall
  351. /etc/init.d/qubes-netwatcher
  352. /etc/init.d/qubes-yum-proxy
  353. /etc/init.d/qubes-qrexec-agent
  354. %post sysvinit
  355. #echo "--> Turning off unnecessary services..."
  356. # FIXME: perhaps there is more elegant way to do this?
  357. for f in /etc/init.d/*
  358. do
  359. srv=`basename $f`
  360. [ $srv = 'functions' ] && continue
  361. [ $srv = 'killall' ] && continue
  362. [ $srv = 'halt' ] && continue
  363. [ $srv = 'single' ] && continue
  364. [ $srv = 'reboot' ] && continue
  365. [ $srv = 'qubes-gui' ] && continue
  366. chkconfig $srv off
  367. done
  368. #echo "--> Enabling essential services..."
  369. chkconfig rsyslog on
  370. chkconfig haldaemon on
  371. chkconfig messagebus on
  372. chkconfig iptables on
  373. chkconfig ip6tables on
  374. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  375. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  376. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  377. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  378. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  379. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  380. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  381. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  382. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  383. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  384. chkconfig --add qubes-yum-proxy || echo "WARNING: Cannot add service qubes-yum-proxy!"
  385. chkconfig qubes-yum-proxy on || echo "WARNING: Cannot enable service qubes-yum-proxy!"
  386. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  387. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  388. # TODO: make this not display the silly message about security context...
  389. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  390. %preun sysvinit
  391. if [ "$1" = 0 ] ; then
  392. # no more packages left
  393. chkconfig qubes-core off
  394. chkconfig qubes-core-netvm off
  395. chkconfig qubes-core-appvm off
  396. chkconfig qubes-firewall off
  397. chkconfig qubes-netwatcher off
  398. chkconfig qubes-yum-proxy off
  399. chkconfig qubes-qrexec-agent off
  400. fi
  401. %package systemd
  402. Summary: Qubes unit files for SystemD init style
  403. License: GPL v2 only
  404. Group: Qubes
  405. Requires: systemd
  406. Requires(post): systemd-units
  407. Requires(preun): systemd-units
  408. Requires(postun): systemd-units
  409. Requires: qubes-core-vm
  410. Provides: qubes-core-vm-init-scripts
  411. Conflicts: qubes-core-vm-sysvinit
  412. %description systemd
  413. The Qubes core startup configuration for SystemD init.
  414. %files systemd
  415. %defattr(-,root,root,-)
  416. /lib/systemd/system/qubes-dvm.service
  417. /lib/systemd/system/qubes-misc-post.service
  418. /lib/systemd/system/qubes-firewall.service
  419. /lib/systemd/system/qubes-netwatcher.service
  420. /lib/systemd/system/qubes-network.service
  421. /lib/systemd/system/qubes-sysinit.service
  422. /lib/systemd/system/qubes-update-check.service
  423. /lib/systemd/system/qubes-update-check.timer
  424. /lib/systemd/system/qubes-yum-proxy.service
  425. /lib/systemd/system/qubes-qrexec-agent.service
  426. %dir /usr/lib/qubes/init
  427. /usr/lib/qubes/init/prepare-dvm.sh
  428. /usr/lib/qubes/init/network-proxy-setup.sh
  429. /usr/lib/qubes/init/misc-post.sh
  430. /usr/lib/qubes/init/misc-post-stop.sh
  431. /usr/lib/qubes/init/qubes-sysinit.sh
  432. /usr/lib/qubes/init/ModemManager.service
  433. /usr/lib/qubes/init/NetworkManager.service
  434. /usr/lib/qubes/init/NetworkManager-wait-online.service
  435. /usr/lib/qubes/init/cups.service
  436. /usr/lib/qubes/init/cups.socket
  437. /usr/lib/qubes/init/cups.path
  438. /usr/lib/qubes/init/ntpd.service
  439. /usr/lib/qubes/init/chronyd.service
  440. %ghost %attr(0644,root,root) /etc/systemd/system/ModemManager.service
  441. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager.service
  442. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager-wait-online.service
  443. %ghost %attr(0644,root,root) /etc/systemd/system/cups.service
  444. %ghost %attr(0644,root,root) /etc/systemd/system/cups.socket
  445. %ghost %attr(0644,root,root) /etc/systemd/system/cups.path
  446. %post systemd
  447. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-firewall qubes-yum-proxy qubes-qrexec-agent; do
  448. /bin/systemctl enable $srv.service 2> /dev/null
  449. done
  450. /bin/systemctl enable qubes-update-check.timer 2> /dev/null
  451. UNITDIR=/lib/systemd/system
  452. OVERRIDEDIR=/usr/lib/qubes/init
  453. # Install overriden services only when original exists
  454. for srv in cups ModemManager NetworkManager NetworkManager-wait-online ntpd chronyd; do
  455. if [ -f $UNITDIR/$srv.service ]; then
  456. cp $OVERRIDEDIR/$srv.service /etc/systemd/system/
  457. fi
  458. if [ -f $UNITDIR/$srv.socket -a -f $OVERRIDEDIR/$srv.socket ]; then
  459. cp $OVERRIDEDIR/$srv.socket /etc/systemd/system/
  460. fi
  461. if [ -f $UNITDIR/$srv.path -a -f $OVERRIDEDIR/$srv.path ]; then
  462. cp $OVERRIDEDIR/$srv.path /etc/systemd/system/
  463. fi
  464. done
  465. # Set default "runlevel"
  466. rm -f /etc/systemd/system/default.target
  467. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  468. DISABLE_SERVICES="alsa-store alsa-restore auditd avahi avahi-daemon backuppc cpuspeed crond"
  469. DISABLE_SERVICES="$DISABLE_SERVICES fedora-autorelabel fedora-autorelabel-mark ipmi hwclock-load hwclock-save"
  470. DISABLE_SERVICES="$DISABLE_SERVICES mdmonitor multipathd openct rpcbind mcelog fedora-storage-init fedora-storage-init-late"
  471. DISABLE_SERVICES="$DISABLE_SERVICES plymouth-start plymouth-read-write plymouth-quit plymouth-quit-wait"
  472. DISABLE_SERVICES="$DISABLE_SERVICES sshd tcsd sm-client sendmail mdmonitor-takeover"
  473. DISABLE_SERVICES="$DISABLE_SERVICES rngd smartd upower irqbalance colord"
  474. for srv in $DISABLE_SERVICES; do
  475. if [ -f /lib/systemd/system/$srv.service ]; then
  476. if fgrep -q '[Install]' /lib/systemd/system/$srv.service; then
  477. /bin/systemctl disable $srv.service 2> /dev/null
  478. else
  479. # forcibly disable
  480. ln -sf /dev/null /etc/systemd/system/$srv.service
  481. fi
  482. fi
  483. done
  484. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  485. # Enable some services
  486. /bin/systemctl enable iptables.service 2> /dev/null
  487. /bin/systemctl enable ip6tables.service 2> /dev/null
  488. /bin/systemctl enable rsyslog.service 2> /dev/null
  489. /bin/systemctl enable ntpd.service 2> /dev/null
  490. # Disable original service to enable overriden one
  491. /bin/systemctl disable ModemManager.service 2> /dev/null
  492. /bin/systemctl disable NetworkManager.service 2> /dev/null
  493. # Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)
  494. /bin/systemctl mask dbus-org.freedesktop.NetworkManager.service 2> /dev/null
  495. /bin/systemctl enable ModemManager.service 2> /dev/null
  496. /bin/systemctl enable NetworkManager.service 2> /dev/null
  497. # Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811
  498. /bin/systemctl enable NetworkManager-dispatcher.service 2> /dev/null
  499. # Enable cups only when it is real SystemD service
  500. [ -e /lib/systemd/system/cups.service ] && /bin/systemctl enable cups.service 2> /dev/null
  501. exit 0
  502. %postun systemd
  503. #Do not run this part on upgrades
  504. if [ "$1" != 0 ] ; then
  505. exit 0
  506. fi
  507. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-qrexec-agent; do
  508. /bin/systemctl disable $srv.service
  509. do