PKGBUILD.install 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444
  1. #!/bin/bash
  2. qubes_preset_file="75-qubes-vm.preset"
  3. ###########################
  4. ## Pre-Install functions ##
  5. ###########################
  6. update_default_user() {
  7. # Make sure there is a qubes group
  8. groupadd --force --system --gid 98 qubes
  9. # Archlinux bash version has a 'bug' when running su -c, /etc/profile is not loaded because bash consider there is no interactive pty when running 'su - user -c' or something like this.
  10. # See https://bugs.archlinux.org/task/31831
  11. id -u 'user' >/dev/null 2>&1 || {
  12. useradd --user-group --create-home --shell /bin/bash user
  13. }
  14. usermod -a --groups qubes user
  15. }
  16. ## arg 1: the new package version
  17. pre_install() {
  18. echo "Pre install..."
  19. update_default_user
  20. # do this whole %pre thing only when updating for the first time...
  21. mkdir -p /var/lib/qubes
  22. # Backup fstab / But use archlinux defaults (cp instead of mv)
  23. if [ -e /etc/fstab ] ; then
  24. cp /etc/fstab /var/lib/qubes/fstab.orig
  25. fi
  26. # Add qubes core related fstab entries
  27. echo "xen /proc/xen xenfs defaults 0 0" >> /etc/fstab
  28. usermod -p '' root
  29. usermod -L user
  30. }
  31. ## arg 1: the new package version
  32. ## arg 2: the old package version
  33. pre_upgrade() {
  34. # do something here
  35. echo "Pre upgrade..."
  36. update_default_user
  37. }
  38. ###################
  39. ## Install Hooks ##
  40. ###################
  41. configure_notification-daemon() {
  42. # Enable autostart of notification-daemon when installed
  43. if [ ! -L /etc/xdg/autostart/notification-daemon.desktop ]; then
  44. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  45. fi
  46. }
  47. configure_selinux() {
  48. # SELinux is not enabled on archlinux
  49. #echo "--> Disabling SELinux..."
  50. echo "SELINUX not enabled on archlinux. skipped."
  51. # sed -e s/^SELINUX=.*$/SELINUX=disabled/ -i /etc/selinux/config
  52. # setenforce 0 2>/dev/null
  53. }
  54. ############################
  55. ## Post-Install functions ##
  56. ############################
  57. update_qubesconfig() {
  58. # Create NetworkManager configuration if we do not have it
  59. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  60. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  61. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  62. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  63. fi
  64. /usr/lib/qubes/qubes-fix-nm-conf.sh
  65. # Remove ip_forward setting from sysctl, so NM will not reset it
  66. # Archlinux now use sysctl.d/ instead of sysctl.conf
  67. #sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  68. # Remove old firmware updates link
  69. if [ -L /lib/firmware/updates ]; then
  70. rm -f /lib/firmware/updates
  71. fi
  72. # Yum proxy configuration is fedora specific
  73. #if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  74. # echo >> /etc/yum.conf
  75. # echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  76. # echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  77. #fi
  78. #/usr/lib/qubes/update-proxy-configs
  79. # Archlinux pacman configuration is handled in update_finalize
  80. # Location of files which contains list of protected files
  81. mkdir -p /etc/qubes/protected-files.d
  82. # shellcheck source=init/functions
  83. . /usr/lib/qubes/init/functions
  84. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  85. if ! is_protected_file /etc/hosts ; then
  86. if ! grep -q localhost /etc/hosts; then
  87. cat <<EOF > /etc/hosts
  88. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 $(hostname)
  89. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  90. EOF
  91. fi
  92. fi
  93. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  94. # in the form expected by qubes-sysinit.sh
  95. if ! is_protected_file /etc/hostname ; then
  96. for ip in '127\.0\.0\.1' '::1'; do
  97. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  98. sed -i "/^${ip}\s/,+0s/\(\s$(hostname)\)\+\(\s\|$\)/\2/g" /etc/hosts
  99. sed -i "s/^${ip}\(\s\|$\).*$/\0 $(hostname)/" /etc/hosts
  100. else
  101. echo "${ip} $(hostname)" >> /etc/hosts
  102. fi
  103. done
  104. fi
  105. }
  106. ############################
  107. ## Service Management Functions ##
  108. ############################
  109. is_static() {
  110. [ -f "/usr/lib/systemd/system/$1" ] && ! grep -q '^[[].nstall]' "/usr/lib/systemd/system/$1"
  111. }
  112. is_masked() {
  113. if [ ! -L /etc/systemd/system/"$1" ]
  114. then
  115. return 1
  116. fi
  117. target=$(readlink /etc/systemd/system/"$1" 2>/dev/null) || :
  118. if [ "$target" = "/dev/null" ]
  119. then
  120. return 0
  121. fi
  122. return 1
  123. }
  124. mask() {
  125. ln -sf /dev/null /etc/systemd/system/"$1"
  126. }
  127. unmask() {
  128. if ! is_masked "$1"
  129. then
  130. return 0
  131. fi
  132. rm -f /etc/systemd/system/"$1"
  133. }
  134. preset_units() {
  135. local represet=
  136. while read -r action unit_name
  137. do
  138. if [ "$action" = "#" ] && [ "$unit_name" = "Units below this line will be re-preset on package upgrade" ]
  139. then
  140. represet=1
  141. continue
  142. fi
  143. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue
  144. [[ -n "$action" && -n "$unit_name" ]] || continue
  145. if [ "$2" = "initial" ] || [ "$represet" = "1" ]
  146. then
  147. if [ "$action" = "disable" ] && is_static "$unit_name"
  148. then
  149. if ! is_masked "$unit_name"
  150. then
  151. # We must effectively mask these units, even if they are static.
  152. mask "$unit_name"
  153. fi
  154. elif [ "$action" = "enable" ] && is_static "$unit_name"
  155. then
  156. if is_masked "$unit_name"
  157. then
  158. # We masked this static unit before, now we unmask it.
  159. unmask "$unit_name"
  160. fi
  161. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  162. else
  163. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  164. fi
  165. fi
  166. done < "$1"
  167. }
  168. restore_units() {
  169. grep '^[[:space:]]*[^#;]' "$1" | while read -r action unit_name
  170. do
  171. if is_static "$unit_name" && is_masked "$unit_name"
  172. then
  173. # If the unit had been masked by us, we must unmask it here.
  174. # Otherwise systemctl preset will fail badly.
  175. unmask "$unit_name"
  176. fi
  177. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  178. done
  179. }
  180. configure_systemd() {
  181. if [ "$1" -eq 1 ]
  182. then
  183. preset_units /usr/lib/systemd/system-preset/$qubes_preset_file initial
  184. changed=true
  185. else
  186. preset_units /usr/lib/systemd/system-preset/$qubes_preset_file upgrade
  187. changed=true
  188. # Upgrade path - now qubes-iptables is used instead
  189. for svc in iptables ip6tables
  190. do
  191. if [ -f "$svc".service ]
  192. then
  193. systemctl --no-reload preset "$svc".service
  194. changed=true
  195. fi
  196. done
  197. fi
  198. if [ "$1" -eq 1 ]
  199. then
  200. # First install.
  201. # Set default "runlevel".
  202. # FIXME: this ought to be done via kernel command line.
  203. # The fewer deviations of the template from the seed
  204. # image, the better.
  205. rm -f /etc/systemd/system/default.target
  206. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  207. changed=true
  208. fi
  209. # remove old symlinks
  210. if [ -L /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  211. then
  212. rm -f /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service
  213. changed=true
  214. fi
  215. if [ -L /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  216. then
  217. rm -f /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service
  218. changed=true
  219. fi
  220. if [ "x$changed" != "x" ]
  221. then
  222. systemctl daemon-reload
  223. fi
  224. }
  225. ######################
  226. ## Archlinux Specific Functions ##
  227. ######################
  228. config_prependtomark() {
  229. FILE=$1
  230. APPENDBEFORELINE=$2
  231. APPENDLINE=$3
  232. grep -F -q "$APPENDLINE" "$FILE" || sed "/$APPENDBEFORELINE/i$APPENDLINE" -i "$FILE"
  233. }
  234. config_appendtomark() {
  235. FILE=$1
  236. APPENDAFTERLINE=$2
  237. APPENDLINE=$3
  238. grep -F -q "$APPENDLINE" "$FILE" || sed "/$APPENDAFTERLINE/a$APPENDLINE" -i "$FILE"
  239. }
  240. config_cleanupmark() {
  241. FILE="$1"
  242. BEGINMARK="$2"
  243. ENDMARK="$3"
  244. if grep -F -q "$BEGINMARK" "$FILE"; then
  245. if grep -F -q "$ENDMARK" "$FILE"; then
  246. cp "$FILE" "$FILE.qubes-update-orig"
  247. sed -i -e "/^$BEGINMARK$/,/^$ENDMARK$/{
  248. /^$ENDMARK$/b
  249. /^$BEGINMARK$/!d
  250. }" "$FILE"
  251. rm -f "$FILE.qubes-update-orig"
  252. else
  253. echo "ERROR: found $BEGINMARK marker but not $ENDMARK in $FILE. Please cleanup this file manually."
  254. fi
  255. elif grep -F -q "$ENDMARK" "$FILE"; then
  256. echo "ERROR: found $ENDMARK marker but not $BEGINMARK in $FILE. Please cleanup this file manually."
  257. fi
  258. }
  259. update_finalize() {
  260. # Archlinux specific: If marker exists, cleanup text between begin and end marker
  261. QUBES_MARKER="### QUBES CONFIG MARKER ###"
  262. if grep -F -q "$QUBES_MARKER" /etc/pacman.conf; then
  263. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "### QUBES CONFIG END MARKER ###"
  264. config_cleanupmark "/etc/pacman.conf" "$QUBES_MARKER" "### QUBES CONFIG END MARKER ###"
  265. # Else, add qubes config block marker
  266. else
  267. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "$QUBES_MARKER"
  268. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "### QUBES CONFIG END MARKER ###"
  269. fi
  270. # Include /etc/pacman.d drop-in directory
  271. config_appendtomark "/etc/pacman.conf" "$QUBES_MARKER" "Include = /etc/pacman.d/*.conf"
  272. /usr/lib/qubes/update-proxy-configs
  273. # Archlinux specific: Update pam.d configuration for su to enable systemd-login wrapper
  274. # This is required as qubes-gui agent calls xinit with su -l user without initializing properly
  275. # the user session.
  276. # pam_unix.so can also be removed from su configuration
  277. # as system-login (which include system-auth) already gives pam_unix.so
  278. # with more appropriate parameters (fix the missing nullok parameter)
  279. if grep -q pam_unix.so /etc/pam.d/su; then
  280. echo "Fixing pam.d"
  281. cp /etc/pam.d/qrexec /etc/pam.d/su-l
  282. fi
  283. # Archlinux specific: ensure tty1 is enabled
  284. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  285. systemctl enable getty\@tty1.service
  286. systemctl daemon-reload
  287. }
  288. ## arg 1: the new package version
  289. post_install() {
  290. update_qubesconfig
  291. # do the rest of %post thing only when updating for the first time...
  292. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  293. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  294. fi
  295. # Remove most of the udev scripts to speed up the VM boot time
  296. # Just leave the xen* scripts, that are needed if this VM was
  297. # ever used as a net backend (e.g. as a VPN domain in the future)
  298. #echo "--> Removing unnecessary udev scripts..."
  299. mkdir -p /var/lib/qubes/removed-udev-scripts
  300. for f in /etc/udev/rules.d/*
  301. do
  302. if [ "$(basename "$f")" == "xen-backend.rules" ] ; then
  303. continue
  304. fi
  305. if [ "$(basename "$f")" == "50-qubes-misc.rules" ] ; then
  306. continue
  307. fi
  308. if echo "$f" | grep -q qubes; then
  309. continue
  310. fi
  311. mv "$f" /var/lib/qubes/removed-udev-scripts/
  312. done
  313. mkdir -p /rw
  314. configure_notification-daemon
  315. configure_selinux
  316. configure_systemd 0
  317. update_finalize
  318. }
  319. ## arg 1: the new package version
  320. ## arg 2: the old package version
  321. post_upgrade() {
  322. update_qubesconfig
  323. configure_notification-daemon
  324. configure_selinux
  325. configure_systemd 1
  326. update_finalize
  327. }
  328. ######################
  329. ## Remove functions ##
  330. ######################
  331. ## arg 1: the old package version
  332. pre_remove() {
  333. # no more packages left
  334. if [ -e /var/lib/qubes/fstab.orig ] ; then
  335. mv /var/lib/qubes/fstab.orig /etc/fstab
  336. fi
  337. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  338. if [ -e /var/lib/qubes/serial.orig ] ; then
  339. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  340. fi
  341. if [ "$1" -eq 0 ] ; then
  342. # Run this only during uninstall.
  343. # Save the preset file to later use it to re-preset services there
  344. # once the Qubes OS preset file is removed.
  345. mkdir -p /run/qubes-uninstall
  346. cp -f /usr/lib/systemd/system-preset/$qubes_preset_file /run/qubes-uninstall/
  347. cp -f /usr/lib/systemd/system-preset/$qubes_preset_file /run/qubes-uninstall/
  348. fi
  349. }
  350. ## arg 1: the old package version
  351. post_remove() {
  352. changed=
  353. if [ -d /run/qubes-uninstall ]
  354. then
  355. # We have a saved preset file (or more).
  356. # Re-preset the units mentioned there.
  357. restore_units /run/qubes-uninstall/$qubes_preset_file
  358. rm -rf /run/qubes-uninstall
  359. changed=true
  360. fi
  361. if [ "x$changed" != "x" ]
  362. then
  363. systemctl daemon-reload
  364. fi
  365. if [ -L /lib/firmware/updates ] ; then
  366. rm /lib/firmware/updates
  367. fi
  368. rm -rf /var/lib/qubes/xdg
  369. for srv in qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-network qubes-qrexec-agent; do
  370. systemctl disable $srv.service
  371. done
  372. }