core-vm.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Conflicts: firewalld
  38. %endif
  39. Requires: /usr/bin/mimeopen
  40. Requires: ethtool
  41. Requires: tinyproxy
  42. Requires: ntpdate
  43. Requires: net-tools
  44. Requires: nautilus-python
  45. Requires: qubes-core-vm-kernel-placeholder
  46. Requires: qubes-utils >= 3.1.2
  47. Requires: initscripts
  48. # for qubes-desktop-run
  49. Requires: pygobject3-base
  50. Requires: dbus-python
  51. # for qubes-session-autostart, xdg-icon
  52. Requires: pyxdg
  53. %if %{fedora} >= 20
  54. # gpk-update-viewer required by qubes-manager
  55. Requires: gnome-packagekit-updater
  56. %endif
  57. Requires: ImageMagick
  58. Requires: librsvg2-tools
  59. Requires: fakeroot
  60. Requires: desktop-notification-daemon
  61. # to show/hide nm-applet
  62. Requires: dconf
  63. Requires: pygtk2
  64. Requires: zenity
  65. Requires: qubes-libvchan
  66. Requires: qubes-db-vm
  67. Provides: qubes-core-vm
  68. Obsoletes: qubes-core-commonvm
  69. Obsoletes: qubes-core-appvm
  70. Obsoletes: qubes-core-netvm
  71. Obsoletes: qubes-core-proxyvm
  72. Obsoletes: qubes-upgrade-vm < 3.1
  73. BuildRequires: xen-devel
  74. BuildRequires: libX11-devel
  75. BuildRequires: qubes-utils-devel >= 3.1.2
  76. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  77. %define _builddir %(pwd)
  78. %define kde_service_dir /usr/share/kde4/services
  79. %description
  80. The Qubes core files for installation inside a Qubes VM.
  81. %prep
  82. # we operate on the current directory, so no need to unpack anything
  83. # symlink is to generate useful debuginfo packages
  84. rm -f %{name}-%{version}
  85. ln -sf . %{name}-%{version}
  86. %setup -T -D
  87. %build
  88. for dir in qubes-rpc qrexec misc; do
  89. (cd $dir; make)
  90. done
  91. %pre
  92. # Make sure there is a qubes group
  93. groupadd --force --system --gid 98 qubes
  94. id -u 'user' >/dev/null 2>&1 || {
  95. useradd --user-group --create-home --shell /bin/bash user
  96. }
  97. usermod -a --groups qubes user
  98. if [ "$1" != 1 ] ; then
  99. # do this whole %pre thing only when updating for the first time...
  100. exit 0
  101. fi
  102. mkdir -p /var/lib/qubes
  103. if [ -e /etc/fstab ] ; then
  104. mv /etc/fstab /var/lib/qubes/fstab.orig
  105. fi
  106. usermod -p '' root
  107. usermod -L user
  108. %install
  109. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  110. make install-vm DESTDIR=$RPM_BUILD_ROOT
  111. %triggerin -- initscripts
  112. if [ -e /etc/init/serial.conf ]; then
  113. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  114. fi
  115. %post
  116. # disable some Upstart services
  117. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  118. if [ -e /etc/init/$F.conf ]; then
  119. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  120. fi
  121. done
  122. # Remove ip_forward setting from sysctl, so NM will not reset it
  123. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  124. # Remove old firmware updates link
  125. if [ -L /lib/firmware/updates ]; then
  126. rm -f /lib/firmware/updates
  127. fi
  128. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  129. echo >> /etc/yum.conf
  130. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  131. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  132. fi
  133. # And actually setup the proxy usage in package managers
  134. /usr/lib/qubes/update-proxy-configs
  135. # Revert 'Prevent unnecessary updates in VMs':
  136. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  137. # Location of files which contains list of protected files
  138. mkdir -p /etc/qubes/protected-files.d
  139. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  140. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  141. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  142. if ! grep -q localhost /etc/hosts; then
  143. cat <<EOF > /etc/hosts
  144. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  145. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  146. EOF
  147. fi
  148. fi
  149. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  150. # in the form expected by qubes-sysinit.sh
  151. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  152. for ip in '127\.0\.0\.1' '::1'; do
  153. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  154. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  155. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  156. else
  157. echo "${ip} `hostname`" >> /etc/hosts
  158. fi
  159. done
  160. fi
  161. %if %{fedora} >= 20
  162. # Make sure there is a default locale set so gnome-terminal will start
  163. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  164. touch /etc/locale.conf
  165. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  166. fi
  167. # ... and make sure it is really generated
  168. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  169. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  170. base=`echo "$current_locale" | cut -f 1 -d .`
  171. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  172. [ -n "$charmap" ] && charmap="-f $charmap"
  173. localedef -i $base $charmap $current_locale
  174. fi
  175. %endif
  176. if [ "$1" != 1 ] ; then
  177. # do the rest of %post thing only when updating for the first time...
  178. exit 0
  179. fi
  180. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  181. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  182. fi
  183. # Remove most of the udev scripts to speed up the VM boot time
  184. # Just leave the xen* scripts, that are needed if this VM was
  185. # ever used as a net backend (e.g. as a VPN domain in the future)
  186. #echo "--> Removing unnecessary udev scripts..."
  187. mkdir -p /var/lib/qubes/removed-udev-scripts
  188. for f in /etc/udev/rules.d/*
  189. do
  190. if [ $(basename $f) == "xen-backend.rules" ] ; then
  191. continue
  192. fi
  193. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  194. continue
  195. fi
  196. if echo $f | grep -q qubes; then
  197. continue
  198. fi
  199. mv $f /var/lib/qubes/removed-udev-scripts/
  200. done
  201. mkdir -p /rw
  202. #rm -f /etc/mtab
  203. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  204. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  205. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  206. %triggerin -- notification-daemon
  207. # Enable autostart of notification-daemon when installed
  208. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  209. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  210. fi
  211. exit 0
  212. %triggerin -- selinux-policy
  213. #echo "--> Disabling SELinux..."
  214. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  215. mv /etc/selinux/config.processed /etc/selinux/config
  216. setenforce 0 2>/dev/null
  217. exit 0
  218. %preun
  219. if [ "$1" = 0 ] ; then
  220. # no more packages left
  221. if [ -e /var/lib/qubes/fstab.orig ] ; then
  222. mv /var/lib/qubes/fstab.orig /etc/fstab
  223. fi
  224. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  225. if [ -e /var/lib/qubes/serial.orig ] ; then
  226. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  227. fi
  228. fi
  229. %postun
  230. if [ $1 -eq 0 ] ; then
  231. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  232. if [ -L /lib/firmware/updates ]; then
  233. rm /lib/firmware/updates
  234. fi
  235. rm -rf /var/lib/qubes/xdg
  236. fi
  237. %posttrans
  238. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  239. %clean
  240. rm -rf $RPM_BUILD_ROOT
  241. rm -f %{name}-%{version}
  242. %files
  243. %defattr(-,root,root,-)
  244. %dir /var/lib/qubes
  245. %dir /var/run/qubes
  246. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  247. %{kde_service_dir}/qvm-copy.desktop
  248. %{kde_service_dir}/qvm-move.desktop
  249. %{kde_service_dir}/qvm-dvm.desktop
  250. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  251. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  252. %config /etc/NetworkManager/conf.d/30-qubes.conf
  253. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  254. /etc/dispvm-dotfiles.tbz
  255. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  256. /etc/fstab
  257. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  258. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  259. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  260. %dir /etc/qubes-rpc
  261. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  262. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  263. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  264. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  265. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  266. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  267. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  268. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  269. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  270. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  271. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  272. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  273. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  274. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  275. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  276. %dir /etc/qubes/autostart
  277. /etc/qubes/autostart/README.txt
  278. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  279. %config(noreplace) /etc/sudoers.d/qubes
  280. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  281. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  282. %config(noreplace) /etc/qubes/iptables.rules
  283. %config(noreplace) /etc/qubes/ip6tables.rules
  284. %config(noreplace) /etc/tinyproxy/filter-updates
  285. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  286. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  287. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  288. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  289. /etc/xen/scripts/vif-route-qubes
  290. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  291. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  292. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  293. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  294. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  295. /usr/sbin/qubes-serial-login
  296. /usr/bin/qvm-copy-to-vm
  297. /usr/bin/qvm-move-to-vm
  298. /usr/bin/qvm-open-in-dvm
  299. /usr/bin/qvm-open-in-vm
  300. /usr/bin/qvm-run
  301. /usr/bin/qvm-mru-entry
  302. /usr/bin/xenstore-watch-qubes
  303. /usr/bin/qubes-desktop-run
  304. /usr/bin/qrexec-fork-server
  305. /usr/bin/qrexec-client-vm
  306. /usr/bin/qubes-session-autostart
  307. %dir /usr/lib/qubes
  308. /usr/lib/qubes/vusb-ctl.py*
  309. /usr/lib/qubes/dispvm-prerun.sh
  310. /usr/lib/qubes/sync-ntp-clock
  311. /usr/lib/qubes/prepare-suspend
  312. /usr/lib/qubes/network-manager-prepare-conf-dir
  313. /usr/lib/qubes/show-hide-nm-applet.sh
  314. /usr/lib/qubes/qrexec-agent
  315. /usr/lib/qubes/qrexec-client-vm
  316. /usr/lib/qubes/qrexec_client_vm
  317. /usr/lib/qubes/qubes-rpc-multiplexer
  318. /usr/lib/qubes/qfile-agent
  319. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  320. /usr/lib/qubes/qopen-in-vm
  321. /usr/lib/qubes/qrun-in-vm
  322. /usr/lib/qubes/qubes-download-dom0-updates.sh
  323. /usr/lib/qubes/qubes-setup-dnat-to-ns
  324. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  325. /usr/lib/qubes/qvm-copy-to-vm.gnome
  326. /usr/lib/qubes/qvm-copy-to-vm.kde
  327. /usr/lib/qubes/qvm-move-to-vm.gnome
  328. /usr/lib/qubes/qvm-move-to-vm.kde
  329. /usr/lib/qubes/setup-ip
  330. /usr/lib/qubes/tar2qfile
  331. /usr/lib/qubes/vm-file-editor
  332. /usr/lib/qubes/wrap-in-html-if-url.sh
  333. /usr/lib/qubes/iptables-updates-proxy
  334. /usr/lib/qubes/close-window
  335. /usr/lib/qubes/xdg-icon
  336. /usr/lib/qubes/update-proxy-configs
  337. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  338. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  339. /usr/sbin/qubes-firewall
  340. /usr/sbin/qubes-netwatcher
  341. /usr/share/qubes/serial.conf
  342. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  343. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  344. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  345. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  346. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  347. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  348. /usr/share/qubes/mime-override/globs
  349. %dir /home_volatile
  350. %attr(700,user,user) /home_volatile/user
  351. %dir /mnt/removable
  352. %dir /rw
  353. %package sysvinit
  354. Summary: Qubes unit files for SysV init style or upstart
  355. License: GPL v2 only
  356. Group: Qubes
  357. Requires: upstart
  358. Requires: qubes-core-vm
  359. Provides: qubes-core-vm-init-scripts
  360. Conflicts: qubes-core-vm-systemd
  361. %description sysvinit
  362. The Qubes core startup configuration for SysV init (or upstart).
  363. %files sysvinit
  364. /etc/init.d/qubes-core
  365. /etc/init.d/qubes-core-appvm
  366. /etc/init.d/qubes-core-netvm
  367. /etc/init.d/qubes-firewall
  368. /etc/init.d/qubes-netwatcher
  369. /etc/init.d/qubes-iptables
  370. /etc/init.d/qubes-updates-proxy
  371. /etc/init.d/qubes-qrexec-agent
  372. /etc/sysconfig/modules/qubes-core.modules
  373. /etc/sysconfig/modules/qubes-misc.modules
  374. %post sysvinit
  375. #echo "--> Turning off unnecessary services..."
  376. # FIXME: perhaps there is more elegant way to do this?
  377. for f in /etc/init.d/*
  378. do
  379. srv=`basename $f`
  380. [ $srv = 'functions' ] && continue
  381. [ $srv = 'killall' ] && continue
  382. [ $srv = 'halt' ] && continue
  383. [ $srv = 'single' ] && continue
  384. [ $srv = 'reboot' ] && continue
  385. [ $srv = 'qubes-gui' ] && continue
  386. chkconfig $srv off
  387. done
  388. #echo "--> Enabling essential services..."
  389. chkconfig rsyslog on
  390. chkconfig haldaemon on
  391. chkconfig messagebus on
  392. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  393. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  394. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  395. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  396. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  397. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  398. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  399. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  400. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  401. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  402. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  403. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  404. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  405. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  406. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  407. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  408. # TODO: make this not display the silly message about security context...
  409. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  410. %preun sysvinit
  411. if [ "$1" = 0 ] ; then
  412. # no more packages left
  413. chkconfig qubes-core off
  414. chkconfig qubes-core-netvm off
  415. chkconfig qubes-core-appvm off
  416. chkconfig qubes-firewall off
  417. chkconfig qubes-netwatcher off
  418. chkconfig qubes-updates-proxy off
  419. chkconfig qubes-qrexec-agent off
  420. fi
  421. %package systemd
  422. Summary: Qubes unit files for SystemD init style
  423. License: GPL v2 only
  424. Group: Qubes
  425. Requires: systemd
  426. Requires(post): systemd-units
  427. Requires(preun): systemd-units
  428. Requires(postun): systemd-units
  429. Requires: qubes-core-vm
  430. Provides: qubes-core-vm-init-scripts
  431. Conflicts: qubes-core-vm-sysvinit
  432. %description systemd
  433. The Qubes core startup configuration for SystemD init.
  434. %files systemd
  435. %defattr(-,root,root,-)
  436. /lib/systemd/system/qubes-dvm.service
  437. /lib/systemd/system/qubes-misc-post.service
  438. /lib/systemd/system/qubes-firewall.service
  439. /lib/systemd/system/qubes-mount-dirs.service
  440. /lib/systemd/system/qubes-netwatcher.service
  441. /lib/systemd/system/qubes-network.service
  442. /lib/systemd/system/qubes-iptables.service
  443. /lib/systemd/system/qubes-sysinit.service
  444. /lib/systemd/system/qubes-update-check.service
  445. /lib/systemd/system/qubes-update-check.timer
  446. /lib/systemd/system/qubes-updates-proxy.service
  447. /lib/systemd/system/qubes-qrexec-agent.service
  448. /lib/systemd/system/qubes-random-seed.service
  449. /lib/systemd/system-preset/75-qubes-vm.preset
  450. /lib/modules-load.d/qubes-core.conf
  451. /lib/modules-load.d/qubes-misc.conf
  452. %dir /usr/lib/qubes/init
  453. /usr/lib/qubes/init/prepare-dvm.sh
  454. /usr/lib/qubes/init/network-proxy-setup.sh
  455. /usr/lib/qubes/init/qubes-iptables
  456. /usr/lib/qubes/init/misc-post.sh
  457. /usr/lib/qubes/init/misc-post-stop.sh
  458. /usr/lib/qubes/init/mount-dirs.sh
  459. /usr/lib/qubes/init/qubes-random-seed.sh
  460. /usr/lib/qubes/init/qubes-sysinit.sh
  461. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  462. /lib/systemd/system/crond.service.d/30_qubes.conf
  463. /lib/systemd/system/cups.service.d/30_qubes.conf
  464. /lib/systemd/system/cups.socket.d/30_qubes.conf
  465. /lib/systemd/system/cups.path.d/30_qubes.conf
  466. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  467. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  468. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  469. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  470. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  471. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  472. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  473. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  474. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  475. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  476. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  477. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  478. %post systemd
  479. PRESET_FAILED=0
  480. if [ $1 -eq 1 ]; then
  481. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  482. else
  483. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-dirs"
  484. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  485. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  486. services="$services qubes-random-seed"
  487. for srv in $services; do
  488. /bin/systemctl --no-reload preset $srv.service
  489. done
  490. /bin/systemctl --no-reload preset qubes-update-check.timer
  491. # Upgrade path - now qubes-iptables is used instead
  492. /bin/systemctl --no-reload preset iptables.service
  493. /bin/systemctl --no-reload preset ip6tables.service
  494. fi
  495. # Set default "runlevel"
  496. rm -f /etc/systemd/system/default.target
  497. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  498. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  499. case "$action" in
  500. (disable)
  501. if [ -f /lib/systemd/system/$unit_name ]; then
  502. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  503. # forcibly disable
  504. ln -sf /dev/null /etc/systemd/system/$unit_name
  505. fi
  506. fi
  507. ;;
  508. *)
  509. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  510. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  511. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  512. fi
  513. ;;
  514. esac
  515. done
  516. /bin/systemctl daemon-reload
  517. exit 0
  518. %postun systemd
  519. #Do not run this part on upgrades
  520. if [ "$1" != 0 ] ; then
  521. exit 0
  522. fi
  523. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-netwatcher qubes-network qubes-qrexec-agent; do
  524. /bin/systemctl disable $srv.service
  525. do