core-vm.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. %if %{fedora} < 22
  34. Requires: yum-plugin-post-transaction-actions
  35. %endif
  36. Requires: NetworkManager >= 0.8.1-1
  37. %if %{fedora} >= 18
  38. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  39. Conflicts: firewalld
  40. %endif
  41. Requires: xdg-utils
  42. Requires: ethtool
  43. Requires: tinyproxy
  44. Requires: ntpdate
  45. Requires: net-tools
  46. Requires: nautilus-python
  47. Requires: qubes-utils >= 3.1.3
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. Requires: dbus-python
  52. # for qubes-session-autostart, xdg-icon
  53. Requires: pyxdg
  54. Requires: python-daemon
  55. Requires: nftables
  56. %if %{fedora} >= 20
  57. # gpk-update-viewer required by qubes-manager
  58. Requires: gnome-packagekit-updater
  59. %endif
  60. Requires: ImageMagick
  61. Requires: librsvg2-tools
  62. Requires: fakeroot
  63. Requires: desktop-notification-daemon
  64. # to show/hide nm-applet
  65. Requires: dconf
  66. Requires: pygtk2
  67. Requires: zenity
  68. Requires: qubes-libvchan
  69. Requires: qubes-db-vm
  70. %if 0%{fedora} >= 23
  71. Requires: python3-dnf-plugins-qubes-hooks
  72. %else
  73. Requires: python2-dnf-plugins-qubes-hooks
  74. %endif
  75. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  76. Obsoletes: qubes-upgrade-vm < 3.2
  77. BuildRequires: xen-devel
  78. BuildRequires: python3-devel
  79. BuildRequires: libX11-devel
  80. BuildRequires: qubes-utils-devel >= 3.1.3
  81. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  82. %package -n python2-dnf-plugins-qubes-hooks
  83. Summary: DNF plugin for Qubes specific post-installation actions
  84. BuildRequires: python2-devel
  85. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  86. %description -n python2-dnf-plugins-qubes-hooks
  87. DNF plugin for Qubes specific post-installation actions:
  88. * notify dom0 that updates were installed
  89. * refresh applications shortcut list
  90. %package -n python3-dnf-plugins-qubes-hooks
  91. Summary: DNF plugin for Qubes specific post-installation actions
  92. BuildRequires: python3-devel
  93. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  94. %description -n python3-dnf-plugins-qubes-hooks
  95. DNF plugin for Qubes specific post-installation actions:
  96. * notify dom0 that updates were installed
  97. * refresh applications shortcut list
  98. %define _builddir %(pwd)
  99. %define kde_service_dir /usr/share/kde4/services
  100. %description
  101. The Qubes core files for installation inside a Qubes VM.
  102. %prep
  103. # we operate on the current directory, so no need to unpack anything
  104. # symlink is to generate useful debuginfo packages
  105. rm -f %{name}-%{version}
  106. ln -sf . %{name}-%{version}
  107. %setup -T -D
  108. %build
  109. for dir in qubes-rpc qrexec misc; do
  110. (cd $dir; make)
  111. done
  112. %pre
  113. # Make sure there is a qubes group
  114. groupadd --force --system --gid 98 qubes
  115. id -u 'user' >/dev/null 2>&1 || {
  116. useradd --user-group --create-home --shell /bin/bash user
  117. }
  118. usermod -a --groups qubes user
  119. if [ "$1" != 1 ] ; then
  120. # do this whole %%pre thing only when updating for the first time...
  121. exit 0
  122. fi
  123. mkdir -p /var/lib/qubes
  124. if [ -e /etc/fstab ] ; then
  125. mv /etc/fstab /var/lib/qubes/fstab.orig
  126. fi
  127. usermod -p '' root
  128. usermod -L user
  129. %install
  130. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  131. make install-vm DESTDIR=$RPM_BUILD_ROOT
  132. %if %{fedora} >= 22
  133. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  134. %endif
  135. %triggerin -- initscripts
  136. if [ -e /etc/init/serial.conf ]; then
  137. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  138. fi
  139. %post
  140. # disable some Upstart services
  141. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  142. if [ -e /etc/init/$F.conf ]; then
  143. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  144. fi
  145. done
  146. # Create NetworkManager configuration if we do not have it
  147. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  148. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  149. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  150. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  151. fi
  152. /usr/lib/qubes/qubes-fix-nm-conf.sh
  153. # Remove ip_forward setting from sysctl, so NM will not reset it
  154. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  155. # Remove old firmware updates link
  156. if [ -L /lib/firmware/updates ]; then
  157. rm -f /lib/firmware/updates
  158. fi
  159. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  160. echo >> /etc/yum.conf
  161. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  162. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  163. fi
  164. # And actually setup the proxy usage in package managers
  165. /usr/lib/qubes/update-proxy-configs
  166. # Location of files which contains list of protected files
  167. mkdir -p /etc/qubes/protected-files.d
  168. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  169. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  170. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  171. if ! grep -q localhost /etc/hosts; then
  172. cat <<EOF > /etc/hosts
  173. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  174. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  175. EOF
  176. fi
  177. fi
  178. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  179. # in the form expected by qubes-sysinit.sh
  180. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  181. for ip in '127\.0\.0\.1' '::1'; do
  182. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  183. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  184. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  185. else
  186. echo "${ip} `hostname`" >> /etc/hosts
  187. fi
  188. done
  189. fi
  190. %if %{fedora} >= 20
  191. # Make sure there is a default locale set so gnome-terminal will start
  192. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  193. touch /etc/locale.conf
  194. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  195. fi
  196. # ... and make sure it is really generated
  197. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  198. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  199. base=`echo "$current_locale" | cut -f 1 -d .`
  200. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  201. [ -n "$charmap" ] && charmap="-f $charmap"
  202. localedef -i $base $charmap $current_locale
  203. fi
  204. %endif
  205. if [ "$1" != 1 ] ; then
  206. # do the rest of %%post thing only when updating for the first time...
  207. exit 0
  208. fi
  209. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  210. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  211. fi
  212. # Remove most of the udev scripts to speed up the VM boot time
  213. # Just leave the xen* scripts, that are needed if this VM was
  214. # ever used as a net backend (e.g. as a VPN domain in the future)
  215. #echo "--> Removing unnecessary udev scripts..."
  216. mkdir -p /var/lib/qubes/removed-udev-scripts
  217. for f in /etc/udev/rules.d/*
  218. do
  219. if [ $(basename $f) == "xen-backend.rules" ] ; then
  220. continue
  221. fi
  222. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  223. continue
  224. fi
  225. if echo $f | grep -q qubes; then
  226. continue
  227. fi
  228. mv $f /var/lib/qubes/removed-udev-scripts/
  229. done
  230. mkdir -p /rw
  231. #rm -f /etc/mtab
  232. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  233. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  234. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  235. %triggerin -- notification-daemon
  236. # Enable autostart of notification-daemon when installed
  237. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  238. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  239. fi
  240. exit 0
  241. %triggerin -- selinux-policy
  242. #echo "--> Disabling SELinux..."
  243. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  244. mv /etc/selinux/config.processed /etc/selinux/config
  245. setenforce 0 2>/dev/null
  246. exit 0
  247. %preun
  248. if [ "$1" = 0 ] ; then
  249. # no more packages left
  250. if [ -e /var/lib/qubes/fstab.orig ] ; then
  251. mv /var/lib/qubes/fstab.orig /etc/fstab
  252. fi
  253. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  254. if [ -e /var/lib/qubes/serial.orig ] ; then
  255. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  256. fi
  257. fi
  258. %postun
  259. if [ $1 -eq 0 ] ; then
  260. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  261. if [ -L /lib/firmware/updates ]; then
  262. rm /lib/firmware/updates
  263. fi
  264. rm -rf /var/lib/qubes/xdg
  265. fi
  266. %posttrans
  267. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  268. %clean
  269. rm -rf $RPM_BUILD_ROOT
  270. rm -f %{name}-%{version}
  271. %files
  272. %defattr(-,root,root,-)
  273. %dir /var/lib/qubes
  274. %dir /var/run/qubes
  275. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  276. %{kde_service_dir}/qvm-copy.desktop
  277. %{kde_service_dir}/qvm-move.desktop
  278. %{kde_service_dir}/qvm-dvm.desktop
  279. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  280. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  281. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  282. /etc/dispvm-dotfiles.tbz
  283. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  284. /etc/fstab
  285. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  286. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  287. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  288. %dir /etc/qubes-rpc
  289. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  290. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  291. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  292. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  293. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  294. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  295. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  296. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  297. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  298. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  299. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  300. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  301. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  302. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  303. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  304. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  305. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  306. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  307. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  308. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  309. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  310. %dir /etc/qubes/autostart
  311. /etc/qubes/autostart/README.txt
  312. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  313. %dir /etc/qubes/suspend-pre.d
  314. /etc/qubes/suspend-pre.d/README
  315. %dir /etc/qubes/suspend-post.d
  316. /etc/qubes/suspend-post.d/README
  317. %config(noreplace) /etc/sudoers.d/qubes
  318. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  319. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  320. %config(noreplace) /etc/qubes/iptables.rules
  321. %config(noreplace) /etc/qubes/ip6tables.rules
  322. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  323. %config(noreplace) /etc/tinyproxy/updates-blacklist
  324. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  325. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  326. %config(noreplace) /etc/qubes-suspend-module-blacklist
  327. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  328. /etc/xen/scripts/vif-route-qubes
  329. /etc/xen/scripts/vif-qubes-nat.sh
  330. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  331. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  332. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  333. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  334. %if %{fedora} < 22
  335. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  336. %endif
  337. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  338. /usr/sbin/qubes-serial-login
  339. /usr/bin/qvm-copy-to-vm
  340. /usr/bin/qvm-move-to-vm
  341. /usr/bin/qvm-open-in-dvm
  342. /usr/bin/qvm-open-in-vm
  343. /usr/bin/qvm-run
  344. /usr/bin/qvm-mru-entry
  345. /usr/bin/qvm-features-request
  346. /usr/bin/xenstore-watch-qubes
  347. /usr/bin/qubes-desktop-run
  348. /usr/bin/qubes-open
  349. /usr/bin/qrexec-fork-server
  350. /usr/bin/qrexec-client-vm
  351. /usr/bin/qubes-session-autostart
  352. %dir /usr/lib/qubes
  353. /usr/lib/qubes/vusb-ctl.py*
  354. /usr/lib/qubes/dispvm-prerun.sh
  355. /usr/lib/qubes/sync-ntp-clock
  356. /usr/lib/qubes/prepare-suspend
  357. /usr/lib/qubes/network-manager-prepare-conf-dir
  358. /usr/lib/qubes/show-hide-nm-applet.sh
  359. /usr/lib/qubes/qrexec-agent
  360. /usr/lib/qubes/qrexec-client-vm
  361. /usr/lib/qubes/qrexec_client_vm
  362. /usr/lib/qubes/qubes-rpc-multiplexer
  363. /usr/lib/qubes/qfile-agent
  364. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  365. /usr/lib/qubes/qopen-in-vm
  366. /usr/lib/qubes/qrun-in-vm
  367. /usr/lib/qubes/qubes-download-dom0-updates.sh
  368. /usr/lib/qubes/qubes-fix-nm-conf.sh
  369. /usr/lib/qubes/qubes-setup-dnat-to-ns
  370. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  371. /usr/lib/qubes/qvm-copy-to-vm.gnome
  372. /usr/lib/qubes/qvm-copy-to-vm.kde
  373. /usr/lib/qubes/qvm-move-to-vm.gnome
  374. /usr/lib/qubes/qvm-move-to-vm.kde
  375. /usr/lib/qubes/setup-ip
  376. /usr/lib/qubes/tar2qfile
  377. /usr/lib/qubes/vm-file-editor
  378. /usr/lib/qubes/iptables-updates-proxy
  379. /usr/lib/qubes/close-window
  380. /usr/lib/qubes/xdg-icon
  381. /usr/lib/qubes/update-proxy-configs
  382. /usr/lib/qubes/upgrades-installed-check
  383. /usr/lib/qubes/upgrades-status-notify
  384. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  385. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  386. /usr/lib/python2.7/site-packages/qubesxdg.py*
  387. /usr/sbin/qubes-firewall
  388. /usr/share/qubes/serial.conf
  389. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  390. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  391. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  392. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  393. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  394. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  395. %dir %{python3_sitelib}/qubesagent-*.egg-info
  396. %{python3_sitelib}/qubesagent-*.egg-info/*
  397. %dir %{python3_sitelib}/qubesagent
  398. %dir %{python3_sitelib}/qubesagent/__pycache__
  399. %{python3_sitelib}/qubesagent/__pycache__/*
  400. %{python3_sitelib}/qubesagent/__init__.py
  401. %{python3_sitelib}/qubesagent/firewall.py
  402. %{python3_sitelib}/qubesagent/test_firewall.py
  403. /usr/share/qubes/mime-override/globs
  404. /usr/share/qubes/qubes-master-key.asc
  405. %dir /home_volatile
  406. %attr(700,user,user) /home_volatile/user
  407. %dir /mnt/removable
  408. %dir /rw
  409. %files -n python2-dnf-plugins-qubes-hooks
  410. %{python2_sitelib}/dnf-plugins/*
  411. %files -n python3-dnf-plugins-qubes-hooks
  412. %{python3_sitelib}/dnf-plugins/*
  413. %package sysvinit
  414. Summary: Qubes unit files for SysV init style or upstart
  415. License: GPL v2 only
  416. Group: Qubes
  417. Requires: upstart
  418. Requires: qubes-core-vm
  419. Provides: qubes-core-vm-init-scripts
  420. Conflicts: qubes-core-vm-systemd
  421. %description sysvinit
  422. The Qubes core startup configuration for SysV init (or upstart).
  423. %files sysvinit
  424. /etc/init.d/qubes-core
  425. /etc/init.d/qubes-core-appvm
  426. /etc/init.d/qubes-core-netvm
  427. /etc/init.d/qubes-firewall
  428. /etc/init.d/qubes-iptables
  429. /etc/init.d/qubes-updates-proxy
  430. /etc/init.d/qubes-qrexec-agent
  431. /etc/sysconfig/modules/qubes-core.modules
  432. /etc/sysconfig/modules/qubes-misc.modules
  433. %post sysvinit
  434. #echo "--> Turning off unnecessary services..."
  435. # FIXME: perhaps there is more elegant way to do this?
  436. for f in /etc/init.d/*
  437. do
  438. srv=`basename $f`
  439. [ $srv = 'functions' ] && continue
  440. [ $srv = 'killall' ] && continue
  441. [ $srv = 'halt' ] && continue
  442. [ $srv = 'single' ] && continue
  443. [ $srv = 'reboot' ] && continue
  444. [ $srv = 'qubes-gui' ] && continue
  445. chkconfig $srv off
  446. done
  447. #echo "--> Enabling essential services..."
  448. chkconfig rsyslog on
  449. chkconfig haldaemon on
  450. chkconfig messagebus on
  451. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  452. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  453. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  454. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  455. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  456. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  457. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  458. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  459. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  460. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  461. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  462. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  463. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  464. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  465. # dropped services
  466. chkconfig qubes-netwatcher off || :
  467. # TODO: make this not display the silly message about security context...
  468. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  469. %preun sysvinit
  470. if [ "$1" = 0 ] ; then
  471. # no more packages left
  472. chkconfig qubes-core off
  473. chkconfig qubes-core-netvm off
  474. chkconfig qubes-core-appvm off
  475. chkconfig qubes-firewall off
  476. chkconfig qubes-updates-proxy off
  477. chkconfig qubes-qrexec-agent off
  478. fi
  479. %package systemd
  480. Summary: Qubes unit files for SystemD init style
  481. License: GPL v2 only
  482. Group: Qubes
  483. Requires: systemd
  484. Requires(post): systemd-units
  485. Requires(preun): systemd-units
  486. Requires(postun): systemd-units
  487. Requires: qubes-core-vm
  488. Provides: qubes-core-vm-init-scripts
  489. Conflicts: qubes-core-vm-sysvinit
  490. %description systemd
  491. The Qubes core startup configuration for SystemD init.
  492. %files systemd
  493. %defattr(-,root,root,-)
  494. /lib/systemd/system/qubes-dvm.service
  495. /lib/systemd/system/qubes-misc-post.service
  496. /lib/systemd/system/qubes-firewall.service
  497. /lib/systemd/system/qubes-mount-dirs.service
  498. /lib/systemd/system/qubes-network.service
  499. /lib/systemd/system/qubes-iptables.service
  500. /lib/systemd/system/qubes-sysinit.service
  501. /lib/systemd/system/qubes-update-check.service
  502. /lib/systemd/system/qubes-update-check.timer
  503. /lib/systemd/system/qubes-updates-proxy.service
  504. /lib/systemd/system/qubes-qrexec-agent.service
  505. /lib/systemd/system-preset/75-qubes-vm.preset
  506. /lib/modules-load.d/qubes-core.conf
  507. /lib/modules-load.d/qubes-misc.conf
  508. %dir /usr/lib/qubes/init
  509. /usr/lib/qubes/init/prepare-dvm.sh
  510. /usr/lib/qubes/init/network-proxy-setup.sh
  511. /usr/lib/qubes/init/qubes-iptables
  512. /usr/lib/qubes/init/misc-post.sh
  513. /usr/lib/qubes/init/misc-post-stop.sh
  514. /usr/lib/qubes/init/mount-dirs.sh
  515. /usr/lib/qubes/init/qubes-random-seed.sh
  516. /usr/lib/qubes/init/qubes-sysinit.sh
  517. /usr/lib/qubes/init/bind-dirs.sh
  518. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  519. /lib/systemd/system/crond.service.d/30_qubes.conf
  520. /lib/systemd/system/cups.service.d/30_qubes.conf
  521. /lib/systemd/system/cups.socket.d/30_qubes.conf
  522. /lib/systemd/system/cups.path.d/30_qubes.conf
  523. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  524. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  525. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  526. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  527. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  528. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  529. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  530. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  531. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  532. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  533. /lib/systemd/system/tor.service.d/30_qubes.conf
  534. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  535. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  536. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  537. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  538. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  539. %post systemd
  540. PRESET_FAILED=0
  541. if [ $1 -eq 1 ]; then
  542. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  543. else
  544. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-dirs"
  545. services="$services qubes-network qubes-sysinit"
  546. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  547. for srv in $services; do
  548. /bin/systemctl --no-reload preset $srv.service
  549. done
  550. /bin/systemctl --no-reload preset qubes-update-check.timer
  551. # Upgrade path - now qubes-iptables is used instead
  552. if [ -f /lib/systemd/system/iptables.service ]; then
  553. /bin/systemctl --no-reload preset iptables.service
  554. fi
  555. if [ -f /lib/systemd/system/ip6tables.service ]; then
  556. /bin/systemctl --no-reload preset ip6tables.service
  557. fi
  558. fi
  559. # dropped services
  560. /bin/systemctl disable qubes-netwatcher.service >/dev/null 2>&1 || :
  561. # Set default "runlevel"
  562. rm -f /etc/systemd/system/default.target
  563. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  564. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  565. case "$action" in
  566. (disable)
  567. if [ -f /lib/systemd/system/$unit_name ]; then
  568. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  569. # forcibly disable
  570. ln -sf /dev/null /etc/systemd/system/$unit_name
  571. fi
  572. fi
  573. ;;
  574. *)
  575. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  576. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  577. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  578. fi
  579. ;;
  580. esac
  581. done
  582. # remove old symlinks
  583. if [ -L /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service ]; then
  584. rm /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service
  585. fi
  586. if [ -L /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service ]; then
  587. rm /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service
  588. fi
  589. /bin/systemctl daemon-reload
  590. exit 0
  591. %postun systemd
  592. #Do not run this part on upgrades
  593. if [ "$1" != 0 ] ; then
  594. exit 0
  595. fi
  596. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-network qubes-qrexec-agent; do
  597. /bin/systemctl disable $srv.service
  598. do