qubes-core-agent.postinst 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431
  1. #!/bin/bash
  2. # postinst script for core-agent-linux
  3. #
  4. # see: dh_installdeb(1)
  5. set -e
  6. # The postint script may be called in the following ways:
  7. # * <postinst> 'configure' <most-recently-configured-version>
  8. # * <old-postinst> 'abort-upgrade' <new version>
  9. # * <conflictor's-postinst> 'abort-remove' 'in-favour' <package>
  10. # <new-version>
  11. # * <postinst> 'abort-remove'
  12. # * <deconfigured's-postinst> 'abort-deconfigure' 'in-favour'
  13. # <failed-install-package> <version> 'removing'
  14. # <conflicting-package> <version>
  15. #
  16. # For details, see http://www.debian.org/doc/debian-policy/ or
  17. # https://www.debian.org/doc/debian-policy/ch-maintainerscripts.html or
  18. # the debian-policy package
  19. # Directory that modified desktop entry config files are stored in
  20. XDG_CONFIG_QUBES="/usr/share/qubes/xdg"
  21. # Install overriden services only when original exists
  22. installOverridenServices() {
  23. override_dir="${1}"
  24. service="${2}"
  25. retval=1
  26. for unit in ${service}; do
  27. unit="${unit%%.*}"
  28. unit_name="$(basename ${unit})"
  29. if [ -f ${unit}.service ]; then
  30. echo "Installing override for ${unit}.service..."
  31. cp ${override_dir}/${unit_name}.service /etc/systemd/system/
  32. retval=0
  33. fi
  34. if [ -f ${unit}.socket -a -f ${override_dir}/${unit}.socket ]; then
  35. echo "Installing override for ${unit}.socket..."
  36. cp ${override_dir}/${unit_name}.socket /etc/systemd/system/
  37. retval=0
  38. fi
  39. if [ -f ${unit}.path -a -f ${override_dir}/${unit}.path ]; then
  40. echo "Installing override for ${unit}.path..."
  41. cp ${override_dir}/${unit_name}.path /etc/systemd/system/
  42. retval=0
  43. fi
  44. done
  45. return ${retval}
  46. }
  47. reenableNetworkManager() {
  48. # Disable original service to enable overriden one
  49. echo "Disabling original service to enable overriden one..."
  50. disableSystemdUnits ModemManager.service
  51. disableSystemdUnits NetworkManager.service
  52. # Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)
  53. echo "Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)"
  54. systemctl mask dbus-org.freedesktop.NetworkManager.service 2> /dev/null || echo "Could not disable D-BUS activation of NetworkManager"
  55. echo "Re-enabling original service to enable overriden one..."
  56. enableSystemdUnits ModemManager.service
  57. enableSystemdUnits NetworkManager.service
  58. # Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811
  59. echo "Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811"
  60. enableSystemdUnits NetworkManager-dispatcher.service
  61. }
  62. remove_ShowIn() {
  63. if [ -e "${1}" ]; then
  64. sed -i '/^\(Not\|Only\)ShowIn/d' "${1}"
  65. fi
  66. }
  67. showIn() {
  68. desktop_entry="${1}"
  69. shown_in="${2}"
  70. message="${shown_in:-"Shown in All;"}"
  71. desktop_entry_qubes="${XDG_CONFIG_QUBES}/autostart/${desktop_entry##*/}"
  72. # Make sure Qubes autostart directory exists
  73. mkdir -p "${XDG_CONFIG_QUBES}/autostart"
  74. # Desktop entry exists, so move to Qubes directory and modify it
  75. if [ -e "${desktop_entry}" ]; then
  76. echo "Desktop Entry Modification - ${message} ${desktop_entry##*/}..."
  77. cp -pf "${desktop_entry}" "${desktop_entry_qubes}"
  78. remove_ShowIn "${desktop_entry_qubes}"
  79. sed -i '/^X-GNOME-Autostart-enabled.*[fF0]/d' "${desktop_entry_qubes}"
  80. # Will only be '' if shown in all
  81. if [ ! "${shown_in}x" == "x" ]; then
  82. echo "${shown_in}" >> "${desktop_entry_qubes}" || true
  83. fi
  84. # Desktop entry must have been removed, so also remove from Qubes directory
  85. else
  86. echo "Desktop Entry Modification - Remove: ${desktop_entry##*/}..."
  87. rm -f "${desktop_entry_qubes}"
  88. fi
  89. }
  90. setArrayAsGlobal() {
  91. local array="$1"
  92. local export_as="$2"
  93. local code=$(declare -p "$array")
  94. local replaced="${code/$array/$export_as}"
  95. eval ${replaced/declare -/declare -g}
  96. }
  97. systemdInfo() {
  98. unit=${1}
  99. return_global_var=${2}
  100. declare -A INFO=()
  101. while read line; do
  102. INFO[${line%%=*}]="${line##*=}"
  103. done < <(systemctl show ${unit} 2> /dev/null)
  104. setArrayAsGlobal INFO $return_global_var
  105. return ${#INFO[@]}
  106. }
  107. displayFailedStatus() {
  108. action=${1}
  109. unit=${2}
  110. # Only display if there are results. In chroot environmnet there will be
  111. # no results to 'systemctl show' command
  112. systemdInfo ${unit} info || {
  113. echo
  114. echo "==================================================="
  115. echo "FAILED: systemd ${action} ${unit}"
  116. echo "==================================================="
  117. echo " LoadState = ${info[LoadState]}"
  118. echo " LoadError = ${info[LoadError]}"
  119. echo " ActiveState = ${info[ActiveState]}"
  120. echo " SubState = ${info[SubState]}"
  121. echo "UnitFileState = ${info[UnitFileState]}"
  122. echo
  123. }
  124. }
  125. # Disable systemd units
  126. disableSystemdUnits() {
  127. for unit in $*; do
  128. systemctl is-enabled ${unit} > /dev/null 2>&1 && {
  129. echo "Disabling ${unit}..."
  130. systemctl is-active ${unit} > /dev/null 2>&1 && {
  131. systemctl stop ${unit} > /dev/null 2>&1 || displayFailedStatus stop ${unit}
  132. }
  133. if [ -f /lib/systemd/system/${unit} ]; then
  134. if fgrep -q '[Install]' /lib/systemd/system/${unit}; then
  135. systemctl disable ${unit} > /dev/null 2>&1 || displayFailedStatus disable ${unit}
  136. else
  137. echo "Masking service: ${unit}"
  138. systemctl mask ${unit}
  139. fi
  140. else
  141. systemctl disable ${unit} > /dev/null 2>&1 || displayFailedStatus disable ${unit}
  142. fi
  143. } || {
  144. echo "It appears ${unit} is already disabled!"
  145. #displayFailedStatus is-disabled ${unit}
  146. }
  147. done
  148. }
  149. # Enable systemd units
  150. enableSystemdUnits() {
  151. for unit in $*; do
  152. systemctl is-enabled ${unit} > /dev/null 2>&1 && {
  153. echo "It appears ${unit} is already enabled!"
  154. #displayFailedStatus is-enabled ${unit}
  155. } || {
  156. echo "Enabling: ${unit}..."
  157. systemctl enable ${unit} > /dev/null 2>&1 || {
  158. echo "Could not enable: ${unit}"
  159. displayFailedStatus enable ${unit}
  160. }
  161. }
  162. done
  163. }
  164. # Manually trigger all triggers to automaticatly configure
  165. triggerTriggers() {
  166. path="$(readlink -m ${0})"
  167. triggers="${path/postinst/triggers}"
  168. awk '{sub(/[ \t]*#.*/,"")} NF' ${triggers} | while read line
  169. do
  170. /bin/bash -c "${0} triggered ${line##* }" || true
  171. done
  172. }
  173. case "${1}" in
  174. configure)
  175. # disable some Upstart services
  176. for init in plymouth-shutdown \
  177. prefdm \
  178. splash-manager \
  179. start-ttys \
  180. tty ; do
  181. dpkg-divert --divert /etc/init/${init}.conf.qubes-disabled --package qubes-core-agent --rename --add /etc/init/${init}.conf
  182. done
  183. # Create NetworkManager configuration if we do not have it
  184. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  185. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  186. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  187. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  188. fi
  189. # Remove old firmware updates link
  190. if [ -L /lib/firmware/updates ]; then
  191. rm -f /lib/firmware/updates
  192. fi
  193. # ensure that hostname resolves to 127.0.1.1 resp. ::1 and that /etc/hosts is
  194. # in the form expected by qubes-sysinit.sh
  195. for ip in '127\.0\.1\.1' '::1'; do
  196. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  197. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  198. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  199. else
  200. echo "${ip//\\/} `hostname`" >> /etc/hosts
  201. fi
  202. done
  203. # remove hostname from 127.0.0.1 line (in debian the hostname is by default
  204. # resolved to 127.0.1.1)
  205. sed -i "/^127\.0\.0\.1\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  206. chown user:user /home_volatile/user
  207. dpkg-divert --divert /etc/init/serial.conf.qubes-orig --package qubes-core-agent --rename --add /etc/init/serial.conf
  208. # Enable Qubes systemd units
  209. enableSystemdUnits \
  210. qubes-sysinit.service \
  211. qubes-misc-post.service \
  212. qubes-netwatcher.service \
  213. qubes-network.service \
  214. qubes-firewall.service \
  215. qubes-updates-proxy.service \
  216. qubes-update-check.timer \
  217. qubes-qrexec-agent.service
  218. # Set default "runlevel"
  219. systemctl set-default multi-user.target
  220. # Process all triggers which will set defaults to wanted values
  221. triggerTriggers
  222. disableSystemdUnits \
  223. alsa-store.service \
  224. alsa-restore.service \
  225. auditd.service \
  226. avahi.service \
  227. avahi-daemon.service \
  228. backuppc.service \
  229. cpuspeed.service \
  230. crond.service \
  231. fedora-autorelabel.service \
  232. fedora-autorelabel-mark.service \
  233. ipmi.service \
  234. hwclock-load.service \
  235. hwclock-save.service \
  236. mdmonitor.service \
  237. multipathd.service \
  238. openct.service \
  239. rpcbind.service \
  240. mcelog.service \
  241. fedora-storage-init.service \
  242. fedora-storage-init-late.service \
  243. plymouth-start.service \
  244. plymouth-read-write.service \
  245. plymouth-quit.service \
  246. plymouth-quit-wait.service \
  247. sshd.service \
  248. tcsd.service \
  249. sm-client.service \
  250. sendmail.service \
  251. mdmonitor-takeover.service \
  252. rngd smartd.service \
  253. upower.service \
  254. irqbalance.service \
  255. colord.service
  256. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  257. # Enable other systemd units
  258. enableSystemdUnits \
  259. rsyslog.service \
  260. netfilter-persistent.service
  261. # XXX: TODO: Needs to be implemented still
  262. # These do not exist on debian; maybe a different package name
  263. # ntpd.service \
  264. ;;
  265. abort-upgrade|abort-remove|abort-deconfigure)
  266. exit 0
  267. ;;
  268. triggered)
  269. for trigger in ${2}; do
  270. case "${trigger}" in
  271. # Update Qubes App Menus
  272. /usr/share/applications)
  273. echo "Updating Qubes App Menus..."
  274. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh || true
  275. ;;
  276. # Install overriden services only when original exists
  277. /lib/systemd/system/NetworkManager.service | \
  278. /lib/systemd/system/NetworkManager-wait-online.service | \
  279. /lib/systemd/system/ModemManager.service)
  280. UNITDIR=/lib/systemd/system
  281. OVERRIDEDIR=/usr/lib/qubes/init
  282. installOverridenServices "${OVERRIDEDIR}" "${trigger}"
  283. if [ $? -eq 0 ]; then
  284. reenableNetworkManager
  285. fi
  286. ;;
  287. # Enable cups only when it is real Systemd service
  288. /lib/systemd/system/cups.service)
  289. [ -e /lib/systemd/system/cups.service ] && enableSystemdUnits cups.service
  290. ;;
  291. # "Enable haveged service"
  292. /lib/systemd/system/haveged.service)
  293. [ -e /lib/systemd/system/haveged.service ] && enableSystemdUnits haveged.service
  294. ;;
  295. # Install overridden serial.conf init script
  296. /etc/init/serial.conf)
  297. echo "Installing over-ridden serial.conf init script..."
  298. if [ -e /etc/init/serial.conf ]; then
  299. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  300. fi
  301. ;;
  302. # Disable SELinux"
  303. /etc/selinux/config)
  304. echo "Disabling SELinux..."
  305. if [ -e /etc/selinux/config ]; then
  306. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  307. mv /etc/selinux/config.processed /etc/selinux/config
  308. setenforce 0 2>/dev/null
  309. fi
  310. ;;
  311. # Desktop Entry Modification - Remove existing rules
  312. /etc/xdg/autostart/gpk-update-icon.desktop | \
  313. /etc/xdg/autostart/nm-applet.desktop | \
  314. /etc/xdg/autostart/abrt-applet.desktop | \
  315. /etc/xdg/autostart/notify-osd.desktop)
  316. showIn "${trigger}"
  317. ;;
  318. # Desktop Entry Modification - Not shown in Qubes
  319. /etc/xdg/autostart/pulseaudio.desktop | \
  320. /etc/xdg/autostart/deja-dup-monitor.desktop | \
  321. /etc/xdg/autostart/imsettings-start.desktop | \
  322. /etc/xdg/autostart/krb5-auth-dialog.desktop | \
  323. /etc/xdg/autostart/pulseaudio.desktop | \
  324. /etc/xdg/autostart/restorecond.desktop | \
  325. /etc/xdg/autostart/sealertauto.desktop | \
  326. /etc/xdg/autostart/gnome-power-manager.desktop | \
  327. /etc/xdg/autostart/gnome-sound-applet.desktop | \
  328. /etc/xdg/autostart/gnome-screensaver.desktop | \
  329. /etc/xdg/autostart/orca-autostart.desktop)
  330. showIn "${trigger}" 'NotShowIn=QUBES;'
  331. ;;
  332. # Desktop Entry Modification - Not shown in in DisposableVM
  333. /etc/xdg/autostart/gcm-apply.desktop)
  334. showIn "${trigger}" 'NotShowIn=DisposableVM;'
  335. ;;
  336. # Desktop Entry Modification - Only shown in AppVM
  337. /etc/xdg/autostart/gnome-keyring-gpg.desktop | \
  338. /etc/xdg/autostart/gnome-keyring-pkcs11.desktop | \
  339. /etc/xdg/autostart/gnome-keyring-secrets.desktop | \
  340. /etc/xdg/autostart/gnome-keyring-ssh.desktop | \
  341. /etc/xdg/autostart/gnome-settings-daemon.desktop | \
  342. /etc/xdg/autostart/user-dirs-update-gtk.desktop | \
  343. /etc/xdg/autostart/gsettings-data-convert.desktop)
  344. showIn "${trigger}" 'OnlyShowIn=GNOME;AppVM;'
  345. ;;
  346. # Desktop Entry Modification - Only shown in Gnome & UpdateableVM
  347. /etc/xdg/autostart/gpk-update-icon.desktop)
  348. showIn "${trigger}" 'OnlyShowIn=GNOME;UpdateableVM;'
  349. ;;
  350. # Desktop Entry Modification - Only shown in Gnome & Qubes
  351. /etc/xdg/autostart/nm-applet.desktop)
  352. showIn "${trigger}" 'OnlyShowIn=GNOME;QUBES;'
  353. ;;
  354. *)
  355. echo "postinst called with unknown trigger \`${2}'" >&2
  356. exit 1
  357. ;;
  358. esac
  359. done
  360. exit 0
  361. ;;
  362. *)
  363. echo "postinst called with unknown argument \`${1}'" >&2
  364. exit 1
  365. ;;
  366. esac
  367. # dh_installdeb will replace this with shell code automatically
  368. # generated by other debhelper scripts.
  369. #DEBHELPER#
  370. exit 0
  371. # vim: set ts=4 sw=4 sts=4 et :