PKGBUILD.install 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426
  1. #!/bin/bash
  2. qubes_preset_file="75-qubes-vm.preset"
  3. ###########################
  4. ## Pre-Install functions ##
  5. ###########################
  6. update_default_user() {
  7. # Make sure there is a qubes group
  8. groupadd --force --system --gid 98 qubes
  9. # Archlinux bash version has a 'bug' when running su -c, /etc/profile is not loaded because bash consider there is no interactive pty when running 'su - user -c' or something like this.
  10. # See https://bugs.archlinux.org/task/31831
  11. id -u 'user' >/dev/null 2>&1 || {
  12. useradd --user-group --create-home --shell /bin/bash user
  13. }
  14. usermod -a --groups qubes user
  15. }
  16. ## arg 1: the new package version
  17. pre_install() {
  18. echo "Pre install..."
  19. update_default_user
  20. # do this whole %pre thing only when updating for the first time...
  21. mkdir -p /var/lib/qubes
  22. # Backup fstab / But use archlinux defaults (cp instead of mv)
  23. if [ -e /etc/fstab ] ; then
  24. cp /etc/fstab /var/lib/qubes/fstab.orig
  25. fi
  26. # Add qubes core related fstab entries
  27. echo "xen /proc/xen xenfs defaults 0 0" >> /etc/fstab
  28. usermod -p '' root
  29. usermod -L user
  30. }
  31. ## arg 1: the new package version
  32. ## arg 2: the old package version
  33. pre_upgrade() {
  34. # do something here
  35. echo "Pre upgrade..."
  36. update_default_user
  37. }
  38. ###################
  39. ## Install Hooks ##
  40. ###################
  41. configure_notification-daemon() {
  42. # Enable autostart of notification-daemon when installed
  43. if [ ! -L /etc/xdg/autostart/notification-daemon.desktop ]; then
  44. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  45. fi
  46. }
  47. configure_selinux() {
  48. # SELinux is not enabled on archlinux
  49. #echo "--> Disabling SELinux..."
  50. echo "SELINUX not enabled on archlinux. skipped."
  51. # sed -e s/^SELINUX=.*$/SELINUX=disabled/ -i /etc/selinux/config
  52. # setenforce 0 2>/dev/null
  53. }
  54. ############################
  55. ## Post-Install functions ##
  56. ############################
  57. update_qubesconfig() {
  58. # Remove old firmware updates link
  59. if [ -L /lib/firmware/updates ]; then
  60. rm -f /lib/firmware/updates
  61. fi
  62. #/usr/lib/qubes/update-proxy-configs
  63. # Archlinux pacman configuration is handled in update_finalize
  64. # Location of files which contains list of protected files
  65. mkdir -p /etc/qubes/protected-files.d
  66. # shellcheck source=init/functions
  67. . /usr/lib/qubes/init/functions
  68. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  69. if ! is_protected_file /etc/hosts ; then
  70. if ! grep -q localhost /etc/hosts; then
  71. cat <<EOF > /etc/hosts
  72. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 $(hostname)
  73. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  74. EOF
  75. fi
  76. fi
  77. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  78. # in the form expected by qubes-sysinit.sh
  79. if ! is_protected_file /etc/hostname ; then
  80. for ip in '127\.0\.0\.1' '::1'; do
  81. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  82. sed -i "/^${ip}\s/,+0s/\(\s$(hostname)\)\+\(\s\|$\)/\2/g" /etc/hosts
  83. sed -i "s/^${ip}\(\s\|$\).*$/\0 $(hostname)/" /etc/hosts
  84. else
  85. echo "${ip} $(hostname)" >> /etc/hosts
  86. fi
  87. done
  88. fi
  89. }
  90. ############################
  91. ## Service Management Functions ##
  92. ############################
  93. is_static() {
  94. [ -f "/usr/lib/systemd/system/$1" ] && ! grep -q '^[[].nstall]' "/usr/lib/systemd/system/$1"
  95. }
  96. is_masked() {
  97. if [ ! -L /etc/systemd/system/"$1" ]
  98. then
  99. return 1
  100. fi
  101. target=$(readlink /etc/systemd/system/"$1" 2>/dev/null) || :
  102. if [ "$target" = "/dev/null" ]
  103. then
  104. return 0
  105. fi
  106. return 1
  107. }
  108. mask() {
  109. ln -sf /dev/null /etc/systemd/system/"$1"
  110. }
  111. unmask() {
  112. if ! is_masked "$1"
  113. then
  114. return 0
  115. fi
  116. rm -f /etc/systemd/system/"$1"
  117. }
  118. preset_units() {
  119. local represet=
  120. while read -r action unit_name
  121. do
  122. if [ "$action" = "#" ] && [ "$unit_name" = "Units below this line will be re-preset on package upgrade" ]
  123. then
  124. represet=1
  125. continue
  126. fi
  127. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue
  128. [[ -n "$action" && -n "$unit_name" ]] || continue
  129. if [ "$2" = "initial" ] || [ "$represet" = "1" ]
  130. then
  131. if [ "$action" = "disable" ] && is_static "$unit_name"
  132. then
  133. if ! is_masked "$unit_name"
  134. then
  135. # We must effectively mask these units, even if they are static.
  136. mask "$unit_name"
  137. fi
  138. elif [ "$action" = "enable" ] && is_static "$unit_name"
  139. then
  140. if is_masked "$unit_name"
  141. then
  142. # We masked this static unit before, now we unmask it.
  143. unmask "$unit_name"
  144. fi
  145. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  146. else
  147. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  148. fi
  149. fi
  150. done < "$1"
  151. }
  152. restore_units() {
  153. grep '^[[:space:]]*[^#;]' "$1" | while read -r action unit_name
  154. do
  155. if is_static "$unit_name" && is_masked "$unit_name"
  156. then
  157. # If the unit had been masked by us, we must unmask it here.
  158. # Otherwise systemctl preset will fail badly.
  159. unmask "$unit_name"
  160. fi
  161. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || :
  162. done
  163. }
  164. configure_systemd() {
  165. if [ "$1" -eq 1 ]
  166. then
  167. preset_units /usr/lib/systemd/system-preset/$qubes_preset_file initial
  168. changed=true
  169. else
  170. preset_units /usr/lib/systemd/system-preset/$qubes_preset_file upgrade
  171. changed=true
  172. # Upgrade path - now qubes-iptables is used instead
  173. for svc in iptables ip6tables
  174. do
  175. if [ -f "$svc".service ]
  176. then
  177. systemctl --no-reload preset "$svc".service
  178. changed=true
  179. fi
  180. done
  181. fi
  182. if [ "$1" -eq 1 ]
  183. then
  184. # First install.
  185. # Set default "runlevel".
  186. # FIXME: this ought to be done via kernel command line.
  187. # The fewer deviations of the template from the seed
  188. # image, the better.
  189. rm -f /etc/systemd/system/default.target
  190. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  191. changed=true
  192. fi
  193. # remove old symlinks
  194. if [ -L /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  195. then
  196. rm -f /etc/systemd/system/sysinit.target.wants/qubes-random-seed.service
  197. changed=true
  198. fi
  199. if [ -L /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  200. then
  201. rm -f /etc/systemd/system/multi-user.target.wants/qubes-mount-home.service
  202. changed=true
  203. fi
  204. if [ "x$changed" != "x" ]
  205. then
  206. systemctl daemon-reload
  207. fi
  208. }
  209. ######################
  210. ## Archlinux Specific Functions ##
  211. ######################
  212. config_prependtomark() {
  213. FILE=$1
  214. APPENDBEFORELINE=$2
  215. APPENDLINE=$3
  216. grep -F -q "$APPENDLINE" "$FILE" || sed "/$APPENDBEFORELINE/i$APPENDLINE" -i "$FILE"
  217. }
  218. config_appendtomark() {
  219. FILE=$1
  220. APPENDAFTERLINE=$2
  221. APPENDLINE=$3
  222. grep -F -q "$APPENDLINE" "$FILE" || sed "/$APPENDAFTERLINE/a$APPENDLINE" -i "$FILE"
  223. }
  224. config_cleanupmark() {
  225. FILE="$1"
  226. BEGINMARK="$2"
  227. ENDMARK="$3"
  228. if grep -F -q "$BEGINMARK" "$FILE"; then
  229. if grep -F -q "$ENDMARK" "$FILE"; then
  230. cp "$FILE" "$FILE.qubes-update-orig"
  231. sed -i -e "/^$BEGINMARK$/,/^$ENDMARK$/{
  232. /^$ENDMARK$/b
  233. /^$BEGINMARK$/!d
  234. }" "$FILE"
  235. rm -f "$FILE.qubes-update-orig"
  236. else
  237. echo "ERROR: found $BEGINMARK marker but not $ENDMARK in $FILE. Please cleanup this file manually."
  238. fi
  239. elif grep -F -q "$ENDMARK" "$FILE"; then
  240. echo "ERROR: found $ENDMARK marker but not $BEGINMARK in $FILE. Please cleanup this file manually."
  241. fi
  242. }
  243. update_finalize() {
  244. # Archlinux specific: If marker exists, cleanup text between begin and end marker
  245. QUBES_MARKER="### QUBES CONFIG MARKER ###"
  246. if grep -F -q "$QUBES_MARKER" /etc/pacman.conf; then
  247. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "### QUBES CONFIG END MARKER ###"
  248. config_cleanupmark "/etc/pacman.conf" "$QUBES_MARKER" "### QUBES CONFIG END MARKER ###"
  249. # Else, add qubes config block marker
  250. else
  251. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "$QUBES_MARKER"
  252. config_prependtomark "/etc/pacman.conf" "# REPOSITORIES" "### QUBES CONFIG END MARKER ###"
  253. fi
  254. # Include /etc/pacman.d drop-in directory
  255. config_appendtomark "/etc/pacman.conf" "$QUBES_MARKER" "Include = /etc/pacman.d/*.conf"
  256. /usr/lib/qubes/update-proxy-configs
  257. # Archlinux specific: Update pam.d configuration for su to enable systemd-login wrapper
  258. # This is required as qubes-gui agent calls xinit with su -l user without initializing properly
  259. # the user session.
  260. # pam_unix.so can also be removed from su configuration
  261. # as system-login (which include system-auth) already gives pam_unix.so
  262. # with more appropriate parameters (fix the missing nullok parameter)
  263. if grep -q pam_unix.so /etc/pam.d/su; then
  264. echo "Fixing pam.d"
  265. cp /etc/pam.d/qrexec /etc/pam.d/su-l
  266. fi
  267. # Archlinux specific: ensure tty1 is enabled
  268. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  269. systemctl enable getty\@tty1.service
  270. systemctl daemon-reload
  271. }
  272. ## arg 1: the new package version
  273. post_install() {
  274. update_qubesconfig
  275. # do the rest of %post thing only when updating for the first time...
  276. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  277. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  278. fi
  279. # Remove most of the udev scripts to speed up the VM boot time
  280. # Just leave the xen* scripts, that are needed if this VM was
  281. # ever used as a net backend (e.g. as a VPN domain in the future)
  282. #echo "--> Removing unnecessary udev scripts..."
  283. mkdir -p /var/lib/qubes/removed-udev-scripts
  284. for f in /etc/udev/rules.d/*
  285. do
  286. if [ "$(basename "$f")" == "xen-backend.rules" ] ; then
  287. continue
  288. fi
  289. if [ "$(basename "$f")" == "50-qubes-misc.rules" ] ; then
  290. continue
  291. fi
  292. if echo "$f" | grep -q qubes; then
  293. continue
  294. fi
  295. mv "$f" /var/lib/qubes/removed-udev-scripts/
  296. done
  297. mkdir -p /rw
  298. configure_notification-daemon
  299. configure_selinux
  300. configure_systemd 0
  301. update_finalize
  302. }
  303. ## arg 1: the new package version
  304. ## arg 2: the old package version
  305. post_upgrade() {
  306. update_qubesconfig
  307. configure_notification-daemon
  308. configure_selinux
  309. configure_systemd 1
  310. update_finalize
  311. }
  312. ######################
  313. ## Remove functions ##
  314. ######################
  315. ## arg 1: the old package version
  316. pre_remove() {
  317. # no more packages left
  318. if [ -e /var/lib/qubes/fstab.orig ] ; then
  319. mv /var/lib/qubes/fstab.orig /etc/fstab
  320. fi
  321. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  322. if [ -e /var/lib/qubes/serial.orig ] ; then
  323. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  324. fi
  325. if [ "$1" -eq 0 ] ; then
  326. # Run this only during uninstall.
  327. # Save the preset file to later use it to re-preset services there
  328. # once the Qubes OS preset file is removed.
  329. mkdir -p /run/qubes-uninstall
  330. cp -f /usr/lib/systemd/system-preset/$qubes_preset_file /run/qubes-uninstall/
  331. cp -f /usr/lib/systemd/system-preset/$qubes_preset_file /run/qubes-uninstall/
  332. fi
  333. }
  334. ## arg 1: the old package version
  335. post_remove() {
  336. changed=
  337. if [ -d /run/qubes-uninstall ]
  338. then
  339. # We have a saved preset file (or more).
  340. # Re-preset the units mentioned there.
  341. restore_units /run/qubes-uninstall/$qubes_preset_file
  342. rm -rf /run/qubes-uninstall
  343. changed=true
  344. fi
  345. if [ "x$changed" != "x" ]
  346. then
  347. systemctl daemon-reload
  348. fi
  349. if [ -L /lib/firmware/updates ] ; then
  350. rm /lib/firmware/updates
  351. fi
  352. rm -rf /var/lib/qubes/xdg
  353. for srv in qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-qrexec-agent; do
  354. systemctl disable $srv.service
  355. done
  356. }