core-vm.spec 23 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-netwatcher qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: ntpdate
  123. Requires: net-tools
  124. Requires: nautilus-python
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. %if %{fedora} >= 20
  138. # gpk-update-viewer required by qubes-manager
  139. Requires: gnome-packagekit-updater
  140. %endif
  141. Requires: ImageMagick
  142. Requires: librsvg2-tools
  143. Requires: fakeroot
  144. Requires: desktop-notification-daemon
  145. # to show/hide nm-applet
  146. Requires: dconf
  147. Requires: pygtk2
  148. Requires: zenity
  149. Requires: qubes-libvchan
  150. Requires: qubes-db-vm
  151. %if 0%{fedora} >= 23
  152. Requires: python3-dnf-plugins-qubes-hooks
  153. %else
  154. Requires: python2-dnf-plugins-qubes-hooks
  155. %endif
  156. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  157. Obsoletes: qubes-upgrade-vm < 3.2
  158. BuildRequires: xen-devel
  159. BuildRequires: libX11-devel
  160. BuildRequires: qubes-utils-devel >= 3.1.3
  161. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  162. %package -n python2-dnf-plugins-qubes-hooks
  163. Summary: DNF plugin for Qubes specific post-installation actions
  164. BuildRequires: python2-devel
  165. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  166. %description -n python2-dnf-plugins-qubes-hooks
  167. DNF plugin for Qubes specific post-installation actions:
  168. * notify dom0 that updates were installed
  169. * refresh applications shortcut list
  170. %package -n python3-dnf-plugins-qubes-hooks
  171. Summary: DNF plugin for Qubes specific post-installation actions
  172. BuildRequires: python3-devel
  173. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  174. %description -n python3-dnf-plugins-qubes-hooks
  175. DNF plugin for Qubes specific post-installation actions:
  176. * notify dom0 that updates were installed
  177. * refresh applications shortcut list
  178. %define _builddir %(pwd)
  179. %define kde_service_dir /usr/share/kde4/services
  180. %description
  181. The Qubes core files for installation inside a Qubes VM.
  182. %prep
  183. # we operate on the current directory, so no need to unpack anything
  184. # symlink is to generate useful debuginfo packages
  185. rm -f %{name}-%{version}
  186. ln -sf . %{name}-%{version}
  187. %setup -T -D
  188. %build
  189. for dir in qubes-rpc qrexec misc; do
  190. (cd $dir; make)
  191. done
  192. %pre
  193. # Make sure there is a qubes group
  194. groupadd --force --system --gid 98 qubes
  195. id -u 'user' >/dev/null 2>&1 || {
  196. useradd --user-group --create-home --shell /bin/bash user
  197. }
  198. usermod -a --groups qubes user
  199. if [ "$1" != 1 ] ; then
  200. # do this whole %%pre thing only when updating for the first time...
  201. exit 0
  202. fi
  203. mkdir -p /var/lib/qubes
  204. if [ -e /etc/fstab ] ; then
  205. mv /etc/fstab /var/lib/qubes/fstab.orig
  206. fi
  207. usermod -p '' root
  208. usermod -L user
  209. %install
  210. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  211. make install-vm DESTDIR=$RPM_BUILD_ROOT
  212. %if %{fedora} >= 22
  213. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  214. %endif
  215. %triggerin -- initscripts
  216. if [ -e /etc/init/serial.conf ]; then
  217. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  218. fi
  219. %post
  220. # disable some Upstart services
  221. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  222. if [ -e /etc/init/$F.conf ]; then
  223. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  224. fi
  225. done
  226. # Create NetworkManager configuration if we do not have it
  227. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  228. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  229. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  230. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  231. fi
  232. /usr/lib/qubes/qubes-fix-nm-conf.sh
  233. # Remove ip_forward setting from sysctl, so NM will not reset it
  234. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  235. # Remove old firmware updates link
  236. if [ -L /lib/firmware/updates ]; then
  237. rm -f /lib/firmware/updates
  238. fi
  239. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  240. echo >> /etc/yum.conf
  241. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  242. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  243. fi
  244. # And actually setup the proxy usage in package managers
  245. /usr/lib/qubes/update-proxy-configs
  246. # Location of files which contains list of protected files
  247. mkdir -p /etc/qubes/protected-files.d
  248. . /usr/lib/qubes/init/functions
  249. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  250. if ! is_protected_file /etc/hosts ; then
  251. if ! grep -q localhost /etc/hosts; then
  252. cat <<EOF > /etc/hosts
  253. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  254. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  255. EOF
  256. fi
  257. fi
  258. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  259. # in the form expected by qubes-sysinit.sh
  260. if ! is_protected_file /etc/hostname ; then
  261. for ip in '127\.0\.0\.1' '::1'; do
  262. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  263. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  264. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  265. else
  266. echo "${ip} `hostname`" >> /etc/hosts
  267. fi
  268. done
  269. fi
  270. %if %{fedora} >= 20
  271. # Make sure there is a default locale set so gnome-terminal will start
  272. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  273. touch /etc/locale.conf
  274. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  275. fi
  276. # ... and make sure it is really generated
  277. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  278. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  279. base=`echo "$current_locale" | cut -f 1 -d .`
  280. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  281. [ -n "$charmap" ] && charmap="-f $charmap"
  282. localedef -i $base $charmap $current_locale
  283. fi
  284. %endif
  285. if [ "$1" != 1 ] ; then
  286. # do the rest of %%post thing only when updating for the first time...
  287. exit 0
  288. fi
  289. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  290. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  291. fi
  292. # Remove most of the udev scripts to speed up the VM boot time
  293. # Just leave the xen* scripts, that are needed if this VM was
  294. # ever used as a net backend (e.g. as a VPN domain in the future)
  295. #echo "--> Removing unnecessary udev scripts..."
  296. mkdir -p /var/lib/qubes/removed-udev-scripts
  297. for f in /etc/udev/rules.d/*
  298. do
  299. if [ $(basename $f) == "xen-backend.rules" ] ; then
  300. continue
  301. fi
  302. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  303. continue
  304. fi
  305. if echo $f | grep -q qubes; then
  306. continue
  307. fi
  308. mv $f /var/lib/qubes/removed-udev-scripts/
  309. done
  310. mkdir -p /rw
  311. #rm -f /etc/mtab
  312. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  313. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  314. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  315. %triggerin -- notification-daemon
  316. # Enable autostart of notification-daemon when installed
  317. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  318. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  319. fi
  320. exit 0
  321. %triggerin -- selinux-policy
  322. #echo "--> Disabling SELinux..."
  323. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  324. mv /etc/selinux/config.processed /etc/selinux/config
  325. setenforce 0 2>/dev/null
  326. exit 0
  327. %preun
  328. if [ "$1" = 0 ] ; then
  329. # no more packages left
  330. if [ -e /var/lib/qubes/fstab.orig ] ; then
  331. mv /var/lib/qubes/fstab.orig /etc/fstab
  332. fi
  333. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  334. if [ -e /var/lib/qubes/serial.orig ] ; then
  335. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  336. fi
  337. fi
  338. %postun
  339. if [ $1 -eq 0 ] ; then
  340. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  341. if [ -L /lib/firmware/updates ]; then
  342. rm /lib/firmware/updates
  343. fi
  344. rm -rf /var/lib/qubes/xdg
  345. fi
  346. %posttrans
  347. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  348. %clean
  349. rm -rf $RPM_BUILD_ROOT
  350. rm -f %{name}-%{version}
  351. %files
  352. %defattr(-,root,root,-)
  353. %dir /var/lib/qubes
  354. %dir /var/run/qubes
  355. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  356. %{kde_service_dir}/qvm-copy.desktop
  357. %{kde_service_dir}/qvm-move.desktop
  358. %{kde_service_dir}/qvm-dvm.desktop
  359. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  360. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  361. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  362. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  363. /etc/fstab
  364. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  365. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  366. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  367. %dir /etc/qubes-rpc
  368. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  369. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  370. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  371. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  372. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  373. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  374. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  375. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  376. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  377. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  378. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  379. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  380. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  381. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  382. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  383. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  384. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  385. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  386. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  387. %dir /etc/qubes/autostart
  388. /etc/qubes/autostart/README.txt
  389. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  390. %dir /etc/qubes/suspend-pre.d
  391. /etc/qubes/suspend-pre.d/README
  392. %dir /etc/qubes/suspend-post.d
  393. /etc/qubes/suspend-post.d/README
  394. %config(noreplace) /etc/sudoers.d/qubes
  395. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  396. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  397. %config(noreplace) /etc/qubes/iptables.rules
  398. %config(noreplace) /etc/qubes/ip6tables.rules
  399. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  400. %config(noreplace) /etc/tinyproxy/updates-blacklist
  401. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  402. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  403. %config(noreplace) /etc/qubes-suspend-module-blacklist
  404. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  405. /etc/xen/scripts/vif-route-qubes
  406. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  407. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  408. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  409. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  410. %if %{fedora} < 22
  411. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  412. %endif
  413. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  414. /usr/sbin/qubes-serial-login
  415. /usr/bin/qvm-copy-to-vm
  416. /usr/bin/qvm-move-to-vm
  417. /usr/bin/qvm-open-in-dvm
  418. /usr/bin/qvm-open-in-vm
  419. /usr/bin/qvm-run
  420. /usr/bin/qvm-mru-entry
  421. /usr/bin/xenstore-watch-qubes
  422. /usr/bin/qubes-desktop-run
  423. /usr/bin/qubes-open
  424. /usr/bin/qrexec-fork-server
  425. /usr/bin/qrexec-client-vm
  426. /usr/bin/qubes-session-autostart
  427. %dir /usr/lib/qubes
  428. /usr/lib/qubes/vusb-ctl.py*
  429. /usr/lib/qubes/dispvm-prerun.sh
  430. /usr/lib/qubes/sync-ntp-clock
  431. /usr/lib/qubes/prepare-suspend
  432. /usr/lib/qubes/network-manager-prepare-conf-dir
  433. /usr/lib/qubes/show-hide-nm-applet.sh
  434. /usr/lib/qubes/qrexec-agent
  435. /usr/lib/qubes/qrexec-client-vm
  436. /usr/lib/qubes/qrexec_client_vm
  437. /usr/lib/qubes/qubes-rpc-multiplexer
  438. /usr/lib/qubes/qfile-agent
  439. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  440. /usr/lib/qubes/qopen-in-vm
  441. /usr/lib/qubes/qrun-in-vm
  442. /usr/lib/qubes/qubes-download-dom0-updates.sh
  443. /usr/lib/qubes/qubes-fix-nm-conf.sh
  444. /usr/lib/qubes/qubes-setup-dnat-to-ns
  445. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  446. /usr/lib/qubes/qvm-copy-to-vm.gnome
  447. /usr/lib/qubes/qvm-copy-to-vm.kde
  448. /usr/lib/qubes/qvm-move-to-vm.gnome
  449. /usr/lib/qubes/qvm-move-to-vm.kde
  450. /usr/lib/qubes/setup-ip
  451. /usr/lib/qubes/tar2qfile
  452. /usr/lib/qubes/vm-file-editor
  453. /usr/lib/qubes/iptables-updates-proxy
  454. /usr/lib/qubes/close-window
  455. /usr/lib/qubes/xdg-icon
  456. /usr/lib/qubes/update-proxy-configs
  457. /usr/lib/qubes/upgrades-installed-check
  458. /usr/lib/qubes/upgrades-status-notify
  459. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  460. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  461. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  462. %dir /usr/lib/qubes/init
  463. /usr/lib/qubes/init/*.sh
  464. /usr/lib/qubes/init/functions
  465. %dir /usr/lib/qubes-bind-dirs.d
  466. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  467. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  468. /usr/sbin/qubes-firewall
  469. /usr/sbin/qubes-netwatcher
  470. /usr/share/qubes/serial.conf
  471. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  472. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  473. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  474. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  475. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  476. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  477. /usr/share/qubes/mime-override/globs
  478. /usr/share/qubes/qubes-master-key.asc
  479. %dir /home_volatile
  480. %attr(700,user,user) /home_volatile/user
  481. %dir /mnt/removable
  482. %dir /rw
  483. %files -n python2-dnf-plugins-qubes-hooks
  484. %{python2_sitelib}/dnf-plugins/*
  485. %files -n python3-dnf-plugins-qubes-hooks
  486. %{python3_sitelib}/dnf-plugins/*
  487. %package sysvinit
  488. Summary: Qubes unit files for SysV init style or upstart
  489. License: GPL v2 only
  490. Group: Qubes
  491. Requires: upstart
  492. Requires: qubes-core-vm
  493. Provides: qubes-core-vm-init-scripts
  494. Conflicts: qubes-core-vm-systemd
  495. %description sysvinit
  496. The Qubes core startup configuration for SysV init (or upstart).
  497. %files sysvinit
  498. /etc/init.d/qubes-sysinit
  499. /etc/init.d/qubes-core-early
  500. /etc/init.d/qubes-core
  501. /etc/init.d/qubes-dvm
  502. /etc/init.d/qubes-core-netvm
  503. /etc/init.d/qubes-firewall
  504. /etc/init.d/qubes-netwatcher
  505. /etc/init.d/qubes-iptables
  506. /etc/init.d/qubes-updates-proxy
  507. /etc/init.d/qubes-qrexec-agent
  508. /etc/sysconfig/modules/qubes-core.modules
  509. /etc/sysconfig/modules/qubes-misc.modules
  510. %post sysvinit
  511. #echo "--> Turning off unnecessary services..."
  512. # FIXME: perhaps there is more elegant way to do this?
  513. for f in /etc/init.d/*
  514. do
  515. srv=`basename $f`
  516. [ $srv = 'functions' ] && continue
  517. [ $srv = 'killall' ] && continue
  518. [ $srv = 'halt' ] && continue
  519. [ $srv = 'single' ] && continue
  520. [ $srv = 'reboot' ] && continue
  521. [ $srv = 'qubes-gui' ] && continue
  522. chkconfig $srv off
  523. done
  524. #echo "--> Enabling essential services..."
  525. chkconfig rsyslog on
  526. chkconfig haldaemon on
  527. chkconfig messagebus on
  528. for svc in %qubes_services ; do
  529. if [ "$1" = 1 ] ; then
  530. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  531. else
  532. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  533. fi
  534. done
  535. # TODO: make this not display the silly message about security context...
  536. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  537. %preun sysvinit
  538. if [ "$1" = 0 ] ; then
  539. # no more packages left
  540. for svc in %qubes_services ; do
  541. chkconfig --del $svc
  542. done
  543. fi
  544. %package systemd
  545. Summary: Qubes unit files for SystemD init style
  546. License: GPL v2 only
  547. Group: Qubes
  548. Requires: systemd
  549. Requires(post): systemd-units
  550. Requires(preun): systemd-units
  551. Requires(postun): systemd-units
  552. Requires: qubes-core-vm
  553. Provides: qubes-core-vm-init-scripts
  554. Conflicts: qubes-core-vm-sysvinit
  555. %description systemd
  556. The Qubes core startup configuration for SystemD init.
  557. %files systemd
  558. %defattr(-,root,root,-)
  559. /lib/systemd/system/qubes-dvm.service
  560. /lib/systemd/system/qubes-misc-post.service
  561. /lib/systemd/system/qubes-firewall.service
  562. /lib/systemd/system/qubes-mount-dirs.service
  563. /lib/systemd/system/qubes-netwatcher.service
  564. /lib/systemd/system/qubes-network.service
  565. /lib/systemd/system/qubes-iptables.service
  566. /lib/systemd/system/qubes-sysinit.service
  567. /lib/systemd/system/qubes-early-vm-config.service
  568. /lib/systemd/system/qubes-update-check.service
  569. /lib/systemd/system/qubes-update-check.timer
  570. /lib/systemd/system/qubes-updates-proxy.service
  571. /lib/systemd/system/qubes-qrexec-agent.service
  572. /lib/systemd/system-preset/%qubes_preset_file
  573. /lib/modules-load.d/qubes-core.conf
  574. /lib/modules-load.d/qubes-misc.conf
  575. /usr/lib/qubes/init/qubes-iptables
  576. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  577. /lib/systemd/system/crond.service.d/30_qubes.conf
  578. /lib/systemd/system/cups.service.d/30_qubes.conf
  579. /lib/systemd/system/cups.socket.d/30_qubes.conf
  580. /lib/systemd/system/cups.path.d/30_qubes.conf
  581. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  582. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  583. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  584. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  585. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  586. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  587. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  588. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  589. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  590. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  591. /lib/systemd/system/tor.service.d/30_qubes.conf
  592. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  593. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  594. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  595. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  596. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  597. %post systemd
  598. changed=
  599. %scriptletfuns
  600. if [ $1 -eq 1 ]
  601. then
  602. preset_units %{_presetdir}/%qubes_preset_file initial
  603. changed=true
  604. else
  605. preset_units %{_presetdir}/%qubes_preset_file upgrade
  606. changed=true
  607. # Upgrade path - now qubes-iptables is used instead
  608. for svc in iptables ip6tables
  609. do
  610. if [ -f "$svc".service ]
  611. then
  612. systemctl --no-reload preset "$svc".service
  613. changed=true
  614. fi
  615. done
  616. fi
  617. if [ $1 -eq 1 ]
  618. then
  619. # First install.
  620. # Set default "runlevel".
  621. # FIXME: this ought to be done via kernel command line.
  622. # The fewer deviations of the template from the seed
  623. # image, the better.
  624. rm -f %{_sysconfdir}/systemd/system/default.target
  625. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  626. changed=true
  627. fi
  628. # remove old symlinks
  629. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  630. then
  631. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  632. changed=true
  633. fi
  634. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  635. then
  636. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  637. changed=true
  638. fi
  639. if [ "x$changed" != "x" ]
  640. then
  641. systemctl daemon-reload
  642. fi
  643. %preun systemd
  644. if [ $1 -eq 0 ] ; then
  645. # Run this only during uninstall.
  646. # Save the preset file to later use it to re-preset services there
  647. # once the Qubes OS preset file is removed.
  648. mkdir -p %{_rundir}/qubes-uninstall
  649. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  650. fi
  651. %postun systemd
  652. changed=
  653. %scriptletfuns
  654. if [ -d %{_rundir}/qubes-uninstall ]
  655. then
  656. # We have a saved preset file (or more).
  657. # Re-preset the units mentioned there.
  658. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  659. rm -rf %{_rundir}/qubes-uninstall
  660. changed=true
  661. fi
  662. if [ "x$changed" != "x" ]
  663. then
  664. systemctl daemon-reload
  665. fi