rules 662 B

12345678910111213141516171819202122232425262728293031
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Uncomment this to turn on verbose mode.
  4. #export DH_VERBOSE=1
  5. export PYTHON_PREFIX_ARG=--install-layout=deb
  6. include /usr/share/dpkg/default.mk
  7. export DESTDIR=$(shell pwd)/debian/tmp
  8. %:
  9. dh $@ --with systemd,python3 --with=config-package
  10. override_dh_auto_build:
  11. make all
  12. override_dh_auto_install:
  13. make install-deb
  14. make -C qubes-rpc install
  15. make -C qubes-rpc/kde install
  16. make -C qubes-rpc/nautilus install
  17. make -C qubes-rpc/thunar install
  18. override_dh_fixperms:
  19. dh_fixperms -a -Xqfile-unpacker
  20. override_dh_systemd_start:
  21. dh_systemd_start --no-restart-on-upgrade
  22. override_dh_install:
  23. dh_install --fail-missing