core-agent.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: nmap-ncat
  123. Requires: ntpdate
  124. Requires: net-tools
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. Requires: python-daemon
  138. # for qvm-feature-request
  139. Requires: python2-qubesdb
  140. Requires: nftables
  141. Requires: ImageMagick
  142. Requires: librsvg2-tools
  143. Requires: desktop-notification-daemon
  144. # to show/hide nm-applet
  145. Requires: dconf
  146. Requires: zenity
  147. Requires: qubes-libvchan
  148. Requires: qubes-db-vm
  149. %if 0%{fedora} >= 23
  150. Requires: python3-dnf-plugins-qubes-hooks
  151. %else
  152. Requires: python2-dnf-plugins-qubes-hooks
  153. %endif
  154. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  155. Obsoletes: qubes-upgrade-vm < 3.2
  156. Provides: qubes-core-vm = %{version}-%{release}
  157. Obsoletes: qubes-core-vm < 4.0.0
  158. BuildRequires: xen-devel
  159. BuildRequires: libX11-devel
  160. BuildRequires: qubes-utils-devel >= 3.1.3
  161. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  162. %description
  163. The Qubes core files for installation inside a Qubes VM.
  164. %package -n python2-dnf-plugins-qubes-hooks
  165. Summary: DNF plugin for Qubes specific post-installation actions
  166. BuildRequires: python2-devel
  167. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  168. %description -n python2-dnf-plugins-qubes-hooks
  169. DNF plugin for Qubes specific post-installation actions:
  170. * notify dom0 that updates were installed
  171. * refresh applications shortcut list
  172. %package -n python3-dnf-plugins-qubes-hooks
  173. Summary: DNF plugin for Qubes specific post-installation actions
  174. BuildRequires: python3-devel
  175. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  176. %description -n python3-dnf-plugins-qubes-hooks
  177. DNF plugin for Qubes specific post-installation actions:
  178. * notify dom0 that updates were installed
  179. * refresh applications shortcut list
  180. %package nautilus
  181. Summary: Qubes integration for Nautilus
  182. Requires: qubes-core-agent
  183. Requires: nautilus-python
  184. %description nautilus
  185. Nautilus addons for inter-VM file copy/move/open.
  186. %package dom0-updates
  187. Summary: Scripts required to handle dom0 updates
  188. Requires: qubes-core-agent
  189. Requires: fakeroot
  190. %description dom0-updates
  191. Scripts required to handle dom0 updates.
  192. %define _builddir %(pwd)
  193. %define kde_service_dir /usr/share/kde4/services
  194. %prep
  195. # we operate on the current directory, so no need to unpack anything
  196. # symlink is to generate useful debuginfo packages
  197. rm -f %{name}-%{version}
  198. ln -sf . %{name}-%{version}
  199. %setup -T -D
  200. %build
  201. for dir in qubes-rpc qrexec misc; do
  202. (cd $dir; make)
  203. done
  204. %pre
  205. # Make sure there is a qubes group
  206. groupadd --force --system --gid 98 qubes
  207. id -u 'user' >/dev/null 2>&1 || {
  208. useradd --user-group --create-home --shell /bin/bash user
  209. }
  210. usermod -a --groups qubes user
  211. if [ "$1" != 1 ] ; then
  212. # do this whole %%pre thing only when updating for the first time...
  213. exit 0
  214. fi
  215. mkdir -p /var/lib/qubes
  216. if [ -e /etc/fstab ] ; then
  217. mv /etc/fstab /var/lib/qubes/fstab.orig
  218. fi
  219. usermod -p '' root
  220. usermod -L user
  221. %install
  222. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  223. make install-vm DESTDIR=$RPM_BUILD_ROOT
  224. %if %{fedora} >= 22
  225. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  226. %endif
  227. %triggerin -- initscripts
  228. if [ -e /etc/init/serial.conf ]; then
  229. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  230. fi
  231. %post
  232. # disable some Upstart services
  233. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  234. if [ -e /etc/init/$F.conf ]; then
  235. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  236. fi
  237. done
  238. # Create NetworkManager configuration if we do not have it
  239. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  240. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  241. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  242. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  243. fi
  244. /usr/lib/qubes/qubes-fix-nm-conf.sh
  245. # Remove ip_forward setting from sysctl, so NM will not reset it
  246. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  247. # Remove old firmware updates link
  248. if [ -L /lib/firmware/updates ]; then
  249. rm -f /lib/firmware/updates
  250. fi
  251. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  252. echo >> /etc/yum.conf
  253. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  254. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  255. fi
  256. # And actually setup the proxy usage in package managers
  257. /usr/lib/qubes/update-proxy-configs
  258. # Location of files which contains list of protected files
  259. mkdir -p /etc/qubes/protected-files.d
  260. . /usr/lib/qubes/init/functions
  261. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  262. if ! is_protected_file /etc/hosts ; then
  263. if ! grep -q localhost /etc/hosts; then
  264. cat <<EOF > /etc/hosts
  265. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  266. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  267. EOF
  268. fi
  269. fi
  270. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  271. # in the form expected by qubes-sysinit.sh
  272. if ! is_protected_file /etc/hostname ; then
  273. for ip in '127\.0\.0\.1' '::1'; do
  274. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  275. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  276. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  277. else
  278. echo "${ip} `hostname`" >> /etc/hosts
  279. fi
  280. done
  281. fi
  282. %if %{fedora} >= 20
  283. # Make sure there is a default locale set so gnome-terminal will start
  284. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  285. touch /etc/locale.conf
  286. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  287. fi
  288. # ... and make sure it is really generated
  289. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  290. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  291. base=`echo "$current_locale" | cut -f 1 -d .`
  292. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  293. [ -n "$charmap" ] && charmap="-f $charmap"
  294. localedef -i $base $charmap $current_locale
  295. fi
  296. %endif
  297. if [ "$1" != 1 ] ; then
  298. # do the rest of %%post thing only when updating for the first time...
  299. exit 0
  300. fi
  301. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  302. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  303. fi
  304. # Remove most of the udev scripts to speed up the VM boot time
  305. # Just leave the xen* scripts, that are needed if this VM was
  306. # ever used as a net backend (e.g. as a VPN domain in the future)
  307. #echo "--> Removing unnecessary udev scripts..."
  308. mkdir -p /var/lib/qubes/removed-udev-scripts
  309. for f in /etc/udev/rules.d/*
  310. do
  311. if [ $(basename $f) == "xen-backend.rules" ] ; then
  312. continue
  313. fi
  314. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  315. continue
  316. fi
  317. if echo $f | grep -q qubes; then
  318. continue
  319. fi
  320. mv $f /var/lib/qubes/removed-udev-scripts/
  321. done
  322. mkdir -p /rw
  323. #rm -f /etc/mtab
  324. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  325. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  326. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  327. %triggerin -- notification-daemon
  328. # Enable autostart of notification-daemon when installed
  329. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  330. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  331. fi
  332. exit 0
  333. %triggerin -- selinux-policy
  334. #echo "--> Disabling SELinux..."
  335. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  336. mv /etc/selinux/config.processed /etc/selinux/config
  337. setenforce 0 2>/dev/null
  338. exit 0
  339. %preun
  340. if [ "$1" = 0 ] ; then
  341. # no more packages left
  342. if [ -e /var/lib/qubes/fstab.orig ] ; then
  343. mv /var/lib/qubes/fstab.orig /etc/fstab
  344. fi
  345. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  346. if [ -e /var/lib/qubes/serial.orig ] ; then
  347. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  348. fi
  349. fi
  350. %postun
  351. if [ $1 -eq 0 ] ; then
  352. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  353. if [ -L /lib/firmware/updates ]; then
  354. rm /lib/firmware/updates
  355. fi
  356. rm -rf /var/lib/qubes/xdg
  357. fi
  358. %posttrans
  359. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  360. %clean
  361. rm -rf $RPM_BUILD_ROOT
  362. rm -f %{name}-%{version}
  363. %files
  364. %defattr(-,root,root,-)
  365. %dir /var/lib/qubes
  366. %dir /var/run/qubes
  367. %{kde_service_dir}/qvm-copy.desktop
  368. %{kde_service_dir}/qvm-move.desktop
  369. %{kde_service_dir}/qvm-dvm.desktop
  370. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  371. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  372. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  373. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  374. /etc/fstab
  375. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  376. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  377. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  378. %dir /etc/qubes-rpc
  379. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  380. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  381. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  382. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  383. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  384. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  385. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  386. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  387. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  388. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  389. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  390. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  391. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  392. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  393. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  394. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  395. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  396. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  397. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  398. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  399. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  400. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  401. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  402. %dir /etc/qubes/autostart
  403. /etc/qubes/autostart/README.txt
  404. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  405. %dir /etc/qubes/suspend-pre.d
  406. /etc/qubes/suspend-pre.d/README
  407. %dir /etc/qubes/suspend-post.d
  408. /etc/qubes/suspend-post.d/README
  409. %dir /etc/qubes/post-install.d
  410. /etc/qubes/post-install.d/README
  411. /etc/qubes/post-install.d/*.sh
  412. %config(noreplace) /etc/sudoers.d/qubes
  413. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  414. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  415. %config(noreplace) /etc/qubes/iptables.rules
  416. %config(noreplace) /etc/qubes/ip6tables.rules
  417. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  418. %config(noreplace) /etc/tinyproxy/updates-blacklist
  419. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  420. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  421. %config(noreplace) /etc/qubes-suspend-module-blacklist
  422. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  423. /etc/xen/scripts/vif-route-qubes
  424. /etc/xen/scripts/vif-qubes-nat.sh
  425. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  426. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  427. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  428. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  429. %if %{fedora} < 22
  430. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  431. %endif
  432. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  433. /usr/sbin/qubes-serial-login
  434. /usr/bin/qvm-copy-to-vm
  435. /usr/bin/qvm-move-to-vm
  436. /usr/bin/qvm-open-in-dvm
  437. /usr/bin/qvm-open-in-vm
  438. /usr/bin/qvm-run-vm
  439. /usr/bin/qvm-features-request
  440. /usr/bin/xenstore-watch-qubes
  441. /usr/bin/qubes-desktop-run
  442. /usr/bin/qubes-open
  443. /usr/bin/qrexec-fork-server
  444. /usr/bin/qrexec-client-vm
  445. /usr/bin/qubes-session-autostart
  446. %dir /usr/lib/qubes
  447. /usr/lib/qubes/vusb-ctl.py*
  448. /usr/lib/qubes/dispvm-prerun.sh
  449. /usr/lib/qubes/sync-ntp-clock
  450. /usr/lib/qubes/prepare-suspend
  451. /usr/lib/qubes/network-manager-prepare-conf-dir
  452. /usr/lib/qubes/show-hide-nm-applet.sh
  453. /usr/lib/qubes/qrexec-agent
  454. /usr/lib/qubes/qrexec-client-vm
  455. /usr/lib/qubes/qrexec_client_vm
  456. /usr/lib/qubes/qubes-rpc-multiplexer
  457. /usr/lib/qubes/qfile-agent
  458. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  459. /usr/lib/qubes/qopen-in-vm
  460. /usr/lib/qubes/qrun-in-vm
  461. /usr/lib/qubes/qubes-fix-nm-conf.sh
  462. /usr/lib/qubes/qubes-setup-dnat-to-ns
  463. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  464. /usr/lib/qubes/qvm-copy-to-vm.kde
  465. /usr/lib/qubes/qvm-move-to-vm.kde
  466. /usr/lib/qubes/setup-ip
  467. /usr/lib/qubes/tar2qfile
  468. /usr/lib/qubes/vm-file-editor
  469. /usr/lib/qubes/iptables-updates-proxy
  470. /usr/lib/qubes/close-window
  471. /usr/lib/qubes/xdg-icon
  472. /usr/lib/qubes/update-proxy-configs
  473. /usr/lib/qubes/upgrades-installed-check
  474. /usr/lib/qubes/upgrades-status-notify
  475. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  476. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  477. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  478. %dir /usr/lib/qubes/init
  479. /usr/lib/qubes/init/*.sh
  480. /usr/lib/qubes/init/functions
  481. %dir /usr/lib/qubes-bind-dirs.d
  482. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  483. /usr/lib/python2.7/site-packages/qubesxdg.py*
  484. /usr/sbin/qubes-firewall
  485. /usr/share/qubes/serial.conf
  486. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  487. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  488. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  489. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  490. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  491. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  492. %dir %{python_sitelib}/qubesagent
  493. %{python_sitelib}/qubesagent/__init__.py*
  494. %{python_sitelib}/qubesagent/firewall.py*
  495. %{python_sitelib}/qubesagent/test_firewall.py*
  496. /usr/share/qubes/mime-override/globs
  497. /usr/share/qubes/qubes-master-key.asc
  498. %dir /home_volatile
  499. %attr(700,user,user) /home_volatile/user
  500. %dir /mnt/removable
  501. %dir /rw
  502. %files -n python2-dnf-plugins-qubes-hooks
  503. %{python2_sitelib}/dnf-plugins/*
  504. %files -n python3-dnf-plugins-qubes-hooks
  505. %{python3_sitelib}/dnf-plugins/*
  506. %files nautilus
  507. /usr/lib/qubes/qvm-copy-to-vm.gnome
  508. /usr/lib/qubes/qvm-move-to-vm.gnome
  509. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  510. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  511. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  512. %files dom0-updates
  513. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  514. /usr/lib/qubes/qubes-download-dom0-updates.sh
  515. %package sysvinit
  516. Summary: Qubes unit files for SysV init style or upstart
  517. License: GPL v2 only
  518. Group: Qubes
  519. Requires: upstart
  520. Requires: qubes-core-agent
  521. Provides: qubes-core-agent-init-scripts
  522. Conflicts: qubes-core-agent-systemd
  523. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  524. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  525. %description sysvinit
  526. The Qubes core startup configuration for SysV init (or upstart).
  527. %files sysvinit
  528. /etc/init.d/qubes-sysinit
  529. /etc/init.d/qubes-core-early
  530. /etc/init.d/qubes-core
  531. /etc/init.d/qubes-dvm
  532. /etc/init.d/qubes-core-netvm
  533. /etc/init.d/qubes-firewall
  534. /etc/init.d/qubes-iptables
  535. /etc/init.d/qubes-updates-proxy
  536. /etc/init.d/qubes-qrexec-agent
  537. /etc/init.d/qubes-updates-proxy-forwarder
  538. /etc/sysconfig/modules/qubes-core.modules
  539. /etc/sysconfig/modules/qubes-misc.modules
  540. %post sysvinit
  541. #echo "--> Turning off unnecessary services..."
  542. # FIXME: perhaps there is more elegant way to do this?
  543. for f in /etc/init.d/*
  544. do
  545. srv=`basename $f`
  546. [ $srv = 'functions' ] && continue
  547. [ $srv = 'killall' ] && continue
  548. [ $srv = 'halt' ] && continue
  549. [ $srv = 'single' ] && continue
  550. [ $srv = 'reboot' ] && continue
  551. [ $srv = 'qubes-gui' ] && continue
  552. chkconfig $srv off
  553. done
  554. #echo "--> Enabling essential services..."
  555. chkconfig rsyslog on
  556. chkconfig haldaemon on
  557. chkconfig messagebus on
  558. for svc in %qubes_services ; do
  559. if [ "$1" = 1 ] ; then
  560. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  561. else
  562. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  563. fi
  564. done
  565. # dropped services
  566. chkconfig qubes-netwatcher off || :
  567. # TODO: make this not display the silly message about security context...
  568. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  569. %preun sysvinit
  570. if [ "$1" = 0 ] ; then
  571. # no more packages left
  572. for svc in %qubes_services ; do
  573. chkconfig --del $svc
  574. done
  575. fi
  576. %package systemd
  577. Summary: Qubes unit files for SystemD init style
  578. License: GPL v2 only
  579. Group: Qubes
  580. Requires: systemd
  581. Requires(post): systemd-units
  582. Requires(preun): systemd-units
  583. Requires(postun): systemd-units
  584. Requires: qubes-core-agent
  585. Provides: qubes-core-agent-init-scripts
  586. Conflicts: qubes-core-agent-sysvinit
  587. Provides: qubes-core-vm-systemd = %{version}-%{release}
  588. Obsoletes: qubes-core-vm-systemd < 4.0.0
  589. %description systemd
  590. The Qubes core startup configuration for SystemD init.
  591. %files systemd
  592. %defattr(-,root,root,-)
  593. /lib/systemd/system/qubes-dvm.service
  594. /lib/systemd/system/qubes-misc-post.service
  595. /lib/systemd/system/qubes-firewall.service
  596. /lib/systemd/system/qubes-mount-dirs.service
  597. /lib/systemd/system/qubes-network.service
  598. /lib/systemd/system/qubes-iptables.service
  599. /lib/systemd/system/qubes-sysinit.service
  600. /lib/systemd/system/qubes-early-vm-config.service
  601. /lib/systemd/system/qubes-update-check.service
  602. /lib/systemd/system/qubes-update-check.timer
  603. /lib/systemd/system/qubes-updates-proxy.service
  604. /lib/systemd/system/qubes-qrexec-agent.service
  605. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  606. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  607. /lib/systemd/system-preset/%qubes_preset_file
  608. /lib/modules-load.d/qubes-core.conf
  609. /lib/modules-load.d/qubes-misc.conf
  610. /usr/lib/qubes/init/qubes-iptables
  611. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  612. /lib/systemd/system/crond.service.d/30_qubes.conf
  613. /lib/systemd/system/cups.service.d/30_qubes.conf
  614. /lib/systemd/system/cups.socket.d/30_qubes.conf
  615. /lib/systemd/system/cups.path.d/30_qubes.conf
  616. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  617. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  618. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  619. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  620. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  621. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  622. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  623. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  624. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  625. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  626. /lib/systemd/system/tor.service.d/30_qubes.conf
  627. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  628. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  629. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  630. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  631. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  632. %post systemd
  633. changed=
  634. %scriptletfuns
  635. if [ $1 -eq 1 ]
  636. then
  637. preset_units %{_presetdir}/%qubes_preset_file initial
  638. changed=true
  639. else
  640. preset_units %{_presetdir}/%qubes_preset_file upgrade
  641. changed=true
  642. # Upgrade path - now qubes-iptables is used instead
  643. for svc in iptables ip6tables
  644. do
  645. if [ -f "$svc".service ]
  646. then
  647. systemctl --no-reload preset "$svc".service
  648. changed=true
  649. fi
  650. done
  651. fi
  652. if [ $1 -eq 1 ]
  653. then
  654. # First install.
  655. # Set default "runlevel".
  656. # FIXME: this ought to be done via kernel command line.
  657. # The fewer deviations of the template from the seed
  658. # image, the better.
  659. rm -f %{_sysconfdir}/systemd/system/default.target
  660. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  661. changed=true
  662. fi
  663. # remove old symlinks
  664. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  665. then
  666. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  667. changed=true
  668. fi
  669. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  670. then
  671. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  672. changed=true
  673. fi
  674. if [ "x$changed" != "x" ]
  675. then
  676. systemctl daemon-reload
  677. fi
  678. %preun systemd
  679. if [ $1 -eq 0 ] ; then
  680. # Run this only during uninstall.
  681. # Save the preset file to later use it to re-preset services there
  682. # once the Qubes OS preset file is removed.
  683. mkdir -p %{_rundir}/qubes-uninstall
  684. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  685. fi
  686. %postun systemd
  687. changed=
  688. %scriptletfuns
  689. if [ -d %{_rundir}/qubes-uninstall ]
  690. then
  691. # We have a saved preset file (or more).
  692. # Re-preset the units mentioned there.
  693. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  694. rm -rf %{_rundir}/qubes-uninstall
  695. changed=true
  696. fi
  697. if [ "x$changed" != "x" ]
  698. then
  699. systemctl daemon-reload
  700. fi