core-vm.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. %if %{fedora} < 22
  34. Requires: yum-plugin-post-transaction-actions
  35. %endif
  36. Requires: NetworkManager >= 0.8.1-1
  37. %if %{fedora} >= 18
  38. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  39. Conflicts: firewalld
  40. %endif
  41. Requires: xdg-utils
  42. Requires: ethtool
  43. Requires: tinyproxy
  44. Requires: ntpdate
  45. Requires: net-tools
  46. Requires: nautilus-python
  47. Requires: qubes-utils >= 3.1.3
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. Requires: dbus-python
  52. # for qubes-session-autostart, xdg-icon
  53. Requires: pyxdg
  54. %if %{fedora} >= 20
  55. # gpk-update-viewer required by qubes-manager
  56. Requires: gnome-packagekit-updater
  57. %endif
  58. Requires: ImageMagick
  59. Requires: librsvg2-tools
  60. Requires: fakeroot
  61. Requires: desktop-notification-daemon
  62. # to show/hide nm-applet
  63. Requires: dconf
  64. Requires: pygtk2
  65. Requires: zenity
  66. Requires: qubes-libvchan
  67. Requires: qubes-db-vm
  68. %if 0%{fedora} >= 23
  69. Requires: python3-dnf-plugins-qubes-hooks
  70. %else
  71. Requires: python2-dnf-plugins-qubes-hooks
  72. %endif
  73. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  74. Obsoletes: qubes-upgrade-vm < 3.1
  75. BuildRequires: xen-devel
  76. BuildRequires: libX11-devel
  77. BuildRequires: qubes-utils-devel >= 3.1.3
  78. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  79. %package -n python2-dnf-plugins-qubes-hooks
  80. Summary: DNF plugin for Qubes specific post-installation actions
  81. BuildRequires: python2-devel
  82. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  83. %description -n python2-dnf-plugins-qubes-hooks
  84. DNF plugin for Qubes specific post-installation actions:
  85. * notify dom0 that updates were installed
  86. * refresh applications shortcut list
  87. %package -n python3-dnf-plugins-qubes-hooks
  88. Summary: DNF plugin for Qubes specific post-installation actions
  89. BuildRequires: python3-devel
  90. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  91. %description -n python3-dnf-plugins-qubes-hooks
  92. DNF plugin for Qubes specific post-installation actions:
  93. * notify dom0 that updates were installed
  94. * refresh applications shortcut list
  95. %define _builddir %(pwd)
  96. %define kde_service_dir /usr/share/kde4/services
  97. %description
  98. The Qubes core files for installation inside a Qubes VM.
  99. %prep
  100. # we operate on the current directory, so no need to unpack anything
  101. # symlink is to generate useful debuginfo packages
  102. rm -f %{name}-%{version}
  103. ln -sf . %{name}-%{version}
  104. %setup -T -D
  105. %build
  106. for dir in qubes-rpc qrexec misc; do
  107. (cd $dir; make)
  108. done
  109. %pre
  110. # Make sure there is a qubes group
  111. groupadd --force --system --gid 98 qubes
  112. id -u 'user' >/dev/null 2>&1 || {
  113. useradd --user-group --create-home --shell /bin/bash user
  114. }
  115. usermod -a --groups qubes user
  116. if [ "$1" != 1 ] ; then
  117. # do this whole %%pre thing only when updating for the first time...
  118. exit 0
  119. fi
  120. mkdir -p /var/lib/qubes
  121. if [ -e /etc/fstab ] ; then
  122. mv /etc/fstab /var/lib/qubes/fstab.orig
  123. fi
  124. usermod -p '' root
  125. usermod -L user
  126. %install
  127. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  128. make install-vm DESTDIR=$RPM_BUILD_ROOT
  129. %if %{fedora} >= 22
  130. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  131. %endif
  132. %triggerin -- initscripts
  133. if [ -e /etc/init/serial.conf ]; then
  134. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  135. fi
  136. %post
  137. # disable some Upstart services
  138. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  139. if [ -e /etc/init/$F.conf ]; then
  140. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  141. fi
  142. done
  143. # Create NetworkManager configuration if we do not have it
  144. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  145. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  146. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  147. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  148. fi
  149. /usr/lib/qubes/qubes-fix-nm-conf.sh
  150. # Remove ip_forward setting from sysctl, so NM will not reset it
  151. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  152. # Remove old firmware updates link
  153. if [ -L /lib/firmware/updates ]; then
  154. rm -f /lib/firmware/updates
  155. fi
  156. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  157. echo >> /etc/yum.conf
  158. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  159. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  160. fi
  161. # And actually setup the proxy usage in package managers
  162. /usr/lib/qubes/update-proxy-configs
  163. # Location of files which contains list of protected files
  164. mkdir -p /etc/qubes/protected-files.d
  165. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  166. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  167. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  168. if ! grep -q localhost /etc/hosts; then
  169. cat <<EOF > /etc/hosts
  170. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  171. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  172. EOF
  173. fi
  174. fi
  175. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  176. # in the form expected by qubes-sysinit.sh
  177. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  178. for ip in '127\.0\.0\.1' '::1'; do
  179. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  180. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  181. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  182. else
  183. echo "${ip} `hostname`" >> /etc/hosts
  184. fi
  185. done
  186. fi
  187. %if %{fedora} >= 20
  188. # Make sure there is a default locale set so gnome-terminal will start
  189. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  190. touch /etc/locale.conf
  191. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  192. fi
  193. # ... and make sure it is really generated
  194. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  195. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  196. base=`echo "$current_locale" | cut -f 1 -d .`
  197. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  198. [ -n "$charmap" ] && charmap="-f $charmap"
  199. localedef -i $base $charmap $current_locale
  200. fi
  201. %endif
  202. if [ "$1" != 1 ] ; then
  203. # do the rest of %%post thing only when updating for the first time...
  204. exit 0
  205. fi
  206. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  207. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  208. fi
  209. # Remove most of the udev scripts to speed up the VM boot time
  210. # Just leave the xen* scripts, that are needed if this VM was
  211. # ever used as a net backend (e.g. as a VPN domain in the future)
  212. #echo "--> Removing unnecessary udev scripts..."
  213. mkdir -p /var/lib/qubes/removed-udev-scripts
  214. for f in /etc/udev/rules.d/*
  215. do
  216. if [ $(basename $f) == "xen-backend.rules" ] ; then
  217. continue
  218. fi
  219. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  220. continue
  221. fi
  222. if echo $f | grep -q qubes; then
  223. continue
  224. fi
  225. mv $f /var/lib/qubes/removed-udev-scripts/
  226. done
  227. mkdir -p /rw
  228. #rm -f /etc/mtab
  229. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  230. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  231. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  232. %triggerin -- notification-daemon
  233. # Enable autostart of notification-daemon when installed
  234. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  235. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  236. fi
  237. exit 0
  238. %triggerin -- selinux-policy
  239. #echo "--> Disabling SELinux..."
  240. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  241. mv /etc/selinux/config.processed /etc/selinux/config
  242. setenforce 0 2>/dev/null
  243. exit 0
  244. %preun
  245. if [ "$1" = 0 ] ; then
  246. # no more packages left
  247. if [ -e /var/lib/qubes/fstab.orig ] ; then
  248. mv /var/lib/qubes/fstab.orig /etc/fstab
  249. fi
  250. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  251. if [ -e /var/lib/qubes/serial.orig ] ; then
  252. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  253. fi
  254. fi
  255. %postun
  256. if [ $1 -eq 0 ] ; then
  257. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  258. if [ -L /lib/firmware/updates ]; then
  259. rm /lib/firmware/updates
  260. fi
  261. rm -rf /var/lib/qubes/xdg
  262. fi
  263. %posttrans
  264. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  265. %clean
  266. rm -rf $RPM_BUILD_ROOT
  267. rm -f %{name}-%{version}
  268. %files
  269. %defattr(-,root,root,-)
  270. %dir /var/lib/qubes
  271. %dir /var/run/qubes
  272. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  273. %{kde_service_dir}/qvm-copy.desktop
  274. %{kde_service_dir}/qvm-move.desktop
  275. %{kde_service_dir}/qvm-dvm.desktop
  276. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  277. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  278. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  279. /etc/dispvm-dotfiles.tbz
  280. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  281. /etc/fstab
  282. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  283. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  284. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  285. %dir /etc/qubes-rpc
  286. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  287. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  288. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  289. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  290. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  291. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  292. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  293. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  294. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  295. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  296. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  297. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  298. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  299. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  300. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  301. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  302. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  303. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  304. %dir /etc/qubes/autostart
  305. /etc/qubes/autostart/README.txt
  306. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  307. %dir /etc/qubes/suspend-pre.d
  308. /etc/qubes/suspend-pre.d/README
  309. %dir /etc/qubes/suspend-post.d
  310. /etc/qubes/suspend-post.d/README
  311. %config(noreplace) /etc/sudoers.d/qubes
  312. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  313. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  314. %config(noreplace) /etc/qubes/iptables.rules
  315. %config(noreplace) /etc/qubes/ip6tables.rules
  316. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  317. %config(noreplace) /etc/tinyproxy/updates-blacklist
  318. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  319. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  320. %config(noreplace) /etc/qubes-suspend-module-blacklist
  321. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  322. /etc/xen/scripts/vif-route-qubes
  323. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  324. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  325. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  326. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  327. %if %{fedora} < 22
  328. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  329. %endif
  330. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  331. /usr/sbin/qubes-serial-login
  332. /usr/bin/qvm-copy-to-vm
  333. /usr/bin/qvm-move-to-vm
  334. /usr/bin/qvm-open-in-dvm
  335. /usr/bin/qvm-open-in-vm
  336. /usr/bin/qvm-run
  337. /usr/bin/qvm-mru-entry
  338. /usr/bin/xenstore-watch-qubes
  339. /usr/bin/qubes-desktop-run
  340. /usr/bin/qubes-open
  341. /usr/bin/qrexec-fork-server
  342. /usr/bin/qrexec-client-vm
  343. /usr/bin/qubes-session-autostart
  344. %dir /usr/lib/qubes
  345. /usr/lib/qubes/vusb-ctl.py*
  346. /usr/lib/qubes/dispvm-prerun.sh
  347. /usr/lib/qubes/sync-ntp-clock
  348. /usr/lib/qubes/prepare-suspend
  349. /usr/lib/qubes/network-manager-prepare-conf-dir
  350. /usr/lib/qubes/show-hide-nm-applet.sh
  351. /usr/lib/qubes/qrexec-agent
  352. /usr/lib/qubes/qrexec-client-vm
  353. /usr/lib/qubes/qrexec_client_vm
  354. /usr/lib/qubes/qubes-rpc-multiplexer
  355. /usr/lib/qubes/qfile-agent
  356. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  357. /usr/lib/qubes/qopen-in-vm
  358. /usr/lib/qubes/qrun-in-vm
  359. /usr/lib/qubes/qubes-download-dom0-updates.sh
  360. /usr/lib/qubes/qubes-fix-nm-conf.sh
  361. /usr/lib/qubes/qubes-setup-dnat-to-ns
  362. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  363. /usr/lib/qubes/qvm-copy-to-vm.gnome
  364. /usr/lib/qubes/qvm-copy-to-vm.kde
  365. /usr/lib/qubes/qvm-move-to-vm.gnome
  366. /usr/lib/qubes/qvm-move-to-vm.kde
  367. /usr/lib/qubes/setup-ip
  368. /usr/lib/qubes/tar2qfile
  369. /usr/lib/qubes/vm-file-editor
  370. /usr/lib/qubes/wrap-in-html-if-url.sh
  371. /usr/lib/qubes/iptables-updates-proxy
  372. /usr/lib/qubes/close-window
  373. /usr/lib/qubes/xdg-icon
  374. /usr/lib/qubes/update-proxy-configs
  375. /usr/lib/qubes/upgrades-installed-check
  376. /usr/lib/qubes/upgrades-status-notify
  377. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  378. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  379. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  380. /usr/sbin/qubes-firewall
  381. /usr/sbin/qubes-netwatcher
  382. /usr/share/qubes/serial.conf
  383. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  384. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  385. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  386. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  387. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  388. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  389. /usr/share/qubes/mime-override/globs
  390. %dir /home_volatile
  391. %attr(700,user,user) /home_volatile/user
  392. %dir /mnt/removable
  393. %dir /rw
  394. %files -n python2-dnf-plugins-qubes-hooks
  395. %{python2_sitelib}/dnf-plugins/*
  396. %files -n python3-dnf-plugins-qubes-hooks
  397. %{python3_sitelib}/dnf-plugins/*
  398. %package sysvinit
  399. Summary: Qubes unit files for SysV init style or upstart
  400. License: GPL v2 only
  401. Group: Qubes
  402. Requires: upstart
  403. Requires: qubes-core-vm
  404. Provides: qubes-core-vm-init-scripts
  405. Conflicts: qubes-core-vm-systemd
  406. %description sysvinit
  407. The Qubes core startup configuration for SysV init (or upstart).
  408. %files sysvinit
  409. /etc/init.d/qubes-core
  410. /etc/init.d/qubes-core-appvm
  411. /etc/init.d/qubes-core-netvm
  412. /etc/init.d/qubes-firewall
  413. /etc/init.d/qubes-netwatcher
  414. /etc/init.d/qubes-iptables
  415. /etc/init.d/qubes-updates-proxy
  416. /etc/init.d/qubes-qrexec-agent
  417. /etc/sysconfig/modules/qubes-core.modules
  418. /etc/sysconfig/modules/qubes-misc.modules
  419. %post sysvinit
  420. #echo "--> Turning off unnecessary services..."
  421. # FIXME: perhaps there is more elegant way to do this?
  422. for f in /etc/init.d/*
  423. do
  424. srv=`basename $f`
  425. [ $srv = 'functions' ] && continue
  426. [ $srv = 'killall' ] && continue
  427. [ $srv = 'halt' ] && continue
  428. [ $srv = 'single' ] && continue
  429. [ $srv = 'reboot' ] && continue
  430. [ $srv = 'qubes-gui' ] && continue
  431. chkconfig $srv off
  432. done
  433. #echo "--> Enabling essential services..."
  434. chkconfig rsyslog on
  435. chkconfig haldaemon on
  436. chkconfig messagebus on
  437. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  438. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  439. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  440. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  441. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  442. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  443. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  444. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  445. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  446. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  447. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  448. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  449. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  450. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  451. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  452. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  453. # TODO: make this not display the silly message about security context...
  454. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  455. %preun sysvinit
  456. if [ "$1" = 0 ] ; then
  457. # no more packages left
  458. chkconfig qubes-core off
  459. chkconfig qubes-core-netvm off
  460. chkconfig qubes-core-appvm off
  461. chkconfig qubes-firewall off
  462. chkconfig qubes-netwatcher off
  463. chkconfig qubes-updates-proxy off
  464. chkconfig qubes-qrexec-agent off
  465. fi
  466. %package systemd
  467. Summary: Qubes unit files for SystemD init style
  468. License: GPL v2 only
  469. Group: Qubes
  470. Requires: systemd
  471. Requires(post): systemd-units
  472. Requires(preun): systemd-units
  473. Requires(postun): systemd-units
  474. Requires: qubes-core-vm
  475. Provides: qubes-core-vm-init-scripts
  476. Conflicts: qubes-core-vm-sysvinit
  477. %description systemd
  478. The Qubes core startup configuration for SystemD init.
  479. %files systemd
  480. %defattr(-,root,root,-)
  481. /lib/systemd/system/qubes-dvm.service
  482. /lib/systemd/system/qubes-misc-post.service
  483. /lib/systemd/system/qubes-firewall.service
  484. /lib/systemd/system/qubes-mount-dirs.service
  485. /lib/systemd/system/qubes-netwatcher.service
  486. /lib/systemd/system/qubes-network.service
  487. /lib/systemd/system/qubes-iptables.service
  488. /lib/systemd/system/qubes-sysinit.service
  489. /lib/systemd/system/qubes-update-check.service
  490. /lib/systemd/system/qubes-update-check.timer
  491. /lib/systemd/system/qubes-updates-proxy.service
  492. /lib/systemd/system/qubes-qrexec-agent.service
  493. /lib/systemd/system/qubes-random-seed.service
  494. /lib/systemd/system-preset/75-qubes-vm.preset
  495. /lib/modules-load.d/qubes-core.conf
  496. /lib/modules-load.d/qubes-misc.conf
  497. %dir /usr/lib/qubes/init
  498. /usr/lib/qubes/init/prepare-dvm.sh
  499. /usr/lib/qubes/init/network-proxy-setup.sh
  500. /usr/lib/qubes/init/qubes-iptables
  501. /usr/lib/qubes/init/misc-post.sh
  502. /usr/lib/qubes/init/misc-post-stop.sh
  503. /usr/lib/qubes/init/mount-dirs.sh
  504. /usr/lib/qubes/init/qubes-random-seed.sh
  505. /usr/lib/qubes/init/qubes-sysinit.sh
  506. /usr/lib/qubes/init/bind-dirs.sh
  507. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  508. /lib/systemd/system/crond.service.d/30_qubes.conf
  509. /lib/systemd/system/cups.service.d/30_qubes.conf
  510. /lib/systemd/system/cups.socket.d/30_qubes.conf
  511. /lib/systemd/system/cups.path.d/30_qubes.conf
  512. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  513. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  514. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  515. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  516. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  517. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  518. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  519. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  520. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  521. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  522. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  523. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  524. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  525. %post systemd
  526. PRESET_FAILED=0
  527. if [ $1 -eq 1 ]; then
  528. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  529. else
  530. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-dirs"
  531. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  532. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  533. services="$services qubes-random-seed"
  534. for srv in $services; do
  535. /bin/systemctl --no-reload preset $srv.service
  536. done
  537. /bin/systemctl --no-reload preset qubes-update-check.timer
  538. # Upgrade path - now qubes-iptables is used instead
  539. /bin/systemctl --no-reload preset iptables.service
  540. /bin/systemctl --no-reload preset ip6tables.service
  541. fi
  542. # Set default "runlevel"
  543. rm -f /etc/systemd/system/default.target
  544. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  545. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  546. case "$action" in
  547. (disable)
  548. if [ -f /lib/systemd/system/$unit_name ]; then
  549. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  550. # forcibly disable
  551. ln -sf /dev/null /etc/systemd/system/$unit_name
  552. fi
  553. fi
  554. ;;
  555. *)
  556. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  557. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  558. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  559. fi
  560. ;;
  561. esac
  562. done
  563. /bin/systemctl daemon-reload
  564. exit 0
  565. %postun systemd
  566. #Do not run this part on upgrades
  567. if [ "$1" != 0 ] ; then
  568. exit 0
  569. fi
  570. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-netwatcher qubes-network qubes-qrexec-agent; do
  571. /bin/systemctl disable $srv.service
  572. do