rules 526 B

1234567891011121314151617181920212223242526
  1. #!/usr/bin/make -f
  2. # -*- makefile -*-
  3. # Uncomment this to turn on verbose mode.
  4. #export DH_VERBOSE=1
  5. DPKG_EXPORT_BUILDFLAGS = 1
  6. include /usr/share/dpkg/default.mk
  7. export DESTDIR=$(shell pwd)/debian/qubes-core-agent
  8. %:
  9. dh $@ --with systemd --with autotools-dev
  10. override_dh_auto_build:
  11. make all
  12. override_dh_auto_install:
  13. make install-common install-deb install-systemd
  14. make -C qrexec install
  15. override_dh_fixperms:
  16. dh_fixperms -a -Xqfile-unpacker
  17. override_dh_systemd_start:
  18. dh_systemd_start --no-restart-on-upgrade