core-vm.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. %if %{fedora} < 22
  34. Requires: yum-plugin-post-transaction-actions
  35. %endif
  36. Requires: NetworkManager >= 0.8.1-1
  37. %if %{fedora} >= 18
  38. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  39. Conflicts: firewalld
  40. %endif
  41. Requires: /usr/bin/mimeopen
  42. Requires: ethtool
  43. Requires: tinyproxy
  44. Requires: ntpdate
  45. Requires: net-tools
  46. Requires: nautilus-python
  47. Requires: qubes-utils >= 3.1.3
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. Requires: dbus-python
  52. # for qubes-session-autostart, xdg-icon
  53. Requires: pyxdg
  54. %if %{fedora} >= 20
  55. # gpk-update-viewer required by qubes-manager
  56. Requires: gnome-packagekit-updater
  57. %endif
  58. Requires: ImageMagick
  59. Requires: librsvg2-tools
  60. Requires: fakeroot
  61. Requires: desktop-notification-daemon
  62. # to show/hide nm-applet
  63. Requires: dconf
  64. Requires: pygtk2
  65. Requires: zenity
  66. Requires: qubes-libvchan
  67. Requires: qubes-db-vm
  68. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  69. Obsoletes: qubes-upgrade-vm < 3.1
  70. BuildRequires: xen-devel
  71. BuildRequires: libX11-devel
  72. BuildRequires: qubes-utils-devel >= 3.1.3
  73. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  74. %define _builddir %(pwd)
  75. %define kde_service_dir /usr/share/kde4/services
  76. %description
  77. The Qubes core files for installation inside a Qubes VM.
  78. %prep
  79. # we operate on the current directory, so no need to unpack anything
  80. # symlink is to generate useful debuginfo packages
  81. rm -f %{name}-%{version}
  82. ln -sf . %{name}-%{version}
  83. %setup -T -D
  84. %build
  85. for dir in qubes-rpc qrexec misc; do
  86. (cd $dir; make)
  87. done
  88. %pre
  89. # Make sure there is a qubes group
  90. groupadd --force --system --gid 98 qubes
  91. id -u 'user' >/dev/null 2>&1 || {
  92. useradd --user-group --create-home --shell /bin/bash user
  93. }
  94. usermod -a --groups qubes user
  95. if [ "$1" != 1 ] ; then
  96. # do this whole %%pre thing only when updating for the first time...
  97. exit 0
  98. fi
  99. mkdir -p /var/lib/qubes
  100. if [ -e /etc/fstab ] ; then
  101. mv /etc/fstab /var/lib/qubes/fstab.orig
  102. fi
  103. usermod -p '' root
  104. usermod -L user
  105. %install
  106. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  107. make install-vm DESTDIR=$RPM_BUILD_ROOT
  108. %if %{fedora} >= 22
  109. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  110. %endif
  111. %triggerin -- initscripts
  112. if [ -e /etc/init/serial.conf ]; then
  113. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  114. fi
  115. %post
  116. # disable some Upstart services
  117. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  118. if [ -e /etc/init/$F.conf ]; then
  119. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  120. fi
  121. done
  122. # Remove ip_forward setting from sysctl, so NM will not reset it
  123. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  124. # Remove old firmware updates link
  125. if [ -L /lib/firmware/updates ]; then
  126. rm -f /lib/firmware/updates
  127. fi
  128. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  129. echo >> /etc/yum.conf
  130. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  131. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  132. fi
  133. # And actually setup the proxy usage in package managers
  134. /usr/lib/qubes/update-proxy-configs
  135. # Location of files which contains list of protected files
  136. mkdir -p /etc/qubes/protected-files.d
  137. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  138. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  139. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  140. if ! grep -q localhost /etc/hosts; then
  141. cat <<EOF > /etc/hosts
  142. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  143. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  144. EOF
  145. fi
  146. fi
  147. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  148. # in the form expected by qubes-sysinit.sh
  149. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  150. for ip in '127\.0\.0\.1' '::1'; do
  151. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  152. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  153. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  154. else
  155. echo "${ip} `hostname`" >> /etc/hosts
  156. fi
  157. done
  158. fi
  159. %if %{fedora} >= 20
  160. # Make sure there is a default locale set so gnome-terminal will start
  161. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  162. touch /etc/locale.conf
  163. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  164. fi
  165. # ... and make sure it is really generated
  166. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  167. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  168. base=`echo "$current_locale" | cut -f 1 -d .`
  169. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  170. [ -n "$charmap" ] && charmap="-f $charmap"
  171. localedef -i $base $charmap $current_locale
  172. fi
  173. %endif
  174. if [ "$1" != 1 ] ; then
  175. # do the rest of %%post thing only when updating for the first time...
  176. exit 0
  177. fi
  178. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  179. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  180. fi
  181. # Remove most of the udev scripts to speed up the VM boot time
  182. # Just leave the xen* scripts, that are needed if this VM was
  183. # ever used as a net backend (e.g. as a VPN domain in the future)
  184. #echo "--> Removing unnecessary udev scripts..."
  185. mkdir -p /var/lib/qubes/removed-udev-scripts
  186. for f in /etc/udev/rules.d/*
  187. do
  188. if [ $(basename $f) == "xen-backend.rules" ] ; then
  189. continue
  190. fi
  191. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  192. continue
  193. fi
  194. if echo $f | grep -q qubes; then
  195. continue
  196. fi
  197. mv $f /var/lib/qubes/removed-udev-scripts/
  198. done
  199. mkdir -p /rw
  200. #rm -f /etc/mtab
  201. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  202. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  203. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  204. %triggerin -- notification-daemon
  205. # Enable autostart of notification-daemon when installed
  206. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  207. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  208. fi
  209. exit 0
  210. %triggerin -- selinux-policy
  211. #echo "--> Disabling SELinux..."
  212. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  213. mv /etc/selinux/config.processed /etc/selinux/config
  214. setenforce 0 2>/dev/null
  215. exit 0
  216. %preun
  217. if [ "$1" = 0 ] ; then
  218. # no more packages left
  219. if [ -e /var/lib/qubes/fstab.orig ] ; then
  220. mv /var/lib/qubes/fstab.orig /etc/fstab
  221. fi
  222. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  223. if [ -e /var/lib/qubes/serial.orig ] ; then
  224. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  225. fi
  226. fi
  227. %postun
  228. if [ $1 -eq 0 ] ; then
  229. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  230. if [ -L /lib/firmware/updates ]; then
  231. rm /lib/firmware/updates
  232. fi
  233. rm -rf /var/lib/qubes/xdg
  234. fi
  235. %posttrans
  236. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  237. %clean
  238. rm -rf $RPM_BUILD_ROOT
  239. rm -f %{name}-%{version}
  240. %files
  241. %defattr(-,root,root,-)
  242. %dir /var/lib/qubes
  243. %dir /var/run/qubes
  244. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  245. %{kde_service_dir}/qvm-copy.desktop
  246. %{kde_service_dir}/qvm-move.desktop
  247. %{kde_service_dir}/qvm-dvm.desktop
  248. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  249. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  250. %config /etc/NetworkManager/conf.d/30-qubes.conf
  251. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  252. /etc/dispvm-dotfiles.tbz
  253. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  254. /etc/fstab
  255. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  256. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  257. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  258. %dir /etc/qubes-rpc
  259. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  260. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  261. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  262. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  263. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  264. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  265. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  266. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  267. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  268. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  269. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  270. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  271. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  272. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  273. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  274. %dir /etc/qubes/autostart
  275. /etc/qubes/autostart/README.txt
  276. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  277. %config(noreplace) /etc/sudoers.d/qubes
  278. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  279. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  280. %config(noreplace) /etc/qubes/iptables.rules
  281. %config(noreplace) /etc/qubes/ip6tables.rules
  282. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  283. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  284. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  285. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  286. /etc/xen/scripts/vif-route-qubes
  287. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  288. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  289. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  290. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  291. %if %{fedora} < 22
  292. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  293. %endif
  294. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  295. /usr/sbin/qubes-serial-login
  296. /usr/bin/qvm-copy-to-vm
  297. /usr/bin/qvm-move-to-vm
  298. /usr/bin/qvm-open-in-dvm
  299. /usr/bin/qvm-open-in-vm
  300. /usr/bin/qvm-run
  301. /usr/bin/qvm-mru-entry
  302. /usr/bin/xenstore-watch-qubes
  303. /usr/bin/qubes-desktop-run
  304. /usr/bin/qrexec-fork-server
  305. /usr/bin/qrexec-client-vm
  306. /usr/bin/qubes-session-autostart
  307. %dir /usr/lib/qubes
  308. /usr/lib/qubes/vusb-ctl.py*
  309. /usr/lib/qubes/dispvm-prerun.sh
  310. /usr/lib/qubes/sync-ntp-clock
  311. /usr/lib/qubes/prepare-suspend
  312. /usr/lib/qubes/network-manager-prepare-conf-dir
  313. /usr/lib/qubes/show-hide-nm-applet.sh
  314. /usr/lib/qubes/qrexec-agent
  315. /usr/lib/qubes/qrexec-client-vm
  316. /usr/lib/qubes/qrexec_client_vm
  317. /usr/lib/qubes/qubes-rpc-multiplexer
  318. /usr/lib/qubes/qfile-agent
  319. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  320. /usr/lib/qubes/qopen-in-vm
  321. /usr/lib/qubes/qrun-in-vm
  322. /usr/lib/qubes/qubes-download-dom0-updates.sh
  323. /usr/lib/qubes/qubes-setup-dnat-to-ns
  324. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  325. /usr/lib/qubes/qvm-copy-to-vm.gnome
  326. /usr/lib/qubes/qvm-copy-to-vm.kde
  327. /usr/lib/qubes/qvm-move-to-vm.gnome
  328. /usr/lib/qubes/qvm-move-to-vm.kde
  329. /usr/lib/qubes/setup-ip
  330. /usr/lib/qubes/tar2qfile
  331. /usr/lib/qubes/vm-file-editor
  332. /usr/lib/qubes/wrap-in-html-if-url.sh
  333. /usr/lib/qubes/iptables-updates-proxy
  334. /usr/lib/qubes/close-window
  335. /usr/lib/qubes/xdg-icon
  336. /usr/lib/qubes/update-proxy-configs
  337. /usr/lib/qubes/upgrades-installed-check
  338. /usr/lib/qubes/upgrades-status-notify
  339. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  340. /usr/lib/python2.7/site-packages/dnf-plugins/qubes-hooks.py*
  341. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  342. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  343. /usr/sbin/qubes-firewall
  344. /usr/sbin/qubes-netwatcher
  345. /usr/share/qubes/serial.conf
  346. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  347. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  348. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  349. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  350. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  351. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  352. /usr/share/qubes/mime-override/globs
  353. %dir /home_volatile
  354. %attr(700,user,user) /home_volatile/user
  355. %dir /mnt/removable
  356. %dir /rw
  357. %package sysvinit
  358. Summary: Qubes unit files for SysV init style or upstart
  359. License: GPL v2 only
  360. Group: Qubes
  361. Requires: upstart
  362. Requires: qubes-core-vm
  363. Provides: qubes-core-vm-init-scripts
  364. Conflicts: qubes-core-vm-systemd
  365. %description sysvinit
  366. The Qubes core startup configuration for SysV init (or upstart).
  367. %files sysvinit
  368. /etc/init.d/qubes-core
  369. /etc/init.d/qubes-core-appvm
  370. /etc/init.d/qubes-core-netvm
  371. /etc/init.d/qubes-firewall
  372. /etc/init.d/qubes-netwatcher
  373. /etc/init.d/qubes-iptables
  374. /etc/init.d/qubes-updates-proxy
  375. /etc/init.d/qubes-qrexec-agent
  376. /etc/sysconfig/modules/qubes-core.modules
  377. /etc/sysconfig/modules/qubes-misc.modules
  378. %post sysvinit
  379. #echo "--> Turning off unnecessary services..."
  380. # FIXME: perhaps there is more elegant way to do this?
  381. for f in /etc/init.d/*
  382. do
  383. srv=`basename $f`
  384. [ $srv = 'functions' ] && continue
  385. [ $srv = 'killall' ] && continue
  386. [ $srv = 'halt' ] && continue
  387. [ $srv = 'single' ] && continue
  388. [ $srv = 'reboot' ] && continue
  389. [ $srv = 'qubes-gui' ] && continue
  390. chkconfig $srv off
  391. done
  392. #echo "--> Enabling essential services..."
  393. chkconfig rsyslog on
  394. chkconfig haldaemon on
  395. chkconfig messagebus on
  396. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  397. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  398. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  399. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  400. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  401. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  402. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  403. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  404. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  405. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  406. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  407. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  408. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  409. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  410. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  411. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  412. # TODO: make this not display the silly message about security context...
  413. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  414. %preun sysvinit
  415. if [ "$1" = 0 ] ; then
  416. # no more packages left
  417. chkconfig qubes-core off
  418. chkconfig qubes-core-netvm off
  419. chkconfig qubes-core-appvm off
  420. chkconfig qubes-firewall off
  421. chkconfig qubes-netwatcher off
  422. chkconfig qubes-updates-proxy off
  423. chkconfig qubes-qrexec-agent off
  424. fi
  425. %package systemd
  426. Summary: Qubes unit files for SystemD init style
  427. License: GPL v2 only
  428. Group: Qubes
  429. Requires: systemd
  430. Requires(post): systemd-units
  431. Requires(preun): systemd-units
  432. Requires(postun): systemd-units
  433. Requires: qubes-core-vm
  434. Provides: qubes-core-vm-init-scripts
  435. Conflicts: qubes-core-vm-sysvinit
  436. %description systemd
  437. The Qubes core startup configuration for SystemD init.
  438. %files systemd
  439. %defattr(-,root,root,-)
  440. /lib/systemd/system/qubes-dvm.service
  441. /lib/systemd/system/qubes-misc-post.service
  442. /lib/systemd/system/qubes-firewall.service
  443. /lib/systemd/system/qubes-mount-dirs.service
  444. /lib/systemd/system/qubes-netwatcher.service
  445. /lib/systemd/system/qubes-network.service
  446. /lib/systemd/system/qubes-iptables.service
  447. /lib/systemd/system/qubes-sysinit.service
  448. /lib/systemd/system/qubes-update-check.service
  449. /lib/systemd/system/qubes-update-check.timer
  450. /lib/systemd/system/qubes-updates-proxy.service
  451. /lib/systemd/system/qubes-qrexec-agent.service
  452. /lib/systemd/system/qubes-random-seed.service
  453. /lib/systemd/system-preset/75-qubes-vm.preset
  454. /lib/modules-load.d/qubes-core.conf
  455. /lib/modules-load.d/qubes-misc.conf
  456. %dir /usr/lib/qubes/init
  457. /usr/lib/qubes/init/prepare-dvm.sh
  458. /usr/lib/qubes/init/network-proxy-setup.sh
  459. /usr/lib/qubes/init/qubes-iptables
  460. /usr/lib/qubes/init/misc-post.sh
  461. /usr/lib/qubes/init/misc-post-stop.sh
  462. /usr/lib/qubes/init/mount-dirs.sh
  463. /usr/lib/qubes/init/qubes-random-seed.sh
  464. /usr/lib/qubes/init/qubes-sysinit.sh
  465. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  466. /lib/systemd/system/crond.service.d/30_qubes.conf
  467. /lib/systemd/system/cups.service.d/30_qubes.conf
  468. /lib/systemd/system/cups.socket.d/30_qubes.conf
  469. /lib/systemd/system/cups.path.d/30_qubes.conf
  470. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  471. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  472. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  473. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  474. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  475. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  476. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  477. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  478. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  479. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  480. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  481. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  482. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  483. %post systemd
  484. PRESET_FAILED=0
  485. if [ $1 -eq 1 ]; then
  486. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  487. else
  488. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-dirs"
  489. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  490. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  491. services="$services qubes-random-seed"
  492. for srv in $services; do
  493. /bin/systemctl --no-reload preset $srv.service
  494. done
  495. /bin/systemctl --no-reload preset qubes-update-check.timer
  496. # Upgrade path - now qubes-iptables is used instead
  497. /bin/systemctl --no-reload preset iptables.service
  498. /bin/systemctl --no-reload preset ip6tables.service
  499. fi
  500. # Set default "runlevel"
  501. rm -f /etc/systemd/system/default.target
  502. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  503. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  504. case "$action" in
  505. (disable)
  506. if [ -f /lib/systemd/system/$unit_name ]; then
  507. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  508. # forcibly disable
  509. ln -sf /dev/null /etc/systemd/system/$unit_name
  510. fi
  511. fi
  512. ;;
  513. *)
  514. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  515. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  516. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  517. fi
  518. ;;
  519. esac
  520. done
  521. /bin/systemctl daemon-reload
  522. exit 0
  523. %postun systemd
  524. #Do not run this part on upgrades
  525. if [ "$1" != 0 ] ; then
  526. exit 0
  527. fi
  528. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-netwatcher qubes-network qubes-qrexec-agent; do
  529. /bin/systemctl disable $srv.service
  530. do