core-vm.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. %if %{fedora} < 22
  34. Requires: yum-plugin-post-transaction-actions
  35. %endif
  36. Requires: NetworkManager >= 0.8.1-1
  37. %if %{fedora} >= 18
  38. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  39. Conflicts: firewalld
  40. %endif
  41. Requires: /usr/bin/mimeopen
  42. Requires: ethtool
  43. Requires: tinyproxy
  44. Requires: ntpdate
  45. Requires: net-tools
  46. Requires: nautilus-python
  47. Requires: qubes-utils >= 3.1.2
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. Requires: dbus-python
  52. # for qubes-session-autostart, xdg-icon
  53. Requires: pyxdg
  54. %if %{fedora} >= 20
  55. # gpk-update-viewer required by qubes-manager
  56. Requires: gnome-packagekit-updater
  57. %endif
  58. Requires: ImageMagick
  59. Requires: librsvg2-tools
  60. Requires: fakeroot
  61. Requires: desktop-notification-daemon
  62. # to show/hide nm-applet
  63. Requires: dconf
  64. Requires: pygtk2
  65. Requires: zenity
  66. Requires: qubes-libvchan
  67. Requires: qubes-db-vm
  68. Provides: qubes-core-vm
  69. Obsoletes: qubes-core-commonvm
  70. Obsoletes: qubes-core-appvm
  71. Obsoletes: qubes-core-netvm
  72. Obsoletes: qubes-core-proxyvm
  73. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  74. Obsoletes: qubes-upgrade-vm < 3.1
  75. BuildRequires: xen-devel
  76. BuildRequires: libX11-devel
  77. BuildRequires: qubes-utils-devel >= 3.1.2
  78. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  79. %define _builddir %(pwd)
  80. %define kde_service_dir /usr/share/kde4/services
  81. %description
  82. The Qubes core files for installation inside a Qubes VM.
  83. %prep
  84. # we operate on the current directory, so no need to unpack anything
  85. # symlink is to generate useful debuginfo packages
  86. rm -f %{name}-%{version}
  87. ln -sf . %{name}-%{version}
  88. %setup -T -D
  89. %build
  90. for dir in qubes-rpc qrexec misc; do
  91. (cd $dir; make)
  92. done
  93. %pre
  94. # Make sure there is a qubes group
  95. groupadd --force --system --gid 98 qubes
  96. id -u 'user' >/dev/null 2>&1 || {
  97. useradd --user-group --create-home --shell /bin/bash user
  98. }
  99. usermod -a --groups qubes user
  100. if [ "$1" != 1 ] ; then
  101. # do this whole %pre thing only when updating for the first time...
  102. exit 0
  103. fi
  104. mkdir -p /var/lib/qubes
  105. if [ -e /etc/fstab ] ; then
  106. mv /etc/fstab /var/lib/qubes/fstab.orig
  107. fi
  108. usermod -p '' root
  109. usermod -L user
  110. %install
  111. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  112. make install-vm DESTDIR=$RPM_BUILD_ROOT
  113. %if %{fedora} >= 22
  114. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  115. %endif
  116. %triggerin -- initscripts
  117. if [ -e /etc/init/serial.conf ]; then
  118. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  119. fi
  120. %post
  121. # disable some Upstart services
  122. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  123. if [ -e /etc/init/$F.conf ]; then
  124. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  125. fi
  126. done
  127. # Remove ip_forward setting from sysctl, so NM will not reset it
  128. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  129. # Remove old firmware updates link
  130. if [ -L /lib/firmware/updates ]; then
  131. rm -f /lib/firmware/updates
  132. fi
  133. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  134. echo >> /etc/yum.conf
  135. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  136. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  137. fi
  138. # And actually setup the proxy usage in package managers
  139. /usr/lib/qubes/update-proxy-configs
  140. # Location of files which contains list of protected files
  141. mkdir -p /etc/qubes/protected-files.d
  142. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  143. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  144. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  145. if ! grep -q localhost /etc/hosts; then
  146. cat <<EOF > /etc/hosts
  147. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  148. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  149. EOF
  150. fi
  151. fi
  152. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  153. # in the form expected by qubes-sysinit.sh
  154. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  155. for ip in '127\.0\.0\.1' '::1'; do
  156. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  157. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  158. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  159. else
  160. echo "${ip} `hostname`" >> /etc/hosts
  161. fi
  162. done
  163. fi
  164. %if %{fedora} >= 20
  165. # Make sure there is a default locale set so gnome-terminal will start
  166. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  167. touch /etc/locale.conf
  168. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  169. fi
  170. # ... and make sure it is really generated
  171. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  172. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  173. base=`echo "$current_locale" | cut -f 1 -d .`
  174. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  175. [ -n "$charmap" ] && charmap="-f $charmap"
  176. localedef -i $base $charmap $current_locale
  177. fi
  178. %endif
  179. if [ "$1" != 1 ] ; then
  180. # do the rest of %post thing only when updating for the first time...
  181. exit 0
  182. fi
  183. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  184. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  185. fi
  186. # Remove most of the udev scripts to speed up the VM boot time
  187. # Just leave the xen* scripts, that are needed if this VM was
  188. # ever used as a net backend (e.g. as a VPN domain in the future)
  189. #echo "--> Removing unnecessary udev scripts..."
  190. mkdir -p /var/lib/qubes/removed-udev-scripts
  191. for f in /etc/udev/rules.d/*
  192. do
  193. if [ $(basename $f) == "xen-backend.rules" ] ; then
  194. continue
  195. fi
  196. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  197. continue
  198. fi
  199. if echo $f | grep -q qubes; then
  200. continue
  201. fi
  202. mv $f /var/lib/qubes/removed-udev-scripts/
  203. done
  204. mkdir -p /rw
  205. #rm -f /etc/mtab
  206. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  207. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  208. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  209. %triggerin -- notification-daemon
  210. # Enable autostart of notification-daemon when installed
  211. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  212. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  213. fi
  214. exit 0
  215. %triggerin -- selinux-policy
  216. #echo "--> Disabling SELinux..."
  217. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  218. mv /etc/selinux/config.processed /etc/selinux/config
  219. setenforce 0 2>/dev/null
  220. exit 0
  221. %preun
  222. if [ "$1" = 0 ] ; then
  223. # no more packages left
  224. if [ -e /var/lib/qubes/fstab.orig ] ; then
  225. mv /var/lib/qubes/fstab.orig /etc/fstab
  226. fi
  227. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  228. if [ -e /var/lib/qubes/serial.orig ] ; then
  229. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  230. fi
  231. fi
  232. %postun
  233. if [ $1 -eq 0 ] ; then
  234. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  235. if [ -L /lib/firmware/updates ]; then
  236. rm /lib/firmware/updates
  237. fi
  238. rm -rf /var/lib/qubes/xdg
  239. fi
  240. %posttrans
  241. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  242. %clean
  243. rm -rf $RPM_BUILD_ROOT
  244. rm -f %{name}-%{version}
  245. %files
  246. %defattr(-,root,root,-)
  247. %dir /var/lib/qubes
  248. %dir /var/run/qubes
  249. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  250. %{kde_service_dir}/qvm-copy.desktop
  251. %{kde_service_dir}/qvm-move.desktop
  252. %{kde_service_dir}/qvm-dvm.desktop
  253. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  254. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  255. %config /etc/NetworkManager/conf.d/30-qubes.conf
  256. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  257. /etc/dispvm-dotfiles.tbz
  258. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  259. /etc/fstab
  260. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  261. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  262. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  263. %dir /etc/qubes-rpc
  264. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  265. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  266. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  267. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  268. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  269. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  270. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  271. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  272. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  273. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  274. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  275. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  276. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  277. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  278. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  279. %dir /etc/qubes/autostart
  280. /etc/qubes/autostart/README.txt
  281. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  282. %config(noreplace) /etc/sudoers.d/qubes
  283. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  284. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  285. %config(noreplace) /etc/qubes/iptables.rules
  286. %config(noreplace) /etc/qubes/ip6tables.rules
  287. %config(noreplace) /etc/tinyproxy/filter-updates
  288. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  289. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  290. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  291. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  292. /etc/xen/scripts/vif-route-qubes
  293. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  294. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  295. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  296. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  297. %if %{fedora} < 22
  298. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  299. %endif
  300. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  301. /usr/sbin/qubes-serial-login
  302. /usr/bin/qvm-copy-to-vm
  303. /usr/bin/qvm-move-to-vm
  304. /usr/bin/qvm-open-in-dvm
  305. /usr/bin/qvm-open-in-vm
  306. /usr/bin/qvm-run
  307. /usr/bin/qvm-mru-entry
  308. /usr/bin/xenstore-watch-qubes
  309. /usr/bin/qubes-desktop-run
  310. /usr/bin/qrexec-fork-server
  311. /usr/bin/qrexec-client-vm
  312. /usr/bin/qubes-session-autostart
  313. %dir /usr/lib/qubes
  314. /usr/lib/qubes/vusb-ctl.py*
  315. /usr/lib/qubes/dispvm-prerun.sh
  316. /usr/lib/qubes/sync-ntp-clock
  317. /usr/lib/qubes/prepare-suspend
  318. /usr/lib/qubes/network-manager-prepare-conf-dir
  319. /usr/lib/qubes/show-hide-nm-applet.sh
  320. /usr/lib/qubes/qrexec-agent
  321. /usr/lib/qubes/qrexec-client-vm
  322. /usr/lib/qubes/qrexec_client_vm
  323. /usr/lib/qubes/qubes-rpc-multiplexer
  324. /usr/lib/qubes/qfile-agent
  325. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  326. /usr/lib/qubes/qopen-in-vm
  327. /usr/lib/qubes/qrun-in-vm
  328. /usr/lib/qubes/qubes-download-dom0-updates.sh
  329. /usr/lib/qubes/qubes-setup-dnat-to-ns
  330. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  331. /usr/lib/qubes/qvm-copy-to-vm.gnome
  332. /usr/lib/qubes/qvm-copy-to-vm.kde
  333. /usr/lib/qubes/qvm-move-to-vm.gnome
  334. /usr/lib/qubes/qvm-move-to-vm.kde
  335. /usr/lib/qubes/setup-ip
  336. /usr/lib/qubes/tar2qfile
  337. /usr/lib/qubes/vm-file-editor
  338. /usr/lib/qubes/wrap-in-html-if-url.sh
  339. /usr/lib/qubes/iptables-updates-proxy
  340. /usr/lib/qubes/close-window
  341. /usr/lib/qubes/xdg-icon
  342. /usr/lib/qubes/update-proxy-configs
  343. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  344. /usr/lib/python2.7/site-packages/dnf-plugins/qubes-hooks.py*
  345. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  346. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  347. /usr/sbin/qubes-firewall
  348. /usr/sbin/qubes-netwatcher
  349. /usr/share/qubes/serial.conf
  350. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  351. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  352. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  353. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  354. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  355. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  356. /usr/share/qubes/mime-override/globs
  357. %dir /home_volatile
  358. %attr(700,user,user) /home_volatile/user
  359. %dir /mnt/removable
  360. %dir /rw
  361. %package sysvinit
  362. Summary: Qubes unit files for SysV init style or upstart
  363. License: GPL v2 only
  364. Group: Qubes
  365. Requires: upstart
  366. Requires: qubes-core-vm
  367. Provides: qubes-core-vm-init-scripts
  368. Conflicts: qubes-core-vm-systemd
  369. %description sysvinit
  370. The Qubes core startup configuration for SysV init (or upstart).
  371. %files sysvinit
  372. /etc/init.d/qubes-core
  373. /etc/init.d/qubes-core-appvm
  374. /etc/init.d/qubes-core-netvm
  375. /etc/init.d/qubes-firewall
  376. /etc/init.d/qubes-netwatcher
  377. /etc/init.d/qubes-iptables
  378. /etc/init.d/qubes-updates-proxy
  379. /etc/init.d/qubes-qrexec-agent
  380. /etc/sysconfig/modules/qubes-core.modules
  381. /etc/sysconfig/modules/qubes-misc.modules
  382. %post sysvinit
  383. #echo "--> Turning off unnecessary services..."
  384. # FIXME: perhaps there is more elegant way to do this?
  385. for f in /etc/init.d/*
  386. do
  387. srv=`basename $f`
  388. [ $srv = 'functions' ] && continue
  389. [ $srv = 'killall' ] && continue
  390. [ $srv = 'halt' ] && continue
  391. [ $srv = 'single' ] && continue
  392. [ $srv = 'reboot' ] && continue
  393. [ $srv = 'qubes-gui' ] && continue
  394. chkconfig $srv off
  395. done
  396. #echo "--> Enabling essential services..."
  397. chkconfig rsyslog on
  398. chkconfig haldaemon on
  399. chkconfig messagebus on
  400. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  401. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  402. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  403. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  404. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  405. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  406. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  407. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  408. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  409. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  410. chkconfig --add qubes-iptables || echo "WARNING: Cannot add service qubes-iptables!"
  411. chkconfig qubes-iptables on || echo "WARNING: Cannot enable service qubes-iptables!"
  412. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  413. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  414. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  415. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  416. # TODO: make this not display the silly message about security context...
  417. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  418. %preun sysvinit
  419. if [ "$1" = 0 ] ; then
  420. # no more packages left
  421. chkconfig qubes-core off
  422. chkconfig qubes-core-netvm off
  423. chkconfig qubes-core-appvm off
  424. chkconfig qubes-firewall off
  425. chkconfig qubes-netwatcher off
  426. chkconfig qubes-updates-proxy off
  427. chkconfig qubes-qrexec-agent off
  428. fi
  429. %package systemd
  430. Summary: Qubes unit files for SystemD init style
  431. License: GPL v2 only
  432. Group: Qubes
  433. Requires: systemd
  434. Requires(post): systemd-units
  435. Requires(preun): systemd-units
  436. Requires(postun): systemd-units
  437. Requires: qubes-core-vm
  438. Provides: qubes-core-vm-init-scripts
  439. Conflicts: qubes-core-vm-sysvinit
  440. %description systemd
  441. The Qubes core startup configuration for SystemD init.
  442. %files systemd
  443. %defattr(-,root,root,-)
  444. /lib/systemd/system/qubes-dvm.service
  445. /lib/systemd/system/qubes-misc-post.service
  446. /lib/systemd/system/qubes-firewall.service
  447. /lib/systemd/system/qubes-mount-dirs.service
  448. /lib/systemd/system/qubes-netwatcher.service
  449. /lib/systemd/system/qubes-network.service
  450. /lib/systemd/system/qubes-iptables.service
  451. /lib/systemd/system/qubes-sysinit.service
  452. /lib/systemd/system/qubes-update-check.service
  453. /lib/systemd/system/qubes-update-check.timer
  454. /lib/systemd/system/qubes-updates-proxy.service
  455. /lib/systemd/system/qubes-qrexec-agent.service
  456. /lib/systemd/system/qubes-random-seed.service
  457. /lib/systemd/system-preset/75-qubes-vm.preset
  458. /lib/modules-load.d/qubes-core.conf
  459. /lib/modules-load.d/qubes-misc.conf
  460. %dir /usr/lib/qubes/init
  461. /usr/lib/qubes/init/prepare-dvm.sh
  462. /usr/lib/qubes/init/network-proxy-setup.sh
  463. /usr/lib/qubes/init/qubes-iptables
  464. /usr/lib/qubes/init/misc-post.sh
  465. /usr/lib/qubes/init/misc-post-stop.sh
  466. /usr/lib/qubes/init/mount-dirs.sh
  467. /usr/lib/qubes/init/qubes-random-seed.sh
  468. /usr/lib/qubes/init/qubes-sysinit.sh
  469. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  470. /lib/systemd/system/crond.service.d/30_qubes.conf
  471. /lib/systemd/system/cups.service.d/30_qubes.conf
  472. /lib/systemd/system/cups.socket.d/30_qubes.conf
  473. /lib/systemd/system/cups.path.d/30_qubes.conf
  474. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  475. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  476. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  477. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  478. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  479. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  480. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  481. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  482. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  483. /lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  484. /lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  485. %post systemd
  486. PRESET_FAILED=0
  487. if [ $1 -eq 1 ]; then
  488. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  489. else
  490. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-dirs"
  491. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  492. services="$services qubes-iptables qubes-updates-proxy qubes-qrexec-agent"
  493. services="$services qubes-random-seed"
  494. for srv in $services; do
  495. /bin/systemctl --no-reload preset $srv.service
  496. done
  497. /bin/systemctl --no-reload preset qubes-update-check.timer
  498. # Upgrade path - now qubes-iptables is used instead
  499. /bin/systemctl --no-reload preset iptables.service
  500. /bin/systemctl --no-reload preset ip6tables.service
  501. fi
  502. # Set default "runlevel"
  503. rm -f /etc/systemd/system/default.target
  504. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  505. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  506. case "$action" in
  507. (disable)
  508. if [ -f /lib/systemd/system/$unit_name ]; then
  509. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  510. # forcibly disable
  511. ln -sf /dev/null /etc/systemd/system/$unit_name
  512. fi
  513. fi
  514. ;;
  515. *)
  516. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  517. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  518. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  519. fi
  520. ;;
  521. esac
  522. done
  523. /bin/systemctl daemon-reload
  524. exit 0
  525. %postun systemd
  526. #Do not run this part on upgrades
  527. if [ "$1" != 0 ] ; then
  528. exit 0
  529. fi
  530. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-dirs qubes-netwatcher qubes-network qubes-qrexec-agent; do
  531. /bin/systemctl disable $srv.service
  532. do