core-agent.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: zenity
  136. Requires: qubes-core-agent-qrexec
  137. Requires: qubes-libvchan
  138. Requires: qubes-db-vm
  139. %if 0%{fedora} >= 23
  140. Requires: python3-dnf-plugins-qubes-hooks
  141. %else
  142. Requires: python2-dnf-plugins-qubes-hooks
  143. %endif
  144. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  145. Obsoletes: qubes-upgrade-vm < 3.2
  146. Provides: qubes-core-vm = %{version}-%{release}
  147. Obsoletes: qubes-core-vm < 4.0.0
  148. Provides: qubes-core-vm-doc = %{version}-%{release}
  149. Obsoletes: qubes-core-vm-doc < 4.0.0
  150. BuildRequires: pandoc
  151. BuildRequires: xen-devel
  152. BuildRequires: libX11-devel
  153. BuildRequires: qubes-utils-devel >= 3.1.3
  154. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  155. %description
  156. The Qubes core files for installation inside a Qubes VM.
  157. %package -n python2-dnf-plugins-qubes-hooks
  158. Summary: DNF plugin for Qubes specific post-installation actions
  159. BuildRequires: python2-devel
  160. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  161. %description -n python2-dnf-plugins-qubes-hooks
  162. DNF plugin for Qubes specific post-installation actions:
  163. * notify dom0 that updates were installed
  164. * refresh applications shortcut list
  165. %package -n python3-dnf-plugins-qubes-hooks
  166. Summary: DNF plugin for Qubes specific post-installation actions
  167. BuildRequires: python3-devel
  168. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  169. %description -n python3-dnf-plugins-qubes-hooks
  170. DNF plugin for Qubes specific post-installation actions:
  171. * notify dom0 that updates were installed
  172. * refresh applications shortcut list
  173. %package qrexec
  174. Summary: Qubes qrexec agent
  175. Requires: qubes-core-agent
  176. Requires: nautilus-python
  177. Conflicts: qubes-core-vm < 4.0.0
  178. %description qrexec
  179. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  180. requested by dom0 or other VMs, according to dom0-enforced policy.
  181. %package nautilus
  182. Summary: Qubes integration for Nautilus
  183. Requires: qubes-core-agent
  184. Requires: nautilus-python
  185. Conflicts: qubes-core-vm < 4.0.0
  186. %description nautilus
  187. Nautilus addons for inter-VM file copy/move/open.
  188. %package dom0-updates
  189. Summary: Scripts required to handle dom0 updates
  190. Requires: qubes-core-agent
  191. Requires: fakeroot
  192. Conflicts: qubes-core-vm < 4.0.0
  193. %description dom0-updates
  194. Scripts required to handle dom0 updates.
  195. %package networking
  196. Summary: Networking support for Qubes VM
  197. Requires: ethtool
  198. Requires: net-tools
  199. Requires: nftables
  200. Requires: socat
  201. Requires: qubes-core-agent
  202. Requires: tinyproxy
  203. Conflicts: qubes-core-vm < 4.0.0
  204. %description networking
  205. This package provides:
  206. * basic network functionality (setting IP address, DNS, default gateway)
  207. * proxy service used by TemplateVMs to download updates
  208. * qubes-firewall service (FirewallVM)
  209. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  210. qubes-core-agent-network-manager.
  211. %package network-manager
  212. Summary: NetworkManager integration for Qubes VM
  213. # to show/hide nm-applet
  214. Requires: NetworkManager >= 0.8.1-1
  215. Requires: dconf
  216. Requires: qubes-core-agent-networking
  217. Conflicts: qubes-core-vm < 4.0.0
  218. %description network-manager
  219. Integration of NetworkManager for Qubes VM:
  220. * make connections config persistent
  221. * adjust DNS redirections when needed
  222. * show/hide NetworkManager applet icon
  223. %package passwordless-root
  224. Summary: Passwordless root access from normal user
  225. Conflicts: qubes-core-vm < 4.0.0
  226. %description passwordless-root
  227. Configure sudo, PolicyKit and similar tool to not ask for any password when
  228. switching from user to root. Since all the user data in a VM is accessible
  229. already from normal user account, there is not much more to guard there. Qubes
  230. VM is a single user system.
  231. %define _builddir %(pwd)
  232. %define kde_service_dir /usr/share/kde4/services
  233. %prep
  234. # we operate on the current directory, so no need to unpack anything
  235. # symlink is to generate useful debuginfo packages
  236. rm -f %{name}-%{version}
  237. ln -sf . %{name}-%{version}
  238. %setup -T -D
  239. %build
  240. for dir in qubes-rpc qrexec misc; do
  241. (cd $dir; make)
  242. done
  243. make -C doc manpages
  244. %pre
  245. # Make sure there is a qubes group
  246. groupadd --force --system --gid 98 qubes
  247. id -u 'user' >/dev/null 2>&1 || {
  248. useradd --user-group --create-home --shell /bin/bash user
  249. }
  250. usermod -a --groups qubes user
  251. if [ "$1" != 1 ] ; then
  252. # do this whole %%pre thing only when updating for the first time...
  253. exit 0
  254. fi
  255. mkdir -p /var/lib/qubes
  256. if [ -e /etc/fstab ] ; then
  257. mv /etc/fstab /var/lib/qubes/fstab.orig
  258. fi
  259. usermod -L user
  260. %pre passwordless-root
  261. usermod -p '' root
  262. %install
  263. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  264. make install-vm DESTDIR=$RPM_BUILD_ROOT
  265. make -C doc install DESTDIR=$RPM_BUILD_ROOT
  266. %if %{fedora} >= 22
  267. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  268. %endif
  269. %triggerin -- initscripts
  270. if [ -e /etc/init/serial.conf ]; then
  271. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  272. fi
  273. %post
  274. # disable some Upstart services
  275. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  276. if [ -e /etc/init/$F.conf ]; then
  277. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  278. fi
  279. done
  280. # Remove old firmware updates link
  281. if [ -L /lib/firmware/updates ]; then
  282. rm -f /lib/firmware/updates
  283. fi
  284. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  285. echo >> /etc/yum.conf
  286. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  287. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  288. fi
  289. # And actually setup the proxy usage in package managers
  290. /usr/lib/qubes/update-proxy-configs
  291. # Location of files which contains list of protected files
  292. mkdir -p /etc/qubes/protected-files.d
  293. . /usr/lib/qubes/init/functions
  294. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  295. if ! is_protected_file /etc/hosts ; then
  296. if ! grep -q localhost /etc/hosts; then
  297. cat <<EOF > /etc/hosts
  298. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  299. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  300. EOF
  301. fi
  302. fi
  303. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  304. # in the form expected by qubes-sysinit.sh
  305. if ! is_protected_file /etc/hostname ; then
  306. for ip in '127\.0\.0\.1' '::1'; do
  307. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  308. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  309. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  310. else
  311. echo "${ip} `hostname`" >> /etc/hosts
  312. fi
  313. done
  314. fi
  315. %if %{fedora} >= 20
  316. # Make sure there is a default locale set so gnome-terminal will start
  317. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  318. touch /etc/locale.conf
  319. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  320. fi
  321. # ... and make sure it is really generated
  322. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  323. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  324. base=`echo "$current_locale" | cut -f 1 -d .`
  325. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  326. [ -n "$charmap" ] && charmap="-f $charmap"
  327. localedef -i $base $charmap $current_locale
  328. fi
  329. %endif
  330. if [ "$1" != 1 ] ; then
  331. # do the rest of %%post thing only when updating for the first time...
  332. exit 0
  333. fi
  334. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  335. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  336. fi
  337. # Remove most of the udev scripts to speed up the VM boot time
  338. # Just leave the xen* scripts, that are needed if this VM was
  339. # ever used as a net backend (e.g. as a VPN domain in the future)
  340. #echo "--> Removing unnecessary udev scripts..."
  341. mkdir -p /var/lib/qubes/removed-udev-scripts
  342. for f in /etc/udev/rules.d/*
  343. do
  344. if [ $(basename $f) == "xen-backend.rules" ] ; then
  345. continue
  346. fi
  347. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  348. continue
  349. fi
  350. if echo $f | grep -q qubes; then
  351. continue
  352. fi
  353. mv $f /var/lib/qubes/removed-udev-scripts/
  354. done
  355. mkdir -p /rw
  356. #rm -f /etc/mtab
  357. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  358. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  359. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  360. %triggerin -- notification-daemon
  361. # Enable autostart of notification-daemon when installed
  362. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  363. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  364. fi
  365. exit 0
  366. %triggerin -- selinux-policy
  367. #echo "--> Disabling SELinux..."
  368. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  369. mv /etc/selinux/config.processed /etc/selinux/config
  370. setenforce 0 2>/dev/null
  371. exit 0
  372. %post network-manager
  373. # Create NetworkManager configuration if we do not have it
  374. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  375. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  376. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  377. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  378. fi
  379. # Remove ip_forward setting from sysctl, so NM will not reset it
  380. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  381. /usr/lib/qubes/qubes-fix-nm-conf.sh
  382. %preun
  383. if [ "$1" = 0 ] ; then
  384. # no more packages left
  385. if [ -e /var/lib/qubes/fstab.orig ] ; then
  386. mv /var/lib/qubes/fstab.orig /etc/fstab
  387. fi
  388. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  389. if [ -e /var/lib/qubes/serial.orig ] ; then
  390. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  391. fi
  392. fi
  393. %postun
  394. if [ $1 -eq 0 ] ; then
  395. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  396. if [ -L /lib/firmware/updates ]; then
  397. rm /lib/firmware/updates
  398. fi
  399. rm -rf /var/lib/qubes/xdg
  400. fi
  401. %postun passwordless-root
  402. if [ $1 -eq 0 ]; then
  403. usermod -p '*' root
  404. fi
  405. %posttrans
  406. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  407. %clean
  408. rm -rf $RPM_BUILD_ROOT
  409. rm -f %{name}-%{version}
  410. %files
  411. %defattr(-,root,root,-)
  412. %dir /var/lib/qubes
  413. %dir /var/run/qubes
  414. %{kde_service_dir}/qvm-copy.desktop
  415. %{kde_service_dir}/qvm-move.desktop
  416. %{kde_service_dir}/qvm-dvm.desktop
  417. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  418. /etc/fstab
  419. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  420. %dir /etc/qubes-rpc
  421. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  422. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  423. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  424. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  425. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  426. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  427. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  428. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  429. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  430. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  431. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  432. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  433. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  434. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  435. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  436. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  437. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  438. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  439. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  440. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  441. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  442. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  443. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  444. %dir /etc/qubes/autostart
  445. /etc/qubes/autostart/README.txt
  446. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  447. %dir /etc/qubes/suspend-pre.d
  448. /etc/qubes/suspend-pre.d/README
  449. %dir /etc/qubes/suspend-post.d
  450. /etc/qubes/suspend-post.d/README
  451. %dir /etc/qubes/post-install.d
  452. /etc/qubes/post-install.d/README
  453. /etc/qubes/post-install.d/*.sh
  454. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  455. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  456. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  457. %config(noreplace) /etc/qubes-suspend-module-blacklist
  458. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  459. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  460. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  461. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  462. %if %{fedora} < 22
  463. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  464. %endif
  465. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  466. /usr/sbin/qubes-serial-login
  467. /usr/bin/qvm-copy-to-vm
  468. /usr/bin/qvm-move-to-vm
  469. /usr/bin/qvm-open-in-dvm
  470. /usr/bin/qvm-open-in-vm
  471. /usr/bin/qvm-run-vm
  472. /usr/bin/qvm-features-request
  473. /usr/bin/xenstore-watch-qubes
  474. /usr/bin/qubes-desktop-run
  475. /usr/bin/qubes-open
  476. /usr/bin/qubes-session-autostart
  477. %dir /usr/lib/qubes
  478. /usr/lib/qubes/sync-ntp-clock
  479. /usr/lib/qubes/prepare-suspend
  480. /usr/lib/qubes/qfile-agent
  481. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  482. /usr/lib/qubes/qopen-in-vm
  483. /usr/lib/qubes/qrun-in-vm
  484. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  485. /usr/lib/qubes/qvm-copy-to-vm.kde
  486. /usr/lib/qubes/qvm-move-to-vm.kde
  487. /usr/lib/qubes/tar2qfile
  488. /usr/lib/qubes/vm-file-editor
  489. /usr/lib/qubes/close-window
  490. /usr/lib/qubes/xdg-icon
  491. /usr/lib/qubes/update-proxy-configs
  492. /usr/lib/qubes/upgrades-installed-check
  493. /usr/lib/qubes/upgrades-status-notify
  494. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  495. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  496. %dir /usr/lib/qubes/init
  497. /usr/lib/qubes/init/bind-dirs.sh
  498. /usr/lib/qubes/init/control-printer-icon.sh
  499. /usr/lib/qubes/init/functions
  500. /usr/lib/qubes/init/misc-post-stop.sh
  501. /usr/lib/qubes/init/misc-post.sh
  502. /usr/lib/qubes/init/mount-dirs.sh
  503. /usr/lib/qubes/init/qubes-early-vm-config.sh
  504. /usr/lib/qubes/init/qubes-random-seed.sh
  505. /usr/lib/qubes/init/qubes-sysinit.sh
  506. /usr/lib/qubes/init/setup-rw.sh
  507. /usr/lib/qubes/init/setup-rwdev.sh
  508. /usr/lib/qubes/init/functions
  509. %dir /usr/lib/qubes-bind-dirs.d
  510. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  511. /usr/lib/python2.7/site-packages/qubesxdg.py*
  512. /usr/share/qubes/serial.conf
  513. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  514. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  515. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  516. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  517. %{_mandir}/man1/qvm-*.1*
  518. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  519. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  520. %dir %{python_sitelib}/qubesagent
  521. %{python_sitelib}/qubesagent/__init__.py*
  522. %{python_sitelib}/qubesagent/firewall.py*
  523. %{python_sitelib}/qubesagent/test_firewall.py*
  524. /usr/share/qubes/mime-override/globs
  525. /usr/share/qubes/qubes-master-key.asc
  526. %dir /mnt/removable
  527. %dir /rw
  528. %files -n python2-dnf-plugins-qubes-hooks
  529. %{python2_sitelib}/dnf-plugins/*
  530. %files -n python3-dnf-plugins-qubes-hooks
  531. %{python3_sitelib}/dnf-plugins/*
  532. %files qrexec
  533. /usr/bin/qrexec-fork-server
  534. /usr/bin/qrexec-client-vm
  535. /usr/lib/qubes/qrexec-agent
  536. /usr/lib/qubes/qrexec-client-vm
  537. /usr/lib/qubes/qrexec_client_vm
  538. /usr/lib/qubes/qubes-rpc-multiplexer
  539. /lib/systemd/system/qubes-qrexec-agent.service
  540. %files nautilus
  541. /usr/lib/qubes/qvm-copy-to-vm.gnome
  542. /usr/lib/qubes/qvm-move-to-vm.gnome
  543. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  544. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  545. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  546. %files dom0-updates
  547. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  548. /usr/lib/qubes/qubes-download-dom0-updates.sh
  549. %files networking
  550. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  551. %config(noreplace) /etc/qubes/ip6tables.rules
  552. %config(noreplace) /etc/qubes/iptables.rules
  553. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  554. %config(noreplace) /etc/tinyproxy/updates-blacklist
  555. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  556. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  557. /etc/xen/scripts/vif-qubes-nat.sh
  558. /etc/xen/scripts/vif-route-qubes
  559. /lib/systemd/system/qubes-firewall.service
  560. /lib/systemd/system/qubes-iptables.service
  561. /lib/systemd/system/qubes-network.service
  562. /lib/systemd/system/qubes-updates-proxy.service
  563. /usr/lib/qubes/init/network-proxy-setup.sh
  564. /usr/lib/qubes/init/qubes-iptables
  565. /usr/lib/qubes/iptables-updates-proxy
  566. /usr/lib/qubes/qubes-setup-dnat-to-ns
  567. /usr/lib/qubes/setup-ip
  568. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  569. /usr/sbin/qubes-firewall
  570. %files network-manager
  571. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  572. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  573. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  574. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  575. /usr/lib/qubes/network-manager-prepare-conf-dir
  576. /usr/lib/qubes/qubes-fix-nm-conf.sh
  577. /usr/lib/qubes/show-hide-nm-applet.sh
  578. %files passwordless-root
  579. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  580. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  581. %config(noreplace) /etc/sudoers.d/qubes
  582. %package sysvinit
  583. Summary: Qubes unit files for SysV init style or upstart
  584. License: GPL v2 only
  585. Group: Qubes
  586. Requires: upstart
  587. Requires: qubes-core-agent
  588. Requires: qubes-core-agent-qrexec
  589. Requires: qubes-core-agent-networking
  590. Provides: qubes-core-agent-init-scripts
  591. Conflicts: qubes-core-agent-systemd
  592. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  593. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  594. %description sysvinit
  595. The Qubes core startup configuration for SysV init (or upstart).
  596. %files sysvinit
  597. /etc/init.d/qubes-sysinit
  598. /etc/init.d/qubes-core-early
  599. /etc/init.d/qubes-core
  600. /etc/init.d/qubes-core-netvm
  601. /etc/init.d/qubes-firewall
  602. /etc/init.d/qubes-iptables
  603. /etc/init.d/qubes-updates-proxy
  604. /etc/init.d/qubes-qrexec-agent
  605. /etc/init.d/qubes-updates-proxy-forwarder
  606. /etc/sysconfig/modules/qubes-core.modules
  607. /etc/sysconfig/modules/qubes-misc.modules
  608. %post sysvinit
  609. #echo "--> Turning off unnecessary services..."
  610. # FIXME: perhaps there is more elegant way to do this?
  611. for f in /etc/init.d/*
  612. do
  613. srv=`basename $f`
  614. [ $srv = 'functions' ] && continue
  615. [ $srv = 'killall' ] && continue
  616. [ $srv = 'halt' ] && continue
  617. [ $srv = 'single' ] && continue
  618. [ $srv = 'reboot' ] && continue
  619. [ $srv = 'qubes-gui' ] && continue
  620. chkconfig $srv off
  621. done
  622. #echo "--> Enabling essential services..."
  623. chkconfig rsyslog on
  624. chkconfig haldaemon on
  625. chkconfig messagebus on
  626. for svc in %qubes_services ; do
  627. if [ "$1" = 1 ] ; then
  628. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  629. else
  630. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  631. fi
  632. done
  633. # dropped services
  634. chkconfig qubes-netwatcher off || :
  635. # TODO: make this not display the silly message about security context...
  636. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  637. %preun sysvinit
  638. if [ "$1" = 0 ] ; then
  639. # no more packages left
  640. for svc in %qubes_services ; do
  641. chkconfig --del $svc
  642. done
  643. fi
  644. %package systemd
  645. Summary: Qubes unit files for SystemD init style
  646. License: GPL v2 only
  647. Group: Qubes
  648. Requires: systemd
  649. Requires(post): systemd-units
  650. Requires(preun): systemd-units
  651. Requires(postun): systemd-units
  652. Requires: qubes-core-agent
  653. Provides: qubes-core-agent-init-scripts
  654. Conflicts: qubes-core-agent-sysvinit
  655. Provides: qubes-core-vm-systemd = %{version}-%{release}
  656. Obsoletes: qubes-core-vm-systemd < 4.0.0
  657. %description systemd
  658. The Qubes core startup configuration for SystemD init.
  659. %files systemd
  660. %defattr(-,root,root,-)
  661. /lib/systemd/system/qubes-misc-post.service
  662. /lib/systemd/system/qubes-mount-dirs.service
  663. /lib/systemd/system/qubes-sysinit.service
  664. /lib/systemd/system/qubes-early-vm-config.service
  665. /lib/systemd/system/qubes-update-check.service
  666. /lib/systemd/system/qubes-update-check.timer
  667. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  668. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  669. /lib/systemd/system-preset/%qubes_preset_file
  670. /lib/modules-load.d/qubes-core.conf
  671. /lib/modules-load.d/qubes-misc.conf
  672. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  673. /lib/systemd/system/crond.service.d/30_qubes.conf
  674. /lib/systemd/system/cups.service.d/30_qubes.conf
  675. /lib/systemd/system/cups.socket.d/30_qubes.conf
  676. /lib/systemd/system/cups.path.d/30_qubes.conf
  677. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  678. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  679. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  680. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  681. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  682. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  683. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  684. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  685. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  686. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  687. /lib/systemd/system/tor.service.d/30_qubes.conf
  688. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  689. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  690. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  691. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  692. %post systemd
  693. changed=
  694. %scriptletfuns
  695. if [ $1 -eq 1 ]
  696. then
  697. preset_units %{_presetdir}/%qubes_preset_file initial
  698. changed=true
  699. else
  700. preset_units %{_presetdir}/%qubes_preset_file upgrade
  701. changed=true
  702. # Upgrade path - now qubes-iptables is used instead
  703. for svc in iptables ip6tables
  704. do
  705. if [ -f "$svc".service ]
  706. then
  707. systemctl --no-reload preset "$svc".service
  708. changed=true
  709. fi
  710. done
  711. fi
  712. if [ $1 -eq 1 ]
  713. then
  714. # First install.
  715. # Set default "runlevel".
  716. # FIXME: this ought to be done via kernel command line.
  717. # The fewer deviations of the template from the seed
  718. # image, the better.
  719. rm -f %{_sysconfdir}/systemd/system/default.target
  720. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  721. changed=true
  722. fi
  723. # remove old symlinks
  724. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  725. then
  726. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  727. changed=true
  728. fi
  729. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  730. then
  731. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  732. changed=true
  733. fi
  734. if [ "x$changed" != "x" ]
  735. then
  736. systemctl daemon-reload
  737. fi
  738. %preun systemd
  739. if [ $1 -eq 0 ] ; then
  740. # Run this only during uninstall.
  741. # Save the preset file to later use it to re-preset services there
  742. # once the Qubes OS preset file is removed.
  743. mkdir -p %{_rundir}/qubes-uninstall
  744. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  745. fi
  746. %postun systemd
  747. changed=
  748. %scriptletfuns
  749. if [ -d %{_rundir}/qubes-uninstall ]
  750. then
  751. # We have a saved preset file (or more).
  752. # Re-preset the units mentioned there.
  753. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  754. rm -rf %{_rundir}/qubes-uninstall
  755. changed=true
  756. fi
  757. if [ "x$changed" != "x" ]
  758. then
  759. systemctl daemon-reload
  760. fi