core-agent.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944945946947948949950951952953954955956957958959960961
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. %if %{fedora} < 22
  111. Requires: yum-plugin-post-transaction-actions
  112. %endif
  113. %if %{fedora} >= 18
  114. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  115. Conflicts: firewalld
  116. %endif
  117. Requires: xdg-utils
  118. Requires: qubes-utils >= 3.1.3
  119. Requires: initscripts
  120. Requires: gawk
  121. Requires: sed
  122. Requires: util-linux
  123. # for qubes-desktop-run
  124. Requires: pygobject3-base
  125. Requires: dbus-python
  126. # for qubes-session-autostart, xdg-icon
  127. Requires: pyxdg
  128. Requires: python-daemon
  129. # for qvm-feature-request
  130. Requires: python2-qubesdb
  131. Requires: ImageMagick
  132. Requires: librsvg2-tools
  133. Requires: zenity
  134. Requires: qubes-core-agent-qrexec
  135. Requires: qubes-libvchan
  136. Requires: qubes-db-vm
  137. %if 0%{fedora} >= 23
  138. Requires: python3-dnf-plugins-qubes-hooks
  139. %else
  140. Requires: python2-dnf-plugins-qubes-hooks
  141. %endif
  142. %if 0%{?rhel} >= 7
  143. Requires: python34-dnf-plugins-qubes-hooks
  144. %endif
  145. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  146. Obsoletes: qubes-upgrade-vm < 3.2
  147. Provides: qubes-core-vm = %{version}-%{release}
  148. Obsoletes: qubes-core-vm < 4.0.0
  149. Provides: qubes-core-vm-doc = %{version}-%{release}
  150. Obsoletes: qubes-core-vm-doc < 4.0.0
  151. BuildRequires: pandoc
  152. BuildRequires: xen-devel
  153. BuildRequires: libX11-devel
  154. BuildRequires: qubes-utils-devel >= 3.1.3
  155. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  156. BuildRequires: pam-devel
  157. %description
  158. The Qubes core files for installation inside a Qubes VM.
  159. %package -n python2-dnf-plugins-qubes-hooks
  160. Summary: DNF plugin for Qubes specific post-installation actions
  161. BuildRequires: python2-devel
  162. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  163. %description -n python2-dnf-plugins-qubes-hooks
  164. DNF plugin for Qubes specific post-installation actions:
  165. * notify dom0 that updates were installed
  166. * refresh applications shortcut list
  167. %if 0%{fedora} >= 23
  168. %package -n python3-dnf-plugins-qubes-hooks
  169. Summary: DNF plugin for Qubes specific post-installation actions
  170. BuildRequires: python3-devel
  171. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  172. %description -n python3-dnf-plugins-qubes-hooks
  173. DNF plugin for Qubes specific post-installation actions:
  174. * notify dom0 that updates were installed
  175. * refresh applications shortcut list
  176. %endif
  177. %if 0%{?rhel} >= 7
  178. %package -n python34-dnf-plugins-qubes-hooks
  179. Summary: DNF plugin for Qubes specific post-installation actions
  180. BuildRequires: python34-devel
  181. %{?python_provide:%python_provide python34-dnf-plugins-qubes-hooks}
  182. %description -n python34-dnf-plugins-qubes-hooks
  183. DNF plugin for Qubes specific post-installation actions:
  184. * notify dom0 that updates were installed
  185. * refresh applications shortcut list
  186. %endif
  187. %package qrexec
  188. Summary: Qubes qrexec agent
  189. Requires: qubes-core-agent
  190. Requires: nautilus-python
  191. Conflicts: qubes-core-vm < 4.0.0
  192. %description qrexec
  193. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  194. requested by dom0 or other VMs, according to dom0-enforced policy.
  195. %package nautilus
  196. Summary: Qubes integration for Nautilus
  197. Requires: qubes-core-agent
  198. Requires: nautilus-python
  199. Conflicts: qubes-core-vm < 4.0.0
  200. %description nautilus
  201. Nautilus addons for inter-VM file copy/move/open.
  202. %package dom0-updates
  203. Summary: Scripts required to handle dom0 updates
  204. Requires: qubes-core-agent
  205. Requires: fakeroot
  206. Conflicts: qubes-core-vm < 4.0.0
  207. %description dom0-updates
  208. Scripts required to handle dom0 updates.
  209. %package networking
  210. Summary: Networking support for Qubes VM
  211. Requires: ethtool
  212. Requires: net-tools
  213. Requires: nftables
  214. Requires: socat
  215. Requires: qubes-core-agent
  216. Requires: tinyproxy
  217. Conflicts: qubes-core-vm < 4.0.0
  218. %description networking
  219. This package provides:
  220. * basic network functionality (setting IP address, DNS, default gateway)
  221. * proxy service used by TemplateVMs to download updates
  222. * qubes-firewall service (FirewallVM)
  223. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  224. qubes-core-agent-network-manager.
  225. %package network-manager
  226. Summary: NetworkManager integration for Qubes VM
  227. # to show/hide nm-applet
  228. Requires: NetworkManager >= 0.8.1-1
  229. Requires: glib2
  230. Requires: qubes-core-agent-networking
  231. Conflicts: qubes-core-vm < 4.0.0
  232. %description network-manager
  233. Integration of NetworkManager for Qubes VM:
  234. * make connections config persistent
  235. * adjust DNS redirections when needed
  236. * show/hide NetworkManager applet icon
  237. %package passwordless-root
  238. Summary: Passwordless root access from normal user
  239. Conflicts: qubes-core-vm < 4.0.0
  240. %description passwordless-root
  241. Configure sudo, PolicyKit and similar tool to not ask for any password when
  242. switching from user to root. Since all the user data in a VM is accessible
  243. already from normal user account, there is not much more to guard there. Qubes
  244. VM is a single user system.
  245. %package thunar
  246. Summary: Thunar support for Qubes VM tools
  247. Requires: Thunar
  248. %description thunar
  249. Thunar support for Qubes VM tools
  250. %define _builddir %(pwd)
  251. %define kde_service_dir /usr/share/kde4/services
  252. %prep
  253. # we operate on the current directory, so no need to unpack anything
  254. # symlink is to generate useful debuginfo packages
  255. rm -f %{name}-%{version}
  256. ln -sf . %{name}-%{version}
  257. %setup -T -D
  258. %build
  259. for dir in qubes-rpc qrexec misc; do
  260. (cd $dir; make)
  261. done
  262. make -C doc manpages
  263. %pre
  264. # Make sure there is a qubes group
  265. groupadd --force --system --gid 98 qubes
  266. id -u 'user' >/dev/null 2>&1 || {
  267. useradd --user-group --create-home --shell /bin/bash user
  268. }
  269. usermod -a --groups qubes user
  270. if [ "$1" != 1 ] ; then
  271. # do this whole %%pre thing only when updating for the first time...
  272. exit 0
  273. fi
  274. mkdir -p /var/lib/qubes
  275. if [ -e /etc/fstab ] ; then
  276. mv /etc/fstab /var/lib/qubes/fstab.orig
  277. fi
  278. usermod -L user
  279. %pre passwordless-root
  280. usermod -p '' root
  281. %install
  282. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  283. make install-vm DESTDIR=$RPM_BUILD_ROOT
  284. %if %{fedora} >= 22
  285. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  286. %endif
  287. %if 0%{?rhel} >= 7
  288. sed -i \
  289. -e 's:-primary:-centos:' \
  290. -e 's:/fc:/centos:' \
  291. $RPM_BUILD_ROOT/etc/yum.repos.d/qubes-*.repo
  292. %endif
  293. %triggerin -- initscripts
  294. if [ -e /etc/init/serial.conf ]; then
  295. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  296. fi
  297. %triggerin -- grub2-tools
  298. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  299. # do not keep Qubes-related settings directly in user-controlled config,
  300. # include another file
  301. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  302. fi
  303. %post
  304. # disable some Upstart services
  305. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  306. if [ -e /etc/init/$F.conf ]; then
  307. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  308. fi
  309. done
  310. # Remove old firmware updates link
  311. if [ -L /lib/firmware/updates ]; then
  312. rm -f /lib/firmware/updates
  313. fi
  314. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  315. echo >> /etc/yum.conf
  316. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  317. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  318. fi
  319. # And actually setup the proxy usage in package managers
  320. /usr/lib/qubes/update-proxy-configs
  321. # Location of files which contains list of protected files
  322. mkdir -p /etc/qubes/protected-files.d
  323. . /usr/lib/qubes/init/functions
  324. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  325. if ! is_protected_file /etc/hosts ; then
  326. if ! grep -q localhost /etc/hosts; then
  327. cat <<EOF > /etc/hosts
  328. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  329. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  330. EOF
  331. fi
  332. fi
  333. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  334. # in the form expected by qubes-sysinit.sh
  335. if ! is_protected_file /etc/hostname ; then
  336. for ip in '127\.0\.0\.1' '::1'; do
  337. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  338. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  339. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  340. else
  341. echo "${ip} `hostname`" >> /etc/hosts
  342. fi
  343. done
  344. fi
  345. if [ "$1" != 1 ] ; then
  346. # do the rest of %%post thing only when updating for the first time...
  347. exit 0
  348. fi
  349. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  350. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  351. fi
  352. # Remove most of the udev scripts to speed up the VM boot time
  353. # Just leave the xen* scripts, that are needed if this VM was
  354. # ever used as a net backend (e.g. as a VPN domain in the future)
  355. #echo "--> Removing unnecessary udev scripts..."
  356. mkdir -p /var/lib/qubes/removed-udev-scripts
  357. for f in /etc/udev/rules.d/*
  358. do
  359. if [ $(basename $f) == "xen-backend.rules" ] ; then
  360. continue
  361. fi
  362. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  363. continue
  364. fi
  365. if echo $f | grep -q qubes; then
  366. continue
  367. fi
  368. mv $f /var/lib/qubes/removed-udev-scripts/
  369. done
  370. mkdir -p /rw
  371. #rm -f /etc/mtab
  372. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  373. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  374. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  375. %triggerin -- notification-daemon
  376. # Enable autostart of notification-daemon when installed
  377. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  378. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  379. fi
  380. exit 0
  381. %triggerin -- selinux-policy
  382. #echo "--> Disabling SELinux..."
  383. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  384. mv /etc/selinux/config.processed /etc/selinux/config
  385. setenforce 0 2>/dev/null
  386. exit 0
  387. %post network-manager
  388. # Create NetworkManager configuration if we do not have it
  389. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  390. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  391. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  392. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  393. fi
  394. # Remove ip_forward setting from sysctl, so NM will not reset it
  395. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  396. /usr/lib/qubes/qubes-fix-nm-conf.sh
  397. %post networking
  398. %systemd_post qubes-firewall.service
  399. %systemd_post qubes-iptables.service
  400. %systemd_post qubes-network.service
  401. %systemd_post qubes-updates-proxy.service
  402. %post qrexec
  403. %systemd_post qubes-qrexec-agent.service
  404. %post thunar
  405. if [ "$1" = 1 ]; then
  406. # There is no system-wide Thunar custom actions. There is only a default
  407. # file and a user file created from the default one. Qubes actions need
  408. # to be placed after all already defined actions and before </actions>
  409. # the end of file.
  410. if [ -f /etc/xdg/Thunar/uca.xml ] ; then
  411. cp -p /etc/xdg/Thunar/uca.xml{,.bak}
  412. sed -i '$e cat /usr/lib/qubes/uca_qubes.xml' /etc/xdg/Thunar/uca.xml
  413. fi
  414. if [ -f /home/user/.config/Thunar/uca.xml ] ; then
  415. cp -p /home/user/.config/Thunar/uca.xml{,.bak}
  416. sed -i '$e cat /usr/lib/qubes/uca_qubes.xml' /home/user/.config/Thunar/uca.xml
  417. fi
  418. fi
  419. %preun
  420. if [ "$1" = 0 ] ; then
  421. # no more packages left
  422. if [ -e /var/lib/qubes/fstab.orig ] ; then
  423. mv /var/lib/qubes/fstab.orig /etc/fstab
  424. fi
  425. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  426. if [ -e /var/lib/qubes/serial.orig ] ; then
  427. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  428. fi
  429. fi
  430. %preun networking
  431. %systemd_preun qubes-firewall.service
  432. %systemd_preun qubes-iptables.service
  433. %systemd_preun qubes-network.service
  434. %systemd_preun qubes-updates-proxy.service
  435. %preun qrexec
  436. %systemd_preun qubes-qrexec-agent.service
  437. %postun thunar
  438. if [ "$1" = 0 ]; then
  439. if [ -f /etc/xdg/Thunar/uca.xml ] ; then
  440. mv /etc/xdg/Thunar/uca.xml{,.uninstall}
  441. mv /etc/xdg/Thunar/uca.xml{.bak,}
  442. fi
  443. if [ -f /home/user/.config/Thunar/uca.xml ] ; then
  444. mv /home/user/.config/Thunar/uca.xml{,.uninstall}
  445. mv /home/user/.config/Thunar/uca.xml{.bak,}
  446. fi
  447. fi
  448. %postun
  449. if [ $1 -eq 0 ] ; then
  450. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  451. if [ -L /lib/firmware/updates ]; then
  452. rm /lib/firmware/updates
  453. fi
  454. rm -rf /var/lib/qubes/xdg
  455. fi
  456. %postun passwordless-root
  457. if [ $1 -eq 0 ]; then
  458. usermod -p '*' root
  459. fi
  460. %posttrans
  461. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  462. %clean
  463. rm -rf $RPM_BUILD_ROOT
  464. rm -f %{name}-%{version}
  465. %files
  466. %defattr(-,root,root,-)
  467. %dir /var/lib/qubes
  468. %dir /var/run/qubes
  469. %{kde_service_dir}/qvm-copy.desktop
  470. %{kde_service_dir}/qvm-move.desktop
  471. %{kde_service_dir}/qvm-dvm.desktop
  472. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  473. /etc/fstab
  474. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  475. %dir /etc/qubes-rpc
  476. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  477. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  478. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  479. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  480. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  481. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  482. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  483. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  484. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  485. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  486. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  487. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  488. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  489. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  490. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  491. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  492. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  493. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  494. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  495. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  496. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  497. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  498. %config(noreplace) /etc/qubes-rpc/qubes.GetDate
  499. %dir /etc/qubes/rpc-config
  500. /etc/qubes/rpc-config/README
  501. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenInVM
  502. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenURL
  503. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectFile
  504. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectDirectory
  505. %config(noreplace) /etc/qubes/rpc-config/qubes.StartApp
  506. %config(noreplace) /etc/qubes/rpc-config/qubes.InstallUpdatesGUI
  507. %dir /etc/qubes/autostart
  508. %config(noreplace) /etc/default/grub.qubes
  509. /etc/qubes/autostart/README.txt
  510. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  511. %dir /etc/qubes/suspend-pre.d
  512. /etc/qubes/suspend-pre.d/README
  513. %dir /etc/qubes/suspend-post.d
  514. /etc/qubes/suspend-post.d/README
  515. /etc/qubes/suspend-post.d/qvm-sync-clock.sh
  516. %dir /etc/qubes/post-install.d
  517. /etc/qubes/post-install.d/README
  518. /etc/qubes/post-install.d/*.sh
  519. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  520. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  521. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  522. %config(noreplace) /etc/qubes-suspend-module-blacklist
  523. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  524. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  525. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  526. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  527. %if %{fedora} < 22
  528. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  529. %endif
  530. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  531. /usr/sbin/qubes-serial-login
  532. /usr/bin/qvm-copy-to-vm
  533. /usr/bin/qvm-move-to-vm
  534. /usr/bin/qvm-copy
  535. /usr/bin/qvm-move
  536. /usr/bin/qvm-open-in-dvm
  537. /usr/bin/qvm-open-in-vm
  538. /usr/bin/qvm-run-vm
  539. /usr/bin/qvm-features-request
  540. /usr/bin/qvm-sync-clock
  541. /usr/bin/xenstore-watch-qubes
  542. /usr/bin/qubes-desktop-run
  543. /usr/bin/qubes-open
  544. /usr/bin/qubes-session-autostart
  545. %dir /usr/lib/qubes
  546. /usr/lib/qubes/prepare-suspend
  547. /usr/lib/qubes/qfile-agent
  548. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  549. /usr/lib/qubes/qopen-in-vm
  550. /usr/lib/qubes/qrun-in-vm
  551. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  552. /usr/lib/qubes/qvm-copy-to-vm.kde
  553. /usr/lib/qubes/qvm-move-to-vm.kde
  554. /usr/lib/qubes/tar2qfile
  555. /usr/lib/qubes/vm-file-editor
  556. /usr/lib/qubes/close-window
  557. /usr/lib/qubes/xdg-icon
  558. /usr/lib/qubes/update-proxy-configs
  559. /usr/lib/qubes/upgrades-installed-check
  560. /usr/lib/qubes/upgrades-status-notify
  561. /usr/lib/qubes/qubes-sync-clock
  562. /usr/lib/qubes/resize-rootfs
  563. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  564. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  565. %dir /usr/lib/qubes/init
  566. /usr/lib/qubes/init/bind-dirs.sh
  567. /usr/lib/qubes/init/control-printer-icon.sh
  568. /usr/lib/qubes/init/functions
  569. /usr/lib/qubes/init/misc-post-stop.sh
  570. /usr/lib/qubes/init/misc-post.sh
  571. /usr/lib/qubes/init/mount-dirs.sh
  572. /usr/lib/qubes/init/qubes-early-vm-config.sh
  573. /usr/lib/qubes/init/qubes-random-seed.sh
  574. /usr/lib/qubes/init/qubes-sysinit.sh
  575. /usr/lib/qubes/init/resize-rootfs-if-needed.sh
  576. /usr/lib/qubes/init/setup-rw.sh
  577. /usr/lib/qubes/init/setup-rwdev.sh
  578. /usr/lib/qubes/init/functions
  579. %dir /usr/lib/qubes-bind-dirs.d
  580. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  581. /usr/lib/python2.7/site-packages/qubesxdg.py*
  582. /usr/share/qubes/serial.conf
  583. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  584. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  585. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  586. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  587. %{_mandir}/man1/qvm-*.1*
  588. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  589. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  590. %dir %{python_sitelib}/qubesagent
  591. %{python_sitelib}/qubesagent/__init__.py*
  592. %{python_sitelib}/qubesagent/firewall.py*
  593. %{python_sitelib}/qubesagent/test_firewall.py*
  594. /usr/share/qubes/mime-override/globs
  595. /usr/share/qubes/qubes-master-key.asc
  596. %dir /mnt/removable
  597. %dir /rw
  598. %files -n python2-dnf-plugins-qubes-hooks
  599. %{python2_sitelib}/dnf-plugins/*
  600. %if 0%{fedora} >= 23
  601. %files -n python3-dnf-plugins-qubes-hooks
  602. %{python3_sitelib}/dnf-plugins/*
  603. %endif
  604. %if 0%{?rhel} >= 7
  605. %files -n python34-dnf-plugins-qubes-hooks
  606. %{python3_sitelib}/dnf-plugins/*
  607. %endif
  608. %files qrexec
  609. %config(noreplace) /etc/pam.d/qrexec
  610. /usr/bin/qrexec-fork-server
  611. /usr/bin/qrexec-client-vm
  612. /usr/lib/qubes/qrexec-agent
  613. /usr/lib/qubes/qrexec-client-vm
  614. /usr/lib/qubes/qrexec_client_vm
  615. /usr/lib/qubes/qubes-rpc-multiplexer
  616. /lib/systemd/system/qubes-qrexec-agent.service
  617. %{_mandir}/man1/qrexec-client-vm.1*
  618. %files nautilus
  619. /usr/lib/qubes/qvm-copy-to-vm.gnome
  620. /usr/lib/qubes/qvm-move-to-vm.gnome
  621. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  622. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  623. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  624. %files thunar
  625. /usr/lib/qubes/qvm-actions.sh
  626. /usr/lib/qubes/uca_qubes.xml
  627. /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/thunar.xml
  628. %files dom0-updates
  629. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  630. /usr/lib/qubes/qubes-download-dom0-updates.sh
  631. %files networking
  632. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  633. %config(noreplace) /etc/qubes/ip6tables.rules
  634. %config(noreplace) /etc/qubes/iptables.rules
  635. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  636. %config(noreplace) /etc/tinyproxy/updates-blacklist
  637. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  638. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  639. /etc/xen/scripts/vif-qubes-nat.sh
  640. /etc/xen/scripts/vif-route-qubes
  641. /lib/systemd/system/qubes-firewall.service
  642. /lib/systemd/system/qubes-iptables.service
  643. /lib/systemd/system/qubes-network.service
  644. /lib/systemd/system/qubes-updates-proxy.service
  645. /usr/lib/qubes/init/network-proxy-setup.sh
  646. /usr/lib/qubes/init/qubes-iptables
  647. /usr/lib/qubes/iptables-updates-proxy
  648. /usr/lib/qubes/qubes-setup-dnat-to-ns
  649. /usr/lib/qubes/setup-ip
  650. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  651. /usr/sbin/qubes-firewall
  652. %files network-manager
  653. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  654. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  655. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  656. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  657. /usr/lib/qubes/network-manager-prepare-conf-dir
  658. /usr/lib/qubes/qubes-fix-nm-conf.sh
  659. /usr/lib/qubes/show-hide-nm-applet.sh
  660. %files passwordless-root
  661. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  662. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  663. %config(noreplace) /etc/sudoers.d/qubes
  664. %package sysvinit
  665. Summary: Qubes unit files for SysV init style or upstart
  666. License: GPL v2 only
  667. Group: Qubes
  668. Requires: upstart
  669. Requires: qubes-core-agent
  670. Requires: qubes-core-agent-qrexec
  671. Requires: qubes-core-agent-networking
  672. Provides: qubes-core-agent-init-scripts
  673. Conflicts: qubes-core-agent-systemd
  674. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  675. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  676. %description sysvinit
  677. The Qubes core startup configuration for SysV init (or upstart).
  678. %files sysvinit
  679. /etc/init.d/qubes-sysinit
  680. /etc/init.d/qubes-core-early
  681. /etc/init.d/qubes-core
  682. /etc/init.d/qubes-core-netvm
  683. /etc/init.d/qubes-firewall
  684. /etc/init.d/qubes-iptables
  685. /etc/init.d/qubes-updates-proxy
  686. /etc/init.d/qubes-qrexec-agent
  687. /etc/init.d/qubes-updates-proxy-forwarder
  688. /etc/sysconfig/modules/qubes-core.modules
  689. %post sysvinit
  690. #echo "--> Turning off unnecessary services..."
  691. # FIXME: perhaps there is more elegant way to do this?
  692. for f in /etc/init.d/*
  693. do
  694. srv=`basename $f`
  695. [ $srv = 'functions' ] && continue
  696. [ $srv = 'killall' ] && continue
  697. [ $srv = 'halt' ] && continue
  698. [ $srv = 'single' ] && continue
  699. [ $srv = 'reboot' ] && continue
  700. [ $srv = 'qubes-gui' ] && continue
  701. chkconfig $srv off
  702. done
  703. #echo "--> Enabling essential services..."
  704. chkconfig rsyslog on
  705. chkconfig haldaemon on
  706. chkconfig messagebus on
  707. for svc in %qubes_services ; do
  708. if [ "$1" = 1 ] ; then
  709. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  710. else
  711. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  712. fi
  713. done
  714. # dropped services
  715. chkconfig qubes-netwatcher off || :
  716. # TODO: make this not display the silly message about security context...
  717. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  718. %preun sysvinit
  719. if [ "$1" = 0 ] ; then
  720. # no more packages left
  721. for svc in %qubes_services ; do
  722. chkconfig --del $svc
  723. done
  724. fi
  725. %package systemd
  726. Summary: Qubes unit files for SystemD init style
  727. License: GPL v2 only
  728. Group: Qubes
  729. Requires: systemd
  730. Requires(post): systemd-units
  731. Requires(preun): systemd-units
  732. Requires(postun): systemd-units
  733. Requires: qubes-core-agent
  734. Provides: qubes-core-agent-init-scripts
  735. Conflicts: qubes-core-agent-sysvinit
  736. Provides: qubes-core-vm-systemd = %{version}-%{release}
  737. Obsoletes: qubes-core-vm-systemd < 4.0.0
  738. %description systemd
  739. The Qubes core startup configuration for SystemD init.
  740. %files systemd
  741. %defattr(-,root,root,-)
  742. /lib/systemd/system/qubes-misc-post.service
  743. /lib/systemd/system/qubes-mount-dirs.service
  744. /lib/systemd/system/qubes-rootfs-resize.service
  745. /lib/systemd/system/qubes-sysinit.service
  746. /lib/systemd/system/qubes-early-vm-config.service
  747. /lib/systemd/system/qubes-update-check.service
  748. /lib/systemd/system/qubes-update-check.timer
  749. /lib/systemd/system/qubes-sync-time.service
  750. /lib/systemd/system/qubes-sync-time.timer
  751. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  752. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  753. /lib/systemd/system-preset/%qubes_preset_file
  754. /lib/modules-load.d/qubes-core.conf
  755. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  756. /lib/systemd/system/crond.service.d/30_qubes.conf
  757. /lib/systemd/system/cups.service.d/30_qubes.conf
  758. /lib/systemd/system/cups.socket.d/30_qubes.conf
  759. /lib/systemd/system/cups.path.d/30_qubes.conf
  760. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  761. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  762. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  763. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  764. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  765. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  766. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  767. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  768. /lib/systemd/system/systemd-timesyncd.service.d/30_qubes.conf
  769. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  770. /lib/systemd/system/tor.service.d/30_qubes.conf
  771. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  772. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  773. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  774. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  775. %post systemd
  776. changed=
  777. %scriptletfuns
  778. if [ $1 -eq 1 ]
  779. then
  780. preset_units %{_presetdir}/%qubes_preset_file initial
  781. changed=true
  782. else
  783. preset_units %{_presetdir}/%qubes_preset_file upgrade
  784. changed=true
  785. # Upgrade path - now qubes-iptables is used instead
  786. for svc in iptables ip6tables
  787. do
  788. if [ -f "$svc".service ]
  789. then
  790. systemctl --no-reload preset "$svc".service
  791. changed=true
  792. fi
  793. done
  794. fi
  795. if [ $1 -eq 1 ]
  796. then
  797. # First install.
  798. # Set default "runlevel".
  799. # FIXME: this ought to be done via kernel command line.
  800. # The fewer deviations of the template from the seed
  801. # image, the better.
  802. rm -f %{_sysconfdir}/systemd/system/default.target
  803. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  804. changed=true
  805. fi
  806. # remove old symlinks
  807. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  808. then
  809. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  810. changed=true
  811. fi
  812. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  813. then
  814. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  815. changed=true
  816. fi
  817. if [ "x$changed" != "x" ]
  818. then
  819. systemctl daemon-reload
  820. fi
  821. %preun systemd
  822. if [ $1 -eq 0 ] ; then
  823. # Run this only during uninstall.
  824. # Save the preset file to later use it to re-preset services there
  825. # once the Qubes OS preset file is removed.
  826. mkdir -p %{_rundir}/qubes-uninstall
  827. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  828. fi
  829. %postun systemd
  830. changed=
  831. %scriptletfuns
  832. if [ -d %{_rundir}/qubes-uninstall ]
  833. then
  834. # We have a saved preset file (or more).
  835. # Re-preset the units mentioned there.
  836. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  837. rm -rf %{_rundir}/qubes-uninstall
  838. changed=true
  839. fi
  840. if [ "x$changed" != "x" ]
  841. then
  842. systemctl daemon-reload
  843. fi