core-agent.spec 30 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884885886887888889890891892893894895896897898899900901902903904905906907908909910911912913914915916917918919920921922923924925926927928929930931932933934935936937938939940941942943944945946947948949950951952953954955956957958959960961962963964
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. %if %{fedora} < 22
  111. Requires: yum-plugin-post-transaction-actions
  112. %endif
  113. %if %{fedora} >= 18
  114. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  115. Conflicts: firewalld
  116. %endif
  117. Requires: xdg-utils
  118. Requires: qubes-utils >= 3.1.3
  119. Requires: initscripts
  120. Requires: gawk
  121. Requires: sed
  122. Requires: util-linux
  123. # for qubes-desktop-run
  124. Requires: pygobject3-base
  125. Requires: dbus-python
  126. # for qubes-session-autostart, xdg-icon
  127. Requires: pyxdg
  128. Requires: python-daemon
  129. # for qvm-feature-request
  130. Requires: python2-qubesdb
  131. Requires: ImageMagick
  132. Requires: librsvg2-tools
  133. Requires: zenity
  134. Requires: qubes-core-agent-qrexec
  135. Requires: qubes-libvchan
  136. Requires: qubes-db-vm
  137. %if 0%{fedora} >= 23
  138. Requires: python3-dnf-plugins-qubes-hooks
  139. %else
  140. Requires: python2-dnf-plugins-qubes-hooks
  141. %endif
  142. %if 0%{?rhel} >= 7
  143. Requires: python34-dnf-plugins-qubes-hooks
  144. %endif
  145. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  146. Obsoletes: qubes-upgrade-vm < 3.2
  147. Provides: qubes-core-vm = %{version}-%{release}
  148. Obsoletes: qubes-core-vm < 4.0.0
  149. Provides: qubes-core-vm-doc = %{version}-%{release}
  150. Obsoletes: qubes-core-vm-doc < 4.0.0
  151. BuildRequires: pandoc
  152. BuildRequires: xen-devel
  153. BuildRequires: libX11-devel
  154. BuildRequires: qubes-utils-devel >= 3.1.3
  155. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  156. BuildRequires: pam-devel
  157. %description
  158. The Qubes core files for installation inside a Qubes VM.
  159. %package -n python2-dnf-plugins-qubes-hooks
  160. Summary: DNF plugin for Qubes specific post-installation actions
  161. BuildRequires: python2-devel
  162. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  163. %description -n python2-dnf-plugins-qubes-hooks
  164. DNF plugin for Qubes specific post-installation actions:
  165. * notify dom0 that updates were installed
  166. * refresh applications shortcut list
  167. %if 0%{fedora} >= 23
  168. %package -n python3-dnf-plugins-qubes-hooks
  169. Summary: DNF plugin for Qubes specific post-installation actions
  170. BuildRequires: python3-devel
  171. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  172. %description -n python3-dnf-plugins-qubes-hooks
  173. DNF plugin for Qubes specific post-installation actions:
  174. * notify dom0 that updates were installed
  175. * refresh applications shortcut list
  176. %endif
  177. %if 0%{?rhel} >= 7
  178. %package -n python34-dnf-plugins-qubes-hooks
  179. Summary: DNF plugin for Qubes specific post-installation actions
  180. BuildRequires: python34-devel
  181. %{?python_provide:%python_provide python34-dnf-plugins-qubes-hooks}
  182. %description -n python34-dnf-plugins-qubes-hooks
  183. DNF plugin for Qubes specific post-installation actions:
  184. * notify dom0 that updates were installed
  185. * refresh applications shortcut list
  186. %endif
  187. %package qrexec
  188. Summary: Qubes qrexec agent
  189. Requires: qubes-core-agent
  190. Requires: nautilus-python
  191. Conflicts: qubes-core-vm < 4.0.0
  192. %description qrexec
  193. Agent part of Qubes RPC system. A daemon responsible for starting processes as
  194. requested by dom0 or other VMs, according to dom0-enforced policy.
  195. %package nautilus
  196. Summary: Qubes integration for Nautilus
  197. Requires: qubes-core-agent
  198. Requires: nautilus-python
  199. Conflicts: qubes-core-vm < 4.0.0
  200. %description nautilus
  201. Nautilus addons for inter-VM file copy/move/open.
  202. %package dom0-updates
  203. Summary: Scripts required to handle dom0 updates
  204. Requires: qubes-core-agent
  205. Requires: fakeroot
  206. Conflicts: qubes-core-vm < 4.0.0
  207. %description dom0-updates
  208. Scripts required to handle dom0 updates.
  209. %package networking
  210. Summary: Networking support for Qubes VM
  211. Requires: ethtool
  212. Requires: iptables
  213. Requires: net-tools
  214. Requires: nftables
  215. Requires: socat
  216. Requires: qubes-core-agent
  217. Requires: tinyproxy
  218. Conflicts: qubes-core-vm < 4.0.0
  219. %description networking
  220. This package provides:
  221. * basic network functionality (setting IP address, DNS, default gateway)
  222. * proxy service used by TemplateVMs to download updates
  223. * qubes-firewall service (FirewallVM)
  224. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  225. qubes-core-agent-network-manager.
  226. %package network-manager
  227. Summary: NetworkManager integration for Qubes VM
  228. # to show/hide nm-applet
  229. Requires: NetworkManager >= 0.8.1-1
  230. Requires: glib2
  231. Requires: qubes-core-agent-networking
  232. Conflicts: qubes-core-vm < 4.0.0
  233. %description network-manager
  234. Integration of NetworkManager for Qubes VM:
  235. * make connections config persistent
  236. * adjust DNS redirections when needed
  237. * show/hide NetworkManager applet icon
  238. %package passwordless-root
  239. Summary: Passwordless root access from normal user
  240. Conflicts: qubes-core-vm < 4.0.0
  241. %description passwordless-root
  242. Configure sudo, PolicyKit and similar tool to not ask for any password when
  243. switching from user to root. Since all the user data in a VM is accessible
  244. already from normal user account, there is not much more to guard there. Qubes
  245. VM is a single user system.
  246. %package thunar
  247. Summary: Thunar support for Qubes VM tools
  248. Requires: Thunar
  249. %description thunar
  250. Thunar support for Qubes VM tools
  251. %define _builddir %(pwd)
  252. %define kde_service_dir /usr/share/kde4/services
  253. %prep
  254. # we operate on the current directory, so no need to unpack anything
  255. # symlink is to generate useful debuginfo packages
  256. rm -f %{name}-%{version}
  257. ln -sf . %{name}-%{version}
  258. %setup -T -D
  259. %build
  260. for dir in qubes-rpc qrexec misc; do
  261. (cd $dir; make)
  262. done
  263. make -C doc manpages
  264. %pre
  265. # Make sure there is a qubes group
  266. groupadd --force --system --gid 98 qubes
  267. id -u 'user' >/dev/null 2>&1 || {
  268. useradd --user-group --create-home --shell /bin/bash user
  269. }
  270. usermod -a --groups qubes user
  271. if [ "$1" != 1 ] ; then
  272. # do this whole %%pre thing only when updating for the first time...
  273. exit 0
  274. fi
  275. mkdir -p /var/lib/qubes
  276. if [ -e /etc/fstab ] ; then
  277. mv /etc/fstab /var/lib/qubes/fstab.orig
  278. fi
  279. usermod -L user
  280. %pre passwordless-root
  281. usermod -p '' root
  282. %install
  283. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  284. make install-vm DESTDIR=$RPM_BUILD_ROOT
  285. %if %{fedora} >= 22
  286. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  287. %endif
  288. %if 0%{?rhel} >= 7
  289. sed -i \
  290. -e 's:-primary:-centos:' \
  291. -e 's:/fc:/centos:' \
  292. $RPM_BUILD_ROOT/etc/yum.repos.d/qubes-*.repo
  293. %endif
  294. %triggerin -- initscripts
  295. if [ -e /etc/init/serial.conf ]; then
  296. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  297. fi
  298. %triggerin -- grub2-tools
  299. if ! grep -q /etc/default/grub.qubes /etc/default/grub 2>/dev/null; then
  300. # do not keep Qubes-related settings directly in user-controlled config,
  301. # include another file
  302. echo '. /etc/default/grub.qubes' >> /etc/default/grub
  303. fi
  304. %post
  305. # disable some Upstart services
  306. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  307. if [ -e /etc/init/$F.conf ]; then
  308. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  309. fi
  310. done
  311. # Remove old firmware updates link
  312. if [ -L /lib/firmware/updates ]; then
  313. rm -f /lib/firmware/updates
  314. fi
  315. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  316. echo >> /etc/yum.conf
  317. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  318. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  319. fi
  320. # And actually setup the proxy usage in package managers
  321. /usr/lib/qubes/update-proxy-configs
  322. # Location of files which contains list of protected files
  323. mkdir -p /etc/qubes/protected-files.d
  324. . /usr/lib/qubes/init/functions
  325. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  326. if ! is_protected_file /etc/hosts ; then
  327. if ! grep -q localhost /etc/hosts; then
  328. cat <<EOF > /etc/hosts
  329. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  330. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  331. EOF
  332. fi
  333. fi
  334. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  335. # in the form expected by qubes-sysinit.sh
  336. if ! is_protected_file /etc/hostname ; then
  337. for ip in '127\.0\.0\.1' '::1'; do
  338. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  339. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  340. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  341. else
  342. echo "${ip} `hostname`" >> /etc/hosts
  343. fi
  344. done
  345. fi
  346. if [ "$1" != 1 ] ; then
  347. # do the rest of %%post thing only when updating for the first time...
  348. exit 0
  349. fi
  350. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  351. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  352. fi
  353. # Remove most of the udev scripts to speed up the VM boot time
  354. # Just leave the xen* scripts, that are needed if this VM was
  355. # ever used as a net backend (e.g. as a VPN domain in the future)
  356. #echo "--> Removing unnecessary udev scripts..."
  357. mkdir -p /var/lib/qubes/removed-udev-scripts
  358. for f in /etc/udev/rules.d/*
  359. do
  360. if [ $(basename $f) == "xen-backend.rules" ] ; then
  361. continue
  362. fi
  363. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  364. continue
  365. fi
  366. if echo $f | grep -q qubes; then
  367. continue
  368. fi
  369. mv $f /var/lib/qubes/removed-udev-scripts/
  370. done
  371. mkdir -p /rw
  372. #rm -f /etc/mtab
  373. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  374. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  375. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  376. %triggerin -- notification-daemon
  377. # Enable autostart of notification-daemon when installed
  378. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  379. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  380. fi
  381. exit 0
  382. %triggerin -- selinux-policy
  383. #echo "--> Disabling SELinux..."
  384. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  385. mv /etc/selinux/config.processed /etc/selinux/config
  386. setenforce 0 2>/dev/null
  387. exit 0
  388. %post network-manager
  389. # Create NetworkManager configuration if we do not have it
  390. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  391. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  392. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  393. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  394. fi
  395. # Remove ip_forward setting from sysctl, so NM will not reset it
  396. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  397. /usr/lib/qubes/qubes-fix-nm-conf.sh
  398. %post networking
  399. %systemd_post qubes-firewall.service
  400. %systemd_post qubes-iptables.service
  401. %systemd_post qubes-network.service
  402. %systemd_post qubes-updates-proxy.service
  403. %post qrexec
  404. %systemd_post qubes-qrexec-agent.service
  405. %post thunar
  406. if [ "$1" = 1 ]; then
  407. # There is no system-wide Thunar custom actions. There is only a default
  408. # file and a user file created from the default one. Qubes actions need
  409. # to be placed after all already defined actions and before </actions>
  410. # the end of file.
  411. if [ -f /etc/xdg/Thunar/uca.xml ] ; then
  412. cp -p /etc/xdg/Thunar/uca.xml{,.bak}
  413. sed -i '$e cat /usr/lib/qubes/uca_qubes.xml' /etc/xdg/Thunar/uca.xml
  414. fi
  415. if [ -f /home/user/.config/Thunar/uca.xml ] ; then
  416. cp -p /home/user/.config/Thunar/uca.xml{,.bak}
  417. sed -i '$e cat /usr/lib/qubes/uca_qubes.xml' /home/user/.config/Thunar/uca.xml
  418. fi
  419. fi
  420. %preun
  421. if [ "$1" = 0 ] ; then
  422. # no more packages left
  423. if [ -e /var/lib/qubes/fstab.orig ] ; then
  424. mv /var/lib/qubes/fstab.orig /etc/fstab
  425. fi
  426. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  427. if [ -e /var/lib/qubes/serial.orig ] ; then
  428. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  429. fi
  430. fi
  431. %preun networking
  432. %systemd_preun qubes-firewall.service
  433. %systemd_preun qubes-iptables.service
  434. %systemd_preun qubes-network.service
  435. %systemd_preun qubes-updates-proxy.service
  436. %preun qrexec
  437. %systemd_preun qubes-qrexec-agent.service
  438. %postun thunar
  439. if [ "$1" = 0 ]; then
  440. if [ -f /etc/xdg/Thunar/uca.xml ] ; then
  441. mv /etc/xdg/Thunar/uca.xml{,.uninstall}
  442. mv /etc/xdg/Thunar/uca.xml{.bak,}
  443. fi
  444. if [ -f /home/user/.config/Thunar/uca.xml ] ; then
  445. mv /home/user/.config/Thunar/uca.xml{,.uninstall}
  446. mv /home/user/.config/Thunar/uca.xml{.bak,}
  447. fi
  448. fi
  449. %postun
  450. if [ $1 -eq 0 ] ; then
  451. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  452. if [ -L /lib/firmware/updates ]; then
  453. rm /lib/firmware/updates
  454. fi
  455. rm -rf /var/lib/qubes/xdg
  456. fi
  457. %postun passwordless-root
  458. if [ $1 -eq 0 ]; then
  459. usermod -p '*' root
  460. fi
  461. %posttrans
  462. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  463. %clean
  464. rm -rf $RPM_BUILD_ROOT
  465. rm -f %{name}-%{version}
  466. %files
  467. %defattr(-,root,root,-)
  468. %dir /var/lib/qubes
  469. %dir /var/run/qubes
  470. %{kde_service_dir}/qvm-copy.desktop
  471. %{kde_service_dir}/qvm-move.desktop
  472. %{kde_service_dir}/qvm-dvm.desktop
  473. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  474. /etc/fstab
  475. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  476. %dir /etc/qubes-rpc
  477. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  478. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  479. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  480. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  481. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  482. %config(noreplace) /etc/qubes-rpc/qubes.VMRootShell
  483. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  484. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  485. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  486. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  487. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  488. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  489. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  490. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  491. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  492. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  493. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  494. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  495. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  496. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  497. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  498. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  499. %config(noreplace) /etc/qubes-rpc/qubes.GetDate
  500. %dir /etc/qubes/rpc-config
  501. /etc/qubes/rpc-config/README
  502. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenInVM
  503. %config(noreplace) /etc/qubes/rpc-config/qubes.OpenURL
  504. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectFile
  505. %config(noreplace) /etc/qubes/rpc-config/qubes.SelectDirectory
  506. %config(noreplace) /etc/qubes/rpc-config/qubes.StartApp
  507. %config(noreplace) /etc/qubes/rpc-config/qubes.InstallUpdatesGUI
  508. %dir /etc/qubes/autostart
  509. %config(noreplace) /etc/default/grub.qubes
  510. /etc/qubes/autostart/README.txt
  511. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  512. %dir /etc/qubes/suspend-pre.d
  513. /etc/qubes/suspend-pre.d/README
  514. %dir /etc/qubes/suspend-post.d
  515. /etc/qubes/suspend-post.d/README
  516. /etc/qubes/suspend-post.d/qvm-sync-clock.sh
  517. %dir /etc/qubes/post-install.d
  518. /etc/qubes/post-install.d/README
  519. /etc/qubes/post-install.d/*.sh
  520. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  521. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  522. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  523. %config(noreplace) /etc/qubes-suspend-module-blacklist
  524. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  525. %config(noreplace) /etc/yum.repos.d/qubes-r4.repo
  526. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  527. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  528. %if %{fedora} < 22
  529. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  530. %endif
  531. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  532. /usr/sbin/qubes-serial-login
  533. /usr/bin/qvm-copy-to-vm
  534. /usr/bin/qvm-move-to-vm
  535. /usr/bin/qvm-copy
  536. /usr/bin/qvm-move
  537. /usr/bin/qvm-open-in-dvm
  538. /usr/bin/qvm-open-in-vm
  539. /usr/bin/qvm-run-vm
  540. /usr/bin/qvm-features-request
  541. /usr/bin/qvm-sync-clock
  542. /usr/bin/xenstore-watch-qubes
  543. /usr/bin/qubes-desktop-run
  544. /usr/bin/qubes-open
  545. /usr/bin/qubes-session-autostart
  546. %dir /usr/lib/qubes
  547. /usr/lib/qubes/prepare-suspend
  548. /usr/lib/qubes/qfile-agent
  549. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  550. /usr/lib/qubes/qopen-in-vm
  551. /usr/lib/qubes/qrun-in-vm
  552. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  553. /usr/lib/qubes/qvm-copy-to-vm.kde
  554. /usr/lib/qubes/qvm-move-to-vm.kde
  555. /usr/lib/qubes/tar2qfile
  556. /usr/lib/qubes/vm-file-editor
  557. /usr/lib/qubes/close-window
  558. /usr/lib/qubes/xdg-icon
  559. /usr/lib/qubes/update-proxy-configs
  560. /usr/lib/qubes/upgrades-installed-check
  561. /usr/lib/qubes/upgrades-status-notify
  562. /usr/lib/qubes/qubes-sync-clock
  563. /usr/lib/qubes/resize-rootfs
  564. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  565. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  566. %dir /usr/lib/qubes/init
  567. /usr/lib/qubes/init/bind-dirs.sh
  568. /usr/lib/qubes/init/control-printer-icon.sh
  569. /usr/lib/qubes/init/functions
  570. /usr/lib/qubes/init/misc-post-stop.sh
  571. /usr/lib/qubes/init/misc-post.sh
  572. /usr/lib/qubes/init/mount-dirs.sh
  573. /usr/lib/qubes/init/qubes-early-vm-config.sh
  574. /usr/lib/qubes/init/qubes-random-seed.sh
  575. /usr/lib/qubes/init/qubes-sysinit.sh
  576. /usr/lib/qubes/init/resize-rootfs-if-needed.sh
  577. /usr/lib/qubes/init/setup-rw.sh
  578. /usr/lib/qubes/init/setup-rwdev.sh
  579. /usr/lib/qubes/init/functions
  580. %dir /usr/lib/qubes-bind-dirs.d
  581. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  582. /usr/lib/python2.7/site-packages/qubesxdg.py*
  583. /usr/share/qubes/serial.conf
  584. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  585. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  586. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  587. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  588. %{_mandir}/man1/qvm-*.1*
  589. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  590. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  591. %dir %{python_sitelib}/qubesagent
  592. %{python_sitelib}/qubesagent/__init__.py*
  593. %{python_sitelib}/qubesagent/firewall.py*
  594. %{python_sitelib}/qubesagent/test_firewall.py*
  595. /usr/share/qubes/mime-override/globs
  596. /usr/share/qubes/qubes-master-key.asc
  597. %dir /mnt/removable
  598. %dir /rw
  599. %files -n python2-dnf-plugins-qubes-hooks
  600. %{python2_sitelib}/dnf-plugins/*
  601. %if 0%{fedora} >= 23
  602. %files -n python3-dnf-plugins-qubes-hooks
  603. %{python3_sitelib}/dnf-plugins/*
  604. %endif
  605. %if 0%{?rhel} >= 7
  606. %files -n python34-dnf-plugins-qubes-hooks
  607. %{python3_sitelib}/dnf-plugins/*
  608. %endif
  609. %files qrexec
  610. %config(noreplace) /etc/pam.d/qrexec
  611. /usr/bin/qrexec-fork-server
  612. /usr/bin/qrexec-client-vm
  613. /usr/lib/qubes/qrexec-agent
  614. /usr/lib/qubes/qrexec-client-vm
  615. /usr/lib/qubes/qrexec_client_vm
  616. /usr/lib/qubes/qubes-rpc-multiplexer
  617. /lib/systemd/system/qubes-qrexec-agent.service
  618. %{_mandir}/man1/qrexec-client-vm.1*
  619. %files nautilus
  620. /usr/lib/qubes/qvm-copy-to-vm.gnome
  621. /usr/lib/qubes/qvm-move-to-vm.gnome
  622. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  623. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  624. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  625. %files thunar
  626. /usr/lib/qubes/qvm-actions.sh
  627. /usr/lib/qubes/uca_qubes.xml
  628. /etc/xdg/xfce4/xfconf/xfce-perchannel-xml/thunar.xml
  629. %files dom0-updates
  630. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  631. /usr/lib/qubes/qubes-download-dom0-updates.sh
  632. %files networking
  633. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  634. %config(noreplace) /etc/qubes/ip6tables.rules
  635. %config(noreplace) /etc/qubes/ip6tables-enabled.rules
  636. %config(noreplace) /etc/qubes/iptables.rules
  637. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  638. %config(noreplace) /etc/tinyproxy/updates-blacklist
  639. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  640. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  641. /etc/xen/scripts/vif-qubes-nat.sh
  642. /etc/xen/scripts/vif-route-qubes
  643. /lib/systemd/system/qubes-firewall.service
  644. /lib/systemd/system/qubes-iptables.service
  645. /lib/systemd/system/qubes-network.service
  646. /lib/systemd/system/qubes-updates-proxy.service
  647. /usr/lib/qubes/init/network-proxy-setup.sh
  648. /usr/lib/qubes/init/qubes-iptables
  649. /usr/lib/qubes/iptables-updates-proxy
  650. /usr/lib/qubes/qubes-setup-dnat-to-ns
  651. /usr/lib/qubes/setup-ip
  652. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  653. /usr/sbin/qubes-firewall
  654. %files network-manager
  655. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  656. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  657. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  658. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  659. /usr/lib/qubes/network-manager-prepare-conf-dir
  660. /usr/lib/qubes/qubes-fix-nm-conf.sh
  661. /usr/lib/qubes/show-hide-nm-applet.sh
  662. %files passwordless-root
  663. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  664. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  665. %config(noreplace) /etc/sudoers.d/qubes
  666. %package sysvinit
  667. Summary: Qubes unit files for SysV init style or upstart
  668. License: GPL v2 only
  669. Group: Qubes
  670. Requires: upstart
  671. Requires: qubes-core-agent
  672. Requires: qubes-core-agent-qrexec
  673. Requires: qubes-core-agent-networking
  674. Provides: qubes-core-agent-init-scripts
  675. Conflicts: qubes-core-agent-systemd
  676. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  677. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  678. %description sysvinit
  679. The Qubes core startup configuration for SysV init (or upstart).
  680. %files sysvinit
  681. /etc/init.d/qubes-sysinit
  682. /etc/init.d/qubes-core-early
  683. /etc/init.d/qubes-core
  684. /etc/init.d/qubes-core-netvm
  685. /etc/init.d/qubes-firewall
  686. /etc/init.d/qubes-iptables
  687. /etc/init.d/qubes-updates-proxy
  688. /etc/init.d/qubes-qrexec-agent
  689. /etc/init.d/qubes-updates-proxy-forwarder
  690. /etc/sysconfig/modules/qubes-core.modules
  691. %post sysvinit
  692. #echo "--> Turning off unnecessary services..."
  693. # FIXME: perhaps there is more elegant way to do this?
  694. for f in /etc/init.d/*
  695. do
  696. srv=`basename $f`
  697. [ $srv = 'functions' ] && continue
  698. [ $srv = 'killall' ] && continue
  699. [ $srv = 'halt' ] && continue
  700. [ $srv = 'single' ] && continue
  701. [ $srv = 'reboot' ] && continue
  702. [ $srv = 'qubes-gui' ] && continue
  703. chkconfig $srv off
  704. done
  705. #echo "--> Enabling essential services..."
  706. chkconfig rsyslog on
  707. chkconfig haldaemon on
  708. chkconfig messagebus on
  709. for svc in %qubes_services ; do
  710. if [ "$1" = 1 ] ; then
  711. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  712. else
  713. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  714. fi
  715. done
  716. # dropped services
  717. chkconfig qubes-netwatcher off || :
  718. # TODO: make this not display the silly message about security context...
  719. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  720. %preun sysvinit
  721. if [ "$1" = 0 ] ; then
  722. # no more packages left
  723. for svc in %qubes_services ; do
  724. chkconfig --del $svc
  725. done
  726. fi
  727. %package systemd
  728. Summary: Qubes unit files for SystemD init style
  729. License: GPL v2 only
  730. Group: Qubes
  731. Requires: systemd
  732. Requires(post): systemd-units
  733. Requires(preun): systemd-units
  734. Requires(postun): systemd-units
  735. Requires: qubes-core-agent
  736. Provides: qubes-core-agent-init-scripts
  737. Conflicts: qubes-core-agent-sysvinit
  738. Provides: qubes-core-vm-systemd = %{version}-%{release}
  739. Obsoletes: qubes-core-vm-systemd < 4.0.0
  740. %description systemd
  741. The Qubes core startup configuration for SystemD init.
  742. %files systemd
  743. %defattr(-,root,root,-)
  744. /lib/systemd/system/qubes-misc-post.service
  745. /lib/systemd/system/qubes-mount-dirs.service
  746. /lib/systemd/system/qubes-rootfs-resize.service
  747. /lib/systemd/system/qubes-sysinit.service
  748. /lib/systemd/system/qubes-early-vm-config.service
  749. /lib/systemd/system/qubes-update-check.service
  750. /lib/systemd/system/qubes-update-check.timer
  751. /lib/systemd/system/qubes-sync-time.service
  752. /lib/systemd/system/qubes-sync-time.timer
  753. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  754. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  755. /lib/systemd/system-preset/%qubes_preset_file
  756. /lib/modules-load.d/qubes-core.conf
  757. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  758. /lib/systemd/system/crond.service.d/30_qubes.conf
  759. /lib/systemd/system/cups.service.d/30_qubes.conf
  760. /lib/systemd/system/cups.socket.d/30_qubes.conf
  761. /lib/systemd/system/cups.path.d/30_qubes.conf
  762. /lib/systemd/system/cups-browsed.service.d/30_qubes.conf
  763. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  764. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  765. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  766. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  767. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  768. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  769. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  770. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  771. /lib/systemd/system/systemd-timesyncd.service.d/30_qubes.conf
  772. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  773. /lib/systemd/system/tor.service.d/30_qubes.conf
  774. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  775. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  776. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  777. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  778. %post systemd
  779. changed=
  780. %scriptletfuns
  781. if [ $1 -eq 1 ]
  782. then
  783. preset_units %{_presetdir}/%qubes_preset_file initial
  784. changed=true
  785. else
  786. preset_units %{_presetdir}/%qubes_preset_file upgrade
  787. changed=true
  788. # Upgrade path - now qubes-iptables is used instead
  789. for svc in iptables ip6tables
  790. do
  791. if [ -f "$svc".service ]
  792. then
  793. systemctl --no-reload preset "$svc".service
  794. changed=true
  795. fi
  796. done
  797. fi
  798. if [ $1 -eq 1 ]
  799. then
  800. # First install.
  801. # Set default "runlevel".
  802. # FIXME: this ought to be done via kernel command line.
  803. # The fewer deviations of the template from the seed
  804. # image, the better.
  805. rm -f %{_sysconfdir}/systemd/system/default.target
  806. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  807. changed=true
  808. fi
  809. # remove old symlinks
  810. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  811. then
  812. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  813. changed=true
  814. fi
  815. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  816. then
  817. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  818. changed=true
  819. fi
  820. if [ "x$changed" != "x" ]
  821. then
  822. systemctl daemon-reload
  823. fi
  824. %preun systemd
  825. if [ $1 -eq 0 ] ; then
  826. # Run this only during uninstall.
  827. # Save the preset file to later use it to re-preset services there
  828. # once the Qubes OS preset file is removed.
  829. mkdir -p %{_rundir}/qubes-uninstall
  830. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  831. fi
  832. %postun systemd
  833. changed=
  834. %scriptletfuns
  835. if [ -d %{_rundir}/qubes-uninstall ]
  836. then
  837. # We have a saved preset file (or more).
  838. # Re-preset the units mentioned there.
  839. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  840. rm -rf %{_rundir}/qubes-uninstall
  841. changed=true
  842. fi
  843. if [ "x$changed" != "x" ]
  844. then
  845. systemctl daemon-reload
  846. fi