core-vm.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: nmap-ncat
  123. Requires: ntpdate
  124. Requires: net-tools
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. Requires: python-daemon
  138. # for qvm-feature-request
  139. Requires: python2-qubesdb
  140. Requires: nftables
  141. Requires: ImageMagick
  142. Requires: librsvg2-tools
  143. Requires: fakeroot
  144. Requires: desktop-notification-daemon
  145. # to show/hide nm-applet
  146. Requires: dconf
  147. Requires: zenity
  148. Requires: qubes-libvchan
  149. Requires: qubes-db-vm
  150. %if 0%{fedora} >= 23
  151. Requires: python3-dnf-plugins-qubes-hooks
  152. %else
  153. Requires: python2-dnf-plugins-qubes-hooks
  154. %endif
  155. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  156. Obsoletes: qubes-upgrade-vm < 3.2
  157. BuildRequires: xen-devel
  158. BuildRequires: libX11-devel
  159. BuildRequires: qubes-utils-devel >= 3.1.3
  160. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  161. %package -n python2-dnf-plugins-qubes-hooks
  162. Summary: DNF plugin for Qubes specific post-installation actions
  163. BuildRequires: python2-devel
  164. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  165. %description -n python2-dnf-plugins-qubes-hooks
  166. DNF plugin for Qubes specific post-installation actions:
  167. * notify dom0 that updates were installed
  168. * refresh applications shortcut list
  169. %package -n python3-dnf-plugins-qubes-hooks
  170. Summary: DNF plugin for Qubes specific post-installation actions
  171. BuildRequires: python3-devel
  172. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  173. %description -n python3-dnf-plugins-qubes-hooks
  174. DNF plugin for Qubes specific post-installation actions:
  175. * notify dom0 that updates were installed
  176. * refresh applications shortcut list
  177. %package -n qubes-nautilus
  178. Summary: Qubes integration for Nautilus
  179. Requires: qubes-core-vm
  180. Requires: nautilus-python
  181. %description -n qubes-nautilus
  182. Nautilus addons for inter-VM file copy/move/open.
  183. %define _builddir %(pwd)
  184. %define kde_service_dir /usr/share/kde4/services
  185. %description
  186. The Qubes core files for installation inside a Qubes VM.
  187. %prep
  188. # we operate on the current directory, so no need to unpack anything
  189. # symlink is to generate useful debuginfo packages
  190. rm -f %{name}-%{version}
  191. ln -sf . %{name}-%{version}
  192. %setup -T -D
  193. %build
  194. for dir in qubes-rpc qrexec misc; do
  195. (cd $dir; make)
  196. done
  197. %pre
  198. # Make sure there is a qubes group
  199. groupadd --force --system --gid 98 qubes
  200. id -u 'user' >/dev/null 2>&1 || {
  201. useradd --user-group --create-home --shell /bin/bash user
  202. }
  203. usermod -a --groups qubes user
  204. if [ "$1" != 1 ] ; then
  205. # do this whole %%pre thing only when updating for the first time...
  206. exit 0
  207. fi
  208. mkdir -p /var/lib/qubes
  209. if [ -e /etc/fstab ] ; then
  210. mv /etc/fstab /var/lib/qubes/fstab.orig
  211. fi
  212. usermod -p '' root
  213. usermod -L user
  214. %install
  215. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  216. make install-vm DESTDIR=$RPM_BUILD_ROOT
  217. %if %{fedora} >= 22
  218. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  219. %endif
  220. %triggerin -- initscripts
  221. if [ -e /etc/init/serial.conf ]; then
  222. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  223. fi
  224. %post
  225. # disable some Upstart services
  226. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  227. if [ -e /etc/init/$F.conf ]; then
  228. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  229. fi
  230. done
  231. # Create NetworkManager configuration if we do not have it
  232. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  233. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  234. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  235. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  236. fi
  237. /usr/lib/qubes/qubes-fix-nm-conf.sh
  238. # Remove ip_forward setting from sysctl, so NM will not reset it
  239. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  240. # Remove old firmware updates link
  241. if [ -L /lib/firmware/updates ]; then
  242. rm -f /lib/firmware/updates
  243. fi
  244. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  245. echo >> /etc/yum.conf
  246. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  247. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  248. fi
  249. # And actually setup the proxy usage in package managers
  250. /usr/lib/qubes/update-proxy-configs
  251. # Location of files which contains list of protected files
  252. mkdir -p /etc/qubes/protected-files.d
  253. . /usr/lib/qubes/init/functions
  254. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  255. if ! is_protected_file /etc/hosts ; then
  256. if ! grep -q localhost /etc/hosts; then
  257. cat <<EOF > /etc/hosts
  258. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  259. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  260. EOF
  261. fi
  262. fi
  263. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  264. # in the form expected by qubes-sysinit.sh
  265. if ! is_protected_file /etc/hostname ; then
  266. for ip in '127\.0\.0\.1' '::1'; do
  267. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  268. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  269. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  270. else
  271. echo "${ip} `hostname`" >> /etc/hosts
  272. fi
  273. done
  274. fi
  275. %if %{fedora} >= 20
  276. # Make sure there is a default locale set so gnome-terminal will start
  277. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  278. touch /etc/locale.conf
  279. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  280. fi
  281. # ... and make sure it is really generated
  282. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  283. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  284. base=`echo "$current_locale" | cut -f 1 -d .`
  285. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  286. [ -n "$charmap" ] && charmap="-f $charmap"
  287. localedef -i $base $charmap $current_locale
  288. fi
  289. %endif
  290. if [ "$1" != 1 ] ; then
  291. # do the rest of %%post thing only when updating for the first time...
  292. exit 0
  293. fi
  294. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  295. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  296. fi
  297. # Remove most of the udev scripts to speed up the VM boot time
  298. # Just leave the xen* scripts, that are needed if this VM was
  299. # ever used as a net backend (e.g. as a VPN domain in the future)
  300. #echo "--> Removing unnecessary udev scripts..."
  301. mkdir -p /var/lib/qubes/removed-udev-scripts
  302. for f in /etc/udev/rules.d/*
  303. do
  304. if [ $(basename $f) == "xen-backend.rules" ] ; then
  305. continue
  306. fi
  307. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  308. continue
  309. fi
  310. if echo $f | grep -q qubes; then
  311. continue
  312. fi
  313. mv $f /var/lib/qubes/removed-udev-scripts/
  314. done
  315. mkdir -p /rw
  316. #rm -f /etc/mtab
  317. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  318. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  319. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  320. %triggerin -- notification-daemon
  321. # Enable autostart of notification-daemon when installed
  322. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  323. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  324. fi
  325. exit 0
  326. %triggerin -- selinux-policy
  327. #echo "--> Disabling SELinux..."
  328. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  329. mv /etc/selinux/config.processed /etc/selinux/config
  330. setenforce 0 2>/dev/null
  331. exit 0
  332. %preun
  333. if [ "$1" = 0 ] ; then
  334. # no more packages left
  335. if [ -e /var/lib/qubes/fstab.orig ] ; then
  336. mv /var/lib/qubes/fstab.orig /etc/fstab
  337. fi
  338. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  339. if [ -e /var/lib/qubes/serial.orig ] ; then
  340. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  341. fi
  342. fi
  343. %postun
  344. if [ $1 -eq 0 ] ; then
  345. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  346. if [ -L /lib/firmware/updates ]; then
  347. rm /lib/firmware/updates
  348. fi
  349. rm -rf /var/lib/qubes/xdg
  350. fi
  351. %posttrans
  352. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  353. %clean
  354. rm -rf $RPM_BUILD_ROOT
  355. rm -f %{name}-%{version}
  356. %files
  357. %defattr(-,root,root,-)
  358. %dir /var/lib/qubes
  359. %dir /var/run/qubes
  360. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  361. %{kde_service_dir}/qvm-copy.desktop
  362. %{kde_service_dir}/qvm-move.desktop
  363. %{kde_service_dir}/qvm-dvm.desktop
  364. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  365. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  366. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  367. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  368. /etc/fstab
  369. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  370. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  371. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  372. %dir /etc/qubes-rpc
  373. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  374. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  375. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  376. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  377. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  378. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  379. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  380. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  381. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  382. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  383. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  384. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  385. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  386. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  387. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  388. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  389. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  390. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  391. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  392. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  393. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  394. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  395. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  396. %dir /etc/qubes/autostart
  397. /etc/qubes/autostart/README.txt
  398. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  399. %dir /etc/qubes/suspend-pre.d
  400. /etc/qubes/suspend-pre.d/README
  401. %dir /etc/qubes/suspend-post.d
  402. /etc/qubes/suspend-post.d/README
  403. %dir /etc/qubes/post-install.d
  404. /etc/qubes/post-install.d/README
  405. /etc/qubes/post-install.d/*.sh
  406. %config(noreplace) /etc/sudoers.d/qubes
  407. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  408. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  409. %config(noreplace) /etc/qubes/iptables.rules
  410. %config(noreplace) /etc/qubes/ip6tables.rules
  411. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  412. %config(noreplace) /etc/tinyproxy/updates-blacklist
  413. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  414. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  415. %config(noreplace) /etc/qubes-suspend-module-blacklist
  416. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  417. /etc/xen/scripts/vif-route-qubes
  418. /etc/xen/scripts/vif-qubes-nat.sh
  419. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  420. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  421. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  422. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  423. %if %{fedora} < 22
  424. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  425. %endif
  426. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  427. /usr/sbin/qubes-serial-login
  428. /usr/bin/qvm-copy-to-vm
  429. /usr/bin/qvm-move-to-vm
  430. /usr/bin/qvm-open-in-dvm
  431. /usr/bin/qvm-open-in-vm
  432. /usr/bin/qvm-run-vm
  433. /usr/bin/qvm-features-request
  434. /usr/bin/xenstore-watch-qubes
  435. /usr/bin/qubes-desktop-run
  436. /usr/bin/qubes-open
  437. /usr/bin/qrexec-fork-server
  438. /usr/bin/qrexec-client-vm
  439. /usr/bin/qubes-session-autostart
  440. %dir /usr/lib/qubes
  441. /usr/lib/qubes/vusb-ctl.py*
  442. /usr/lib/qubes/dispvm-prerun.sh
  443. /usr/lib/qubes/sync-ntp-clock
  444. /usr/lib/qubes/prepare-suspend
  445. /usr/lib/qubes/network-manager-prepare-conf-dir
  446. /usr/lib/qubes/show-hide-nm-applet.sh
  447. /usr/lib/qubes/qrexec-agent
  448. /usr/lib/qubes/qrexec-client-vm
  449. /usr/lib/qubes/qrexec_client_vm
  450. /usr/lib/qubes/qubes-rpc-multiplexer
  451. /usr/lib/qubes/qfile-agent
  452. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  453. /usr/lib/qubes/qopen-in-vm
  454. /usr/lib/qubes/qrun-in-vm
  455. /usr/lib/qubes/qubes-download-dom0-updates.sh
  456. /usr/lib/qubes/qubes-fix-nm-conf.sh
  457. /usr/lib/qubes/qubes-setup-dnat-to-ns
  458. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  459. /usr/lib/qubes/qvm-copy-to-vm.kde
  460. /usr/lib/qubes/qvm-move-to-vm.kde
  461. /usr/lib/qubes/setup-ip
  462. /usr/lib/qubes/tar2qfile
  463. /usr/lib/qubes/vm-file-editor
  464. /usr/lib/qubes/iptables-updates-proxy
  465. /usr/lib/qubes/close-window
  466. /usr/lib/qubes/xdg-icon
  467. /usr/lib/qubes/update-proxy-configs
  468. /usr/lib/qubes/upgrades-installed-check
  469. /usr/lib/qubes/upgrades-status-notify
  470. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  471. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  472. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  473. %dir /usr/lib/qubes/init
  474. /usr/lib/qubes/init/*.sh
  475. /usr/lib/qubes/init/functions
  476. %dir /usr/lib/qubes-bind-dirs.d
  477. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  478. /usr/lib/python2.7/site-packages/qubesxdg.py*
  479. /usr/sbin/qubes-firewall
  480. /usr/share/qubes/serial.conf
  481. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  482. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  483. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  484. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  485. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  486. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  487. %dir %{python_sitelib}/qubesagent
  488. %{python_sitelib}/qubesagent/__init__.py*
  489. %{python_sitelib}/qubesagent/firewall.py*
  490. %{python_sitelib}/qubesagent/test_firewall.py*
  491. /usr/share/qubes/mime-override/globs
  492. /usr/share/qubes/qubes-master-key.asc
  493. %dir /home_volatile
  494. %attr(700,user,user) /home_volatile/user
  495. %dir /mnt/removable
  496. %dir /rw
  497. %files -n python2-dnf-plugins-qubes-hooks
  498. %{python2_sitelib}/dnf-plugins/*
  499. %files -n python3-dnf-plugins-qubes-hooks
  500. %{python3_sitelib}/dnf-plugins/*
  501. %files -n qubes-nautilus
  502. /usr/lib/qubes/qvm-copy-to-vm.gnome
  503. /usr/lib/qubes/qvm-move-to-vm.gnome
  504. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  505. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  506. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  507. %package sysvinit
  508. Summary: Qubes unit files for SysV init style or upstart
  509. License: GPL v2 only
  510. Group: Qubes
  511. Requires: upstart
  512. Requires: qubes-core-vm
  513. Provides: qubes-core-vm-init-scripts
  514. Conflicts: qubes-core-vm-systemd
  515. %description sysvinit
  516. The Qubes core startup configuration for SysV init (or upstart).
  517. %files sysvinit
  518. /etc/init.d/qubes-sysinit
  519. /etc/init.d/qubes-core-early
  520. /etc/init.d/qubes-core
  521. /etc/init.d/qubes-dvm
  522. /etc/init.d/qubes-core-netvm
  523. /etc/init.d/qubes-firewall
  524. /etc/init.d/qubes-iptables
  525. /etc/init.d/qubes-updates-proxy
  526. /etc/init.d/qubes-qrexec-agent
  527. /etc/init.d/qubes-updates-proxy-forwarder
  528. /etc/sysconfig/modules/qubes-core.modules
  529. /etc/sysconfig/modules/qubes-misc.modules
  530. %post sysvinit
  531. #echo "--> Turning off unnecessary services..."
  532. # FIXME: perhaps there is more elegant way to do this?
  533. for f in /etc/init.d/*
  534. do
  535. srv=`basename $f`
  536. [ $srv = 'functions' ] && continue
  537. [ $srv = 'killall' ] && continue
  538. [ $srv = 'halt' ] && continue
  539. [ $srv = 'single' ] && continue
  540. [ $srv = 'reboot' ] && continue
  541. [ $srv = 'qubes-gui' ] && continue
  542. chkconfig $srv off
  543. done
  544. #echo "--> Enabling essential services..."
  545. chkconfig rsyslog on
  546. chkconfig haldaemon on
  547. chkconfig messagebus on
  548. for svc in %qubes_services ; do
  549. if [ "$1" = 1 ] ; then
  550. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  551. else
  552. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  553. fi
  554. done
  555. # dropped services
  556. chkconfig qubes-netwatcher off || :
  557. # TODO: make this not display the silly message about security context...
  558. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  559. %preun sysvinit
  560. if [ "$1" = 0 ] ; then
  561. # no more packages left
  562. for svc in %qubes_services ; do
  563. chkconfig --del $svc
  564. done
  565. fi
  566. %package systemd
  567. Summary: Qubes unit files for SystemD init style
  568. License: GPL v2 only
  569. Group: Qubes
  570. Requires: systemd
  571. Requires(post): systemd-units
  572. Requires(preun): systemd-units
  573. Requires(postun): systemd-units
  574. Requires: qubes-core-vm
  575. Provides: qubes-core-vm-init-scripts
  576. Conflicts: qubes-core-vm-sysvinit
  577. %description systemd
  578. The Qubes core startup configuration for SystemD init.
  579. %files systemd
  580. %defattr(-,root,root,-)
  581. /lib/systemd/system/qubes-dvm.service
  582. /lib/systemd/system/qubes-misc-post.service
  583. /lib/systemd/system/qubes-firewall.service
  584. /lib/systemd/system/qubes-mount-dirs.service
  585. /lib/systemd/system/qubes-network.service
  586. /lib/systemd/system/qubes-iptables.service
  587. /lib/systemd/system/qubes-sysinit.service
  588. /lib/systemd/system/qubes-early-vm-config.service
  589. /lib/systemd/system/qubes-update-check.service
  590. /lib/systemd/system/qubes-update-check.timer
  591. /lib/systemd/system/qubes-updates-proxy.service
  592. /lib/systemd/system/qubes-qrexec-agent.service
  593. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  594. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  595. /lib/systemd/system-preset/%qubes_preset_file
  596. /lib/modules-load.d/qubes-core.conf
  597. /lib/modules-load.d/qubes-misc.conf
  598. /usr/lib/qubes/init/qubes-iptables
  599. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  600. /lib/systemd/system/crond.service.d/30_qubes.conf
  601. /lib/systemd/system/cups.service.d/30_qubes.conf
  602. /lib/systemd/system/cups.socket.d/30_qubes.conf
  603. /lib/systemd/system/cups.path.d/30_qubes.conf
  604. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  605. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  606. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  607. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  608. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  609. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  610. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  611. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  612. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  613. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  614. /lib/systemd/system/tor.service.d/30_qubes.conf
  615. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  616. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  617. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  618. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  619. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  620. %post systemd
  621. changed=
  622. %scriptletfuns
  623. if [ $1 -eq 1 ]
  624. then
  625. preset_units %{_presetdir}/%qubes_preset_file initial
  626. changed=true
  627. else
  628. preset_units %{_presetdir}/%qubes_preset_file upgrade
  629. changed=true
  630. # Upgrade path - now qubes-iptables is used instead
  631. for svc in iptables ip6tables
  632. do
  633. if [ -f "$svc".service ]
  634. then
  635. systemctl --no-reload preset "$svc".service
  636. changed=true
  637. fi
  638. done
  639. fi
  640. if [ $1 -eq 1 ]
  641. then
  642. # First install.
  643. # Set default "runlevel".
  644. # FIXME: this ought to be done via kernel command line.
  645. # The fewer deviations of the template from the seed
  646. # image, the better.
  647. rm -f %{_sysconfdir}/systemd/system/default.target
  648. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  649. changed=true
  650. fi
  651. # remove old symlinks
  652. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  653. then
  654. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  655. changed=true
  656. fi
  657. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  658. then
  659. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  660. changed=true
  661. fi
  662. if [ "x$changed" != "x" ]
  663. then
  664. systemctl daemon-reload
  665. fi
  666. %preun systemd
  667. if [ $1 -eq 0 ] ; then
  668. # Run this only during uninstall.
  669. # Save the preset file to later use it to re-preset services there
  670. # once the Qubes OS preset file is removed.
  671. mkdir -p %{_rundir}/qubes-uninstall
  672. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  673. fi
  674. %postun systemd
  675. changed=
  676. %scriptletfuns
  677. if [ -d %{_rundir}/qubes-uninstall ]
  678. then
  679. # We have a saved preset file (or more).
  680. # Re-preset the units mentioned there.
  681. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  682. rm -rf %{_rundir}/qubes-uninstall
  683. changed=true
  684. fi
  685. if [ "x$changed" != "x" ]
  686. then
  687. systemctl daemon-reload
  688. fi