core-vm.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-dvm
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-vm
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. Requires: NetworkManager >= 0.8.1-1
  115. %if %{fedora} >= 18
  116. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  117. Conflicts: firewalld
  118. %endif
  119. Requires: xdg-utils
  120. Requires: ethtool
  121. Requires: tinyproxy
  122. Requires: ntpdate
  123. Requires: net-tools
  124. Requires: nautilus-python
  125. Requires: qubes-utils >= 3.1.3
  126. Requires: initscripts
  127. Requires: gawk
  128. Requires: sed
  129. # for dispvm-prerun.sh
  130. Requires: procps-ng
  131. Requires: util-linux
  132. # for qubes-desktop-run
  133. Requires: pygobject3-base
  134. Requires: dbus-python
  135. # for qubes-session-autostart, xdg-icon
  136. Requires: pyxdg
  137. Requires: python3-daemon
  138. Requires: nftables
  139. Requires: ImageMagick
  140. Requires: librsvg2-tools
  141. Requires: fakeroot
  142. Requires: desktop-notification-daemon
  143. # to show/hide nm-applet
  144. Requires: dconf
  145. Requires: zenity
  146. Requires: qubes-libvchan
  147. Requires: qubes-db-vm
  148. %if 0%{fedora} >= 23
  149. Requires: python3-dnf-plugins-qubes-hooks
  150. %else
  151. Requires: python2-dnf-plugins-qubes-hooks
  152. %endif
  153. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  154. Obsoletes: qubes-upgrade-vm < 3.2
  155. BuildRequires: xen-devel
  156. BuildRequires: python3-devel
  157. BuildRequires: libX11-devel
  158. BuildRequires: qubes-utils-devel >= 3.1.3
  159. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  160. %package -n python2-dnf-plugins-qubes-hooks
  161. Summary: DNF plugin for Qubes specific post-installation actions
  162. BuildRequires: python2-devel
  163. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  164. %description -n python2-dnf-plugins-qubes-hooks
  165. DNF plugin for Qubes specific post-installation actions:
  166. * notify dom0 that updates were installed
  167. * refresh applications shortcut list
  168. %package -n python3-dnf-plugins-qubes-hooks
  169. Summary: DNF plugin for Qubes specific post-installation actions
  170. BuildRequires: python3-devel
  171. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  172. %description -n python3-dnf-plugins-qubes-hooks
  173. DNF plugin for Qubes specific post-installation actions:
  174. * notify dom0 that updates were installed
  175. * refresh applications shortcut list
  176. %define _builddir %(pwd)
  177. %define kde_service_dir /usr/share/kde4/services
  178. %description
  179. The Qubes core files for installation inside a Qubes VM.
  180. %prep
  181. # we operate on the current directory, so no need to unpack anything
  182. # symlink is to generate useful debuginfo packages
  183. rm -f %{name}-%{version}
  184. ln -sf . %{name}-%{version}
  185. %setup -T -D
  186. %build
  187. for dir in qubes-rpc qrexec misc; do
  188. (cd $dir; make)
  189. done
  190. %pre
  191. # Make sure there is a qubes group
  192. groupadd --force --system --gid 98 qubes
  193. id -u 'user' >/dev/null 2>&1 || {
  194. useradd --user-group --create-home --shell /bin/bash user
  195. }
  196. usermod -a --groups qubes user
  197. if [ "$1" != 1 ] ; then
  198. # do this whole %%pre thing only when updating for the first time...
  199. exit 0
  200. fi
  201. mkdir -p /var/lib/qubes
  202. if [ -e /etc/fstab ] ; then
  203. mv /etc/fstab /var/lib/qubes/fstab.orig
  204. fi
  205. usermod -p '' root
  206. usermod -L user
  207. %install
  208. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  209. make install-vm DESTDIR=$RPM_BUILD_ROOT
  210. %if %{fedora} >= 22
  211. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  212. %endif
  213. %triggerin -- initscripts
  214. if [ -e /etc/init/serial.conf ]; then
  215. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  216. fi
  217. %post
  218. # disable some Upstart services
  219. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  220. if [ -e /etc/init/$F.conf ]; then
  221. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  222. fi
  223. done
  224. # Create NetworkManager configuration if we do not have it
  225. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  226. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  227. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  228. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  229. fi
  230. /usr/lib/qubes/qubes-fix-nm-conf.sh
  231. # Remove ip_forward setting from sysctl, so NM will not reset it
  232. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  233. # Remove old firmware updates link
  234. if [ -L /lib/firmware/updates ]; then
  235. rm -f /lib/firmware/updates
  236. fi
  237. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  238. echo >> /etc/yum.conf
  239. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  240. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  241. fi
  242. # And actually setup the proxy usage in package managers
  243. /usr/lib/qubes/update-proxy-configs
  244. # Location of files which contains list of protected files
  245. mkdir -p /etc/qubes/protected-files.d
  246. . /usr/lib/qubes/init/functions
  247. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  248. if ! is_protected_file /etc/hosts ; then
  249. if ! grep -q localhost /etc/hosts; then
  250. cat <<EOF > /etc/hosts
  251. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  252. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  253. EOF
  254. fi
  255. fi
  256. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  257. # in the form expected by qubes-sysinit.sh
  258. if ! is_protected_file /etc/hostname ; then
  259. for ip in '127\.0\.0\.1' '::1'; do
  260. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  261. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  262. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  263. else
  264. echo "${ip} `hostname`" >> /etc/hosts
  265. fi
  266. done
  267. fi
  268. %if %{fedora} >= 20
  269. # Make sure there is a default locale set so gnome-terminal will start
  270. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  271. touch /etc/locale.conf
  272. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  273. fi
  274. # ... and make sure it is really generated
  275. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  276. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  277. base=`echo "$current_locale" | cut -f 1 -d .`
  278. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  279. [ -n "$charmap" ] && charmap="-f $charmap"
  280. localedef -i $base $charmap $current_locale
  281. fi
  282. %endif
  283. if [ "$1" != 1 ] ; then
  284. # do the rest of %%post thing only when updating for the first time...
  285. exit 0
  286. fi
  287. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  288. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  289. fi
  290. # Remove most of the udev scripts to speed up the VM boot time
  291. # Just leave the xen* scripts, that are needed if this VM was
  292. # ever used as a net backend (e.g. as a VPN domain in the future)
  293. #echo "--> Removing unnecessary udev scripts..."
  294. mkdir -p /var/lib/qubes/removed-udev-scripts
  295. for f in /etc/udev/rules.d/*
  296. do
  297. if [ $(basename $f) == "xen-backend.rules" ] ; then
  298. continue
  299. fi
  300. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  301. continue
  302. fi
  303. if echo $f | grep -q qubes; then
  304. continue
  305. fi
  306. mv $f /var/lib/qubes/removed-udev-scripts/
  307. done
  308. mkdir -p /rw
  309. #rm -f /etc/mtab
  310. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  311. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  312. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  313. %triggerin -- notification-daemon
  314. # Enable autostart of notification-daemon when installed
  315. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  316. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  317. fi
  318. exit 0
  319. %triggerin -- selinux-policy
  320. #echo "--> Disabling SELinux..."
  321. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  322. mv /etc/selinux/config.processed /etc/selinux/config
  323. setenforce 0 2>/dev/null
  324. exit 0
  325. %preun
  326. if [ "$1" = 0 ] ; then
  327. # no more packages left
  328. if [ -e /var/lib/qubes/fstab.orig ] ; then
  329. mv /var/lib/qubes/fstab.orig /etc/fstab
  330. fi
  331. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  332. if [ -e /var/lib/qubes/serial.orig ] ; then
  333. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  334. fi
  335. fi
  336. %postun
  337. if [ $1 -eq 0 ] ; then
  338. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  339. if [ -L /lib/firmware/updates ]; then
  340. rm /lib/firmware/updates
  341. fi
  342. rm -rf /var/lib/qubes/xdg
  343. fi
  344. %posttrans
  345. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  346. %clean
  347. rm -rf $RPM_BUILD_ROOT
  348. rm -f %{name}-%{version}
  349. %files
  350. %defattr(-,root,root,-)
  351. %dir /var/lib/qubes
  352. %dir /var/run/qubes
  353. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  354. %{kde_service_dir}/qvm-copy.desktop
  355. %{kde_service_dir}/qvm-move.desktop
  356. %{kde_service_dir}/qvm-dvm.desktop
  357. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  358. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  359. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  360. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  361. /etc/fstab
  362. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  363. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  364. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  365. %dir /etc/qubes-rpc
  366. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  367. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  368. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  369. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  370. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  371. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  372. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  373. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  374. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  375. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  376. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  377. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  378. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  379. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  380. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  381. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  382. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  383. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  384. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  385. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  386. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  387. %dir /etc/qubes/autostart
  388. /etc/qubes/autostart/README.txt
  389. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  390. %dir /etc/qubes/suspend-pre.d
  391. /etc/qubes/suspend-pre.d/README
  392. %dir /etc/qubes/suspend-post.d
  393. /etc/qubes/suspend-post.d/README
  394. %config(noreplace) /etc/sudoers.d/qubes
  395. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  396. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  397. %config(noreplace) /etc/qubes/iptables.rules
  398. %config(noreplace) /etc/qubes/ip6tables.rules
  399. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  400. %config(noreplace) /etc/tinyproxy/updates-blacklist
  401. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  402. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  403. %config(noreplace) /etc/qubes-suspend-module-blacklist
  404. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  405. /etc/xen/scripts/vif-route-qubes
  406. /etc/xen/scripts/vif-qubes-nat.sh
  407. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  408. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  409. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  410. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  411. %if %{fedora} < 22
  412. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  413. %endif
  414. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  415. /usr/sbin/qubes-serial-login
  416. /usr/bin/qvm-copy-to-vm
  417. /usr/bin/qvm-move-to-vm
  418. /usr/bin/qvm-open-in-dvm
  419. /usr/bin/qvm-open-in-vm
  420. /usr/bin/qvm-run
  421. /usr/bin/qvm-features-request
  422. /usr/bin/xenstore-watch-qubes
  423. /usr/bin/qubes-desktop-run
  424. /usr/bin/qubes-open
  425. /usr/bin/qrexec-fork-server
  426. /usr/bin/qrexec-client-vm
  427. /usr/bin/qubes-session-autostart
  428. %dir /usr/lib/qubes
  429. /usr/lib/qubes/vusb-ctl.py*
  430. /usr/lib/qubes/dispvm-prerun.sh
  431. /usr/lib/qubes/sync-ntp-clock
  432. /usr/lib/qubes/prepare-suspend
  433. /usr/lib/qubes/network-manager-prepare-conf-dir
  434. /usr/lib/qubes/show-hide-nm-applet.sh
  435. /usr/lib/qubes/qrexec-agent
  436. /usr/lib/qubes/qrexec-client-vm
  437. /usr/lib/qubes/qrexec_client_vm
  438. /usr/lib/qubes/qubes-rpc-multiplexer
  439. /usr/lib/qubes/qfile-agent
  440. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  441. /usr/lib/qubes/qopen-in-vm
  442. /usr/lib/qubes/qrun-in-vm
  443. /usr/lib/qubes/qubes-download-dom0-updates.sh
  444. /usr/lib/qubes/qubes-fix-nm-conf.sh
  445. /usr/lib/qubes/qubes-setup-dnat-to-ns
  446. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  447. /usr/lib/qubes/qvm-copy-to-vm.gnome
  448. /usr/lib/qubes/qvm-copy-to-vm.kde
  449. /usr/lib/qubes/qvm-move-to-vm.gnome
  450. /usr/lib/qubes/qvm-move-to-vm.kde
  451. /usr/lib/qubes/setup-ip
  452. /usr/lib/qubes/tar2qfile
  453. /usr/lib/qubes/vm-file-editor
  454. /usr/lib/qubes/iptables-updates-proxy
  455. /usr/lib/qubes/close-window
  456. /usr/lib/qubes/xdg-icon
  457. /usr/lib/qubes/update-proxy-configs
  458. /usr/lib/qubes/upgrades-installed-check
  459. /usr/lib/qubes/upgrades-status-notify
  460. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  461. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  462. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  463. %dir /usr/lib/qubes/init
  464. /usr/lib/qubes/init/*.sh
  465. /usr/lib/qubes/init/functions
  466. %dir /usr/lib/qubes-bind-dirs.d
  467. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  468. /usr/lib/python2.7/site-packages/qubesxdg.py*
  469. /usr/sbin/qubes-firewall
  470. /usr/share/qubes/serial.conf
  471. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  472. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  473. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  474. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  475. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  476. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  477. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  478. %dir %{python3_sitelib}/qubesagent-*.egg-info
  479. %{python3_sitelib}/qubesagent-*.egg-info/*
  480. %dir %{python3_sitelib}/qubesagent
  481. %dir %{python3_sitelib}/qubesagent/__pycache__
  482. %{python3_sitelib}/qubesagent/__pycache__/*
  483. %{python3_sitelib}/qubesagent/__init__.py
  484. %{python3_sitelib}/qubesagent/firewall.py
  485. %{python3_sitelib}/qubesagent/test_firewall.py
  486. /usr/share/qubes/mime-override/globs
  487. /usr/share/qubes/qubes-master-key.asc
  488. %dir /home_volatile
  489. %attr(700,user,user) /home_volatile/user
  490. %dir /mnt/removable
  491. %dir /rw
  492. %files -n python2-dnf-plugins-qubes-hooks
  493. %{python2_sitelib}/dnf-plugins/*
  494. %files -n python3-dnf-plugins-qubes-hooks
  495. %{python3_sitelib}/dnf-plugins/*
  496. %package sysvinit
  497. Summary: Qubes unit files for SysV init style or upstart
  498. License: GPL v2 only
  499. Group: Qubes
  500. Requires: upstart
  501. Requires: qubes-core-vm
  502. Provides: qubes-core-vm-init-scripts
  503. Conflicts: qubes-core-vm-systemd
  504. %description sysvinit
  505. The Qubes core startup configuration for SysV init (or upstart).
  506. %files sysvinit
  507. /etc/init.d/qubes-sysinit
  508. /etc/init.d/qubes-core-early
  509. /etc/init.d/qubes-core
  510. /etc/init.d/qubes-dvm
  511. /etc/init.d/qubes-core-netvm
  512. /etc/init.d/qubes-firewall
  513. /etc/init.d/qubes-iptables
  514. /etc/init.d/qubes-updates-proxy
  515. /etc/init.d/qubes-qrexec-agent
  516. /etc/sysconfig/modules/qubes-core.modules
  517. /etc/sysconfig/modules/qubes-misc.modules
  518. %post sysvinit
  519. #echo "--> Turning off unnecessary services..."
  520. # FIXME: perhaps there is more elegant way to do this?
  521. for f in /etc/init.d/*
  522. do
  523. srv=`basename $f`
  524. [ $srv = 'functions' ] && continue
  525. [ $srv = 'killall' ] && continue
  526. [ $srv = 'halt' ] && continue
  527. [ $srv = 'single' ] && continue
  528. [ $srv = 'reboot' ] && continue
  529. [ $srv = 'qubes-gui' ] && continue
  530. chkconfig $srv off
  531. done
  532. #echo "--> Enabling essential services..."
  533. chkconfig rsyslog on
  534. chkconfig haldaemon on
  535. chkconfig messagebus on
  536. for svc in %qubes_services ; do
  537. if [ "$1" = 1 ] ; then
  538. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  539. else
  540. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  541. fi
  542. done
  543. # dropped services
  544. chkconfig qubes-netwatcher off || :
  545. # TODO: make this not display the silly message about security context...
  546. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  547. %preun sysvinit
  548. if [ "$1" = 0 ] ; then
  549. # no more packages left
  550. for svc in %qubes_services ; do
  551. chkconfig --del $svc
  552. done
  553. fi
  554. %package systemd
  555. Summary: Qubes unit files for SystemD init style
  556. License: GPL v2 only
  557. Group: Qubes
  558. Requires: systemd
  559. Requires(post): systemd-units
  560. Requires(preun): systemd-units
  561. Requires(postun): systemd-units
  562. Requires: qubes-core-vm
  563. Provides: qubes-core-vm-init-scripts
  564. Conflicts: qubes-core-vm-sysvinit
  565. %description systemd
  566. The Qubes core startup configuration for SystemD init.
  567. %files systemd
  568. %defattr(-,root,root,-)
  569. /lib/systemd/system/qubes-dvm.service
  570. /lib/systemd/system/qubes-misc-post.service
  571. /lib/systemd/system/qubes-firewall.service
  572. /lib/systemd/system/qubes-mount-dirs.service
  573. /lib/systemd/system/qubes-network.service
  574. /lib/systemd/system/qubes-iptables.service
  575. /lib/systemd/system/qubes-sysinit.service
  576. /lib/systemd/system/qubes-early-vm-config.service
  577. /lib/systemd/system/qubes-update-check.service
  578. /lib/systemd/system/qubes-update-check.timer
  579. /lib/systemd/system/qubes-updates-proxy.service
  580. /lib/systemd/system/qubes-qrexec-agent.service
  581. /lib/systemd/system-preset/%qubes_preset_file
  582. /lib/modules-load.d/qubes-core.conf
  583. /lib/modules-load.d/qubes-misc.conf
  584. /usr/lib/qubes/init/qubes-iptables
  585. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  586. /lib/systemd/system/crond.service.d/30_qubes.conf
  587. /lib/systemd/system/cups.service.d/30_qubes.conf
  588. /lib/systemd/system/cups.socket.d/30_qubes.conf
  589. /lib/systemd/system/cups.path.d/30_qubes.conf
  590. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  591. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  592. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  593. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  594. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  595. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  596. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  597. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  598. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  599. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  600. /lib/systemd/system/tor.service.d/30_qubes.conf
  601. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  602. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  603. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  604. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  605. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  606. %post systemd
  607. changed=
  608. %scriptletfuns
  609. if [ $1 -eq 1 ]
  610. then
  611. preset_units %{_presetdir}/%qubes_preset_file initial
  612. changed=true
  613. else
  614. preset_units %{_presetdir}/%qubes_preset_file upgrade
  615. changed=true
  616. # Upgrade path - now qubes-iptables is used instead
  617. for svc in iptables ip6tables
  618. do
  619. if [ -f "$svc".service ]
  620. then
  621. systemctl --no-reload preset "$svc".service
  622. changed=true
  623. fi
  624. done
  625. fi
  626. if [ $1 -eq 1 ]
  627. then
  628. # First install.
  629. # Set default "runlevel".
  630. # FIXME: this ought to be done via kernel command line.
  631. # The fewer deviations of the template from the seed
  632. # image, the better.
  633. rm -f %{_sysconfdir}/systemd/system/default.target
  634. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  635. changed=true
  636. fi
  637. # remove old symlinks
  638. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  639. then
  640. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  641. changed=true
  642. fi
  643. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  644. then
  645. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  646. changed=true
  647. fi
  648. if [ "x$changed" != "x" ]
  649. then
  650. systemctl daemon-reload
  651. fi
  652. %preun systemd
  653. if [ $1 -eq 0 ] ; then
  654. # Run this only during uninstall.
  655. # Save the preset file to later use it to re-preset services there
  656. # once the Qubes OS preset file is removed.
  657. mkdir -p %{_rundir}/qubes-uninstall
  658. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  659. fi
  660. %postun systemd
  661. changed=
  662. %scriptletfuns
  663. if [ -d %{_rundir}/qubes-uninstall ]
  664. then
  665. # We have a saved preset file (or more).
  666. # Re-preset the units mentioned there.
  667. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  668. rm -rf %{_rundir}/qubes-uninstall
  669. changed=true
  670. fi
  671. if [ "x$changed" != "x" ]
  672. then
  673. systemctl daemon-reload
  674. fi