core-agent.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: zenity
  136. Requires: qubes-libvchan
  137. Requires: qubes-db-vm
  138. %if 0%{fedora} >= 23
  139. Requires: python3-dnf-plugins-qubes-hooks
  140. %else
  141. Requires: python2-dnf-plugins-qubes-hooks
  142. %endif
  143. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  144. Obsoletes: qubes-upgrade-vm < 3.2
  145. Provides: qubes-core-vm = %{version}-%{release}
  146. Obsoletes: qubes-core-vm < 4.0.0
  147. Provides: qubes-core-vm-doc = %{version}-%{release}
  148. Obsoletes: qubes-core-vm-doc < 4.0.0
  149. BuildRequires: pandoc
  150. BuildRequires: xen-devel
  151. BuildRequires: libX11-devel
  152. BuildRequires: qubes-utils-devel >= 3.1.3
  153. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  154. %description
  155. The Qubes core files for installation inside a Qubes VM.
  156. %package -n python2-dnf-plugins-qubes-hooks
  157. Summary: DNF plugin for Qubes specific post-installation actions
  158. BuildRequires: python2-devel
  159. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  160. %description -n python2-dnf-plugins-qubes-hooks
  161. DNF plugin for Qubes specific post-installation actions:
  162. * notify dom0 that updates were installed
  163. * refresh applications shortcut list
  164. %package -n python3-dnf-plugins-qubes-hooks
  165. Summary: DNF plugin for Qubes specific post-installation actions
  166. BuildRequires: python3-devel
  167. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  168. %description -n python3-dnf-plugins-qubes-hooks
  169. DNF plugin for Qubes specific post-installation actions:
  170. * notify dom0 that updates were installed
  171. * refresh applications shortcut list
  172. %package nautilus
  173. Summary: Qubes integration for Nautilus
  174. Requires: qubes-core-agent
  175. Requires: nautilus-python
  176. Conflicts: qubes-core-vm < 4.0.0
  177. %description nautilus
  178. Nautilus addons for inter-VM file copy/move/open.
  179. %package dom0-updates
  180. Summary: Scripts required to handle dom0 updates
  181. Requires: qubes-core-agent
  182. Requires: fakeroot
  183. Conflicts: qubes-core-vm < 4.0.0
  184. %description dom0-updates
  185. Scripts required to handle dom0 updates.
  186. %package networking
  187. Summary: Networking support for Qubes VM
  188. Requires: ethtool
  189. Requires: net-tools
  190. Requires: nftables
  191. Requires: nmap-ncat
  192. Requires: qubes-core-agent
  193. Requires: tinyproxy
  194. Conflicts: qubes-core-vm < 4.0.0
  195. %description networking
  196. This package provides:
  197. * basic network functionality (setting IP address, DNS, default gateway)
  198. * proxy service used by TemplateVMs to download updates
  199. * qubes-firewall service (FirewallVM)
  200. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  201. qubes-core-agent-network-manager.
  202. %package network-manager
  203. Summary: NetworkManager integration for Qubes VM
  204. # to show/hide nm-applet
  205. Requires: NetworkManager >= 0.8.1-1
  206. Requires: dconf
  207. Requires: qubes-core-agent-networking
  208. Conflicts: qubes-core-vm < 4.0.0
  209. %description network-manager
  210. Integration of NetworkManager for Qubes VM:
  211. * make connections config persistent
  212. * adjust DNS redirections when needed
  213. * show/hide NetworkManager applet icon
  214. %define _builddir %(pwd)
  215. %define kde_service_dir /usr/share/kde4/services
  216. %prep
  217. # we operate on the current directory, so no need to unpack anything
  218. # symlink is to generate useful debuginfo packages
  219. rm -f %{name}-%{version}
  220. ln -sf . %{name}-%{version}
  221. %setup -T -D
  222. %build
  223. for dir in qubes-rpc qrexec misc; do
  224. (cd $dir; make)
  225. done
  226. make -C doc manpages
  227. %pre
  228. # Make sure there is a qubes group
  229. groupadd --force --system --gid 98 qubes
  230. id -u 'user' >/dev/null 2>&1 || {
  231. useradd --user-group --create-home --shell /bin/bash user
  232. }
  233. usermod -a --groups qubes user
  234. if [ "$1" != 1 ] ; then
  235. # do this whole %%pre thing only when updating for the first time...
  236. exit 0
  237. fi
  238. mkdir -p /var/lib/qubes
  239. if [ -e /etc/fstab ] ; then
  240. mv /etc/fstab /var/lib/qubes/fstab.orig
  241. fi
  242. usermod -p '' root
  243. usermod -L user
  244. %install
  245. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  246. make install-vm DESTDIR=$RPM_BUILD_ROOT
  247. make -C doc install DESTDIR=$RPM_BUILD_ROOT
  248. %if %{fedora} >= 22
  249. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  250. %endif
  251. %triggerin -- initscripts
  252. if [ -e /etc/init/serial.conf ]; then
  253. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  254. fi
  255. %post
  256. # disable some Upstart services
  257. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  258. if [ -e /etc/init/$F.conf ]; then
  259. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  260. fi
  261. done
  262. # Remove old firmware updates link
  263. if [ -L /lib/firmware/updates ]; then
  264. rm -f /lib/firmware/updates
  265. fi
  266. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  267. echo >> /etc/yum.conf
  268. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  269. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  270. fi
  271. # And actually setup the proxy usage in package managers
  272. /usr/lib/qubes/update-proxy-configs
  273. # Location of files which contains list of protected files
  274. mkdir -p /etc/qubes/protected-files.d
  275. . /usr/lib/qubes/init/functions
  276. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  277. if ! is_protected_file /etc/hosts ; then
  278. if ! grep -q localhost /etc/hosts; then
  279. cat <<EOF > /etc/hosts
  280. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  281. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  282. EOF
  283. fi
  284. fi
  285. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  286. # in the form expected by qubes-sysinit.sh
  287. if ! is_protected_file /etc/hostname ; then
  288. for ip in '127\.0\.0\.1' '::1'; do
  289. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  290. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  291. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  292. else
  293. echo "${ip} `hostname`" >> /etc/hosts
  294. fi
  295. done
  296. fi
  297. %if %{fedora} >= 20
  298. # Make sure there is a default locale set so gnome-terminal will start
  299. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  300. touch /etc/locale.conf
  301. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  302. fi
  303. # ... and make sure it is really generated
  304. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  305. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  306. base=`echo "$current_locale" | cut -f 1 -d .`
  307. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  308. [ -n "$charmap" ] && charmap="-f $charmap"
  309. localedef -i $base $charmap $current_locale
  310. fi
  311. %endif
  312. if [ "$1" != 1 ] ; then
  313. # do the rest of %%post thing only when updating for the first time...
  314. exit 0
  315. fi
  316. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  317. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  318. fi
  319. # Remove most of the udev scripts to speed up the VM boot time
  320. # Just leave the xen* scripts, that are needed if this VM was
  321. # ever used as a net backend (e.g. as a VPN domain in the future)
  322. #echo "--> Removing unnecessary udev scripts..."
  323. mkdir -p /var/lib/qubes/removed-udev-scripts
  324. for f in /etc/udev/rules.d/*
  325. do
  326. if [ $(basename $f) == "xen-backend.rules" ] ; then
  327. continue
  328. fi
  329. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  330. continue
  331. fi
  332. if echo $f | grep -q qubes; then
  333. continue
  334. fi
  335. mv $f /var/lib/qubes/removed-udev-scripts/
  336. done
  337. mkdir -p /rw
  338. #rm -f /etc/mtab
  339. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  340. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  341. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  342. %triggerin -- notification-daemon
  343. # Enable autostart of notification-daemon when installed
  344. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  345. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  346. fi
  347. exit 0
  348. %triggerin -- selinux-policy
  349. #echo "--> Disabling SELinux..."
  350. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  351. mv /etc/selinux/config.processed /etc/selinux/config
  352. setenforce 0 2>/dev/null
  353. exit 0
  354. %post network-manager
  355. # Create NetworkManager configuration if we do not have it
  356. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  357. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  358. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  359. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  360. fi
  361. # Remove ip_forward setting from sysctl, so NM will not reset it
  362. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  363. /usr/lib/qubes/qubes-fix-nm-conf.sh
  364. %preun
  365. if [ "$1" = 0 ] ; then
  366. # no more packages left
  367. if [ -e /var/lib/qubes/fstab.orig ] ; then
  368. mv /var/lib/qubes/fstab.orig /etc/fstab
  369. fi
  370. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  371. if [ -e /var/lib/qubes/serial.orig ] ; then
  372. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  373. fi
  374. fi
  375. %postun
  376. if [ $1 -eq 0 ] ; then
  377. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  378. if [ -L /lib/firmware/updates ]; then
  379. rm /lib/firmware/updates
  380. fi
  381. rm -rf /var/lib/qubes/xdg
  382. fi
  383. %posttrans
  384. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  385. %clean
  386. rm -rf $RPM_BUILD_ROOT
  387. rm -f %{name}-%{version}
  388. %files
  389. %defattr(-,root,root,-)
  390. %dir /var/lib/qubes
  391. %dir /var/run/qubes
  392. %{kde_service_dir}/qvm-copy.desktop
  393. %{kde_service_dir}/qvm-move.desktop
  394. %{kde_service_dir}/qvm-dvm.desktop
  395. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  396. /etc/fstab
  397. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  398. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  399. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  400. %dir /etc/qubes-rpc
  401. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  402. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  403. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  404. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  405. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  406. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  407. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  408. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  409. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  410. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  411. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  412. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  413. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  414. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  415. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  416. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  417. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  418. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  419. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  420. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  421. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  422. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  423. %dir /etc/qubes/autostart
  424. /etc/qubes/autostart/README.txt
  425. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  426. %dir /etc/qubes/suspend-pre.d
  427. /etc/qubes/suspend-pre.d/README
  428. %dir /etc/qubes/suspend-post.d
  429. /etc/qubes/suspend-post.d/README
  430. %dir /etc/qubes/post-install.d
  431. /etc/qubes/post-install.d/README
  432. /etc/qubes/post-install.d/*.sh
  433. %config(noreplace) /etc/sudoers.d/qubes
  434. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  435. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  436. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  437. %config(noreplace) /etc/qubes-suspend-module-blacklist
  438. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  439. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  440. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  441. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  442. %if %{fedora} < 22
  443. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  444. %endif
  445. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  446. /usr/sbin/qubes-serial-login
  447. /usr/bin/qvm-copy-to-vm
  448. /usr/bin/qvm-move-to-vm
  449. /usr/bin/qvm-open-in-dvm
  450. /usr/bin/qvm-open-in-vm
  451. /usr/bin/qvm-run-vm
  452. /usr/bin/qvm-features-request
  453. /usr/bin/xenstore-watch-qubes
  454. /usr/bin/qubes-desktop-run
  455. /usr/bin/qubes-open
  456. /usr/bin/qrexec-fork-server
  457. /usr/bin/qrexec-client-vm
  458. /usr/bin/qubes-session-autostart
  459. %dir /usr/lib/qubes
  460. /usr/lib/qubes/vusb-ctl.py*
  461. /usr/lib/qubes/sync-ntp-clock
  462. /usr/lib/qubes/prepare-suspend
  463. /usr/lib/qubes/qrexec-agent
  464. /usr/lib/qubes/qrexec-client-vm
  465. /usr/lib/qubes/qrexec_client_vm
  466. /usr/lib/qubes/qubes-rpc-multiplexer
  467. /usr/lib/qubes/qfile-agent
  468. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  469. /usr/lib/qubes/qopen-in-vm
  470. /usr/lib/qubes/qrun-in-vm
  471. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  472. /usr/lib/qubes/qvm-copy-to-vm.kde
  473. /usr/lib/qubes/qvm-move-to-vm.kde
  474. /usr/lib/qubes/tar2qfile
  475. /usr/lib/qubes/vm-file-editor
  476. /usr/lib/qubes/close-window
  477. /usr/lib/qubes/xdg-icon
  478. /usr/lib/qubes/update-proxy-configs
  479. /usr/lib/qubes/upgrades-installed-check
  480. /usr/lib/qubes/upgrades-status-notify
  481. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  482. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  483. %dir /usr/lib/qubes/init
  484. /usr/lib/qubes/init/bind-dirs.sh
  485. /usr/lib/qubes/init/control-printer-icon.sh
  486. /usr/lib/qubes/init/functions
  487. /usr/lib/qubes/init/misc-post-stop.sh
  488. /usr/lib/qubes/init/misc-post.sh
  489. /usr/lib/qubes/init/mount-dirs.sh
  490. /usr/lib/qubes/init/qubes-early-vm-config.sh
  491. /usr/lib/qubes/init/qubes-random-seed.sh
  492. /usr/lib/qubes/init/qubes-sysinit.sh
  493. /usr/lib/qubes/init/setup-rw.sh
  494. /usr/lib/qubes/init/setup-rwdev.sh
  495. /usr/lib/qubes/init/functions
  496. %dir /usr/lib/qubes-bind-dirs.d
  497. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  498. /usr/lib/python2.7/site-packages/qubesxdg.py*
  499. /usr/share/qubes/serial.conf
  500. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  501. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  502. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  503. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  504. %{_mandir}/man1/qvm-*.1*
  505. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  506. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  507. %dir %{python_sitelib}/qubesagent
  508. %{python_sitelib}/qubesagent/__init__.py*
  509. %{python_sitelib}/qubesagent/firewall.py*
  510. %{python_sitelib}/qubesagent/test_firewall.py*
  511. /usr/share/qubes/mime-override/globs
  512. /usr/share/qubes/qubes-master-key.asc
  513. %dir /mnt/removable
  514. %dir /rw
  515. %files -n python2-dnf-plugins-qubes-hooks
  516. %{python2_sitelib}/dnf-plugins/*
  517. %files -n python3-dnf-plugins-qubes-hooks
  518. %{python3_sitelib}/dnf-plugins/*
  519. %files nautilus
  520. /usr/lib/qubes/qvm-copy-to-vm.gnome
  521. /usr/lib/qubes/qvm-move-to-vm.gnome
  522. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  523. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  524. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  525. %files dom0-updates
  526. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  527. /usr/lib/qubes/qubes-download-dom0-updates.sh
  528. %files networking
  529. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  530. %config(noreplace) /etc/qubes/ip6tables.rules
  531. %config(noreplace) /etc/qubes/iptables.rules
  532. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  533. %config(noreplace) /etc/tinyproxy/updates-blacklist
  534. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  535. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  536. /etc/xen/scripts/vif-qubes-nat.sh
  537. /etc/xen/scripts/vif-route-qubes
  538. /lib/systemd/system/qubes-firewall.service
  539. /lib/systemd/system/qubes-iptables.service
  540. /lib/systemd/system/qubes-network.service
  541. /lib/systemd/system/qubes-updates-proxy.service
  542. /usr/lib/qubes/init/network-proxy-setup.sh
  543. /usr/lib/qubes/init/qubes-iptables
  544. /usr/lib/qubes/iptables-updates-proxy
  545. /usr/lib/qubes/qubes-setup-dnat-to-ns
  546. /usr/lib/qubes/setup-ip
  547. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  548. /usr/sbin/qubes-firewall
  549. %files network-manager
  550. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  551. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  552. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  553. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  554. /usr/lib/qubes/network-manager-prepare-conf-dir
  555. /usr/lib/qubes/qubes-fix-nm-conf.sh
  556. /usr/lib/qubes/show-hide-nm-applet.sh
  557. %package sysvinit
  558. Summary: Qubes unit files for SysV init style or upstart
  559. License: GPL v2 only
  560. Group: Qubes
  561. Requires: upstart
  562. Requires: qubes-core-agent
  563. Requires: qubes-core-agent-networking
  564. Provides: qubes-core-agent-init-scripts
  565. Conflicts: qubes-core-agent-systemd
  566. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  567. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  568. %description sysvinit
  569. The Qubes core startup configuration for SysV init (or upstart).
  570. %files sysvinit
  571. /etc/init.d/qubes-sysinit
  572. /etc/init.d/qubes-core-early
  573. /etc/init.d/qubes-core
  574. /etc/init.d/qubes-core-netvm
  575. /etc/init.d/qubes-firewall
  576. /etc/init.d/qubes-iptables
  577. /etc/init.d/qubes-updates-proxy
  578. /etc/init.d/qubes-qrexec-agent
  579. /etc/init.d/qubes-updates-proxy-forwarder
  580. /etc/sysconfig/modules/qubes-core.modules
  581. /etc/sysconfig/modules/qubes-misc.modules
  582. %post sysvinit
  583. #echo "--> Turning off unnecessary services..."
  584. # FIXME: perhaps there is more elegant way to do this?
  585. for f in /etc/init.d/*
  586. do
  587. srv=`basename $f`
  588. [ $srv = 'functions' ] && continue
  589. [ $srv = 'killall' ] && continue
  590. [ $srv = 'halt' ] && continue
  591. [ $srv = 'single' ] && continue
  592. [ $srv = 'reboot' ] && continue
  593. [ $srv = 'qubes-gui' ] && continue
  594. chkconfig $srv off
  595. done
  596. #echo "--> Enabling essential services..."
  597. chkconfig rsyslog on
  598. chkconfig haldaemon on
  599. chkconfig messagebus on
  600. for svc in %qubes_services ; do
  601. if [ "$1" = 1 ] ; then
  602. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  603. else
  604. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  605. fi
  606. done
  607. # dropped services
  608. chkconfig qubes-netwatcher off || :
  609. # TODO: make this not display the silly message about security context...
  610. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  611. %preun sysvinit
  612. if [ "$1" = 0 ] ; then
  613. # no more packages left
  614. for svc in %qubes_services ; do
  615. chkconfig --del $svc
  616. done
  617. fi
  618. %package systemd
  619. Summary: Qubes unit files for SystemD init style
  620. License: GPL v2 only
  621. Group: Qubes
  622. Requires: systemd
  623. Requires(post): systemd-units
  624. Requires(preun): systemd-units
  625. Requires(postun): systemd-units
  626. Requires: qubes-core-agent
  627. Provides: qubes-core-agent-init-scripts
  628. Conflicts: qubes-core-agent-sysvinit
  629. Provides: qubes-core-vm-systemd = %{version}-%{release}
  630. Obsoletes: qubes-core-vm-systemd < 4.0.0
  631. %description systemd
  632. The Qubes core startup configuration for SystemD init.
  633. %files systemd
  634. %defattr(-,root,root,-)
  635. /lib/systemd/system/qubes-misc-post.service
  636. /lib/systemd/system/qubes-mount-dirs.service
  637. /lib/systemd/system/qubes-sysinit.service
  638. /lib/systemd/system/qubes-early-vm-config.service
  639. /lib/systemd/system/qubes-update-check.service
  640. /lib/systemd/system/qubes-update-check.timer
  641. /lib/systemd/system/qubes-qrexec-agent.service
  642. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  643. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  644. /lib/systemd/system-preset/%qubes_preset_file
  645. /lib/modules-load.d/qubes-core.conf
  646. /lib/modules-load.d/qubes-misc.conf
  647. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  648. /lib/systemd/system/crond.service.d/30_qubes.conf
  649. /lib/systemd/system/cups.service.d/30_qubes.conf
  650. /lib/systemd/system/cups.socket.d/30_qubes.conf
  651. /lib/systemd/system/cups.path.d/30_qubes.conf
  652. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  653. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  654. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  655. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  656. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  657. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  658. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  659. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  660. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  661. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  662. /lib/systemd/system/tor.service.d/30_qubes.conf
  663. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  664. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  665. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  666. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  667. %post systemd
  668. changed=
  669. %scriptletfuns
  670. if [ $1 -eq 1 ]
  671. then
  672. preset_units %{_presetdir}/%qubes_preset_file initial
  673. changed=true
  674. else
  675. preset_units %{_presetdir}/%qubes_preset_file upgrade
  676. changed=true
  677. # Upgrade path - now qubes-iptables is used instead
  678. for svc in iptables ip6tables
  679. do
  680. if [ -f "$svc".service ]
  681. then
  682. systemctl --no-reload preset "$svc".service
  683. changed=true
  684. fi
  685. done
  686. fi
  687. if [ $1 -eq 1 ]
  688. then
  689. # First install.
  690. # Set default "runlevel".
  691. # FIXME: this ought to be done via kernel command line.
  692. # The fewer deviations of the template from the seed
  693. # image, the better.
  694. rm -f %{_sysconfdir}/systemd/system/default.target
  695. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  696. changed=true
  697. fi
  698. # remove old symlinks
  699. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  700. then
  701. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  702. changed=true
  703. fi
  704. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  705. then
  706. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  707. changed=true
  708. fi
  709. if [ "x$changed" != "x" ]
  710. then
  711. systemctl daemon-reload
  712. fi
  713. %preun systemd
  714. if [ $1 -eq 0 ] ; then
  715. # Run this only during uninstall.
  716. # Save the preset file to later use it to re-preset services there
  717. # once the Qubes OS preset file is removed.
  718. mkdir -p %{_rundir}/qubes-uninstall
  719. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  720. fi
  721. %postun systemd
  722. changed=
  723. %scriptletfuns
  724. if [ -d %{_rundir}/qubes-uninstall ]
  725. then
  726. # We have a saved preset file (or more).
  727. # Re-preset the units mentioned there.
  728. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  729. rm -rf %{_rundir}/qubes-uninstall
  730. changed=true
  731. fi
  732. if [ "x$changed" != "x" ]
  733. then
  734. systemctl daemon-reload
  735. fi