qrexec_disable_all_warnings_as_errors.patch 957 B

12345678910111213141516171819
  1. qrexec: Disable all warnings being treated as errors
  2. gcc -g -O2 -fstack-protector-strong -Wformat -Werror=format-security -I. -g -Wall -Wextra -Werror -pie -fPIC `pkg-config --cflags vchan-xen` -D_FORTIFY_SOURCE=2 -c -o qrexec-agent-data.o qrexec-agent-data.c
  3. qrexec-agent-data.c: In function 'handle_remote_data':
  4. qrexec-agent-data.c:217:17: error: dereferencing type-punned pointer will break strict-aliasing rules [-Werror=strict-aliasing]
  5. status = *(unsigned int *)buf;
  6. ^
  7. cc1: all warnings being treated as errors
  8. <builtin>: recipe for target 'qrexec-agent-data.o' failed
  9. --- a/qrexec/Makefile
  10. +++ b/qrexec/Makefile
  11. @@ -1,5 +1,5 @@
  12. CC=gcc
  13. -CFLAGS+=-I. -g -Wall -Wextra -Werror -pie -fPIC `pkg-config --cflags vchan-$(BACKEND_VMM)`
  14. +CFLAGS+=-I. -g -Wall -Wextra -pie -fPIC `pkg-config --cflags vchan-$(BACKEND_VMM)`
  15. LIBS=`pkg-config --libs vchan-$(BACKEND_VMM)` -lqrexec-utils
  16. all: qrexec-agent qrexec-client-vm