core-vm.spec 22 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Requires: iptables-services
  38. Conflicts: firewalld
  39. %endif
  40. Requires: /usr/bin/mimeopen
  41. Requires: ethtool
  42. Requires: tinyproxy
  43. Requires: ntpdate
  44. Requires: net-tools
  45. Requires: nautilus-actions
  46. Requires: qubes-core-vm-kernel-placeholder
  47. Requires: qubes-utils
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. %if %{fedora} >= 20
  52. # gpk-update-viewer required by qubes-manager
  53. Requires: gnome-packagekit-updater
  54. %endif
  55. Requires: ImageMagick
  56. Requires: fakeroot
  57. Requires: desktop-notification-daemon
  58. Requires: qubes-libvchan
  59. Requires: qubes-db-vm
  60. Provides: qubes-core-vm
  61. Obsoletes: qubes-core-commonvm
  62. Obsoletes: qubes-core-appvm
  63. Obsoletes: qubes-core-netvm
  64. Obsoletes: qubes-core-proxyvm
  65. Obsoletes: qubes-upgrade-vm < 2.0
  66. BuildRequires: xen-devel
  67. BuildRequires: qubes-utils-devel >= 2.0.5
  68. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  69. %define _builddir %(pwd)
  70. %define kde_service_dir /usr/share/kde4/services
  71. %define installOverridenServices() \
  72. UNITDIR=/lib/systemd/system\
  73. OVERRIDEDIR=/usr/lib/qubes/init\
  74. # Install overriden services only when original exists\
  75. for srv in %*; do\
  76. if [ -f $UNITDIR/$srv.service ]; then\
  77. cp $OVERRIDEDIR/$srv.service /etc/systemd/system/\
  78. /bin/systemctl is-enabled $srv.service >/dev/null && /bin/systemctl --no-reload reenable $srv.service 2>/dev/null\
  79. fi\
  80. if [ -f $UNITDIR/$srv.socket -a -f $OVERRIDEDIR/$srv.socket ]; then\
  81. cp $OVERRIDEDIR/$srv.socket /etc/systemd/system/\
  82. /bin/systemctl is-enabled $srv.socket >/dev/null && /bin/systemctl --no-reload reenable $srv.socket 2>/dev/null\
  83. fi\
  84. if [ -f $UNITDIR/$srv.path -a -f $OVERRIDEDIR/$srv.path ]; then\
  85. cp $OVERRIDEDIR/$srv.path /etc/systemd/system/\
  86. /bin/systemctl is-enabled $srv.path >/dev/null && /bin/systemctl --no-reload reenable $srv.path 2>/dev/null\
  87. fi\
  88. done\
  89. /bin/systemctl daemon-reload\
  90. %{nil}
  91. %description
  92. The Qubes core files for installation inside a Qubes VM.
  93. %prep
  94. # we operate on the current directory, so no need to unpack anything
  95. # symlink is to generate useful debuginfo packages
  96. rm -f %{name}-%{version}
  97. ln -sf . %{name}-%{version}
  98. %setup -T -D
  99. %build
  100. for dir in qubes-rpc qrexec misc; do
  101. (cd $dir; make)
  102. done
  103. %pre
  104. if [ "$1" != 1 ] ; then
  105. # do this whole %pre thing only when updating for the first time...
  106. exit 0
  107. fi
  108. mkdir -p /var/lib/qubes
  109. if [ -e /etc/fstab ] ; then
  110. mv /etc/fstab /var/lib/qubes/fstab.orig
  111. fi
  112. adduser --create-home user
  113. usermod -p '' root
  114. usermod -L user
  115. %install
  116. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  117. make install-vm DESTDIR=$RPM_BUILD_ROOT
  118. # Create ghost files to silent rpmbuild warnings, those files will NOT be
  119. # included in package
  120. mkdir -p $RPM_BUILD_ROOT/etc/systemd/system
  121. for f in ModemManager.service NetworkManager.service \
  122. NetworkManager-wait-online.service cups.service cups.socket cups.path; do
  123. cp $RPM_BUILD_ROOT/usr/lib/qubes/init/$f $RPM_BUILD_ROOT/etc/systemd/system/
  124. done
  125. %if %{fedora} < 21
  126. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/iptables $RPM_BUILD_ROOT/etc/sysconfig/iptables
  127. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/ip6tables $RPM_BUILD_ROOT/etc/sysconfig/ip6tables
  128. %endif
  129. %triggerin -- initscripts
  130. if [ -e /etc/init/serial.conf ]; then
  131. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  132. fi
  133. %triggerin -- pulseaudio-module-x11
  134. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/pulseaudio.desktop
  135. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/pulseaudio.desktop
  136. %post
  137. # disable some Upstart services
  138. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  139. if [ -e /etc/init/$F.conf ]; then
  140. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  141. fi
  142. done
  143. remove_ShowIn () {
  144. if [ -e /etc/xdg/autostart/$1.desktop ]; then
  145. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/$1.desktop
  146. fi
  147. }
  148. # reenable if disabled by some earlier version of package
  149. remove_ShowIn abrt-applet.desktop imsettings-start.desktop
  150. # don't want it at all
  151. for F in deja-dup-monitor krb5-auth-dialog pulseaudio restorecond sealertauto gnome-power-manager gnome-sound-applet gnome-screensaver orca-autostart; do
  152. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  153. remove_ShowIn $F
  154. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/$F.desktop
  155. fi
  156. done
  157. # don't want it in DisposableVM
  158. for F in gcm-apply ; do
  159. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  160. remove_ShowIn $F
  161. echo 'NotShowIn=DisposableVM;' >> /etc/xdg/autostart/$F.desktop
  162. fi
  163. done
  164. # want it in AppVM only
  165. for F in gnome-keyring-gpg gnome-keyring-pkcs11 gnome-keyring-secrets gnome-keyring-ssh gnome-settings-daemon user-dirs-update-gtk gsettings-data-convert ; do
  166. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  167. remove_ShowIn $F
  168. echo 'OnlyShowIn=GNOME;AppVM;' >> /etc/xdg/autostart/$F.desktop
  169. fi
  170. done
  171. # remove existing rule to add own later
  172. for F in gpk-update-icon nm-applet ; do
  173. remove_ShowIn $F
  174. done
  175. echo 'OnlyShowIn=GNOME;UpdateableVM;' >> /etc/xdg/autostart/gpk-update-icon.desktop || :
  176. %if %{fedora} >= 20
  177. echo 'OnlyShowIn=GNOME;QUBES;' >> /etc/xdg/autostart/nm-applet.desktop || :
  178. %else
  179. echo 'OnlyShowIn=GNOME;NetVM;' >> /etc/xdg/autostart/nm-applet.desktop || :
  180. %endif
  181. # Create NetworkManager configuration if we do not have it
  182. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  183. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  184. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  185. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  186. fi
  187. /usr/lib/qubes/qubes-fix-nm-conf.sh
  188. # Remove ip_forward setting from sysctl, so NM will not reset it
  189. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  190. # Remove old firmware updates link
  191. if [ -L /lib/firmware/updates ]; then
  192. rm -f /lib/firmware/updates
  193. fi
  194. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  195. echo >> /etc/yum.conf
  196. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  197. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  198. fi
  199. # Revert 'Prevent unnecessary updates in VMs':
  200. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  201. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  202. if ! grep -q localhost /etc/hosts; then
  203. cat <<EOF > /etc/hosts
  204. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  205. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  206. EOF
  207. fi
  208. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  209. # in the form expected by qubes-sysinit.sh
  210. for ip in '127\.0\.0\.1' '::1'; do
  211. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  212. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  213. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  214. else
  215. echo "${ip} `hostname`" >> /etc/hosts
  216. fi
  217. done
  218. # Copy ip(|6)tables into place if they do not already exist in filesystem.
  219. # This prevents conflict with iptables-service
  220. if [ ! -f '/etc/sysconfig/iptables' ]; then
  221. cp -p /usr/lib/qubes/init/iptables /etc/sysconfig/iptables
  222. fi
  223. if [ ! -f '/etc/sysconfig/ip6tables' ]; then
  224. cp -p /usr/lib/qubes/init/ip6tables /etc/sysconfig/ip6tables
  225. fi
  226. if [ "$1" != 1 ] ; then
  227. # do the rest of %post thing only when updating for the first time...
  228. exit 0
  229. fi
  230. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  231. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  232. fi
  233. # Remove most of the udev scripts to speed up the VM boot time
  234. # Just leave the xen* scripts, that are needed if this VM was
  235. # ever used as a net backend (e.g. as a VPN domain in the future)
  236. #echo "--> Removing unnecessary udev scripts..."
  237. mkdir -p /var/lib/qubes/removed-udev-scripts
  238. for f in /etc/udev/rules.d/*
  239. do
  240. if [ $(basename $f) == "xen-backend.rules" ] ; then
  241. continue
  242. fi
  243. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  244. continue
  245. fi
  246. if echo $f | grep -q qubes; then
  247. continue
  248. fi
  249. mv $f /var/lib/qubes/removed-udev-scripts/
  250. done
  251. mkdir -p /rw
  252. #rm -f /etc/mtab
  253. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  254. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  255. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  256. %triggerin -- notification-daemon
  257. # Enable autostart of notification-daemon when installed
  258. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  259. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  260. fi
  261. exit 0
  262. %triggerin -- selinux-policy
  263. #echo "--> Disabling SELinux..."
  264. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  265. mv /etc/selinux/config.processed /etc/selinux/config
  266. setenforce 0 2>/dev/null
  267. exit 0
  268. %preun
  269. if [ "$1" = 0 ] ; then
  270. # no more packages left
  271. if [ -e /var/lib/qubes/fstab.orig ] ; then
  272. mv /var/lib/qubes/fstab.orig /etc/fstab
  273. fi
  274. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  275. if [ -e /var/lib/qubes/serial.orig ] ; then
  276. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  277. fi
  278. fi
  279. %postun
  280. if [ $1 -eq 0 ] ; then
  281. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  282. if [ -L /lib/firmware/updates ]; then
  283. rm /lib/firmware/updates
  284. fi
  285. fi
  286. %posttrans
  287. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  288. %clean
  289. rm -rf $RPM_BUILD_ROOT
  290. rm -f %{name}-%{version}
  291. %files
  292. %defattr(-,root,root,-)
  293. %dir /var/lib/qubes
  294. %dir /var/run/qubes
  295. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  296. %{kde_service_dir}/qvm-copy.desktop
  297. %{kde_service_dir}/qvm-move.desktop
  298. %{kde_service_dir}/qvm-dvm.desktop
  299. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  300. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  301. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  302. /etc/dispvm-dotfiles.tbz
  303. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  304. /etc/fstab
  305. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  306. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  307. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  308. %dir /etc/qubes-rpc
  309. /etc/qubes-rpc/qubes.Filecopy
  310. /etc/qubes-rpc/qubes.OpenInVM
  311. /etc/qubes-rpc/qubes.GetAppmenus
  312. /etc/qubes-rpc/qubes.VMShell
  313. /etc/qubes-rpc/qubes.SyncNtpClock
  314. /etc/qubes-rpc/qubes.SuspendPre
  315. /etc/qubes-rpc/qubes.SuspendPost
  316. /etc/qubes-rpc/qubes.WaitForSession
  317. /etc/qubes-rpc/qubes.DetachPciDevice
  318. /etc/qubes-rpc/qubes.Backup
  319. /etc/qubes-rpc/qubes.Restore
  320. /etc/qubes-rpc/qubes.SelectFile
  321. /etc/qubes-rpc/qubes.SelectDirectory
  322. /etc/qubes-rpc/qubes.GetImageRGBA
  323. /etc/qubes-rpc/qubes.SetDateTime
  324. %config(noreplace) /etc/sudoers.d/qubes
  325. %if %{fedora} < 21
  326. %config(noreplace) /etc/sysconfig/iptables
  327. %config(noreplace) /etc/sysconfig/ip6tables
  328. %endif
  329. /usr/lib/qubes/init/iptables
  330. /usr/lib/qubes/init/ip6tables
  331. %config(noreplace) /etc/tinyproxy/filter-updates
  332. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  333. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  334. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  335. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  336. /etc/xdg/nautilus-actions/nautilus-actions.conf
  337. /etc/xen/scripts/vif-route-qubes
  338. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  339. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  340. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  341. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  342. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  343. /usr/sbin/qubes-serial-login
  344. /usr/bin/qvm-copy-to-vm
  345. /usr/bin/qvm-move-to-vm
  346. /usr/bin/qvm-open-in-dvm
  347. /usr/bin/qvm-open-in-vm
  348. /usr/bin/qvm-run
  349. /usr/bin/qvm-mru-entry
  350. /usr/bin/xenstore-watch-qubes
  351. /usr/bin/qubes-desktop-run
  352. %dir /usr/lib/qubes
  353. /usr/lib/qubes/vusb-ctl.py*
  354. /usr/lib/qubes/dispvm-prerun.sh
  355. /usr/lib/qubes/sync-ntp-clock
  356. /usr/lib/qubes/prepare-suspend
  357. /usr/lib/qubes/network-manager-prepare-conf-dir
  358. /usr/lib/qubes/show-hide-nm-applet.sh
  359. /usr/lib/qubes/qrexec-agent
  360. /usr/lib/qubes/qrexec-client-vm
  361. /usr/lib/qubes/qrexec_client_vm
  362. /usr/lib/qubes/qubes-rpc-multiplexer
  363. /usr/lib/qubes/qfile-agent
  364. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  365. /usr/lib/qubes/qopen-in-vm
  366. /usr/lib/qubes/qrun-in-vm
  367. /usr/lib/qubes/qubes-download-dom0-updates.sh
  368. /usr/lib/qubes/qubes-fix-nm-conf.sh
  369. /usr/lib/qubes/qubes-setup-dnat-to-ns
  370. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  371. /usr/lib/qubes/qvm-copy-to-vm.gnome
  372. /usr/lib/qubes/qvm-copy-to-vm.kde
  373. /usr/lib/qubes/qvm-move-to-vm.gnome
  374. /usr/lib/qubes/qvm-move-to-vm.kde
  375. /usr/lib/qubes/setup-ip
  376. /usr/lib/qubes/tar2qfile
  377. /usr/lib/qubes/vm-file-editor
  378. /usr/lib/qubes/wrap-in-html-if-url.sh
  379. /usr/lib/qubes/iptables-updates-proxy
  380. /usr/lib/qubes/close-window
  381. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  382. /usr/sbin/qubes-firewall
  383. /usr/sbin/qubes-netwatcher
  384. /usr/share/qubes/serial.conf
  385. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  386. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  387. /usr/share/file-manager/actions/qvm-copy-gnome.desktop
  388. /usr/share/file-manager/actions/qvm-move-gnome.desktop
  389. /usr/share/file-manager/actions/qvm-dvm-gnome.desktop
  390. %dir /usr/share/qubes
  391. /usr/share/qubes/mime-override/globs
  392. %dir /home_volatile
  393. %attr(700,user,user) /home_volatile/user
  394. %dir /mnt/removable
  395. %dir /rw
  396. %package sysvinit
  397. Summary: Qubes unit files for SysV init style or upstart
  398. License: GPL v2 only
  399. Group: Qubes
  400. Requires: upstart
  401. Requires: qubes-core-vm
  402. Provides: qubes-core-vm-init-scripts
  403. Conflicts: qubes-core-vm-systemd
  404. %description sysvinit
  405. The Qubes core startup configuration for SysV init (or upstart).
  406. %files sysvinit
  407. /etc/init.d/qubes-core
  408. /etc/init.d/qubes-core-appvm
  409. /etc/init.d/qubes-core-netvm
  410. /etc/init.d/qubes-firewall
  411. /etc/init.d/qubes-netwatcher
  412. /etc/init.d/qubes-updates-proxy
  413. /etc/init.d/qubes-qrexec-agent
  414. /etc/sysconfig/modules/qubes-core.modules
  415. /etc/sysconfig/modules/qubes-misc.modules
  416. %post sysvinit
  417. #echo "--> Turning off unnecessary services..."
  418. # FIXME: perhaps there is more elegant way to do this?
  419. for f in /etc/init.d/*
  420. do
  421. srv=`basename $f`
  422. [ $srv = 'functions' ] && continue
  423. [ $srv = 'killall' ] && continue
  424. [ $srv = 'halt' ] && continue
  425. [ $srv = 'single' ] && continue
  426. [ $srv = 'reboot' ] && continue
  427. [ $srv = 'qubes-gui' ] && continue
  428. chkconfig $srv off
  429. done
  430. #echo "--> Enabling essential services..."
  431. chkconfig rsyslog on
  432. chkconfig haldaemon on
  433. chkconfig messagebus on
  434. chkconfig iptables on
  435. chkconfig ip6tables on
  436. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  437. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  438. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  439. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  440. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  441. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  442. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  443. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  444. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  445. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  446. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  447. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  448. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  449. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  450. # TODO: make this not display the silly message about security context...
  451. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  452. %preun sysvinit
  453. if [ "$1" = 0 ] ; then
  454. # no more packages left
  455. chkconfig qubes-core off
  456. chkconfig qubes-core-netvm off
  457. chkconfig qubes-core-appvm off
  458. chkconfig qubes-firewall off
  459. chkconfig qubes-netwatcher off
  460. chkconfig qubes-updates-proxy off
  461. chkconfig qubes-qrexec-agent off
  462. fi
  463. %package systemd
  464. Summary: Qubes unit files for SystemD init style
  465. License: GPL v2 only
  466. Group: Qubes
  467. Requires: systemd
  468. Requires(post): systemd-units
  469. Requires(preun): systemd-units
  470. Requires(postun): systemd-units
  471. Requires: qubes-core-vm
  472. Provides: qubes-core-vm-init-scripts
  473. Conflicts: qubes-core-vm-sysvinit
  474. %description systemd
  475. The Qubes core startup configuration for SystemD init.
  476. %files systemd
  477. %defattr(-,root,root,-)
  478. /lib/systemd/system/qubes-dvm.service
  479. /lib/systemd/system/qubes-misc-post.service
  480. /lib/systemd/system/qubes-firewall.service
  481. /lib/systemd/system/qubes-netwatcher.service
  482. /lib/systemd/system/qubes-network.service
  483. /lib/systemd/system/qubes-sysinit.service
  484. /lib/systemd/system/qubes-update-check.service
  485. /lib/systemd/system/qubes-update-check.timer
  486. /lib/systemd/system/qubes-updates-proxy.service
  487. /lib/systemd/system/qubes-qrexec-agent.service
  488. /lib/modules-load.d/qubes-core.conf
  489. /lib/modules-load.d/qubes-misc.conf
  490. %dir /usr/lib/qubes/init
  491. /usr/lib/qubes/init/prepare-dvm.sh
  492. /usr/lib/qubes/init/network-proxy-setup.sh
  493. /usr/lib/qubes/init/misc-post.sh
  494. /usr/lib/qubes/init/misc-post-stop.sh
  495. /usr/lib/qubes/init/qubes-sysinit.sh
  496. /usr/lib/qubes/init/ModemManager.service
  497. /usr/lib/qubes/init/NetworkManager.service
  498. /usr/lib/qubes/init/NetworkManager-wait-online.service
  499. /usr/lib/qubes/init/cups.service
  500. /usr/lib/qubes/init/cups.socket
  501. /usr/lib/qubes/init/cups.path
  502. /usr/lib/qubes/init/ntpd.service
  503. /usr/lib/qubes/init/chronyd.service
  504. /usr/lib/qubes/init/crond.service
  505. %ghost %attr(0644,root,root) /etc/systemd/system/ModemManager.service
  506. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager.service
  507. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager-wait-online.service
  508. %ghost %attr(0644,root,root) /etc/systemd/system/cups.service
  509. %ghost %attr(0644,root,root) /etc/systemd/system/cups.socket
  510. %ghost %attr(0644,root,root) /etc/systemd/system/cups.path
  511. %post systemd
  512. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-firewall qubes-updates-proxy qubes-qrexec-agent; do
  513. /bin/systemctl --no-reload enable $srv.service 2> /dev/null
  514. done
  515. /bin/systemctl --no-reload enable qubes-update-check.timer 2> /dev/null
  516. # Set default "runlevel"
  517. rm -f /etc/systemd/system/default.target
  518. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  519. DISABLE_SERVICES="alsa-store alsa-restore auditd avahi avahi-daemon backuppc cpuspeed"
  520. DISABLE_SERVICES="$DISABLE_SERVICES fedora-autorelabel fedora-autorelabel-mark ipmi hwclock-load hwclock-save"
  521. DISABLE_SERVICES="$DISABLE_SERVICES mdmonitor multipathd openct rpcbind mcelog fedora-storage-init fedora-storage-init-late"
  522. DISABLE_SERVICES="$DISABLE_SERVICES plymouth-start plymouth-read-write plymouth-quit plymouth-quit-wait"
  523. DISABLE_SERVICES="$DISABLE_SERVICES sshd tcsd sm-client sendmail mdmonitor-takeover"
  524. DISABLE_SERVICES="$DISABLE_SERVICES rngd smartd upower irqbalance colord"
  525. for srv in $DISABLE_SERVICES; do
  526. if [ -f /lib/systemd/system/$srv.service ]; then
  527. if fgrep -q '[Install]' /lib/systemd/system/$srv.service; then
  528. /bin/systemctl --no-reload disable $srv.service 2> /dev/null
  529. else
  530. # forcibly disable
  531. ln -sf /dev/null /etc/systemd/system/$srv.service
  532. fi
  533. fi
  534. done
  535. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  536. # Enable some services
  537. /bin/systemctl --no-reload enable iptables.service 2> /dev/null
  538. /bin/systemctl --no-reload enable ip6tables.service 2> /dev/null
  539. /bin/systemctl --no-reload enable rsyslog.service 2> /dev/null
  540. /bin/systemctl --no-reload enable ntpd.service 2> /dev/null
  541. /bin/systemctl --no-reload enable crond.service 2> /dev/null
  542. # Enable cups only when it is real SystemD service
  543. [ -e /lib/systemd/system/cups.service ] && /bin/systemctl --no-reload enable cups.service 2> /dev/null
  544. /bin/systemctl daemon-reload
  545. exit 0
  546. %triggerin systemd -- NetworkManager
  547. %installOverridenServices ModemManager NetworkManager NetworkManager-wait-online
  548. # Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)
  549. /bin/systemctl mask dbus-org.freedesktop.NetworkManager.service 2> /dev/null
  550. # Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811
  551. /bin/systemctl enable NetworkManager-dispatcher.service 2> /dev/null
  552. exit 0
  553. %triggerin systemd -- cups
  554. %installOverridenServices cups
  555. exit 0
  556. %triggerin systemd -- cronie
  557. %installOverridenServices crond
  558. exit 0
  559. %triggerin systemd -- haveged
  560. /bin/systemctl enable haveged.service 2> /dev/null
  561. exit 0
  562. %postun systemd
  563. #Do not run this part on upgrades
  564. if [ "$1" != 0 ] ; then
  565. exit 0
  566. fi
  567. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-qrexec-agent; do
  568. /bin/systemctl disable $srv.service
  569. do