core-vm.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Requires: iptables-services
  38. Conflicts: firewalld
  39. %endif
  40. Requires: /usr/bin/mimeopen
  41. Requires: ethtool
  42. Requires: tinyproxy
  43. Requires: ntpdate
  44. Requires: net-tools
  45. Requires: nautilus-python
  46. Requires: qubes-core-vm-kernel-placeholder
  47. Requires: qubes-utils
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. Requires: dbus-python
  52. # for qubes-session-autostart, xdg-icon
  53. Requires: pyxdg
  54. %if %{fedora} >= 20
  55. # gpk-update-viewer required by qubes-manager
  56. Requires: gnome-packagekit-updater
  57. %endif
  58. Requires: ImageMagick
  59. Requires: librsvg2-tools
  60. Requires: fakeroot
  61. Requires: desktop-notification-daemon
  62. Requires: pygtk2
  63. Requires: zenity
  64. Requires: qubes-libvchan
  65. Requires: qubes-db-vm
  66. Provides: qubes-core-vm
  67. Obsoletes: qubes-core-commonvm
  68. Obsoletes: qubes-core-appvm
  69. Obsoletes: qubes-core-netvm
  70. Obsoletes: qubes-core-proxyvm
  71. Obsoletes: qubes-upgrade-vm < 3.0
  72. BuildRequires: xen-devel
  73. BuildRequires: libX11-devel
  74. BuildRequires: qubes-utils-devel >= 3.0.1
  75. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  76. %define _builddir %(pwd)
  77. %define kde_service_dir /usr/share/kde4/services
  78. %description
  79. The Qubes core files for installation inside a Qubes VM.
  80. %prep
  81. # we operate on the current directory, so no need to unpack anything
  82. # symlink is to generate useful debuginfo packages
  83. rm -f %{name}-%{version}
  84. ln -sf . %{name}-%{version}
  85. %setup -T -D
  86. %build
  87. for dir in qubes-rpc qrexec misc; do
  88. (cd $dir; make)
  89. done
  90. %pre
  91. # Make sure there is a qubes group
  92. groupadd --force --system --gid 98 qubes
  93. id -u 'user' >/dev/null 2>&1 || {
  94. useradd --user-group --create-home --shell /bin/bash user
  95. }
  96. usermod -a --groups qubes user
  97. if [ "$1" != 1 ] ; then
  98. # do this whole %pre thing only when updating for the first time...
  99. exit 0
  100. fi
  101. mkdir -p /var/lib/qubes
  102. if [ -e /etc/fstab ] ; then
  103. mv /etc/fstab /var/lib/qubes/fstab.orig
  104. fi
  105. usermod -p '' root
  106. usermod -L user
  107. %install
  108. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  109. make install-vm DESTDIR=$RPM_BUILD_ROOT
  110. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/iptables $RPM_BUILD_ROOT/etc/sysconfig/iptables.qubes
  111. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/ip6tables $RPM_BUILD_ROOT/etc/sysconfig/ip6tables.qubes
  112. %triggerin -- initscripts
  113. if [ -e /etc/init/serial.conf ]; then
  114. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  115. fi
  116. %triggerin -- iptables
  117. if ! grep -q IPTABLES_DATA /etc/sysconfig/iptables-config; then
  118. cat <<EOF >>/etc/sysconfig/iptables-config
  119. ### Automatically added by Qubes:
  120. # Override default rules location on Qubes
  121. IPTABLES_DATA=/etc/sysconfig/iptables.qubes
  122. EOF
  123. fi
  124. if ! grep -q IP6TABLES_DATA /etc/sysconfig/ip6tables-config; then
  125. cat <<EOF >>/etc/sysconfig/ip6tables-config
  126. ### Automatically added by Qubes:
  127. # Override default rules location on Qubes
  128. IP6TABLES_DATA=/etc/sysconfig/ip6tables.qubes
  129. EOF
  130. fi
  131. %post
  132. # disable some Upstart services
  133. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  134. if [ -e /etc/init/$F.conf ]; then
  135. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  136. fi
  137. done
  138. # Create NetworkManager configuration if we do not have it
  139. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  140. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  141. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  142. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  143. fi
  144. /usr/lib/qubes/qubes-fix-nm-conf.sh
  145. # Remove ip_forward setting from sysctl, so NM will not reset it
  146. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  147. # Remove old firmware updates link
  148. if [ -L /lib/firmware/updates ]; then
  149. rm -f /lib/firmware/updates
  150. fi
  151. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  152. echo >> /etc/yum.conf
  153. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  154. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  155. fi
  156. # Revert 'Prevent unnecessary updates in VMs':
  157. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  158. # Location of files which contains list of protected files
  159. mkdir -p /etc/qubes/protected-files.d
  160. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  161. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  162. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  163. if ! grep -q localhost /etc/hosts; then
  164. cat <<EOF > /etc/hosts
  165. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  166. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  167. EOF
  168. fi
  169. fi
  170. # Make sure that /etc/sysconfig/ip(|6)tables exists. Otherwise iptales.service
  171. # would not start (even when configured to use another configuration file.
  172. if [ ! -e '/etc/sysconfig/iptables' ]; then
  173. ln -s iptables.qubes /etc/sysconfig/iptables
  174. fi
  175. if [ ! -e '/etc/sysconfig/ip6tables' ]; then
  176. ln -s ip6tables.qubes /etc/sysconfig/ip6tables
  177. fi
  178. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  179. # in the form expected by qubes-sysinit.sh
  180. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  181. for ip in '127\.0\.0\.1' '::1'; do
  182. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  183. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  184. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  185. else
  186. echo "${ip} `hostname`" >> /etc/hosts
  187. fi
  188. done
  189. fi
  190. %if %{fedora} >= 20
  191. # Make sure there is a default locale set so gnome-terminal will start
  192. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  193. touch /etc/locale.conf
  194. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  195. fi
  196. # ... and make sure it is really generated
  197. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  198. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  199. base=`echo "$current_locale" | cut -f 1 -d .`
  200. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  201. [ -n "$charmap" ] && charmap="-f $charmap"
  202. localedef -i $base $charmap $current_locale
  203. fi
  204. %endif
  205. if [ "$1" != 1 ] ; then
  206. # do the rest of %post thing only when updating for the first time...
  207. exit 0
  208. fi
  209. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  210. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  211. fi
  212. # Remove most of the udev scripts to speed up the VM boot time
  213. # Just leave the xen* scripts, that are needed if this VM was
  214. # ever used as a net backend (e.g. as a VPN domain in the future)
  215. #echo "--> Removing unnecessary udev scripts..."
  216. mkdir -p /var/lib/qubes/removed-udev-scripts
  217. for f in /etc/udev/rules.d/*
  218. do
  219. if [ $(basename $f) == "xen-backend.rules" ] ; then
  220. continue
  221. fi
  222. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  223. continue
  224. fi
  225. if echo $f | grep -q qubes; then
  226. continue
  227. fi
  228. mv $f /var/lib/qubes/removed-udev-scripts/
  229. done
  230. mkdir -p /rw
  231. #rm -f /etc/mtab
  232. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  233. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  234. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  235. %triggerin -- notification-daemon
  236. # Enable autostart of notification-daemon when installed
  237. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  238. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  239. fi
  240. exit 0
  241. %triggerin -- selinux-policy
  242. #echo "--> Disabling SELinux..."
  243. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  244. mv /etc/selinux/config.processed /etc/selinux/config
  245. setenforce 0 2>/dev/null
  246. exit 0
  247. %preun
  248. if [ "$1" = 0 ] ; then
  249. # no more packages left
  250. if [ -e /var/lib/qubes/fstab.orig ] ; then
  251. mv /var/lib/qubes/fstab.orig /etc/fstab
  252. fi
  253. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  254. if [ -e /var/lib/qubes/serial.orig ] ; then
  255. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  256. fi
  257. fi
  258. %postun
  259. if [ $1 -eq 0 ] ; then
  260. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  261. if [ -L /lib/firmware/updates ]; then
  262. rm /lib/firmware/updates
  263. fi
  264. rm -rf /var/lib/qubes/xdg
  265. fi
  266. %posttrans
  267. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  268. %clean
  269. rm -rf $RPM_BUILD_ROOT
  270. rm -f %{name}-%{version}
  271. %files
  272. %defattr(-,root,root,-)
  273. %dir /var/lib/qubes
  274. %dir /var/run/qubes
  275. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  276. %{kde_service_dir}/qvm-copy.desktop
  277. %{kde_service_dir}/qvm-move.desktop
  278. %{kde_service_dir}/qvm-dvm.desktop
  279. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  280. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  281. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  282. /etc/dispvm-dotfiles.tbz
  283. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  284. /etc/fstab
  285. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  286. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  287. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  288. %dir /etc/qubes-rpc
  289. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  290. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  291. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  292. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  293. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  294. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  295. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  296. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  297. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  298. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  299. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  300. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  301. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  302. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  303. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  304. %dir /etc/qubes/autostart
  305. /etc/qubes/autostart/README.txt
  306. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  307. %config(noreplace) /etc/sudoers.d/qubes
  308. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  309. %config(noreplace) /etc/sysconfig/iptables.qubes
  310. %config(noreplace) /etc/sysconfig/ip6tables.qubes
  311. /usr/lib/qubes/init/iptables
  312. /usr/lib/qubes/init/ip6tables
  313. %config(noreplace) /etc/tinyproxy/filter-updates
  314. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  315. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  316. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  317. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  318. /etc/xen/scripts/vif-route-qubes
  319. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  320. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  321. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  322. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  323. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  324. /usr/sbin/qubes-serial-login
  325. /usr/bin/qvm-copy-to-vm
  326. /usr/bin/qvm-move-to-vm
  327. /usr/bin/qvm-open-in-dvm
  328. /usr/bin/qvm-open-in-vm
  329. /usr/bin/qvm-run
  330. /usr/bin/qvm-mru-entry
  331. /usr/bin/xenstore-watch-qubes
  332. /usr/bin/qubes-desktop-run
  333. /usr/bin/qrexec-fork-server
  334. /usr/bin/qrexec-client-vm
  335. /usr/bin/qubes-session-autostart
  336. %dir /usr/lib/qubes
  337. /usr/lib/qubes/vusb-ctl.py*
  338. /usr/lib/qubes/dispvm-prerun.sh
  339. /usr/lib/qubes/sync-ntp-clock
  340. /usr/lib/qubes/prepare-suspend
  341. /usr/lib/qubes/network-manager-prepare-conf-dir
  342. /usr/lib/qubes/show-hide-nm-applet.sh
  343. /usr/lib/qubes/qrexec-agent
  344. /usr/lib/qubes/qrexec-client-vm
  345. /usr/lib/qubes/qrexec_client_vm
  346. /usr/lib/qubes/qubes-rpc-multiplexer
  347. /usr/lib/qubes/qfile-agent
  348. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  349. /usr/lib/qubes/qopen-in-vm
  350. /usr/lib/qubes/qrun-in-vm
  351. /usr/lib/qubes/qubes-download-dom0-updates.sh
  352. /usr/lib/qubes/qubes-fix-nm-conf.sh
  353. /usr/lib/qubes/qubes-setup-dnat-to-ns
  354. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  355. /usr/lib/qubes/qvm-copy-to-vm.gnome
  356. /usr/lib/qubes/qvm-copy-to-vm.kde
  357. /usr/lib/qubes/qvm-move-to-vm.gnome
  358. /usr/lib/qubes/qvm-move-to-vm.kde
  359. /usr/lib/qubes/setup-ip
  360. /usr/lib/qubes/tar2qfile
  361. /usr/lib/qubes/vm-file-editor
  362. /usr/lib/qubes/wrap-in-html-if-url.sh
  363. /usr/lib/qubes/iptables-updates-proxy
  364. /usr/lib/qubes/close-window
  365. /usr/lib/qubes/xdg-icon
  366. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  367. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  368. /usr/sbin/qubes-firewall
  369. /usr/sbin/qubes-netwatcher
  370. /usr/share/qubes/serial.conf
  371. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  372. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  373. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  374. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  375. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  376. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  377. %dir /var/lib/qubes
  378. /usr/share/qubes/mime-override/globs
  379. %dir /home_volatile
  380. %attr(700,user,user) /home_volatile/user
  381. %dir /mnt/removable
  382. %dir /rw
  383. %package sysvinit
  384. Summary: Qubes unit files for SysV init style or upstart
  385. License: GPL v2 only
  386. Group: Qubes
  387. Requires: upstart
  388. Requires: qubes-core-vm
  389. Provides: qubes-core-vm-init-scripts
  390. Conflicts: qubes-core-vm-systemd
  391. %description sysvinit
  392. The Qubes core startup configuration for SysV init (or upstart).
  393. %files sysvinit
  394. /etc/init.d/qubes-core
  395. /etc/init.d/qubes-core-appvm
  396. /etc/init.d/qubes-core-netvm
  397. /etc/init.d/qubes-firewall
  398. /etc/init.d/qubes-netwatcher
  399. /etc/init.d/qubes-updates-proxy
  400. /etc/init.d/qubes-qrexec-agent
  401. /etc/sysconfig/modules/qubes-core.modules
  402. /etc/sysconfig/modules/qubes-misc.modules
  403. %post sysvinit
  404. #echo "--> Turning off unnecessary services..."
  405. # FIXME: perhaps there is more elegant way to do this?
  406. for f in /etc/init.d/*
  407. do
  408. srv=`basename $f`
  409. [ $srv = 'functions' ] && continue
  410. [ $srv = 'killall' ] && continue
  411. [ $srv = 'halt' ] && continue
  412. [ $srv = 'single' ] && continue
  413. [ $srv = 'reboot' ] && continue
  414. [ $srv = 'qubes-gui' ] && continue
  415. chkconfig $srv off
  416. done
  417. #echo "--> Enabling essential services..."
  418. chkconfig rsyslog on
  419. chkconfig haldaemon on
  420. chkconfig messagebus on
  421. chkconfig iptables on
  422. chkconfig ip6tables on
  423. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  424. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  425. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  426. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  427. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  428. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  429. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  430. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  431. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  432. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  433. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  434. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  435. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  436. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  437. # TODO: make this not display the silly message about security context...
  438. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  439. %preun sysvinit
  440. if [ "$1" = 0 ] ; then
  441. # no more packages left
  442. chkconfig qubes-core off
  443. chkconfig qubes-core-netvm off
  444. chkconfig qubes-core-appvm off
  445. chkconfig qubes-firewall off
  446. chkconfig qubes-netwatcher off
  447. chkconfig qubes-updates-proxy off
  448. chkconfig qubes-qrexec-agent off
  449. fi
  450. %package systemd
  451. Summary: Qubes unit files for SystemD init style
  452. License: GPL v2 only
  453. Group: Qubes
  454. Requires: systemd
  455. Requires(post): systemd-units
  456. Requires(preun): systemd-units
  457. Requires(postun): systemd-units
  458. Requires: qubes-core-vm
  459. Provides: qubes-core-vm-init-scripts
  460. Conflicts: qubes-core-vm-sysvinit
  461. %description systemd
  462. The Qubes core startup configuration for SystemD init.
  463. %files systemd
  464. %defattr(-,root,root,-)
  465. /lib/systemd/system/qubes-dvm.service
  466. /lib/systemd/system/qubes-misc-post.service
  467. /lib/systemd/system/qubes-firewall.service
  468. /lib/systemd/system/qubes-mount-home.service
  469. /lib/systemd/system/qubes-netwatcher.service
  470. /lib/systemd/system/qubes-network.service
  471. /lib/systemd/system/qubes-sysinit.service
  472. /lib/systemd/system/qubes-update-check.service
  473. /lib/systemd/system/qubes-update-check.timer
  474. /lib/systemd/system/qubes-updates-proxy.service
  475. /lib/systemd/system/qubes-qrexec-agent.service
  476. /lib/systemd/system-preset/75-qubes-vm.preset
  477. /lib/modules-load.d/qubes-core.conf
  478. /lib/modules-load.d/qubes-misc.conf
  479. %dir /usr/lib/qubes/init
  480. /usr/lib/qubes/init/prepare-dvm.sh
  481. /usr/lib/qubes/init/network-proxy-setup.sh
  482. /usr/lib/qubes/init/misc-post.sh
  483. /usr/lib/qubes/init/misc-post-stop.sh
  484. /usr/lib/qubes/init/mount-home.sh
  485. /usr/lib/qubes/init/qubes-sysinit.sh
  486. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  487. /lib/systemd/system/crond.service.d/30_qubes.conf
  488. /lib/systemd/system/cups.service.d/30_qubes.conf
  489. /lib/systemd/system/cups.socket.d/30_qubes.conf
  490. /lib/systemd/system/cups.path.d/30_qubes.conf
  491. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  492. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  493. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  494. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  495. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  496. %post systemd
  497. PRESET_FAILED=0
  498. if [ $1 -eq 1 ]; then
  499. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  500. else
  501. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-home"
  502. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  503. services="$services qubes-updates-proxy qubes-qrexec-agent"
  504. for srv in $services; do
  505. /bin/systemctl --no-reload preset $srv.service
  506. done
  507. /bin/systemctl --no-reload preset qubes-update-check.timer
  508. fi
  509. # Set default "runlevel"
  510. rm -f /etc/systemd/system/default.target
  511. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  512. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  513. case "$action" in
  514. (disable)
  515. if [ -f /lib/systemd/system/$unit_name ]; then
  516. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  517. # forcibly disable
  518. ln -sf /dev/null /etc/systemd/system/$unit_name
  519. fi
  520. fi
  521. ;;
  522. *)
  523. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  524. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  525. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  526. fi
  527. ;;
  528. esac
  529. done
  530. /bin/systemctl daemon-reload
  531. exit 0
  532. %postun systemd
  533. #Do not run this part on upgrades
  534. if [ "$1" != 0 ] ; then
  535. exit 0
  536. fi
  537. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-home qubes-netwatcher qubes-network qubes-qrexec-agent; do
  538. /bin/systemctl disable $srv.service
  539. do