core-vm.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  24. Name: qubes-core-vm
  25. Version: %{version}
  26. Release: 1%{dist}
  27. Summary: The Qubes core files for VM
  28. Group: Qubes
  29. Vendor: Invisible Things Lab
  30. License: GPL
  31. URL: http://www.qubes-os.org
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Requires: iptables-services
  38. Conflicts: firewalld
  39. %endif
  40. Requires: /usr/bin/mimeopen
  41. Requires: ethtool
  42. Requires: tinyproxy
  43. Requires: ntpdate
  44. Requires: net-tools
  45. Requires: nautilus-python
  46. Requires: qubes-core-vm-kernel-placeholder
  47. Requires: qubes-utils
  48. Requires: initscripts
  49. # for qubes-desktop-run
  50. Requires: pygobject3-base
  51. # for qubes-session-autostart
  52. Requires: pyxdg
  53. %if %{fedora} >= 20
  54. # gpk-update-viewer required by qubes-manager
  55. Requires: gnome-packagekit-updater
  56. %endif
  57. Requires: ImageMagick
  58. Requires: fakeroot
  59. Requires: desktop-notification-daemon
  60. Requires: pygtk2
  61. Requires: zenity
  62. Requires: qubes-libvchan
  63. Requires: qubes-db-vm
  64. Provides: qubes-core-vm
  65. Obsoletes: qubes-core-commonvm
  66. Obsoletes: qubes-core-appvm
  67. Obsoletes: qubes-core-netvm
  68. Obsoletes: qubes-core-proxyvm
  69. Obsoletes: qubes-upgrade-vm < 3.0
  70. BuildRequires: xen-devel
  71. BuildRequires: libX11-devel
  72. BuildRequires: qubes-utils-devel >= 3.0.1
  73. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  74. %define _builddir %(pwd)
  75. %define kde_service_dir /usr/share/kde4/services
  76. %description
  77. The Qubes core files for installation inside a Qubes VM.
  78. %prep
  79. # we operate on the current directory, so no need to unpack anything
  80. # symlink is to generate useful debuginfo packages
  81. rm -f %{name}-%{version}
  82. ln -sf . %{name}-%{version}
  83. %setup -T -D
  84. %build
  85. for dir in qubes-rpc qrexec misc; do
  86. (cd $dir; make)
  87. done
  88. %pre
  89. # Make sure there is a qubes group
  90. groupadd --force --system --gid 98 qubes
  91. id -u 'user' >/dev/null 2>&1 || {
  92. useradd --user-group --create-home --shell /bin/bash user
  93. }
  94. usermod -a --groups qubes user
  95. if [ "$1" != 1 ] ; then
  96. # do this whole %pre thing only when updating for the first time...
  97. exit 0
  98. fi
  99. mkdir -p /var/lib/qubes
  100. if [ -e /etc/fstab ] ; then
  101. mv /etc/fstab /var/lib/qubes/fstab.orig
  102. fi
  103. usermod -p '' root
  104. usermod -L user
  105. %install
  106. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  107. make install-vm DESTDIR=$RPM_BUILD_ROOT
  108. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/iptables $RPM_BUILD_ROOT/etc/sysconfig/iptables.qubes
  109. cp -p $RPM_BUILD_ROOT/usr/lib/qubes/init/ip6tables $RPM_BUILD_ROOT/etc/sysconfig/ip6tables.qubes
  110. %triggerin -- initscripts
  111. if [ -e /etc/init/serial.conf ]; then
  112. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  113. fi
  114. %triggerin -- iptables
  115. if ! grep -q IPTABLES_DATA /etc/sysconfig/iptables-config; then
  116. cat <<EOF >>/etc/sysconfig/iptables-config
  117. ### Automatically added by Qubes:
  118. # Override default rules location on Qubes
  119. IPTABLES_DATA=/etc/sysconfig/iptables.qubes
  120. EOF
  121. fi
  122. if ! grep -q IP6TABLES_DATA /etc/sysconfig/ip6tables-config; then
  123. cat <<EOF >>/etc/sysconfig/ip6tables-config
  124. ### Automatically added by Qubes:
  125. # Override default rules location on Qubes
  126. IP6TABLES_DATA=/etc/sysconfig/ip6tables.qubes
  127. EOF
  128. fi
  129. %post
  130. # disable some Upstart services
  131. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  132. if [ -e /etc/init/$F.conf ]; then
  133. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  134. fi
  135. done
  136. # Create NetworkManager configuration if we do not have it
  137. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  138. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  139. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  140. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  141. fi
  142. /usr/lib/qubes/qubes-fix-nm-conf.sh
  143. # Remove ip_forward setting from sysctl, so NM will not reset it
  144. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  145. # Remove old firmware updates link
  146. if [ -L /lib/firmware/updates ]; then
  147. rm -f /lib/firmware/updates
  148. fi
  149. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  150. echo >> /etc/yum.conf
  151. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  152. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  153. fi
  154. # Revert 'Prevent unnecessary updates in VMs':
  155. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  156. # Location of files which contains list of protected files
  157. mkdir -p /etc/qubes/protected-files.d
  158. PROTECTED_FILE_LIST='/etc/qubes/protected-files.d'
  159. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  160. if ! grep -rq "^/etc/hosts$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  161. if ! grep -q localhost /etc/hosts; then
  162. cat <<EOF > /etc/hosts
  163. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  164. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  165. EOF
  166. fi
  167. fi
  168. # Make sure that /etc/sysconfig/ip(|6)tables exists. Otherwise iptales.service
  169. # would not start (even when configured to use another configuration file.
  170. if [ ! -e '/etc/sysconfig/iptables' ]; then
  171. ln -s iptables.qubes /etc/sysconfig/iptables
  172. fi
  173. if [ ! -e '/etc/sysconfig/ip6tables' ]; then
  174. ln -s ip6tables.qubes /etc/sysconfig/ip6tables
  175. fi
  176. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  177. # in the form expected by qubes-sysinit.sh
  178. if ! grep -rq "^/etc/hostname$" "${PROTECTED_FILE_LIST}" 2>/dev/null; then
  179. for ip in '127\.0\.0\.1' '::1'; do
  180. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  181. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  182. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  183. else
  184. echo "${ip} `hostname`" >> /etc/hosts
  185. fi
  186. done
  187. fi
  188. %if %{fedora} >= 20
  189. # Make sure there is a default locale set so gnome-terminal will start
  190. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  191. touch /etc/locale.conf
  192. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  193. fi
  194. # ... and make sure it is really generated
  195. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  196. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  197. base=`echo "$current_locale" | cut -f 1 -d .`
  198. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  199. [ -n "$charmap" ] && charmap="-f $charmap"
  200. localedef -i $base $charmap $current_locale
  201. fi
  202. %endif
  203. if [ "$1" != 1 ] ; then
  204. # do the rest of %post thing only when updating for the first time...
  205. exit 0
  206. fi
  207. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  208. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  209. fi
  210. # Remove most of the udev scripts to speed up the VM boot time
  211. # Just leave the xen* scripts, that are needed if this VM was
  212. # ever used as a net backend (e.g. as a VPN domain in the future)
  213. #echo "--> Removing unnecessary udev scripts..."
  214. mkdir -p /var/lib/qubes/removed-udev-scripts
  215. for f in /etc/udev/rules.d/*
  216. do
  217. if [ $(basename $f) == "xen-backend.rules" ] ; then
  218. continue
  219. fi
  220. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  221. continue
  222. fi
  223. if echo $f | grep -q qubes; then
  224. continue
  225. fi
  226. mv $f /var/lib/qubes/removed-udev-scripts/
  227. done
  228. mkdir -p /rw
  229. #rm -f /etc/mtab
  230. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  231. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  232. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  233. %triggerin -- notification-daemon
  234. # Enable autostart of notification-daemon when installed
  235. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  236. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  237. fi
  238. exit 0
  239. %triggerin -- selinux-policy
  240. #echo "--> Disabling SELinux..."
  241. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  242. mv /etc/selinux/config.processed /etc/selinux/config
  243. setenforce 0 2>/dev/null
  244. exit 0
  245. %preun
  246. if [ "$1" = 0 ] ; then
  247. # no more packages left
  248. if [ -e /var/lib/qubes/fstab.orig ] ; then
  249. mv /var/lib/qubes/fstab.orig /etc/fstab
  250. fi
  251. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  252. if [ -e /var/lib/qubes/serial.orig ] ; then
  253. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  254. fi
  255. fi
  256. %postun
  257. if [ $1 -eq 0 ] ; then
  258. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  259. if [ -L /lib/firmware/updates ]; then
  260. rm /lib/firmware/updates
  261. fi
  262. rm -rf /var/lib/qubes/xdg
  263. fi
  264. %posttrans
  265. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  266. %clean
  267. rm -rf $RPM_BUILD_ROOT
  268. rm -f %{name}-%{version}
  269. %files
  270. %defattr(-,root,root,-)
  271. %dir /var/lib/qubes
  272. %dir /var/run/qubes
  273. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  274. %{kde_service_dir}/qvm-copy.desktop
  275. %{kde_service_dir}/qvm-move.desktop
  276. %{kde_service_dir}/qvm-dvm.desktop
  277. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  278. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  279. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  280. /etc/dispvm-dotfiles.tbz
  281. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  282. /etc/fstab
  283. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  284. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  285. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  286. %dir /etc/qubes-rpc
  287. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  288. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  289. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  290. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  291. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  292. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  293. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  294. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  295. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  296. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  297. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  298. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  299. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  300. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  301. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  302. %dir /etc/qubes/autostart
  303. /etc/qubes/autostart/README.txt
  304. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  305. %config(noreplace) /etc/sudoers.d/qubes
  306. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  307. %config(noreplace) /etc/sysconfig/iptables.qubes
  308. %config(noreplace) /etc/sysconfig/ip6tables.qubes
  309. /usr/lib/qubes/init/iptables
  310. /usr/lib/qubes/init/ip6tables
  311. %config(noreplace) /etc/tinyproxy/filter-updates
  312. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  313. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  314. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  315. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  316. /etc/xen/scripts/vif-route-qubes
  317. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  318. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  319. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  320. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  321. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  322. /usr/sbin/qubes-serial-login
  323. /usr/bin/qvm-copy-to-vm
  324. /usr/bin/qvm-move-to-vm
  325. /usr/bin/qvm-open-in-dvm
  326. /usr/bin/qvm-open-in-vm
  327. /usr/bin/qvm-run
  328. /usr/bin/qvm-mru-entry
  329. /usr/bin/xenstore-watch-qubes
  330. /usr/bin/qubes-desktop-run
  331. /usr/bin/qrexec-fork-server
  332. /usr/bin/qrexec-client-vm
  333. /usr/bin/qubes-session-autostart
  334. %dir /usr/lib/qubes
  335. /usr/lib/qubes/vusb-ctl.py*
  336. /usr/lib/qubes/dispvm-prerun.sh
  337. /usr/lib/qubes/sync-ntp-clock
  338. /usr/lib/qubes/prepare-suspend
  339. /usr/lib/qubes/network-manager-prepare-conf-dir
  340. /usr/lib/qubes/show-hide-nm-applet.sh
  341. /usr/lib/qubes/qrexec-agent
  342. /usr/lib/qubes/qrexec-client-vm
  343. /usr/lib/qubes/qrexec_client_vm
  344. /usr/lib/qubes/qubes-rpc-multiplexer
  345. /usr/lib/qubes/qfile-agent
  346. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  347. /usr/lib/qubes/qopen-in-vm
  348. /usr/lib/qubes/qrun-in-vm
  349. /usr/lib/qubes/qubes-download-dom0-updates.sh
  350. /usr/lib/qubes/qubes-fix-nm-conf.sh
  351. /usr/lib/qubes/qubes-setup-dnat-to-ns
  352. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  353. /usr/lib/qubes/qvm-copy-to-vm.gnome
  354. /usr/lib/qubes/qvm-copy-to-vm.kde
  355. /usr/lib/qubes/qvm-move-to-vm.gnome
  356. /usr/lib/qubes/qvm-move-to-vm.kde
  357. /usr/lib/qubes/setup-ip
  358. /usr/lib/qubes/tar2qfile
  359. /usr/lib/qubes/vm-file-editor
  360. /usr/lib/qubes/wrap-in-html-if-url.sh
  361. /usr/lib/qubes/iptables-updates-proxy
  362. /usr/lib/qubes/close-window
  363. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  364. /usr/lib64/python2.7/site-packages/qubes/xdg.py*
  365. /usr/sbin/qubes-firewall
  366. /usr/sbin/qubes-netwatcher
  367. /usr/share/qubes/serial.conf
  368. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  369. /usr/share/glib-2.0/schemas/org.gnome.nautilus.gschema.override
  370. /usr/share/glib-2.0/schemas/org.mate.NotificationDaemon.gschema.override
  371. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  372. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  373. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  374. %dir /var/lib/qubes
  375. /usr/share/qubes/mime-override/globs
  376. %dir /home_volatile
  377. %attr(700,user,user) /home_volatile/user
  378. %dir /mnt/removable
  379. %dir /rw
  380. %package sysvinit
  381. Summary: Qubes unit files for SysV init style or upstart
  382. License: GPL v2 only
  383. Group: Qubes
  384. Requires: upstart
  385. Requires: qubes-core-vm
  386. Provides: qubes-core-vm-init-scripts
  387. Conflicts: qubes-core-vm-systemd
  388. %description sysvinit
  389. The Qubes core startup configuration for SysV init (or upstart).
  390. %files sysvinit
  391. /etc/init.d/qubes-core
  392. /etc/init.d/qubes-core-appvm
  393. /etc/init.d/qubes-core-netvm
  394. /etc/init.d/qubes-firewall
  395. /etc/init.d/qubes-netwatcher
  396. /etc/init.d/qubes-updates-proxy
  397. /etc/init.d/qubes-qrexec-agent
  398. /etc/sysconfig/modules/qubes-core.modules
  399. /etc/sysconfig/modules/qubes-misc.modules
  400. %post sysvinit
  401. #echo "--> Turning off unnecessary services..."
  402. # FIXME: perhaps there is more elegant way to do this?
  403. for f in /etc/init.d/*
  404. do
  405. srv=`basename $f`
  406. [ $srv = 'functions' ] && continue
  407. [ $srv = 'killall' ] && continue
  408. [ $srv = 'halt' ] && continue
  409. [ $srv = 'single' ] && continue
  410. [ $srv = 'reboot' ] && continue
  411. [ $srv = 'qubes-gui' ] && continue
  412. chkconfig $srv off
  413. done
  414. #echo "--> Enabling essential services..."
  415. chkconfig rsyslog on
  416. chkconfig haldaemon on
  417. chkconfig messagebus on
  418. chkconfig iptables on
  419. chkconfig ip6tables on
  420. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  421. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  422. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  423. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  424. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  425. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  426. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  427. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  428. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  429. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  430. chkconfig --add qubes-updates-proxy || echo "WARNING: Cannot add service qubes-updates-proxy!"
  431. chkconfig qubes-updates-proxy on || echo "WARNING: Cannot enable service qubes-updates-proxy!"
  432. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  433. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  434. # TODO: make this not display the silly message about security context...
  435. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  436. %preun sysvinit
  437. if [ "$1" = 0 ] ; then
  438. # no more packages left
  439. chkconfig qubes-core off
  440. chkconfig qubes-core-netvm off
  441. chkconfig qubes-core-appvm off
  442. chkconfig qubes-firewall off
  443. chkconfig qubes-netwatcher off
  444. chkconfig qubes-updates-proxy off
  445. chkconfig qubes-qrexec-agent off
  446. fi
  447. %package systemd
  448. Summary: Qubes unit files for SystemD init style
  449. License: GPL v2 only
  450. Group: Qubes
  451. Requires: systemd
  452. Requires(post): systemd-units
  453. Requires(preun): systemd-units
  454. Requires(postun): systemd-units
  455. Requires: qubes-core-vm
  456. Provides: qubes-core-vm-init-scripts
  457. Conflicts: qubes-core-vm-sysvinit
  458. %description systemd
  459. The Qubes core startup configuration for SystemD init.
  460. %files systemd
  461. %defattr(-,root,root,-)
  462. /lib/systemd/system/qubes-dvm.service
  463. /lib/systemd/system/qubes-misc-post.service
  464. /lib/systemd/system/qubes-firewall.service
  465. /lib/systemd/system/qubes-mount-home.service
  466. /lib/systemd/system/qubes-netwatcher.service
  467. /lib/systemd/system/qubes-network.service
  468. /lib/systemd/system/qubes-sysinit.service
  469. /lib/systemd/system/qubes-update-check.service
  470. /lib/systemd/system/qubes-update-check.timer
  471. /lib/systemd/system/qubes-updates-proxy.service
  472. /lib/systemd/system/qubes-qrexec-agent.service
  473. /lib/systemd/system-preset/75-qubes-vm.preset
  474. /lib/modules-load.d/qubes-core.conf
  475. /lib/modules-load.d/qubes-misc.conf
  476. %dir /usr/lib/qubes/init
  477. /usr/lib/qubes/init/prepare-dvm.sh
  478. /usr/lib/qubes/init/network-proxy-setup.sh
  479. /usr/lib/qubes/init/misc-post.sh
  480. /usr/lib/qubes/init/misc-post-stop.sh
  481. /usr/lib/qubes/init/mount-home.sh
  482. /usr/lib/qubes/init/qubes-sysinit.sh
  483. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  484. /lib/systemd/system/crond.service.d/30_qubes.conf
  485. /lib/systemd/system/cups.service.d/30_qubes.conf
  486. /lib/systemd/system/cups.socket.d/30_qubes.conf
  487. /lib/systemd/system/cups.path.d/30_qubes.conf
  488. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  489. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  490. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  491. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  492. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  493. %post systemd
  494. PRESET_FAILED=0
  495. if [ $1 -eq 1 ]; then
  496. /bin/systemctl --no-reload preset-all > /dev/null 2>&1 && PRESET_FAILED=0 || PRESET_FAILED=1
  497. else
  498. services="qubes-dvm qubes-misc-post qubes-firewall qubes-mount-home"
  499. services="$services qubes-netwatcher qubes-network qubes-sysinit"
  500. services="$services qubes-updates-proxy qubes-qrexec-agent"
  501. for srv in $services; do
  502. /bin/systemctl --no-reload preset $srv.service
  503. done
  504. /bin/systemctl --no-reload preset qubes-update-check.timer
  505. fi
  506. # Set default "runlevel"
  507. rm -f /etc/systemd/system/default.target
  508. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  509. grep '^[[:space:]]*[^#;]' /lib/systemd/system-preset/75-qubes-vm.preset | while read action unit_name; do
  510. case "$action" in
  511. (disable)
  512. if [ -f /lib/systemd/system/$unit_name ]; then
  513. if ! fgrep -q '[Install]' /lib/systemd/system/$unit_name; then
  514. # forcibly disable
  515. ln -sf /dev/null /etc/systemd/system/$unit_name
  516. fi
  517. fi
  518. ;;
  519. *)
  520. # preset-all is not available in fc20; so preset each unit file listed in 75-qubes-vm.preset
  521. if [ $1 -eq 1 -a "${PRESET_FAILED}" -eq 1 ]; then
  522. systemctl --no-reload preset "${unit_name}" > /dev/null 2>&1 || true
  523. fi
  524. ;;
  525. esac
  526. done
  527. /bin/systemctl daemon-reload
  528. exit 0
  529. %postun systemd
  530. #Do not run this part on upgrades
  531. if [ "$1" != 0 ] ; then
  532. exit 0
  533. fi
  534. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-mount-home qubes-netwatcher qubes-network qubes-qrexec-agent; do
  535. /bin/systemctl disable $srv.service
  536. do