core-agent.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %define qubes_services qubes-core qubes-core-netvm qubes-core-early qubes-firewall qubes-iptables qubes-updates-proxy qubes-qrexec-agent qubes-updates-proxy-forwarder
  23. %define qubes_preset_file 75-qubes-vm.preset
  24. %{!?version: %define version %(cat version)}
  25. %{!?backend_vmm: %define backend_vmm %(echo $BACKEND_VMM)}
  26. %define scriptletfuns is_static() { \
  27. [ -f "%{_unitdir}/$1" ] && ! grep -q '^[[].nstall]' "%{_unitdir}/$1" \
  28. } \
  29. \
  30. is_masked() { \
  31. if [ ! -L %{_sysconfdir}/systemd/system/"$1" ] \
  32. then \
  33. return 1 \
  34. fi \
  35. target=`readlink %{_sysconfdir}/systemd/system/"$1" 2>/dev/null` || : \
  36. if [ "$target" = "/dev/null" ] \
  37. then \
  38. return 0 \
  39. fi \
  40. return 1 \
  41. } \
  42. \
  43. mask() { \
  44. ln -sf /dev/null %{_sysconfdir}/systemd/system/"$1" \
  45. } \
  46. \
  47. unmask() { \
  48. if ! is_masked "$1" \
  49. then \
  50. return 0 \
  51. fi \
  52. rm -f %{_sysconfdir}/systemd/system/"$1" \
  53. } \
  54. \
  55. preset_units() { \
  56. local represet= \
  57. cat "$1" | while read action unit_name \
  58. do \
  59. if [ "$action" = "#" -a "$unit_name" = "Units below this line will be re-preset on package upgrade" ] \
  60. then \
  61. represet=1 \
  62. continue \
  63. fi \
  64. echo "$action $unit_name" | grep -q '^[[:space:]]*[^#;]' || continue \
  65. [ -n "$action" -a -n "$unit_name" ] || continue \
  66. if [ "$2" = "initial" -o "$represet" = "1" ] \
  67. then \
  68. if [ "$action" = "disable" ] && is_static "$unit_name" \
  69. then \
  70. if ! is_masked "$unit_name" \
  71. then \
  72. # We must effectively mask these units, even if they are static. \
  73. mask "$unit_name" \
  74. fi \
  75. elif [ "$action" = "enable" ] && is_static "$unit_name" \
  76. then \
  77. if is_masked "$unit_name" \
  78. then \
  79. # We masked this static unit before, now we unmask it. \
  80. unmask "$unit_name" \
  81. fi \
  82. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  83. else \
  84. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  85. fi \
  86. fi \
  87. done \
  88. } \
  89. \
  90. restore_units() { \
  91. grep '^[[:space:]]*[^#;]' "$1" | while read action unit_name \
  92. do \
  93. if is_static "$unit_name" && is_masked "$unit_name" \
  94. then \
  95. # If the unit had been masked by us, we must unmask it here. \
  96. # Otherwise systemctl preset will fail badly. \
  97. unmask "$unit_name" \
  98. fi \
  99. systemctl --no-reload preset "$unit_name" >/dev/null 2>&1 || : \
  100. done \
  101. } \
  102. Name: qubes-core-agent
  103. Version: %{version}
  104. Release: 1%{dist}
  105. Summary: The Qubes core files for VM
  106. Group: Qubes
  107. Vendor: Invisible Things Lab
  108. License: GPL
  109. URL: http://www.qubes-os.org
  110. Requires: fedora-release
  111. %if %{fedora} < 22
  112. Requires: yum-plugin-post-transaction-actions
  113. %endif
  114. %if %{fedora} >= 18
  115. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  116. Conflicts: firewalld
  117. %endif
  118. Requires: xdg-utils
  119. Requires: ntpdate
  120. Requires: qubes-utils >= 3.1.3
  121. Requires: initscripts
  122. Requires: gawk
  123. Requires: sed
  124. Requires: util-linux
  125. # for qubes-desktop-run
  126. Requires: pygobject3-base
  127. Requires: dbus-python
  128. # for qubes-session-autostart, xdg-icon
  129. Requires: pyxdg
  130. Requires: python-daemon
  131. # for qvm-feature-request
  132. Requires: python2-qubesdb
  133. Requires: ImageMagick
  134. Requires: librsvg2-tools
  135. Requires: desktop-notification-daemon
  136. Requires: zenity
  137. Requires: qubes-libvchan
  138. Requires: qubes-db-vm
  139. %if 0%{fedora} >= 23
  140. Requires: python3-dnf-plugins-qubes-hooks
  141. %else
  142. Requires: python2-dnf-plugins-qubes-hooks
  143. %endif
  144. Obsoletes: qubes-core-vm-kernel-placeholder <= 1.0
  145. Obsoletes: qubes-upgrade-vm < 3.2
  146. Provides: qubes-core-vm = %{version}-%{release}
  147. Obsoletes: qubes-core-vm < 4.0.0
  148. Provides: qubes-core-vm-doc = %{version}-%{release}
  149. Obsoletes: qubes-core-vm-doc < 4.0.0
  150. BuildRequires: pandoc
  151. BuildRequires: xen-devel
  152. BuildRequires: libX11-devel
  153. BuildRequires: qubes-utils-devel >= 3.1.3
  154. BuildRequires: qubes-libvchan-%{backend_vmm}-devel
  155. %description
  156. The Qubes core files for installation inside a Qubes VM.
  157. %package -n python2-dnf-plugins-qubes-hooks
  158. Summary: DNF plugin for Qubes specific post-installation actions
  159. BuildRequires: python2-devel
  160. %{?python_provide:%python_provide python2-dnf-plugins-qubes-hooks}
  161. %description -n python2-dnf-plugins-qubes-hooks
  162. DNF plugin for Qubes specific post-installation actions:
  163. * notify dom0 that updates were installed
  164. * refresh applications shortcut list
  165. %package -n python3-dnf-plugins-qubes-hooks
  166. Summary: DNF plugin for Qubes specific post-installation actions
  167. BuildRequires: python3-devel
  168. %{?python_provide:%python_provide python3-dnf-plugins-qubes-hooks}
  169. %description -n python3-dnf-plugins-qubes-hooks
  170. DNF plugin for Qubes specific post-installation actions:
  171. * notify dom0 that updates were installed
  172. * refresh applications shortcut list
  173. %package nautilus
  174. Summary: Qubes integration for Nautilus
  175. Requires: qubes-core-agent
  176. Requires: nautilus-python
  177. %description nautilus
  178. Nautilus addons for inter-VM file copy/move/open.
  179. %package dom0-updates
  180. Summary: Scripts required to handle dom0 updates
  181. Requires: qubes-core-agent
  182. Requires: fakeroot
  183. %description dom0-updates
  184. Scripts required to handle dom0 updates.
  185. %package networking
  186. Summary: Networking support for Qubes VM
  187. Requires: ethtool
  188. Requires: net-tools
  189. Requires: nftables
  190. Requires: nmap-ncat
  191. Requires: qubes-core-agent
  192. Requires: tinyproxy
  193. %description networking
  194. This package provides:
  195. * basic network functionality (setting IP address, DNS, default gateway)
  196. * proxy service used by TemplateVMs to download updates
  197. * qubes-firewall service (FirewallVM)
  198. Note: if you want to use NetworkManager (you do want it in NetVM), install also
  199. qubes-core-agent-network-manager.
  200. %package network-manager
  201. Summary: NetworkManager integration for Qubes VM
  202. # to show/hide nm-applet
  203. Requires: NetworkManager >= 0.8.1-1
  204. Requires: dconf
  205. Requires: qubes-core-agent-networking
  206. %description network-manager
  207. Integration of NetworkManager for Qubes VM:
  208. * make connections config persistent
  209. * adjust DNS redirections when needed
  210. * show/hide NetworkManager applet icon
  211. %define _builddir %(pwd)
  212. %define kde_service_dir /usr/share/kde4/services
  213. %prep
  214. # we operate on the current directory, so no need to unpack anything
  215. # symlink is to generate useful debuginfo packages
  216. rm -f %{name}-%{version}
  217. ln -sf . %{name}-%{version}
  218. %setup -T -D
  219. %build
  220. for dir in qubes-rpc qrexec misc; do
  221. (cd $dir; make)
  222. done
  223. make -C doc manpages
  224. %pre
  225. # Make sure there is a qubes group
  226. groupadd --force --system --gid 98 qubes
  227. id -u 'user' >/dev/null 2>&1 || {
  228. useradd --user-group --create-home --shell /bin/bash user
  229. }
  230. usermod -a --groups qubes user
  231. if [ "$1" != 1 ] ; then
  232. # do this whole %%pre thing only when updating for the first time...
  233. exit 0
  234. fi
  235. mkdir -p /var/lib/qubes
  236. if [ -e /etc/fstab ] ; then
  237. mv /etc/fstab /var/lib/qubes/fstab.orig
  238. fi
  239. usermod -p '' root
  240. usermod -L user
  241. %install
  242. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  243. make install-vm DESTDIR=$RPM_BUILD_ROOT
  244. make -C doc install DESTDIR=$RPM_BUILD_ROOT
  245. %if %{fedora} >= 22
  246. rm -f $RPM_BUILD_ROOT/etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  247. %endif
  248. %triggerin -- initscripts
  249. if [ -e /etc/init/serial.conf ]; then
  250. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  251. fi
  252. %post
  253. # disable some Upstart services
  254. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  255. if [ -e /etc/init/$F.conf ]; then
  256. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  257. fi
  258. done
  259. # Remove old firmware updates link
  260. if [ -L /lib/firmware/updates ]; then
  261. rm -f /lib/firmware/updates
  262. fi
  263. if test -f /etc/yum.conf && ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  264. echo >> /etc/yum.conf
  265. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  266. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  267. fi
  268. # And actually setup the proxy usage in package managers
  269. /usr/lib/qubes/update-proxy-configs
  270. # Location of files which contains list of protected files
  271. mkdir -p /etc/qubes/protected-files.d
  272. . /usr/lib/qubes/init/functions
  273. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  274. if ! is_protected_file /etc/hosts ; then
  275. if ! grep -q localhost /etc/hosts; then
  276. cat <<EOF > /etc/hosts
  277. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  278. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  279. EOF
  280. fi
  281. fi
  282. # ensure that hostname resolves to 127.0.0.1 resp. ::1 and that /etc/hosts is
  283. # in the form expected by qubes-sysinit.sh
  284. if ! is_protected_file /etc/hostname ; then
  285. for ip in '127\.0\.0\.1' '::1'; do
  286. if grep -q "^${ip}\(\s\|$\)" /etc/hosts; then
  287. sed -i "/^${ip}\s/,+0s/\(\s`hostname`\)\+\(\s\|$\)/\2/g" /etc/hosts
  288. sed -i "s/^${ip}\(\s\|$\).*$/\0 `hostname`/" /etc/hosts
  289. else
  290. echo "${ip} `hostname`" >> /etc/hosts
  291. fi
  292. done
  293. fi
  294. %if %{fedora} >= 20
  295. # Make sure there is a default locale set so gnome-terminal will start
  296. if [ ! -e /etc/locale.conf ] || ! grep -q LANG /etc/locale.conf; then
  297. touch /etc/locale.conf
  298. echo "LANG=en_US.UTF-8" >> /etc/locale.conf
  299. fi
  300. # ... and make sure it is really generated
  301. current_locale=`grep LANG /etc/locale.conf|cut -f 2 -d = | tr -d '"'`
  302. if [ -n "$current_locale" ] && ! locale -a | grep -q "$current_locale"; then
  303. base=`echo "$current_locale" | cut -f 1 -d .`
  304. charmap=`echo "$current_locale.UTF-8" | cut -f 2 -d .`
  305. [ -n "$charmap" ] && charmap="-f $charmap"
  306. localedef -i $base $charmap $current_locale
  307. fi
  308. %endif
  309. if [ "$1" != 1 ] ; then
  310. # do the rest of %%post thing only when updating for the first time...
  311. exit 0
  312. fi
  313. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  314. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  315. fi
  316. # Remove most of the udev scripts to speed up the VM boot time
  317. # Just leave the xen* scripts, that are needed if this VM was
  318. # ever used as a net backend (e.g. as a VPN domain in the future)
  319. #echo "--> Removing unnecessary udev scripts..."
  320. mkdir -p /var/lib/qubes/removed-udev-scripts
  321. for f in /etc/udev/rules.d/*
  322. do
  323. if [ $(basename $f) == "xen-backend.rules" ] ; then
  324. continue
  325. fi
  326. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  327. continue
  328. fi
  329. if echo $f | grep -q qubes; then
  330. continue
  331. fi
  332. mv $f /var/lib/qubes/removed-udev-scripts/
  333. done
  334. mkdir -p /rw
  335. #rm -f /etc/mtab
  336. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  337. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  338. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  339. %triggerin -- notification-daemon
  340. # Enable autostart of notification-daemon when installed
  341. if [ ! -e /etc/xdg/autostart/notification-daemon.desktop ]; then
  342. ln -s /usr/share/applications/notification-daemon.desktop /etc/xdg/autostart/
  343. fi
  344. exit 0
  345. %triggerin -- selinux-policy
  346. #echo "--> Disabling SELinux..."
  347. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  348. mv /etc/selinux/config.processed /etc/selinux/config
  349. setenforce 0 2>/dev/null
  350. exit 0
  351. %post network-manager
  352. # Create NetworkManager configuration if we do not have it
  353. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  354. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  355. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  356. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  357. fi
  358. # Remove ip_forward setting from sysctl, so NM will not reset it
  359. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  360. /usr/lib/qubes/qubes-fix-nm-conf.sh
  361. %preun
  362. if [ "$1" = 0 ] ; then
  363. # no more packages left
  364. if [ -e /var/lib/qubes/fstab.orig ] ; then
  365. mv /var/lib/qubes/fstab.orig /etc/fstab
  366. fi
  367. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  368. if [ -e /var/lib/qubes/serial.orig ] ; then
  369. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  370. fi
  371. fi
  372. %postun
  373. if [ $1 -eq 0 ] ; then
  374. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  375. if [ -L /lib/firmware/updates ]; then
  376. rm /lib/firmware/updates
  377. fi
  378. rm -rf /var/lib/qubes/xdg
  379. fi
  380. %posttrans
  381. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  382. %clean
  383. rm -rf $RPM_BUILD_ROOT
  384. rm -f %{name}-%{version}
  385. %files
  386. %defattr(-,root,root,-)
  387. %dir /var/lib/qubes
  388. %dir /var/run/qubes
  389. %{kde_service_dir}/qvm-copy.desktop
  390. %{kde_service_dir}/qvm-move.desktop
  391. %{kde_service_dir}/qvm-dvm.desktop
  392. %config(noreplace) /etc/X11/xorg-preload-apps.conf
  393. /etc/fstab
  394. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  395. %config(noreplace) /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  396. %config(noreplace) /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  397. %dir /etc/qubes-rpc
  398. %config(noreplace) /etc/qubes-rpc/qubes.Filecopy
  399. %config(noreplace) /etc/qubes-rpc/qubes.OpenInVM
  400. %config(noreplace) /etc/qubes-rpc/qubes.OpenURL
  401. %config(noreplace) /etc/qubes-rpc/qubes.GetAppmenus
  402. %config(noreplace) /etc/qubes-rpc/qubes.VMShell
  403. %config(noreplace) /etc/qubes-rpc/qubes.SyncNtpClock
  404. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPre
  405. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPreAll
  406. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPost
  407. %config(noreplace) /etc/qubes-rpc/qubes.SuspendPostAll
  408. %config(noreplace) /etc/qubes-rpc/qubes.WaitForSession
  409. %config(noreplace) /etc/qubes-rpc/qubes.DetachPciDevice
  410. %config(noreplace) /etc/qubes-rpc/qubes.Backup
  411. %config(noreplace) /etc/qubes-rpc/qubes.Restore
  412. %config(noreplace) /etc/qubes-rpc/qubes.SelectFile
  413. %config(noreplace) /etc/qubes-rpc/qubes.SelectDirectory
  414. %config(noreplace) /etc/qubes-rpc/qubes.GetImageRGBA
  415. %config(noreplace) /etc/qubes-rpc/qubes.SetDateTime
  416. %config(noreplace) /etc/qubes-rpc/qubes.InstallUpdatesGUI
  417. %config(noreplace) /etc/qubes-rpc/qubes.ResizeDisk
  418. %config(noreplace) /etc/qubes-rpc/qubes.StartApp
  419. %config(noreplace) /etc/qubes-rpc/qubes.PostInstall
  420. %dir /etc/qubes/autostart
  421. /etc/qubes/autostart/README.txt
  422. %config /etc/qubes/autostart/*.desktop.d/30_qubes.conf
  423. %dir /etc/qubes/suspend-pre.d
  424. /etc/qubes/suspend-pre.d/README
  425. %dir /etc/qubes/suspend-post.d
  426. /etc/qubes/suspend-post.d/README
  427. %dir /etc/qubes/post-install.d
  428. /etc/qubes/post-install.d/README
  429. /etc/qubes/post-install.d/*.sh
  430. %config(noreplace) /etc/sudoers.d/qubes
  431. %config(noreplace) /etc/sudoers.d/qt_x11_no_mitshm
  432. %config(noreplace) /etc/sysctl.d/20_tcp_timestamps.conf
  433. %config(noreplace) /etc/udev/rules.d/50-qubes-misc.rules
  434. %config(noreplace) /etc/qubes-suspend-module-blacklist
  435. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  436. %config(noreplace) /etc/yum.repos.d/qubes-r3.repo
  437. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  438. %config(noreplace) /etc/dnf/plugins/qubes-hooks.conf
  439. %if %{fedora} < 22
  440. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  441. %endif
  442. /usr/lib/systemd/system/user@.service.d/90-session-stop-timeout.conf
  443. /usr/sbin/qubes-serial-login
  444. /usr/bin/qvm-copy-to-vm
  445. /usr/bin/qvm-move-to-vm
  446. /usr/bin/qvm-open-in-dvm
  447. /usr/bin/qvm-open-in-vm
  448. /usr/bin/qvm-run-vm
  449. /usr/bin/qvm-features-request
  450. /usr/bin/xenstore-watch-qubes
  451. /usr/bin/qubes-desktop-run
  452. /usr/bin/qubes-open
  453. /usr/bin/qrexec-fork-server
  454. /usr/bin/qrexec-client-vm
  455. /usr/bin/qubes-session-autostart
  456. %dir /usr/lib/qubes
  457. /usr/lib/qubes/vusb-ctl.py*
  458. /usr/lib/qubes/sync-ntp-clock
  459. /usr/lib/qubes/prepare-suspend
  460. /usr/lib/qubes/qrexec-agent
  461. /usr/lib/qubes/qrexec-client-vm
  462. /usr/lib/qubes/qrexec_client_vm
  463. /usr/lib/qubes/qubes-rpc-multiplexer
  464. /usr/lib/qubes/qfile-agent
  465. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  466. /usr/lib/qubes/qopen-in-vm
  467. /usr/lib/qubes/qrun-in-vm
  468. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  469. /usr/lib/qubes/qvm-copy-to-vm.kde
  470. /usr/lib/qubes/qvm-move-to-vm.kde
  471. /usr/lib/qubes/tar2qfile
  472. /usr/lib/qubes/vm-file-editor
  473. /usr/lib/qubes/close-window
  474. /usr/lib/qubes/xdg-icon
  475. /usr/lib/qubes/update-proxy-configs
  476. /usr/lib/qubes/upgrades-installed-check
  477. /usr/lib/qubes/upgrades-status-notify
  478. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  479. /usr/lib/dracut/dracut.conf.d/30-qubes.conf
  480. %dir /usr/lib/qubes/init
  481. /usr/lib/qubes/init/bind-dirs.sh
  482. /usr/lib/qubes/init/control-printer-icon.sh
  483. /usr/lib/qubes/init/functions
  484. /usr/lib/qubes/init/misc-post-stop.sh
  485. /usr/lib/qubes/init/misc-post.sh
  486. /usr/lib/qubes/init/mount-dirs.sh
  487. /usr/lib/qubes/init/qubes-early-vm-config.sh
  488. /usr/lib/qubes/init/qubes-random-seed.sh
  489. /usr/lib/qubes/init/qubes-sysinit.sh
  490. /usr/lib/qubes/init/setup-rw.sh
  491. /usr/lib/qubes/init/setup-rwdev.sh
  492. /usr/lib/qubes/init/functions
  493. %dir /usr/lib/qubes-bind-dirs.d
  494. /usr/lib/qubes-bind-dirs.d/30_cron.conf
  495. /usr/lib/python2.7/site-packages/qubesxdg.py*
  496. /usr/share/qubes/serial.conf
  497. /usr/share/glib-2.0/schemas/20_org.gnome.settings-daemon.plugins.updates.qubes.gschema.override
  498. /usr/share/glib-2.0/schemas/20_org.gnome.nautilus.qubes.gschema.override
  499. /usr/share/glib-2.0/schemas/20_org.mate.NotificationDaemon.qubes.gschema.override
  500. /usr/share/glib-2.0/schemas/20_org.gnome.desktop.wm.preferences.qubes.gschema.override
  501. %{_mandir}/man1/qvm-*.1*
  502. %dir %{python_sitelib}/qubesagent-*-py2.7.egg-info
  503. %{python_sitelib}/qubesagent-*-py2.7.egg-info/*
  504. %dir %{python_sitelib}/qubesagent
  505. %{python_sitelib}/qubesagent/__init__.py*
  506. %{python_sitelib}/qubesagent/firewall.py*
  507. %{python_sitelib}/qubesagent/test_firewall.py*
  508. /usr/share/qubes/mime-override/globs
  509. /usr/share/qubes/qubes-master-key.asc
  510. %dir /mnt/removable
  511. %dir /rw
  512. %files -n python2-dnf-plugins-qubes-hooks
  513. %{python2_sitelib}/dnf-plugins/*
  514. %files -n python3-dnf-plugins-qubes-hooks
  515. %{python3_sitelib}/dnf-plugins/*
  516. %files nautilus
  517. /usr/lib/qubes/qvm-copy-to-vm.gnome
  518. /usr/lib/qubes/qvm-move-to-vm.gnome
  519. /usr/share/nautilus-python/extensions/qvm_copy_nautilus.py*
  520. /usr/share/nautilus-python/extensions/qvm_move_nautilus.py*
  521. /usr/share/nautilus-python/extensions/qvm_dvm_nautilus.py*
  522. %files dom0-updates
  523. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  524. /usr/lib/qubes/qubes-download-dom0-updates.sh
  525. %files networking
  526. %config(noreplace) /etc/qubes-rpc/qubes.UpdatesProxy
  527. %config(noreplace) /etc/qubes/ip6tables.rules
  528. %config(noreplace) /etc/qubes/iptables.rules
  529. %config(noreplace) /etc/tinyproxy/tinyproxy-updates.conf
  530. %config(noreplace) /etc/tinyproxy/updates-blacklist
  531. %config(noreplace) /etc/udev/rules.d/99-qubes-network.rules
  532. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  533. /etc/xen/scripts/vif-qubes-nat.sh
  534. /etc/xen/scripts/vif-route-qubes
  535. /lib/systemd/system/qubes-firewall.service
  536. /lib/systemd/system/qubes-iptables.service
  537. /lib/systemd/system/qubes-network.service
  538. /lib/systemd/system/qubes-updates-proxy.service
  539. /usr/lib/qubes/init/network-proxy-setup.sh
  540. /usr/lib/qubes/init/qubes-iptables
  541. /usr/lib/qubes/iptables-updates-proxy
  542. /usr/lib/qubes/qubes-setup-dnat-to-ns
  543. /usr/lib/qubes/setup-ip
  544. /usr/lib/tmpfiles.d/qubes-core-agent-linux.conf
  545. /usr/sbin/qubes-firewall
  546. %files network-manager
  547. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  548. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  549. /etc/xdg/autostart/00-qubes-show-hide-nm-applet.desktop
  550. /usr/lib/NetworkManager/conf.d/30-qubes.conf
  551. /usr/lib/qubes/network-manager-prepare-conf-dir
  552. /usr/lib/qubes/qubes-fix-nm-conf.sh
  553. /usr/lib/qubes/show-hide-nm-applet.sh
  554. %package sysvinit
  555. Summary: Qubes unit files for SysV init style or upstart
  556. License: GPL v2 only
  557. Group: Qubes
  558. Requires: upstart
  559. Requires: qubes-core-agent
  560. Requires: qubes-core-agent-networking
  561. Provides: qubes-core-agent-init-scripts
  562. Conflicts: qubes-core-agent-systemd
  563. Provides: qubes-core-vm-sysvinit = %{version}-%{release}
  564. Obsoletes: qubes-core-vm-sysvinit < 4.0.0
  565. %description sysvinit
  566. The Qubes core startup configuration for SysV init (or upstart).
  567. %files sysvinit
  568. /etc/init.d/qubes-sysinit
  569. /etc/init.d/qubes-core-early
  570. /etc/init.d/qubes-core
  571. /etc/init.d/qubes-core-netvm
  572. /etc/init.d/qubes-firewall
  573. /etc/init.d/qubes-iptables
  574. /etc/init.d/qubes-updates-proxy
  575. /etc/init.d/qubes-qrexec-agent
  576. /etc/init.d/qubes-updates-proxy-forwarder
  577. /etc/sysconfig/modules/qubes-core.modules
  578. /etc/sysconfig/modules/qubes-misc.modules
  579. %post sysvinit
  580. #echo "--> Turning off unnecessary services..."
  581. # FIXME: perhaps there is more elegant way to do this?
  582. for f in /etc/init.d/*
  583. do
  584. srv=`basename $f`
  585. [ $srv = 'functions' ] && continue
  586. [ $srv = 'killall' ] && continue
  587. [ $srv = 'halt' ] && continue
  588. [ $srv = 'single' ] && continue
  589. [ $srv = 'reboot' ] && continue
  590. [ $srv = 'qubes-gui' ] && continue
  591. chkconfig $srv off
  592. done
  593. #echo "--> Enabling essential services..."
  594. chkconfig rsyslog on
  595. chkconfig haldaemon on
  596. chkconfig messagebus on
  597. for svc in %qubes_services ; do
  598. if [ "$1" = 1 ] ; then
  599. chkconfig --add $svc || echo "WARNING: Cannot add service $svc!"
  600. else
  601. chkconfig $svc resetpriorities || echo "WARNING: Cannot reset priorities of service $svc!"
  602. fi
  603. done
  604. # dropped services
  605. chkconfig qubes-netwatcher off || :
  606. # TODO: make this not display the silly message about security context...
  607. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  608. %preun sysvinit
  609. if [ "$1" = 0 ] ; then
  610. # no more packages left
  611. for svc in %qubes_services ; do
  612. chkconfig --del $svc
  613. done
  614. fi
  615. %package systemd
  616. Summary: Qubes unit files for SystemD init style
  617. License: GPL v2 only
  618. Group: Qubes
  619. Requires: systemd
  620. Requires(post): systemd-units
  621. Requires(preun): systemd-units
  622. Requires(postun): systemd-units
  623. Requires: qubes-core-agent
  624. Provides: qubes-core-agent-init-scripts
  625. Conflicts: qubes-core-agent-sysvinit
  626. Provides: qubes-core-vm-systemd = %{version}-%{release}
  627. Obsoletes: qubes-core-vm-systemd < 4.0.0
  628. %description systemd
  629. The Qubes core startup configuration for SystemD init.
  630. %files systemd
  631. %defattr(-,root,root,-)
  632. /lib/systemd/system/qubes-misc-post.service
  633. /lib/systemd/system/qubes-mount-dirs.service
  634. /lib/systemd/system/qubes-sysinit.service
  635. /lib/systemd/system/qubes-early-vm-config.service
  636. /lib/systemd/system/qubes-update-check.service
  637. /lib/systemd/system/qubes-update-check.timer
  638. /lib/systemd/system/qubes-qrexec-agent.service
  639. /lib/systemd/system/qubes-updates-proxy-forwarder@.service
  640. /lib/systemd/system/qubes-updates-proxy-forwarder.socket
  641. /lib/systemd/system-preset/%qubes_preset_file
  642. /lib/modules-load.d/qubes-core.conf
  643. /lib/modules-load.d/qubes-misc.conf
  644. /lib/systemd/system/chronyd.service.d/30_qubes.conf
  645. /lib/systemd/system/crond.service.d/30_qubes.conf
  646. /lib/systemd/system/cups.service.d/30_qubes.conf
  647. /lib/systemd/system/cups.socket.d/30_qubes.conf
  648. /lib/systemd/system/cups.path.d/30_qubes.conf
  649. /lib/systemd/system/org.cups.cupsd.service.d/30_qubes.conf
  650. /lib/systemd/system/org.cups.cupsd.socket.d/30_qubes.conf
  651. /lib/systemd/system/org.cups.cupsd.path.d/30_qubes.conf
  652. /lib/systemd/system/getty@tty.service.d/30_qubes.conf
  653. /lib/systemd/system/ModemManager.service.d/30_qubes.conf
  654. /lib/systemd/system/NetworkManager.service.d/30_qubes.conf
  655. /lib/systemd/system/NetworkManager-wait-online.service.d/30_qubes.conf
  656. /lib/systemd/system/ntpd.service.d/30_qubes.conf
  657. /lib/systemd/system/systemd-random-seed.service.d/30_qubes.conf
  658. /lib/systemd/system/tinyproxy.service.d/30_not_needed_in_qubes_by_default.conf
  659. /lib/systemd/system/tor.service.d/30_qubes.conf
  660. /lib/systemd/system/tor@default.service.d/30_qubes.conf
  661. /lib/systemd/system/tmp.mount.d/30_qubes.conf
  662. /usr/lib/systemd/user/pulseaudio.service.d/30_qubes.conf
  663. /usr/lib/systemd/user/pulseaudio.socket.d/30_qubes.conf
  664. %post systemd
  665. changed=
  666. %scriptletfuns
  667. if [ $1 -eq 1 ]
  668. then
  669. preset_units %{_presetdir}/%qubes_preset_file initial
  670. changed=true
  671. else
  672. preset_units %{_presetdir}/%qubes_preset_file upgrade
  673. changed=true
  674. # Upgrade path - now qubes-iptables is used instead
  675. for svc in iptables ip6tables
  676. do
  677. if [ -f "$svc".service ]
  678. then
  679. systemctl --no-reload preset "$svc".service
  680. changed=true
  681. fi
  682. done
  683. fi
  684. if [ $1 -eq 1 ]
  685. then
  686. # First install.
  687. # Set default "runlevel".
  688. # FIXME: this ought to be done via kernel command line.
  689. # The fewer deviations of the template from the seed
  690. # image, the better.
  691. rm -f %{_sysconfdir}/systemd/system/default.target
  692. ln -s %{_unitdir}/multi-user.target %{_sysconfdir}/systemd/system/default.target
  693. changed=true
  694. fi
  695. # remove old symlinks
  696. if [ -L %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service ]
  697. then
  698. rm -f %{_sysconfdir}/systemd/system/sysinit.target.wants/qubes-random-seed.service
  699. changed=true
  700. fi
  701. if [ -L %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service ]
  702. then
  703. rm -f %{_sysconfdir}/systemd/system/multi-user.target.wants/qubes-mount-home.service
  704. changed=true
  705. fi
  706. if [ "x$changed" != "x" ]
  707. then
  708. systemctl daemon-reload
  709. fi
  710. %preun systemd
  711. if [ $1 -eq 0 ] ; then
  712. # Run this only during uninstall.
  713. # Save the preset file to later use it to re-preset services there
  714. # once the Qubes OS preset file is removed.
  715. mkdir -p %{_rundir}/qubes-uninstall
  716. cp -f %{_presetdir}/%qubes_preset_file %{_rundir}/qubes-uninstall/
  717. fi
  718. %postun systemd
  719. changed=
  720. %scriptletfuns
  721. if [ -d %{_rundir}/qubes-uninstall ]
  722. then
  723. # We have a saved preset file (or more).
  724. # Re-preset the units mentioned there.
  725. restore_units %{_rundir}/qubes-uninstall/%qubes_preset_file
  726. rm -rf %{_rundir}/qubes-uninstall
  727. changed=true
  728. fi
  729. if [ "x$changed" != "x" ]
  730. then
  731. systemctl daemon-reload
  732. fi