core-vm.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562
  1. #
  2. # The Qubes OS Project, http://www.qubes-os.org
  3. #
  4. # Copyright (C) 2010 Joanna Rutkowska <joanna@invisiblethingslab.com>
  5. # Copyright (C) 2010 Rafal Wojtczuk <rafal@invisiblethingslab.com>
  6. #
  7. # This program is free software; you can redistribute it and/or
  8. # modify it under the terms of the GNU General Public License
  9. # as published by the Free Software Foundation; either version 2
  10. # of the License, or (at your option) any later version.
  11. #
  12. # This program is distributed in the hope that it will be useful,
  13. # but WITHOUT ANY WARRANTY; without even the implied warranty of
  14. # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
  15. # GNU General Public License for more details.
  16. #
  17. # You should have received a copy of the GNU General Public License
  18. # along with this program; if not, write to the Free Software
  19. # Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA.
  20. #
  21. #
  22. %{!?version: %define version %(cat version)}
  23. Name: qubes-core-vm
  24. Version: %{version}
  25. Release: 1%{dist}
  26. Summary: The Qubes core files for VM
  27. Group: Qubes
  28. Vendor: Invisible Things Lab
  29. License: GPL
  30. URL: http://www.qubes-os.org
  31. Requires: /usr/bin/xenstore-read
  32. Requires: fedora-release
  33. Requires: yum-plugin-post-transaction-actions
  34. Requires: NetworkManager >= 0.8.1-1
  35. %if %{fedora} >= 18
  36. # Fedora >= 18 defaults to firewalld, which isn't supported nor needed by Qubes
  37. Requires: iptables-services
  38. Conflicts: firewalld
  39. %endif
  40. Requires: /usr/bin/mimeopen
  41. Requires: ethtool
  42. Requires: tinyproxy
  43. Requires: ntpdate
  44. Requires: net-tools
  45. Requires: nautilus-actions
  46. Requires: qubes-core-vm-kernel-placeholder
  47. Requires: qubes-utils
  48. %if %{fedora} >= 20
  49. # gpk-update-viewer required by qubes-manager
  50. Requires: gnome-packagekit-updater
  51. %endif
  52. Provides: qubes-core-vm
  53. Obsoletes: qubes-core-commonvm
  54. Obsoletes: qubes-core-appvm
  55. Obsoletes: qubes-core-netvm
  56. Obsoletes: qubes-core-proxyvm
  57. Obsoletes: qubes-upgrade-vm < 2.0
  58. BuildRequires: xen-devel
  59. BuildRequires: qubes-utils-devel
  60. %define _builddir %(pwd)
  61. %define kde_service_dir /usr/share/kde4/services
  62. %description
  63. The Qubes core files for installation inside a Qubes VM.
  64. %prep
  65. # we operate on the current directory, so no need to unpack anything
  66. # symlink is to generate useful debuginfo packages
  67. rm -f %{name}-%{version}
  68. ln -sf . %{name}-%{version}
  69. %setup -T -D
  70. %build
  71. for dir in qubes-rpc qrexec misc; do
  72. (cd $dir; make)
  73. done
  74. %pre
  75. if [ "$1" != 1 ] ; then
  76. # do this whole %pre thing only when updating for the first time...
  77. exit 0
  78. fi
  79. mkdir -p /var/lib/qubes
  80. if [ -e /etc/fstab ] ; then
  81. mv /etc/fstab /var/lib/qubes/fstab.orig
  82. fi
  83. adduser --create-home user
  84. %install
  85. (cd qrexec; make install DESTDIR=$RPM_BUILD_ROOT)
  86. make install-vm DESTDIR=$RPM_BUILD_ROOT
  87. # Create ghost files to silent rpmbuild warnings, those files will NOT be
  88. # included in package
  89. mkdir -p $RPM_BUILD_ROOT/etc/systemd/system
  90. for f in ModemManager.service NetworkManager.service \
  91. NetworkManager-wait-online.service cups.service cups.socket cups.path; do
  92. cp $RPM_BUILD_ROOT/usr/lib/qubes/init/$f $RPM_BUILD_ROOT/etc/systemd/system/
  93. done
  94. %triggerin -- initscripts
  95. if [ -e /etc/init/serial.conf ]; then
  96. cp /usr/share/qubes/serial.conf /etc/init/serial.conf
  97. fi
  98. %post
  99. # disable some Upstart services
  100. for F in plymouth-shutdown prefdm splash-manager start-ttys tty ; do
  101. if [ -e /etc/init/$F.conf ]; then
  102. mv -f /etc/init/$F.conf /etc/init/$F.conf.disabled
  103. fi
  104. done
  105. remove_ShowIn () {
  106. if [ -e /etc/xdg/autostart/$1.desktop ]; then
  107. sed -i '/^\(Not\|Only\)ShowIn/d' /etc/xdg/autostart/$1.desktop
  108. fi
  109. }
  110. # don't want it at all
  111. for F in abrt-applet deja-dup-monitor imsettings-start krb5-auth-dialog pulseaudio restorecond sealertauto gnome-power-manager gnome-sound-applet gnome-screensaver orca-autostart; do
  112. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  113. remove_ShowIn $F
  114. echo 'NotShowIn=QUBES;' >> /etc/xdg/autostart/$F.desktop
  115. fi
  116. done
  117. # don't want it in DisposableVM
  118. for F in gcm-apply ; do
  119. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  120. remove_ShowIn $F
  121. echo 'NotShowIn=DisposableVM;' >> /etc/xdg/autostart/$F.desktop
  122. fi
  123. done
  124. # want it in AppVM only
  125. for F in gnome-keyring-gpg gnome-keyring-pkcs11 gnome-keyring-secrets gnome-keyring-ssh gnome-settings-daemon user-dirs-update-gtk gsettings-data-convert ; do
  126. if [ -e /etc/xdg/autostart/$F.desktop ]; then
  127. remove_ShowIn $F
  128. echo 'OnlyShowIn=GNOME;AppVM;' >> /etc/xdg/autostart/$F.desktop
  129. fi
  130. done
  131. # remove existing rule to add own later
  132. for F in gpk-update-icon nm-applet ; do
  133. remove_ShowIn $F
  134. done
  135. echo 'OnlyShowIn=GNOME;UpdateableVM;' >> /etc/xdg/autostart/gpk-update-icon.desktop || :
  136. %if %{fedora} >= 20
  137. echo 'OnlyShowIn=GNOME;QUBES;' >> /etc/xdg/autostart/nm-applet.desktop || :
  138. %else
  139. echo 'OnlyShowIn=GNOME;NetVM;' >> /etc/xdg/autostart/nm-applet.desktop || :
  140. %endif
  141. usermod -p '' root
  142. usermod -L user
  143. # Create NetworkManager configuration if we do not have it
  144. if ! [ -e /etc/NetworkManager/NetworkManager.conf ]; then
  145. echo '[main]' > /etc/NetworkManager/NetworkManager.conf
  146. echo 'plugins = keyfile' >> /etc/NetworkManager/NetworkManager.conf
  147. echo '[keyfile]' >> /etc/NetworkManager/NetworkManager.conf
  148. fi
  149. /usr/lib/qubes/qubes-fix-nm-conf.sh
  150. # Remove ip_forward setting from sysctl, so NM will not reset it
  151. sed 's/^net.ipv4.ip_forward.*/#\0/' -i /etc/sysctl.conf
  152. # Install firmware link only on system which haven't it yet
  153. if ! [ -e /lib/firmware/updates ]; then
  154. ln -s /lib/modules/firmware /lib/firmware/updates
  155. fi
  156. if ! grep -q '/etc/yum\.conf\.d/qubes-proxy\.conf' /etc/yum.conf; then
  157. echo >> /etc/yum.conf
  158. echo '# Yum does not support inclusion of config dir...' >> /etc/yum.conf
  159. echo 'include=file:///etc/yum.conf.d/qubes-proxy.conf' >> /etc/yum.conf
  160. fi
  161. # Revert 'Prevent unnecessary updates in VMs':
  162. sed -i -e '/^exclude = kernel/d' /etc/yum.conf
  163. # qubes-core-vm has been broken for some time - it overrides /etc/hosts; restore original content
  164. if ! grep -q localhost /etc/hosts; then
  165. cat <<EOF > /etc/hosts
  166. 127.0.0.1 localhost localhost.localdomain localhost4 localhost4.localdomain4 `hostname`
  167. ::1 localhost localhost.localdomain localhost6 localhost6.localdomain6
  168. EOF
  169. fi
  170. if [ "$1" != 1 ] ; then
  171. # do the rest of %post thing only when updating for the first time...
  172. exit 0
  173. fi
  174. if [ -e /etc/init/serial.conf ] && ! [ -f /var/lib/qubes/serial.orig ] ; then
  175. cp /etc/init/serial.conf /var/lib/qubes/serial.orig
  176. fi
  177. #echo "--> Disabling SELinux..."
  178. sed -e s/^SELINUX=.*$/SELINUX=disabled/ </etc/selinux/config >/etc/selinux/config.processed
  179. mv /etc/selinux/config.processed /etc/selinux/config
  180. setenforce 0 2>/dev/null
  181. # Remove most of the udev scripts to speed up the VM boot time
  182. # Just leave the xen* scripts, that are needed if this VM was
  183. # ever used as a net backend (e.g. as a VPN domain in the future)
  184. #echo "--> Removing unnecessary udev scripts..."
  185. mkdir -p /var/lib/qubes/removed-udev-scripts
  186. for f in /etc/udev/rules.d/*
  187. do
  188. if [ $(basename $f) == "xen-backend.rules" ] ; then
  189. continue
  190. fi
  191. if [ $(basename $f) == "50-qubes-misc.rules" ] ; then
  192. continue
  193. fi
  194. if echo $f | grep -q qubes; then
  195. continue
  196. fi
  197. mv $f /var/lib/qubes/removed-udev-scripts/
  198. done
  199. mkdir -p /rw
  200. #rm -f /etc/mtab
  201. #echo "--> Removing HWADDR setting from /etc/sysconfig/network-scripts/ifcfg-eth0"
  202. #mv /etc/sysconfig/network-scripts/ifcfg-eth0 /etc/sysconfig/network-scripts/ifcfg-eth0.orig
  203. #grep -v HWADDR /etc/sysconfig/network-scripts/ifcfg-eth0.orig > /etc/sysconfig/network-scripts/ifcfg-eth0
  204. %preun
  205. if [ "$1" = 0 ] ; then
  206. # no more packages left
  207. if [ -e /var/lib/qubes/fstab.orig ] ; then
  208. mv /var/lib/qubes/fstab.orig /etc/fstab
  209. fi
  210. mv /var/lib/qubes/removed-udev-scripts/* /etc/udev/rules.d/
  211. if [ -e /var/lib/qubes/serial.orig ] ; then
  212. mv /var/lib/qubes/serial.orig /etc/init/serial.conf
  213. fi
  214. fi
  215. %postun
  216. if [ $1 -eq 0 ] ; then
  217. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  218. if [ -l /lib/firmware/updates ]; then
  219. rm /lib/firmware/updates
  220. fi
  221. fi
  222. %posttrans
  223. /usr/bin/glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  224. %clean
  225. rm -rf $RPM_BUILD_ROOT
  226. rm -f %{name}-%{version}
  227. %files
  228. %defattr(-,root,root,-)
  229. %dir /var/lib/qubes
  230. %dir /var/run/qubes
  231. %dir %attr(0775,user,user) /var/lib/qubes/dom0-updates
  232. %{kde_service_dir}/qvm-copy.desktop
  233. %{kde_service_dir}/qvm-dvm.desktop
  234. /etc/NetworkManager/dispatcher.d/30-qubes-external-ip
  235. /etc/NetworkManager/dispatcher.d/qubes-nmhook
  236. /etc/X11/xorg-preload-apps.conf
  237. /etc/dispvm-dotfiles.tbz
  238. /etc/dhclient.d/qubes-setup-dnat-to-ns.sh
  239. /etc/fstab
  240. /etc/pki/rpm-gpg/RPM-GPG-KEY-qubes*
  241. /etc/polkit-1/localauthority/50-local.d/qubes-allow-all.pkla
  242. /etc/polkit-1/rules.d/00-qubes-allow-all.rules
  243. %dir /etc/qubes-rpc
  244. /etc/qubes-rpc/qubes.Filecopy
  245. /etc/qubes-rpc/qubes.OpenInVM
  246. /etc/qubes-rpc/qubes.GetAppmenus
  247. /etc/qubes-rpc/qubes.VMShell
  248. /etc/qubes-rpc/qubes.SyncNtpClock
  249. /etc/qubes-rpc/qubes.SuspendPre
  250. /etc/qubes-rpc/qubes.SuspendPost
  251. /etc/qubes-rpc/qubes.WaitForSession
  252. /etc/qubes-rpc/qubes.DetachPciDevice
  253. /etc/qubes-rpc/qubes.Backup
  254. /etc/qubes-rpc/qubes.Restore
  255. /etc/qubes-rpc/qubes.SelectFile
  256. /etc/qubes-rpc/qubes.SelectDirectory
  257. /etc/sudoers.d/qubes
  258. %config(noreplace) /etc/sysconfig/iptables
  259. %config(noreplace) /etc/sysconfig/ip6tables
  260. /etc/sysconfig/modules/qubes-core.modules
  261. /etc/sysconfig/modules/qubes-misc.modules
  262. %config(noreplace) /etc/tinyproxy/filter-qubes-yum
  263. %config(noreplace) /etc/tinyproxy/tinyproxy-qubes-yum.conf
  264. /etc/udev/rules.d/50-qubes-misc.rules
  265. /etc/udev/rules.d/99-qubes-network.rules
  266. /etc/xdg/autostart/qubes-show-hide-nm-applet.desktop
  267. /etc/xdg/nautilus-actions/nautilus-actions.conf
  268. /etc/xen/scripts/vif-route-qubes
  269. %config(noreplace) /etc/yum.conf.d/qubes-proxy.conf
  270. %config(noreplace) /etc/yum.repos.d/qubes-r2-beta2.repo
  271. %config(noreplace) /etc/yum.repos.d/qubes-r2-beta3.repo
  272. /etc/yum/pluginconf.d/yum-qubes-hooks.conf
  273. /etc/yum/post-actions/qubes-trigger-sync-appmenus.action
  274. /usr/sbin/qubes-serial-login
  275. /usr/bin/qvm-copy-to-vm
  276. /usr/bin/qvm-open-in-dvm
  277. /usr/bin/qvm-open-in-vm
  278. /usr/bin/qvm-run
  279. /usr/bin/qvm-mru-entry
  280. /usr/bin/xenstore-watch-qubes
  281. %dir /usr/lib/qubes
  282. /usr/lib/qubes/vusb-ctl.py*
  283. /usr/lib/qubes/dispvm-prerun.sh
  284. /usr/lib/qubes/sync-ntp-clock
  285. /usr/lib/qubes/prepare-suspend
  286. /usr/lib/qubes/network-manager-prepare-conf-dir
  287. /usr/lib/qubes/show-hide-nm-applet.sh
  288. /usr/lib/qubes/qrexec-agent
  289. /usr/lib/qubes/qrexec-client-vm
  290. /usr/lib/qubes/qrexec_client_vm
  291. /usr/lib/qubes/qubes-rpc-multiplexer
  292. /usr/lib/qubes/qfile-agent
  293. %attr(4755,root,root) /usr/lib/qubes/qfile-unpacker
  294. /usr/lib/qubes/qopen-in-vm
  295. /usr/lib/qubes/qrun-in-vm
  296. /usr/lib/qubes/qubes-download-dom0-updates.sh
  297. /usr/lib/qubes/qubes-fix-nm-conf.sh
  298. /usr/lib/qubes/qubes-setup-dnat-to-ns
  299. /usr/lib/qubes/qubes-trigger-sync-appmenus.sh
  300. /usr/lib/qubes/qvm-copy-to-vm.gnome
  301. /usr/lib/qubes/qvm-copy-to-vm.kde
  302. /usr/lib/qubes/setup-ip
  303. /usr/lib/qubes/tar2qfile
  304. /usr/lib/qubes/vm-file-editor
  305. /usr/lib/qubes/wrap-in-html-if-url.sh
  306. /usr/lib/qubes/iptables-yum-proxy
  307. /usr/lib/yum-plugins/yum-qubes-hooks.py*
  308. /usr/sbin/qubes-firewall
  309. /usr/sbin/qubes-netwatcher
  310. /usr/share/qubes/serial.conf
  311. /usr/share/glib-2.0/schemas/org.gnome.settings-daemon.plugins.updates.gschema.override
  312. /usr/share/file-manager/actions/qvm-copy-gnome.desktop
  313. /usr/share/file-manager/actions/qvm-dvm-gnome.desktop
  314. %dir /usr/share/qubes
  315. /usr/share/qubes/mime-override/globs
  316. %dir /home_volatile
  317. %attr(700,user,user) /home_volatile/user
  318. %dir /mnt/removable
  319. %package sysvinit
  320. Summary: Qubes unit files for SysV init style or upstart
  321. License: GPL v2 only
  322. Group: Qubes
  323. Requires: upstart
  324. Requires: qubes-core-vm
  325. Provides: qubes-core-vm-init-scripts
  326. Conflicts: qubes-core-vm-systemd
  327. %description sysvinit
  328. The Qubes core startup configuration for SysV init (or upstart).
  329. %files sysvinit
  330. /etc/init.d/qubes-core
  331. /etc/init.d/qubes-core-appvm
  332. /etc/init.d/qubes-core-netvm
  333. /etc/init.d/qubes-firewall
  334. /etc/init.d/qubes-netwatcher
  335. /etc/init.d/qubes-yum-proxy
  336. /etc/init.d/qubes-qrexec-agent
  337. %post sysvinit
  338. #echo "--> Turning off unnecessary services..."
  339. # FIXME: perhaps there is more elegant way to do this?
  340. for f in /etc/init.d/*
  341. do
  342. srv=`basename $f`
  343. [ $srv = 'functions' ] && continue
  344. [ $srv = 'killall' ] && continue
  345. [ $srv = 'halt' ] && continue
  346. [ $srv = 'single' ] && continue
  347. [ $srv = 'reboot' ] && continue
  348. [ $srv = 'qubes-gui' ] && continue
  349. chkconfig $srv off
  350. done
  351. #echo "--> Enabling essential services..."
  352. chkconfig rsyslog on
  353. chkconfig haldaemon on
  354. chkconfig messagebus on
  355. chkconfig iptables on
  356. chkconfig ip6tables on
  357. chkconfig --add qubes-core || echo "WARNING: Cannot add service qubes-core!"
  358. chkconfig qubes-core on || echo "WARNING: Cannot enable service qubes-core!"
  359. chkconfig --add qubes-core-netvm || echo "WARNING: Cannot add service qubes-core-netvm!"
  360. chkconfig qubes-core-netvm on || echo "WARNING: Cannot enable service qubes-core-netvm!"
  361. chkconfig --add qubes-core-appvm || echo "WARNING: Cannot add service qubes-core-appvm!"
  362. chkconfig qubes-core-appvm on || echo "WARNING: Cannot enable service qubes-core-appvm!"
  363. chkconfig --add qubes-firewall || echo "WARNING: Cannot add service qubes-firewall!"
  364. chkconfig qubes-firewall on || echo "WARNING: Cannot enable service qubes-firewall!"
  365. chkconfig --add qubes-netwatcher || echo "WARNING: Cannot add service qubes-netwatcher!"
  366. chkconfig qubes-netwatcher on || echo "WARNING: Cannot enable service qubes-netwatcher!"
  367. chkconfig --add qubes-yum-proxy || echo "WARNING: Cannot add service qubes-yum-proxy!"
  368. chkconfig qubes-yum-proxy on || echo "WARNING: Cannot enable service qubes-yum-proxy!"
  369. chkconfig --add qubes-qrexec-agent || echo "WARNING: Cannot add service qubes-qrexec-agent!"
  370. chkconfig qubes-qrexec-agent on || echo "WARNING: Cannot enable service qubes-qrexec-agent!"
  371. # TODO: make this not display the silly message about security context...
  372. sed -i s/^id:.:initdefault:/id:3:initdefault:/ /etc/inittab
  373. %preun sysvinit
  374. if [ "$1" = 0 ] ; then
  375. # no more packages left
  376. chkconfig qubes-core off
  377. chkconfig qubes-core-netvm off
  378. chkconfig qubes-core-appvm off
  379. chkconfig qubes-firewall off
  380. chkconfig qubes-netwatcher off
  381. chkconfig qubes-yum-proxy off
  382. chkconfig qubes-qrexec-agent off
  383. fi
  384. %package systemd
  385. Summary: Qubes unit files for SystemD init style
  386. License: GPL v2 only
  387. Group: Qubes
  388. Requires: systemd
  389. Requires(post): systemd-units
  390. Requires(preun): systemd-units
  391. Requires(postun): systemd-units
  392. Requires: qubes-core-vm
  393. Provides: qubes-core-vm-init-scripts
  394. Conflicts: qubes-core-vm-sysvinit
  395. %description systemd
  396. The Qubes core startup configuration for SystemD init.
  397. %files systemd
  398. %defattr(-,root,root,-)
  399. /lib/systemd/system/qubes-dvm.service
  400. /lib/systemd/system/qubes-misc-post.service
  401. /lib/systemd/system/qubes-firewall.service
  402. /lib/systemd/system/qubes-netwatcher.service
  403. /lib/systemd/system/qubes-network.service
  404. /lib/systemd/system/qubes-sysinit.service
  405. /lib/systemd/system/qubes-update-check.service
  406. /lib/systemd/system/qubes-update-check.timer
  407. /lib/systemd/system/qubes-yum-proxy.service
  408. /lib/systemd/system/qubes-qrexec-agent.service
  409. %dir /usr/lib/qubes/init
  410. /usr/lib/qubes/init/prepare-dvm.sh
  411. /usr/lib/qubes/init/network-proxy-setup.sh
  412. /usr/lib/qubes/init/misc-post.sh
  413. /usr/lib/qubes/init/misc-post-stop.sh
  414. /usr/lib/qubes/init/qubes-sysinit.sh
  415. /usr/lib/qubes/init/ModemManager.service
  416. /usr/lib/qubes/init/NetworkManager.service
  417. /usr/lib/qubes/init/NetworkManager-wait-online.service
  418. /usr/lib/qubes/init/cups.service
  419. /usr/lib/qubes/init/cups.socket
  420. /usr/lib/qubes/init/cups.path
  421. /usr/lib/qubes/init/ntpd.service
  422. /usr/lib/qubes/init/chronyd.service
  423. %ghost %attr(0644,root,root) /etc/systemd/system/ModemManager.service
  424. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager.service
  425. %ghost %attr(0644,root,root) /etc/systemd/system/NetworkManager-wait-online.service
  426. %ghost %attr(0644,root,root) /etc/systemd/system/cups.service
  427. %ghost %attr(0644,root,root) /etc/systemd/system/cups.socket
  428. %ghost %attr(0644,root,root) /etc/systemd/system/cups.path
  429. %post systemd
  430. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-firewall qubes-yum-proxy qubes-qrexec-agent; do
  431. /bin/systemctl enable $srv.service 2> /dev/null
  432. done
  433. /bin/systemctl enable qubes-update-check.timer 2> /dev/null
  434. UNITDIR=/lib/systemd/system
  435. OVERRIDEDIR=/usr/lib/qubes/init
  436. # Install overriden services only when original exists
  437. for srv in cups ModemManager NetworkManager NetworkManager-wait-online ntpd chronyd; do
  438. if [ -f $UNITDIR/$srv.service ]; then
  439. cp $OVERRIDEDIR/$srv.service /etc/systemd/system/
  440. fi
  441. if [ -f $UNITDIR/$srv.socket -a -f $OVERRIDEDIR/$srv.socket ]; then
  442. cp $OVERRIDEDIR/$srv.socket /etc/systemd/system/
  443. fi
  444. if [ -f $UNITDIR/$srv.path -a -f $OVERRIDEDIR/$srv.path ]; then
  445. cp $OVERRIDEDIR/$srv.path /etc/systemd/system/
  446. fi
  447. done
  448. # Set default "runlevel"
  449. rm -f /etc/systemd/system/default.target
  450. ln -s /lib/systemd/system/multi-user.target /etc/systemd/system/default.target
  451. DISABLE_SERVICES="alsa-store alsa-restore auditd avahi avahi-daemon backuppc cpuspeed crond"
  452. DISABLE_SERVICES="$DISABLE_SERVICES fedora-autorelabel fedora-autorelabel-mark ipmi hwclock-load hwclock-save"
  453. DISABLE_SERVICES="$DISABLE_SERVICES mdmonitor multipathd openct rpcbind mcelog fedora-storage-init fedora-storage-init-late"
  454. DISABLE_SERVICES="$DISABLE_SERVICES plymouth-start plymouth-read-write plymouth-quit plymouth-quit-wait"
  455. DISABLE_SERVICES="$DISABLE_SERVICES sshd tcsd sm-client sendmail mdmonitor-takeover"
  456. DISABLE_SERVICES="$DISABLE_SERVICES rngd smartd upower irqbalance colord"
  457. for srv in $DISABLE_SERVICES; do
  458. if [ -f /lib/systemd/system/$srv.service ]; then
  459. if fgrep -q '[Install]' /lib/systemd/system/$srv.service; then
  460. /bin/systemctl disable $srv.service 2> /dev/null
  461. else
  462. # forcibly disable
  463. ln -sf /dev/null /etc/systemd/system/$srv.service
  464. fi
  465. fi
  466. done
  467. rm -f /etc/systemd/system/getty.target.wants/getty@tty*.service
  468. # Enable some services
  469. /bin/systemctl enable iptables.service 2> /dev/null
  470. /bin/systemctl enable ip6tables.service 2> /dev/null
  471. /bin/systemctl enable rsyslog.service 2> /dev/null
  472. /bin/systemctl enable ntpd.service 2> /dev/null
  473. # Disable original service to enable overriden one
  474. /bin/systemctl disable ModemManager.service 2> /dev/null
  475. /bin/systemctl disable NetworkManager.service 2> /dev/null
  476. # Disable D-BUS activation of NetworkManager - in AppVm it causes problems (eg PackageKit timeouts)
  477. /bin/systemctl mask dbus-org.freedesktop.NetworkManager.service 2> /dev/null
  478. /bin/systemctl enable ModemManager.service 2> /dev/null
  479. /bin/systemctl enable NetworkManager.service 2> /dev/null
  480. # Fix for https://bugzilla.redhat.com/show_bug.cgi?id=974811
  481. /bin/systemctl enable NetworkManager-dispatcher.service 2> /dev/null
  482. # Enable cups only when it is real SystemD service
  483. [ -e /lib/systemd/system/cups.service ] && /bin/systemctl enable cups.service 2> /dev/null
  484. exit 0
  485. %postun systemd
  486. #Do not run this part on upgrades
  487. if [ "$1" != 0 ] ; then
  488. exit 0
  489. fi
  490. for srv in qubes-dvm qubes-sysinit qubes-misc-post qubes-netwatcher qubes-network qubes-qrexec-agent; do
  491. /bin/systemctl disable $srv.service
  492. do